Action (libgdx API)

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d
Interface Action

All Known Implementing Classes:
Delay, FadeIn, FadeOut, FadeTo, Forever, MoveBy, MoveTo, Parallel, Repeat, RotateBy, RotateTo, ScaleTo, Sequence
public interface Action

An Action is used with an Actor and modifes the Actor's attributes over time.

Author:
mzechner

Method Summary
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.

Method Detail

setTarget

void setTarget(Actor actor)
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Parameters:
actor - the actor.

act

void act(float delta)
Apply the action.

Parameters:
delta - delta time in seconds

isDone

boolean isDone()
Returns:
whether the action is done or not

finish

void finish()
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

copy

Action copy()
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call setTarget(Actor) on it without any side effects.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Copyright 2010 Mario Zechner (contact@badlogicgames.com), Nathan Sweet (admin@esotericsoftware.com)


Uses of Interface com.badlogic.gdx.scenes.scene2d.Action (libgdx API)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.badlogic.gdx.scenes.scene2d.Action

Packages that use Action
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actions

Uses of Action in com.badlogic.gdx.scenes.scene2d

Fields in com.badlogic.gdx.scenes.scene2d with type parameters of type Action
protected  PooledLinkedList<Action> Actor.actions

Methods in com.badlogic.gdx.scenes.scene2d that return Action
 Action Action.copy()
Creates a copy of this action.

Methods in com.badlogic.gdx.scenes.scene2d with parameters of type Action
 void Actor.action(Action action)
Adds an Action to the Actor.

Uses of Action in com.badlogic.gdx.scenes.scene2d.actions

Classes in com.badlogic.gdx.scenes.scene2d.actions that implement Action
class | Delay
class | FadeIn
class | FadeOut
class | FadeTo
class | Forever
class | MoveBy
class | MoveTo
class | Parallel
class | Repeat
class | RotateBy
class | RotateTo
class | ScaleTo
class | Sequence

Fields in com.badlogic.gdx.scenes.scene2d.actions declared as Action
protected Action | Delay.action
protected Action | Forever.action
protected Action | Repeat.action

Fields in com.badlogic.gdx.scenes.scene2d.actions with type parameters of type Action
protected java.util.List<Action> | Parallel.actions
protected java.util.List<Action> | Sequence.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return Action
Action | Delay.copy()
Action | FadeIn.copy()
Action | FadeOut.copy()
Action | FadeTo.copy()
Action | Forever.copy()
Action | MoveBy.copy()
Action | MoveTo.copy()
Action | Parallel.copy()
Action | Repeat.copy()
Action | RotateBy.copy()
Action | RotateTo.copy()
Action | ScaleTo.copy()
Action | Sequence.copy()

Methods in com.badlogic.gdx.scenes.scene2d.actions with parameters of type Action
static Parallel | Parallel.$(Action... actions)
static Sequence | Sequence.$(Action... actions)
static Forever | Forever.$(Action action)
static Delay | Delay.$(Action action, float duration)
static Repeat | Repeat.$(Action action, int times)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Actor (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d
Class Actor

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.Actor
Direct Known Subclasses:
Button, Group, Image, Label
public abstract class Actor
extends java.lang.Object

An Actor is part of a Stage or a Group within a Stage. It has a position, a rectangular size given as width and height, a rotation angle, a scale in x and y and an origin relative to the position which is used for rotation and scaling.

The position of an Actor is coincident with its unrotated, unscaled bottom left corner.

An Actor can be a child of a Group or the Stage. The object it belongs to is called the Actor's parent. An Actor's position is always relative to the bottom left corner of its parent.

Every Actor must have a unique name within a Stage.

An Actor can receive touch events when its touchable attribute is set to true. The Stage will delegate touch events to an Actor in this case, calling its touchDown(float, float, int), touchUp(float, float, int) and touchDragged(float, float, int) methods. The coordinates passed to an Actor will be in the Actor's coordinate system, easing the pain of intersection testing. The coordinate system has it's origin at the Actor's rotated and scaled bottom left corner, with the x-axis pointing to the right and the y-axis pointing to the left.

An Actor can be intersection tested via a call this its hit(float, float) method. The coordinates given are again in the Actor's coordinate system.

An Actor might render itself when its render(SpriteBatch) method is called. The projection and transform matrices are setup so that an Actor can simply call the SpriteBatch.draw(com.badlogic.gdx.graphics.Texture, float, float, float, float, float, float, float, float, float, int, int, int, int, boolean, boolean) method to render himself. Using a Sprite instance is also an option. An Actor might decide to not render itself at all or chose another way to render itself. For the later it has to call SpriteBatch.end() first, setup up all render states needed to render itself, render itself and then call SpriteBatch.begin() again so that the rendering for other Actor's is undisturbed. You have to know what you do if you want to try this.

An Actor can be controlled by Actions. An Action will modify some of the attributes of an Actor such as its position or rotation. Actions can be chained and make for rather sophisticated time based behaviour.

Author:
mzechner

Field Summary
protected PooledLinkedList<Action> | actions
Color | color
float | height
java.lang.String | name
float | originX
float | originY
Group | parent
float | rotation
float | scaleX
float | scaleY
boolean | touchable
float | width
float | x
float | y
Constructor Summary
Actor(java.lang.String name)
Method Summary
protected void | act(float delta)
void | action(Action action) Adds an Action to the Actor.
void | clearActions() Clears all actions of this Actor.
abstract Actor | hit(float x, float y)
void | remove() Removes this actor from the Stage
protected abstract void | render(SpriteBatch batch) Renders the Actor.
void | toLocalCoordinates(Vector2 point) Transforms the given point in stage coordinates to the Actor's local coordinate system.
java.lang.String | toString()
protected abstract boolean | touchDown(float x, float y, int pointer)
protected abstract boolean | touchDragged(float x, float y, int pointer)
protected abstract boolean | touchUp(float x, float y, int pointer)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

parent

public Group parent

name

public final java.lang.String name

touchable

public boolean touchable

x

public float x

y

public float y

width

public float width

height

public float height

originX

public float originX

originY

public float originY

scaleX

public float scaleX

scaleY

public float scaleY

rotation

public float rotation

color

public final Color color

actions

protected PooledLinkedList<Action> actions
Constructor Detail

Actor

public Actor(java.lang.String name)
Method Detail

render

protected abstract void render(SpriteBatch batch)
Renders the Actor. The spriteBatch is configured so that the Actor can render in its parents coordinate system.

Parameters:
batch - the spritebatch to render with

touchDown

protected abstract boolean touchDown(float x,
                                     float y,
                                     int pointer)

touchUp

protected abstract boolean touchUp(float x,
                                   float y,
                                   int pointer)

touchDragged

protected abstract boolean touchDragged(float x,
                                        float y,
                                        int pointer)

hit

public abstract Actor hit(float x,
                          float y)

toLocalCoordinates

public void toLocalCoordinates(Vector2 point)
Transforms the given point in stage coordinates to the Actor's local coordinate system.

Parameters:
point - the point

remove

public void remove()
Removes this actor from the Stage

act

protected void act(float delta)

action

public void action(Action action)
Adds an Action to the Actor. Actions will be automatically performed in the order added to the Actor and will be removed when they are done.

Parameters:
action - the action

clearActions

public void clearActions()
Clears all actions of this Actor.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.Actor (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.Actor

Packages that use Actor
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actions
com.badlogic.gdx.scenes.scene2d.actors

Uses of Actor in com.badlogic.gdx.scenes.scene2d

Subclasses of Actor in com.badlogic.gdx.scenes.scene2d
 class Group
A group is an Actor that contains other Actors (also other Groups which are Actors).

Fields in com.badlogic.gdx.scenes.scene2d declared as Actor
Actor | Group.focusedActor
Actor | Group.lastTouchedChild

Fields in com.badlogic.gdx.scenes.scene2d with type parameters of type Actor
protected java.util.List<Actor> | Group.children
protected java.util.List<Actor> | Group.immutableChildren
protected java.util.Map<java.lang.String,Actor> | Group.namesToActors

Methods in com.badlogic.gdx.scenes.scene2d that return Actor
Actor | Group.findActor(java.lang.String name) Finds the Actor with the given name in this Group and its children.
Actor | Stage.findActor(java.lang.String name) Finds the Actor with the given name in the stage hierarchy.
Actor | Stage.getLastTouchedChild()
abstract Actor | Actor.hit(float x, float y)
Actor | Group.hit(float x, float y)
Actor | Stage.hit(float x, float y) Returns the Actor intersecting with the point (x,y) in stage coordinates.

Methods in com.badlogic.gdx.scenes.scene2d that return types with arguments of type Actor
java.util.List<Actor> | Group.getActors()
java.util.List<Actor> | Stage.getActors()

Methods in com.badlogic.gdx.scenes.scene2d with parameters of type Actor
void | Group.addActor(Actor actor) Adds an Actor to this Group.
void | Stage.addActor(Actor actor) Adds an Actor to this stage
void | Group.focus(Actor actor) Sets the focus to the given child Actor.
void | Group.removeActor(Actor actor) Removes an Actor from this Group.
void | Action.setTarget(Actor actor) Sets the Actor of this action.
boolean | Group.swapActor(Actor first, Actor second) Swap two actors' sort order by reference.
static void | Group.toChildCoordinates(Actor child, float x, float y, Vector2 out) Transforms the coordinates given in the child's parent coordinate system to the child Actor's coordinate system.

Uses of Actor in com.badlogic.gdx.scenes.scene2d.actions

Fields in com.badlogic.gdx.scenes.scene2d.actions declared as Actor
protected Actor | FadeIn.target
protected Actor | FadeOut.target
protected Actor | FadeTo.target
protected Actor | Forever.target
protected Actor | MoveBy.target
protected Actor | MoveTo.target
protected Actor | Repeat.target
protected Actor | RotateBy.target
protected Actor | RotateTo.target
protected Actor | ScaleTo.target
protected Actor | Sequence.target

Methods in com.badlogic.gdx.scenes.scene2d.actions with parameters of type Actor
void | Delay.setTarget(Actor actor)
void | FadeIn.setTarget(Actor actor)
void | FadeOut.setTarget(Actor actor)
void | FadeTo.setTarget(Actor actor)
void | Forever.setTarget(Actor actor)
void | MoveBy.setTarget(Actor actor)
void | MoveTo.setTarget(Actor actor)
void | Parallel.setTarget(Actor actor)
void | Repeat.setTarget(Actor actor)
void | RotateBy.setTarget(Actor actor)
void | RotateTo.setTarget(Actor actor)
void | ScaleTo.setTarget(Actor actor)
void | Sequence.setTarget(Actor actor)

Uses of Actor in com.badlogic.gdx.scenes.scene2d.actors

Subclasses of Actor in com.badlogic.gdx.scenes.scene2d.actors
class | BoundGroup This is a group that respects its width and height.
class | Button A simple Button Actor, useful for simple UIs
class | Image
class | Label
class | LinearGroup

Methods in com.badlogic.gdx.scenes.scene2d.actors that return Actor
Actor | BoundGroup.hit(float x, float y)
Actor | Button.hit(float x, float y)
Actor | Image.hit(float x, float y)
Actor | Label.hit(float x, float y)

Methods in com.badlogic.gdx.scenes.scene2d.actors with parameters of type Actor
void | LinearGroup.addActor(Actor actor)
void | LinearGroup.removeActor(Actor actor)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


All Classes (libgdx API)

 All Classes
Action
Actor
AndroidApplication
Application
Application.ApplicationType
ApplicationListener
AtomicQueue
Audio
AudioDevice
AudioRecorder
AudioTools
BitmapFont
BitmapFont.HAlignment
BitmapFont.TextBounds
BitmapFontCache
Body
BodyDef
BodyDef.BodyType
BoundGroup
BoundingBox
Box2DDebugRenderer
BufferUtils
Button
Button.ClickListener
CatmullRomSpline
CircleShape
Color
Contact
ContactFilter
ContactListener
Decoder
Delay
DestructionListener
DFT
DistanceJoint
DistanceJointDef
EarCutTriangulator
FadeIn
FadeOut
FadeTo
FFT
FileHandle
FileHandleStream
Files
Files.FileType
Filter
Fixture
FixtureDef
FloatArray
FloatBag
Forever
FourierTransform
FrameBuffer
FrictionJoint
FrictionJointDef
Frustum
Game
Gdx
GdxNativesLoader
GdxRuntimeException
GearJoint
GearJointDef
GL10
GL11
GL20
GLCommon
Graphics
Graphics.GraphicsType
Group
Image
ImmediateModeRenderer
IndexBufferObject
IndexBufferObjectSubData
IndexData
Input
Input.Keys
Input.TextInputListener
InputAdapter
InputMultiplexer
InputProcessor
IntArray
IntBag
Intersector
IntHashMap
IntHashMap.Entry
JoglApplication
Joint
JointDef
JointDef.JointType
JointEdge
JSONArray
JSONException
JSONObject
JSONString
JSONStringer
JSONTokener
JSONWriter
KissFFT
Label
LinearGroup
LinearGroup.LinearGroupLayout
LineJoint
LineJointDef
LittleEndianInputStream
LocklessThreadQueue
LocklessThreadQueue.ObjectFactory
LongArray
LongBag
LongHashMap
LongHashMap.Entry
LwjglApplet
LwjglApplication
LwjglCanvas
MassData
MathUtils
Matrix3
Matrix4
MD5Animation
MD5AnimationInfo
MD5Jni
MD5Joints
MD5Loader
MD5Mesh
MD5Model
MD5Quaternion
MD5Renderer
Mesh
Mesh.VertexDataType
ModelLoader
MouseJoint
MouseJointDef
MoveBy
MoveTo
Mpg123Decoder
Music
NativeFFT
ObjLoader
OrthographicCamera
OrthographicCamera.Side
Parallel
ParticleEffect
ParticleEmitter
ParticleEmitter.GradientColorValue
ParticleEmitter.NumericValue
ParticleEmitter.ParticleValue
ParticleEmitter.RangedNumericValue
ParticleEmitter.ScaledNumericValue
ParticleEmitter.SpawnEllipseSide
ParticleEmitter.SpawnShape
ParticleEmitter.SpawnShapeValue
PauseableThread
PerspectiveCamera
Pixmap
Pixmap.Format
Plane
Plane.PlaneSide
PolygonShape
Pool
Pool.PoolObjectFactory
PooledLinkedList
PrismaticJoint
PrismaticJointDef
PulleyJoint
PulleyJointDef
Quaternion
QueryCallback
Ray
Rectangle
Repeat
RevoluteJoint
RevoluteJointDef
RotateBy
RotateTo
ScaleTo
Screen
Segment
Sequence
ShaderProgram
Shape
Shape.Type
Sound
Sphere
Sprite
SpriteBatch
SpriteCache
Stage
Texture
Texture.TextureFilter
Texture.TextureWrap
TextureAtlas
TextureAtlas.AtlasRegion
TextureData
TextureRegion
ThresholdFunction
Transform
TWL
Vector2
Vector3
Version
VertexArray
VertexAttribute
VertexAttributes
VertexBufferObject
VertexBufferObjectSubData
VertexData
VorbisDecoder
WeldJoint
WeldJointDef
WindowedMean
World
WorldManifold


AndroidApplication (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.backends.android
Class AndroidApplication

java.lang.Object
    extended by  Activity
        extended by  com.badlogic.gdx.backends.android.AndroidApplication
All Implemented Interfaces:
Application
public class AndroidApplication
extends Activity
implements Application

An implementation of the Application interface for Android. Create an Activity that derives from this class. In the Activity#onCreate(Bundle) method call the initialize(ApplicationListener,boolean) method specifying the configuration for the GLSurfaceView.

Author:
mzechner

Nested Class Summary
Nested classes/interfaces inherited from interface com.badlogic.gdx.Application
Application.ApplicationType
Field Summary
protected AndroidAudio | audio
protected AndroidFiles | files
protected boolean | firstResume
protected AndroidGraphics | graphics
protected Handler | handler
protected AndroidInput | input
protected ApplicationListener | listener
Constructor Summary
AndroidApplication()
Method Summary
Audio | getAudio()
Files | getFiles()
Graphics | getGraphics()
Input | getInput()
long | getJavaHeap()
long | getNativeHeap()
Application.ApplicationType | getType()
int | getVersion()
void | initialize(ApplicationListener listener, boolean useGL2IfAvailable) This method has to be called in the Activity#onCreate(Bundle) method.
void | initialize(ApplicationListener listener, boolean useGL2IfAvailable, int sleepTime) This method has to be called in the Activity#onCreate(Bundle) method.
View | initializeForView(ApplicationListener listener, boolean useGL2IfAvailable, int sleepTime) This method has to be called in the Activity#onCreate(Bundle) method.
void | log(java.lang.String tag, java.lang.String message) Logs a message to the console or logcat
protected void | onDestroy()
protected void | onPause()
protected void | onResume()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

graphics

protected AndroidGraphics graphics

input

protected AndroidInput input

audio

protected AndroidAudio audio

files

protected AndroidFiles files

listener

protected ApplicationListener listener

handler

protected Handler handler

firstResume

protected boolean firstResume
Constructor Detail

AndroidApplication

public AndroidApplication()
Method Detail

initialize

public void initialize(ApplicationListener listener,
                       boolean useGL2IfAvailable)
This method has to be called in the Activity#onCreate(Bundle) method. It sets up all the things necessary to get input, render via OpenGL and so on. If useGL20IfAvailable is set the AndroidApplication will try to create an OpenGL ES 2.0 context which can then be used via Graphics.getGL20(). The GL10 and GL11 interfaces should not be used when OpenGL ES 2.0 is enabled. To query whether enabling OpenGL ES 2.0 was successful use the Graphics.isGL20Available() method. Sleep time in touch event handler is 0, so no sleeping is performed.

Parameters:
listener - the ApplicationListener implementing the program logic
useGL2IfAvailable - whether to use OpenGL ES 2.0 if its available.

initialize

public void initialize(ApplicationListener listener,
                       boolean useGL2IfAvailable,
                       int sleepTime)
This method has to be called in the Activity#onCreate(Bundle) method. It sets up all the things necessary to get input, render via OpenGL and so on. If useGL20IfAvailable is set the AndroidApplication will try to create an OpenGL ES 2.0 context which can then be used via Graphics.getGL20(). The GL10 and GL11 interfaces should not be used when OpenGL ES 2.0 is enabled. To query whether enabling OpenGL ES 2.0 was successful use the Graphics.isGL20Available() method. sleepTime specifies the number of milliseconds to sleep in the touch event handler. This may be used on <= 1.6 Android devices. Note that it will not solve the CPU usage problem of the event handler of the Android system. Things will still slow down.

Parameters:
listener - the ApplicationListener implementing the program logic
useGL2IfAvailable - whether to use OpenGL ES 2.0 if its available.
sleepTime - specifies the number of milliseconds to sleep in the touch event handler

initializeForView

public View initializeForView(ApplicationListener listener,
                              boolean useGL2IfAvailable,
                              int sleepTime)
This method has to be called in the Activity#onCreate(Bundle) method. It sets up all the things necessary to get input, render via OpenGL and so on. If useGL20IfAvailable is set the AndroidApplication will try to create an OpenGL ES 2.0 context which can then be used via Graphics.getGL20(). The GL10 and GL11 interfaces should not be used when OpenGL ES 2.0 is enabled. To query whether enabling OpenGL ES 2.0 was successful use the Graphics.isGL20Available() method. sleepTime specifies the number of milliseconds to sleep in the touch event handler. This may be used on <= 1.6 Android devices. Note that it will not solve the CPU usage problem of the event handler of the Android system. Things will still slow down. Note: you have to add the returned view to your layout!

Parameters:
listener - the ApplicationListener implementing the program logic
useGL2IfAvailable - whether to use OpenGL ES 2.0 if its available.
sleepTime - specifies the number of milliseconds to sleep in the touch event handler
Returns:
the GLSurfaceView of the application

onPause

protected void onPause()

onResume

protected void onResume()

onDestroy

protected void onDestroy()

getAudio

public Audio getAudio()

Specified by:
getAudio in interface Application
Returns:
the Audio instance

getFiles

public Files getFiles()

Specified by:
getFiles in interface Application
Returns:
the Files instance

getGraphics

public Graphics getGraphics()

Specified by:
getGraphics in interface Application
Returns:
the Graphics instance

getInput

public Input getInput()

Specified by:
getInput in interface Application
Returns:
the Input instance

log

public void log(java.lang.String tag,
                java.lang.String message)
Logs a message to the console or logcat

Specified by:
log in interface Application

getType

public Application.ApplicationType getType()

Specified by:
getType in interface Application
Returns:
what Application.ApplicationType this application has, e.g. Android or Desktop

getVersion

public int getVersion()

Specified by:
getVersion in interface Application
Returns:
the Android API level on Android or 0 on the desktop.

getJavaHeap

public long getJavaHeap()
Specified by:
getJavaHeap in interface Application
Returns:
the Java heap memory use in bytes

getNativeHeap

public long getNativeHeap()
Specified by:
getNativeHeap in interface Application
Returns:
the Native heap memory use in bytes
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.backends.android.AndroidApplication (libgdx API)

Uses of Class
com.badlogic.gdx.backends.android.AndroidApplication

No usage of com.badlogic.gdx.backends.android.AndroidApplication

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Application (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Interface Application

All Known Implementing Classes:
AndroidApplication, JoglApplication, LwjglApplication, LwjglCanvas
public interface Application

An Application is the main entry point of your project. It sets up a window and rendering surface and manages the different aspects of your application, namely Graphics, Audio, Input and Files. Think of an Application being equivalent to a JFrame of Activity.

An application can either be a desktop application JoglApplication, LwjglApplication found in gdx-backends-jogl.jar and gdx-backends-lwjgl.jar respectively), or an Android application AndroidApplication found in gdx-backends-android.jar). Each application class has it's own startup and initialization methods. Please refer to their documentation for more information.

While game programmers are used to having a main loop, libgdx employs a different concept to accomodate the event based nature of Android applications a little more. You application logic must be implemented in a ApplicationListener which has methods that get called by the Application when the application is created, resumed, paused, disposed or rendered. As a developer you will simply implement the ApplicationListener interface and fill in the functionality accordingly. The ApplicationListener is provided to a concrete Application instance as a parameter to the constructor or another initialization method. Please refer to the documentation of the Application implementations for more information. Note that the ApplicationListener can be provided to any Application implementation. This means that you only need to write your program logic once and have it run on different platforms by passing it to a concrete Application implementation.

The Application interface provides you with a set of modules for graphics, audio, input and file i/o.

Graphics offers you various methods to output visuals to the screen. This is achieved via OpenGL ES 1.0, 1.1 or 2.0 depending on what's available an the platform. On the desktop the features of OpenGL ES 2.0 are emulated via desktop OpenGL. On Android the functionality of the Java OpenGL ES bindings is used.

Audio offers you various methods to output and record sound and music. This is achieved via the Java Sound API on the desktop. On Android the Android media framework is used.

Input offers you various methods to poll user input from the keyboard, touch screen, mouse and accelerometer. Additionally you can implement an InputProcessor and use it with Input.setInputProcessor(InputProcessor) to receive input events.

Files offers you various methods to access internal and external files. An internal file is a file that is stored near your application. On Android internal file are equivalent to assets. On the desktop the classpath is first scanned for the specified file. If that fails then the root directory of your application is used for a look up. External files are resources you create in your application and write to an external storage. On Android external files reside on the SD-card, on the desktop external files are written to a users home directory. If you know what you do you can also specify absolute file names. This is not portable, so take great care when using this feature.

The Application also has a set of methods that you can use to query specific information such as the operating system the application is currently running on and so forth. This allows you to have operating system dependent code paths. It is however not recommended to use this facilities.

The Application also has a simple logging method which will print to standard out on the desktop and to logcat on Android.

Author:
mzechner

Nested Class Summary
static class Application.ApplicationType
Enumeration of possible Application types
Method Summary
Audio | getAudio()
Files | getFiles()
Graphics | getGraphics()
Input | getInput()
long | getJavaHeap()
long | getNativeHeap()
Application.ApplicationType | getType()
int | getVersion()
void | log(java.lang.String tag, java.lang.String message) Logs a message to the console or logcat

Method Detail

getGraphics

Graphics getGraphics()
Returns:
the Graphics instance

getAudio

Audio getAudio()
Returns:
the Audio instance

getInput

Input getInput()
Returns:
the Input instance

getFiles

Files getFiles()
Returns:
the Files instance

log

void log(java.lang.String tag,
         java.lang.String message)
Logs a message to the console or logcat

getType

Application.ApplicationType getType()
Returns:
what Application.ApplicationType this application has, e.g. Android or Desktop

getVersion

int getVersion()
Returns:
the Android API level on Android or 0 on the desktop.

getJavaHeap

long getJavaHeap()
Returns:
the Java heap memory use in bytes

getNativeHeap

long getNativeHeap()
Returns:
the Native heap memory use in bytes
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.Application (libgdx API)

Uses of Interface
com.badlogic.gdx.Application

Packages that use Application
com.badlogic.gdx
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl

Uses of Application in com.badlogic.gdx

Fields in com.badlogic.gdx declared as Application
static Application Gdx.app

Uses of Application in com.badlogic.gdx.backends.android

Classes in com.badlogic.gdx.backends.android that implement Application
 class AndroidApplication
An implementation of the Application interface for Android.

Uses of Application in com.badlogic.gdx.backends.jogl

Classes in com.badlogic.gdx.backends.jogl that implement Application
 class JoglApplication
An implemenation of the Application interface based on Jogl for Windows, Linux and Mac.

Uses of Application in com.badlogic.gdx.backends.lwjgl

Classes in com.badlogic.gdx.backends.lwjgl that implement Application
class | LwjglApplication An OpenGL surface fullscreen or in a lightweight window.
class | LwjglCanvas An OpenGL surface on an AWT Canvas, allowing OpenGL to be embedded in a Swing application.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Application.ApplicationType (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx
Enum Application.ApplicationType

java.lang.Object
    extended by  java.lang.Enum<Application.ApplicationType>
        extended by  com.badlogic.gdx.Application.ApplicationType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Application.ApplicationType>
Enclosing interface:
Application
public static enum Application.ApplicationType
extends java.lang.Enum<Application.ApplicationType>

Enumeration of possible Application types

Author:
mzechner

Enum Constant Summary
Android
Applet
Desktop
Method Summary
static Application.ApplicationType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Application.ApplicationType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

Android

public static final Application.ApplicationType Android

Desktop

public static final Application.ApplicationType Desktop

Applet

public static final Application.ApplicationType Applet
Method Detail

values

public static Application.ApplicationType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Application.ApplicationType c : Application.ApplicationType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Application.ApplicationType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.Application.ApplicationType (libgdx API)

Uses of Class
com.badlogic.gdx.Application.ApplicationType

Packages that use Application.ApplicationType
com.badlogic.gdx
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl

Uses of Application.ApplicationType in com.badlogic.gdx

Methods in com.badlogic.gdx that return Application.ApplicationType
Application.ApplicationType | Application.getType()
static Application.ApplicationType | Application.ApplicationType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Application.ApplicationType[] | Application.ApplicationType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of Application.ApplicationType in com.badlogic.gdx.backends.android

Methods in com.badlogic.gdx.backends.android that return Application.ApplicationType
 Application.ApplicationType AndroidApplication.getType()

Uses of Application.ApplicationType in com.badlogic.gdx.backends.jogl

Methods in com.badlogic.gdx.backends.jogl that return Application.ApplicationType
 Application.ApplicationType JoglApplication.getType()

Uses of Application.ApplicationType in com.badlogic.gdx.backends.lwjgl

Methods in com.badlogic.gdx.backends.lwjgl that return Application.ApplicationType
Application.ApplicationType | LwjglApplication.getType()
Application.ApplicationType | LwjglCanvas.getType()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ApplicationListener (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Interface ApplicationListener

All Known Implementing Classes:
Game
public interface ApplicationListener

An ApplicationListener is called when the Application is created, resumed, rendering, paused or destroyed. All methods are called in a thread that has the OpenGL context current. You can thus safely create and manipulate graphics resources.

The ApplicationListener interface follows the standard Android activity life-cycle and is emulated on the desktop accordingly.

Author:
mzechner

Method Summary
void | create() Called when the Application is first created.
void | dispose() Called when the Application is destroyed.
void | pause() Called when the Application is paused.
void | render() Called when the Application should render itself.
void | resize(int width, int height) Called when the Application is resized.
void | resume() Called when the Application is resumed from a paused state.

Method Detail

create

void create()
Called when the Application is first created.

resume

void resume()
Called when the Application is resumed from a paused state. On Android this happens when the activity gets focus again. On the desktop this method will never be called.

render

void render()
Called when the Application should render itself.

resize

void resize(int width,
            int height)
Called when the Application is resized. This can happen at any point during a non-paused state but will never happen before a call to create().

Parameters:
width - the new width in pixels
height - the new height in pixels

pause

void pause()
Called when the Application is paused. An Application is paused before it is destroyed, when a user pressed the Home button on Android or an incoming call happend. On the desktop this will only be called immediately before dispose() is called.

dispose

void dispose()
Called when the Application is destroyed. Preceded by a call to pause().

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.ApplicationListener (libgdx API)

Uses of Interface
com.badlogic.gdx.ApplicationListener

Packages that use ApplicationListener
com.badlogic.gdx
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl

Uses of ApplicationListener in com.badlogic.gdx

Classes in com.badlogic.gdx that implement ApplicationListener
 class Game
An ApplicationListener that delegates to a Screen.

Uses of ApplicationListener in com.badlogic.gdx.backends.android

Fields in com.badlogic.gdx.backends.android declared as ApplicationListener
protected  ApplicationListener AndroidApplication.listener

Methods in com.badlogic.gdx.backends.android with parameters of type ApplicationListener
void | AndroidApplication.initialize(ApplicationListener listener, boolean useGL2IfAvailable) This method has to be called in the Activity#onCreate(Bundle) method.
void | AndroidApplication.initialize(ApplicationListener listener, boolean useGL2IfAvailable, int sleepTime) This method has to be called in the Activity#onCreate(Bundle) method.
View | AndroidApplication.initializeForView(ApplicationListener listener, boolean useGL2IfAvailable, int sleepTime) This method has to be called in the Activity#onCreate(Bundle) method.

Uses of ApplicationListener in com.badlogic.gdx.backends.jogl

Constructors in com.badlogic.gdx.backends.jogl with parameters of type ApplicationListener
JoglApplication(ApplicationListener listener, java.lang.String title, int width, int height, boolean useGL20IfAvailable)
Creates a new JoglApplication with the given title and dimensions.

Uses of ApplicationListener in com.badlogic.gdx.backends.lwjgl

Constructors in com.badlogic.gdx.backends.lwjgl with parameters of type ApplicationListener
LwjglApplet(ApplicationListener listener, boolean useGL2)
LwjglApplication(ApplicationListener listener, boolean useGL2, java.awt.Canvas canvas)
LwjglApplication(ApplicationListener listener, java.lang.String title, int width, int height, boolean useGL2)
LwjglCanvas(ApplicationListener listener, boolean useGL2)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


AtomicQueue (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class AtomicQueue<T>

java.lang.Object
    extended by  com.badlogic.gdx.utils.AtomicQueue<T>

public class AtomicQueue<T>
extends java.lang.Object

Author:
Matthias Mann

Constructor Summary
AtomicQueue()
Method Summary
T | poll()
boolean | put(T o)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AtomicQueue

public AtomicQueue()
Method Detail

put

public boolean put(T o)

poll

public T poll()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.AtomicQueue (libgdx API)

Uses of Class
com.badlogic.gdx.utils.AtomicQueue

No usage of com.badlogic.gdx.utils.AtomicQueue

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Audio (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Interface Audio

public interface Audio

This interface encapsulates the creation and management of audio resources. It allows you to get direct access to the audio hardware via the AudioDevice and AudioRecorder interfaces, create sound effects via the Sound interface and play music streams via the Music interface.

All resources created via this interface have to be disposed as soon as they are no longer used.

Note that all Music instances will be automatically paused when the ApplicationListener.pause() method is called, and automatically resumed when the ApplicationListener.resume() method is called.

Author:
mzechner

Method Summary
AudioDevice | newAudioDevice(boolean isMono) Creates a new AudioDevice either in 44.1khz mono or stereo mode.
AudioRecorder | newAudioRecoder(int samplingRate, boolean isMono) Creates a new AudioRecorder.
Music | newMusic(FileHandle file) Creates a new Music instance which is used to play back a music stream from a file.
Sound | newSound(FileHandle fileHandle) Creates a new Sound which is used to play back audio effects such as gun shots or explosions.

Method Detail

newAudioDevice

AudioDevice newAudioDevice(boolean isMono)
Creates a new AudioDevice either in 44.1khz mono or stereo mode. The AudioDevice has to be disposed via its AudioDevice.dispose() method when it is no longer used.

Parameters:
isMono - whether the AudioDevice should be in mono or stereo mode
Returns:
the AudioDevice
Throws:
GdxRuntimeException - in case the device could not be created

newAudioRecoder

AudioRecorder newAudioRecoder(int samplingRate,
                              boolean isMono)
Creates a new AudioRecorder. The AudioRecorder has to be disposed after it is no longer used.

Parameters:
samplingRate - the sampling rate in Herz
isMono - whether the recorder records in mono or stereo
Returns:
the AudioRecorder
Throws:
GdxRuntimeException - in case the recorder could not be created

newSound

Sound newSound(FileHandle fileHandle)

Creates a new Sound which is used to play back audio effects such as gun shots or explosions. The Sound's audio data is retrieved from the file specified via the FileHandle. Note that the complete audio data is loaded into RAM. You should therefore not load big audio files with this methods. The current upper limit for decoded audio is 1 MB.

Currently supported formats are WAV, MP3 and OGG.

The Sound has to be disposed if it is no longer used via the Sound.dispose() method.

Returns:
the new Sound
Throws:
GdxRuntimeException - in case the sound could not be loaded

newMusic

Music newMusic(FileHandle file)
Creates a new Music instance which is used to play back a music stream from a file. Currently supported formats are WAV, MP3 and OGG. The Music instance has to be disposed if it is no longer used via the Music.dispose() method. Music instances are automatically paused when ApplicationListener.pause() is called and resumed when ApplicationListener.resume() is called.

Parameters:
file - the FileHandle
Returns:
the new Music or null if the Music could not be loaded
Throws:
GdxRuntimeException - in case the music could not be loaded
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.Audio (libgdx API)

Uses of Interface
com.badlogic.gdx.Audio

Packages that use Audio
com.badlogic.gdx
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl

Uses of Audio in com.badlogic.gdx

Fields in com.badlogic.gdx declared as Audio
static Audio Gdx.audio

Methods in com.badlogic.gdx that return Audio
 Audio Application.getAudio()

Uses of Audio in com.badlogic.gdx.backends.android

Methods in com.badlogic.gdx.backends.android that return Audio
 Audio AndroidApplication.getAudio()

Uses of Audio in com.badlogic.gdx.backends.jogl

Methods in com.badlogic.gdx.backends.jogl that return Audio
 Audio JoglApplication.getAudio()

Uses of Audio in com.badlogic.gdx.backends.lwjgl

Methods in com.badlogic.gdx.backends.lwjgl that return Audio
Audio | LwjglApplication.getAudio()
Audio | LwjglCanvas.getAudio()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


AudioDevice (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio
Interface AudioDevice

public interface AudioDevice

Encapsulates an audio device in 44.1khz mono or stereo mode. Use the writeSamples(float[], int, int) and writeSamples(short[], int, int) methods to write float or 16-bit signed short PCM data directly to the audio device. Stereo samples are interleaved in the order left channel sample, right channel sample. The dispose() method must be called when this AudioDevice is no longer needed.

Author:
badlogicgames@gmail.com

Method Summary
void | dispose() Frees all resources associated with this AudioDevice.
boolean | isMono()
void | writeSamples(float[] samples, int offset, int numSamples) Writes the array of float PCM samples to the audio device and blocks until they have been processed.
void | writeSamples(short[] samples, int offset, int numSamples) Writes the array of 16-bit signed PCM samples to the audio device and blocks until they have been processed.

Method Detail

isMono

boolean isMono()
Returns:
whether this AudioDevice is in mono or stereo mode.

writeSamples

void writeSamples(short[] samples,
                  int offset,
                  int numSamples)
Writes the array of 16-bit signed PCM samples to the audio device and blocks until they have been processed.

Parameters:
samples - The samples.
offset - The offset into the samples array
numSamples - the number of samples to write to the device

writeSamples

void writeSamples(float[] samples,
                  int offset,
                  int numSamples)
Writes the array of float PCM samples to the audio device and blocks until they have been processed.

Parameters:
samples - The samples.
offset - The offset into the samples array
numSamples - the number of samples to write to the device

dispose

void dispose()
Frees all resources associated with this AudioDevice. Needs to be called when the device is no longer needed.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.audio.AudioDevice (libgdx API)

Uses of Interface
com.badlogic.gdx.audio.AudioDevice

Packages that use AudioDevice
com.badlogic.gdx

Uses of AudioDevice in com.badlogic.gdx

Methods in com.badlogic.gdx that return AudioDevice
 AudioDevice Audio.newAudioDevice(boolean isMono)
Creates a new AudioDevice either in 44.1khz mono or stereo mode.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


AudioRecorder (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio
Interface AudioRecorder

public interface AudioRecorder

An AudioRecorder allows to record input from an audio device. It has a sampling rate and is either stereo or mono. Samples are returned in signed 16-bit PCM format. Stereo samples are interleaved in the order left channel, right channel. The AudioRecorder has to be disposed if no longer needed via the dispose().

Author:
mzechner

Method Summary
void | dispose() Disposes the AudioRecorder
void | read(short[] samples, int offset, int numSamples) Reads in numSamples samples into the array samples starting at offset.

Method Detail

read

void read(short[] samples,
          int offset,
          int numSamples)
Reads in numSamples samples into the array samples starting at offset. If the recorder is in stereo you have to multiply numSamples by 2.

Parameters:
samples - the array to write the samples to
offset - the offset into the array
numSamples - the number of samples to be read

dispose

void dispose()
Disposes the AudioRecorder

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.audio.AudioRecorder (libgdx API)

Uses of Interface
com.badlogic.gdx.audio.AudioRecorder

Packages that use AudioRecorder
com.badlogic.gdx

Uses of AudioRecorder in com.badlogic.gdx

Methods in com.badlogic.gdx that return AudioRecorder
 AudioRecorder Audio.newAudioRecoder(int samplingRate, boolean isMono)
Creates a new AudioRecorder.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


AudioTools (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.analysis
Class AudioTools

java.lang.Object
    extended by  com.badlogic.gdx.audio.analysis.AudioTools

public class AudioTools
extends java.lang.Object

Class holding various static native methods for processing audio data.

Author:
mzechner

Constructor Summary
AudioTools()
Method Summary
static java.nio.FloatBuffer | allocateFloatBuffer(int numSamples, int numChannels) Allcoates a direct buffer for the given number of samples and channels.
static java.nio.ShortBuffer | allocateShortBuffer(int numSamples, int numChannels) Allcoates a direct buffer for the given number of samples and channels.
static void | convertToFloat(java.nio.ShortBuffer source, java.nio.FloatBuffer target, int numSamples) Converts the 16-bit signed PCM data given in source to 32-bit float PCM in the range [-1,1].
static void | convertToMono(java.nio.FloatBuffer source, java.nio.FloatBuffer target, int numSamples) Converts the samples in source which are assumed to be interleaved left/right stereo samples to mono, writting the converted samples to target.
static void | convertToMono(java.nio.ShortBuffer source, java.nio.ShortBuffer target, int numSamples) Converts the samples in source which are assumed to be interleaved left/right stereo samples to mono, writting the converted samples to target.
static void | convertToShort(java.nio.FloatBuffer source, java.nio.FloatBuffer target, int numSamples) Converts the 32-bit float PCM data given in source to 16-bit signed PCM in the range [-1,1].
static float | spectralFlux(java.nio.FloatBuffer spectrumA, java.nio.FloatBuffer spectrumB, int numSamples) Calculates the spectral flux between the two given spectra.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AudioTools

public AudioTools()
Method Detail

convertToFloat

public static void convertToFloat(java.nio.ShortBuffer source,
                                  java.nio.FloatBuffer target,
                                  int numSamples)
Converts the 16-bit signed PCM data given in source to 32-bit float PCM in the range [-1,1]. It is assumed that there's numSamples elements available in both buffers. Source and target get read and written to from offset 0. All buffers must be direct.

Parameters:
source - the source buffer
target - the target buffer
numSamples - the number of samples

convertToShort

public static void convertToShort(java.nio.FloatBuffer source,
                                  java.nio.FloatBuffer target,
                                  int numSamples)
Converts the 32-bit float PCM data given in source to 16-bit signed PCM in the range [-1,1]. It is assumed that there's numSamples elements available in both buffers. Source and target get read and written to from offset 0. All buffers must be direct.

Parameters:
source - the source buffer
target - the target buffer
numSamples - the number of samples

convertToMono

public static void convertToMono(java.nio.ShortBuffer source,
                                 java.nio.ShortBuffer target,
                                 int numSamples)
Converts the samples in source which are assumed to be interleaved left/right stereo samples to mono, writting the converted samples to target. Source is assumed to hold numSamples samples, target should hold numSamples / 2. Samples are read and written from position 0 up to numSamples. All buffers must be direct.

Parameters:
source - the source buffer
target - the target buffer
numSamples - the number of samples to convert (target will have numSamples /2 filled after a call to this)

convertToMono

public static void convertToMono(java.nio.FloatBuffer source,
                                 java.nio.FloatBuffer target,
                                 int numSamples)
Converts the samples in source which are assumed to be interleaved left/right stereo samples to mono, writting the converted samples to target. Source is assumed to hold numSamples samples, target should hold numSamples / 2. Samples are read and written from position 0 up to numSamples. All buffers must be direct.

Parameters:
source - the source buffer
target - the target buffer
numSamples - the number of samples to convert (target will have numSamples /2 filled after a call to this)

spectralFlux

public static float spectralFlux(java.nio.FloatBuffer spectrumA,
                                 java.nio.FloatBuffer spectrumB,
                                 int numSamples)
Calculates the spectral flux between the two given spectra. Both buffers are assumed to hold numSamples elements. Spectrum B is the current spectrum spectrum A the last spectrum. All buffers must be direct.

Parameters:
spectrumA - the first spectrum
spectrumB - the second spectrum
numSamples - the number of elements
Returns:
the spectral flux

allocateFloatBuffer

public static java.nio.FloatBuffer allocateFloatBuffer(int numSamples,
                                                       int numChannels)
Allcoates a direct buffer for the given number of samples and channels. The final numer of samples is numSamples * numChannels.

Parameters:
numSamples - the number of samples
numChannels - the number of channels
Returns:
the direct buffer

allocateShortBuffer

public static java.nio.ShortBuffer allocateShortBuffer(int numSamples,
                                                       int numChannels)
Allcoates a direct buffer for the given number of samples and channels. The final numer of samples is numSamples * numChannels.

Parameters:
numSamples - the number of samples
numChannels - the number of channels
Returns:
the direct buffer
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.audio.analysis.AudioTools (libgdx API)

Uses of Class
com.badlogic.gdx.audio.analysis.AudioTools

No usage of com.badlogic.gdx.audio.analysis.AudioTools

Overview Package Class Use Tree Deprecated Index Help
libgdx API


BitmapFont (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class BitmapFont

java.lang.Object
    extended by  com.badlogic.gdx.graphics.BitmapFont

public class BitmapFont
extends java.lang.Object

Renders bitmap fonts. The font consists of 2 files: an image file or TextureRegion containing the glyphs and a file in the AngleCode BMFont text format that describes where each glyph is on the image. Currently only a single image of glyphs is supported.

Text is drawn using a SpriteBatch. Text can be cached in a BitmapFontCache for faster rendering of static text, which saves needing to compute the location of each glyph each frame.

* The texture for a BitmapFont loaded from a file is managed. dispose() must be called to free the texture when no longer needed. A BitmapFont loaded using a TextureRegion is managed if the region's texture is managed. Disposing the BitmapFont disposes the region's texture, which may not be desirable if the texture is still being used elsewhere.

The code is based on Matthias Mann's TWL BitmapFont class. Thanks for sharing, Matthias! :)

Author:
Nathan Sweet , Matthias Mann

Nested Class Summary
static class | BitmapFont.HAlignment
static class | BitmapFont.TextBounds
Constructor Summary
BitmapFont()
Creates a BitmapFont using the default 15pt Arial font included in the libgdx JAR file.
BitmapFont(FileHandle fontFile, boolean flip)
Creates a BitmapFont from a BMFont file.
BitmapFont(FileHandle fontFile, FileHandle imageFile, boolean flip)
Creates a BitmapFont from a BMFont file, using the specified image for glyphs.
BitmapFont(FileHandle fontFile, TextureRegion region, boolean flip)
Creates a BitmapFont with the glyphs relative to the specified region.
Method Summary
int | computeVisibleGlpyhs(java.lang.CharSequence str, int start, int end, float availableWidth) Returns the number of glyphs from the substring that can be rendered in the specified width.
void | dispose() Disposes the texture used by this BitmapFont's region.
BitmapFont.TextBounds | draw(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y) Draws a string at the specified position and color.
BitmapFont.TextBounds | draw(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, int start, int end) Draws a substring at the specified position.
BitmapFont.TextBounds | drawMultiLine(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y) Draws a string, which may contain newlines (\n), at the specified position.
BitmapFont.TextBounds | drawMultiLine(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float alignmentWidth, BitmapFont.HAlignment alignment) Draws a string, which may contain newlines (\n), at the specified position and alignment.
BitmapFont.TextBounds | drawWrapped(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float wrapWidth) Draws a string, which may contain newlines (\n), with the specified position and color.
BitmapFont.TextBounds | drawWrapped(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float wrapWidth, BitmapFont.HAlignment alignment) Draws a string, which may contain newlines (\n), with the specified position and color.
int | getAscent() Returns the ascent, which is the distance from the cap height to the top of the tallest glyph.
BitmapFont.TextBounds | getBounds(java.lang.CharSequence str) Returns the size of the specified string.
BitmapFont.TextBounds | getBounds(java.lang.CharSequence str, int start, int end) Returns the size of the specified substring.
int | getCapHeight() Returns the cap height, which is the distance from the top of most uppercase characters to the basline.
Color | getColor() Returns the color of this font.
int | getLineHeight() Returns the line height, which is the distance from one line of text to the next.
BitmapFont.TextBounds | getMultiLineBounds(java.lang.CharSequence str) Returns the size of the specified string, which may contain newlines.
TextureRegion | getRegion()
int | getSpaceWidth() Returns the width of the space character.
BitmapFont.TextBounds | getWrappedBounds(java.lang.CharSequence str, float wrapWidth) Returns the size of the specified string, which may contain newlines and is wrapped to keep it within a rectangle of the specified width.
int | getXHeight() Returns the x-height, which is the distance from the top of most lowercase characters to the basline.
void | setColor(Color tint)
void | setColor(float r, float g, float b, float a)
void | setFixedWidthGlyphs(java.lang.CharSequence glyphs) Makes the specified glyphs fixed width.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BitmapFont

public BitmapFont()
Creates a BitmapFont using the default 15pt Arial font included in the libgdx JAR file. This is convenient to easily display text without bothering with generating a bitmap font.

BitmapFont

public BitmapFont(FileHandle fontFile,
                  TextureRegion region,
                  boolean flip)
Creates a BitmapFont with the glyphs relative to the specified region.

Parameters:
region - The texture region containing the glyphs. The glyphs must be relative to the lower left corner (ie, the region should not be flipped).
flip - If true, the glyphs will be flipped for use with a perspective where 0,0 is the upper left corner.

BitmapFont

public BitmapFont(FileHandle fontFile,
                  boolean flip)
Creates a BitmapFont from a BMFont file. The image file name is read from the BMFont file and the image is loaded from the same directory.

Parameters:
flip - If true, the glyphs will be flipped for use with a perspective where 0,0 is the upper left corner.

BitmapFont

public BitmapFont(FileHandle fontFile,
                  FileHandle imageFile,
                  boolean flip)
Creates a BitmapFont from a BMFont file, using the specified image for glyphs. Any image specified in the BMFont file is ignored.

Parameters:
flip - If true, the glyphs will be flipped for use with a perspective where 0,0 is the upper left corner.
Method Detail

draw

public BitmapFont.TextBounds draw(SpriteBatch spriteBatch,
                                  java.lang.CharSequence str,
                                  float x,
                                  float y)
Draws a string at the specified position and color.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the rendered string (the height is the distance from y to the baseline). Note the same TextBounds instance is used for all methods that return TextBounds.

draw

public BitmapFont.TextBounds draw(SpriteBatch spriteBatch,
                                  java.lang.CharSequence str,
                                  float x,
                                  float y,
                                  int start,
                                  int end)
Draws a substring at the specified position.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
start - The first character of the string to draw.
end - The last character of the string to draw (exclusive).
Returns:
The bounds of the rendered string (the height is the distance from y to the baseline). Note the same TextBounds instance is used for all methods that return TextBounds.

drawMultiLine

public BitmapFont.TextBounds drawMultiLine(SpriteBatch spriteBatch,
                                           java.lang.CharSequence str,
                                           float x,
                                           float y)
Draws a string, which may contain newlines (\n), at the specified position.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the rendered string (the height is the distance from y to the baseline of the last line). Note the same TextBounds instance is used for all methods that return TextBounds.

drawMultiLine

public BitmapFont.TextBounds drawMultiLine(SpriteBatch spriteBatch,
                                           java.lang.CharSequence str,
                                           float x,
                                           float y,
                                           float alignmentWidth,
                                           BitmapFont.HAlignment alignment)
Draws a string, which may contain newlines (\n), at the specified position and alignment. Each line is aligned horizontally within a rectangle of the specified width.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the rendered string (the height is the distance from y to the baseline of the last line). Note the same TextBounds instance is used for all methods that return TextBounds.

drawWrapped

public BitmapFont.TextBounds drawWrapped(SpriteBatch spriteBatch,
                                         java.lang.CharSequence str,
                                         float x,
                                         float y,
                                         float wrapWidth)
Draws a string, which may contain newlines (\n), with the specified position and color. Each line is automatically wrapped to keep it within a rectangle of the specified width.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the rendered string (the height is the distance from y to the baseline of the last line). Note the same TextBounds instance is used for all methods that return TextBounds.

drawWrapped

public BitmapFont.TextBounds drawWrapped(SpriteBatch spriteBatch,
                                         java.lang.CharSequence str,
                                         float x,
                                         float y,
                                         float wrapWidth,
                                         BitmapFont.HAlignment alignment)
Draws a string, which may contain newlines (\n), with the specified position and color. Each line is automatically wrapped to keep it within a rectangle of the specified width, and aligned horizontally within that rectangle.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the rendered string (the height is the distance from y to the baseline of the last line). Note the same TextBounds instance is used for all methods that return TextBounds.

getBounds

public BitmapFont.TextBounds getBounds(java.lang.CharSequence str)
Returns the size of the specified string. The height is the distance from the top of most capital letters in the font (the cap height) to the baseline. Note the same TextBounds instance is used for all methods that return TextBounds.

getBounds

public BitmapFont.TextBounds getBounds(java.lang.CharSequence str,
                                       int start,
                                       int end)
Returns the size of the specified substring. The height is the distance from the top of most capital letters in the font (the cap height) to the baseline. Note the same TextBounds instance is used for all methods that return TextBounds.

Parameters:
start - The first character of the string.
end - The last character of the string (exclusive).

getMultiLineBounds

public BitmapFont.TextBounds getMultiLineBounds(java.lang.CharSequence str)
Returns the size of the specified string, which may contain newlines. The height is the distance from the top of most capital letters in the font (the cap height) to the baseline of the last line of text. Note the same TextBounds instance is used for all methods that return TextBounds.

getWrappedBounds

public BitmapFont.TextBounds getWrappedBounds(java.lang.CharSequence str,
                                              float wrapWidth)
Returns the size of the specified string, which may contain newlines and is wrapped to keep it within a rectangle of the specified width. The height is the distance from the top of most capital letters in the font (the cap height) to the baseline of the last line of text. Note the same TextBounds instance is used for all methods that return TextBounds.

computeVisibleGlpyhs

public int computeVisibleGlpyhs(java.lang.CharSequence str,
                                int start,
                                int end,
                                float availableWidth)
Returns the number of glyphs from the substring that can be rendered in the specified width.

Parameters:
start - The first character of the string.
end - The last character of the string (exclusive).

setColor

public void setColor(Color tint)

setColor

public void setColor(float r,
                     float g,
                     float b,
                     float a)

getColor

public Color getColor()
Returns the color of this font. Changing the returned color will have no affect, setColor(Color) or setColor(float, float, float, float) must be used.

getRegion

public TextureRegion getRegion()

getLineHeight

public int getLineHeight()
Returns the line height, which is the distance from one line of text to the next.

getSpaceWidth

public int getSpaceWidth()
Returns the width of the space character.

getXHeight

public int getXHeight()
Returns the x-height, which is the distance from the top of most lowercase characters to the basline.

getCapHeight

public int getCapHeight()
Returns the cap height, which is the distance from the top of most uppercase characters to the basline. Since the drawing position is the cap height of the first line, the cap height can be used to get the location of the baseline.

getAscent

public int getAscent()
Returns the ascent, which is the distance from the cap height to the top of the tallest glyph.

dispose

public void dispose()
Disposes the texture used by this BitmapFont's region.

setFixedWidthGlyphs

public void setFixedWidthGlyphs(java.lang.CharSequence glyphs)
Makes the specified glyphs fixed width. This can be useful to make the numbers in a font fixed width. Eg, when horizontally centering a score or loading percentage text, it will not jump around as different numbers are shown.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.BitmapFont (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.BitmapFont

Packages that use BitmapFont
com.badlogic.gdx.graphics

Uses of BitmapFont in com.badlogic.gdx.graphics

Constructors in com.badlogic.gdx.graphics with parameters of type BitmapFont
BitmapFontCache(BitmapFont font)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


BitmapFont.HAlignment (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.graphics
Enum BitmapFont.HAlignment

java.lang.Object
    extended by  java.lang.Enum<BitmapFont.HAlignment>
        extended by  com.badlogic.gdx.graphics.BitmapFont.HAlignment
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<BitmapFont.HAlignment>
Enclosing class:
BitmapFont
public static enum BitmapFont.HAlignment
extends java.lang.Enum<BitmapFont.HAlignment>

Enum Constant Summary
CENTER
LEFT
RIGHT
Method Summary
static BitmapFont.HAlignment | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BitmapFont.HAlignment[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

LEFT

public static final BitmapFont.HAlignment LEFT

CENTER

public static final BitmapFont.HAlignment CENTER

RIGHT

public static final BitmapFont.HAlignment RIGHT
Method Detail

values

public static BitmapFont.HAlignment[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (BitmapFont.HAlignment c : BitmapFont.HAlignment.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static BitmapFont.HAlignment valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.graphics.BitmapFont.HAlignment (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.BitmapFont.HAlignment

Packages that use BitmapFont.HAlignment
com.badlogic.gdx.graphics

Uses of BitmapFont.HAlignment in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return BitmapFont.HAlignment
static BitmapFont.HAlignment | BitmapFont.HAlignment.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BitmapFont.HAlignment[] | BitmapFont.HAlignment.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.badlogic.gdx.graphics with parameters of type BitmapFont.HAlignment
BitmapFont.TextBounds | BitmapFont.drawMultiLine(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float alignmentWidth, BitmapFont.HAlignment alignment) Draws a string, which may contain newlines (\n), at the specified position and alignment.
BitmapFont.TextBounds | BitmapFont.drawWrapped(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float wrapWidth, BitmapFont.HAlignment alignment) Draws a string, which may contain newlines (\n), with the specified position and color.
BitmapFont.TextBounds | BitmapFontCache.setMultiLineText(java.lang.CharSequence str, float x, float y, float alignmentWidth, BitmapFont.HAlignment alignment) Caches a string, which may contain newlines (\n), with the specified position and alignment.
BitmapFont.TextBounds | BitmapFontCache.setWrappedText(java.lang.CharSequence str, float x, float y, float wrapWidth, BitmapFont.HAlignment alignment) Caches a string, which may contain newlines (\n), with the specified position.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


BitmapFont.TextBounds (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class BitmapFont.TextBounds

java.lang.Object
    extended by  com.badlogic.gdx.graphics.BitmapFont.TextBounds
Enclosing class:
BitmapFont
public static class BitmapFont.TextBounds
extends java.lang.Object

Field Summary
int | height
int | width
Constructor Summary
BitmapFont.TextBounds()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

width

public int width

height

public int height
Constructor Detail

BitmapFont.TextBounds

public BitmapFont.TextBounds()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.BitmapFont.TextBounds (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.BitmapFont.TextBounds

Packages that use BitmapFont.TextBounds
com.badlogic.gdx.graphics

Uses of BitmapFont.TextBounds in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return BitmapFont.TextBounds
BitmapFont.TextBounds | BitmapFont.draw(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y) Draws a string at the specified position and color.
BitmapFont.TextBounds | BitmapFont.draw(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, int start, int end) Draws a substring at the specified position.
BitmapFont.TextBounds | BitmapFont.drawMultiLine(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y) Draws a string, which may contain newlines (\n), at the specified position.
BitmapFont.TextBounds | BitmapFont.drawMultiLine(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float alignmentWidth, BitmapFont.HAlignment alignment) Draws a string, which may contain newlines (\n), at the specified position and alignment.
BitmapFont.TextBounds | BitmapFont.drawWrapped(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float wrapWidth) Draws a string, which may contain newlines (\n), with the specified position and color.
BitmapFont.TextBounds | BitmapFont.drawWrapped(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float wrapWidth, BitmapFont.HAlignment alignment) Draws a string, which may contain newlines (\n), with the specified position and color.
BitmapFont.TextBounds | BitmapFontCache.getBounds() Returns the size of the cached string.
BitmapFont.TextBounds | BitmapFont.getBounds(java.lang.CharSequence str) Returns the size of the specified string.
BitmapFont.TextBounds | BitmapFont.getBounds(java.lang.CharSequence str, int start, int end) Returns the size of the specified substring.
BitmapFont.TextBounds | BitmapFont.getMultiLineBounds(java.lang.CharSequence str) Returns the size of the specified string, which may contain newlines.
BitmapFont.TextBounds | BitmapFont.getWrappedBounds(java.lang.CharSequence str, float wrapWidth) Returns the size of the specified string, which may contain newlines and is wrapped to keep it within a rectangle of the specified width.
BitmapFont.TextBounds | BitmapFontCache.setMultiLineText(java.lang.CharSequence str, float x, float y) Caches a string, which may contain newlines (\n), with the specified position.
BitmapFont.TextBounds | BitmapFontCache.setMultiLineText(java.lang.CharSequence str, float x, float y, float alignmentWidth, BitmapFont.HAlignment alignment) Caches a string, which may contain newlines (\n), with the specified position and alignment.
BitmapFont.TextBounds | BitmapFontCache.setText(java.lang.CharSequence str, float x, float y) Caches a string with the specified position.
BitmapFont.TextBounds | BitmapFontCache.setText(java.lang.CharSequence str, float x, float y, int start, int end) Caches a substring with the specified position.
BitmapFont.TextBounds | BitmapFontCache.setWrappedText(java.lang.CharSequence str, float x, float y, float wrapWidth) Caches a string, which may contain newlines (\n), with the specified position.
BitmapFont.TextBounds | BitmapFontCache.setWrappedText(java.lang.CharSequence str, float x, float y, float wrapWidth, BitmapFont.HAlignment alignment) Caches a string, which may contain newlines (\n), with the specified position.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


BitmapFontCache (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class BitmapFontCache

java.lang.Object
    extended by  com.badlogic.gdx.graphics.BitmapFontCache

public class BitmapFontCache
extends java.lang.Object

Caches glyph geometry for a BitmapFont, providing a fast way to render static text. This saves needing to compute the location of each glyph each frame.

Author:
Nathan Sweet , Matthias Mann

Constructor Summary
BitmapFontCache(BitmapFont font)
Method Summary
void | draw(SpriteBatch spriteBatch)
BitmapFont.TextBounds | getBounds() Returns the size of the cached string.
float | getX() Returns the x position of the cached string, relative to the position when the string was cached.
float | getY() Returns the y position of the cached string, relative to the position when the string was cached.
void | setColor(Color tint)
void | setColor(float r, float g, float b, float a)
BitmapFont.TextBounds | setMultiLineText(java.lang.CharSequence str, float x, float y) Caches a string, which may contain newlines (\n), with the specified position.
BitmapFont.TextBounds | setMultiLineText(java.lang.CharSequence str, float x, float y, float alignmentWidth, BitmapFont.HAlignment alignment) Caches a string, which may contain newlines (\n), with the specified position and alignment.
void | setPosition(float x, float y) Sets the position of the text, relative to the position when the cached text was created.
BitmapFont.TextBounds | setText(java.lang.CharSequence str, float x, float y) Caches a string with the specified position.
BitmapFont.TextBounds | setText(java.lang.CharSequence str, float x, float y, int start, int end) Caches a substring with the specified position.
BitmapFont.TextBounds | setWrappedText(java.lang.CharSequence str, float x, float y, float wrapWidth) Caches a string, which may contain newlines (\n), with the specified position.
BitmapFont.TextBounds | setWrappedText(java.lang.CharSequence str, float x, float y, float wrapWidth, BitmapFont.HAlignment alignment) Caches a string, which may contain newlines (\n), with the specified position.
void | translate(float xAmount, float yAmount) Sets the position of the text, relative to its current position.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BitmapFontCache

public BitmapFontCache(BitmapFont font)
Method Detail

setPosition

public void setPosition(float x,
                        float y)
Sets the position of the text, relative to the position when the cached text was created.

Parameters:
x - The x coordinate
y - The y coodinate

translate

public void translate(float xAmount,
                      float yAmount)
Sets the position of the text, relative to its current position.

Parameters:
xAmount - The amount in x to move the text
yAmount - The amount in y to move the text

setColor

public void setColor(Color tint)

setColor

public void setColor(float r,
                     float g,
                     float b,
                     float a)

draw

public void draw(SpriteBatch spriteBatch)

setText

public BitmapFont.TextBounds setText(java.lang.CharSequence str,
                                     float x,
                                     float y)
Caches a string with the specified position.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the cached string (the height is the distance from y to the baseline).

setText

public BitmapFont.TextBounds setText(java.lang.CharSequence str,
                                     float x,
                                     float y,
                                     int start,
                                     int end)
Caches a substring with the specified position.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
start - The first character of the string to draw.
end - The last character of the string to draw (exclusive).
Returns:
The bounds of the cached string (the height is the distance from y to the baseline).

setMultiLineText

public BitmapFont.TextBounds setMultiLineText(java.lang.CharSequence str,
                                              float x,
                                              float y)
Caches a string, which may contain newlines (\n), with the specified position.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the cached string (the height is the distance from y to the baseline of the last line).

setMultiLineText

public BitmapFont.TextBounds setMultiLineText(java.lang.CharSequence str,
                                              float x,
                                              float y,
                                              float alignmentWidth,
                                              BitmapFont.HAlignment alignment)
Caches a string, which may contain newlines (\n), with the specified position and alignment. Each line is aligned horizontally within a rectangle of the specified width.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the cached string (the height is the distance from y to the baseline of the last line).

setWrappedText

public BitmapFont.TextBounds setWrappedText(java.lang.CharSequence str,
                                            float x,
                                            float y,
                                            float wrapWidth)
Caches a string, which may contain newlines (\n), with the specified position. Each line is automatically wrapped to keep it within a rectangle of the specified width.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the cached string (the height is the distance from y to the baseline of the last line).

setWrappedText

public BitmapFont.TextBounds setWrappedText(java.lang.CharSequence str,
                                            float x,
                                            float y,
                                            float wrapWidth,
                                            BitmapFont.HAlignment alignment)
Caches a string, which may contain newlines (\n), with the specified position. Each line is automatically wrapped to keep it within a rectangle of the specified width, and aligned horizontally within that rectangle.

Parameters:
x - The x position for the left most character.
y - The y position for the top of most capital letters in the font (the cap height).
Returns:
The bounds of the cached string (the height is the distance from y to the baseline of the last line).

getBounds

public BitmapFont.TextBounds getBounds()
Returns the size of the cached string. The height is the distance from the top of most capital letters in the font (the cap height) to the baseline of the last line of text.

getX

public float getX()
Returns the x position of the cached string, relative to the position when the string was cached.

getY

public float getY()
Returns the y position of the cached string, relative to the position when the string was cached.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.BitmapFontCache (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.BitmapFontCache

No usage of com.badlogic.gdx.graphics.BitmapFontCache

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Body (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class Body

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Body

public class Body
extends java.lang.Object

A rigid body. These are created via World.CreateBody.

Author:
mzechner

Field Summary
protected long | addr the address of the body
protected java.util.ArrayList<JointEdge> | joints Joints of this body
Vector2 | linVelLoc
Vector2 | linVelWorld
Vector2 | localPoint2
Vector2 | localVector
Constructor Summary
protected Body(World world, long addr)
Constructs a new body with the given address
Method Summary
void | applyAngularImpulse(float impulse) Apply an angular impulse.
void | applyForce(Vector2 force, Vector2 point) Apply a force at a world point.
void | applyLinearImpulse(Vector2 impulse, Vector2 point) Apply an impulse at a point.
void | applyTorque(float torque) Apply a torque.
Fixture | createFixture(FixtureDef def) Creates a fixture and attach it to this body.
Fixture | createFixture(Shape shape, float density) Creates a fixture from a shape and attach it to this body.
void | destroyFixture(Fixture fixture) Destroy a fixture.
float | getAngle() Get the angle in radians.
float | getAngularDamping() Get the angular damping of the body.
float | getAngularVelocity() Get the angular velocity.
java.util.ArrayList<Fixture> | getFixtureList() Get the list of all fixtures attached to this body.
float | getInertia() Get the rotational inertia of the body about the local origin.
java.util.ArrayList<JointEdge> | getJointList() Get the list of all joints attached to this body.
float | getLinearDamping() Get the linear damping of the body.
Vector2 | getLinearVelocity()
Vector2 | getLinearVelocityFromLocalPoint(Vector2 localPoint) Get the world velocity of a local point.
Vector2 | getLinearVelocityFromWorldPoint(Vector2 worldPoint) Get the world linear velocity of a world point attached to this body.
Vector2 | getLocalCenter()
Vector2 | getLocalPoint(Vector2 worldPoint) Gets a local point relative to the body's origin given a world point.
Vector2 | getLocalVector(Vector2 worldVector) Gets a local vector given a world vector.
float | getMass() Get the total mass of the body.
MassData | getMassData() Get the mass data of the body.
Vector2 | getPosition() Get the world body origin position.
Transform | getTransform()
BodyDef.BodyType | getType() Get the type of this body.
java.lang.Object | getUserData() Get the user data
World | getWorld() Get the parent world of this body.
Vector2 | getWorldCenter()
Vector2 | getWorldPoint(Vector2 localPoint) Get the world coordinates of a point given the local coordinates.
Vector2 | getWorldVector(Vector2 localVector) Get the world coordinates of a vector given the local coordinates.
boolean | isActive() Get the active state of the body.
boolean | isAwake() Get the sleeping state of this body.
boolean | isBullet() Is this body treated like a bullet for continuous collision detection?
boolean | isFixedRotation() Does this body have fixed rotation?
boolean | isSleepingAllowed() Is this body allowed to sleep
void | resetMassData() This resets the mass properties to the sum of the mass properties of the fixtures.
void | setActive(boolean flag) Set the active state of the body.
void | setAngularDamping(float angularDamping) Set the angular damping of the body.
void | setAngularVelocity(float omega) Set the angular velocity.
void | setAwake(boolean flag) Set the sleep state of the body.
void | setBullet(boolean flag) Should this body be treated like a bullet for continuous collision detection?
void | setFixedRotation(boolean flag) Set this body to have fixed rotation.
void | setLinearDamping(float linearDamping) Set the linear damping of the body.
void | setLinearVelocity(Vector2 v) Set the linear velocity of the center of mass.
void | setMassData(MassData data) Set the mass properties to override the mass properties of the fixtures.
void | setSleepingAllowed(boolean flag) You can disable sleeping on this body.
void | setTransform(Vector2 position, float angle) Set the position of the body's origin and rotation.
void | setType(BodyDef.BodyType type) Set the type of this body.
void | setUserData(java.lang.Object userData) Set the user data
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

addr

protected final long addr
the address of the body

joints

protected java.util.ArrayList<JointEdge> joints
Joints of this body

localPoint2

public final Vector2 localPoint2

localVector

public final Vector2 localVector

linVelWorld

public final Vector2 linVelWorld

linVelLoc

public final Vector2 linVelLoc
Constructor Detail

Body

protected Body(World world,
               long addr)
Constructs a new body with the given address

Parameters:
world - the world
addr - the address
Method Detail

createFixture

public Fixture createFixture(FixtureDef def)
Creates a fixture and attach it to this body. Use this function if you need to set some fixture parameters, like friction. Otherwise you can create the fixture directly from a shape. If the density is non-zero, this function automatically updates the mass of the body. Contacts are not created until the next time step.

Parameters:
def - the fixture definition.

createFixture

public Fixture createFixture(Shape shape,
                             float density)
Creates a fixture from a shape and attach it to this body. This is a convenience function. Use b2FixtureDef if you need to set parameters like friction, restitution, user data, or filtering. If the density is non-zero, this function automatically updates the mass of the body.

Parameters:
shape - the shape to be cloned.
density - the shape density (set to zero for static bodies).

destroyFixture

public void destroyFixture(Fixture fixture)
Destroy a fixture. This removes the fixture from the broad-phase and destroys all contacts associated with this fixture. This will automatically adjust the mass of the body if the body is dynamic and the fixture has positive density. All fixtures attached to a body are implicitly destroyed when the body is destroyed.

Parameters:
fixture - the fixture to be removed.

setTransform

public void setTransform(Vector2 position,
                         float angle)
Set the position of the body's origin and rotation. This breaks any contacts and wakes the other bodies. Manipulating a body's transform may cause non-physical behavior.

Parameters:
position - the world position of the body's local origin.
angle - the world rotation in radians.

getTransform

public Transform getTransform()

getPosition

public Vector2 getPosition()
Get the world body origin position.

Returns:
the world position of the body's origin.

getAngle

public float getAngle()
Get the angle in radians.

Returns:
the current world rotation angle in radians.

getWorldCenter

public Vector2 getWorldCenter()

getLocalCenter

public Vector2 getLocalCenter()

setLinearVelocity

public void setLinearVelocity(Vector2 v)
Set the linear velocity of the center of mass.

getLinearVelocity

public Vector2 getLinearVelocity()

setAngularVelocity

public void setAngularVelocity(float omega)
Set the angular velocity.

getAngularVelocity

public float getAngularVelocity()
Get the angular velocity.

applyForce

public void applyForce(Vector2 force,
                       Vector2 point)
Apply a force at a world point. If the force is not applied at the center of mass, it will generate a torque and affect the angular velocity. This wakes up the body.

Parameters:
force - the world force vector, usually in Newtons (N).
point - the world position of the point of application.

applyTorque

public void applyTorque(float torque)
Apply a torque. This affects the angular velocity without affecting the linear velocity of the center of mass. This wakes up the body.

Parameters:
torque - about the z-axis (out of the screen), usually in N-m.

applyLinearImpulse

public void applyLinearImpulse(Vector2 impulse,
                               Vector2 point)
Apply an impulse at a point. This immediately modifies the velocity. It also modifies the angular velocity if the point of application is not at the center of mass. This wakes up the body.

Parameters:
impulse - the world impulse vector, usually in N-seconds or kg-m/s.
point - the world position of the point of application.

applyAngularImpulse

public void applyAngularImpulse(float impulse)
Apply an angular impulse.

Parameters:
impulse - the angular impulse in units of kg*m*m/s

getMass

public float getMass()
Get the total mass of the body.

Returns:
the mass, usually in kilograms (kg).

getInertia

public float getInertia()
Get the rotational inertia of the body about the local origin.

Returns:
the rotational inertia, usually in kg-m^2.

getMassData

public MassData getMassData()
Get the mass data of the body.

Returns:
a struct containing the mass, inertia and center of the body.

setMassData

public void setMassData(MassData data)
Set the mass properties to override the mass properties of the fixtures. Note that this changes the center of mass position. Note that creating or destroying fixtures can also alter the mass. This function has no effect if the body isn't dynamic.

Parameters:
data - the mass properties.

resetMassData

public void resetMassData()
This resets the mass properties to the sum of the mass properties of the fixtures. This normally does not need to be called unless you called SetMassData to override the mass and you later want to reset the mass.

getWorldPoint

public Vector2 getWorldPoint(Vector2 localPoint)
Get the world coordinates of a point given the local coordinates.

Parameters:
localPoint - a point on the body measured relative the the body's origin.
Returns:
the same point expressed in world coordinates.

getWorldVector

public Vector2 getWorldVector(Vector2 localVector)
Get the world coordinates of a vector given the local coordinates.

Parameters:
localVector - a vector fixed in the body.
Returns:
the same vector expressed in world coordinates.

getLocalPoint

public Vector2 getLocalPoint(Vector2 worldPoint)
Gets a local point relative to the body's origin given a world point.

Parameters:
worldPoint - a point in world coordinates.
Returns:
the corresponding local point relative to the body's origin.

getLocalVector

public Vector2 getLocalVector(Vector2 worldVector)
Gets a local vector given a world vector.

Parameters:
worldVector - a vector in world coordinates.
Returns:
the corresponding local vector.

getLinearVelocityFromWorldPoint

public Vector2 getLinearVelocityFromWorldPoint(Vector2 worldPoint)
Get the world linear velocity of a world point attached to this body.

Parameters:
worldPoint - a point in world coordinates.
Returns:
the world velocity of a point.

getLinearVelocityFromLocalPoint

public Vector2 getLinearVelocityFromLocalPoint(Vector2 localPoint)
Get the world velocity of a local point.

Parameters:
localPoint - a point in local coordinates.
Returns:
the world velocity of a point.

getLinearDamping

public float getLinearDamping()
Get the linear damping of the body.

setLinearDamping

public void setLinearDamping(float linearDamping)
Set the linear damping of the body.

getAngularDamping

public float getAngularDamping()
Get the angular damping of the body.

setAngularDamping

public void setAngularDamping(float angularDamping)
Set the angular damping of the body.

setType

public void setType(BodyDef.BodyType type)
Set the type of this body. This may alter the mass and velocity.

getType

public BodyDef.BodyType getType()
Get the type of this body.

setBullet

public void setBullet(boolean flag)
Should this body be treated like a bullet for continuous collision detection?

isBullet

public boolean isBullet()
Is this body treated like a bullet for continuous collision detection?

setSleepingAllowed

public void setSleepingAllowed(boolean flag)
You can disable sleeping on this body. If you disable sleeping, the

isSleepingAllowed

public boolean isSleepingAllowed()
Is this body allowed to sleep

setAwake

public void setAwake(boolean flag)
Set the sleep state of the body. A sleeping body has very low CPU cost.

Parameters:
flag - set to true to put body to sleep, false to wake it.

isAwake

public boolean isAwake()
Get the sleeping state of this body.

Returns:
true if the body is sleeping.

setActive

public void setActive(boolean flag)
Set the active state of the body. An inactive body is not simulated and cannot be collided with or woken up. If you pass a flag of true, all fixtures will be added to the broad-phase. If you pass a flag of false, all fixtures will be removed from the broad-phase and all contacts will be destroyed. Fixtures and joints are otherwise unaffected. You may continue to create/destroy fixtures and joints on inactive bodies. Fixtures on an inactive body are implicitly inactive and will not participate in collisions, ray-casts, or queries. Joints connected to an inactive body are implicitly inactive. An inactive body is still owned by a b2World object and remains in the body list.

isActive

public boolean isActive()
Get the active state of the body.

setFixedRotation

public void setFixedRotation(boolean flag)
Set this body to have fixed rotation. This causes the mass to be reset.

isFixedRotation

public boolean isFixedRotation()
Does this body have fixed rotation?

getFixtureList

public java.util.ArrayList<Fixture> getFixtureList()
Get the list of all fixtures attached to this body. Do not modify the list!

getJointList

public java.util.ArrayList<JointEdge> getJointList()
Get the list of all joints attached to this body. Do not modify the list!

getWorld

public World getWorld()
Get the parent world of this body.

getUserData

public java.lang.Object getUserData()
Get the user data

setUserData

public void setUserData(java.lang.Object userData)
Set the user data

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.Body (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.Body

Packages that use Body
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints

Uses of Body in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as Body
Body | JointDef.bodyA The first attached body.
Body | JointDef.bodyB The second attached body
Body | JointEdge.other

Fields in com.badlogic.gdx.physics.box2d with type parameters of type Body
protected  LongHashMap<Body> World.bodies
all known bodies

Methods in com.badlogic.gdx.physics.box2d that return Body
Body | World.createBody(BodyDef def) Create a rigid body given a definition.
Body | Fixture.getBody() Get the parent body of this fixture.
Body | Joint.getBodyA() Get the first body attached to this joint.
Body | Joint.getBodyB() Get the second body attached to this joint.

Methods in com.badlogic.gdx.physics.box2d that return types with arguments of type Body
 java.util.Iterator<Body> World.getBodies()

Methods in com.badlogic.gdx.physics.box2d with parameters of type Body
 void World.destroyBody(Body body)
Destroy a rigid body given a definition.

Constructors in com.badlogic.gdx.physics.box2d with parameters of type Body
Fixture(Body body, long addr)
Constructs a new fixture
JointEdge(Body other, Joint joint)

Uses of Body in com.badlogic.gdx.physics.box2d.joints

Methods in com.badlogic.gdx.physics.box2d.joints with parameters of type Body
void | FrictionJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchor) Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
void | RevoluteJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchor) Initialize the bodies, anchors, and reference angle using a world anchor point.
void | WeldJointDef.initialize(Body body1, Body body2, Vector2 anchor)
void | DistanceJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchorA, Vector2 anchorB) Initialize the bodies, anchors, and length using the world anchors.
void | LineJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchor, Vector2 axis) Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
void | PrismaticJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchor, Vector2 axis) Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
void | PulleyJointDef.initialize(Body bodyA, Body bodyB, Vector2 groundAnchorA, Vector2 groundAnchorB, Vector2 anchorA, Vector2 anchorB, float ratio) Initialize the bodies, anchors, lengths, max lengths, and ratio using the world anchors.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


BodyDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class BodyDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.BodyDef

public class BodyDef
extends java.lang.Object

A body definition holds all the data needed to construct a rigid body. You can safely re-use body definitions. Shapes are added to a body after construction.

Author:
mzechner

Nested Class Summary
static class BodyDef.BodyType
The body type.
Field Summary
boolean | active Does this body start out active?
boolean | allowSleep Set this flag to false if this body should never fall asleep.
float | angle The world angle of the body in radians.
float | angularDamping Angular damping is use to reduce the angular velocity.
float | angularVelocity The angular velocity of the body.
boolean | awake Is this body initially awake or sleeping?
boolean | bullet Is this a fast moving body that should be prevented from tunneling through other moving bodies? Note that all bodies are prevented from tunneling through kinematic and static bodies.
boolean | fixedRotation Should this body be prevented from rotating? Useful for characters.
float | inertiaScale Experimental: scales the inertia tensor.
float | linearDamping Linear damping is use to reduce the linear velocity.
Vector2 | linearVelocity The linear velocity of the body's origin in world co-ordinates.
Vector2 | position The world position of the body.
BodyDef.BodyType | type The body type: static, kinematic, or dynamic.
Constructor Summary
BodyDef()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

type

public BodyDef.BodyType type
The body type: static, kinematic, or dynamic. Note: if a dynamic body would have zero mass, the mass is set to one.

position

public final Vector2 position
The world position of the body. Avoid creating bodies at the origin since this can lead to many overlapping shapes.

angle

public float angle
The world angle of the body in radians.

linearVelocity

public final Vector2 linearVelocity
The linear velocity of the body's origin in world co-ordinates.

angularVelocity

public float angularVelocity
The angular velocity of the body.

linearDamping

public float linearDamping
Linear damping is use to reduce the linear velocity. The damping parameter can be larger than 1.0f but the damping effect becomes sensitive to the time step when the damping parameter is large.

angularDamping

public float angularDamping
Angular damping is use to reduce the angular velocity. The damping parameter can be larger than 1.0f but the damping effect becomes sensitive to the time step when the damping parameter is large.

allowSleep

public boolean allowSleep
Set this flag to false if this body should never fall asleep. Note that this increases CPU usage.

awake

public boolean awake
Is this body initially awake or sleeping?

fixedRotation

public boolean fixedRotation
Should this body be prevented from rotating? Useful for characters.

bullet

public boolean bullet
Is this a fast moving body that should be prevented from tunneling through other moving bodies? Note that all bodies are prevented from tunneling through kinematic and static bodies. This setting is only considered on dynamic bodies.

active

public boolean active
Does this body start out active?

inertiaScale

public float inertiaScale
Experimental: scales the inertia tensor.

Constructor Detail

BodyDef

public BodyDef()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.BodyDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.BodyDef

Packages that use BodyDef
com.badlogic.gdx.physics.box2d

Uses of BodyDef in com.badlogic.gdx.physics.box2d

Methods in com.badlogic.gdx.physics.box2d with parameters of type BodyDef
 Body World.createBody(BodyDef def)
Create a rigid body given a definition.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


BodyDef.BodyType (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.physics.box2d
Enum BodyDef.BodyType

java.lang.Object
    extended by  java.lang.Enum<BodyDef.BodyType>
        extended by  com.badlogic.gdx.physics.box2d.BodyDef.BodyType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<BodyDef.BodyType>
Enclosing class:
BodyDef
public static enum BodyDef.BodyType
extends java.lang.Enum<BodyDef.BodyType>

The body type. static: zero mass, zero velocity, may be manually moved kinematic: zero mass, non-zero velocity set by user, moved by solver dynamic: positive mass, non-zero velocity determined by forces, moved by solver

Enum Constant Summary
DynamicBody
KinematicBody
StaticBody
Method Summary
int | getValue()
static BodyDef.BodyType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BodyDef.BodyType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

StaticBody

public static final BodyDef.BodyType StaticBody

KinematicBody

public static final BodyDef.BodyType KinematicBody

DynamicBody

public static final BodyDef.BodyType DynamicBody
Method Detail

values

public static BodyDef.BodyType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (BodyDef.BodyType c : BodyDef.BodyType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static BodyDef.BodyType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.BodyDef.BodyType (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.BodyDef.BodyType

Packages that use BodyDef.BodyType
com.badlogic.gdx.physics.box2d

Uses of BodyDef.BodyType in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as BodyDef.BodyType
 BodyDef.BodyType BodyDef.type
The body type: static, kinematic, or dynamic.

Methods in com.badlogic.gdx.physics.box2d that return BodyDef.BodyType
BodyDef.BodyType | Body.getType() Get the type of this body.
static BodyDef.BodyType | BodyDef.BodyType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static BodyDef.BodyType[] | BodyDef.BodyType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.badlogic.gdx.physics.box2d with parameters of type BodyDef.BodyType
 void Body.setType(BodyDef.BodyType type)
Set the type of this body.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


BoundGroup (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actors
Class BoundGroup

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.Actor
        extended by  com.badlogic.gdx.scenes.scene2d.Group
            extended by  com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
Direct Known Subclasses:
LinearGroup
public class BoundGroup
extends Group

This is a group that respects its width and height. Useful for implementing layouts.

Author:
mzechner

Field Summary
Fields inherited from class com.badlogic.gdx.scenes.scene2d.Group
children, debug, debugTexture, focusedActor, groups, immutableChildren, immutableGroups, lastTouchedChild, namesToActors, oldBatchTransform, scenetransform, tmp4, transform
Fields inherited from class com.badlogic.gdx.scenes.scene2d.Actor
actions, color, height, name, originX, originY, parent, rotation, scaleX, scaleY, touchable, width, x, y
Constructor Summary
BoundGroup(java.lang.String name, float width, float height)
Method Summary
Actor | hit(float x, float y)
protected boolean | touchDown(float x, float y, int pointer)
protected boolean | touchDragged(float x, float y, int pointer)
protected boolean | touchUp(float x, float y, int pointer)
Methods inherited from class com.badlogic.gdx.scenes.scene2d.Group
act, addActor, disableDebugging, enableDebugging, findActor, focus, getActors, getGroups, removeActor, render, swapActor, swapActor, toChildCoordinates, updateTransform
Methods inherited from class com.badlogic.gdx.scenes.scene2d.Actor
action, clearActions, remove, toLocalCoordinates, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BoundGroup

public BoundGroup(java.lang.String name,
                  float width,
                  float height)
Method Detail

touchDown

protected boolean touchDown(float x,
                            float y,
                            int pointer)
Overrides:
touchDown in class Group

touchUp

protected boolean touchUp(float x,
                          float y,
                          int pointer)
Overrides:
touchUp in class Group

touchDragged

protected boolean touchDragged(float x,
                               float y,
                               int pointer)
Overrides:
touchDragged in class Group

hit

public Actor hit(float x,
                 float y)
Overrides:
hit in class Group
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actors.BoundGroup (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actors.BoundGroup

Packages that use BoundGroup
com.badlogic.gdx.scenes.scene2d.actors

Uses of BoundGroup in com.badlogic.gdx.scenes.scene2d.actors

Subclasses of BoundGroup in com.badlogic.gdx.scenes.scene2d.actors
 class LinearGroup

Overview Package Class Use Tree Deprecated Index Help
libgdx API


BoundingBox (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math.collision
Class BoundingBox

java.lang.Object
    extended by  com.badlogic.gdx.math.collision.BoundingBox

public final class BoundingBox
extends java.lang.Object

Encapsulates an axis aligned bounding box represented by a minimum and a maximum Vector. Additionally you can query for the bounding box's center, dimensions and corner points.

Author:
badlogicgames@gmail.com

Field Summary
Vector3 | max
Vector3 | min
Constructor Summary
BoundingBox()
Constructs a new bounding box with the minimum and maximum vector set to zeros.
BoundingBox(BoundingBox bounds)
Constructs a new bounding box from the given bounding box.
BoundingBox(Vector3 minimum, Vector3 maximum)
Constructs the new bounding box using the given minimum and maximum vector.
Method Summary
BoundingBox | clr() Sets the minimum and maximum vector to zeros
boolean | contains(BoundingBox bounds) Returns wheter the given bounding box is contained in this bounding box.
boolean | contains(Vector3 v) Returns wheter the given vector is contained in this bounding box.
BoundingBox | ext(BoundingBox a_bounds) Extends this bounding box by the given bounding box.
BoundingBox | ext(float x, float y, float z) Extends the bounding box by the given vector.
BoundingBox | ext(Vector3 point) Extends the bounding box to incorporate the given Vector3.
Vector3 | getCenter()
Vector3[] | getCorners()
Vector3 | getDimensions()
Vector3 | getMax()
Vector3 | getMin()
BoundingBox | inf() Sets the minimum and maximum vector to positive and negative infinity.
boolean | isValid() Returns wheter this bounding box is valid.
BoundingBox | mul(Matrix4 matrix) Multiplies the bounding box by the given matrix.
BoundingBox | set(BoundingBox bounds) Sets the given bounding box.
BoundingBox | set(java.util.List<Vector3> points) Sets the bounding box minimum and maximum vector from the given points.
BoundingBox | set(Vector3[] points) Sets the bounding box minimum and maximum vector from the given points.
BoundingBox | set(Vector3 minimum, Vector3 maximum) Sets the given minimum and maximum vector.
java.lang.String | toString()
protected void | updateCorners()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

min

public final Vector3 min

max

public final Vector3 max
Constructor Detail

BoundingBox

public BoundingBox()
Constructs a new bounding box with the minimum and maximum vector set to zeros.

BoundingBox

public BoundingBox(BoundingBox bounds)
Constructs a new bounding box from the given bounding box.

Parameters:
bounds - The bounding box to copy

BoundingBox

public BoundingBox(Vector3 minimum,
                   Vector3 maximum)
Constructs the new bounding box using the given minimum and maximum vector.

Parameters:
minimum - The minimum vector
maximum - The maximum vector
Method Detail

getCenter

public Vector3 getCenter()
Returns:
the center of the bounding box

updateCorners

protected void updateCorners()

getCorners

public Vector3[] getCorners()
Returns:
the corners of this bounding box

getDimensions

public Vector3 getDimensions()
Returns:
The dimensions of this bounding box on all three axis

getMin

public Vector3 getMin()
Returns:
The minimum vector

getMax

public Vector3 getMax()
Returns:
The maximum vector

set

public BoundingBox set(BoundingBox bounds)
Sets the given bounding box.

Parameters:
bounds - The bounds.
Returns:
This bounding box for chaining.

set

public BoundingBox set(Vector3 minimum,
                       Vector3 maximum)
Sets the given minimum and maximum vector.

Parameters:
minimum - The minimum vector
maximum - The maximum vector
Returns:
This bounding box for chaining.

set

public BoundingBox set(Vector3[] points)
Sets the bounding box minimum and maximum vector from the given points.

Parameters:
points - The points.
Returns:
This bounding box for chaining.

set

public BoundingBox set(java.util.List<Vector3> points)
Sets the bounding box minimum and maximum vector from the given points.

Parameters:
points - The points.
Returns:
This bounding box for chaining.

inf

public BoundingBox inf()
Sets the minimum and maximum vector to positive and negative infinity.

Returns:
This bounding box for chaining.

ext

public BoundingBox ext(Vector3 point)
Extends the bounding box to incorporate the given Vector3.

Parameters:
point - The vector
Returns:
This bounding box for chaining.

clr

public BoundingBox clr()
Sets the minimum and maximum vector to zeros

Returns:
This bounding box for chaining.

isValid

public boolean isValid()
Returns wheter this bounding box is valid. This means that min != max and min < max.

Returns:
True in case the bounding box is valid, false otherwise

ext

public BoundingBox ext(BoundingBox a_bounds)
Extends this bounding box by the given bounding box.

Parameters:
a_bounds - The bounding box
Returns:
This bounding box for chaining.

mul

public BoundingBox mul(Matrix4 matrix)
Multiplies the bounding box by the given matrix. This is achieved by multiplying the 8 corner points and then calculating the minimum and maximum vectors from the transformed points.

Parameters:
matrix - The matrix
Returns:
This bounding box for chaining.

contains

public boolean contains(BoundingBox bounds)
Returns wheter the given bounding box is contained in this bounding box.

Parameters:
bounds - The bounding box
Returns:
Wheter the given bounding box is contained

contains

public boolean contains(Vector3 v)
Returns wheter the given vector is contained in this bounding box.

Parameters:
v - The vector
Returns:
Wheter the vector is contained or not.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

ext

public BoundingBox ext(float x,
                       float y,
                       float z)
Extends the bounding box by the given vector.

Parameters:
x - The x-coordinate
y - The y-coordinate
z - The z-coordinate
Returns:
This bounding box for chaining.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.collision.BoundingBox (libgdx API)

Uses of Class
com.badlogic.gdx.math.collision.BoundingBox

Packages that use BoundingBox
com.badlogic.gdx.graphics.loaders.md5
com.badlogic.gdx.math
com.badlogic.gdx.math.collision

Uses of BoundingBox in com.badlogic.gdx.graphics.loaders.md5

Fields in com.badlogic.gdx.graphics.loaders.md5 declared as BoundingBox
 BoundingBox[] MD5Animation.bounds

Uses of BoundingBox in com.badlogic.gdx.math

Methods in com.badlogic.gdx.math with parameters of type BoundingBox
boolean | Frustum.boundsInFrustum(BoundingBox bounds) Returns wheter the given BoundingBox is in the frustum.
static boolean | Intersector.intersectRayBoundsFast(Ray ray, BoundingBox bounds) Quick check wheter the given Ray and BoundingBox intersect.

Uses of BoundingBox in com.badlogic.gdx.math.collision

Methods in com.badlogic.gdx.math.collision that return BoundingBox
BoundingBox | BoundingBox.clr() Sets the minimum and maximum vector to zeros
BoundingBox | BoundingBox.ext(BoundingBox a_bounds) Extends this bounding box by the given bounding box.
BoundingBox | BoundingBox.ext(float x, float y, float z) Extends the bounding box by the given vector.
BoundingBox | BoundingBox.ext(Vector3 point) Extends the bounding box to incorporate the given Vector3.
BoundingBox | BoundingBox.inf() Sets the minimum and maximum vector to positive and negative infinity.
BoundingBox | BoundingBox.mul(Matrix4 matrix) Multiplies the bounding box by the given matrix.
BoundingBox | BoundingBox.set(BoundingBox bounds) Sets the given bounding box.
BoundingBox | BoundingBox.set(java.util.List<Vector3> points) Sets the bounding box minimum and maximum vector from the given points.
BoundingBox | BoundingBox.set(Vector3[] points) Sets the bounding box minimum and maximum vector from the given points.
BoundingBox | BoundingBox.set(Vector3 minimum, Vector3 maximum) Sets the given minimum and maximum vector.

Methods in com.badlogic.gdx.math.collision with parameters of type BoundingBox
boolean | BoundingBox.contains(BoundingBox bounds) Returns wheter the given bounding box is contained in this bounding box.
BoundingBox | BoundingBox.ext(BoundingBox a_bounds) Extends this bounding box by the given bounding box.
BoundingBox | BoundingBox.set(BoundingBox bounds) Sets the given bounding box.

Constructors in com.badlogic.gdx.math.collision with parameters of type BoundingBox
BoundingBox(BoundingBox bounds)
Constructs a new bounding box from the given bounding box.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Box2DDebugRenderer (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class Box2DDebugRenderer

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Box2DDebugRenderer

public class Box2DDebugRenderer
extends java.lang.Object

Field Summary
SpriteBatch | batch a spritebatch and a font for text rendering
protected ImmediateModeRenderer | renderer the immediate mode renderer to output our debug drawings
Constructor Summary
Box2DDebugRenderer()
Method Summary
void | dispose()
void | render(World world) This assumes that the projection matrix has already been set.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

renderer

protected ImmediateModeRenderer renderer
the immediate mode renderer to output our debug drawings

batch

public SpriteBatch batch
a spritebatch and a font for text rendering

Constructor Detail

Box2DDebugRenderer

public Box2DDebugRenderer()
Method Detail

render

public void render(World world)
This assumes that the projection matrix has already been set.

dispose

public void dispose()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.Box2DDebugRenderer (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.Box2DDebugRenderer

No usage of com.badlogic.gdx.physics.box2d.Box2DDebugRenderer

Overview Package Class Use Tree Deprecated Index Help
libgdx API


BufferUtils (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class BufferUtils

java.lang.Object
    extended by  com.badlogic.gdx.utils.BufferUtils

public class BufferUtils
extends java.lang.Object

Class with static helper methods to increase the speed of array/direct buffer and direct buffer/direct buffer transfers

Author:
mzechner

Constructor Summary
BufferUtils()
Method Summary
static boolean | bitEqual(int value1, float value2)
static void | copy(float[] src, java.nio.Buffer dst, int numFloats, int offset) Copies numFloats floats from src starting at offset to dst.
static int | float2int(float value)
static float | int2float(int value)
static java.nio.ByteBuffer | newByteBuffer(int numBytes)
static java.nio.FloatBuffer | newFloatBuffer(int numFloats)
static java.nio.IntBuffer | newIntBuffer(int numInts)
static java.nio.ShortBuffer | newShortBuffer(int numShorts)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BufferUtils

public BufferUtils()
Method Detail

copy

public static void copy(float[] src,
                        java.nio.Buffer dst,
                        int numFloats,
                        int offset)
Copies numFloats floats from src starting at offset to dst. Dst is assumed to be a direct Buffer. The method will crash if that is not the case. The position and limit of the buffer are ignored, the copy is placed at position 0 in the buffer. After the copying process the position of the buffer is set to 0 and its limit is set to numFloats * 4 if it is a ByteBuffer and numFloats if it is a FloatBuffer. In case the Buffer is neither a ByteBuffer nor a FloatBuffer the limit is not set. This is an expert method, use at your own risk.

Parameters:
src - the source array
dst - the destination buffer, has to be a direct Buffer
numFloats - the number of floats to copy
offset - the offset in src to start copying from

int2float

public static float int2float(int value)

float2int

public static int float2int(float value)

bitEqual

public static boolean bitEqual(int value1,
                               float value2)

newFloatBuffer

public static java.nio.FloatBuffer newFloatBuffer(int numFloats)

newShortBuffer

public static java.nio.ShortBuffer newShortBuffer(int numShorts)

newIntBuffer

public static java.nio.IntBuffer newIntBuffer(int numInts)

newByteBuffer

public static java.nio.ByteBuffer newByteBuffer(int numBytes)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.BufferUtils (libgdx API)

Uses of Class
com.badlogic.gdx.utils.BufferUtils

No usage of com.badlogic.gdx.utils.BufferUtils

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Button (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actors
Class Button

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.Actor
        extended by  com.badlogic.gdx.scenes.scene2d.actors.Button

public class Button
extends Actor

A simple Button Actor, useful for simple UIs

Author:
mzechner

Nested Class Summary
static interface Button.ClickListener
Field Summary
Button.ClickListener | clickListener
protected boolean | pressed
TextureRegion | pressedRegion
TextureRegion | unpressedRegion
Fields inherited from class com.badlogic.gdx.scenes.scene2d.Actor
actions, color, height, name, originX, originY, parent, rotation, scaleX, scaleY, touchable, width, x, y
Constructor Summary
Button(java.lang.String name)
Creates a new Button instance with the given name.
Button(java.lang.String name, Texture texture)
Creates a new Button instance with the given name, using the complete supplied texture for displaying the pressed and unpressed state of the button.
Button(java.lang.String name, TextureRegion region)
Button(java.lang.String name, TextureRegion unpressedRegion, TextureRegion pressedRegion)
Method Summary
Actor | hit(float x, float y)
protected void | render(SpriteBatch batch) Renders the Actor.
protected boolean | touchDown(float x, float y, int pointer)
protected boolean | touchDragged(float x, float y, int pointer)
protected boolean | touchUp(float x, float y, int pointer)
Methods inherited from class com.badlogic.gdx.scenes.scene2d.Actor
act, action, clearActions, remove, toLocalCoordinates, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

pressedRegion

public final TextureRegion pressedRegion

unpressedRegion

public final TextureRegion unpressedRegion

clickListener

public Button.ClickListener clickListener

pressed

protected boolean pressed
Constructor Detail

Button

public Button(java.lang.String name)
Creates a new Button instance with the given name.

Parameters:
name - the name

Button

public Button(java.lang.String name,
              Texture texture)
Creates a new Button instance with the given name, using the complete supplied texture for displaying the pressed and unpressed state of the button.

Parameters:
name - the name
texture - the Texture

Button

public Button(java.lang.String name,
              TextureRegion region)

Button

public Button(java.lang.String name,
              TextureRegion unpressedRegion,
              TextureRegion pressedRegion)
Method Detail

render

protected void render(SpriteBatch batch)
Description copied from class: Actor
Renders the Actor. The spriteBatch is configured so that the Actor can render in its parents coordinate system.

Specified by:
render in class Actor
Parameters:
batch - the spritebatch to render with

touchDown

protected boolean touchDown(float x,
                            float y,
                            int pointer)
Specified by:
touchDown in class Actor

touchUp

protected boolean touchUp(float x,
                          float y,
                          int pointer)
Specified by:
touchUp in class Actor

touchDragged

protected boolean touchDragged(float x,
                               float y,
                               int pointer)
Specified by:
touchDragged in class Actor

hit

public Actor hit(float x,
                 float y)
Specified by:
hit in class Actor
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actors.Button (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actors.Button

Packages that use Button
com.badlogic.gdx.scenes.scene2d.actors

Uses of Button in com.badlogic.gdx.scenes.scene2d.actors

Methods in com.badlogic.gdx.scenes.scene2d.actors with parameters of type Button
 void Button.ClickListener.clicked(Button button)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Button.ClickListener (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actors
Interface Button.ClickListener

Enclosing class:
Button
public static interface Button.ClickListener

Method Summary
 void clicked(Button button)

Method Detail

clicked

void clicked(Button button)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.scenes.scene2d.actors.Button.ClickListener (libgdx API)

Uses of Interface
com.badlogic.gdx.scenes.scene2d.actors.Button.ClickListener

Packages that use Button.ClickListener
com.badlogic.gdx.scenes.scene2d.actors

Uses of Button.ClickListener in com.badlogic.gdx.scenes.scene2d.actors

Fields in com.badlogic.gdx.scenes.scene2d.actors declared as Button.ClickListener
 Button.ClickListener Button.clickListener

Overview Package Class Use Tree Deprecated Index Help
libgdx API


CatmullRomSpline (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class CatmullRomSpline

java.lang.Object
    extended by  com.badlogic.gdx.math.CatmullRomSpline

public final class CatmullRomSpline
extends java.lang.Object

Encapsulates a catmull rom spline with n control points, n >= 4. For more information on this type of spline see http://www.mvps.org/directx/articles/catmull/.

Author:
badlogicgames@gmail.com

Constructor Summary
CatmullRomSpline()
Method Summary
void | add(Vector3 point) Adds a new control point
java.util.List<Vector3> | getControlPoints()
java.util.List<Vector3> | getPath(int numPoints) Returns a path, between every two control points numPoints are generated and the control points themselves are added too.
java.util.List<Vector3> | getTangentNormals(int numPoints, java.util.List<Vector3> up)
java.util.List<Vector3> | getTangentNormals(int numPoints, Vector3 up) Returns the tangent's normals using the tangent and provided up vector doing a cross product.
java.util.List<Vector3> | getTangentNormals2D(int numPoints) Returns all tangent's normals in 2D space for the points in a path.
java.util.List<Vector3> | getTangents(int numPoints) Returns all tangents for the points in a path.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CatmullRomSpline

public CatmullRomSpline()
Method Detail

add

public void add(Vector3 point)
Adds a new control point

Parameters:
point - the point

getControlPoints

public java.util.List<Vector3> getControlPoints()
Returns:
all control points

getPath

public java.util.List<Vector3> getPath(int numPoints)
Returns a path, between every two control points numPoints are generated and the control points themselves are added too. The first and the last controlpoint are omitted. if there's less than 4 controlpoints an empty path is returned.

Parameters:
numPoints - number of points returned for a segment
Returns:
the path

getTangents

public java.util.List<Vector3> getTangents(int numPoints)
Returns all tangents for the points in a path. Same semantics as getPath.

Parameters:
numPoints - number of points returned for a segment
Returns:
the tangents of the points in the path

getTangentNormals2D

public java.util.List<Vector3> getTangentNormals2D(int numPoints)
Returns all tangent's normals in 2D space for the points in a path. The controlpoints have to lie in the x/y plane for this to work. Same semantics as getPath.

Parameters:
numPoints - number of points returned for a segment
Returns:
the tangents of the points in the path

getTangentNormals

public java.util.List<Vector3> getTangentNormals(int numPoints,
                                                 Vector3 up)
Returns the tangent's normals using the tangent and provided up vector doing a cross product.

Parameters:
numPoints - number of points per segment
up - up vector
Returns:
a list of tangent normals

getTangentNormals

public java.util.List<Vector3> getTangentNormals(int numPoints,
                                                 java.util.List<Vector3> up)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.CatmullRomSpline (libgdx API)

Uses of Class
com.badlogic.gdx.math.CatmullRomSpline

No usage of com.badlogic.gdx.math.CatmullRomSpline

Overview Package Class Use Tree Deprecated Index Help
libgdx API


CircleShape (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class CircleShape

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Shape
        extended by  com.badlogic.gdx.physics.box2d.CircleShape

public class CircleShape
extends Shape

A circle shape.

Author:
mzechner

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.Shape
Shape.Type
Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Shape
addr
Constructor Summary
 | CircleShape()
protected | CircleShape(long addr)
Method Summary
Vector2 | getPosition()
Shape.Type | getType() Get the type of this shape.
void | setPosition(Vector2 position) Sets the position of the shape
Methods inherited from class com.badlogic.gdx.physics.box2d.Shape
dispose, getRadius, jniGetType, setRadius
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CircleShape

public CircleShape()

CircleShape

protected CircleShape(long addr)
Method Detail

getType

public Shape.Type getType()
Get the type of this shape. You can use this to down cast to the concrete shape.

Specified by:
getType in class Shape
Returns:
the shape type.

getPosition

public Vector2 getPosition()

setPosition

public void setPosition(Vector2 position)
Sets the position of the shape

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.CircleShape (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.CircleShape

No usage of com.badlogic.gdx.physics.box2d.CircleShape

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Color (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class Color

java.lang.Object
    extended by  com.badlogic.gdx.graphics.Color

public class Color
extends java.lang.Object

A color class, holding the r, g, b and alpha component as floats in the range [0,1]. All methods perform clamping on the internal values after execution.

Author:
mzechner

Field Summary
float | a the red, green, blue and alpha components
float | b the red, green, blue and alpha components
static Color | BLACK
static Color | BLUE
float | g the red, green, blue and alpha components
static Color | GREEN
float | r the red, green, blue and alpha components
static Color | RED
static Color | WHITE
Constructor Summary
Color(Color color)
Constructs a new color using the given color
Color(float r, float g, float b, float a)
Constructor, sets the components of the color
Method Summary
Color | add(Color color) Adds the given color to this color.
void | clamp()
boolean | equals(java.lang.Object o)
int | hashCode()
Color | mul(Color color) Multiplies the this color and the given color
Color | mul(float value) Multiplies all components of this Color with the given value.
Color | set(Color color) Sets this color to the given color.
void | set(float r, float g, float b, float a)
Color | sub(Color color) Subtracts the given color from this color
float | toFloatBits() Packs the 4 components of this color into a 32-bit int and returns it as a float.
static float | toFloatBits(float r, float g, float b, float a) Packs the 4 components of this color into a 32-bit int and returns it as a float.
static float | toFloatBits(int r, int g, int b, int a) Packs the four color components which should be in the range 0-255 into a 32-bit integer and then converts it to a float.
int | toIntBits() Packs the 4 components of this color into a 32-bit int.
static float | toIntBits(int r, int g, int b, int a) Packs the four color components which should be in the range 0-255 into a 32-bit.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

WHITE

public static final Color WHITE

BLACK

public static final Color BLACK

RED

public static final Color RED

GREEN

public static final Color GREEN

BLUE

public static final Color BLUE

r

public float r
the red, green, blue and alpha components

g

public float g
the red, green, blue and alpha components

b

public float b
the red, green, blue and alpha components

a

public float a
the red, green, blue and alpha components

Constructor Detail

Color

public Color(float r,
             float g,
             float b,
             float a)
Constructor, sets the components of the color

Parameters:
r - the red component
g - the green component
b - the blue component
a - the alpha component

Color

public Color(Color color)
Constructs a new color using the given color

Parameters:
color - the color
Method Detail

set

public Color set(Color color)
Sets this color to the given color.

Parameters:
color - the Color

mul

public Color mul(Color color)
Multiplies the this color and the given color

Parameters:
color - the color
Returns:
this color.

mul

public Color mul(float value)
Multiplies all components of this Color with the given value.

Parameters:
value - the value
Returns:
this color

add

public Color add(Color color)
Adds the given color to this color.

Parameters:
color - the color
Returns:
this color

sub

public Color sub(Color color)
Subtracts the given color from this color

Parameters:
color - the color
Returns:
this color

clamp

public void clamp()

set

public void set(float r,
                float g,
                float b,
                float a)

equals

public boolean equals(java.lang.Object o)
Overrides:
equals in class java.lang.Object

hashCode

public int hashCode()
Overrides:
hashCode in class java.lang.Object

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

toFloatBits

public static float toFloatBits(int r,
                                int g,
                                int b,
                                int a)
Packs the four color components which should be in the range 0-255 into a 32-bit integer and then converts it to a float. Note that no range checking is performed for higher performance.

Parameters:
r - the red component, 0 - 255
g - the green component, 0 - 255
b - the blue component, 0 - 255
a - the alpha component, 0 - 255
Returns:
the packed color as a float

toIntBits

public static float toIntBits(int r,
                              int g,
                              int b,
                              int a)
Packs the four color components which should be in the range 0-255 into a 32-bit. Note that no range checking is performed for higher performance.

Parameters:
r - the red component, 0 - 255
g - the green component, 0 - 255
b - the blue component, 0 - 255
a - the alpha component, 0 - 255
Returns:
the packed color as a 32-bit int

toFloatBits

public float toFloatBits()
Packs the 4 components of this color into a 32-bit int and returns it as a float.

Returns:
the packed color as a 32-bit float

toIntBits

public int toIntBits()
Packs the 4 components of this color into a 32-bit int.

Returns:
the packed color as a 32-bit int.

toFloatBits

public static float toFloatBits(float r,
                                float g,
                                float b,
                                float a)
Packs the 4 components of this color into a 32-bit int and returns it as a float.

Returns:
the packed color as a 32-bit float
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.Color (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.Color

Packages that use Color
com.badlogic.gdx.graphics
com.badlogic.gdx.scenes.scene2d

Uses of Color in com.badlogic.gdx.graphics

Fields in com.badlogic.gdx.graphics declared as Color
static Color | Color.BLACK
static Color | Color.BLUE
static Color | Color.GREEN
static Color | Color.RED
static Color | Color.WHITE

Methods in com.badlogic.gdx.graphics that return Color
Color | Color.add(Color color) Adds the given color to this color.
Color | BitmapFont.getColor() Returns the color of this font.
Color | Sprite.getColor() Returns the color of this sprite.
Color | SpriteBatch.getColor()
Color | SpriteCache.getColor()
Color | Color.mul(Color color) Multiplies the this color and the given color
Color | Color.mul(float value) Multiplies all components of this Color with the given value.
Color | Color.set(Color color) Sets this color to the given color.
Color | Color.sub(Color color) Subtracts the given color from this color

Methods in com.badlogic.gdx.graphics with parameters of type Color
Color | Color.add(Color color) Adds the given color to this color.
Color | Color.mul(Color color) Multiplies the this color and the given color
Color | Color.set(Color color) Sets this color to the given color.
void | BitmapFont.setColor(Color tint)
void | BitmapFontCache.setColor(Color tint)
void | Sprite.setColor(Color tint)
void | SpriteBatch.setColor(Color tint) Sets the color used to tint images when they are added to the SpriteBatch.
void | SpriteCache.setColor(Color tint) Sets the color used to tint images when they are added to the SpriteCache.
Color | Color.sub(Color color) Subtracts the given color from this color

Constructors in com.badlogic.gdx.graphics with parameters of type Color
Color(Color color)
Constructs a new color using the given color

Uses of Color in com.badlogic.gdx.scenes.scene2d

Fields in com.badlogic.gdx.scenes.scene2d declared as Color
 Color Actor.color

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Constant Field Values (libgdx API)

Constant Field Values

Contents
  • com.badlogic.*
com.badlogic.*

com.badlogic.gdx.Input.Keys
public static final int | ANY_KEY | -1
public static final int | KEYCODE_0 | 7
public static final int | KEYCODE_1 | 8
public static final int | KEYCODE_2 | 9
public static final int | KEYCODE_3 | 10
public static final int | KEYCODE_4 | 11
public static final int | KEYCODE_5 | 12
public static final int | KEYCODE_6 | 13
public static final int | KEYCODE_7 | 14
public static final int | KEYCODE_8 | 15
public static final int | KEYCODE_9 | 16
public static final int | KEYCODE_A | 29
public static final int | KEYCODE_ALT_LEFT | 57
public static final int | KEYCODE_ALT_RIGHT | 58
public static final int | KEYCODE_APOSTROPHE | 75
public static final int | KEYCODE_AT | 77
public static final int | KEYCODE_B | 30
public static final int | KEYCODE_BACK | 4
public static final int | KEYCODE_BACKSLASH | 73
public static final int | KEYCODE_C | 31
public static final int | KEYCODE_CALL | 5
public static final int | KEYCODE_CAMERA | 27
public static final int | KEYCODE_CLEAR | 28
public static final int | KEYCODE_COMMA | 55
public static final int | KEYCODE_D | 32
public static final int | KEYCODE_DEL | 67
public static final int | KEYCODE_DPAD_CENTER | 23
public static final int | KEYCODE_DPAD_DOWN | 20
public static final int | KEYCODE_DPAD_LEFT | 21
public static final int | KEYCODE_DPAD_RIGHT | 22
public static final int | KEYCODE_DPAD_UP | 19
public static final int | KEYCODE_E | 33
public static final int | KEYCODE_ENDCALL | 6
public static final int | KEYCODE_ENTER | 66
public static final int | KEYCODE_ENVELOPE | 65
public static final int | KEYCODE_EQUALS | 70
public static final int | KEYCODE_EXPLORER | 64
public static final int | KEYCODE_F | 34
public static final int | KEYCODE_FOCUS | 80
public static final int | KEYCODE_G | 35
public static final int | KEYCODE_GRAVE | 68
public static final int | KEYCODE_H | 36
public static final int | KEYCODE_HEADSETHOOK | 79
public static final int | KEYCODE_HOME | 3
public static final int | KEYCODE_I | 37
public static final int | KEYCODE_J | 38
public static final int | KEYCODE_K | 39
public static final int | KEYCODE_L | 40
public static final int | KEYCODE_LEFT_BRACKET | 71
public static final int | KEYCODE_M | 41
public static final int | KEYCODE_MEDIA_FAST_FORWARD | 90
public static final int | KEYCODE_MEDIA_NEXT | 87
public static final int | KEYCODE_MEDIA_PLAY_PAUSE | 85
public static final int | KEYCODE_MEDIA_PREVIOUS | 88
public static final int | KEYCODE_MEDIA_REWIND | 89
public static final int | KEYCODE_MEDIA_STOP | 86
public static final int | KEYCODE_MENU | 82
public static final int | KEYCODE_MINUS | 69
public static final int | KEYCODE_MUTE | 91
public static final int | KEYCODE_N | 42
public static final int | KEYCODE_NOTIFICATION | 83
public static final int | KEYCODE_NUM | 78
public static final int | KEYCODE_O | 43
public static final int | KEYCODE_P | 44
public static final int | KEYCODE_PERIOD | 56
public static final int | KEYCODE_PLUS | 81
public static final int | KEYCODE_POUND | 18
public static final int | KEYCODE_POWER | 26
public static final int | KEYCODE_Q | 45
public static final int | KEYCODE_R | 46
public static final int | KEYCODE_RIGHT_BRACKET | 72
public static final int | KEYCODE_S | 47
public static final int | KEYCODE_SEARCH | 84
public static final int | KEYCODE_SEMICOLON | 74
public static final int | KEYCODE_SHIFT_LEFT | 59
public static final int | KEYCODE_SHIFT_RIGHT | 60
public static final int | KEYCODE_SLASH | 76
public static final int | KEYCODE_SOFT_LEFT | 1
public static final int | KEYCODE_SOFT_RIGHT | 2
public static final int | KEYCODE_SPACE | 62
public static final int | KEYCODE_STAR | 17
public static final int | KEYCODE_SYM | 63
public static final int | KEYCODE_T | 48
public static final int | KEYCODE_TAB | 61
public static final int | KEYCODE_U | 49
public static final int | KEYCODE_UNKNOWN | 0
public static final int | KEYCODE_V | 50
public static final int | KEYCODE_VOLUME_DOWN | 25
public static final int | KEYCODE_VOLUME_UP | 24
public static final int | KEYCODE_W | 51
public static final int | KEYCODE_X | 52
public static final int | KEYCODE_Y | 53
public static final int | KEYCODE_Z | 54
public static final int | META_ALT_LEFT_ON | 16
public static final int | META_ALT_ON | 2
public static final int | META_ALT_RIGHT_ON | 32
public static final int | META_SHIFT_LEFT_ON | 64
public static final int | META_SHIFT_ON | 1
public static final int | META_SHIFT_RIGHT_ON | 128
public static final int | META_SYM_ON | 4

com.badlogic.gdx.audio.analysis.FourierTransform
public static final int | HAMMING | 1
protected static final int | LINAVG | 2
protected static final int | LOGAVG | 3
protected static final int | NOAVG | 4
public static final int | NONE | 0
protected static final float | TWO_PI | 6.2831854820251465f

com.badlogic.gdx.graphics.GL10
public static final int | GL_ADD | 260
public static final int | GL_ALIASED_LINE_WIDTH_RANGE | 33902
public static final int | GL_ALIASED_POINT_SIZE_RANGE | 33901
public static final int | GL_ALPHA | 6406
public static final int | GL_ALPHA_BITS | 3413
public static final int | GL_ALPHA_TEST | 3008
public static final int | GL_ALWAYS | 519
public static final int | GL_AMBIENT | 4608
public static final int | GL_AMBIENT_AND_DIFFUSE | 5634
public static final int | GL_AND | 5377
public static final int | GL_AND_INVERTED | 5380
public static final int | GL_AND_REVERSE | 5378
public static final int | GL_BACK | 1029
public static final int | GL_BLEND | 3042
public static final int | GL_BLUE_BITS | 3412
public static final int | GL_BYTE | 5120
public static final int | GL_CCW | 2305
public static final int | GL_CLAMP_TO_EDGE | 33071
public static final int | GL_CLEAR | 5376
public static final int | GL_COLOR_ARRAY | 32886
public static final int | GL_COLOR_BUFFER_BIT | 16384
public static final int | GL_COLOR_LOGIC_OP | 3058
public static final int | GL_COLOR_MATERIAL | 2903
public static final int | GL_COMPRESSED_TEXTURE_FORMATS | 34467
public static final int | GL_CONSTANT_ATTENUATION | 4615
public static final int | GL_COPY | 5379
public static final int | GL_COPY_INVERTED | 5388
public static final int | GL_CULL_FACE | 2884
public static final int | GL_CW | 2304
public static final int | GL_DECAL | 8449
public static final int | GL_DECR | 7683
public static final int | GL_DEPTH_BITS | 3414
public static final int | GL_DEPTH_BUFFER_BIT | 256
public static final int | GL_DEPTH_TEST | 2929
public static final int | GL_DIFFUSE | 4609
public static final int | GL_DITHER | 3024
public static final int | GL_DONT_CARE | 4352
public static final int | GL_DST_ALPHA | 772
public static final int | GL_DST_COLOR | 774
public static final int | GL_EMISSION | 5632
public static final int | GL_EQUAL | 514
public static final int | GL_EQUIV | 5385
public static final int | GL_EXP | 2048
public static final int | GL_EXP2 | 2049
public static final int | GL_EXTENSIONS | 7939
public static final int | GL_FALSE | 0
public static final int | GL_FASTEST | 4353
public static final int | GL_FILL | 6914
public static final int | GL_FLAT | 7424
public static final int | GL_FLOAT | 5126
public static final int | GL_FOG | 2912
public static final int | GL_FOG_COLOR | 2918
public static final int | GL_FOG_DENSITY | 2914
public static final int | GL_FOG_END | 2916
public static final int | GL_FOG_HINT | 3156
public static final int | GL_FOG_MODE | 2917
public static final int | GL_FOG_START | 2915
public static final int | GL_FRONT | 1028
public static final int | GL_FRONT_AND_BACK | 1032
public static final int | GL_GEQUAL | 518
public static final int | GL_GREATER | 516
public static final int | GL_GREEN_BITS | 3411
public static final int | GL_IMPLEMENTATION_COLOR_READ_FORMAT_OES | 35739
public static final int | GL_IMPLEMENTATION_COLOR_READ_TYPE_OES | 35738
public static final int | GL_INCR | 7682
public static final int | GL_INVALID_ENUM | 1280
public static final int | GL_INVALID_OPERATION | 1282
public static final int | GL_INVALID_VALUE | 1281
public static final int | GL_INVERT | 5386
public static final int | GL_KEEP | 7680
public static final int | GL_LEQUAL | 515
public static final int | GL_LESS | 513
public static final int | GL_LIGHT_MODEL_AMBIENT | 2899
public static final int | GL_LIGHT_MODEL_TWO_SIDE | 2898
public static final int | GL_LIGHT0 | 16384
public static final int | GL_LIGHT1 | 16385
public static final int | GL_LIGHT2 | 16386
public static final int | GL_LIGHT3 | 16387
public static final int | GL_LIGHT4 | 16388
public static final int | GL_LIGHT5 | 16389
public static final int | GL_LIGHT6 | 16390
public static final int | GL_LIGHT7 | 16391
public static final int | GL_LIGHTING | 2896
public static final int | GL_LINE | 6913
public static final int | GL_LINE_LOOP | 2
public static final int | GL_LINE_SMOOTH | 2848
public static final int | GL_LINE_SMOOTH_HINT | 3154
public static final int | GL_LINE_STRIP | 3
public static final int | GL_LINEAR | 9729
public static final int | GL_LINEAR_ATTENUATION | 4616
public static final int | GL_LINEAR_MIPMAP_LINEAR | 9987
public static final int | GL_LINEAR_MIPMAP_NEAREST | 9985
public static final int | GL_LINES | 1
public static final int | GL_LUMINANCE | 6409
public static final int | GL_LUMINANCE_ALPHA | 6410
public static final int | GL_MAX_ELEMENTS_INDICES | 33001
public static final int | GL_MAX_ELEMENTS_VERTICES | 33000
public static final int | GL_MAX_LIGHTS | 3377
public static final int | GL_MAX_MODELVIEW_STACK_DEPTH | 3382
public static final int | GL_MAX_PROJECTION_STACK_DEPTH | 3384
public static final int | GL_MAX_TEXTURE_SIZE | 3379
public static final int | GL_MAX_TEXTURE_STACK_DEPTH | 3385
public static final int | GL_MAX_TEXTURE_UNITS | 34018
public static final int | GL_MAX_VIEWPORT_DIMS | 3386
public static final int | GL_MODELVIEW | 5888
public static final int | GL_MODULATE | 8448
public static final int | GL_MULTISAMPLE | 32925
public static final int | GL_NAND | 5390
public static final int | GL_NEAREST | 9728
public static final int | GL_NEAREST_MIPMAP_LINEAR | 9986
public static final int | GL_NEAREST_MIPMAP_NEAREST | 9984
public static final int | GL_NEVER | 512
public static final int | GL_NICEST | 4354
public static final int | GL_NO_ERROR | 0
public static final int | GL_NOOP | 5381
public static final int | GL_NOR | 5384
public static final int | GL_NORMAL_ARRAY | 32885
public static final int | GL_NORMALIZE | 2977
public static final int | GL_NOTEQUAL | 517
public static final int | GL_NUM_COMPRESSED_TEXTURE_FORMATS | 34466
public static final int | GL_OES_compressed_paletted_texture | 1
public static final int | GL_OES_read_format | 1
public static final int | GL_OES_VERSION_1_0 | 1
public static final int | GL_ONE | 1
public static final int | GL_ONE_MINUS_DST_ALPHA | 773
public static final int | GL_ONE_MINUS_DST_COLOR | 775
public static final int | GL_ONE_MINUS_SRC_ALPHA | 771
public static final int | GL_ONE_MINUS_SRC_COLOR | 769
public static final int | GL_OR | 5383
public static final int | GL_OR_INVERTED | 5389
public static final int | GL_OR_REVERSE | 5387
public static final int | GL_OUT_OF_MEMORY | 1285
public static final int | GL_PACK_ALIGNMENT | 3333
public static final int | GL_PALETTE4_R5_G6_B5_OES | 35730
public static final int | GL_PALETTE4_RGB5_A1_OES | 35732
public static final int | GL_PALETTE4_RGB8_OES | 35728
public static final int | GL_PALETTE4_RGBA4_OES | 35731
public static final int | GL_PALETTE4_RGBA8_OES | 35729
public static final int | GL_PALETTE8_R5_G6_B5_OES | 35735
public static final int | GL_PALETTE8_RGB5_A1_OES | 35737
public static final int | GL_PALETTE8_RGB8_OES | 35733
public static final int | GL_PALETTE8_RGBA4_OES | 35736
public static final int | GL_PALETTE8_RGBA8_OES | 35734
public static final int | GL_PERSPECTIVE_CORRECTION_HINT | 3152
public static final int | GL_POINT | 6912
public static final int | GL_POINT_SMOOTH | 2832
public static final int | GL_POINT_SMOOTH_HINT | 3153
public static final int | GL_POINTS | 0
public static final int | GL_POLYGON_OFFSET_FILL | 32823
public static final int | GL_POLYGON_SMOOTH_HINT | 3155
public static final int | GL_POSITION | 4611
public static final int | GL_PROJECTION | 5889
public static final int | GL_QUADRATIC_ATTENUATION | 4617
public static final int | GL_RED_BITS | 3410
public static final int | GL_RENDERER | 7937
public static final int | GL_REPEAT | 10497
public static final int | GL_REPLACE | 7681
public static final int | GL_RESCALE_NORMAL | 32826
public static final int | GL_RGB | 6407
public static final int | GL_RGBA | 6408
public static final int | GL_SAMPLE_ALPHA_TO_COVERAGE | 32926
public static final int | GL_SAMPLE_ALPHA_TO_ONE | 32927
public static final int | GL_SAMPLE_COVERAGE | 32928
public static final int | GL_SCISSOR_TEST | 3089
public static final int | GL_SET | 5391
public static final int | GL_SHININESS | 5633
public static final int | GL_SHORT | 5122
public static final int | GL_SMOOTH | 7425
public static final int | GL_SMOOTH_LINE_WIDTH_RANGE | 2850
public static final int | GL_SMOOTH_POINT_SIZE_RANGE | 2834
public static final int | GL_SPECULAR | 4610
public static final int | GL_SPOT_CUTOFF | 4614
public static final int | GL_SPOT_DIRECTION | 4612
public static final int | GL_SPOT_EXPONENT | 4613
public static final int | GL_SRC_ALPHA | 770
public static final int | GL_SRC_ALPHA_SATURATE | 776
public static final int | GL_SRC_COLOR | 768
public static final int | GL_STACK_OVERFLOW | 1283
public static final int | GL_STACK_UNDERFLOW | 1284
public static final int | GL_STENCIL_BITS | 3415
public static final int | GL_STENCIL_BUFFER_BIT | 1024
public static final int | GL_STENCIL_TEST | 2960
public static final int | GL_SUBPIXEL_BITS | 3408
public static final int | GL_TEXTURE | 5890
public static final int | GL_TEXTURE_2D | 3553
public static final int | GL_TEXTURE_COORD_ARRAY | 32888
public static final int | GL_TEXTURE_ENV | 8960
public static final int | GL_TEXTURE_ENV_COLOR | 8705
public static final int | GL_TEXTURE_ENV_MODE | 8704
public static final int | GL_TEXTURE_MAG_FILTER | 10240
public static final int | GL_TEXTURE_MIN_FILTER | 10241
public static final int | GL_TEXTURE_WRAP_S | 10242
public static final int | GL_TEXTURE_WRAP_T | 10243
public static final int | GL_TEXTURE0 | 33984
public static final int | GL_TEXTURE1 | 33985
public static final int | GL_TEXTURE10 | 33994
public static final int | GL_TEXTURE11 | 33995
public static final int | GL_TEXTURE12 | 33996
public static final int | GL_TEXTURE13 | 33997
public static final int | GL_TEXTURE14 | 33998
public static final int | GL_TEXTURE15 | 33999
public static final int | GL_TEXTURE16 | 34000
public static final int | GL_TEXTURE17 | 34001
public static final int | GL_TEXTURE18 | 34002
public static final int | GL_TEXTURE19 | 34003
public static final int | GL_TEXTURE2 | 33986
public static final int | GL_TEXTURE20 | 34004
public static final int | GL_TEXTURE21 | 34005
public static final int | GL_TEXTURE22 | 34006
public static final int | GL_TEXTURE23 | 34007
public static final int | GL_TEXTURE24 | 34008
public static final int | GL_TEXTURE25 | 34009
public static final int | GL_TEXTURE26 | 34010
public static final int | GL_TEXTURE27 | 34011
public static final int | GL_TEXTURE28 | 34012
public static final int | GL_TEXTURE29 | 34013
public static final int | GL_TEXTURE3 | 33987
public static final int | GL_TEXTURE30 | 34014
public static final int | GL_TEXTURE31 | 34015
public static final int | GL_TEXTURE4 | 33988
public static final int | GL_TEXTURE5 | 33989
public static final int | GL_TEXTURE6 | 33990
public static final int | GL_TEXTURE7 | 33991
public static final int | GL_TEXTURE8 | 33992
public static final int | GL_TEXTURE9 | 33993
public static final int | GL_TRIANGLE_FAN | 6
public static final int | GL_TRIANGLE_STRIP | 5
public static final int | GL_TRIANGLES | 4
public static final int | GL_TRUE | 1
public static final int | GL_UNPACK_ALIGNMENT | 3317
public static final int | GL_UNSIGNED_BYTE | 5121
public static final int | GL_UNSIGNED_SHORT | 5123
public static final int | GL_UNSIGNED_SHORT_4_4_4_4 | 32819
public static final int | GL_UNSIGNED_SHORT_5_5_5_1 | 32820
public static final int | GL_UNSIGNED_SHORT_5_6_5 | 33635
public static final int | GL_VENDOR | 7936
public static final int | GL_VERSION | 7938
public static final int | GL_VERTEX_ARRAY | 32884
public static final int | GL_XOR | 5382
public static final int | GL_ZERO | 0

com.badlogic.gdx.graphics.GL11
public static final int | GL_ACTIVE_TEXTURE | 34016
public static final int | GL_ADD_SIGNED | 34164
public static final int | GL_ALPHA_SCALE | 3356
public static final int | GL_ALPHA_TEST_FUNC | 3009
public static final int | GL_ALPHA_TEST_REF | 3010
public static final int | GL_ARRAY_BUFFER | 34962
public static final int | GL_ARRAY_BUFFER_BINDING | 34964
public static final int | GL_BLEND_DST | 3040
public static final int | GL_BLEND_SRC | 3041
public static final int | GL_BUFFER_SIZE | 34660
public static final int | GL_BUFFER_USAGE | 34661
public static final int | GL_CLIENT_ACTIVE_TEXTURE | 34017
public static final int | GL_CLIP_PLANE0 | 12288
public static final int | GL_CLIP_PLANE1 | 12289
public static final int | GL_CLIP_PLANE2 | 12290
public static final int | GL_CLIP_PLANE3 | 12291
public static final int | GL_CLIP_PLANE4 | 12292
public static final int | GL_CLIP_PLANE5 | 12293
public static final int | GL_COLOR_ARRAY_BUFFER_BINDING | 34968
public static final int | GL_COLOR_ARRAY_POINTER | 32912
public static final int | GL_COLOR_ARRAY_SIZE | 32897
public static final int | GL_COLOR_ARRAY_STRIDE | 32899
public static final int | GL_COLOR_ARRAY_TYPE | 32898
public static final int | GL_COLOR_CLEAR_VALUE | 3106
public static final int | GL_COLOR_WRITEMASK | 3107
public static final int | GL_COMBINE | 34160
public static final int | GL_COMBINE_ALPHA | 34162
public static final int | GL_COMBINE_RGB | 34161
public static final int | GL_CONSTANT | 34166
public static final int | GL_COORD_REPLACE_OES | 34914
public static final int | GL_CULL_FACE_MODE | 2885
public static final int | GL_CURRENT_COLOR | 2816
public static final int | GL_CURRENT_NORMAL | 2818
public static final int | GL_CURRENT_TEXTURE_COORDS | 2819
public static final int | GL_DEPTH_CLEAR_VALUE | 2931
public static final int | GL_DEPTH_FUNC | 2932
public static final int | GL_DEPTH_RANGE | 2928
public static final int | GL_DEPTH_WRITEMASK | 2930
public static final int | GL_DOT3_RGB | 34478
public static final int | GL_DOT3_RGBA | 34479
public static final int | GL_DYNAMIC_DRAW | 35048
public static final int | GL_ELEMENT_ARRAY_BUFFER | 34963
public static final int | GL_ELEMENT_ARRAY_BUFFER_BINDING | 34965
public static final int | GL_FRONT_FACE | 2886
public static final int | GL_GENERATE_MIPMAP | 33169
public static final int | GL_GENERATE_MIPMAP_HINT | 33170
public static final int | GL_INTERPOLATE | 34165
public static final int | GL_LINE_WIDTH | 2849
public static final int | GL_LOGIC_OP_MODE | 3056
public static final int | GL_MATRIX_MODE | 2976
public static final int | GL_MAX_CLIP_PLANES | 3378
public static final int | GL_MAX_ELEMENTS_INDICES | 33001
public static final int | GL_MAX_ELEMENTS_VERTICES | 33000
public static final int | GL_MODELVIEW_MATRIX | 2982
public static final int | GL_MODELVIEW_STACK_DEPTH | 2979
public static final int | GL_NORMAL_ARRAY_BUFFER_BINDING | 34967
public static final int | GL_NORMAL_ARRAY_POINTER | 32911
public static final int | GL_NORMAL_ARRAY_STRIDE | 32895
public static final int | GL_NORMAL_ARRAY_TYPE | 32894
public static final int | GL_OES_point_size_array | 1
public static final int | GL_OES_point_sprite | 1
public static final int | GL_OES_VERSION_1_0 | 1
public static final int | GL_OPERAND0_ALPHA | 34200
public static final int | GL_OPERAND0_RGB | 34192
public static final int | GL_OPERAND1_ALPHA | 34201
public static final int | GL_OPERAND1_RGB | 34193
public static final int | GL_OPERAND2_ALPHA | 34202
public static final int | GL_OPERAND2_RGB | 34194
public static final int | GL_POINT_DISTANCE_ATTENUATION | 33065
public static final int | GL_POINT_FADE_THRESHOLD_SIZE | 33064
public static final int | GL_POINT_SIZE | 2833
public static final int | GL_POINT_SIZE_ARRAY_BUFFER_BINDING_OES | 35743
public static final int | GL_POINT_SIZE_ARRAY_OES | 35740
public static final int | GL_POINT_SIZE_ARRAY_POINTER_OES | 35212
public static final int | GL_POINT_SIZE_ARRAY_STRIDE_OES | 35211
public static final int | GL_POINT_SIZE_ARRAY_TYPE_OES | 35210
public static final int | GL_POINT_SIZE_MAX | 33063
public static final int | GL_POINT_SIZE_MIN | 33062
public static final int | GL_POINT_SPRITE_OES | 34913
public static final int | GL_POLYGON_OFFSET_FACTOR | 32824
public static final int | GL_POLYGON_OFFSET_UNITS | 10752
public static final int | GL_POLYGON_SMOOTH_HINT | 3155
public static final int | GL_PREVIOUS | 34168
public static final int | GL_PRIMARY_COLOR | 34167
public static final int | GL_PROJECTION_MATRIX | 2983
public static final int | GL_PROJECTION_STACK_DEPTH | 2980
public static final int | GL_RGB_SCALE | 34163
public static final int | GL_SAMPLE_BUFFERS | 32936
public static final int | GL_SAMPLE_COVERAGE_INVERT | 32939
public static final int | GL_SAMPLE_COVERAGE_VALUE | 32938
public static final int | GL_SAMPLES | 32937
public static final int | GL_SCISSOR_BOX | 3088
public static final int | GL_SHADE_MODEL | 2900
public static final int | GL_SRC0_ALPHA | 34184
public static final int | GL_SRC0_RGB | 34176
public static final int | GL_SRC1_ALPHA | 34185
public static final int | GL_SRC1_RGB | 34177
public static final int | GL_SRC2_ALPHA | 34186
public static final int | GL_SRC2_RGB | 34178
public static final int | GL_STATIC_DRAW | 35044
public static final int | GL_STENCIL_CLEAR_VALUE | 2961
public static final int | GL_STENCIL_FAIL | 2964
public static final int | GL_STENCIL_FUNC | 2962
public static final int | GL_STENCIL_PASS_DEPTH_FAIL | 2965
public static final int | GL_STENCIL_PASS_DEPTH_PASS | 2966
public static final int | GL_STENCIL_REF | 2967
public static final int | GL_STENCIL_VALUE_MASK | 2963
public static final int | GL_STENCIL_WRITEMASK | 2968
public static final int | GL_SUBTRACT | 34023
public static final int | GL_TEXTURE_BINDING_2D | 32873
public static final int | GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING | 34970
public static final int | GL_TEXTURE_COORD_ARRAY_POINTER | 32914
public static final int | GL_TEXTURE_COORD_ARRAY_SIZE | 32904
public static final int | GL_TEXTURE_COORD_ARRAY_STRIDE | 32906
public static final int | GL_TEXTURE_COORD_ARRAY_TYPE | 32905
public static final int | GL_TEXTURE_MATRIX | 2984
public static final int | GL_TEXTURE_STACK_DEPTH | 2981
public static final int | GL_VERSION_ES_CL_1_0 | 1
public static final int | GL_VERSION_ES_CL_1_1 | 1
public static final int | GL_VERSION_ES_CM_1_0 | 1
public static final int | GL_VERSION_ES_CM_1_1 | 1
public static final int | GL_VERTEX_ARRAY_BUFFER_BINDING | 34966
public static final int | GL_VERTEX_ARRAY_POINTER | 32910
public static final int | GL_VERTEX_ARRAY_SIZE | 32890
public static final int | GL_VERTEX_ARRAY_STRIDE | 32892
public static final int | GL_VERTEX_ARRAY_TYPE | 32891
public static final int | GL_VIEWPORT | 2978

com.badlogic.gdx.graphics.GL20
public static final int | GL_ACTIVE_ATTRIBUTE_MAX_LENGTH | 35722
public static final int | GL_ACTIVE_ATTRIBUTES | 35721
public static final int | GL_ACTIVE_TEXTURE | 34016
public static final int | GL_ACTIVE_UNIFORM_MAX_LENGTH | 35719
public static final int | GL_ACTIVE_UNIFORMS | 35718
public static final int | GL_ALIASED_LINE_WIDTH_RANGE | 33902
public static final int | GL_ALIASED_POINT_SIZE_RANGE | 33901
public static final int | GL_ALPHA | 6406
public static final int | GL_ALPHA_BITS | 3413
public static final int | GL_ALWAYS | 519
public static final int | GL_ARRAY_BUFFER | 34962
public static final int | GL_ARRAY_BUFFER_BINDING | 34964
public static final int | GL_ATTACHED_SHADERS | 35717
public static final int | GL_BACK | 1029
public static final int | GL_BLEND | 3042
public static final int | GL_BLEND_COLOR | 32773
public static final int | GL_BLEND_DST_ALPHA | 32970
public static final int | GL_BLEND_DST_RGB | 32968
public static final int | GL_BLEND_EQUATION | 32777
public static final int | GL_BLEND_EQUATION_ALPHA | 34877
public static final int | GL_BLEND_EQUATION_RGB | 32777
public static final int | GL_BLEND_SRC_ALPHA | 32971
public static final int | GL_BLEND_SRC_RGB | 32969
public static final int | GL_BLUE_BITS | 3412
public static final int | GL_BOOL | 35670
public static final int | GL_BOOL_VEC2 | 35671
public static final int | GL_BOOL_VEC3 | 35672
public static final int | GL_BOOL_VEC4 | 35673
public static final int | GL_BUFFER_SIZE | 34660
public static final int | GL_BUFFER_USAGE | 34661
public static final int | GL_BYTE | 5120
public static final int | GL_CCW | 2305
public static final int | GL_CLAMP_TO_EDGE | 33071
public static final int | GL_COLOR_ATTACHMENT0 | 36064
public static final int | GL_COLOR_BUFFER_BIT | 16384
public static final int | GL_COLOR_CLEAR_VALUE | 3106
public static final int | GL_COLOR_WRITEMASK | 3107
public static final int | GL_COMPILE_STATUS | 35713
public static final int | GL_COMPRESSED_TEXTURE_FORMATS | 34467
public static final int | GL_CONSTANT_ALPHA | 32771
public static final int | GL_CONSTANT_COLOR | 32769
public static final int | GL_CULL_FACE | 2884
public static final int | GL_CULL_FACE_MODE | 2885
public static final int | GL_CURRENT_PROGRAM | 35725
public static final int | GL_CURRENT_VERTEX_ATTRIB | 34342
public static final int | GL_CW | 2304
public static final int | GL_DECR | 7683
public static final int | GL_DECR_WRAP | 34056
public static final int | GL_DELETE_STATUS | 35712
public static final int | GL_DEPTH_ATTACHMENT | 36096
public static final int | GL_DEPTH_BITS | 3414
public static final int | GL_DEPTH_BUFFER_BIT | 256
public static final int | GL_DEPTH_CLEAR_VALUE | 2931
public static final int | GL_DEPTH_COMPONENT | 6402
public static final int | GL_DEPTH_COMPONENT16 | 33189
public static final int | GL_DEPTH_FUNC | 2932
public static final int | GL_DEPTH_RANGE | 2928
public static final int | GL_DEPTH_TEST | 2929
public static final int | GL_DEPTH_WRITEMASK | 2930
public static final int | GL_DITHER | 3024
public static final int | GL_DONT_CARE | 4352
public static final int | GL_DST_ALPHA | 772
public static final int | GL_DST_COLOR | 774
public static final int | GL_DYNAMIC_DRAW | 35048
public static final int | GL_ELEMENT_ARRAY_BUFFER | 34963
public static final int | GL_ELEMENT_ARRAY_BUFFER_BINDING | 34965
public static final int | GL_EQUAL | 514
public static final int | GL_ES_VERSION_2_0 | 1
public static final int | GL_EXTENSIONS | 7939
public static final int | GL_FALSE | 0
public static final int | GL_FASTEST | 4353
public static final int | GL_FIXED | 5132
public static final int | GL_FLOAT | 5126
public static final int | GL_FLOAT_MAT2 | 35674
public static final int | GL_FLOAT_MAT3 | 35675
public static final int | GL_FLOAT_MAT4 | 35676
public static final int | GL_FLOAT_VEC2 | 35664
public static final int | GL_FLOAT_VEC3 | 35665
public static final int | GL_FLOAT_VEC4 | 35666
public static final int | GL_FRAGMENT_SHADER | 35632
public static final int | GL_FRAMEBUFFER | 36160
public static final int | GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME | 36049
public static final int | GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE | 36048
public static final int | GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE | 36051
public static final int | GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL | 36050
public static final int | GL_FRAMEBUFFER_BINDING | 36006
public static final int | GL_FRAMEBUFFER_COMPLETE | 36053
public static final int | GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT | 36054
public static final int | GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS | 36057
public static final int | GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT | 36055
public static final int | GL_FRAMEBUFFER_UNSUPPORTED | 36061
public static final int | GL_FRONT | 1028
public static final int | GL_FRONT_AND_BACK | 1032
public static final int | GL_FRONT_FACE | 2886
public static final int | GL_FUNC_ADD | 32774
public static final int | GL_FUNC_REVERSE_SUBTRACT | 32779
public static final int | GL_FUNC_SUBTRACT | 32778
public static final int | GL_GENERATE_MIPMAP_HINT | 33170
public static final int | GL_GEQUAL | 518
public static final int | GL_GREATER | 516
public static final int | GL_GREEN_BITS | 3411
public static final int | GL_HIGH_FLOAT | 36338
public static final int | GL_HIGH_INT | 36341
public static final int | GL_IMPLEMENTATION_COLOR_READ_FORMAT | 35739
public static final int | GL_IMPLEMENTATION_COLOR_READ_TYPE | 35738
public static final int | GL_INCR | 7682
public static final int | GL_INCR_WRAP | 34055
public static final int | GL_INFO_LOG_LENGTH | 35716
public static final int | GL_INT | 5124
public static final int | GL_INT_VEC2 | 35667
public static final int | GL_INT_VEC3 | 35668
public static final int | GL_INT_VEC4 | 35669
public static final int | GL_INVALID_ENUM | 1280
public static final int | GL_INVALID_FRAMEBUFFER_OPERATION | 1286
public static final int | GL_INVALID_OPERATION | 1282
public static final int | GL_INVALID_VALUE | 1281
public static final int | GL_INVERT | 5386
public static final int | GL_KEEP | 7680
public static final int | GL_LEQUAL | 515
public static final int | GL_LESS | 513
public static final int | GL_LINE_LOOP | 2
public static final int | GL_LINE_STRIP | 3
public static final int | GL_LINE_WIDTH | 2849
public static final int | GL_LINEAR | 9729
public static final int | GL_LINEAR_MIPMAP_LINEAR | 9987
public static final int | GL_LINEAR_MIPMAP_NEAREST | 9985
public static final int | GL_LINES | 1
public static final int | GL_LINK_STATUS | 35714
public static final int | GL_LOW_FLOAT | 36336
public static final int | GL_LOW_INT | 36339
public static final int | GL_LUMINANCE | 6409
public static final int | GL_LUMINANCE_ALPHA | 6410
public static final int | GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS | 35661
public static final int | GL_MAX_CUBE_MAP_TEXTURE_SIZE | 34076
public static final int | GL_MAX_FRAGMENT_UNIFORM_VECTORS | 36349
public static final int | GL_MAX_RENDERBUFFER_SIZE | 34024
public static final int | GL_MAX_TEXTURE_IMAGE_UNITS | 34930
public static final int | GL_MAX_TEXTURE_SIZE | 3379
public static final int | GL_MAX_VARYING_VECTORS | 36348
public static final int | GL_MAX_VERTEX_ATTRIBS | 34921
public static final int | GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS | 35660
public static final int | GL_MAX_VERTEX_UNIFORM_VECTORS | 36347
public static final int | GL_MAX_VIEWPORT_DIMS | 3386
public static final int | GL_MEDIUM_FLOAT | 36337
public static final int | GL_MEDIUM_INT | 36340
public static final int | GL_MIRRORED_REPEAT | 33648
public static final int | GL_NEAREST | 9728
public static final int | GL_NEAREST_MIPMAP_LINEAR | 9986
public static final int | GL_NEAREST_MIPMAP_NEAREST | 9984
public static final int | GL_NEVER | 512
public static final int | GL_NICEST | 4354
public static final int | GL_NO_ERROR | 0
public static final int | GL_NONE | 0
public static final int | GL_NOTEQUAL | 517
public static final int | GL_NUM_COMPRESSED_TEXTURE_FORMATS | 34466
public static final int | GL_NUM_SHADER_BINARY_FORMATS | 36345
public static final int | GL_ONE | 1
public static final int | GL_ONE_MINUS_CONSTANT_ALPHA | 32772
public static final int | GL_ONE_MINUS_CONSTANT_COLOR | 32770
public static final int | GL_ONE_MINUS_DST_ALPHA | 773
public static final int | GL_ONE_MINUS_DST_COLOR | 775
public static final int | GL_ONE_MINUS_SRC_ALPHA | 771
public static final int | GL_ONE_MINUS_SRC_COLOR | 769
public static final int | GL_OUT_OF_MEMORY | 1285
public static final int | GL_PACK_ALIGNMENT | 3333
public static final int | GL_POINTS | 0
public static final int | GL_POLYGON_OFFSET_FACTOR | 32824
public static final int | GL_POLYGON_OFFSET_FILL | 32823
public static final int | GL_POLYGON_OFFSET_UNITS | 10752
public static final int | GL_RED_BITS | 3410
public static final int | GL_RENDERBUFFER | 36161
public static final int | GL_RENDERBUFFER_ALPHA_SIZE | 36179
public static final int | GL_RENDERBUFFER_BINDING | 36007
public static final int | GL_RENDERBUFFER_BLUE_SIZE | 36178
public static final int | GL_RENDERBUFFER_DEPTH_SIZE | 36180
public static final int | GL_RENDERBUFFER_GREEN_SIZE | 36177
public static final int | GL_RENDERBUFFER_HEIGHT | 36163
public static final int | GL_RENDERBUFFER_INTERNAL_FORMAT | 36164
public static final int | GL_RENDERBUFFER_RED_SIZE | 36176
public static final int | GL_RENDERBUFFER_STENCIL_SIZE | 36181
public static final int | GL_RENDERBUFFER_WIDTH | 36162
public static final int | GL_RENDERER | 7937
public static final int | GL_REPEAT | 10497
public static final int | GL_REPLACE | 7681
public static final int | GL_RGB | 6407
public static final int | GL_RGB5_A1 | 32855
public static final int | GL_RGB565 | 36194
public static final int | GL_RGBA | 6408
public static final int | GL_RGBA4 | 32854
public static final int | GL_SAMPLE_ALPHA_TO_COVERAGE | 32926
public static final int | GL_SAMPLE_BUFFERS | 32936
public static final int | GL_SAMPLE_COVERAGE | 32928
public static final int | GL_SAMPLE_COVERAGE_INVERT | 32939
public static final int | GL_SAMPLE_COVERAGE_VALUE | 32938
public static final int | GL_SAMPLER_2D | 35678
public static final int | GL_SAMPLER_CUBE | 35680
public static final int | GL_SAMPLES | 32937
public static final int | GL_SCISSOR_BOX | 3088
public static final int | GL_SCISSOR_TEST | 3089
public static final int | GL_SHADER_BINARY_FORMATS | 36344
public static final int | GL_SHADER_COMPILER | 36346
public static final int | GL_SHADER_SOURCE_LENGTH | 35720
public static final int | GL_SHADER_TYPE | 35663
public static final int | GL_SHADING_LANGUAGE_VERSION | 35724
public static final int | GL_SHORT | 5122
public static final int | GL_SRC_ALPHA | 770
public static final int | GL_SRC_ALPHA_SATURATE | 776
public static final int | GL_SRC_COLOR | 768
public static final int | GL_STATIC_DRAW | 35044
public static final int | GL_STENCIL_ATTACHMENT | 36128
public static final int | GL_STENCIL_BACK_FAIL | 34817
public static final int | GL_STENCIL_BACK_FUNC | 34816
public static final int | GL_STENCIL_BACK_PASS_DEPTH_FAIL | 34818
public static final int | GL_STENCIL_BACK_PASS_DEPTH_PASS | 34819
public static final int | GL_STENCIL_BACK_REF | 36003
public static final int | GL_STENCIL_BACK_VALUE_MASK | 36004
public static final int | GL_STENCIL_BACK_WRITEMASK | 36005
public static final int | GL_STENCIL_BITS | 3415
public static final int | GL_STENCIL_BUFFER_BIT | 1024
public static final int | GL_STENCIL_CLEAR_VALUE | 2961
public static final int | GL_STENCIL_FAIL | 2964
public static final int | GL_STENCIL_FUNC | 2962
public static final int | GL_STENCIL_INDEX | 6401
public static final int | GL_STENCIL_INDEX8 | 36168
public static final int | GL_STENCIL_PASS_DEPTH_FAIL | 2965
public static final int | GL_STENCIL_PASS_DEPTH_PASS | 2966
public static final int | GL_STENCIL_REF | 2967
public static final int | GL_STENCIL_TEST | 2960
public static final int | GL_STENCIL_VALUE_MASK | 2963
public static final int | GL_STENCIL_WRITEMASK | 2968
public static final int | GL_STREAM_DRAW | 35040
public static final int | GL_SUBPIXEL_BITS | 3408
public static final int | GL_TEXTURE | 5890
public static final int | GL_TEXTURE_2D | 3553
public static final int | GL_TEXTURE_BINDING_2D | 32873
public static final int | GL_TEXTURE_BINDING_CUBE_MAP | 34068
public static final int | GL_TEXTURE_CUBE_MAP | 34067
public static final int | GL_TEXTURE_CUBE_MAP_NEGATIVE_X | 34070
public static final int | GL_TEXTURE_CUBE_MAP_NEGATIVE_Y | 34072
public static final int | GL_TEXTURE_CUBE_MAP_NEGATIVE_Z | 34074
public static final int | GL_TEXTURE_CUBE_MAP_POSITIVE_X | 34069
public static final int | GL_TEXTURE_CUBE_MAP_POSITIVE_Y | 34071
public static final int | GL_TEXTURE_CUBE_MAP_POSITIVE_Z | 34073
public static final int | GL_TEXTURE_MAG_FILTER | 10240
public static final int | GL_TEXTURE_MIN_FILTER | 10241
public static final int | GL_TEXTURE_WRAP_S | 10242
public static final int | GL_TEXTURE_WRAP_T | 10243
public static final int | GL_TEXTURE0 | 33984
public static final int | GL_TEXTURE1 | 33985
public static final int | GL_TEXTURE10 | 33994
public static final int | GL_TEXTURE11 | 33995
public static final int | GL_TEXTURE12 | 33996
public static final int | GL_TEXTURE13 | 33997
public static final int | GL_TEXTURE14 | 33998
public static final int | GL_TEXTURE15 | 33999
public static final int | GL_TEXTURE16 | 34000
public static final int | GL_TEXTURE17 | 34001
public static final int | GL_TEXTURE18 | 34002
public static final int | GL_TEXTURE19 | 34003
public static final int | GL_TEXTURE2 | 33986
public static final int | GL_TEXTURE20 | 34004
public static final int | GL_TEXTURE21 | 34005
public static final int | GL_TEXTURE22 | 34006
public static final int | GL_TEXTURE23 | 34007
public static final int | GL_TEXTURE24 | 34008
public static final int | GL_TEXTURE25 | 34009
public static final int | GL_TEXTURE26 | 34010
public static final int | GL_TEXTURE27 | 34011
public static final int | GL_TEXTURE28 | 34012
public static final int | GL_TEXTURE29 | 34013
public static final int | GL_TEXTURE3 | 33987
public static final int | GL_TEXTURE30 | 34014
public static final int | GL_TEXTURE31 | 34015
public static final int | GL_TEXTURE4 | 33988
public static final int | GL_TEXTURE5 | 33989
public static final int | GL_TEXTURE6 | 33990
public static final int | GL_TEXTURE7 | 33991
public static final int | GL_TEXTURE8 | 33992
public static final int | GL_TEXTURE9 | 33993
public static final int | GL_TRIANGLE_FAN | 6
public static final int | GL_TRIANGLE_STRIP | 5
public static final int | GL_TRIANGLES | 4
public static final int | GL_TRUE | 1
public static final int | GL_UNPACK_ALIGNMENT | 3317
public static final int | GL_UNSIGNED_BYTE | 5121
public static final int | GL_UNSIGNED_INT | 5125
public static final int | GL_UNSIGNED_SHORT | 5123
public static final int | GL_UNSIGNED_SHORT_4_4_4_4 | 32819
public static final int | GL_UNSIGNED_SHORT_5_5_5_1 | 32820
public static final int | GL_UNSIGNED_SHORT_5_6_5 | 33635
public static final int | GL_VALIDATE_STATUS | 35715
public static final int | GL_VENDOR | 7936
public static final int | GL_VERSION | 7938
public static final int | GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING | 34975
public static final int | GL_VERTEX_ATTRIB_ARRAY_ENABLED | 34338
public static final int | GL_VERTEX_ATTRIB_ARRAY_NORMALIZED | 34922
public static final int | GL_VERTEX_ATTRIB_ARRAY_POINTER | 34373
public static final int | GL_VERTEX_ATTRIB_ARRAY_SIZE | 34339
public static final int | GL_VERTEX_ATTRIB_ARRAY_STRIDE | 34340
public static final int | GL_VERTEX_ATTRIB_ARRAY_TYPE | 34341
public static final int | GL_VERTEX_SHADER | 35633
public static final int | GL_VIEWPORT | 2978
public static final int | GL_ZERO | 0

com.badlogic.gdx.graphics.VertexAttributes.Usage
public static final int | Color | 1
public static final int | ColorPacked | 5
public static final int | Generic | 4
public static final int | Normal | 2
public static final int | Position | 0
public static final int | TextureCoordinates | 3

com.badlogic.gdx.math.Matrix4
public static final int | M00 | 0
public static final int | M01 | 4
public static final int | M02 | 8
public static final int | M03 | 12
public static final int | M10 | 1
public static final int | M11 | 5
public static final int | M12 | 9
public static final int | M13 | 13
public static final int | M20 | 2
public static final int | M21 | 6
public static final int | M22 | 10
public static final int | M23 | 14
public static final int | M30 | 3
public static final int | M31 | 7
public static final int | M32 | 11
public static final int | M33 | 15

com.badlogic.gdx.physics.box2d.Transform
public static final int | COL1_X | 2
public static final int | COL1_Y | 3
public static final int | COL2_X | 4
public static final int | COL2_Y | 5
public static final int | POS_X | 0
public static final int | POS_Y | 1

com.badlogic.gdx.utils.MathUtils
public static final float | degreesToRadians | 0.01745329238474369f
public static final float | PI | 3.1415927410125732f
public static final float | radiansToDegrees | 57.2957763671875f

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Contact (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class Contact

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Contact

public class Contact
extends java.lang.Object

The class manages contact between two shapes. A contact exists for each overlapping AABB in the broad-phase (except if filtered). Therefore a contact object may exist that has no contact points.

Author:
mzechner

Field Summary
protected long | addr the address
protected World | world the world
protected WorldManifold | worldManifold the world manifold
Constructor Summary
protected Contact(World world, long addr)
Method Summary
Fixture | getFixtureA() Get the first fixture in this contact.
Fixture | getFixtureB() Get the second fixture in this contact.
WorldManifold | GetWorldManifold()
boolean | isEnabled() Has this contact been disabled?
boolean | isTouching()
void | setEnabled(boolean flag) Enable/disable this contact.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

addr

protected long addr
the address

world

protected World world
the world

worldManifold

protected final WorldManifold worldManifold
the world manifold

Constructor Detail

Contact

protected Contact(World world,
                  long addr)
Method Detail

GetWorldManifold

public WorldManifold GetWorldManifold()

isTouching

public boolean isTouching()

setEnabled

public void setEnabled(boolean flag)
Enable/disable this contact. This can be used inside the pre-solve contact listener. The contact is only disabled for the current time step (or sub-step in continuous collisions).

isEnabled

public boolean isEnabled()
Has this contact been disabled?

getFixtureA

public Fixture getFixtureA()
Get the first fixture in this contact.

getFixtureB

public Fixture getFixtureB()
Get the second fixture in this contact.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.Contact (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.Contact

Packages that use Contact
com.badlogic.gdx.physics.box2d

Uses of Contact in com.badlogic.gdx.physics.box2d

Methods in com.badlogic.gdx.physics.box2d that return types with arguments of type Contact
 java.util.List<Contact> World.getContactList()

Methods in com.badlogic.gdx.physics.box2d with parameters of type Contact
void | ContactListener.beginContact(Contact contact) Called when two fixtures begin to touch.
void | ContactListener.endContact(Contact contact) Called when two fixtures cease to touch.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ContactFilter (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Interface ContactFilter

public interface ContactFilter

Implement this class to provide collision filtering. In other words, you can implement this class if you want finer control over contact creation.

Author:
mzechner

Method Summary
 boolean shouldCollide(Fixture fixtureA, Fixture fixtureB)

Method Detail

shouldCollide

boolean shouldCollide(Fixture fixtureA,
                      Fixture fixtureB)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.physics.box2d.ContactFilter (libgdx API)

Uses of Interface
com.badlogic.gdx.physics.box2d.ContactFilter

Packages that use ContactFilter
com.badlogic.gdx.physics.box2d

Uses of ContactFilter in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as ContactFilter
protected  ContactFilter World.contactFilter
Contact filter

Methods in com.badlogic.gdx.physics.box2d with parameters of type ContactFilter
 void World.setContactFilter(ContactFilter filter)
Register a contact filter to provide specific control over collision.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ContactListener (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Interface ContactListener

public interface ContactListener

Method Summary
void | beginContact(Contact contact) Called when two fixtures begin to touch.
void | endContact(Contact contact) Called when two fixtures cease to touch.

Method Detail

beginContact

void beginContact(Contact contact)
Called when two fixtures begin to touch.

endContact

void endContact(Contact contact)
Called when two fixtures cease to touch.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.physics.box2d.ContactListener (libgdx API)

Uses of Interface
com.badlogic.gdx.physics.box2d.ContactListener

Packages that use ContactListener
com.badlogic.gdx.physics.box2d

Uses of ContactListener in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as ContactListener
protected  ContactListener World.contactListener
Contact listener

Methods in com.badlogic.gdx.physics.box2d with parameters of type ContactListener
 void World.setContactListener(ContactListener listener)
Register a contact event listener.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Decoder (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.io
Interface Decoder

All Known Implementing Classes:
Mpg123Decoder, VorbisDecoder
public interface Decoder

Interface for audio decoders that return successive amplitude frames. When a decoder is no longer used it has to be disposed.

Author:
badlogicgames@gmail.com

Method Summary
 void dispose()
Disposes the decoder and frees all associated resources
 float getLength()
 int getNumChannels()
 int getRate()
 int readSamples(java.nio.ShortBuffer samples)
Reads in samples.capacity() samples in 16-bit signed PCM format from the decoder.
 int skipSamples(int numSamples)
Skips numSamples samples.

Method Detail

readSamples

int readSamples(java.nio.ShortBuffer samples)
Reads in samples.capacity() samples in 16-bit signed PCM format from the decoder. Returns the actual number read in. If this number is smaller than the capacity of the buffer then the end of stream has been reached. The provided ShortBuffer must be a direct buffer.

Parameters:
samples - The number of read samples.

skipSamples

int skipSamples(int numSamples)
Skips numSamples samples. If the decoded file is in stereo the left and right channel samples are counted as 2 samples.

Parameters:
numSamples - the number of samples to skip
Returns:
the number of samples actually skipped. If this is < numSamples then the end of the file has been reached.

getNumChannels

int getNumChannels()
Returns:
the number of channels

getRate

int getRate()
Returns:
the sampling rate in herz, e.g. 44100

getLength

float getLength()
Returns:
the length of the file in seconds

dispose

void dispose()
Disposes the decoder and frees all associated resources

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.audio.io.Decoder (libgdx API)

Uses of Interface
com.badlogic.gdx.audio.io.Decoder

Packages that use Decoder
com.badlogic.gdx.audio.io

Uses of Decoder in com.badlogic.gdx.audio.io

Classes in com.badlogic.gdx.audio.io that implement Decoder
class | Mpg123Decoder A Decoder implementation that decodes MP3 files via libmpg123 natively.
class | VorbisDecoder A Decoder implementation that decodes OGG Vorbis files using tremor

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Delay (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class Delay

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.Delay
All Implemented Interfaces:
Action
public class Delay
extends java.lang.Object
implements Action

Field Summary
protected Action | action
protected float | duration
protected float | taken
Constructor Summary
Delay()
Method Summary
static Delay | $(Action action, float duration)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

taken

protected float taken

duration

protected float duration

action

protected Action action
Constructor Detail

Delay

public Delay()
Method Detail

$

public static Delay $(Action action,
                      float duration)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.Delay (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.Delay

Packages that use Delay
com.badlogic.gdx.scenes.scene2d.actions

Uses of Delay in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return Delay
static Delay Delay.$(Action action, float duration)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Deprecated List (libgdx API)

Deprecated API

Contents
Overview Package Class Use Tree Deprecated Index Help
libgdx API


DestructionListener (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Interface DestructionListener

public interface DestructionListener

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.physics.box2d.DestructionListener (libgdx API)

Uses of Interface
com.badlogic.gdx.physics.box2d.DestructionListener

Packages that use DestructionListener
com.badlogic.gdx.physics.box2d

Uses of DestructionListener in com.badlogic.gdx.physics.box2d

Methods in com.badlogic.gdx.physics.box2d with parameters of type DestructionListener
 void World.setDestructionListener(DestructionListener listener)
Register a destruction listener.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


DFT (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.analysis
Class DFT

java.lang.Object
    extended by  com.badlogic.gdx.audio.analysis.FourierTransform
        extended by  com.badlogic.gdx.audio.analysis.DFT

public class DFT
extends FourierTransform

DFT stands for Discrete Fourier Transform and is the most widely used Fourier Transform. You will never want to use this class due to the fact that it is a brute force implementation of the DFT and as such is quite slow. Use an FFT instead. This exists primarily as a way to ensure that other implementations of the DFT are working properly. This implementation expects an even timeSize and will throw and IllegalArgumentException if this is not the case.

Author:
Damien Di Fede
See Also:
FourierTransform, FFT, The Discrete Fourier Transform

Field Summary
Fields inherited from class com.badlogic.gdx.audio.analysis.FourierTransform
averages, avgPerOctave, bandWidth, HAMMING, imag, LINAVG, LOGAVG, NOAVG, NONE, octaves, real, sampleRate, spectrum, timeSize, TWO_PI, whichAverage, whichWindow
Constructor Summary
DFT(int timeSize, float sampleRate)
Constructs a DFT that expects audio buffers of length timeSize that have been recorded with a sample rate of sampleRate.
Method Summary
protected void | allocateArrays()
void | forward(float[] samples) Performs a forward transform on buffer.
void | inverse(float[] buffer) Performs an inverse transform of the frequency spectrum and places the result in buffer.
void | scaleBand(int i, float s) Not currently implemented.
void | setBand(int i, float a) Not currently implemented.
Methods inherited from class com.badlogic.gdx.audio.analysis.FourierTransform
avgSize, calcAvg, doWindow, fillSpectrum, forward, freqToIndex, getAverageCenterFrequency, getAvg, getBand, getBandWidth, getFreq, getImaginaryPart, getRealPart, getSpectrum, hamming, indexToFreq, inverse, linAverages, logAverages, noAverages, scaleFreq, setComplex, setFreq, specSize, timeSize, window
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DFT

public DFT(int timeSize,
           float sampleRate)
Constructs a DFT that expects audio buffers of length timeSize that have been recorded with a sample rate of sampleRate. Will throw an IllegalArgumentException if timeSize is not even.

Parameters:
timeSize - the length of the audio buffers you plan to analyze
sampleRate - the sample rate of the audio samples you plan to analyze
Method Detail

allocateArrays

protected void allocateArrays()
Specified by:
allocateArrays in class FourierTransform

scaleBand

public void scaleBand(int i,
                      float s)
Not currently implemented.

Specified by:
scaleBand in class FourierTransform
Parameters:
i - the frequency band to modify
s - the scaling factor

setBand

public void setBand(int i,
                    float a)
Not currently implemented.

Specified by:
setBand in class FourierTransform
Parameters:
i - the frequency band to modify
a - the new amplitude

forward

public void forward(float[] samples)
Description copied from class: FourierTransform
Performs a forward transform on buffer.

Specified by:
forward in class FourierTransform
Parameters:
samples - the buffer to analyze

inverse

public void inverse(float[] buffer)
Description copied from class: FourierTransform
Performs an inverse transform of the frequency spectrum and places the result in buffer.

Specified by:
inverse in class FourierTransform
Parameters:
buffer - the buffer to place the result of the inverse transform in
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.audio.analysis.DFT (libgdx API)

Uses of Class
com.badlogic.gdx.audio.analysis.DFT

No usage of com.badlogic.gdx.audio.analysis.DFT

Overview Package Class Use Tree Deprecated Index Help
libgdx API


DistanceJoint (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class DistanceJoint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
        extended by  com.badlogic.gdx.physics.box2d.joints.DistanceJoint

public class DistanceJoint
extends Joint

A distance joint constrains two points on two bodies to remain at a fixed distance from each other. You can view this as a massless, rigid rod.

Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Joint
addr, jointEdgeA, jointEdgeB
Constructor Summary
DistanceJoint(World world, long addr)
Method Summary
float | getDampingRatio() Set/get damping ratio.
float | getFrequency() Set/get frequency in Hz.
float | getLength() Set/get the natural length.
void | setDampingRatio(float ratio) Set/get damping ratio.
void | setFrequency(float hz) Set/get frequency in Hz.
void | setLength(float length) Set/get the natural length.
Methods inherited from class com.badlogic.gdx.physics.box2d.Joint
getAnchorA, getAnchorB, getBodyA, getBodyB, getReactionForce, getReactionTorque, getType, isActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DistanceJoint

public DistanceJoint(World world,
                     long addr)
Method Detail

setLength

public void setLength(float length)
Set/get the natural length. Manipulating the length can lead to non-physical behavior when the frequency is zero.

getLength

public float getLength()
Set/get the natural length. Manipulating the length can lead to non-physical behavior when the frequency is zero.

setFrequency

public void setFrequency(float hz)
Set/get frequency in Hz.

getFrequency

public float getFrequency()
Set/get frequency in Hz.

setDampingRatio

public void setDampingRatio(float ratio)
Set/get damping ratio.

getDampingRatio

public float getDampingRatio()
Set/get damping ratio.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.DistanceJoint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.DistanceJoint

No usage of com.badlogic.gdx.physics.box2d.joints.DistanceJoint

Overview Package Class Use Tree Deprecated Index Help
libgdx API


DistanceJointDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class DistanceJointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
        extended by  com.badlogic.gdx.physics.box2d.joints.DistanceJointDef

public class DistanceJointDef
extends JointDef

Distance joint definition. This requires defining an anchor point on both bodies and the non-zero length of the distance joint. The definition uses local anchor points so that the initial configuration can violate the constraint slightly. This helps when saving and loading a game.

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType
Field Summary
float | dampingRatio The damping ratio.
float | frequencyHz The mass-spring-damper frequency in Hertz.
float | length The natural length between the anchor points.
Vector2 | localAnchorA The local anchor point relative to body1's origin.
Vector2 | localAnchorB The local anchor point relative to body2's origin.
Fields inherited from class com.badlogic.gdx.physics.box2d.JointDef
bodyA, bodyB, collideConnected, type
Constructor Summary
DistanceJointDef()
Method Summary
 void initialize(Body bodyA, Body bodyB, Vector2 anchorA, Vector2 anchorB)
Initialize the bodies, anchors, and length using the world anchors.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

localAnchorA

public final Vector2 localAnchorA
The local anchor point relative to body1's origin.

localAnchorB

public final Vector2 localAnchorB
The local anchor point relative to body2's origin.

length

public float length
The natural length between the anchor points.

frequencyHz

public float frequencyHz
The mass-spring-damper frequency in Hertz.

dampingRatio

public float dampingRatio
The damping ratio. 0 = no damping, 1 = critical damping.

Constructor Detail

DistanceJointDef

public DistanceJointDef()
Method Detail

initialize

public void initialize(Body bodyA,
                       Body bodyB,
                       Vector2 anchorA,
                       Vector2 anchorB)
Initialize the bodies, anchors, and length using the world anchors.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.DistanceJointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.DistanceJointDef

No usage of com.badlogic.gdx.physics.box2d.joints.DistanceJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


EarCutTriangulator (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class EarCutTriangulator

java.lang.Object
    extended by  com.badlogic.gdx.math.EarCutTriangulator

public final class EarCutTriangulator
extends java.lang.Object

A simple implementation of the ear cutting algorithm to triangulate simple polygons without holes. For more information see http://cgm.cs.mcgill.ca/~godfried/teaching/cg-projects/97/Ian/algorithm2.html

Author:
badlogicgames@gmail.com

Constructor Summary
EarCutTriangulator()
Method Summary
boolean | polygonClockwise(java.util.List<Vector2> polygon)
java.util.List<Vector2> | triangulate(java.util.List<Vector2> polygon) Triangulates the list of points and returns an array of Vector3 triples that each form a single triangle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EarCutTriangulator

public EarCutTriangulator()
Method Detail

triangulate

public java.util.List<Vector2> triangulate(java.util.List<Vector2> polygon)
Triangulates the list of points and returns an array of Vector3 triples that each form a single triangle.

Parameters:
polygon - The polygon to triangulate
Returns:
The list of triangle vertices.

polygonClockwise

public boolean polygonClockwise(java.util.List<Vector2> polygon)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.EarCutTriangulator (libgdx API)

Uses of Class
com.badlogic.gdx.math.EarCutTriangulator

No usage of com.badlogic.gdx.math.EarCutTriangulator

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FadeIn (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class FadeIn

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.FadeIn
All Implemented Interfaces:
Action
public class FadeIn
extends java.lang.Object
implements Action

Field Summary
protected float | deltaAlpha
protected boolean | done
protected float | duration
protected float | invDuration
protected float | startAlpha
protected float | taken
protected Actor | target
Constructor Summary
FadeIn()
Method Summary
static FadeIn | $(float duration)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

startAlpha

protected float startAlpha

deltaAlpha

protected float deltaAlpha

duration

protected float duration

invDuration

protected float invDuration

taken

protected float taken

target

protected Actor target

done

protected boolean done
Constructor Detail

FadeIn

public FadeIn()
Method Detail

$

public static FadeIn $(float duration)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.FadeIn (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.FadeIn

Packages that use FadeIn
com.badlogic.gdx.scenes.scene2d.actions

Uses of FadeIn in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return FadeIn
static FadeIn FadeIn.$(float duration)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FadeOut (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class FadeOut

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.FadeOut
All Implemented Interfaces:
Action
public class FadeOut
extends java.lang.Object
implements Action

Field Summary
protected float | deltaAlpha
protected boolean | done
protected float | duration
protected float | invDuration
protected float | startAlpha
protected float | taken
protected Actor | target
Constructor Summary
FadeOut()
Method Summary
static FadeOut | $(float duration)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

startAlpha

protected float startAlpha

deltaAlpha

protected float deltaAlpha

duration

protected float duration

invDuration

protected float invDuration

taken

protected float taken

target

protected Actor target

done

protected boolean done
Constructor Detail

FadeOut

public FadeOut()
Method Detail

$

public static FadeOut $(float duration)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.FadeOut (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.FadeOut

Packages that use FadeOut
com.badlogic.gdx.scenes.scene2d.actions

Uses of FadeOut in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return FadeOut
static FadeOut FadeOut.$(float duration)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FadeTo (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class FadeTo

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.FadeTo
All Implemented Interfaces:
Action
public class FadeTo
extends java.lang.Object
implements Action

Field Summary
protected float | deltaAlpha
protected boolean | done
protected float | duration
protected float | invDuration
protected float | startAlpha
protected float | taken
protected Actor | target
protected float | toAlpha
Constructor Summary
FadeTo()
Method Summary
static FadeTo | $(float alpha, float duration)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

toAlpha

protected float toAlpha

startAlpha

protected float startAlpha

deltaAlpha

protected float deltaAlpha

duration

protected float duration

invDuration

protected float invDuration

taken

protected float taken

target

protected Actor target

done

protected boolean done
Constructor Detail

FadeTo

public FadeTo()
Method Detail

$

public static FadeTo $(float alpha,
                       float duration)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.FadeTo (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.FadeTo

Packages that use FadeTo
com.badlogic.gdx.scenes.scene2d.actions

Uses of FadeTo in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return FadeTo
static FadeTo FadeTo.$(float alpha, float duration)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FFT (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.analysis
Class FFT

java.lang.Object
    extended by  com.badlogic.gdx.audio.analysis.FourierTransform
        extended by  com.badlogic.gdx.audio.analysis.FFT

public class FFT
extends FourierTransform

FFT stands for Fast Fourier Transform. It is an efficient way to calculate the Complex Discrete Fourier Transform. There is not much to say about this class other than the fact that when you want to analyze the spectrum of an audio buffer you will almost always use this class. One restriction of this class is that the audio buffers you want to analyze must have a length that is a power of two. If you try to construct an FFT with a timeSize that is not a power of two, an IllegalArgumentException will be thrown.

Author:
Damien Di Fede
See Also:
FourierTransform, The Fast Fourier Transform

Field Summary
Fields inherited from class com.badlogic.gdx.audio.analysis.FourierTransform
averages, avgPerOctave, bandWidth, HAMMING, imag, LINAVG, LOGAVG, NOAVG, NONE, octaves, real, sampleRate, spectrum, timeSize, TWO_PI, whichAverage, whichWindow
Constructor Summary
FFT(int timeSize, float sampleRate)
Constructs an FFT that will accept sample buffers that are timeSize long and have been recorded with a sample rate of sampleRate.
Method Summary
protected void | allocateArrays()
void | forward(float[] buffer) Performs a forward transform on buffer.
void | forward(float[] buffReal, float[] buffImag) Performs a forward transform on the passed buffers.
void | inverse(float[] buffer) Performs an inverse transform of the frequency spectrum and places the result in buffer.
static void | main(java.lang.String[] argv)
void | scaleBand(int i, float s) Scales the amplitude of the ith frequency band by s.
void | setBand(int i, float a) Sets the amplitude of the ith frequency band to a.
Methods inherited from class com.badlogic.gdx.audio.analysis.FourierTransform
avgSize, calcAvg, doWindow, fillSpectrum, forward, freqToIndex, getAverageCenterFrequency, getAvg, getBand, getBandWidth, getFreq, getImaginaryPart, getRealPart, getSpectrum, hamming, indexToFreq, inverse, linAverages, logAverages, noAverages, scaleFreq, setComplex, setFreq, specSize, timeSize, window
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FFT

public FFT(int timeSize,
           float sampleRate)
Constructs an FFT that will accept sample buffers that are timeSize long and have been recorded with a sample rate of sampleRate. timeSize must be a power of two. This will throw an exception if it is not.

Parameters:
timeSize - the length of the sample buffers you will be analyzing
sampleRate - the sample rate of the audio you will be analyzing
Method Detail

allocateArrays

protected void allocateArrays()
Specified by:
allocateArrays in class FourierTransform

scaleBand

public void scaleBand(int i,
                      float s)
Description copied from class: FourierTransform
Scales the amplitude of the ith frequency band by s. You can use this to shape the spectrum before using inverse().

Specified by:
scaleBand in class FourierTransform
Parameters:
i - the frequency band to modify
s - the scaling factor

setBand

public void setBand(int i,
                    float a)
Description copied from class: FourierTransform
Sets the amplitude of the ith frequency band to a. You can use this to shape the spectrum before using inverse().

Specified by:
setBand in class FourierTransform
Parameters:
i - the frequency band to modify
a - the new amplitude

forward

public void forward(float[] buffer)
Description copied from class: FourierTransform
Performs a forward transform on buffer.

Specified by:
forward in class FourierTransform
Parameters:
buffer - the buffer to analyze

forward

public void forward(float[] buffReal,
                    float[] buffImag)
Performs a forward transform on the passed buffers.

Parameters:
buffReal - the real part of the time domain signal to transform
buffImag - the imaginary part of the time domain signal to transform

inverse

public void inverse(float[] buffer)
Description copied from class: FourierTransform
Performs an inverse transform of the frequency spectrum and places the result in buffer.

Specified by:
inverse in class FourierTransform
Parameters:
buffer - the buffer to place the result of the inverse transform in

main

public static void main(java.lang.String[] argv)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.audio.analysis.FFT (libgdx API)

Uses of Class
com.badlogic.gdx.audio.analysis.FFT

No usage of com.badlogic.gdx.audio.analysis.FFT

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FileHandle (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.files
Class FileHandle

java.lang.Object
    extended by  com.badlogic.gdx.files.FileHandle
Direct Known Subclasses:
FileHandleStream
public abstract class FileHandle
extends java.lang.Object

Represents a file or directory on the filesystem, classpath, Android SD card, or Android assets directory. FileHandles are created via a Files instance.

Author:
mzechner, Nathan Sweet

Field Summary
protected java.io.File | file
protected Files.FileType | type
Constructor Summary
protected | FileHandle()
protected | FileHandle(java.io.File file, Files.FileType type)
protected | FileHandle(java.lang.String fileName, Files.FileType type)
Method Summary
abstract FileHandle | child(java.lang.String name) Returns a handle to the child with the specified name.
void | copyTo(FileHandle dest) Copies this file to the specified file, overwriting the file if it already exists.
boolean | delete() Deletes this file or empty directory and returns success.
boolean | deleteDirectory() Deletes this file or directory and all children, recursively.
boolean | exists()
java.lang.String | extension()
boolean | isDirectory() Returns true if this file is a directory.
long | length() Returns the length in bytes of this file, or 0 if this file is a directory or does not exist.
FileHandle[] | list() Returns the paths to the children of this directory.
void | mkdirs()
void | moveTo(FileHandle dest) Moves this file to the specified file, overwriting the file if it already exists.
java.lang.String | name()
java.lang.String | nameWithoutExtension()
abstract FileHandle | parent()
java.lang.String | path()
java.io.InputStream | read() Returns a stream for reading this file.
java.lang.String | toString()
Files.FileType | type()
java.io.OutputStream | write(boolean append) Returns a stream for writing to this file.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

file

protected java.io.File file

type

protected Files.FileType type
Constructor Detail

FileHandle

protected FileHandle()

FileHandle

protected FileHandle(java.lang.String fileName,
                     Files.FileType type)

FileHandle

protected FileHandle(java.io.File file,
                     Files.FileType type)
Method Detail

path

public java.lang.String path()

name

public java.lang.String name()

extension

public java.lang.String extension()

nameWithoutExtension

public java.lang.String nameWithoutExtension()

type

public Files.FileType type()

read

public java.io.InputStream read()
Returns a stream for reading this file.

write

public java.io.OutputStream write(boolean append)
Returns a stream for writing to this file.

Parameters:
append - If false, this file will be overwritten if it exists, otherwise it will be appended.

list

public FileHandle[] list()
Returns the paths to the children of this directory. Returns an empty list if this file handle represents a file and not a directory.

isDirectory

public boolean isDirectory()
Returns true if this file is a directory. Always returns false for classpath files. On Android, an internal handle to an empty directory will return false.

child

public abstract FileHandle child(java.lang.String name)
Returns a handle to the child with the specified name.

parent

public abstract FileHandle parent()

mkdirs

public void mkdirs()

exists

public boolean exists()

delete

public boolean delete()
Deletes this file or empty directory and returns success. Will not delete a directory that has children.

deleteDirectory

public boolean deleteDirectory()
Deletes this file or directory and all children, recursively.

copyTo

public void copyTo(FileHandle dest)
Copies this file to the specified file, overwriting the file if it already exists.

moveTo

public void moveTo(FileHandle dest)
Moves this file to the specified file, overwriting the file if it already exists.

length

public long length()
Returns the length in bytes of this file, or 0 if this file is a directory or does not exist.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.files.FileHandle (libgdx API)

Uses of Class
com.badlogic.gdx.files.FileHandle

Packages that use FileHandle
com.badlogic.gdx
com.badlogic.gdx.files
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.particles

Uses of FileHandle in com.badlogic.gdx

Methods in com.badlogic.gdx that return FileHandle
FileHandle | Files.absolute(java.lang.String path) Convenience method that returns a Files.FileType.Absolute file handle.
FileHandle | Files.classpath(java.lang.String path) Convenience method that returns a Files.FileType.Classpath file handle.
FileHandle | Files.external(java.lang.String path) Convenience method that returns a Files.FileType.External file handle.
FileHandle | Files.getFileHandle(java.lang.String path, Files.FileType type) Returns a handle representing a file or directory.
FileHandle | Files.internal(java.lang.String path) Convenience method that returns a Files.FileType.Internal file handle.

Methods in com.badlogic.gdx with parameters of type FileHandle
Music | Audio.newMusic(FileHandle file) Creates a new Music instance which is used to play back a music stream from a file.
Pixmap | Graphics.newPixmap(FileHandle file) Creates a new Pixmap from the given file which is assumed to point to a bitmap in a readable format.
Sound | Audio.newSound(FileHandle fileHandle) Creates a new Sound which is used to play back audio effects such as gun shots or explosions.
Texture | Graphics.newTexture(FileHandle file, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture from the given FileHandle using the specified minification and magnification filter and texture wraps in u and v.

Uses of FileHandle in com.badlogic.gdx.files

Subclasses of FileHandle in com.badlogic.gdx.files
 class FileHandleStream
A FileHandle intended to be subclassed for the purpose of implemented FileHandleStream.read() and/or FileHandleStream.write(boolean).

Methods in com.badlogic.gdx.files that return FileHandle
abstract FileHandle | FileHandle.child(java.lang.String name) Returns a handle to the child with the specified name.
FileHandle | FileHandleStream.child(java.lang.String name)
FileHandle[] | FileHandle.list() Returns the paths to the children of this directory.
FileHandle[] | FileHandleStream.list()
abstract FileHandle | FileHandle.parent()
FileHandle | FileHandleStream.parent()

Methods in com.badlogic.gdx.files with parameters of type FileHandle
void | FileHandle.copyTo(FileHandle dest) Copies this file to the specified file, overwriting the file if it already exists.
void | FileHandleStream.copyTo(FileHandle dest)
void | FileHandle.moveTo(FileHandle dest) Moves this file to the specified file, overwriting the file if it already exists.
void | FileHandleStream.moveTo(FileHandle dest)

Uses of FileHandle in com.badlogic.gdx.graphics

Constructors in com.badlogic.gdx.graphics with parameters of type FileHandle
BitmapFont(FileHandle fontFile, boolean flip)
Creates a BitmapFont from a BMFont file.
BitmapFont(FileHandle fontFile, FileHandle imageFile, boolean flip)
Creates a BitmapFont from a BMFont file, using the specified image for glyphs.
BitmapFont(FileHandle fontFile, TextureRegion region, boolean flip)
Creates a BitmapFont with the glyphs relative to the specified region.
TextureAtlas(FileHandle imagesDir)
Loads a pack file named "pack" in the specified directory and also looks there for page images named in the pack file.
TextureAtlas(FileHandle imagesDir, boolean flip)
TextureAtlas(FileHandle packFile, FileHandle imagesDir)
TextureAtlas(FileHandle packFile, FileHandle imagesDir, boolean flip)

Uses of FileHandle in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles with parameters of type FileHandle
void | ParticleEffect.load(FileHandle effectFile, FileHandle imagesDir)
void | ParticleEffect.load(FileHandle effectFile, TextureAtlas atlas)
void | ParticleEffect.loadEmitterImages(FileHandle imagesDir)
void | ParticleEffect.loadEmitters(FileHandle effectFile)
protected Texture | ParticleEffect.loadTexture(FileHandle file)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FileHandleStream (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.files
Class FileHandleStream

java.lang.Object
    extended by  com.badlogic.gdx.files.FileHandle
        extended by  com.badlogic.gdx.files.FileHandleStream

public abstract class FileHandleStream
extends FileHandle

A FileHandle intended to be subclassed for the purpose of implemented read() and/or write(boolean). Methods that would manipulate the file instead throw UnsupportedOperationException.

Author:
Nathan Sweet

Field Summary
Fields inherited from class com.badlogic.gdx.files.FileHandle
file, type
Constructor Summary
FileHandleStream(java.lang.String path)
Method Summary
FileHandle | child(java.lang.String name) Returns a handle to the child with the specified name.
void | copyTo(FileHandle dest) Copies this file to the specified file, overwriting the file if it already exists.
boolean | delete() Deletes this file or empty directory and returns success.
boolean | deleteDirectory() Deletes this file or directory and all children, recursively.
boolean | exists()
boolean | isDirectory() Returns true if this file is a directory.
long | length() Returns the length in bytes of this file, or 0 if this file is a directory or does not exist.
FileHandle[] | list() Returns the paths to the children of this directory.
void | mkdirs()
void | moveTo(FileHandle dest) Moves this file to the specified file, overwriting the file if it already exists.
FileHandle | parent()
java.io.InputStream | read() Returns a stream for reading this file.
java.io.OutputStream | write(boolean overwrite) Returns a stream for writing to this file.
Methods inherited from class com.badlogic.gdx.files.FileHandle
extension, name, nameWithoutExtension, path, toString, type
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FileHandleStream

public FileHandleStream(java.lang.String path)
Method Detail

isDirectory

public boolean isDirectory()
Description copied from class: FileHandle
Returns true if this file is a directory. Always returns false for classpath files. On Android, an internal handle to an empty directory will return false.

Overrides:
isDirectory in class FileHandle

length

public long length()
Description copied from class: FileHandle
Returns the length in bytes of this file, or 0 if this file is a directory or does not exist.

Overrides:
length in class FileHandle

exists

public boolean exists()
Overrides:
exists in class FileHandle

child

public FileHandle child(java.lang.String name)
Description copied from class: FileHandle
Returns a handle to the child with the specified name.

Specified by:
child in class FileHandle

parent

public FileHandle parent()
Specified by:
parent in class FileHandle

read

public java.io.InputStream read()
Description copied from class: FileHandle
Returns a stream for reading this file.

Overrides:
read in class FileHandle

write

public java.io.OutputStream write(boolean overwrite)
Description copied from class: FileHandle
Returns a stream for writing to this file.

Overrides:
write in class FileHandle
Parameters:
overwrite - If false, this file will be overwritten if it exists, otherwise it will be appended.

list

public FileHandle[] list()
Description copied from class: FileHandle
Returns the paths to the children of this directory. Returns an empty list if this file handle represents a file and not a directory.

Overrides:
list in class FileHandle

mkdirs

public void mkdirs()
Overrides:
mkdirs in class FileHandle

delete

public boolean delete()
Description copied from class: FileHandle
Deletes this file or empty directory and returns success. Will not delete a directory that has children.

Overrides:
delete in class FileHandle

deleteDirectory

public boolean deleteDirectory()
Description copied from class: FileHandle
Deletes this file or directory and all children, recursively.

Overrides:
deleteDirectory in class FileHandle

copyTo

public void copyTo(FileHandle dest)
Description copied from class: FileHandle
Copies this file to the specified file, overwriting the file if it already exists.

Overrides:
copyTo in class FileHandle

moveTo

public void moveTo(FileHandle dest)
Description copied from class: FileHandle
Moves this file to the specified file, overwriting the file if it already exists.

Overrides:
moveTo in class FileHandle
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.files.FileHandleStream (libgdx API)

Uses of Class
com.badlogic.gdx.files.FileHandleStream

No usage of com.badlogic.gdx.files.FileHandleStream

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Files (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Interface Files

public interface Files

Provides standard access to the filesystem, classpath, Android SD card, and Android assets directory.

Author:
mzechner, Nathan Sweet

Nested Class Summary
static class Files.FileType
Indicates how to resolve a path to a file.
Method Summary
FileHandle | absolute(java.lang.String path) Convenience method that returns a Files.FileType.Absolute file handle.
FileHandle | classpath(java.lang.String path) Convenience method that returns a Files.FileType.Classpath file handle.
FileHandle | external(java.lang.String path) Convenience method that returns a Files.FileType.External file handle.
java.lang.String | getExternalStoragePath() Returns the external storage path directory.
FileHandle | getFileHandle(java.lang.String path, Files.FileType type) Returns a handle representing a file or directory.
FileHandle | internal(java.lang.String path) Convenience method that returns a Files.FileType.Internal file handle.
boolean | isExternalStorageAvailable() Returns true if the external storage is ready for file IO.

Method Detail

getFileHandle

FileHandle getFileHandle(java.lang.String path,
                         Files.FileType type)
Returns a handle representing a file or directory.

Parameters:
type - Determines how the path is resolved.
Throws:
GdxRuntimeException - if the type is classpath or internal and the file does not exist.
See Also:
Files.FileType

classpath

FileHandle classpath(java.lang.String path)
Convenience method that returns a Files.FileType.Classpath file handle.

internal

FileHandle internal(java.lang.String path)
Convenience method that returns a Files.FileType.Internal file handle.

external

FileHandle external(java.lang.String path)
Convenience method that returns a Files.FileType.External file handle.

absolute

FileHandle absolute(java.lang.String path)
Convenience method that returns a Files.FileType.Absolute file handle.

getExternalStoragePath

java.lang.String getExternalStoragePath()
Returns the external storage path directory. This is the SD card on Android and the home directory of the current user on the desktop.

isExternalStorageAvailable

boolean isExternalStorageAvailable()
Returns true if the external storage is ready for file IO. Eg, on Android, the SD card is not available when mounted for use with a PC.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.Files (libgdx API)

Uses of Interface
com.badlogic.gdx.Files

Packages that use Files
com.badlogic.gdx
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl

Uses of Files in com.badlogic.gdx

Fields in com.badlogic.gdx declared as Files
static Files Gdx.files

Methods in com.badlogic.gdx that return Files
 Files Application.getFiles()

Uses of Files in com.badlogic.gdx.backends.android

Methods in com.badlogic.gdx.backends.android that return Files
 Files AndroidApplication.getFiles()

Uses of Files in com.badlogic.gdx.backends.jogl

Methods in com.badlogic.gdx.backends.jogl that return Files
 Files JoglApplication.getFiles()

Uses of Files in com.badlogic.gdx.backends.lwjgl

Methods in com.badlogic.gdx.backends.lwjgl that return Files
Files | LwjglApplication.getFiles()
Files | LwjglCanvas.getFiles()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Files.FileType (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx
Enum Files.FileType

java.lang.Object
    extended by  java.lang.Enum<Files.FileType>
        extended by  com.badlogic.gdx.Files.FileType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Files.FileType>
Enclosing interface:
Files
public static enum Files.FileType
extends java.lang.Enum<Files.FileType>

Indicates how to resolve a path to a file.

Author:
mzechner, Nathan Sweet

Enum Constant Summary
Absolute
Path that is a fully qualified, absolute filesystem path.
Classpath
Path relative to the root of the classpath.
External
Path relative to the root of the SD card on Android and to the home directory of the current user on the desktop.
Internal
Path relative to the asset directory on Android and to the application's root directory on the desktop.
Method Summary
static Files.FileType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Files.FileType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

Classpath

public static final Files.FileType Classpath
Path relative to the root of the classpath. Classpath files are always readonly. Note that classpath files are not compatible with some functionality on Android, such as Audio.newSound(FileHandle) and Audio.newMusic(FileHandle).

Internal

public static final Files.FileType Internal
Path relative to the asset directory on Android and to the application's root directory on the desktop. On the desktop, if the file is not, the classpath is then checked. This enables files to be found when using JWS or applets. Internal files are always readonly.

External

public static final Files.FileType External
Path relative to the root of the SD card on Android and to the home directory of the current user on the desktop.

Absolute

public static final Files.FileType Absolute
Path that is a fully qualified, absolute filesystem path. To ensure portability across platforms use absolute files only when absolutely (heh) necessary.

Method Detail

values

public static Files.FileType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Files.FileType c : Files.FileType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Files.FileType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.Files.FileType (libgdx API)

Uses of Class
com.badlogic.gdx.Files.FileType

Packages that use Files.FileType
com.badlogic.gdx
com.badlogic.gdx.files
com.badlogic.gdx.twl

Uses of Files.FileType in com.badlogic.gdx

Methods in com.badlogic.gdx that return Files.FileType
static Files.FileType | Files.FileType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Files.FileType[] | Files.FileType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.badlogic.gdx with parameters of type Files.FileType
 FileHandle Files.getFileHandle(java.lang.String path, Files.FileType type)
Returns a handle representing a file or directory.

Uses of Files.FileType in com.badlogic.gdx.files

Fields in com.badlogic.gdx.files declared as Files.FileType
protected  Files.FileType FileHandle.type

Methods in com.badlogic.gdx.files that return Files.FileType
 Files.FileType FileHandle.type()

Constructors in com.badlogic.gdx.files with parameters of type Files.FileType
FileHandle(java.io.File file, Files.FileType type)
FileHandle(java.lang.String fileName, Files.FileType type)

Uses of Files.FileType in com.badlogic.gdx.twl

Methods in com.badlogic.gdx.twl with parameters of type Files.FileType
static java.net.URL TWL.getThemeURL(java.lang.String themeFile, Files.FileType fileType)
Returns a URL to a theme file, which can be used with ThemeManager to create a theme for GUI#applyTheme(ThemeManager).

Constructors in com.badlogic.gdx.twl with parameters of type Files.FileType
TWL(java.lang.String themeFile, Files.FileType fileType)
Creates a new TWL instance with the specified theme file.
TWL(java.lang.String themeFile, Files.FileType fileType, Widget widget)
Creates a new TWL instance with the specified theme file.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Filter (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class Filter

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Filter

public class Filter
extends java.lang.Object

This holds contact filtering data.

Author:
mzechner

Field Summary
short | categoryBits The collision category bits.
short | groupIndex Collision groups allow a certain group of objects to never collide (negative) or always collide (positive).
short | maskBits The collision mask bits.
Constructor Summary
Filter()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

categoryBits

public short categoryBits
The collision category bits. Normally you would just set one bit.

maskBits

public short maskBits
The collision mask bits. This states the categories that this shape would accept for collision.

groupIndex

public short groupIndex
Collision groups allow a certain group of objects to never collide (negative) or always collide (positive). Zero means no collision group. Non-zero group filtering always wins against the mask bits.

Constructor Detail

Filter

public Filter()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.Filter (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.Filter

Packages that use Filter
com.badlogic.gdx.physics.box2d

Uses of Filter in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as Filter
 Filter FixtureDef.filter
Contact filtering data.

Methods in com.badlogic.gdx.physics.box2d that return Filter
 Filter Fixture.getFilterData()

Methods in com.badlogic.gdx.physics.box2d with parameters of type Filter
 void Fixture.setFilterData(Filter filter)
Set the contact filtering data.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Fixture (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class Fixture

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Fixture

public class Fixture
extends java.lang.Object

Field Summary
protected long | addr the address of the fixture
protected Shape | shape the shape, initialized lazy
protected java.lang.Object | userData user specified data
Constructor Summary
protected Fixture(Body body, long addr)
Constructs a new fixture
Method Summary
Body | getBody() Get the parent body of this fixture.
float | getDensity() Get the density of this fixture.
Filter | getFilterData()
float | getFriction() Get the coefficient of friction.
float | getRestitution() Get the coefficient of restitution.
Shape | getShape() Returns the shape of this fixture
Shape.Type | getType() Get the type of the child shape.
java.lang.Object | getUserData()
boolean | isSensor() Is this fixture a sensor (non-solid)?
void | setDensity(float density) Set the density of this fixture.
void | setFilterData(Filter filter) Set the contact filtering data.
void | setFriction(float friction) Set the coefficient of friction.
void | setRestitution(float restitution) Set the coefficient of restitution.
void | setSensor(boolean sensor) Set if this fixture is a sensor.
void | setUserData(java.lang.Object userData) Sets custom user data.
boolean | testPoint(Vector2 p) Test a point for containment in this fixture.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

addr

protected final long addr
the address of the fixture

shape

protected Shape shape
the shape, initialized lazy

userData

protected java.lang.Object userData
user specified data

Constructor Detail

Fixture

protected Fixture(Body body,
                  long addr)
Constructs a new fixture

Parameters:
addr - the address of the fixture
Method Detail

getType

public Shape.Type getType()
Get the type of the child shape. You can use this to down cast to the concrete shape.

Returns:
the shape type.

getShape

public Shape getShape()
Returns the shape of this fixture

setSensor

public void setSensor(boolean sensor)
Set if this fixture is a sensor.

isSensor

public boolean isSensor()
Is this fixture a sensor (non-solid)?

Returns:
the true if the shape is a sensor.

setFilterData

public void setFilterData(Filter filter)
Set the contact filtering data. This will not update contacts until the next time step when either parent body is active and awake.

getFilterData

public Filter getFilterData()

getBody

public Body getBody()
Get the parent body of this fixture. This is NULL if the fixture is not attached.

testPoint

public boolean testPoint(Vector2 p)
Test a point for containment in this fixture.

Parameters:
p - a point in world coordinates.

setDensity

public void setDensity(float density)
Set the density of this fixture. This will _not_ automatically adjust the mass of the body. You must call b2Body::ResetMassData to update the body's mass.

getDensity

public float getDensity()
Get the density of this fixture.

getFriction

public float getFriction()
Get the coefficient of friction.

setFriction

public void setFriction(float friction)
Set the coefficient of friction.

getRestitution

public float getRestitution()
Get the coefficient of restitution.

setRestitution

public void setRestitution(float restitution)
Set the coefficient of restitution.

setUserData

public void setUserData(java.lang.Object userData)
Sets custom user data.

getUserData

public java.lang.Object getUserData()
Returns:
custom user data
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.Fixture (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.Fixture

Packages that use Fixture
com.badlogic.gdx.physics.box2d

Uses of Fixture in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d with type parameters of type Fixture
protected  LongHashMap<Fixture> World.fixtures
all known fixtures

Methods in com.badlogic.gdx.physics.box2d that return Fixture
Fixture | Body.createFixture(FixtureDef def) Creates a fixture and attach it to this body.
Fixture | Body.createFixture(Shape shape, float density) Creates a fixture from a shape and attach it to this body.
Fixture | Contact.getFixtureA() Get the first fixture in this contact.
Fixture | Contact.getFixtureB() Get the second fixture in this contact.

Methods in com.badlogic.gdx.physics.box2d that return types with arguments of type Fixture
 java.util.ArrayList<Fixture> Body.getFixtureList()
Get the list of all fixtures attached to this body.

Methods in com.badlogic.gdx.physics.box2d with parameters of type Fixture
void | Body.destroyFixture(Fixture fixture) Destroy a fixture.
boolean | QueryCallback.reportFixture(Fixture fixture) Called for each fixture found in the query AABB.
boolean | ContactFilter.shouldCollide(Fixture fixtureA, Fixture fixtureB)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FixtureDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class FixtureDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.FixtureDef

public class FixtureDef
extends java.lang.Object

A fixture definition is used to create a fixture. This class defines an abstract fixture definition. You can reuse fixture definitions safely.

Author:
mzechner

Field Summary
float | density The density, usually in kg/m^2.
Filter | filter Contact filtering data.
float | friction The friction coefficient, usually in the range [0,1].
boolean | isSensor A sensor shape collects contact information but never generates a collision response.
float | restitution The restitution (elasticity) usually in the range [0,1].
Shape | shape The shape, this must be set.
Constructor Summary
FixtureDef()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

shape

public Shape shape
The shape, this must be set. The shape will be cloned, so you can create the shape on the stack.

friction

public float friction
The friction coefficient, usually in the range [0,1].

restitution

public float restitution
The restitution (elasticity) usually in the range [0,1].

density

public float density
The density, usually in kg/m^2.

isSensor

public boolean isSensor
A sensor shape collects contact information but never generates a collision response.

filter

public final Filter filter
Contact filtering data.

Constructor Detail

FixtureDef

public FixtureDef()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.FixtureDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.FixtureDef

Packages that use FixtureDef
com.badlogic.gdx.physics.box2d

Uses of FixtureDef in com.badlogic.gdx.physics.box2d

Methods in com.badlogic.gdx.physics.box2d with parameters of type FixtureDef
 Fixture Body.createFixture(FixtureDef def)
Creates a fixture and attach it to this body.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FloatArray (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class FloatArray

java.lang.Object
    extended by  com.badlogic.gdx.utils.FloatArray

public class FloatArray
extends java.lang.Object

An ordered, resizable float array. Avoids the boxing that occurs with ArrayList.

Author:
Matthias Mann, Nathan Sweet

Field Summary
float[] | items
int | size
Constructor Summary
FloatArray()
FloatArray(FloatArray array)
FloatArray(FloatBag bag)
FloatArray(int capacity)
Method Summary
void | add(float value)
void | addAll(FloatArray array)
void | addAll(FloatBag bag)
void | clear()
boolean | contains(float value)
void | ensureCapacity(int additionalCapacity) Increases the size of the backing array to acommodate the specified number of additional items.
float | get(int index)
int | indexOf(float value)
void | insert(int index, float value)
float | pop() Removes and returns the last item.
float | pop(int index) Removes and returns the specified item.
void | removeIndex(int index)
boolean | removeValue(float value)
void | set(int index, float value)
void | shrink() Reduces the size of the backing array to the size of the actual items.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

items

public float[] items

size

public int size
Constructor Detail

FloatArray

public FloatArray()

FloatArray

public FloatArray(int capacity)

FloatArray

public FloatArray(FloatArray array)

FloatArray

public FloatArray(FloatBag bag)
Method Detail

add

public void add(float value)

addAll

public void addAll(FloatArray array)

addAll

public void addAll(FloatBag bag)

set

public void set(int index,
                float value)

insert

public void insert(int index,
                   float value)

get

public float get(int index)

contains

public boolean contains(float value)

indexOf

public int indexOf(float value)

removeValue

public boolean removeValue(float value)

removeIndex

public void removeIndex(int index)

pop

public float pop()
Removes and returns the last item.

pop

public float pop(int index)
Removes and returns the specified item.

clear

public void clear()

shrink

public void shrink()
Reduces the size of the backing array to the size of the actual items. This is useful to release memory when many items have been removed, or if it is known the more items will not be added.

ensureCapacity

public void ensureCapacity(int additionalCapacity)
Increases the size of the backing array to acommodate the specified number of additional items. Useful before adding many items to avoid multiple backing array resizes.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.FloatArray (libgdx API)

Uses of Class
com.badlogic.gdx.utils.FloatArray

Packages that use FloatArray
com.badlogic.gdx.utils

Uses of FloatArray in com.badlogic.gdx.utils

Methods in com.badlogic.gdx.utils with parameters of type FloatArray
void | FloatArray.addAll(FloatArray array)
void | FloatBag.addAll(FloatArray array)

Constructors in com.badlogic.gdx.utils with parameters of type FloatArray
FloatArray(FloatArray array)
FloatBag(FloatArray array)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FloatBag (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class FloatBag

java.lang.Object
    extended by  com.badlogic.gdx.utils.FloatBag

public class FloatBag
extends java.lang.Object

An unordered, resizable int array. Avoids the boxing that occurs with ArrayList. Avoids a memory copy when removing elements (the last element is moved to the removed element's position).

Author:
Riven, Nathan Sweet

Field Summary
float[] | items
int | size
Constructor Summary
FloatBag()
FloatBag(FloatArray array)
FloatBag(FloatBag bag)
FloatBag(int capacity)
Method Summary
void | add(float value)
void | addAll(FloatArray array)
void | addAll(FloatBag bag)
void | clear()
boolean | contains(float value)
void | ensureCapacity(int additionalCapacity) Increases the size of the backing array to acommodate the specified number of additional items.
float | get(int index)
int | indexOf(float value)
float | pop() Removes and returns the last item.
float | pop(int index) Removes and returns the specified item.
void | removeIndex(int index)
boolean | removeValue(float value)
void | shrink() Reduces the size of the backing array to the size of the actual items.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

items

public float[] items

size

public int size
Constructor Detail

FloatBag

public FloatBag()

FloatBag

public FloatBag(int capacity)

FloatBag

public FloatBag(FloatBag bag)

FloatBag

public FloatBag(FloatArray array)
Method Detail

add

public void add(float value)

addAll

public void addAll(FloatBag bag)

addAll

public void addAll(FloatArray array)

get

public float get(int index)

contains

public boolean contains(float value)

indexOf

public int indexOf(float value)

removeValue

public boolean removeValue(float value)

removeIndex

public void removeIndex(int index)

pop

public float pop()
Removes and returns the last item.

pop

public float pop(int index)
Removes and returns the specified item.

clear

public void clear()

shrink

public void shrink()
Reduces the size of the backing array to the size of the actual items. This is useful to release memory when many items have been removed, or if it is known the more items will not be added.

ensureCapacity

public void ensureCapacity(int additionalCapacity)
Increases the size of the backing array to acommodate the specified number of additional items. Useful before adding many items to avoid multiple backing array resizes.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.FloatBag (libgdx API)

Uses of Class
com.badlogic.gdx.utils.FloatBag

Packages that use FloatBag
com.badlogic.gdx.utils

Uses of FloatBag in com.badlogic.gdx.utils

Methods in com.badlogic.gdx.utils with parameters of type FloatBag
void | FloatArray.addAll(FloatBag bag)
void | FloatBag.addAll(FloatBag bag)

Constructors in com.badlogic.gdx.utils with parameters of type FloatBag
FloatArray(FloatBag bag)
FloatBag(FloatBag bag)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Forever (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class Forever

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.Forever
All Implemented Interfaces:
Action
public class Forever
extends java.lang.Object
implements Action

Field Summary
protected Action | action
protected Actor | target
Constructor Summary
Forever()
Method Summary
static Forever | $(Action action)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

action

protected Action action

target

protected Actor target
Constructor Detail

Forever

public Forever()
Method Detail

$

public static Forever $(Action action)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.Forever (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.Forever

Packages that use Forever
com.badlogic.gdx.scenes.scene2d.actions

Uses of Forever in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return Forever
static Forever Forever.$(Action action)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FourierTransform (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.analysis
Class FourierTransform

java.lang.Object
    extended by  com.badlogic.gdx.audio.analysis.FourierTransform
Direct Known Subclasses:
DFT, FFT
public abstract class FourierTransform
extends java.lang.Object

A Fourier Transform is an algorithm that transforms a signal in the time domain, such as a sample buffer, into a signal in the frequency domain, often called the spectrum. The spectrum does not represent individual frequencies, but actually represents frequency bands centered on particular frequencies. The center frequency of each band is usually expressed as a fraction of the sampling rate of the time domain signal and is equal to the index of the frequency band divided by the total number of bands. The total number of frequency bands is usually equal to the length of the time domain signal, but access is only provided to frequency bands with indices less than half the length, because they correspond to frequencies below the Nyquist frequency. In other words, given a signal of length N, there will be N/2 frequency bands in the spectrum.

As an example, if you construct a FourierTransform with a timeSize of 1024 and and a sampleRate of 44100 Hz, then the spectrum will contain values for frequencies below 22010 Hz, which is the Nyquist frequency (half the sample rate). If you ask for the value of band number 5, this will correspond to a frequency band centered on 5/1024 * 44100 = 0.0048828125 * 44100 = 215 Hz. The width of that frequency band is equal to 2/1024, expressed as a fraction of the total bandwidth of the spectrum. The total bandwith of the spectrum is equal to the Nyquist frequency, which in this case is 22100, so the bandwidth is equal to about 50 Hz. It is not necessary for you to remember all of these relationships, though it is good to be aware of them. The function getFreq() allows you to query the spectrum with a frequency in Hz and the function getBandWidth() will return the bandwidth in Hz of each frequency band in the spectrum.

Usage

A typical usage of a FourierTransform is to analyze a signal so that the frequency spectrum may be represented in some way, typically with vertical lines. You could do this in Processing with the following code, where audio is an AudioSource and fft is an FFT (one of the derived classes of FourierTransform).

 fft.forward(audio.left);
 for (int i = 0; i < fft.specSize(); i++) {
        // draw the line for frequency band i, scaling it by 4 so we can see it a bit better
        line(i, height, i, height - fft.getBand(i) * 4);
 }
Windowing

Windowing is the process of shaping the audio samples before transforming them to the frequency domain. If you call the window() function with an appropriate constant, such as FourierTransform.HAMMING, the sample buffers passed to the object for analysis will be shaped by the current window before being transformed. The result of using a window is to reduce the noise in the spectrum somewhat.

Averages

FourierTransform also has functions that allow you to request the creation of an average spectrum. An average spectrum is simply a spectrum with fewer bands than the full spectrum where each average band is the average of the amplitudes of some number of contiguous frequency bands in the full spectrum.

linAverages() allows you to specify the number of averages that you want and will group frequency bands into groups of equal number. So if you have a spectrum with 512 frequency bands and you ask for 64 averages, each average will span 8 bands of the full spectrum.

logAverages() will group frequency bands by octave and allows you to specify the size of the smallest octave to use (in Hz) and also how many bands to split each octave into. So you might ask for the smallest octave to be 60 Hz and to split each octave into two bands. The result is that the bandwidth of each average is different. One frequency is an octave above another when it's frequency is twice that of the lower frequency. So, 120 Hz is an octave above 60 Hz, 240 Hz is an octave above 120 Hz, and so on. When octaves are split, they are split based on Hz, so if you split the octave 60-120 Hz in half, you will get 60-90Hz and 90-120Hz. You can see how these bandwidths increase as your octave sizes grow. For instance, the last octave will always span sampleRate/4 - sampleRate/2, which in the case of audio sampled at 44100 Hz is 11025-22010 Hz. These logarithmically spaced averages are usually much more useful than the full spectrum or the linearly spaced averages because they map more directly to how humans perceive sound.

calcAvg() allows you to specify the frequency band you want an average calculated for. You might ask for 60-500Hz and this function will group together the bands from the full spectrum that fall into that range and average their amplitudes for you.

If you don't want any averages calculated, then you can call noAverages(). This will not impact your ability to use calcAvg(), it will merely prevent the object from calculating an average array every time you use forward().

Inverse Transform

FourierTransform also supports taking the inverse transform of a spectrum. This means that a frequency spectrum will be transformed into a time domain signal and placed in a provided sample buffer. The length of the time domain signal will be timeSize() long. The set and scale functions allow you the ability to shape the spectrum already stored in the object before taking the inverse transform. You might use these to filter frequencies in a spectrum or modify it in some other way.

Author:
Damien Di Fede
See Also:
The Discrete Fourier Transform

Field Summary
protected float[] | averages
protected int | avgPerOctave
protected float | bandWidth
static int | HAMMING A constant indicating a Hamming window should be used on sample buffers.
protected float[] | imag
protected static int | LINAVG
protected static int | LOGAVG
protected static int | NOAVG
static int | NONE A constant indicating no window should be used on sample buffers.
protected int | octaves
protected float[] | real
protected int | sampleRate
protected float[] | spectrum
protected int | timeSize
protected static float | TWO_PI
protected int | whichAverage
protected int | whichWindow
Method Summary
protected abstract void | allocateArrays()
int | avgSize() Returns the number of averages currently being calculated.
float | calcAvg(float lowFreq, float hiFreq) Calculate the average amplitude of the frequency band bounded by lowFreq and hiFreq, inclusive.
protected void | doWindow(float[] samples)
protected void | fillSpectrum()
abstract void | forward(float[] buffer) Performs a forward transform on buffer.
void | forward(float[] buffer, int startAt) Performs a forward transform on values in buffer.
int | freqToIndex(float freq) Returns the index of the frequency band that contains the requested frequency.
float | getAverageCenterFrequency(int i) Returns the center frequency of the ith average band.
float | getAvg(int i) Gets the value of the ith average.
float | getBand(int i) Returns the amplitude of the requested frequency band.
float | getBandWidth() Returns the width of each frequency band in the spectrum (in Hz).
float | getFreq(float freq) Gets the amplitude of the requested frequency in the spectrum.
float[] | getImaginaryPart()
float[] | getRealPart()
float[] | getSpectrum()
protected void | hamming(float[] samples)
float | indexToFreq(int i) Returns the middle frequency of the ith band.
abstract void | inverse(float[] buffer) Performs an inverse transform of the frequency spectrum and places the result in buffer.
void | inverse(float[] freqReal, float[] freqImag, float[] buffer) Performs an inverse transform of the frequency spectrum represented by freqReal and freqImag and places the result in buffer.
void | linAverages(int numAvg) Sets the number of averages used when computing the spectrum and spaces the averages in a linear manner.
void | logAverages(int minBandwidth, int bandsPerOctave) Sets the number of averages used when computing the spectrum based on the minimum bandwidth for an octave and the number of bands per octave.
void | noAverages() Sets the object to not compute averages.
abstract void | scaleBand(int i, float s) Scales the amplitude of the ith frequency band by s.
void | scaleFreq(float freq, float s) Scales the amplitude of the requested frequency by a.
abstract void | setBand(int i, float a) Sets the amplitude of the ith frequency band to a.
protected void | setComplex(float[] r, float[] i)
void | setFreq(float freq, float a) Sets the amplitude of the requested frequency in the spectrum to a.
int | specSize() Returns the size of the spectrum created by this transform.
int | timeSize() Returns the length of the time domain signal expected by this transform.
void | window(int which) Sets the window to use on the samples before taking the forward transform.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NONE

public static final int NONE
A constant indicating no window should be used on sample buffers.

See Also:
Constant Field Values

HAMMING

public static final int HAMMING
A constant indicating a Hamming window should be used on sample buffers.

See Also:
Constant Field Values

LINAVG

protected static final int LINAVG
See Also:
Constant Field Values

LOGAVG

protected static final int LOGAVG
See Also:
Constant Field Values

NOAVG

protected static final int NOAVG
See Also:
Constant Field Values

TWO_PI

protected static final float TWO_PI
See Also:
Constant Field Values

timeSize

protected int timeSize

sampleRate

protected int sampleRate

bandWidth

protected float bandWidth

whichWindow

protected int whichWindow

real

protected float[] real

imag

protected float[] imag

spectrum

protected float[] spectrum

averages

protected float[] averages

whichAverage

protected int whichAverage

octaves

protected int octaves

avgPerOctave

protected int avgPerOctave
Method Detail

allocateArrays

protected abstract void allocateArrays()

setComplex

protected void setComplex(float[] r,
                          float[] i)

fillSpectrum

protected void fillSpectrum()

noAverages

public void noAverages()
Sets the object to not compute averages.

linAverages

public void linAverages(int numAvg)
Sets the number of averages used when computing the spectrum and spaces the averages in a linear manner. In other words, each average band will be specSize() / numAvg bands wide.

Parameters:
numAvg - how many averages to compute

logAverages

public void logAverages(int minBandwidth,
                        int bandsPerOctave)
Sets the number of averages used when computing the spectrum based on the minimum bandwidth for an octave and the number of bands per octave. For example, with audio that has a sample rate of 44100 Hz, logAverages(11, 1) will result in 12 averages, each corresponding to an octave, the first spanning 0 to 11 Hz. To ensure that each octave band is a full octave, the number of octaves is computed by dividing the Nyquist frequency by two, and then the result of that by two, and so on. This means that the actual bandwidth of the lowest octave may not be exactly the value specified.

Parameters:
minBandwidth - the minimum bandwidth used for an octave
bandsPerOctave - how many bands to split each octave into

window

public void window(int which)
Sets the window to use on the samples before taking the forward transform. If an invalid window is asked for, an error will be reported and the current window will not be changed.

Parameters:
which - FourierTransform.HAMMING or FourierTransform.NONE

doWindow

protected void doWindow(float[] samples)

hamming

protected void hamming(float[] samples)

timeSize

public int timeSize()
Returns the length of the time domain signal expected by this transform.

Returns:
the length of the time domain signal expected by this transform

specSize

public int specSize()
Returns the size of the spectrum created by this transform. In other words, the number of frequency bands produced by this transform. This is typically equal to timeSize()/2 + 1, see above for an explanation.

Returns:
the size of the spectrum

getBand

public float getBand(int i)
Returns the amplitude of the requested frequency band.

Parameters:
i - the index of a frequency band
Returns:
the amplitude of the requested frequency band

getBandWidth

public float getBandWidth()
Returns the width of each frequency band in the spectrum (in Hz). It should be noted that the bandwidth of the first and last frequency bands is half as large as the value returned by this function.

Returns:
the width of each frequency band in Hz.

setBand

public abstract void setBand(int i,
                             float a)
Sets the amplitude of the ith frequency band to a. You can use this to shape the spectrum before using inverse().

Parameters:
i - the frequency band to modify
a - the new amplitude

scaleBand

public abstract void scaleBand(int i,
                               float s)
Scales the amplitude of the ith frequency band by s. You can use this to shape the spectrum before using inverse().

Parameters:
i - the frequency band to modify
s - the scaling factor

freqToIndex

public int freqToIndex(float freq)
Returns the index of the frequency band that contains the requested frequency.

Parameters:
freq - the frequency you want the index for (in Hz)
Returns:
the index of the frequency band that contains freq

indexToFreq

public float indexToFreq(int i)
Returns the middle frequency of the ith band.

Parameters:
i - the index of the band you want to middle frequency of

getAverageCenterFrequency

public float getAverageCenterFrequency(int i)
Returns the center frequency of the ith average band.

Parameters:
i - which average band you want the center frequency of.

getFreq

public float getFreq(float freq)
Gets the amplitude of the requested frequency in the spectrum.

Parameters:
freq - the frequency in Hz
Returns:
the amplitude of the frequency in the spectrum

setFreq

public void setFreq(float freq,
                    float a)
Sets the amplitude of the requested frequency in the spectrum to a.

Parameters:
freq - the frequency in Hz
a - the new amplitude

scaleFreq

public void scaleFreq(float freq,
                      float s)
Scales the amplitude of the requested frequency by a.

Parameters:
freq - the frequency in Hz
s - the scaling factor

avgSize

public int avgSize()
Returns the number of averages currently being calculated.

Returns:
the length of the averages array

getAvg

public float getAvg(int i)
Gets the value of the ith average.

Parameters:
i - the average you want the value of
Returns:
the value of the requested average band

calcAvg

public float calcAvg(float lowFreq,
                     float hiFreq)
Calculate the average amplitude of the frequency band bounded by lowFreq and hiFreq, inclusive.

Parameters:
lowFreq - the lower bound of the band
hiFreq - the upper bound of the band
Returns:
the average of all spectrum values within the bounds

forward

public abstract void forward(float[] buffer)
Performs a forward transform on buffer.

Parameters:
buffer - the buffer to analyze

forward

public void forward(float[] buffer,
                    int startAt)
Performs a forward transform on values in buffer.

Parameters:
buffer - the buffer of samples
startAt - the index to start at in the buffer. there must be at least timeSize() samples between the starting index and the end of the buffer. If there aren't, an error will be issued and the operation will not be performed.

inverse

public abstract void inverse(float[] buffer)
Performs an inverse transform of the frequency spectrum and places the result in buffer.

Parameters:
buffer - the buffer to place the result of the inverse transform in

inverse

public void inverse(float[] freqReal,
                    float[] freqImag,
                    float[] buffer)
Performs an inverse transform of the frequency spectrum represented by freqReal and freqImag and places the result in buffer.

Parameters:
freqReal - the real part of the frequency spectrum
freqImag - the imaginary part the frequency spectrum
buffer - the buffer to place the inverse transform in

getSpectrum

public float[] getSpectrum()
Returns:
the spectrum of the last FourierTransform.forward() call.

getRealPart

public float[] getRealPart()
Returns:
the real part of the last FourierTransform.forward() call.

getImaginaryPart

public float[] getImaginaryPart()
Returns:
the imaginary part of the last FourierTransform.forward() call.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.audio.analysis.FourierTransform (libgdx API)

Uses of Class
com.badlogic.gdx.audio.analysis.FourierTransform

Packages that use FourierTransform
com.badlogic.gdx.audio.analysis

Uses of FourierTransform in com.badlogic.gdx.audio.analysis

Subclasses of FourierTransform in com.badlogic.gdx.audio.analysis
class | DFT DFT stands for Discrete Fourier Transform and is the most widely used Fourier Transform.
class | FFT FFT stands for Fast Fourier Transform.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FrameBuffer (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.glutils
Class FrameBuffer

java.lang.Object
    extended by  com.badlogic.gdx.graphics.glutils.FrameBuffer

public class FrameBuffer
extends java.lang.Object

Encapsulates OpenGL ES 2.0 frame buffer objects. This is a simple helper class which should cover most FBO uses. It will automatically create a texture for the color attachment and a renderbuffer for the depth buffer. You can get a hold of the texture by getColorBufferTexture(). This class will only work with OpenGL ES 2.0.

FrameBuffers are managed. In case of an OpenGL context loss, which only happens on Android when a user switches to another application or receives an incoming call, the framebuffer will be automatically recreated.

A FrameBuffer must be disposed if it is no longer needed

Author:
mzechner

Constructor Summary
FrameBuffer(Pixmap.Format format, int width, int height, boolean hasDepth)
Creates a new FrameBuffer having the given dimensions and potentially a depth buffer attached.
Method Summary
void | begin() Makes the frame buffer current so everything gets drawn to it.
static void | clearAllFrameBuffers()
void | dispose() Releases all resources associated with the FrameBuffer.
void | end() Unbinds the framebuffer, all drawing will be performed to the normal framebuffer from here on.
Texture | getColorBufferTexture()
int | getHeight()
int | getWidth()
static void | invalidateAllFrameBuffers() Invalidates all frame buffers.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FrameBuffer

public FrameBuffer(Pixmap.Format format,
                   int width,
                   int height,
                   boolean hasDepth)
Creates a new FrameBuffer having the given dimensions and potentially a depth buffer attached.

Parameters:
format - the format of the color buffer
width - the width of the framebuffer in pixels
height - the height of the framebuffer in pixels
hasDepth - whether to attach a depth buffer
Throws:
GdxRuntimeException - in case the FraeBuffer could not be created
Method Detail

dispose

public void dispose()
Releases all resources associated with the FrameBuffer.

begin

public void begin()
Makes the frame buffer current so everything gets drawn to it.

end

public void end()
Unbinds the framebuffer, all drawing will be performed to the normal framebuffer from here on.

invalidateAllFrameBuffers

public static void invalidateAllFrameBuffers()
Invalidates all frame buffers. This can be used when the OpenGL context is lost to rebuild all managed frame buffers. This assumes that the texture attached to this buffer has already been rebuild! Use with care.

clearAllFrameBuffers

public static void clearAllFrameBuffers()

getColorBufferTexture

public Texture getColorBufferTexture()
Returns:
the color buffer texture

getHeight

public int getHeight()
Returns:
the height of the framebuffer in pixels

getWidth

public int getWidth()
Returns:
the width of the framebuffer in pixels
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.glutils.FrameBuffer (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.glutils.FrameBuffer

No usage of com.badlogic.gdx.graphics.glutils.FrameBuffer

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FrictionJoint (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class FrictionJoint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
        extended by  com.badlogic.gdx.physics.box2d.joints.FrictionJoint

public class FrictionJoint
extends Joint

Friction joint. This is used for top-down friction. It provides 2D translational friction and angular friction.

Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Joint
addr, jointEdgeA, jointEdgeB
Constructor Summary
FrictionJoint(World world, long addr)
Method Summary
float | getMaxForce() Get the maximum friction force in N.
float | getMaxTorque() Get the maximum friction torque in N*m.
void | setMaxForce(float force) Set the maximum friction force in N.
void | setMaxTorque(float torque) Set the maximum friction torque in N*m.
Methods inherited from class com.badlogic.gdx.physics.box2d.Joint
getAnchorA, getAnchorB, getBodyA, getBodyB, getReactionForce, getReactionTorque, getType, isActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FrictionJoint

public FrictionJoint(World world,
                     long addr)
Method Detail

setMaxForce

public void setMaxForce(float force)
Set the maximum friction force in N.

getMaxForce

public float getMaxForce()
Get the maximum friction force in N.

setMaxTorque

public void setMaxTorque(float torque)
Set the maximum friction torque in N*m.

getMaxTorque

public float getMaxTorque()
Get the maximum friction torque in N*m.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.FrictionJoint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.FrictionJoint

No usage of com.badlogic.gdx.physics.box2d.joints.FrictionJoint

Overview Package Class Use Tree Deprecated Index Help
libgdx API


FrictionJointDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class FrictionJointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
        extended by  com.badlogic.gdx.physics.box2d.joints.FrictionJointDef

public class FrictionJointDef
extends JointDef

Friction joint definition.

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType
Field Summary
Vector2 | localAnchorA The local anchor point relative to bodyA's origin.
Vector2 | localAnchorB The local anchor point relative to bodyB's origin.
float | maxForce The maximum friction force in N.
float | maxTorque The maximum friction torque in N-m.
Fields inherited from class com.badlogic.gdx.physics.box2d.JointDef
bodyA, bodyB, collideConnected, type
Constructor Summary
FrictionJointDef()
Method Summary
 void initialize(Body bodyA, Body bodyB, Vector2 anchor)
Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

localAnchorA

public final Vector2 localAnchorA
The local anchor point relative to bodyA's origin.

localAnchorB

public final Vector2 localAnchorB
The local anchor point relative to bodyB's origin.

maxForce

public float maxForce
The maximum friction force in N.

maxTorque

public float maxTorque
The maximum friction torque in N-m.

Constructor Detail

FrictionJointDef

public FrictionJointDef()
Method Detail

initialize

public void initialize(Body bodyA,
                       Body bodyB,
                       Vector2 anchor)
Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.FrictionJointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.FrictionJointDef

No usage of com.badlogic.gdx.physics.box2d.joints.FrictionJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Frustum (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class Frustum

java.lang.Object
    extended by  com.badlogic.gdx.math.Frustum

public final class Frustum
extends java.lang.Object

Encapsulates a view frustum based on clipping planes. Offers methods to perform culling of simple geometric objects like points, spheres and BoundingBoxes.

Author:
badlogicgames@gmail.com

Field Summary
protected float | aspect
protected float | far
protected float | far_height
protected float | far_width
protected float | fov
protected float | near
protected float | near_height
protected float | near_width
protected java.util.List<Plane> | planes
protected float | tang
Constructor Summary
Frustum()
Method Summary
void | addPlane(Plane plane) Adds a new Plane to the frustum
boolean | boundsInFrustum(BoundingBox bounds) Returns wheter the given BoundingBox is in the frustum.
Ray | calculatePickRay(float screen_width, float screen_height, float mouse_x, float mouse_y, Vector3 pos, Vector3 dir, Vector3 up) Calculates the pick ray for the given window coordinates.
java.util.List<Plane> | getPlanes()
boolean | pointInFrustum(Vector3 point) Returns wheter the point is in the frustum.
void | setCameraOrientation(Vector3 pos, Vector3 dir, Vector3 up) Sets the camera orientation.
void | setCameraParameters(float fov, float aspect, float near, float far) Sets the camera parameters.
boolean | sphereInFrustum(Vector3 center, float radius) Returns wheter the given sphere is in the frustum.
boolean | sphereInFrustumWithoutNearFar(Vector3 center, float radius) Returns wheter the given sphere is in the frustum not checking wheter it is behind the near and far clipping plane.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

planes

protected java.util.List<Plane> planes

near

protected float near

far

protected float far

fov

protected float fov

aspect

protected float aspect

near_width

protected float near_width

near_height

protected float near_height

far_width

protected float far_width

far_height

protected float far_height

tang

protected float tang
Constructor Detail

Frustum

public Frustum()
Method Detail

getPlanes

public java.util.List<Plane> getPlanes()
Returns:
The list of Planes that make up this frustum.

addPlane

public void addPlane(Plane plane)
Adds a new Plane to the frustum

Parameters:
plane - The plane to add

setCameraParameters

public void setCameraParameters(float fov,
                                float aspect,
                                float near,
                                float far)
Sets the camera parameters.

Parameters:
fov - The field of view in degrees
aspect - The aspect ratio
near - The near plane
far - The far plane

setCameraOrientation

public void setCameraOrientation(Vector3 pos,
                                 Vector3 dir,
                                 Vector3 up)
Sets the camera orientation. This will add 6 planes for near, far, left, right, top and bottom of the frustum. Call setCameraParameters(float, float, float, float) before calling this function.

Parameters:
pos - The camera position
dir - The camera direction with unit length
up - The camera up vector with unit length

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

pointInFrustum

public boolean pointInFrustum(Vector3 point)
Returns wheter the point is in the frustum.

Parameters:
point - The point
Returns:
Wheter the point is in the frustum.

sphereInFrustum

public boolean sphereInFrustum(Vector3 center,
                               float radius)
Returns wheter the given sphere is in the frustum.

Parameters:
center - The center of the sphere
radius - The radius of the sphere
Returns:
Wheter the sphere is in the frustum

sphereInFrustumWithoutNearFar

public boolean sphereInFrustumWithoutNearFar(Vector3 center,
                                             float radius)
Returns wheter the given sphere is in the frustum not checking wheter it is behind the near and far clipping plane.

Parameters:
center - The center of the sphere
radius - The radius of the sphere
Returns:
Wheter the sphere is in the frustum

boundsInFrustum

public boolean boundsInFrustum(BoundingBox bounds)
Returns wheter the given BoundingBox is in the frustum.

Parameters:
bounds - The bounding box
Returns:
Wheter the bounding box is in the frustum

calculatePickRay

public Ray calculatePickRay(float screen_width,
                            float screen_height,
                            float mouse_x,
                            float mouse_y,
                            Vector3 pos,
                            Vector3 dir,
                            Vector3 up)
Calculates the pick ray for the given window coordinates. Assumes the window coordinate system has it's y downwards. The returned Ray is a member of this instance so don't reuse it outside this class.

Parameters:
screen_width - The window width in pixels
screen_height - The window height in pixels
mouse_x - The window x-coordinate
mouse_y - The window y-coordinate
pos - The camera position
dir - The camera direction, having unit length
up - The camera up vector, having unit length
Returns:
the picking ray.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.Frustum (libgdx API)

Uses of Class
com.badlogic.gdx.math.Frustum

Packages that use Frustum
com.badlogic.gdx.graphics

Uses of Frustum in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Frustum
 Frustum PerspectiveCamera.getFrustum()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Game (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Class Game

java.lang.Object
    extended by  com.badlogic.gdx.Game
All Implemented Interfaces:
ApplicationListener
public abstract class Game
extends java.lang.Object
implements ApplicationListener

An ApplicationListener that delegates to a Screen. This allows an application to easily have multiple screens.

Screens are not disposed automatically. You must handle whether you want to keep screens around or dispose of them when another screen is set.

Constructor Summary
Game()
Method Summary
void | dispose() Called when the Application is destroyed.
Screen | getScreen()
void | pause() Called when the Application is paused.
void | render() Called when the Application should render itself.
void | resize(int width, int height) Called when the Application is resized.
void | resume() Called when the Application is resumed from a paused state.
void | setScreen(Screen screen) Sets the current screen.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.badlogic.gdx.ApplicationListener
create

Constructor Detail

Game

public Game()
Method Detail

dispose

public void dispose()
Description copied from interface: ApplicationListener
Called when the Application is destroyed. Preceded by a call to ApplicationListener.pause().

Specified by:
dispose in interface ApplicationListener

pause

public void pause()
Description copied from interface: ApplicationListener
Called when the Application is paused. An Application is paused before it is destroyed, when a user pressed the Home button on Android or an incoming call happend. On the desktop this will only be called immediately before ApplicationListener.dispose() is called.

Specified by:
pause in interface ApplicationListener

resume

public void resume()
Description copied from interface: ApplicationListener
Called when the Application is resumed from a paused state. On Android this happens when the activity gets focus again. On the desktop this method will never be called.

Specified by:
resume in interface ApplicationListener

render

public void render()
Description copied from interface: ApplicationListener
Called when the Application should render itself.

Specified by:
render in interface ApplicationListener

resize

public void resize(int width,
                   int height)
Description copied from interface: ApplicationListener
Called when the Application is resized. This can happen at any point during a non-paused state but will never happen before a call to ApplicationListener.create().

Specified by:
resize in interface ApplicationListener
Parameters:
width - the new width in pixels
height - the new height in pixels

setScreen

public void setScreen(Screen screen)
Sets the current screen. Screen.hide() is called on any old screen, and Screen.show() is called on the new screen.

getScreen

public Screen getScreen()
Returns:
the currently active Screen.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.Game (libgdx API)

Uses of Class
com.badlogic.gdx.Game

No usage of com.badlogic.gdx.Game

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Gdx (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Class Gdx

java.lang.Object
    extended by  com.badlogic.gdx.Gdx

public class Gdx
extends java.lang.Object

Environment class holding references to the Application, Graphics, Audio, Files and Input instances. The references are held in public static fields. Do not mess with this! This essentially allows you static access to all sub systems. It is your responsiblity to keep things thread safe. Don't use Graphics in a thread that is not the rendering thread or things will go crazy. Really.

There's also references to GLCommon, GL10, GL11 and GL20. The same rules as above apply. Don't mess with this or things will break!

This is kind of messy but better than throwing around Graphics and similar instances. I'm aware of the design faux pas.

Author:
mzechner

Field Summary
static Application | app
static Audio | audio
static Files | files
static GLCommon | gl
static GL10 | gl10
static GL11 | gl11
static GL20 | gl20
static Graphics | graphics
static Input | input
Constructor Summary
Gdx()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

app

public static Application app

graphics

public static Graphics graphics

audio

public static Audio audio

input

public static Input input

files

public static Files files

gl

public static GLCommon gl

gl10

public static GL10 gl10

gl11

public static GL11 gl11

gl20

public static GL20 gl20
Constructor Detail

Gdx

public Gdx()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.Gdx (libgdx API)

Uses of Class
com.badlogic.gdx.Gdx

No usage of com.badlogic.gdx.Gdx

Overview Package Class Use Tree Deprecated Index Help
libgdx API


GdxNativesLoader (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class GdxNativesLoader

java.lang.Object
    extended by  com.badlogic.gdx.utils.GdxNativesLoader

public class GdxNativesLoader
extends java.lang.Object

Constructor Summary
GdxNativesLoader()
Method Summary
static java.lang.String | getLibraryPrefix()
static java.lang.String | getLibrarySuffix()
static boolean | is64Bit()
static boolean | loadLibraries() loads the necessary libraries depending on the operating system
static boolean | loadLibrary(java.lang.String libName, java.lang.String classPath, java.lang.String outputPath)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GdxNativesLoader

public GdxNativesLoader()
Method Detail

loadLibraries

public static boolean loadLibraries()
loads the necessary libraries depending on the operating system

getLibraryPrefix

public static java.lang.String getLibraryPrefix()

getLibrarySuffix

public static java.lang.String getLibrarySuffix()

is64Bit

public static boolean is64Bit()

loadLibrary

public static boolean loadLibrary(java.lang.String libName,
                                  java.lang.String classPath,
                                  java.lang.String outputPath)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.GdxNativesLoader (libgdx API)

Uses of Class
com.badlogic.gdx.utils.GdxNativesLoader

No usage of com.badlogic.gdx.utils.GdxNativesLoader

Overview Package Class Use Tree Deprecated Index Help
libgdx API


GdxRuntimeException (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class GdxRuntimeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.badlogic.gdx.utils.GdxRuntimeException
All Implemented Interfaces:
java.io.Serializable
public class GdxRuntimeException
extends java.lang.RuntimeException

Typed runtime exception used throughout libgdx

Author:
mzechner
See Also:
Serialized Form

Constructor Summary
GdxRuntimeException(java.lang.String message)
GdxRuntimeException(java.lang.String message, java.lang.Throwable t)
GdxRuntimeException(java.lang.Throwable t)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

GdxRuntimeException

public GdxRuntimeException(java.lang.String message)

GdxRuntimeException

public GdxRuntimeException(java.lang.Throwable t)

GdxRuntimeException

public GdxRuntimeException(java.lang.String message,
                           java.lang.Throwable t)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.GdxRuntimeException (libgdx API)

Uses of Class
com.badlogic.gdx.utils.GdxRuntimeException

No usage of com.badlogic.gdx.utils.GdxRuntimeException

Overview Package Class Use Tree Deprecated Index Help
libgdx API


GearJoint (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class GearJoint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
        extended by  com.badlogic.gdx.physics.box2d.joints.GearJoint

public class GearJoint
extends Joint

A gear joint is used to connect two joints together. Either joint can be a revolute or prismatic joint. You specify a gear ratio to bind the motions together: coordinate1 + ratio * coordinate2 = constant The ratio can be negative or positive. If one joint is a revolute joint and the other joint is a prismatic joint, then the ratio will have units of length or units of 1/length.

Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Joint
addr, jointEdgeA, jointEdgeB
Constructor Summary
GearJoint(World world, long addr)
Method Summary
float | getRatio() Set/Get the gear ratio.
void | setRatio(float ratio) Set/Get the gear ratio.
Methods inherited from class com.badlogic.gdx.physics.box2d.Joint
getAnchorA, getAnchorB, getBodyA, getBodyB, getReactionForce, getReactionTorque, getType, isActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GearJoint

public GearJoint(World world,
                 long addr)
Method Detail

setRatio

public void setRatio(float ratio)
Set/Get the gear ratio.

getRatio

public float getRatio()
Set/Get the gear ratio.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.GearJoint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.GearJoint

No usage of com.badlogic.gdx.physics.box2d.joints.GearJoint

Overview Package Class Use Tree Deprecated Index Help
libgdx API


GearJointDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class GearJointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
        extended by  com.badlogic.gdx.physics.box2d.joints.GearJointDef

public class GearJointDef
extends JointDef

Gear joint definition. This definition requires two existing revolute or prismatic joints (any combination will work). The provided joints must attach a dynamic body to a static body.

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType
Field Summary
Joint | joint1 The first revolute/prismatic joint attached to the gear joint.
Joint | joint2 The second revolute/prismatic joint attached to the gear joint.
float | ratio The gear ratio.
Fields inherited from class com.badlogic.gdx.physics.box2d.JointDef
bodyA, bodyB, collideConnected, type
Constructor Summary
GearJointDef()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

joint1

public Joint joint1
The first revolute/prismatic joint attached to the gear joint.

joint2

public Joint joint2
The second revolute/prismatic joint attached to the gear joint.

ratio

public float ratio
The gear ratio.

See Also:
for explanation.
Constructor Detail

GearJointDef

public GearJointDef()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.GearJointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.GearJointDef

No usage of com.badlogic.gdx.physics.box2d.joints.GearJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


GL10 (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Interface GL10

All Superinterfaces:
GLCommon
All Known Subinterfaces:
GL11
public interface GL10
extends GLCommon

Interface wrapping all standard OpenGL ES 1.0 methods. Note that this excludes and fixed point OpenGL ES 1.0 methods!

Author:
mzechner

Field Summary
static int | GL_ADD
static int | GL_ALIASED_LINE_WIDTH_RANGE
static int | GL_ALIASED_POINT_SIZE_RANGE
static int | GL_ALPHA
static int | GL_ALPHA_BITS
static int | GL_ALPHA_TEST
static int | GL_ALWAYS
static int | GL_AMBIENT
static int | GL_AMBIENT_AND_DIFFUSE
static int | GL_AND
static int | GL_AND_INVERTED
static int | GL_AND_REVERSE
static int | GL_BACK
static int | GL_BLEND
static int | GL_BLUE_BITS
static int | GL_BYTE
static int | GL_CCW
static int | GL_CLAMP_TO_EDGE
static int | GL_CLEAR
static int | GL_COLOR_ARRAY
static int | GL_COLOR_BUFFER_BIT
static int | GL_COLOR_LOGIC_OP
static int | GL_COLOR_MATERIAL
static int | GL_COMPRESSED_TEXTURE_FORMATS
static int | GL_CONSTANT_ATTENUATION
static int | GL_COPY
static int | GL_COPY_INVERTED
static int | GL_CULL_FACE
static int | GL_CW
static int | GL_DECAL
static int | GL_DECR
static int | GL_DEPTH_BITS
static int | GL_DEPTH_BUFFER_BIT
static int | GL_DEPTH_TEST
static int | GL_DIFFUSE
static int | GL_DITHER
static int | GL_DONT_CARE
static int | GL_DST_ALPHA
static int | GL_DST_COLOR
static int | GL_EMISSION
static int | GL_EQUAL
static int | GL_EQUIV
static int | GL_EXP
static int | GL_EXP2
static int | GL_EXTENSIONS
static int | GL_FALSE
static int | GL_FASTEST
static int | GL_FILL
static int | GL_FLAT
static int | GL_FLOAT
static int | GL_FOG
static int | GL_FOG_COLOR
static int | GL_FOG_DENSITY
static int | GL_FOG_END
static int | GL_FOG_HINT
static int | GL_FOG_MODE
static int | GL_FOG_START
static int | GL_FRONT
static int | GL_FRONT_AND_BACK
static int | GL_GEQUAL
static int | GL_GREATER
static int | GL_GREEN_BITS
static int | GL_IMPLEMENTATION_COLOR_READ_FORMAT_OES
static int | GL_IMPLEMENTATION_COLOR_READ_TYPE_OES
static int | GL_INCR
static int | GL_INVALID_ENUM
static int | GL_INVALID_OPERATION
static int | GL_INVALID_VALUE
static int | GL_INVERT
static int | GL_KEEP
static int | GL_LEQUAL
static int | GL_LESS
static int | GL_LIGHT_MODEL_AMBIENT
static int | GL_LIGHT_MODEL_TWO_SIDE
static int | GL_LIGHT0
static int | GL_LIGHT1
static int | GL_LIGHT2
static int | GL_LIGHT3
static int | GL_LIGHT4
static int | GL_LIGHT5
static int | GL_LIGHT6
static int | GL_LIGHT7
static int | GL_LIGHTING
static int | GL_LINE
static int | GL_LINE_LOOP
static int | GL_LINE_SMOOTH
static int | GL_LINE_SMOOTH_HINT
static int | GL_LINE_STRIP
static int | GL_LINEAR
static int | GL_LINEAR_ATTENUATION
static int | GL_LINEAR_MIPMAP_LINEAR
static int | GL_LINEAR_MIPMAP_NEAREST
static int | GL_LINES
static int | GL_LUMINANCE
static int | GL_LUMINANCE_ALPHA
static int | GL_MAX_ELEMENTS_INDICES
static int | GL_MAX_ELEMENTS_VERTICES
static int | GL_MAX_LIGHTS
static int | GL_MAX_MODELVIEW_STACK_DEPTH
static int | GL_MAX_PROJECTION_STACK_DEPTH
static int | GL_MAX_TEXTURE_SIZE
static int | GL_MAX_TEXTURE_STACK_DEPTH
static int | GL_MAX_TEXTURE_UNITS
static int | GL_MAX_VIEWPORT_DIMS
static int | GL_MODELVIEW
static int | GL_MODULATE
static int | GL_MULTISAMPLE
static int | GL_NAND
static int | GL_NEAREST
static int | GL_NEAREST_MIPMAP_LINEAR
static int | GL_NEAREST_MIPMAP_NEAREST
static int | GL_NEVER
static int | GL_NICEST
static int | GL_NO_ERROR
static int | GL_NOOP
static int | GL_NOR
static int | GL_NORMAL_ARRAY
static int | GL_NORMALIZE
static int | GL_NOTEQUAL
static int | GL_NUM_COMPRESSED_TEXTURE_FORMATS
static int | GL_OES_compressed_paletted_texture
static int | GL_OES_read_format
static int | GL_OES_VERSION_1_0
static int | GL_ONE
static int | GL_ONE_MINUS_DST_ALPHA
static int | GL_ONE_MINUS_DST_COLOR
static int | GL_ONE_MINUS_SRC_ALPHA
static int | GL_ONE_MINUS_SRC_COLOR
static int | GL_OR
static int | GL_OR_INVERTED
static int | GL_OR_REVERSE
static int | GL_OUT_OF_MEMORY
static int | GL_PACK_ALIGNMENT
static int | GL_PALETTE4_R5_G6_B5_OES
static int | GL_PALETTE4_RGB5_A1_OES
static int | GL_PALETTE4_RGB8_OES
static int | GL_PALETTE4_RGBA4_OES
static int | GL_PALETTE4_RGBA8_OES
static int | GL_PALETTE8_R5_G6_B5_OES
static int | GL_PALETTE8_RGB5_A1_OES
static int | GL_PALETTE8_RGB8_OES
static int | GL_PALETTE8_RGBA4_OES
static int | GL_PALETTE8_RGBA8_OES
static int | GL_PERSPECTIVE_CORRECTION_HINT
static int | GL_POINT
static int | GL_POINT_SMOOTH
static int | GL_POINT_SMOOTH_HINT
static int | GL_POINTS
static int | GL_POLYGON_OFFSET_FILL
static int | GL_POLYGON_SMOOTH_HINT
static int | GL_POSITION
static int | GL_PROJECTION
static int | GL_QUADRATIC_ATTENUATION
static int | GL_RED_BITS
static int | GL_RENDERER
static int | GL_REPEAT
static int | GL_REPLACE
static int | GL_RESCALE_NORMAL
static int | GL_RGB
static int | GL_RGBA
static int | GL_SAMPLE_ALPHA_TO_COVERAGE
static int | GL_SAMPLE_ALPHA_TO_ONE
static int | GL_SAMPLE_COVERAGE
static int | GL_SCISSOR_TEST
static int | GL_SET
static int | GL_SHININESS
static int | GL_SHORT
static int | GL_SMOOTH
static int | GL_SMOOTH_LINE_WIDTH_RANGE
static int | GL_SMOOTH_POINT_SIZE_RANGE
static int | GL_SPECULAR
static int | GL_SPOT_CUTOFF
static int | GL_SPOT_DIRECTION
static int | GL_SPOT_EXPONENT
static int | GL_SRC_ALPHA
static int | GL_SRC_ALPHA_SATURATE
static int | GL_SRC_COLOR
static int | GL_STACK_OVERFLOW
static int | GL_STACK_UNDERFLOW
static int | GL_STENCIL_BITS
static int | GL_STENCIL_BUFFER_BIT
static int | GL_STENCIL_TEST
static int | GL_SUBPIXEL_BITS
static int | GL_TEXTURE
static int | GL_TEXTURE_2D
static int | GL_TEXTURE_COORD_ARRAY
static int | GL_TEXTURE_ENV
static int | GL_TEXTURE_ENV_COLOR
static int | GL_TEXTURE_ENV_MODE
static int | GL_TEXTURE_MAG_FILTER
static int | GL_TEXTURE_MIN_FILTER
static int | GL_TEXTURE_WRAP_S
static int | GL_TEXTURE_WRAP_T
static int | GL_TEXTURE0
static int | GL_TEXTURE1
static int | GL_TEXTURE10
static int | GL_TEXTURE11
static int | GL_TEXTURE12
static int | GL_TEXTURE13
static int | GL_TEXTURE14
static int | GL_TEXTURE15
static int | GL_TEXTURE16
static int | GL_TEXTURE17
static int | GL_TEXTURE18
static int | GL_TEXTURE19
static int | GL_TEXTURE2
static int | GL_TEXTURE20
static int | GL_TEXTURE21
static int | GL_TEXTURE22
static int | GL_TEXTURE23
static int | GL_TEXTURE24
static int | GL_TEXTURE25
static int | GL_TEXTURE26
static int | GL_TEXTURE27
static int | GL_TEXTURE28
static int | GL_TEXTURE29
static int | GL_TEXTURE3
static int | GL_TEXTURE30
static int | GL_TEXTURE31
static int | GL_TEXTURE4
static int | GL_TEXTURE5
static int | GL_TEXTURE6
static int | GL_TEXTURE7
static int | GL_TEXTURE8
static int | GL_TEXTURE9
static int | GL_TRIANGLE_FAN
static int | GL_TRIANGLE_STRIP
static int | GL_TRIANGLES
static int | GL_TRUE
static int | GL_UNPACK_ALIGNMENT
static int | GL_UNSIGNED_BYTE
static int | GL_UNSIGNED_SHORT
static int | GL_UNSIGNED_SHORT_4_4_4_4
static int | GL_UNSIGNED_SHORT_5_5_5_1
static int | GL_UNSIGNED_SHORT_5_6_5
static int | GL_VENDOR
static int | GL_VERSION
static int | GL_VERTEX_ARRAY
static int | GL_XOR
static int | GL_ZERO
Method Summary
void | glAlphaFunc(int func, float ref)
void | glClientActiveTexture(int texture)
void | glColor4f(float red, float green, float blue, float alpha)
void | glColorPointer(int size, int type, int stride, java.nio.Buffer pointer)
void | glDeleteTextures(int n, int[] textures, int offset)
void | glDisableClientState(int array)
void | glEnableClientState(int array)
void | glFogf(int pname, float param)
void | glFogfv(int pname, float[] params, int offset)
void | glFogfv(int pname, java.nio.FloatBuffer params)
void | glFrustumf(float left, float right, float bottom, float top, float zNear, float zFar)
void | glGenTextures(int n, int[] textures, int offset)
void | glGetIntegerv(int pname, int[] params, int offset)
void | glLightf(int light, int pname, float param)
void | glLightfv(int light, int pname, float[] params, int offset)
void | glLightfv(int light, int pname, java.nio.FloatBuffer params)
void | glLightModelf(int pname, float param)
void | glLightModelfv(int pname, float[] params, int offset)
void | glLightModelfv(int pname, java.nio.FloatBuffer params)
void | glLoadIdentity()
void | glLoadMatrixf(float[] m, int offset)
void | glLoadMatrixf(java.nio.FloatBuffer m)
void | glLogicOp(int opcode)
void | glMaterialf(int face, int pname, float param)
void | glMaterialfv(int face, int pname, float[] params, int offset)
void | glMaterialfv(int face, int pname, java.nio.FloatBuffer params)
void | glMatrixMode(int mode)
void | glMultiTexCoord4f(int target, float s, float t, float r, float q)
void | glMultMatrixf(float[] m, int offset)
void | glMultMatrixf(java.nio.FloatBuffer m)
void | glNormal3f(float nx, float ny, float nz)
void | glNormalPointer(int type, int stride, java.nio.Buffer pointer)
void | glOrthof(float left, float right, float bottom, float top, float zNear, float zFar)
void | glPointSize(float size)
void | glPolygonMode(int face, int mode)
void | glPopMatrix()
void | glPushMatrix()
void | glRotatef(float angle, float x, float y, float z)
void | glSampleCoverage(float value, boolean invert)
void | glScalef(float x, float y, float z)
void | glShadeModel(int mode)
void | glTexCoordPointer(int size, int type, int stride, java.nio.Buffer pointer)
void | glTexEnvf(int target, int pname, float param)
void | glTexEnvfv(int target, int pname, float[] params, int offset)
void | glTexEnvfv(int target, int pname, java.nio.FloatBuffer params)
void | glTranslatef(float x, float y, float z)
void | glVertexPointer(int size, int type, int stride, java.nio.Buffer pointer)
Methods inherited from interface com.badlogic.gdx.graphics.GLCommon
glActiveTexture, glBindTexture, glBlendFunc, glClear, glClearColor, glClearDepthf, glClearStencil, glColorMask, glCompressedTexImage2D, glCompressedTexSubImage2D, glCopyTexImage2D, glCopyTexSubImage2D, glCullFace, glDeleteTextures, glDepthFunc, glDepthMask, glDepthRangef, glDisable, glDrawArrays, glDrawElements, glEnable, glFinish, glFlush, glFrontFace, glGenTextures, glGetError, glGetIntegerv, glGetString, glHint, glLineWidth, glPixelStorei, glPolygonOffset, glReadPixels, glScissor, glStencilFunc, glStencilMask, glStencilOp, glTexImage2D, glTexParameterf, glTexSubImage2D, glViewport

Field Detail

GL_OES_VERSION_1_0

static final int GL_OES_VERSION_1_0
See Also:
Constant Field Values

GL_OES_read_format

static final int GL_OES_read_format
See Also:
Constant Field Values

GL_OES_compressed_paletted_texture

static final int GL_OES_compressed_paletted_texture
See Also:
Constant Field Values

GL_DEPTH_BUFFER_BIT

static final int GL_DEPTH_BUFFER_BIT
See Also:
Constant Field Values

GL_STENCIL_BUFFER_BIT

static final int GL_STENCIL_BUFFER_BIT
See Also:
Constant Field Values

GL_COLOR_BUFFER_BIT

static final int GL_COLOR_BUFFER_BIT
See Also:
Constant Field Values

GL_FALSE

static final int GL_FALSE
See Also:
Constant Field Values

GL_TRUE

static final int GL_TRUE
See Also:
Constant Field Values

GL_POINTS

static final int GL_POINTS
See Also:
Constant Field Values

GL_LINES

static final int GL_LINES
See Also:
Constant Field Values

GL_LINE_LOOP

static final int GL_LINE_LOOP
See Also:
Constant Field Values

GL_LINE_STRIP

static final int GL_LINE_STRIP
See Also:
Constant Field Values

GL_TRIANGLES

static final int GL_TRIANGLES
See Also:
Constant Field Values

GL_TRIANGLE_STRIP

static final int GL_TRIANGLE_STRIP
See Also:
Constant Field Values

GL_TRIANGLE_FAN

static final int GL_TRIANGLE_FAN
See Also:
Constant Field Values

GL_NEVER

static final int GL_NEVER
See Also:
Constant Field Values

GL_LESS

static final int GL_LESS
See Also:
Constant Field Values

GL_EQUAL

static final int GL_EQUAL
See Also:
Constant Field Values

GL_LEQUAL

static final int GL_LEQUAL
See Also:
Constant Field Values

GL_GREATER

static final int GL_GREATER
See Also:
Constant Field Values

GL_NOTEQUAL

static final int GL_NOTEQUAL
See Also:
Constant Field Values

GL_GEQUAL

static final int GL_GEQUAL
See Also:
Constant Field Values

GL_ALWAYS

static final int GL_ALWAYS
See Also:
Constant Field Values

GL_ZERO

static final int GL_ZERO
See Also:
Constant Field Values

GL_ONE

static final int GL_ONE
See Also:
Constant Field Values

GL_SRC_COLOR

static final int GL_SRC_COLOR
See Also:
Constant Field Values

GL_ONE_MINUS_SRC_COLOR

static final int GL_ONE_MINUS_SRC_COLOR
See Also:
Constant Field Values

GL_SRC_ALPHA

static final int GL_SRC_ALPHA
See Also:
Constant Field Values

GL_ONE_MINUS_SRC_ALPHA

static final int GL_ONE_MINUS_SRC_ALPHA
See Also:
Constant Field Values

GL_DST_ALPHA

static final int GL_DST_ALPHA
See Also:
Constant Field Values

GL_ONE_MINUS_DST_ALPHA

static final int GL_ONE_MINUS_DST_ALPHA
See Also:
Constant Field Values

GL_DST_COLOR

static final int GL_DST_COLOR
See Also:
Constant Field Values

GL_ONE_MINUS_DST_COLOR

static final int GL_ONE_MINUS_DST_COLOR
See Also:
Constant Field Values

GL_SRC_ALPHA_SATURATE

static final int GL_SRC_ALPHA_SATURATE
See Also:
Constant Field Values

GL_FRONT

static final int GL_FRONT
See Also:
Constant Field Values

GL_BACK

static final int GL_BACK
See Also:
Constant Field Values

GL_FRONT_AND_BACK

static final int GL_FRONT_AND_BACK
See Also:
Constant Field Values

GL_FOG

static final int GL_FOG
See Also:
Constant Field Values

GL_LIGHTING

static final int GL_LIGHTING
See Also:
Constant Field Values

GL_TEXTURE_2D

static final int GL_TEXTURE_2D
See Also:
Constant Field Values

GL_CULL_FACE

static final int GL_CULL_FACE
See Also:
Constant Field Values

GL_ALPHA_TEST

static final int GL_ALPHA_TEST
See Also:
Constant Field Values

GL_BLEND

static final int GL_BLEND
See Also:
Constant Field Values

GL_COLOR_LOGIC_OP

static final int GL_COLOR_LOGIC_OP
See Also:
Constant Field Values

GL_DITHER

static final int GL_DITHER
See Also:
Constant Field Values

GL_STENCIL_TEST

static final int GL_STENCIL_TEST
See Also:
Constant Field Values

GL_DEPTH_TEST

static final int GL_DEPTH_TEST
See Also:
Constant Field Values

GL_POINT_SMOOTH

static final int GL_POINT_SMOOTH
See Also:
Constant Field Values

GL_LINE_SMOOTH

static final int GL_LINE_SMOOTH
See Also:
Constant Field Values

GL_SCISSOR_TEST

static final int GL_SCISSOR_TEST
See Also:
Constant Field Values

GL_COLOR_MATERIAL

static final int GL_COLOR_MATERIAL
See Also:
Constant Field Values

GL_NORMALIZE

static final int GL_NORMALIZE
See Also:
Constant Field Values

GL_RESCALE_NORMAL

static final int GL_RESCALE_NORMAL
See Also:
Constant Field Values

GL_POLYGON_OFFSET_FILL

static final int GL_POLYGON_OFFSET_FILL
See Also:
Constant Field Values

GL_VERTEX_ARRAY

static final int GL_VERTEX_ARRAY
See Also:
Constant Field Values

GL_NORMAL_ARRAY

static final int GL_NORMAL_ARRAY
See Also:
Constant Field Values

GL_COLOR_ARRAY

static final int GL_COLOR_ARRAY
See Also:
Constant Field Values

GL_TEXTURE_COORD_ARRAY

static final int GL_TEXTURE_COORD_ARRAY
See Also:
Constant Field Values

GL_MULTISAMPLE

static final int GL_MULTISAMPLE
See Also:
Constant Field Values

GL_SAMPLE_ALPHA_TO_COVERAGE

static final int GL_SAMPLE_ALPHA_TO_COVERAGE
See Also:
Constant Field Values

GL_SAMPLE_ALPHA_TO_ONE

static final int GL_SAMPLE_ALPHA_TO_ONE
See Also:
Constant Field Values

GL_SAMPLE_COVERAGE

static final int GL_SAMPLE_COVERAGE
See Also:
Constant Field Values

GL_NO_ERROR

static final int GL_NO_ERROR
See Also:
Constant Field Values

GL_INVALID_ENUM

static final int GL_INVALID_ENUM
See Also:
Constant Field Values

GL_INVALID_VALUE

static final int GL_INVALID_VALUE
See Also:
Constant Field Values

GL_INVALID_OPERATION

static final int GL_INVALID_OPERATION
See Also:
Constant Field Values

GL_STACK_OVERFLOW

static final int GL_STACK_OVERFLOW
See Also:
Constant Field Values

GL_STACK_UNDERFLOW

static final int GL_STACK_UNDERFLOW
See Also:
Constant Field Values

GL_OUT_OF_MEMORY

static final int GL_OUT_OF_MEMORY
See Also:
Constant Field Values

GL_EXP

static final int GL_EXP
See Also:
Constant Field Values

GL_EXP2

static final int GL_EXP2
See Also:
Constant Field Values

GL_FOG_DENSITY

static final int GL_FOG_DENSITY
See Also:
Constant Field Values

GL_FOG_START

static final int GL_FOG_START
See Also:
Constant Field Values

GL_FOG_END

static final int GL_FOG_END
See Also:
Constant Field Values

GL_FOG_MODE

static final int GL_FOG_MODE
See Also:
Constant Field Values

GL_FOG_COLOR

static final int GL_FOG_COLOR
See Also:
Constant Field Values

GL_CW

static final int GL_CW
See Also:
Constant Field Values

GL_CCW

static final int GL_CCW
See Also:
Constant Field Values

GL_SMOOTH_POINT_SIZE_RANGE

static final int GL_SMOOTH_POINT_SIZE_RANGE
See Also:
Constant Field Values

GL_SMOOTH_LINE_WIDTH_RANGE

static final int GL_SMOOTH_LINE_WIDTH_RANGE
See Also:
Constant Field Values

GL_ALIASED_POINT_SIZE_RANGE

static final int GL_ALIASED_POINT_SIZE_RANGE
See Also:
Constant Field Values

GL_ALIASED_LINE_WIDTH_RANGE

static final int GL_ALIASED_LINE_WIDTH_RANGE
See Also:
Constant Field Values

GL_IMPLEMENTATION_COLOR_READ_TYPE_OES

static final int GL_IMPLEMENTATION_COLOR_READ_TYPE_OES
See Also:
Constant Field Values

GL_IMPLEMENTATION_COLOR_READ_FORMAT_OES

static final int GL_IMPLEMENTATION_COLOR_READ_FORMAT_OES
See Also:
Constant Field Values

GL_MAX_LIGHTS

static final int GL_MAX_LIGHTS
See Also:
Constant Field Values

GL_MAX_TEXTURE_SIZE

static final int GL_MAX_TEXTURE_SIZE
See Also:
Constant Field Values

GL_MAX_MODELVIEW_STACK_DEPTH

static final int GL_MAX_MODELVIEW_STACK_DEPTH
See Also:
Constant Field Values

GL_MAX_PROJECTION_STACK_DEPTH

static final int GL_MAX_PROJECTION_STACK_DEPTH
See Also:
Constant Field Values

GL_MAX_TEXTURE_STACK_DEPTH

static final int GL_MAX_TEXTURE_STACK_DEPTH
See Also:
Constant Field Values

GL_MAX_VIEWPORT_DIMS

static final int GL_MAX_VIEWPORT_DIMS
See Also:
Constant Field Values

GL_MAX_ELEMENTS_VERTICES

static final int GL_MAX_ELEMENTS_VERTICES
See Also:
Constant Field Values

GL_MAX_ELEMENTS_INDICES

static final int GL_MAX_ELEMENTS_INDICES
See Also:
Constant Field Values

GL_MAX_TEXTURE_UNITS

static final int GL_MAX_TEXTURE_UNITS
See Also:
Constant Field Values

GL_NUM_COMPRESSED_TEXTURE_FORMATS

static final int GL_NUM_COMPRESSED_TEXTURE_FORMATS
See Also:
Constant Field Values

GL_COMPRESSED_TEXTURE_FORMATS

static final int GL_COMPRESSED_TEXTURE_FORMATS
See Also:
Constant Field Values

GL_SUBPIXEL_BITS

static final int GL_SUBPIXEL_BITS
See Also:
Constant Field Values

GL_RED_BITS

static final int GL_RED_BITS
See Also:
Constant Field Values

GL_GREEN_BITS

static final int GL_GREEN_BITS
See Also:
Constant Field Values

GL_BLUE_BITS

static final int GL_BLUE_BITS
See Also:
Constant Field Values

GL_ALPHA_BITS

static final int GL_ALPHA_BITS
See Also:
Constant Field Values

GL_DEPTH_BITS

static final int GL_DEPTH_BITS
See Also:
Constant Field Values

GL_STENCIL_BITS

static final int GL_STENCIL_BITS
See Also:
Constant Field Values

GL_DONT_CARE

static final int GL_DONT_CARE
See Also:
Constant Field Values

GL_FASTEST

static final int GL_FASTEST
See Also:
Constant Field Values

GL_NICEST

static final int GL_NICEST
See Also:
Constant Field Values

GL_PERSPECTIVE_CORRECTION_HINT

static final int GL_PERSPECTIVE_CORRECTION_HINT
See Also:
Constant Field Values

GL_POINT_SMOOTH_HINT

static final int GL_POINT_SMOOTH_HINT
See Also:
Constant Field Values

GL_LINE_SMOOTH_HINT

static final int GL_LINE_SMOOTH_HINT
See Also:
Constant Field Values

GL_POLYGON_SMOOTH_HINT

static final int GL_POLYGON_SMOOTH_HINT
See Also:
Constant Field Values

GL_FOG_HINT

static final int GL_FOG_HINT
See Also:
Constant Field Values

GL_LIGHT_MODEL_AMBIENT

static final int GL_LIGHT_MODEL_AMBIENT
See Also:
Constant Field Values

GL_LIGHT_MODEL_TWO_SIDE

static final int GL_LIGHT_MODEL_TWO_SIDE
See Also:
Constant Field Values

GL_AMBIENT

static final int GL_AMBIENT
See Also:
Constant Field Values

GL_DIFFUSE

static final int GL_DIFFUSE
See Also:
Constant Field Values

GL_SPECULAR

static final int GL_SPECULAR
See Also:
Constant Field Values

GL_POSITION

static final int GL_POSITION
See Also:
Constant Field Values

GL_SPOT_DIRECTION

static final int GL_SPOT_DIRECTION
See Also:
Constant Field Values

GL_SPOT_EXPONENT

static final int GL_SPOT_EXPONENT
See Also:
Constant Field Values

GL_SPOT_CUTOFF

static final int GL_SPOT_CUTOFF
See Also:
Constant Field Values

GL_CONSTANT_ATTENUATION

static final int GL_CONSTANT_ATTENUATION
See Also:
Constant Field Values

GL_LINEAR_ATTENUATION

static final int GL_LINEAR_ATTENUATION
See Also:
Constant Field Values

GL_QUADRATIC_ATTENUATION

static final int GL_QUADRATIC_ATTENUATION
See Also:
Constant Field Values

GL_BYTE

static final int GL_BYTE
See Also:
Constant Field Values

GL_UNSIGNED_BYTE

static final int GL_UNSIGNED_BYTE
See Also:
Constant Field Values

GL_SHORT

static final int GL_SHORT
See Also:
Constant Field Values

GL_UNSIGNED_SHORT

static final int GL_UNSIGNED_SHORT
See Also:
Constant Field Values

GL_FLOAT

static final int GL_FLOAT
See Also:
Constant Field Values

GL_CLEAR

static final int GL_CLEAR
See Also:
Constant Field Values

GL_AND

static final int GL_AND
See Also:
Constant Field Values

GL_AND_REVERSE

static final int GL_AND_REVERSE
See Also:
Constant Field Values

GL_COPY

static final int GL_COPY
See Also:
Constant Field Values

GL_AND_INVERTED

static final int GL_AND_INVERTED
See Also:
Constant Field Values

GL_NOOP

static final int GL_NOOP
See Also:
Constant Field Values

GL_XOR

static final int GL_XOR
See Also:
Constant Field Values

GL_OR

static final int GL_OR
See Also:
Constant Field Values

GL_NOR

static final int GL_NOR
See Also:
Constant Field Values

GL_EQUIV

static final int GL_EQUIV
See Also:
Constant Field Values

GL_INVERT

static final int GL_INVERT
See Also:
Constant Field Values

GL_OR_REVERSE

static final int GL_OR_REVERSE
See Also:
Constant Field Values

GL_COPY_INVERTED

static final int GL_COPY_INVERTED
See Also:
Constant Field Values

GL_OR_INVERTED

static final int GL_OR_INVERTED
See Also:
Constant Field Values

GL_NAND

static final int GL_NAND
See Also:
Constant Field Values

GL_SET

static final int GL_SET
See Also:
Constant Field Values

GL_EMISSION

static final int GL_EMISSION
See Also:
Constant Field Values

GL_SHININESS

static final int GL_SHININESS
See Also:
Constant Field Values

GL_AMBIENT_AND_DIFFUSE

static final int GL_AMBIENT_AND_DIFFUSE
See Also:
Constant Field Values

GL_MODELVIEW

static final int GL_MODELVIEW
See Also:
Constant Field Values

GL_PROJECTION

static final int GL_PROJECTION
See Also:
Constant Field Values

GL_TEXTURE

static final int GL_TEXTURE
See Also:
Constant Field Values

GL_ALPHA

static final int GL_ALPHA
See Also:
Constant Field Values

GL_RGB

static final int GL_RGB
See Also:
Constant Field Values

GL_RGBA

static final int GL_RGBA
See Also:
Constant Field Values

GL_LUMINANCE

static final int GL_LUMINANCE
See Also:
Constant Field Values

GL_LUMINANCE_ALPHA

static final int GL_LUMINANCE_ALPHA
See Also:
Constant Field Values

GL_UNPACK_ALIGNMENT

static final int GL_UNPACK_ALIGNMENT
See Also:
Constant Field Values

GL_PACK_ALIGNMENT

static final int GL_PACK_ALIGNMENT
See Also:
Constant Field Values

GL_UNSIGNED_SHORT_4_4_4_4

static final int GL_UNSIGNED_SHORT_4_4_4_4
See Also:
Constant Field Values

GL_UNSIGNED_SHORT_5_5_5_1

static final int GL_UNSIGNED_SHORT_5_5_5_1
See Also:
Constant Field Values

GL_UNSIGNED_SHORT_5_6_5

static final int GL_UNSIGNED_SHORT_5_6_5
See Also:
Constant Field Values

GL_FLAT

static final int GL_FLAT
See Also:
Constant Field Values

GL_SMOOTH

static final int GL_SMOOTH
See Also:
Constant Field Values

GL_KEEP

static final int GL_KEEP
See Also:
Constant Field Values

GL_REPLACE

static final int GL_REPLACE
See Also:
Constant Field Values

GL_INCR

static final int GL_INCR
See Also:
Constant Field Values

GL_DECR

static final int GL_DECR
See Also:
Constant Field Values

GL_VENDOR

static final int GL_VENDOR
See Also:
Constant Field Values

GL_RENDERER

static final int GL_RENDERER
See Also:
Constant Field Values

GL_VERSION

static final int GL_VERSION
See Also:
Constant Field Values

GL_EXTENSIONS

static final int GL_EXTENSIONS
See Also:
Constant Field Values

GL_MODULATE

static final int GL_MODULATE
See Also:
Constant Field Values

GL_DECAL

static final int GL_DECAL
See Also:
Constant Field Values

GL_ADD

static final int GL_ADD
See Also:
Constant Field Values

GL_TEXTURE_ENV_MODE

static final int GL_TEXTURE_ENV_MODE
See Also:
Constant Field Values

GL_TEXTURE_ENV_COLOR

static final int GL_TEXTURE_ENV_COLOR
See Also:
Constant Field Values

GL_TEXTURE_ENV

static final int GL_TEXTURE_ENV
See Also:
Constant Field Values

GL_NEAREST

static final int GL_NEAREST
See Also:
Constant Field Values

GL_LINEAR

static final int GL_LINEAR
See Also:
Constant Field Values

GL_NEAREST_MIPMAP_NEAREST

static final int GL_NEAREST_MIPMAP_NEAREST
See Also:
Constant Field Values

GL_LINEAR_MIPMAP_NEAREST

static final int GL_LINEAR_MIPMAP_NEAREST
See Also:
Constant Field Values

GL_NEAREST_MIPMAP_LINEAR

static final int GL_NEAREST_MIPMAP_LINEAR
See Also:
Constant Field Values

GL_LINEAR_MIPMAP_LINEAR

static final int GL_LINEAR_MIPMAP_LINEAR
See Also:
Constant Field Values

GL_TEXTURE_MAG_FILTER

static final int GL_TEXTURE_MAG_FILTER
See Also:
Constant Field Values

GL_TEXTURE_MIN_FILTER

static final int GL_TEXTURE_MIN_FILTER
See Also:
Constant Field Values

GL_TEXTURE_WRAP_S

static final int GL_TEXTURE_WRAP_S
See Also:
Constant Field Values

GL_TEXTURE_WRAP_T

static final int GL_TEXTURE_WRAP_T
See Also:
Constant Field Values

GL_TEXTURE0

static final int GL_TEXTURE0
See Also:
Constant Field Values

GL_TEXTURE1

static final int GL_TEXTURE1
See Also:
Constant Field Values

GL_TEXTURE2

static final int GL_TEXTURE2
See Also:
Constant Field Values

GL_TEXTURE3

static final int GL_TEXTURE3
See Also:
Constant Field Values

GL_TEXTURE4

static final int GL_TEXTURE4
See Also:
Constant Field Values

GL_TEXTURE5

static final int GL_TEXTURE5
See Also:
Constant Field Values

GL_TEXTURE6

static final int GL_TEXTURE6
See Also:
Constant Field Values

GL_TEXTURE7

static final int GL_TEXTURE7
See Also:
Constant Field Values

GL_TEXTURE8

static final int GL_TEXTURE8
See Also:
Constant Field Values

GL_TEXTURE9

static final int GL_TEXTURE9
See Also:
Constant Field Values

GL_TEXTURE10

static final int GL_TEXTURE10
See Also:
Constant Field Values

GL_TEXTURE11

static final int GL_TEXTURE11
See Also:
Constant Field Values

GL_TEXTURE12

static final int GL_TEXTURE12
See Also:
Constant Field Values

GL_TEXTURE13

static final int GL_TEXTURE13
See Also:
Constant Field Values

GL_TEXTURE14

static final int GL_TEXTURE14
See Also:
Constant Field Values

GL_TEXTURE15

static final int GL_TEXTURE15
See Also:
Constant Field Values

GL_TEXTURE16

static final int GL_TEXTURE16
See Also:
Constant Field Values

GL_TEXTURE17

static final int GL_TEXTURE17
See Also:
Constant Field Values

GL_TEXTURE18

static final int GL_TEXTURE18
See Also:
Constant Field Values

GL_TEXTURE19

static final int GL_TEXTURE19
See Also:
Constant Field Values

GL_TEXTURE20

static final int GL_TEXTURE20
See Also:
Constant Field Values

GL_TEXTURE21

static final int GL_TEXTURE21
See Also:
Constant Field Values

GL_TEXTURE22

static final int GL_TEXTURE22
See Also:
Constant Field Values

GL_TEXTURE23

static final int GL_TEXTURE23
See Also:
Constant Field Values

GL_TEXTURE24

static final int GL_TEXTURE24
See Also:
Constant Field Values

GL_TEXTURE25

static final int GL_TEXTURE25
See Also:
Constant Field Values

GL_TEXTURE26

static final int GL_TEXTURE26
See Also:
Constant Field Values

GL_TEXTURE27

static final int GL_TEXTURE27
See Also:
Constant Field Values

GL_TEXTURE28

static final int GL_TEXTURE28
See Also:
Constant Field Values

GL_TEXTURE29

static final int GL_TEXTURE29
See Also:
Constant Field Values

GL_TEXTURE30

static final int GL_TEXTURE30
See Also:
Constant Field Values

GL_TEXTURE31

static final int GL_TEXTURE31
See Also:
Constant Field Values

GL_REPEAT

static final int GL_REPEAT
See Also:
Constant Field Values

GL_CLAMP_TO_EDGE

static final int GL_CLAMP_TO_EDGE
See Also:
Constant Field Values

GL_PALETTE4_RGB8_OES

static final int GL_PALETTE4_RGB8_OES
See Also:
Constant Field Values

GL_PALETTE4_RGBA8_OES

static final int GL_PALETTE4_RGBA8_OES
See Also:
Constant Field Values

GL_PALETTE4_R5_G6_B5_OES

static final int GL_PALETTE4_R5_G6_B5_OES
See Also:
Constant Field Values

GL_PALETTE4_RGBA4_OES

static final int GL_PALETTE4_RGBA4_OES
See Also:
Constant Field Values

GL_PALETTE4_RGB5_A1_OES

static final int GL_PALETTE4_RGB5_A1_OES
See Also:
Constant Field Values

GL_PALETTE8_RGB8_OES

static final int GL_PALETTE8_RGB8_OES
See Also:
Constant Field Values

GL_PALETTE8_RGBA8_OES

static final int GL_PALETTE8_RGBA8_OES
See Also:
Constant Field Values

GL_PALETTE8_R5_G6_B5_OES

static final int GL_PALETTE8_R5_G6_B5_OES
See Also:
Constant Field Values

GL_PALETTE8_RGBA4_OES

static final int GL_PALETTE8_RGBA4_OES
See Also:
Constant Field Values

GL_PALETTE8_RGB5_A1_OES

static final int GL_PALETTE8_RGB5_A1_OES
See Also:
Constant Field Values

GL_LIGHT0

static final int GL_LIGHT0
See Also:
Constant Field Values

GL_LIGHT1

static final int GL_LIGHT1
See Also:
Constant Field Values

GL_LIGHT2

static final int GL_LIGHT2
See Also:
Constant Field Values

GL_LIGHT3

static final int GL_LIGHT3
See Also:
Constant Field Values

GL_LIGHT4

static final int GL_LIGHT4
See Also:
Constant Field Values

GL_LIGHT5

static final int GL_LIGHT5
See Also:
Constant Field Values

GL_LIGHT6

static final int GL_LIGHT6
See Also:
Constant Field Values

GL_LIGHT7

static final int GL_LIGHT7
See Also:
Constant Field Values

GL_POINT

static final int GL_POINT
See Also:
Constant Field Values

GL_LINE

static final int GL_LINE
See Also:
Constant Field Values

GL_FILL

static final int GL_FILL
See Also:
Constant Field Values
Method Detail

glAlphaFunc

void glAlphaFunc(int func,
                 float ref)

glClientActiveTexture

void glClientActiveTexture(int texture)

glColor4f

void glColor4f(float red,
               float green,
               float blue,
               float alpha)

glColorPointer

void glColorPointer(int size,
                    int type,
                    int stride,
                    java.nio.Buffer pointer)

glDeleteTextures

void glDeleteTextures(int n,
                      int[] textures,
                      int offset)

glDisableClientState

void glDisableClientState(int array)

glEnableClientState

void glEnableClientState(int array)

glFogf

void glFogf(int pname,
            float param)

glFogfv

void glFogfv(int pname,
             float[] params,
             int offset)

glFogfv

void glFogfv(int pname,
             java.nio.FloatBuffer params)

glFrustumf

void glFrustumf(float left,
                float right,
                float bottom,
                float top,
                float zNear,
                float zFar)

glGenTextures

void glGenTextures(int n,
                   int[] textures,
                   int offset)

glGetIntegerv

void glGetIntegerv(int pname,
                   int[] params,
                   int offset)

glLightModelf

void glLightModelf(int pname,
                   float param)

glLightModelfv

void glLightModelfv(int pname,
                    float[] params,
                    int offset)

glLightModelfv

void glLightModelfv(int pname,
                    java.nio.FloatBuffer params)

glLightf

void glLightf(int light,
              int pname,
              float param)

glLightfv

void glLightfv(int light,
               int pname,
               float[] params,
               int offset)

glLightfv

void glLightfv(int light,
               int pname,
               java.nio.FloatBuffer params)

glLoadIdentity

void glLoadIdentity()

glLoadMatrixf

void glLoadMatrixf(float[] m,
                   int offset)

glLoadMatrixf

void glLoadMatrixf(java.nio.FloatBuffer m)

glLogicOp

void glLogicOp(int opcode)

glMaterialf

void glMaterialf(int face,
                 int pname,
                 float param)

glMaterialfv

void glMaterialfv(int face,
                  int pname,
                  float[] params,
                  int offset)

glMaterialfv

void glMaterialfv(int face,
                  int pname,
                  java.nio.FloatBuffer params)

glMatrixMode

void glMatrixMode(int mode)

glMultMatrixf

void glMultMatrixf(float[] m,
                   int offset)

glMultMatrixf

void glMultMatrixf(java.nio.FloatBuffer m)

glMultiTexCoord4f

void glMultiTexCoord4f(int target,
                       float s,
                       float t,
                       float r,
                       float q)

glNormal3f

void glNormal3f(float nx,
                float ny,
                float nz)

glNormalPointer

void glNormalPointer(int type,
                     int stride,
                     java.nio.Buffer pointer)

glOrthof

void glOrthof(float left,
              float right,
              float bottom,
              float top,
              float zNear,
              float zFar)

glPointSize

void glPointSize(float size)

glPopMatrix

void glPopMatrix()

glPushMatrix

void glPushMatrix()

glRotatef

void glRotatef(float angle,
               float x,
               float y,
               float z)

glSampleCoverage

void glSampleCoverage(float value,
                      boolean invert)

glScalef

void glScalef(float x,
              float y,
              float z)

glShadeModel

void glShadeModel(int mode)

glTexCoordPointer

void glTexCoordPointer(int size,
                       int type,
                       int stride,
                       java.nio.Buffer pointer)

glTexEnvf

void glTexEnvf(int target,
               int pname,
               float param)

glTexEnvfv

void glTexEnvfv(int target,
                int pname,
                float[] params,
                int offset)

glTexEnvfv

void glTexEnvfv(int target,
                int pname,
                java.nio.FloatBuffer params)

glTranslatef

void glTranslatef(float x,
                  float y,
                  float z)

glVertexPointer

void glVertexPointer(int size,
                     int type,
                     int stride,
                     java.nio.Buffer pointer)

glPolygonMode

void glPolygonMode(int face,
                   int mode)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.graphics.GL10 (libgdx API)

Uses of Interface
com.badlogic.gdx.graphics.GL10

Packages that use GL10
com.badlogic.gdx
com.badlogic.gdx.graphics

Uses of GL10 in com.badlogic.gdx

Fields in com.badlogic.gdx declared as GL10
static GL10 Gdx.gl10

Methods in com.badlogic.gdx that return GL10
 GL10 Graphics.getGL10()

Uses of GL10 in com.badlogic.gdx.graphics

Subinterfaces of GL10 in com.badlogic.gdx.graphics
 interface GL11
Interface wrapping all OpenGL ES 1.1 methods.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


GL11 (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Interface GL11

All Superinterfaces:
GL10, GLCommon
public interface GL11
extends GL10

Interface wrapping all OpenGL ES 1.1 methods. This interface inherits all the methods from GL10. Note that this excludes all fixed point methods!

Author:
mzechner

Field Summary
static int | GL_ACTIVE_TEXTURE
static int | GL_ADD_SIGNED
static int | GL_ALPHA_SCALE
static int | GL_ALPHA_TEST_FUNC
static int | GL_ALPHA_TEST_REF
static int | GL_ARRAY_BUFFER
static int | GL_ARRAY_BUFFER_BINDING
static int | GL_BLEND_DST
static int | GL_BLEND_SRC
static int | GL_BUFFER_SIZE
static int | GL_BUFFER_USAGE
static int | GL_CLIENT_ACTIVE_TEXTURE
static int | GL_CLIP_PLANE0
static int | GL_CLIP_PLANE1
static int | GL_CLIP_PLANE2
static int | GL_CLIP_PLANE3
static int | GL_CLIP_PLANE4
static int | GL_CLIP_PLANE5
static int | GL_COLOR_ARRAY_BUFFER_BINDING
static int | GL_COLOR_ARRAY_POINTER
static int | GL_COLOR_ARRAY_SIZE
static int | GL_COLOR_ARRAY_STRIDE
static int | GL_COLOR_ARRAY_TYPE
static int | GL_COLOR_CLEAR_VALUE
static int | GL_COLOR_WRITEMASK
static int | GL_COMBINE
static int | GL_COMBINE_ALPHA
static int | GL_COMBINE_RGB
static int | GL_CONSTANT
static int | GL_COORD_REPLACE_OES
static int | GL_CULL_FACE_MODE
static int | GL_CURRENT_COLOR
static int | GL_CURRENT_NORMAL
static int | GL_CURRENT_TEXTURE_COORDS
static int | GL_DEPTH_CLEAR_VALUE
static int | GL_DEPTH_FUNC
static int | GL_DEPTH_RANGE
static int | GL_DEPTH_WRITEMASK
static int | GL_DOT3_RGB
static int | GL_DOT3_RGBA
static int | GL_DYNAMIC_DRAW
static int | GL_ELEMENT_ARRAY_BUFFER
static int | GL_ELEMENT_ARRAY_BUFFER_BINDING
static int | GL_FRONT_FACE
static int | GL_GENERATE_MIPMAP
static int | GL_GENERATE_MIPMAP_HINT
static int | GL_INTERPOLATE
static int | GL_LINE_WIDTH
static int | GL_LOGIC_OP_MODE
static int | GL_MATRIX_MODE
static int | GL_MAX_CLIP_PLANES
static int | GL_MAX_ELEMENTS_INDICES
static int | GL_MAX_ELEMENTS_VERTICES
static int | GL_MODELVIEW_MATRIX
static int | GL_MODELVIEW_STACK_DEPTH
static int | GL_NORMAL_ARRAY_BUFFER_BINDING
static int | GL_NORMAL_ARRAY_POINTER
static int | GL_NORMAL_ARRAY_STRIDE
static int | GL_NORMAL_ARRAY_TYPE
static int | GL_OES_point_size_array
static int | GL_OES_point_sprite
static int | GL_OES_VERSION_1_0
static int | GL_OPERAND0_ALPHA
static int | GL_OPERAND0_RGB
static int | GL_OPERAND1_ALPHA
static int | GL_OPERAND1_RGB
static int | GL_OPERAND2_ALPHA
static int | GL_OPERAND2_RGB
static int | GL_POINT_DISTANCE_ATTENUATION
static int | GL_POINT_FADE_THRESHOLD_SIZE
static int | GL_POINT_SIZE
static int | GL_POINT_SIZE_ARRAY_BUFFER_BINDING_OES
static int | GL_POINT_SIZE_ARRAY_OES
static int | GL_POINT_SIZE_ARRAY_POINTER_OES
static int | GL_POINT_SIZE_ARRAY_STRIDE_OES
static int | GL_POINT_SIZE_ARRAY_TYPE_OES
static int | GL_POINT_SIZE_MAX
static int | GL_POINT_SIZE_MIN
static int | GL_POINT_SPRITE_OES
static int | GL_POLYGON_OFFSET_FACTOR
static int | GL_POLYGON_OFFSET_UNITS
static int | GL_POLYGON_SMOOTH_HINT
static int | GL_PREVIOUS
static int | GL_PRIMARY_COLOR
static int | GL_PROJECTION_MATRIX
static int | GL_PROJECTION_STACK_DEPTH
static int | GL_RGB_SCALE
static int | GL_SAMPLE_BUFFERS
static int | GL_SAMPLE_COVERAGE_INVERT
static int | GL_SAMPLE_COVERAGE_VALUE
static int | GL_SAMPLES
static int | GL_SCISSOR_BOX
static int | GL_SHADE_MODEL
static int | GL_SRC0_ALPHA
static int | GL_SRC0_RGB
static int | GL_SRC1_ALPHA
static int | GL_SRC1_RGB
static int | GL_SRC2_ALPHA
static int | GL_SRC2_RGB
static int | GL_STATIC_DRAW
static int | GL_STENCIL_CLEAR_VALUE
static int | GL_STENCIL_FAIL
static int | GL_STENCIL_FUNC
static int | GL_STENCIL_PASS_DEPTH_FAIL
static int | GL_STENCIL_PASS_DEPTH_PASS
static int | GL_STENCIL_REF
static int | GL_STENCIL_VALUE_MASK
static int | GL_STENCIL_WRITEMASK
static int | GL_SUBTRACT
static int | GL_TEXTURE_BINDING_2D
static int | GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING
static int | GL_TEXTURE_COORD_ARRAY_POINTER
static int | GL_TEXTURE_COORD_ARRAY_SIZE
static int | GL_TEXTURE_COORD_ARRAY_STRIDE
static int | GL_TEXTURE_COORD_ARRAY_TYPE
static int | GL_TEXTURE_MATRIX
static int | GL_TEXTURE_STACK_DEPTH
static int | GL_VERSION_ES_CL_1_0
static int | GL_VERSION_ES_CL_1_1
static int | GL_VERSION_ES_CM_1_0
static int | GL_VERSION_ES_CM_1_1
static int | GL_VERTEX_ARRAY_BUFFER_BINDING
static int | GL_VERTEX_ARRAY_POINTER
static int | GL_VERTEX_ARRAY_SIZE
static int | GL_VERTEX_ARRAY_STRIDE
static int | GL_VERTEX_ARRAY_TYPE
static int | GL_VIEWPORT
Fields inherited from interface com.badlogic.gdx.graphics.GL10
GL_ADD, GL_ALIASED_LINE_WIDTH_RANGE, GL_ALIASED_POINT_SIZE_RANGE, GL_ALPHA, GL_ALPHA_BITS, GL_ALPHA_TEST, GL_ALWAYS, GL_AMBIENT, GL_AMBIENT_AND_DIFFUSE, GL_AND, GL_AND_INVERTED, GL_AND_REVERSE, GL_BACK, GL_BLEND, GL_BLUE_BITS, GL_BYTE, GL_CCW, GL_CLAMP_TO_EDGE, GL_CLEAR, GL_COLOR_ARRAY, GL_COLOR_BUFFER_BIT, GL_COLOR_LOGIC_OP, GL_COLOR_MATERIAL, GL_COMPRESSED_TEXTURE_FORMATS, GL_CONSTANT_ATTENUATION, GL_COPY, GL_COPY_INVERTED, GL_CULL_FACE, GL_CW, GL_DECAL, GL_DECR, GL_DEPTH_BITS, GL_DEPTH_BUFFER_BIT, GL_DEPTH_TEST, GL_DIFFUSE, GL_DITHER, GL_DONT_CARE, GL_DST_ALPHA, GL_DST_COLOR, GL_EMISSION, GL_EQUAL, GL_EQUIV, GL_EXP, GL_EXP2, GL_EXTENSIONS, GL_FALSE, GL_FASTEST, GL_FILL, GL_FLAT, GL_FLOAT, GL_FOG, GL_FOG_COLOR, GL_FOG_DENSITY, GL_FOG_END, GL_FOG_HINT, GL_FOG_MODE, GL_FOG_START, GL_FRONT, GL_FRONT_AND_BACK, GL_GEQUAL, GL_GREATER, GL_GREEN_BITS, GL_IMPLEMENTATION_COLOR_READ_FORMAT_OES, GL_IMPLEMENTATION_COLOR_READ_TYPE_OES, GL_INCR, GL_INVALID_ENUM, GL_INVALID_OPERATION, GL_INVALID_VALUE, GL_INVERT, GL_KEEP, GL_LEQUAL, GL_LESS, GL_LIGHT_MODEL_AMBIENT, GL_LIGHT_MODEL_TWO_SIDE, GL_LIGHT0, GL_LIGHT1, GL_LIGHT2, GL_LIGHT3, GL_LIGHT4, GL_LIGHT5, GL_LIGHT6, GL_LIGHT7, GL_LIGHTING, GL_LINE, GL_LINE_LOOP, GL_LINE_SMOOTH, GL_LINE_SMOOTH_HINT, GL_LINE_STRIP, GL_LINEAR, GL_LINEAR_ATTENUATION, GL_LINEAR_MIPMAP_LINEAR, GL_LINEAR_MIPMAP_NEAREST, GL_LINES, GL_LUMINANCE, GL_LUMINANCE_ALPHA, GL_MAX_LIGHTS, GL_MAX_MODELVIEW_STACK_DEPTH, GL_MAX_PROJECTION_STACK_DEPTH, GL_MAX_TEXTURE_SIZE, GL_MAX_TEXTURE_STACK_DEPTH, GL_MAX_TEXTURE_UNITS, GL_MAX_VIEWPORT_DIMS, GL_MODELVIEW, GL_MODULATE, GL_MULTISAMPLE, GL_NAND, GL_NEAREST, GL_NEAREST_MIPMAP_LINEAR, GL_NEAREST_MIPMAP_NEAREST, GL_NEVER, GL_NICEST, GL_NO_ERROR, GL_NOOP, GL_NOR, GL_NORMAL_ARRAY, GL_NORMALIZE, GL_NOTEQUAL, GL_NUM_COMPRESSED_TEXTURE_FORMATS, GL_OES_compressed_paletted_texture, GL_OES_read_format, GL_ONE, GL_ONE_MINUS_DST_ALPHA, GL_ONE_MINUS_DST_COLOR, GL_ONE_MINUS_SRC_ALPHA, GL_ONE_MINUS_SRC_COLOR, GL_OR, GL_OR_INVERTED, GL_OR_REVERSE, GL_OUT_OF_MEMORY, GL_PACK_ALIGNMENT, GL_PALETTE4_R5_G6_B5_OES, GL_PALETTE4_RGB5_A1_OES, GL_PALETTE4_RGB8_OES, GL_PALETTE4_RGBA4_OES, GL_PALETTE4_RGBA8_OES, GL_PALETTE8_R5_G6_B5_OES, GL_PALETTE8_RGB5_A1_OES, GL_PALETTE8_RGB8_OES, GL_PALETTE8_RGBA4_OES, GL_PALETTE8_RGBA8_OES, GL_PERSPECTIVE_CORRECTION_HINT, GL_POINT, GL_POINT_SMOOTH, GL_POINT_SMOOTH_HINT, GL_POINTS, GL_POLYGON_OFFSET_FILL, GL_POSITION, GL_PROJECTION, GL_QUADRATIC_ATTENUATION, GL_RED_BITS, GL_RENDERER, GL_REPEAT, GL_REPLACE, GL_RESCALE_NORMAL, GL_RGB, GL_RGBA, GL_SAMPLE_ALPHA_TO_COVERAGE, GL_SAMPLE_ALPHA_TO_ONE, GL_SAMPLE_COVERAGE, GL_SCISSOR_TEST, GL_SET, GL_SHININESS, GL_SHORT, GL_SMOOTH, GL_SMOOTH_LINE_WIDTH_RANGE, GL_SMOOTH_POINT_SIZE_RANGE, GL_SPECULAR, GL_SPOT_CUTOFF, GL_SPOT_DIRECTION, GL_SPOT_EXPONENT, GL_SRC_ALPHA, GL_SRC_ALPHA_SATURATE, GL_SRC_COLOR, GL_STACK_OVERFLOW, GL_STACK_UNDERFLOW, GL_STENCIL_BITS, GL_STENCIL_BUFFER_BIT, GL_STENCIL_TEST, GL_SUBPIXEL_BITS, GL_TEXTURE, GL_TEXTURE_2D, GL_TEXTURE_COORD_ARRAY, GL_TEXTURE_ENV, GL_TEXTURE_ENV_COLOR, GL_TEXTURE_ENV_MODE, GL_TEXTURE_MAG_FILTER, GL_TEXTURE_MIN_FILTER, GL_TEXTURE_WRAP_S, GL_TEXTURE_WRAP_T, GL_TEXTURE0, GL_TEXTURE1, GL_TEXTURE10, GL_TEXTURE11, GL_TEXTURE12, GL_TEXTURE13, GL_TEXTURE14, GL_TEXTURE15, GL_TEXTURE16, GL_TEXTURE17, GL_TEXTURE18, GL_TEXTURE19, GL_TEXTURE2, GL_TEXTURE20, GL_TEXTURE21, GL_TEXTURE22, GL_TEXTURE23, GL_TEXTURE24, GL_TEXTURE25, GL_TEXTURE26, GL_TEXTURE27, GL_TEXTURE28, GL_TEXTURE29, GL_TEXTURE3, GL_TEXTURE30, GL_TEXTURE31, GL_TEXTURE4, GL_TEXTURE5, GL_TEXTURE6, GL_TEXTURE7, GL_TEXTURE8, GL_TEXTURE9, GL_TRIANGLE_FAN, GL_TRIANGLE_STRIP, GL_TRIANGLES, GL_TRUE, GL_UNPACK_ALIGNMENT, GL_UNSIGNED_BYTE, GL_UNSIGNED_SHORT, GL_UNSIGNED_SHORT_4_4_4_4, GL_UNSIGNED_SHORT_5_5_5_1, GL_UNSIGNED_SHORT_5_6_5, GL_VENDOR, GL_VERSION, GL_VERTEX_ARRAY, GL_XOR, GL_ZERO
Method Summary
void | glBindBuffer(int target, int buffer)
void | glBufferData(int target, int size, java.nio.Buffer data, int usage)
void | glBufferSubData(int target, int offset, int size, java.nio.Buffer data)
void | glClipPlanef(int plane, float[] equation, int offset)
void | glClipPlanef(int plane, java.nio.FloatBuffer equation)
void | glColor4ub(byte red, byte green, byte blue, byte alpha)
void | glColorPointer(int size, int type, int stride, int pointer)
void | glDeleteBuffers(int n, int[] buffers, int offset)
void | glDeleteBuffers(int n, java.nio.IntBuffer buffers)
void | glDrawElements(int mode, int count, int type, int indices)
void | glGenBuffers(int n, int[] buffers, int offset)
void | glGenBuffers(int n, java.nio.IntBuffer buffers)
void | glGetBooleanv(int pname, boolean[] params, int offset)
void | glGetBooleanv(int pname, java.nio.IntBuffer params)
void | glGetBufferParameteriv(int target, int pname, int[] params, int offset)
void | glGetBufferParameteriv(int target, int pname, java.nio.IntBuffer params)
void | glGetClipPlanef(int pname, float[] eqn, int offset)
void | glGetClipPlanef(int pname, java.nio.FloatBuffer eqn)
void | glGetFloatv(int pname, float[] params, int offset)
void | glGetFloatv(int pname, java.nio.FloatBuffer params)
void | glGetLightfv(int light, int pname, float[] params, int offset)
void | glGetLightfv(int light, int pname, java.nio.FloatBuffer params)
void | glGetMaterialfv(int face, int pname, float[] params, int offset)
void | glGetMaterialfv(int face, int pname, java.nio.FloatBuffer params)
void | glGetPointerv(int pname, java.nio.Buffer[] params)
void | glGetTexEnviv(int env, int pname, int[] params, int offset)
void | glGetTexEnviv(int env, int pname, java.nio.IntBuffer params)
void | glGetTexParameterfv(int target, int pname, float[] params, int offset)
void | glGetTexParameterfv(int target, int pname, java.nio.FloatBuffer params)
void | glGetTexParameteriv(int target, int pname, int[] params, int offset)
void | glGetTexParameteriv(int target, int pname, java.nio.IntBuffer params)
boolean | glIsBuffer(int buffer)
boolean | glIsEnabled(int cap)
boolean | glIsTexture(int texture)
void | glNormalPointer(int type, int stride, int pointer)
void | glPointParameterf(int pname, float param)
void | glPointParameterfv(int pname, float[] params, int offset)
void | glPointParameterfv(int pname, java.nio.FloatBuffer params)
void | glPointSizePointerOES(int type, int stride, java.nio.Buffer pointer)
void | glTexCoordPointer(int size, int type, int stride, int pointer)
void | glTexEnvi(int target, int pname, int param)
void | glTexEnviv(int target, int pname, int[] params, int offset)
void | glTexEnviv(int target, int pname, java.nio.IntBuffer params)
void | glTexParameterfv(int target, int pname, float[] params, int offset)
void | glTexParameterfv(int target, int pname, java.nio.FloatBuffer params)
void | glTexParameteri(int target, int pname, int param)
void | glTexParameteriv(int target, int pname, int[] params, int offset)
void | glTexParameteriv(int target, int pname, java.nio.IntBuffer params)
void | glVertexPointer(int size, int type, int stride, int pointer)
Methods inherited from interface com.badlogic.gdx.graphics.GL10
glAlphaFunc, glClientActiveTexture, glColor4f, glColorPointer, glDeleteTextures, glDisableClientState, glEnableClientState, glFogf, glFogfv, glFogfv, glFrustumf, glGenTextures, glGetIntegerv, glLightf, glLightfv, glLightfv, glLightModelf, glLightModelfv, glLightModelfv, glLoadIdentity, glLoadMatrixf, glLoadMatrixf, glLogicOp, glMaterialf, glMaterialfv, glMaterialfv, glMatrixMode, glMultiTexCoord4f, glMultMatrixf, glMultMatrixf, glNormal3f, glNormalPointer, glOrthof, glPointSize, glPolygonMode, glPopMatrix, glPushMatrix, glRotatef, glSampleCoverage, glScalef, glShadeModel, glTexCoordPointer, glTexEnvf, glTexEnvfv, glTexEnvfv, glTranslatef, glVertexPointer
Methods inherited from interface com.badlogic.gdx.graphics.GLCommon
glActiveTexture, glBindTexture, glBlendFunc, glClear, glClearColor, glClearDepthf, glClearStencil, glColorMask, glCompressedTexImage2D, glCompressedTexSubImage2D, glCopyTexImage2D, glCopyTexSubImage2D, glCullFace, glDeleteTextures, glDepthFunc, glDepthMask, glDepthRangef, glDisable, glDrawArrays, glDrawElements, glEnable, glFinish, glFlush, glFrontFace, glGenTextures, glGetError, glGetIntegerv, glGetString, glHint, glLineWidth, glPixelStorei, glPolygonOffset, glReadPixels, glScissor, glStencilFunc, glStencilMask, glStencilOp, glTexImage2D, glTexParameterf, glTexSubImage2D, glViewport

Field Detail

GL_OES_VERSION_1_0

static final int GL_OES_VERSION_1_0
See Also:
Constant Field Values

GL_MAX_ELEMENTS_VERTICES

static final int GL_MAX_ELEMENTS_VERTICES
See Also:
Constant Field Values

GL_MAX_ELEMENTS_INDICES

static final int GL_MAX_ELEMENTS_INDICES
See Also:
Constant Field Values

GL_POLYGON_SMOOTH_HINT

static final int GL_POLYGON_SMOOTH_HINT
See Also:
Constant Field Values

GL_VERSION_ES_CM_1_0

static final int GL_VERSION_ES_CM_1_0
See Also:
Constant Field Values

GL_VERSION_ES_CL_1_0

static final int GL_VERSION_ES_CL_1_0
See Also:
Constant Field Values

GL_VERSION_ES_CM_1_1

static final int GL_VERSION_ES_CM_1_1
See Also:
Constant Field Values

GL_VERSION_ES_CL_1_1

static final int GL_VERSION_ES_CL_1_1
See Also:
Constant Field Values

GL_CLIP_PLANE0

static final int GL_CLIP_PLANE0
See Also:
Constant Field Values

GL_CLIP_PLANE1

static final int GL_CLIP_PLANE1
See Also:
Constant Field Values

GL_CLIP_PLANE2

static final int GL_CLIP_PLANE2
See Also:
Constant Field Values

GL_CLIP_PLANE3

static final int GL_CLIP_PLANE3
See Also:
Constant Field Values

GL_CLIP_PLANE4

static final int GL_CLIP_PLANE4
See Also:
Constant Field Values

GL_CLIP_PLANE5

static final int GL_CLIP_PLANE5
See Also:
Constant Field Values

GL_CURRENT_COLOR

static final int GL_CURRENT_COLOR
See Also:
Constant Field Values

GL_CURRENT_NORMAL

static final int GL_CURRENT_NORMAL
See Also:
Constant Field Values

GL_CURRENT_TEXTURE_COORDS

static final int GL_CURRENT_TEXTURE_COORDS
See Also:
Constant Field Values

GL_POINT_SIZE

static final int GL_POINT_SIZE
See Also:
Constant Field Values

GL_POINT_SIZE_MIN

static final int GL_POINT_SIZE_MIN
See Also:
Constant Field Values

GL_POINT_SIZE_MAX

static final int GL_POINT_SIZE_MAX
See Also:
Constant Field Values

GL_POINT_FADE_THRESHOLD_SIZE

static final int GL_POINT_FADE_THRESHOLD_SIZE
See Also:
Constant Field Values

GL_POINT_DISTANCE_ATTENUATION

static final int GL_POINT_DISTANCE_ATTENUATION
See Also:
Constant Field Values

GL_LINE_WIDTH

static final int GL_LINE_WIDTH
See Also:
Constant Field Values

GL_CULL_FACE_MODE

static final int GL_CULL_FACE_MODE
See Also:
Constant Field Values

GL_FRONT_FACE

static final int GL_FRONT_FACE
See Also:
Constant Field Values

GL_SHADE_MODEL

static final int GL_SHADE_MODEL
See Also:
Constant Field Values

GL_DEPTH_RANGE

static final int GL_DEPTH_RANGE
See Also:
Constant Field Values

GL_DEPTH_WRITEMASK

static final int GL_DEPTH_WRITEMASK
See Also:
Constant Field Values

GL_DEPTH_CLEAR_VALUE

static final int GL_DEPTH_CLEAR_VALUE
See Also:
Constant Field Values

GL_DEPTH_FUNC

static final int GL_DEPTH_FUNC
See Also:
Constant Field Values

GL_STENCIL_CLEAR_VALUE

static final int GL_STENCIL_CLEAR_VALUE
See Also:
Constant Field Values

GL_STENCIL_FUNC

static final int GL_STENCIL_FUNC
See Also:
Constant Field Values

GL_STENCIL_VALUE_MASK

static final int GL_STENCIL_VALUE_MASK
See Also:
Constant Field Values

GL_STENCIL_FAIL

static final int GL_STENCIL_FAIL
See Also:
Constant Field Values

GL_STENCIL_PASS_DEPTH_FAIL

static final int GL_STENCIL_PASS_DEPTH_FAIL
See Also:
Constant Field Values

GL_STENCIL_PASS_DEPTH_PASS

static final int GL_STENCIL_PASS_DEPTH_PASS
See Also:
Constant Field Values

GL_STENCIL_REF

static final int GL_STENCIL_REF
See Also:
Constant Field Values

GL_STENCIL_WRITEMASK

static final int GL_STENCIL_WRITEMASK
See Also:
Constant Field Values

GL_MATRIX_MODE

static final int GL_MATRIX_MODE
See Also:
Constant Field Values

GL_VIEWPORT

static final int GL_VIEWPORT
See Also:
Constant Field Values

GL_MODELVIEW_STACK_DEPTH

static final int GL_MODELVIEW_STACK_DEPTH
See Also:
Constant Field Values

GL_PROJECTION_STACK_DEPTH

static final int GL_PROJECTION_STACK_DEPTH
See Also:
Constant Field Values

GL_TEXTURE_STACK_DEPTH

static final int GL_TEXTURE_STACK_DEPTH
See Also:
Constant Field Values

GL_MODELVIEW_MATRIX

static final int GL_MODELVIEW_MATRIX
See Also:
Constant Field Values

GL_PROJECTION_MATRIX

static final int GL_PROJECTION_MATRIX
See Also:
Constant Field Values

GL_TEXTURE_MATRIX

static final int GL_TEXTURE_MATRIX
See Also:
Constant Field Values

GL_ALPHA_TEST_FUNC

static final int GL_ALPHA_TEST_FUNC
See Also:
Constant Field Values

GL_ALPHA_TEST_REF

static final int GL_ALPHA_TEST_REF
See Also:
Constant Field Values

GL_BLEND_DST

static final int GL_BLEND_DST
See Also:
Constant Field Values

GL_BLEND_SRC

static final int GL_BLEND_SRC
See Also:
Constant Field Values

GL_LOGIC_OP_MODE

static final int GL_LOGIC_OP_MODE
See Also:
Constant Field Values

GL_SCISSOR_BOX

static final int GL_SCISSOR_BOX
See Also:
Constant Field Values

GL_COLOR_CLEAR_VALUE

static final int GL_COLOR_CLEAR_VALUE
See Also:
Constant Field Values

GL_COLOR_WRITEMASK

static final int GL_COLOR_WRITEMASK
See Also:
Constant Field Values

GL_MAX_CLIP_PLANES

static final int GL_MAX_CLIP_PLANES
See Also:
Constant Field Values

GL_POLYGON_OFFSET_UNITS

static final int GL_POLYGON_OFFSET_UNITS
See Also:
Constant Field Values

GL_POLYGON_OFFSET_FACTOR

static final int GL_POLYGON_OFFSET_FACTOR
See Also:
Constant Field Values

GL_TEXTURE_BINDING_2D

static final int GL_TEXTURE_BINDING_2D
See Also:
Constant Field Values

GL_VERTEX_ARRAY_SIZE

static final int GL_VERTEX_ARRAY_SIZE
See Also:
Constant Field Values

GL_VERTEX_ARRAY_TYPE

static final int GL_VERTEX_ARRAY_TYPE
See Also:
Constant Field Values

GL_VERTEX_ARRAY_STRIDE

static final int GL_VERTEX_ARRAY_STRIDE
See Also:
Constant Field Values

GL_NORMAL_ARRAY_TYPE

static final int GL_NORMAL_ARRAY_TYPE
See Also:
Constant Field Values

GL_NORMAL_ARRAY_STRIDE

static final int GL_NORMAL_ARRAY_STRIDE
See Also:
Constant Field Values

GL_COLOR_ARRAY_SIZE

static final int GL_COLOR_ARRAY_SIZE
See Also:
Constant Field Values

GL_COLOR_ARRAY_TYPE

static final int GL_COLOR_ARRAY_TYPE
See Also:
Constant Field Values

GL_COLOR_ARRAY_STRIDE

static final int GL_COLOR_ARRAY_STRIDE
See Also:
Constant Field Values

GL_TEXTURE_COORD_ARRAY_SIZE

static final int GL_TEXTURE_COORD_ARRAY_SIZE
See Also:
Constant Field Values

GL_TEXTURE_COORD_ARRAY_TYPE

static final int GL_TEXTURE_COORD_ARRAY_TYPE
See Also:
Constant Field Values

GL_TEXTURE_COORD_ARRAY_STRIDE

static final int GL_TEXTURE_COORD_ARRAY_STRIDE
See Also:
Constant Field Values

GL_VERTEX_ARRAY_POINTER

static final int GL_VERTEX_ARRAY_POINTER
See Also:
Constant Field Values

GL_NORMAL_ARRAY_POINTER

static final int GL_NORMAL_ARRAY_POINTER
See Also:
Constant Field Values

GL_COLOR_ARRAY_POINTER

static final int GL_COLOR_ARRAY_POINTER
See Also:
Constant Field Values

GL_TEXTURE_COORD_ARRAY_POINTER

static final int GL_TEXTURE_COORD_ARRAY_POINTER
See Also:
Constant Field Values

GL_SAMPLE_BUFFERS

static final int GL_SAMPLE_BUFFERS
See Also:
Constant Field Values

GL_SAMPLES

static final int GL_SAMPLES
See Also:
Constant Field Values

GL_SAMPLE_COVERAGE_VALUE

static final int GL_SAMPLE_COVERAGE_VALUE
See Also:
Constant Field Values

GL_SAMPLE_COVERAGE_INVERT

static final int GL_SAMPLE_COVERAGE_INVERT
See Also:
Constant Field Values

GL_GENERATE_MIPMAP_HINT

static final int GL_GENERATE_MIPMAP_HINT
See Also:
Constant Field Values

GL_GENERATE_MIPMAP

static final int GL_GENERATE_MIPMAP
See Also:
Constant Field Values

GL_ACTIVE_TEXTURE

static final int GL_ACTIVE_TEXTURE
See Also:
Constant Field Values

GL_CLIENT_ACTIVE_TEXTURE

static final int GL_CLIENT_ACTIVE_TEXTURE
See Also:
Constant Field Values

GL_ARRAY_BUFFER

static final int GL_ARRAY_BUFFER
See Also:
Constant Field Values

GL_ELEMENT_ARRAY_BUFFER

static final int GL_ELEMENT_ARRAY_BUFFER
See Also:
Constant Field Values

GL_ARRAY_BUFFER_BINDING

static final int GL_ARRAY_BUFFER_BINDING
See Also:
Constant Field Values

GL_ELEMENT_ARRAY_BUFFER_BINDING

static final int GL_ELEMENT_ARRAY_BUFFER_BINDING
See Also:
Constant Field Values

GL_VERTEX_ARRAY_BUFFER_BINDING

static final int GL_VERTEX_ARRAY_BUFFER_BINDING
See Also:
Constant Field Values

GL_NORMAL_ARRAY_BUFFER_BINDING

static final int GL_NORMAL_ARRAY_BUFFER_BINDING
See Also:
Constant Field Values

GL_COLOR_ARRAY_BUFFER_BINDING

static final int GL_COLOR_ARRAY_BUFFER_BINDING
See Also:
Constant Field Values

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING

static final int GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING
See Also:
Constant Field Values

GL_STATIC_DRAW

static final int GL_STATIC_DRAW
See Also:
Constant Field Values

GL_DYNAMIC_DRAW

static final int GL_DYNAMIC_DRAW
See Also:
Constant Field Values

GL_BUFFER_SIZE

static final int GL_BUFFER_SIZE
See Also:
Constant Field Values

GL_BUFFER_USAGE

static final int GL_BUFFER_USAGE
See Also:
Constant Field Values

GL_SUBTRACT

static final int GL_SUBTRACT
See Also:
Constant Field Values

GL_COMBINE

static final int GL_COMBINE
See Also:
Constant Field Values

GL_COMBINE_RGB

static final int GL_COMBINE_RGB
See Also:
Constant Field Values

GL_COMBINE_ALPHA

static final int GL_COMBINE_ALPHA
See Also:
Constant Field Values

GL_RGB_SCALE

static final int GL_RGB_SCALE
See Also:
Constant Field Values

GL_ADD_SIGNED

static final int GL_ADD_SIGNED
See Also:
Constant Field Values

GL_INTERPOLATE

static final int GL_INTERPOLATE
See Also:
Constant Field Values

GL_CONSTANT

static final int GL_CONSTANT
See Also:
Constant Field Values

GL_PRIMARY_COLOR

static final int GL_PRIMARY_COLOR
See Also:
Constant Field Values

GL_PREVIOUS

static final int GL_PREVIOUS
See Also:
Constant Field Values

GL_OPERAND0_RGB

static final int GL_OPERAND0_RGB
See Also:
Constant Field Values

GL_OPERAND1_RGB

static final int GL_OPERAND1_RGB
See Also:
Constant Field Values

GL_OPERAND2_RGB

static final int GL_OPERAND2_RGB
See Also:
Constant Field Values

GL_OPERAND0_ALPHA

static final int GL_OPERAND0_ALPHA
See Also:
Constant Field Values

GL_OPERAND1_ALPHA

static final int GL_OPERAND1_ALPHA
See Also:
Constant Field Values

GL_OPERAND2_ALPHA

static final int GL_OPERAND2_ALPHA
See Also:
Constant Field Values

GL_ALPHA_SCALE

static final int GL_ALPHA_SCALE
See Also:
Constant Field Values

GL_SRC0_RGB

static final int GL_SRC0_RGB
See Also:
Constant Field Values

GL_SRC1_RGB

static final int GL_SRC1_RGB
See Also:
Constant Field Values

GL_SRC2_RGB

static final int GL_SRC2_RGB
See Also:
Constant Field Values

GL_SRC0_ALPHA

static final int GL_SRC0_ALPHA
See Also:
Constant Field Values

GL_SRC1_ALPHA

static final int GL_SRC1_ALPHA
See Also:
Constant Field Values

GL_SRC2_ALPHA

static final int GL_SRC2_ALPHA
See Also:
Constant Field Values

GL_DOT3_RGB

static final int GL_DOT3_RGB
See Also:
Constant Field Values

GL_DOT3_RGBA

static final int GL_DOT3_RGBA
See Also:
Constant Field Values

GL_POINT_SIZE_ARRAY_OES

static final int GL_POINT_SIZE_ARRAY_OES
See Also:
Constant Field Values

GL_POINT_SIZE_ARRAY_TYPE_OES

static final int GL_POINT_SIZE_ARRAY_TYPE_OES
See Also:
Constant Field Values

GL_POINT_SIZE_ARRAY_STRIDE_OES

static final int GL_POINT_SIZE_ARRAY_STRIDE_OES
See Also:
Constant Field Values

GL_POINT_SIZE_ARRAY_POINTER_OES

static final int GL_POINT_SIZE_ARRAY_POINTER_OES
See Also:
Constant Field Values

GL_POINT_SIZE_ARRAY_BUFFER_BINDING_OES

static final int GL_POINT_SIZE_ARRAY_BUFFER_BINDING_OES
See Also:
Constant Field Values

GL_POINT_SPRITE_OES

static final int GL_POINT_SPRITE_OES
See Also:
Constant Field Values

GL_COORD_REPLACE_OES

static final int GL_COORD_REPLACE_OES
See Also:
Constant Field Values

GL_OES_point_size_array

static final int GL_OES_point_size_array
See Also:
Constant Field Values

GL_OES_point_sprite

static final int GL_OES_point_sprite
See Also:
Constant Field Values
Method Detail

glClipPlanef

void glClipPlanef(int plane,
                  float[] equation,
                  int offset)

glClipPlanef

void glClipPlanef(int plane,
                  java.nio.FloatBuffer equation)

glGetClipPlanef

void glGetClipPlanef(int pname,
                     float[] eqn,
                     int offset)

glGetClipPlanef

void glGetClipPlanef(int pname,
                     java.nio.FloatBuffer eqn)

glGetFloatv

void glGetFloatv(int pname,
                 float[] params,
                 int offset)

glGetFloatv

void glGetFloatv(int pname,
                 java.nio.FloatBuffer params)

glGetLightfv

void glGetLightfv(int light,
                  int pname,
                  float[] params,
                  int offset)

glGetLightfv

void glGetLightfv(int light,
                  int pname,
                  java.nio.FloatBuffer params)

glGetMaterialfv

void glGetMaterialfv(int face,
                     int pname,
                     float[] params,
                     int offset)

glGetMaterialfv

void glGetMaterialfv(int face,
                     int pname,
                     java.nio.FloatBuffer params)

glGetTexParameterfv

void glGetTexParameterfv(int target,
                         int pname,
                         float[] params,
                         int offset)

glGetTexParameterfv

void glGetTexParameterfv(int target,
                         int pname,
                         java.nio.FloatBuffer params)

glPointParameterf

void glPointParameterf(int pname,
                       float param)

glPointParameterfv

void glPointParameterfv(int pname,
                        float[] params,
                        int offset)

glPointParameterfv

void glPointParameterfv(int pname,
                        java.nio.FloatBuffer params)

glTexParameterfv

void glTexParameterfv(int target,
                      int pname,
                      float[] params,
                      int offset)

glTexParameterfv

void glTexParameterfv(int target,
                      int pname,
                      java.nio.FloatBuffer params)

glBindBuffer

void glBindBuffer(int target,
                  int buffer)

glBufferData

void glBufferData(int target,
                  int size,
                  java.nio.Buffer data,
                  int usage)

glBufferSubData

void glBufferSubData(int target,
                     int offset,
                     int size,
                     java.nio.Buffer data)

glColor4ub

void glColor4ub(byte red,
                byte green,
                byte blue,
                byte alpha)

glDeleteBuffers

void glDeleteBuffers(int n,
                     int[] buffers,
                     int offset)

glDeleteBuffers

void glDeleteBuffers(int n,
                     java.nio.IntBuffer buffers)

glGetBooleanv

void glGetBooleanv(int pname,
                   boolean[] params,
                   int offset)

glGetBooleanv

void glGetBooleanv(int pname,
                   java.nio.IntBuffer params)

glGetBufferParameteriv

void glGetBufferParameteriv(int target,
                            int pname,
                            int[] params,
                            int offset)

glGetBufferParameteriv

void glGetBufferParameteriv(int target,
                            int pname,
                            java.nio.IntBuffer params)

glGenBuffers

void glGenBuffers(int n,
                  int[] buffers,
                  int offset)

glGenBuffers

void glGenBuffers(int n,
                  java.nio.IntBuffer buffers)

glGetPointerv

void glGetPointerv(int pname,
                   java.nio.Buffer[] params)

glGetTexEnviv

void glGetTexEnviv(int env,
                   int pname,
                   int[] params,
                   int offset)

glGetTexEnviv

void glGetTexEnviv(int env,
                   int pname,
                   java.nio.IntBuffer params)

glGetTexParameteriv

void glGetTexParameteriv(int target,
                         int pname,
                         int[] params,
                         int offset)

glGetTexParameteriv

void glGetTexParameteriv(int target,
                         int pname,
                         java.nio.IntBuffer params)

glIsBuffer

boolean glIsBuffer(int buffer)

glIsEnabled

boolean glIsEnabled(int cap)

glIsTexture

boolean glIsTexture(int texture)

glTexEnvi

void glTexEnvi(int target,
               int pname,
               int param)

glTexEnviv

void glTexEnviv(int target,
                int pname,
                int[] params,
                int offset)

glTexEnviv

void glTexEnviv(int target,
                int pname,
                java.nio.IntBuffer params)

glTexParameteri

void glTexParameteri(int target,
                     int pname,
                     int param)

glTexParameteriv

void glTexParameteriv(int target,
                      int pname,
                      int[] params,
                      int offset)

glTexParameteriv

void glTexParameteriv(int target,
                      int pname,
                      java.nio.IntBuffer params)

glPointSizePointerOES

void glPointSizePointerOES(int type,
                           int stride,
                           java.nio.Buffer pointer)

glVertexPointer

void glVertexPointer(int size,
                     int type,
                     int stride,
                     int pointer)

glColorPointer

void glColorPointer(int size,
                    int type,
                    int stride,
                    int pointer)

glNormalPointer

void glNormalPointer(int type,
                     int stride,
                     int pointer)

glTexCoordPointer

void glTexCoordPointer(int size,
                       int type,
                       int stride,
                       int pointer)

glDrawElements

void glDrawElements(int mode,
                    int count,
                    int type,
                    int indices)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.graphics.GL11 (libgdx API)

Uses of Interface
com.badlogic.gdx.graphics.GL11

Packages that use GL11
com.badlogic.gdx

Uses of GL11 in com.badlogic.gdx

Fields in com.badlogic.gdx declared as GL11
static GL11 Gdx.gl11

Methods in com.badlogic.gdx that return GL11
 GL11 Graphics.getGL11()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


GL20 (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Interface GL20

All Superinterfaces:
GLCommon
public interface GL20
extends GLCommon

Interface wrapping all the methods of OpenGL ES 2.0

Author:
mzechner

Field Summary
static int | GL_ACTIVE_ATTRIBUTE_MAX_LENGTH
static int | GL_ACTIVE_ATTRIBUTES
static int | GL_ACTIVE_TEXTURE
static int | GL_ACTIVE_UNIFORM_MAX_LENGTH
static int | GL_ACTIVE_UNIFORMS
static int | GL_ALIASED_LINE_WIDTH_RANGE
static int | GL_ALIASED_POINT_SIZE_RANGE
static int | GL_ALPHA
static int | GL_ALPHA_BITS
static int | GL_ALWAYS
static int | GL_ARRAY_BUFFER
static int | GL_ARRAY_BUFFER_BINDING
static int | GL_ATTACHED_SHADERS
static int | GL_BACK
static int | GL_BLEND
static int | GL_BLEND_COLOR
static int | GL_BLEND_DST_ALPHA
static int | GL_BLEND_DST_RGB
static int | GL_BLEND_EQUATION
static int | GL_BLEND_EQUATION_ALPHA
static int | GL_BLEND_EQUATION_RGB
static int | GL_BLEND_SRC_ALPHA
static int | GL_BLEND_SRC_RGB
static int | GL_BLUE_BITS
static int | GL_BOOL
static int | GL_BOOL_VEC2
static int | GL_BOOL_VEC3
static int | GL_BOOL_VEC4
static int | GL_BUFFER_SIZE
static int | GL_BUFFER_USAGE
static int | GL_BYTE
static int | GL_CCW
static int | GL_CLAMP_TO_EDGE
static int | GL_COLOR_ATTACHMENT0
static int | GL_COLOR_BUFFER_BIT
static int | GL_COLOR_CLEAR_VALUE
static int | GL_COLOR_WRITEMASK
static int | GL_COMPILE_STATUS
static int | GL_COMPRESSED_TEXTURE_FORMATS
static int | GL_CONSTANT_ALPHA
static int | GL_CONSTANT_COLOR
static int | GL_CULL_FACE
static int | GL_CULL_FACE_MODE
static int | GL_CURRENT_PROGRAM
static int | GL_CURRENT_VERTEX_ATTRIB
static int | GL_CW
static int | GL_DECR
static int | GL_DECR_WRAP
static int | GL_DELETE_STATUS
static int | GL_DEPTH_ATTACHMENT
static int | GL_DEPTH_BITS
static int | GL_DEPTH_BUFFER_BIT
static int | GL_DEPTH_CLEAR_VALUE
static int | GL_DEPTH_COMPONENT
static int | GL_DEPTH_COMPONENT16
static int | GL_DEPTH_FUNC
static int | GL_DEPTH_RANGE
static int | GL_DEPTH_TEST
static int | GL_DEPTH_WRITEMASK
static int | GL_DITHER
static int | GL_DONT_CARE
static int | GL_DST_ALPHA
static int | GL_DST_COLOR
static int | GL_DYNAMIC_DRAW
static int | GL_ELEMENT_ARRAY_BUFFER
static int | GL_ELEMENT_ARRAY_BUFFER_BINDING
static int | GL_EQUAL
static int | GL_ES_VERSION_2_0
static int | GL_EXTENSIONS
static int | GL_FALSE
static int | GL_FASTEST
static int | GL_FIXED
static int | GL_FLOAT
static int | GL_FLOAT_MAT2
static int | GL_FLOAT_MAT3
static int | GL_FLOAT_MAT4
static int | GL_FLOAT_VEC2
static int | GL_FLOAT_VEC3
static int | GL_FLOAT_VEC4
static int | GL_FRAGMENT_SHADER
static int | GL_FRAMEBUFFER
static int | GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME
static int | GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE
static int | GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE
static int | GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL
static int | GL_FRAMEBUFFER_BINDING
static int | GL_FRAMEBUFFER_COMPLETE
static int | GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
static int | GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS
static int | GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT
static int | GL_FRAMEBUFFER_UNSUPPORTED
static int | GL_FRONT
static int | GL_FRONT_AND_BACK
static int | GL_FRONT_FACE
static int | GL_FUNC_ADD
static int | GL_FUNC_REVERSE_SUBTRACT
static int | GL_FUNC_SUBTRACT
static int | GL_GENERATE_MIPMAP_HINT
static int | GL_GEQUAL
static int | GL_GREATER
static int | GL_GREEN_BITS
static int | GL_HIGH_FLOAT
static int | GL_HIGH_INT
static int | GL_IMPLEMENTATION_COLOR_READ_FORMAT
static int | GL_IMPLEMENTATION_COLOR_READ_TYPE
static int | GL_INCR
static int | GL_INCR_WRAP
static int | GL_INFO_LOG_LENGTH
static int | GL_INT
static int | GL_INT_VEC2
static int | GL_INT_VEC3
static int | GL_INT_VEC4
static int | GL_INVALID_ENUM
static int | GL_INVALID_FRAMEBUFFER_OPERATION
static int | GL_INVALID_OPERATION
static int | GL_INVALID_VALUE
static int | GL_INVERT
static int | GL_KEEP
static int | GL_LEQUAL
static int | GL_LESS
static int | GL_LINE_LOOP
static int | GL_LINE_STRIP
static int | GL_LINE_WIDTH
static int | GL_LINEAR
static int | GL_LINEAR_MIPMAP_LINEAR
static int | GL_LINEAR_MIPMAP_NEAREST
static int | GL_LINES
static int | GL_LINK_STATUS
static int | GL_LOW_FLOAT
static int | GL_LOW_INT
static int | GL_LUMINANCE
static int | GL_LUMINANCE_ALPHA
static int | GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS
static int | GL_MAX_CUBE_MAP_TEXTURE_SIZE
static int | GL_MAX_FRAGMENT_UNIFORM_VECTORS
static int | GL_MAX_RENDERBUFFER_SIZE
static int | GL_MAX_TEXTURE_IMAGE_UNITS
static int | GL_MAX_TEXTURE_SIZE
static int | GL_MAX_VARYING_VECTORS
static int | GL_MAX_VERTEX_ATTRIBS
static int | GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS
static int | GL_MAX_VERTEX_UNIFORM_VECTORS
static int | GL_MAX_VIEWPORT_DIMS
static int | GL_MEDIUM_FLOAT
static int | GL_MEDIUM_INT
static int | GL_MIRRORED_REPEAT
static int | GL_NEAREST
static int | GL_NEAREST_MIPMAP_LINEAR
static int | GL_NEAREST_MIPMAP_NEAREST
static int | GL_NEVER
static int | GL_NICEST
static int | GL_NO_ERROR
static int | GL_NONE
static int | GL_NOTEQUAL
static int | GL_NUM_COMPRESSED_TEXTURE_FORMATS
static int | GL_NUM_SHADER_BINARY_FORMATS
static int | GL_ONE
static int | GL_ONE_MINUS_CONSTANT_ALPHA
static int | GL_ONE_MINUS_CONSTANT_COLOR
static int | GL_ONE_MINUS_DST_ALPHA
static int | GL_ONE_MINUS_DST_COLOR
static int | GL_ONE_MINUS_SRC_ALPHA
static int | GL_ONE_MINUS_SRC_COLOR
static int | GL_OUT_OF_MEMORY
static int | GL_PACK_ALIGNMENT
static int | GL_POINTS
static int | GL_POLYGON_OFFSET_FACTOR
static int | GL_POLYGON_OFFSET_FILL
static int | GL_POLYGON_OFFSET_UNITS
static int | GL_RED_BITS
static int | GL_RENDERBUFFER
static int | GL_RENDERBUFFER_ALPHA_SIZE
static int | GL_RENDERBUFFER_BINDING
static int | GL_RENDERBUFFER_BLUE_SIZE
static int | GL_RENDERBUFFER_DEPTH_SIZE
static int | GL_RENDERBUFFER_GREEN_SIZE
static int | GL_RENDERBUFFER_HEIGHT
static int | GL_RENDERBUFFER_INTERNAL_FORMAT
static int | GL_RENDERBUFFER_RED_SIZE
static int | GL_RENDERBUFFER_STENCIL_SIZE
static int | GL_RENDERBUFFER_WIDTH
static int | GL_RENDERER
static int | GL_REPEAT
static int | GL_REPLACE
static int | GL_RGB
static int | GL_RGB5_A1
static int | GL_RGB565
static int | GL_RGBA
static int | GL_RGBA4
static int | GL_SAMPLE_ALPHA_TO_COVERAGE
static int | GL_SAMPLE_BUFFERS
static int | GL_SAMPLE_COVERAGE
static int | GL_SAMPLE_COVERAGE_INVERT
static int | GL_SAMPLE_COVERAGE_VALUE
static int | GL_SAMPLER_2D
static int | GL_SAMPLER_CUBE
static int | GL_SAMPLES
static int | GL_SCISSOR_BOX
static int | GL_SCISSOR_TEST
static int | GL_SHADER_BINARY_FORMATS
static int | GL_SHADER_COMPILER
static int | GL_SHADER_SOURCE_LENGTH
static int | GL_SHADER_TYPE
static int | GL_SHADING_LANGUAGE_VERSION
static int | GL_SHORT
static int | GL_SRC_ALPHA
static int | GL_SRC_ALPHA_SATURATE
static int | GL_SRC_COLOR
static int | GL_STATIC_DRAW
static int | GL_STENCIL_ATTACHMENT
static int | GL_STENCIL_BACK_FAIL
static int | GL_STENCIL_BACK_FUNC
static int | GL_STENCIL_BACK_PASS_DEPTH_FAIL
static int | GL_STENCIL_BACK_PASS_DEPTH_PASS
static int | GL_STENCIL_BACK_REF
static int | GL_STENCIL_BACK_VALUE_MASK
static int | GL_STENCIL_BACK_WRITEMASK
static int | GL_STENCIL_BITS
static int | GL_STENCIL_BUFFER_BIT
static int | GL_STENCIL_CLEAR_VALUE
static int | GL_STENCIL_FAIL
static int | GL_STENCIL_FUNC
static int | GL_STENCIL_INDEX
static int | GL_STENCIL_INDEX8
static int | GL_STENCIL_PASS_DEPTH_FAIL
static int | GL_STENCIL_PASS_DEPTH_PASS
static int | GL_STENCIL_REF
static int | GL_STENCIL_TEST
static int | GL_STENCIL_VALUE_MASK
static int | GL_STENCIL_WRITEMASK
static int | GL_STREAM_DRAW
static int | GL_SUBPIXEL_BITS
static int | GL_TEXTURE
static int | GL_TEXTURE_2D
static int | GL_TEXTURE_BINDING_2D
static int | GL_TEXTURE_BINDING_CUBE_MAP
static int | GL_TEXTURE_CUBE_MAP
static int | GL_TEXTURE_CUBE_MAP_NEGATIVE_X
static int | GL_TEXTURE_CUBE_MAP_NEGATIVE_Y
static int | GL_TEXTURE_CUBE_MAP_NEGATIVE_Z
static int | GL_TEXTURE_CUBE_MAP_POSITIVE_X
static int | GL_TEXTURE_CUBE_MAP_POSITIVE_Y
static int | GL_TEXTURE_CUBE_MAP_POSITIVE_Z
static int | GL_TEXTURE_MAG_FILTER
static int | GL_TEXTURE_MIN_FILTER
static int | GL_TEXTURE_WRAP_S
static int | GL_TEXTURE_WRAP_T
static int | GL_TEXTURE0
static int | GL_TEXTURE1
static int | GL_TEXTURE10
static int | GL_TEXTURE11
static int | GL_TEXTURE12
static int | GL_TEXTURE13
static int | GL_TEXTURE14
static int | GL_TEXTURE15
static int | GL_TEXTURE16
static int | GL_TEXTURE17
static int | GL_TEXTURE18
static int | GL_TEXTURE19
static int | GL_TEXTURE2
static int | GL_TEXTURE20
static int | GL_TEXTURE21
static int | GL_TEXTURE22
static int | GL_TEXTURE23
static int | GL_TEXTURE24
static int | GL_TEXTURE25
static int | GL_TEXTURE26
static int | GL_TEXTURE27
static int | GL_TEXTURE28
static int | GL_TEXTURE29
static int | GL_TEXTURE3
static int | GL_TEXTURE30
static int | GL_TEXTURE31
static int | GL_TEXTURE4
static int | GL_TEXTURE5
static int | GL_TEXTURE6
static int | GL_TEXTURE7
static int | GL_TEXTURE8
static int | GL_TEXTURE9
static int | GL_TRIANGLE_FAN
static int | GL_TRIANGLE_STRIP
static int | GL_TRIANGLES
static int | GL_TRUE
static int | GL_UNPACK_ALIGNMENT
static int | GL_UNSIGNED_BYTE
static int | GL_UNSIGNED_INT
static int | GL_UNSIGNED_SHORT
static int | GL_UNSIGNED_SHORT_4_4_4_4
static int | GL_UNSIGNED_SHORT_5_5_5_1
static int | GL_UNSIGNED_SHORT_5_6_5
static int | GL_VALIDATE_STATUS
static int | GL_VENDOR
static int | GL_VERSION
static int | GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING
static int | GL_VERTEX_ATTRIB_ARRAY_ENABLED
static int | GL_VERTEX_ATTRIB_ARRAY_NORMALIZED
static int | GL_VERTEX_ATTRIB_ARRAY_POINTER
static int | GL_VERTEX_ATTRIB_ARRAY_SIZE
static int | GL_VERTEX_ATTRIB_ARRAY_STRIDE
static int | GL_VERTEX_ATTRIB_ARRAY_TYPE
static int | GL_VERTEX_SHADER
static int | GL_VIEWPORT
static int | GL_ZERO
Method Summary
void | glAttachShader(int program, int shader)
void | glBindAttribLocation(int program, int index, java.lang.String name)
void | glBindBuffer(int target, int buffer)
void | glBindFramebuffer(int target, int framebuffer)
void | glBindRenderbuffer(int target, int renderbuffer)
void | glBlendColor(float red, float green, float blue, float alpha)
void | glBlendEquation(int mode)
void | glBlendEquationSeparate(int modeRGB, int modeAlpha)
void | glBlendFuncSeparate(int srcRGB, int dstRGB, int srcAlpha, int dstAlpha)
void | glBufferData(int target, int size, java.nio.Buffer data, int usage)
void | glBufferSubData(int target, int offset, int size, java.nio.Buffer data)
int | glCheckFramebufferStatus(int target)
void | glCompileShader(int shader)
int | glCreateProgram()
int | glCreateShader(int type)
void | glDeleteBuffers(int n, java.nio.IntBuffer buffers)
void | glDeleteFramebuffers(int n, java.nio.IntBuffer framebuffers)
void | glDeleteProgram(int program)
void | glDeleteRenderbuffers(int n, java.nio.IntBuffer renderbuffers)
void | glDeleteShader(int shader)
void | glDetachShader(int program, int shader)
void | glDisableVertexAttribArray(int index)
void | glDrawElements(int mode, int count, int type, int indices)
void | glEnableVertexAttribArray(int index)
void | glFramebufferRenderbuffer(int target, int attachment, int renderbuffertarget, int renderbuffer)
void | glFramebufferTexture2D(int target, int attachment, int textarget, int texture, int level)
void | glGenBuffers(int n, java.nio.IntBuffer buffers)
void | glGenerateMipmap(int target)
void | glGenFramebuffers(int n, java.nio.IntBuffer framebuffers)
void | glGenRenderbuffers(int n, java.nio.IntBuffer renderbuffers)
java.lang.String | glGetActiveAttrib(int program, int index, java.nio.IntBuffer size, java.nio.Buffer type)
java.lang.String | glGetActiveUniform(int program, int index, java.nio.IntBuffer size, java.nio.Buffer type)
void | glGetAttachedShaders(int program, int maxcount, java.nio.Buffer count, java.nio.IntBuffer shaders)
int | glGetAttribLocation(int program, java.lang.String name)
void | glGetBooleanv(int pname, java.nio.Buffer params)
void | glGetBufferParameteriv(int target, int pname, java.nio.IntBuffer params)
void | glGetFloatv(int pname, java.nio.FloatBuffer params)
void | glGetFramebufferAttachmentParameteriv(int target, int attachment, int pname, java.nio.IntBuffer params)
java.lang.String | glGetProgramInfoLog(int program)
void | glGetProgramiv(int program, int pname, java.nio.IntBuffer params)
void | glGetRenderbufferParameteriv(int target, int pname, java.nio.IntBuffer params)
java.lang.String | glGetShaderInfoLog(int shader)
void | glGetShaderiv(int shader, int pname, java.nio.IntBuffer params)
void | glGetShaderPrecisionFormat(int shadertype, int precisiontype, java.nio.IntBuffer range, java.nio.IntBuffer precision)
void | glGetShaderSource(int shader, int bufsize, java.nio.Buffer length, java.lang.String source)
void | glGetTexParameterfv(int target, int pname, java.nio.FloatBuffer params)
void | glGetTexParameteriv(int target, int pname, java.nio.IntBuffer params)
void | glGetUniformfv(int program, int location, java.nio.FloatBuffer params)
void | glGetUniformiv(int program, int location, java.nio.IntBuffer params)
int | glGetUniformLocation(int program, java.lang.String name)
void | glGetVertexAttribfv(int index, int pname, java.nio.FloatBuffer params)
void | glGetVertexAttribiv(int index, int pname, java.nio.IntBuffer params)
void | glGetVertexAttribPointerv(int index, int pname, java.nio.Buffer pointer)
boolean | glIsBuffer(int buffer)
boolean | glIsEnabled(int cap)
boolean | glIsFramebuffer(int framebuffer)
boolean | glIsProgram(int program)
boolean | glIsRenderbuffer(int renderbuffer)
boolean | glIsShader(int shader)
boolean | glIsTexture(int texture)
void | glLinkProgram(int program)
void | glReleaseShaderCompiler()
void | glRenderbufferStorage(int target, int internalformat, int width, int height)
void | glSampleCoverage(float value, boolean invert)
void | glShaderBinary(int n, java.nio.IntBuffer shaders, int binaryformat, java.nio.Buffer binary, int length)
void | glShaderSource(int shader, java.lang.String string)
void | glStencilFuncSeparate(int face, int func, int ref, int mask)
void | glStencilMaskSeparate(int face, int mask)
void | glStencilOpSeparate(int face, int fail, int zfail, int zpass)
void | glTexParameterfv(int target, int pname, java.nio.FloatBuffer params)
void | glTexParameteri(int target, int pname, int param)
void | glTexParameteriv(int target, int pname, java.nio.IntBuffer params)
void | glUniform1f(int location, float x)
void | glUniform1fv(int location, int count, java.nio.FloatBuffer v)
void | glUniform1i(int location, int x)
void | glUniform1iv(int location, int count, java.nio.IntBuffer v)
void | glUniform2f(int location, float x, float y)
void | glUniform2fv(int location, int count, java.nio.FloatBuffer v)
void | glUniform2i(int location, int x, int y)
void | glUniform2iv(int location, int count, java.nio.IntBuffer v)
void | glUniform3f(int location, float x, float y, float z)
void | glUniform3fv(int location, int count, java.nio.FloatBuffer v)
void | glUniform3i(int location, int x, int y, int z)
void | glUniform3iv(int location, int count, java.nio.IntBuffer v)
void | glUniform4f(int location, float x, float y, float z, float w)
void | glUniform4fv(int location, int count, java.nio.FloatBuffer v)
void | glUniform4i(int location, int x, int y, int z, int w)
void | glUniform4iv(int location, int count, java.nio.IntBuffer v)
void | glUniformMatrix2fv(int location, int count, boolean transpose, java.nio.FloatBuffer value)
void | glUniformMatrix3fv(int location, int count, boolean transpose, java.nio.FloatBuffer value)
void | glUniformMatrix4fv(int location, int count, boolean transpose, java.nio.FloatBuffer value)
void | glUseProgram(int program)
void | glValidateProgram(int program)
void | glVertexAttrib1f(int indx, float x)
void | glVertexAttrib1fv(int indx, java.nio.FloatBuffer values)
void | glVertexAttrib2f(int indx, float x, float y)
void | glVertexAttrib2fv(int indx, java.nio.FloatBuffer values)
void | glVertexAttrib3f(int indx, float x, float y, float z)
void | glVertexAttrib3fv(int indx, java.nio.FloatBuffer values)
void | glVertexAttrib4f(int indx, float x, float y, float z, float w)
void | glVertexAttrib4fv(int indx, java.nio.FloatBuffer values)
void | glVertexAttribPointer(int indx, int size, int type, boolean normalized, int stride, java.nio.Buffer ptr)
void | glVertexAttribPointer(int indx, int size, int type, boolean normalized, int stride, int ptr)
Methods inherited from interface com.badlogic.gdx.graphics.GLCommon
glActiveTexture, glBindTexture, glBlendFunc, glClear, glClearColor, glClearDepthf, glClearStencil, glColorMask, glCompressedTexImage2D, glCompressedTexSubImage2D, glCopyTexImage2D, glCopyTexSubImage2D, glCullFace, glDeleteTextures, glDepthFunc, glDepthMask, glDepthRangef, glDisable, glDrawArrays, glDrawElements, glEnable, glFinish, glFlush, glFrontFace, glGenTextures, glGetError, glGetIntegerv, glGetString, glHint, glLineWidth, glPixelStorei, glPolygonOffset, glReadPixels, glScissor, glStencilFunc, glStencilMask, glStencilOp, glTexImage2D, glTexParameterf, glTexSubImage2D, glViewport

Field Detail

GL_ES_VERSION_2_0

static final int GL_ES_VERSION_2_0
See Also:
Constant Field Values

GL_DEPTH_BUFFER_BIT

static final int GL_DEPTH_BUFFER_BIT
See Also:
Constant Field Values

GL_STENCIL_BUFFER_BIT

static final int GL_STENCIL_BUFFER_BIT
See Also:
Constant Field Values

GL_COLOR_BUFFER_BIT

static final int GL_COLOR_BUFFER_BIT
See Also:
Constant Field Values

GL_FALSE

static final int GL_FALSE
See Also:
Constant Field Values

GL_TRUE

static final int GL_TRUE
See Also:
Constant Field Values

GL_POINTS

static final int GL_POINTS
See Also:
Constant Field Values

GL_LINES

static final int GL_LINES
See Also:
Constant Field Values

GL_LINE_LOOP

static final int GL_LINE_LOOP
See Also:
Constant Field Values

GL_LINE_STRIP

static final int GL_LINE_STRIP
See Also:
Constant Field Values

GL_TRIANGLES

static final int GL_TRIANGLES
See Also:
Constant Field Values

GL_TRIANGLE_STRIP

static final int GL_TRIANGLE_STRIP
See Also:
Constant Field Values

GL_TRIANGLE_FAN

static final int GL_TRIANGLE_FAN
See Also:
Constant Field Values

GL_ZERO

static final int GL_ZERO
See Also:
Constant Field Values

GL_ONE

static final int GL_ONE
See Also:
Constant Field Values

GL_SRC_COLOR

static final int GL_SRC_COLOR
See Also:
Constant Field Values

GL_ONE_MINUS_SRC_COLOR

static final int GL_ONE_MINUS_SRC_COLOR
See Also:
Constant Field Values

GL_SRC_ALPHA

static final int GL_SRC_ALPHA
See Also:
Constant Field Values

GL_ONE_MINUS_SRC_ALPHA

static final int GL_ONE_MINUS_SRC_ALPHA
See Also:
Constant Field Values

GL_DST_ALPHA

static final int GL_DST_ALPHA
See Also:
Constant Field Values

GL_ONE_MINUS_DST_ALPHA

static final int GL_ONE_MINUS_DST_ALPHA
See Also:
Constant Field Values

GL_DST_COLOR

static final int GL_DST_COLOR
See Also:
Constant Field Values

GL_ONE_MINUS_DST_COLOR

static final int GL_ONE_MINUS_DST_COLOR
See Also:
Constant Field Values

GL_SRC_ALPHA_SATURATE

static final int GL_SRC_ALPHA_SATURATE
See Also:
Constant Field Values

GL_FUNC_ADD

static final int GL_FUNC_ADD
See Also:
Constant Field Values

GL_BLEND_EQUATION

static final int GL_BLEND_EQUATION
See Also:
Constant Field Values

GL_BLEND_EQUATION_RGB

static final int GL_BLEND_EQUATION_RGB
See Also:
Constant Field Values

GL_BLEND_EQUATION_ALPHA

static final int GL_BLEND_EQUATION_ALPHA
See Also:
Constant Field Values

GL_FUNC_SUBTRACT

static final int GL_FUNC_SUBTRACT
See Also:
Constant Field Values

GL_FUNC_REVERSE_SUBTRACT

static final int GL_FUNC_REVERSE_SUBTRACT
See Also:
Constant Field Values

GL_BLEND_DST_RGB

static final int GL_BLEND_DST_RGB
See Also:
Constant Field Values

GL_BLEND_SRC_RGB

static final int GL_BLEND_SRC_RGB
See Also:
Constant Field Values

GL_BLEND_DST_ALPHA

static final int GL_BLEND_DST_ALPHA
See Also:
Constant Field Values

GL_BLEND_SRC_ALPHA

static final int GL_BLEND_SRC_ALPHA
See Also:
Constant Field Values

GL_CONSTANT_COLOR

static final int GL_CONSTANT_COLOR
See Also:
Constant Field Values

GL_ONE_MINUS_CONSTANT_COLOR

static final int GL_ONE_MINUS_CONSTANT_COLOR
See Also:
Constant Field Values

GL_CONSTANT_ALPHA

static final int GL_CONSTANT_ALPHA
See Also:
Constant Field Values

GL_ONE_MINUS_CONSTANT_ALPHA

static final int GL_ONE_MINUS_CONSTANT_ALPHA
See Also:
Constant Field Values

GL_BLEND_COLOR

static final int GL_BLEND_COLOR
See Also:
Constant Field Values

GL_ARRAY_BUFFER

static final int GL_ARRAY_BUFFER
See Also:
Constant Field Values

GL_ELEMENT_ARRAY_BUFFER

static final int GL_ELEMENT_ARRAY_BUFFER
See Also:
Constant Field Values

GL_ARRAY_BUFFER_BINDING

static final int GL_ARRAY_BUFFER_BINDING
See Also:
Constant Field Values

GL_ELEMENT_ARRAY_BUFFER_BINDING

static final int GL_ELEMENT_ARRAY_BUFFER_BINDING
See Also:
Constant Field Values

GL_STREAM_DRAW

static final int GL_STREAM_DRAW
See Also:
Constant Field Values

GL_STATIC_DRAW

static final int GL_STATIC_DRAW
See Also:
Constant Field Values

GL_DYNAMIC_DRAW

static final int GL_DYNAMIC_DRAW
See Also:
Constant Field Values

GL_BUFFER_SIZE

static final int GL_BUFFER_SIZE
See Also:
Constant Field Values

GL_BUFFER_USAGE

static final int GL_BUFFER_USAGE
See Also:
Constant Field Values

GL_CURRENT_VERTEX_ATTRIB

static final int GL_CURRENT_VERTEX_ATTRIB
See Also:
Constant Field Values

GL_FRONT

static final int GL_FRONT
See Also:
Constant Field Values

GL_BACK

static final int GL_BACK
See Also:
Constant Field Values

GL_FRONT_AND_BACK

static final int GL_FRONT_AND_BACK
See Also:
Constant Field Values

GL_TEXTURE_2D

static final int GL_TEXTURE_2D
See Also:
Constant Field Values

GL_CULL_FACE

static final int GL_CULL_FACE
See Also:
Constant Field Values

GL_BLEND

static final int GL_BLEND
See Also:
Constant Field Values

GL_DITHER

static final int GL_DITHER
See Also:
Constant Field Values

GL_STENCIL_TEST

static final int GL_STENCIL_TEST
See Also:
Constant Field Values

GL_DEPTH_TEST

static final int GL_DEPTH_TEST
See Also:
Constant Field Values

GL_SCISSOR_TEST

static final int GL_SCISSOR_TEST
See Also:
Constant Field Values

GL_POLYGON_OFFSET_FILL

static final int GL_POLYGON_OFFSET_FILL
See Also:
Constant Field Values

GL_SAMPLE_ALPHA_TO_COVERAGE

static final int GL_SAMPLE_ALPHA_TO_COVERAGE
See Also:
Constant Field Values

GL_SAMPLE_COVERAGE

static final int GL_SAMPLE_COVERAGE
See Also:
Constant Field Values

GL_NO_ERROR

static final int GL_NO_ERROR
See Also:
Constant Field Values

GL_INVALID_ENUM

static final int GL_INVALID_ENUM
See Also:
Constant Field Values

GL_INVALID_VALUE

static final int GL_INVALID_VALUE
See Also:
Constant Field Values

GL_INVALID_OPERATION

static final int GL_INVALID_OPERATION
See Also:
Constant Field Values

GL_OUT_OF_MEMORY

static final int GL_OUT_OF_MEMORY
See Also:
Constant Field Values

GL_CW

static final int GL_CW
See Also:
Constant Field Values

GL_CCW

static final int GL_CCW
See Also:
Constant Field Values

GL_LINE_WIDTH

static final int GL_LINE_WIDTH
See Also:
Constant Field Values

GL_ALIASED_POINT_SIZE_RANGE

static final int GL_ALIASED_POINT_SIZE_RANGE
See Also:
Constant Field Values

GL_ALIASED_LINE_WIDTH_RANGE

static final int GL_ALIASED_LINE_WIDTH_RANGE
See Also:
Constant Field Values

GL_CULL_FACE_MODE

static final int GL_CULL_FACE_MODE
See Also:
Constant Field Values

GL_FRONT_FACE

static final int GL_FRONT_FACE
See Also:
Constant Field Values

GL_DEPTH_RANGE

static final int GL_DEPTH_RANGE
See Also:
Constant Field Values

GL_DEPTH_WRITEMASK

static final int GL_DEPTH_WRITEMASK
See Also:
Constant Field Values

GL_DEPTH_CLEAR_VALUE

static final int GL_DEPTH_CLEAR_VALUE
See Also:
Constant Field Values

GL_DEPTH_FUNC

static final int GL_DEPTH_FUNC
See Also:
Constant Field Values

GL_STENCIL_CLEAR_VALUE

static final int GL_STENCIL_CLEAR_VALUE
See Also:
Constant Field Values

GL_STENCIL_FUNC

static final int GL_STENCIL_FUNC
See Also:
Constant Field Values

GL_STENCIL_FAIL

static final int GL_STENCIL_FAIL
See Also:
Constant Field Values

GL_STENCIL_PASS_DEPTH_FAIL

static final int GL_STENCIL_PASS_DEPTH_FAIL
See Also:
Constant Field Values

GL_STENCIL_PASS_DEPTH_PASS

static final int GL_STENCIL_PASS_DEPTH_PASS
See Also:
Constant Field Values

GL_STENCIL_REF

static final int GL_STENCIL_REF
See Also:
Constant Field Values

GL_STENCIL_VALUE_MASK

static final int GL_STENCIL_VALUE_MASK
See Also:
Constant Field Values

GL_STENCIL_WRITEMASK

static final int GL_STENCIL_WRITEMASK
See Also:
Constant Field Values

GL_STENCIL_BACK_FUNC

static final int GL_STENCIL_BACK_FUNC
See Also:
Constant Field Values

GL_STENCIL_BACK_FAIL

static final int GL_STENCIL_BACK_FAIL
See Also:
Constant Field Values

GL_STENCIL_BACK_PASS_DEPTH_FAIL

static final int GL_STENCIL_BACK_PASS_DEPTH_FAIL
See Also:
Constant Field Values

GL_STENCIL_BACK_PASS_DEPTH_PASS

static final int GL_STENCIL_BACK_PASS_DEPTH_PASS
See Also:
Constant Field Values

GL_STENCIL_BACK_REF

static final int GL_STENCIL_BACK_REF
See Also:
Constant Field Values

GL_STENCIL_BACK_VALUE_MASK

static final int GL_STENCIL_BACK_VALUE_MASK
See Also:
Constant Field Values

GL_STENCIL_BACK_WRITEMASK

static final int GL_STENCIL_BACK_WRITEMASK
See Also:
Constant Field Values

GL_VIEWPORT

static final int GL_VIEWPORT
See Also:
Constant Field Values

GL_SCISSOR_BOX

static final int GL_SCISSOR_BOX
See Also:
Constant Field Values

GL_COLOR_CLEAR_VALUE

static final int GL_COLOR_CLEAR_VALUE
See Also:
Constant Field Values

GL_COLOR_WRITEMASK

static final int GL_COLOR_WRITEMASK
See Also:
Constant Field Values

GL_UNPACK_ALIGNMENT

static final int GL_UNPACK_ALIGNMENT
See Also:
Constant Field Values

GL_PACK_ALIGNMENT

static final int GL_PACK_ALIGNMENT
See Also:
Constant Field Values

GL_MAX_TEXTURE_SIZE

static final int GL_MAX_TEXTURE_SIZE
See Also:
Constant Field Values

GL_MAX_VIEWPORT_DIMS

static final int GL_MAX_VIEWPORT_DIMS
See Also:
Constant Field Values

GL_SUBPIXEL_BITS

static final int GL_SUBPIXEL_BITS
See Also:
Constant Field Values

GL_RED_BITS

static final int GL_RED_BITS
See Also:
Constant Field Values

GL_GREEN_BITS

static final int GL_GREEN_BITS
See Also:
Constant Field Values

GL_BLUE_BITS

static final int GL_BLUE_BITS
See Also:
Constant Field Values

GL_ALPHA_BITS

static final int GL_ALPHA_BITS
See Also:
Constant Field Values

GL_DEPTH_BITS

static final int GL_DEPTH_BITS
See Also:
Constant Field Values

GL_STENCIL_BITS

static final int GL_STENCIL_BITS
See Also:
Constant Field Values

GL_POLYGON_OFFSET_UNITS

static final int GL_POLYGON_OFFSET_UNITS
See Also:
Constant Field Values

GL_POLYGON_OFFSET_FACTOR

static final int GL_POLYGON_OFFSET_FACTOR
See Also:
Constant Field Values

GL_TEXTURE_BINDING_2D

static final int GL_TEXTURE_BINDING_2D
See Also:
Constant Field Values

GL_SAMPLE_BUFFERS

static final int GL_SAMPLE_BUFFERS
See Also:
Constant Field Values

GL_SAMPLES

static final int GL_SAMPLES
See Also:
Constant Field Values

GL_SAMPLE_COVERAGE_VALUE

static final int GL_SAMPLE_COVERAGE_VALUE
See Also:
Constant Field Values

GL_SAMPLE_COVERAGE_INVERT

static final int GL_SAMPLE_COVERAGE_INVERT
See Also:
Constant Field Values

GL_NUM_COMPRESSED_TEXTURE_FORMATS

static final int GL_NUM_COMPRESSED_TEXTURE_FORMATS
See Also:
Constant Field Values

GL_COMPRESSED_TEXTURE_FORMATS

static final int GL_COMPRESSED_TEXTURE_FORMATS
See Also:
Constant Field Values

GL_DONT_CARE

static final int GL_DONT_CARE
See Also:
Constant Field Values

GL_FASTEST

static final int GL_FASTEST
See Also:
Constant Field Values

GL_NICEST

static final int GL_NICEST
See Also:
Constant Field Values

GL_GENERATE_MIPMAP_HINT

static final int GL_GENERATE_MIPMAP_HINT
See Also:
Constant Field Values

GL_BYTE

static final int GL_BYTE
See Also:
Constant Field Values

GL_UNSIGNED_BYTE

static final int GL_UNSIGNED_BYTE
See Also:
Constant Field Values

GL_SHORT

static final int GL_SHORT
See Also:
Constant Field Values

GL_UNSIGNED_SHORT

static final int GL_UNSIGNED_SHORT
See Also:
Constant Field Values

GL_INT

static final int GL_INT
See Also:
Constant Field Values

GL_UNSIGNED_INT

static final int GL_UNSIGNED_INT
See Also:
Constant Field Values

GL_FLOAT

static final int GL_FLOAT
See Also:
Constant Field Values

GL_FIXED

static final int GL_FIXED
See Also:
Constant Field Values

GL_DEPTH_COMPONENT

static final int GL_DEPTH_COMPONENT
See Also:
Constant Field Values

GL_ALPHA

static final int GL_ALPHA
See Also:
Constant Field Values

GL_RGB

static final int GL_RGB
See Also:
Constant Field Values

GL_RGBA

static final int GL_RGBA
See Also:
Constant Field Values

GL_LUMINANCE

static final int GL_LUMINANCE
See Also:
Constant Field Values

GL_LUMINANCE_ALPHA

static final int GL_LUMINANCE_ALPHA
See Also:
Constant Field Values

GL_UNSIGNED_SHORT_4_4_4_4

static final int GL_UNSIGNED_SHORT_4_4_4_4
See Also:
Constant Field Values

GL_UNSIGNED_SHORT_5_5_5_1

static final int GL_UNSIGNED_SHORT_5_5_5_1
See Also:
Constant Field Values

GL_UNSIGNED_SHORT_5_6_5

static final int GL_UNSIGNED_SHORT_5_6_5
See Also:
Constant Field Values

GL_FRAGMENT_SHADER

static final int GL_FRAGMENT_SHADER
See Also:
Constant Field Values

GL_VERTEX_SHADER

static final int GL_VERTEX_SHADER
See Also:
Constant Field Values

GL_MAX_VERTEX_ATTRIBS

static final int GL_MAX_VERTEX_ATTRIBS
See Also:
Constant Field Values

GL_MAX_VERTEX_UNIFORM_VECTORS

static final int GL_MAX_VERTEX_UNIFORM_VECTORS
See Also:
Constant Field Values

GL_MAX_VARYING_VECTORS

static final int GL_MAX_VARYING_VECTORS
See Also:
Constant Field Values

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS

static final int GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS
See Also:
Constant Field Values

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS

static final int GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS
See Also:
Constant Field Values

GL_MAX_TEXTURE_IMAGE_UNITS

static final int GL_MAX_TEXTURE_IMAGE_UNITS
See Also:
Constant Field Values

GL_MAX_FRAGMENT_UNIFORM_VECTORS

static final int GL_MAX_FRAGMENT_UNIFORM_VECTORS
See Also:
Constant Field Values

GL_SHADER_TYPE

static final int GL_SHADER_TYPE
See Also:
Constant Field Values

GL_DELETE_STATUS

static final int GL_DELETE_STATUS
See Also:
Constant Field Values

GL_LINK_STATUS

static final int GL_LINK_STATUS
See Also:
Constant Field Values

GL_VALIDATE_STATUS

static final int GL_VALIDATE_STATUS
See Also:
Constant Field Values

GL_ATTACHED_SHADERS

static final int GL_ATTACHED_SHADERS
See Also:
Constant Field Values

GL_ACTIVE_UNIFORMS

static final int GL_ACTIVE_UNIFORMS
See Also:
Constant Field Values

GL_ACTIVE_UNIFORM_MAX_LENGTH

static final int GL_ACTIVE_UNIFORM_MAX_LENGTH
See Also:
Constant Field Values

GL_ACTIVE_ATTRIBUTES

static final int GL_ACTIVE_ATTRIBUTES
See Also:
Constant Field Values

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH

static final int GL_ACTIVE_ATTRIBUTE_MAX_LENGTH
See Also:
Constant Field Values

GL_SHADING_LANGUAGE_VERSION

static final int GL_SHADING_LANGUAGE_VERSION
See Also:
Constant Field Values

GL_CURRENT_PROGRAM

static final int GL_CURRENT_PROGRAM
See Also:
Constant Field Values

GL_NEVER

static final int GL_NEVER
See Also:
Constant Field Values

GL_LESS

static final int GL_LESS
See Also:
Constant Field Values

GL_EQUAL

static final int GL_EQUAL
See Also:
Constant Field Values

GL_LEQUAL

static final int GL_LEQUAL
See Also:
Constant Field Values

GL_GREATER

static final int GL_GREATER
See Also:
Constant Field Values

GL_NOTEQUAL

static final int GL_NOTEQUAL
See Also:
Constant Field Values

GL_GEQUAL

static final int GL_GEQUAL
See Also:
Constant Field Values

GL_ALWAYS

static final int GL_ALWAYS
See Also:
Constant Field Values

GL_KEEP

static final int GL_KEEP
See Also:
Constant Field Values

GL_REPLACE

static final int GL_REPLACE
See Also:
Constant Field Values

GL_INCR

static final int GL_INCR
See Also:
Constant Field Values

GL_DECR

static final int GL_DECR
See Also:
Constant Field Values

GL_INVERT

static final int GL_INVERT
See Also:
Constant Field Values

GL_INCR_WRAP

static final int GL_INCR_WRAP
See Also:
Constant Field Values

GL_DECR_WRAP

static final int GL_DECR_WRAP
See Also:
Constant Field Values

GL_VENDOR

static final int GL_VENDOR
See Also:
Constant Field Values

GL_RENDERER

static final int GL_RENDERER
See Also:
Constant Field Values

GL_VERSION

static final int GL_VERSION
See Also:
Constant Field Values

GL_EXTENSIONS

static final int GL_EXTENSIONS
See Also:
Constant Field Values

GL_NEAREST

static final int GL_NEAREST
See Also:
Constant Field Values

GL_LINEAR

static final int GL_LINEAR
See Also:
Constant Field Values

GL_NEAREST_MIPMAP_NEAREST

static final int GL_NEAREST_MIPMAP_NEAREST
See Also:
Constant Field Values

GL_LINEAR_MIPMAP_NEAREST

static final int GL_LINEAR_MIPMAP_NEAREST
See Also:
Constant Field Values

GL_NEAREST_MIPMAP_LINEAR

static final int GL_NEAREST_MIPMAP_LINEAR
See Also:
Constant Field Values

GL_LINEAR_MIPMAP_LINEAR

static final int GL_LINEAR_MIPMAP_LINEAR
See Also:
Constant Field Values

GL_TEXTURE_MAG_FILTER

static final int GL_TEXTURE_MAG_FILTER
See Also:
Constant Field Values

GL_TEXTURE_MIN_FILTER

static final int GL_TEXTURE_MIN_FILTER
See Also:
Constant Field Values

GL_TEXTURE_WRAP_S

static final int GL_TEXTURE_WRAP_S
See Also:
Constant Field Values

GL_TEXTURE_WRAP_T

static final int GL_TEXTURE_WRAP_T
See Also:
Constant Field Values

GL_TEXTURE

static final int GL_TEXTURE
See Also:
Constant Field Values

GL_TEXTURE_CUBE_MAP

static final int GL_TEXTURE_CUBE_MAP
See Also:
Constant Field Values

GL_TEXTURE_BINDING_CUBE_MAP

static final int GL_TEXTURE_BINDING_CUBE_MAP
See Also:
Constant Field Values

GL_TEXTURE_CUBE_MAP_POSITIVE_X

static final int GL_TEXTURE_CUBE_MAP_POSITIVE_X
See Also:
Constant Field Values

GL_TEXTURE_CUBE_MAP_NEGATIVE_X

static final int GL_TEXTURE_CUBE_MAP_NEGATIVE_X
See Also:
Constant Field Values

GL_TEXTURE_CUBE_MAP_POSITIVE_Y

static final int GL_TEXTURE_CUBE_MAP_POSITIVE_Y
See Also:
Constant Field Values

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y

static final int GL_TEXTURE_CUBE_MAP_NEGATIVE_Y
See Also:
Constant Field Values

GL_TEXTURE_CUBE_MAP_POSITIVE_Z

static final int GL_TEXTURE_CUBE_MAP_POSITIVE_Z
See Also:
Constant Field Values

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z

static final int GL_TEXTURE_CUBE_MAP_NEGATIVE_Z
See Also:
Constant Field Values

GL_MAX_CUBE_MAP_TEXTURE_SIZE

static final int GL_MAX_CUBE_MAP_TEXTURE_SIZE
See Also:
Constant Field Values

GL_TEXTURE0

static final int GL_TEXTURE0
See Also:
Constant Field Values

GL_TEXTURE1

static final int GL_TEXTURE1
See Also:
Constant Field Values

GL_TEXTURE2

static final int GL_TEXTURE2
See Also:
Constant Field Values

GL_TEXTURE3

static final int GL_TEXTURE3
See Also:
Constant Field Values

GL_TEXTURE4

static final int GL_TEXTURE4
See Also:
Constant Field Values

GL_TEXTURE5

static final int GL_TEXTURE5
See Also:
Constant Field Values

GL_TEXTURE6

static final int GL_TEXTURE6
See Also:
Constant Field Values

GL_TEXTURE7

static final int GL_TEXTURE7
See Also:
Constant Field Values

GL_TEXTURE8

static final int GL_TEXTURE8
See Also:
Constant Field Values

GL_TEXTURE9

static final int GL_TEXTURE9
See Also:
Constant Field Values

GL_TEXTURE10

static final int GL_TEXTURE10
See Also:
Constant Field Values

GL_TEXTURE11

static final int GL_TEXTURE11
See Also:
Constant Field Values

GL_TEXTURE12

static final int GL_TEXTURE12
See Also:
Constant Field Values

GL_TEXTURE13

static final int GL_TEXTURE13
See Also:
Constant Field Values

GL_TEXTURE14

static final int GL_TEXTURE14
See Also:
Constant Field Values

GL_TEXTURE15

static final int GL_TEXTURE15
See Also:
Constant Field Values

GL_TEXTURE16

static final int GL_TEXTURE16
See Also:
Constant Field Values

GL_TEXTURE17

static final int GL_TEXTURE17
See Also:
Constant Field Values

GL_TEXTURE18

static final int GL_TEXTURE18
See Also:
Constant Field Values

GL_TEXTURE19

static final int GL_TEXTURE19
See Also:
Constant Field Values

GL_TEXTURE20

static final int GL_TEXTURE20
See Also:
Constant Field Values

GL_TEXTURE21

static final int GL_TEXTURE21
See Also:
Constant Field Values

GL_TEXTURE22

static final int GL_TEXTURE22
See Also:
Constant Field Values

GL_TEXTURE23

static final int GL_TEXTURE23
See Also:
Constant Field Values

GL_TEXTURE24

static final int GL_TEXTURE24
See Also:
Constant Field Values

GL_TEXTURE25

static final int GL_TEXTURE25
See Also:
Constant Field Values

GL_TEXTURE26

static final int GL_TEXTURE26
See Also:
Constant Field Values

GL_TEXTURE27

static final int GL_TEXTURE27
See Also:
Constant Field Values

GL_TEXTURE28

static final int GL_TEXTURE28
See Also:
Constant Field Values

GL_TEXTURE29

static final int GL_TEXTURE29
See Also:
Constant Field Values

GL_TEXTURE30

static final int GL_TEXTURE30
See Also:
Constant Field Values

GL_TEXTURE31

static final int GL_TEXTURE31
See Also:
Constant Field Values

GL_ACTIVE_TEXTURE

static final int GL_ACTIVE_TEXTURE
See Also:
Constant Field Values

GL_REPEAT

static final int GL_REPEAT
See Also:
Constant Field Values

GL_CLAMP_TO_EDGE

static final int GL_CLAMP_TO_EDGE
See Also:
Constant Field Values

GL_MIRRORED_REPEAT

static final int GL_MIRRORED_REPEAT
See Also:
Constant Field Values

GL_FLOAT_VEC2

static final int GL_FLOAT_VEC2
See Also:
Constant Field Values

GL_FLOAT_VEC3

static final int GL_FLOAT_VEC3
See Also:
Constant Field Values

GL_FLOAT_VEC4

static final int GL_FLOAT_VEC4
See Also:
Constant Field Values

GL_INT_VEC2

static final int GL_INT_VEC2
See Also:
Constant Field Values

GL_INT_VEC3

static final int GL_INT_VEC3
See Also:
Constant Field Values

GL_INT_VEC4

static final int GL_INT_VEC4
See Also:
Constant Field Values

GL_BOOL

static final int GL_BOOL
See Also:
Constant Field Values

GL_BOOL_VEC2

static final int GL_BOOL_VEC2
See Also:
Constant Field Values

GL_BOOL_VEC3

static final int GL_BOOL_VEC3
See Also:
Constant Field Values

GL_BOOL_VEC4

static final int GL_BOOL_VEC4
See Also:
Constant Field Values

GL_FLOAT_MAT2

static final int GL_FLOAT_MAT2
See Also:
Constant Field Values

GL_FLOAT_MAT3

static final int GL_FLOAT_MAT3
See Also:
Constant Field Values

GL_FLOAT_MAT4

static final int GL_FLOAT_MAT4
See Also:
Constant Field Values

GL_SAMPLER_2D

static final int GL_SAMPLER_2D
See Also:
Constant Field Values

GL_SAMPLER_CUBE

static final int GL_SAMPLER_CUBE
See Also:
Constant Field Values

GL_VERTEX_ATTRIB_ARRAY_ENABLED

static final int GL_VERTEX_ATTRIB_ARRAY_ENABLED
See Also:
Constant Field Values

GL_VERTEX_ATTRIB_ARRAY_SIZE

static final int GL_VERTEX_ATTRIB_ARRAY_SIZE
See Also:
Constant Field Values

GL_VERTEX_ATTRIB_ARRAY_STRIDE

static final int GL_VERTEX_ATTRIB_ARRAY_STRIDE
See Also:
Constant Field Values

GL_VERTEX_ATTRIB_ARRAY_TYPE

static final int GL_VERTEX_ATTRIB_ARRAY_TYPE
See Also:
Constant Field Values

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED

static final int GL_VERTEX_ATTRIB_ARRAY_NORMALIZED
See Also:
Constant Field Values

GL_VERTEX_ATTRIB_ARRAY_POINTER

static final int GL_VERTEX_ATTRIB_ARRAY_POINTER
See Also:
Constant Field Values

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING

static final int GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING
See Also:
Constant Field Values

GL_IMPLEMENTATION_COLOR_READ_TYPE

static final int GL_IMPLEMENTATION_COLOR_READ_TYPE
See Also:
Constant Field Values

GL_IMPLEMENTATION_COLOR_READ_FORMAT

static final int GL_IMPLEMENTATION_COLOR_READ_FORMAT
See Also:
Constant Field Values

GL_COMPILE_STATUS

static final int GL_COMPILE_STATUS
See Also:
Constant Field Values

GL_INFO_LOG_LENGTH

static final int GL_INFO_LOG_LENGTH
See Also:
Constant Field Values

GL_SHADER_SOURCE_LENGTH

static final int GL_SHADER_SOURCE_LENGTH
See Also:
Constant Field Values

GL_SHADER_COMPILER

static final int GL_SHADER_COMPILER
See Also:
Constant Field Values

GL_SHADER_BINARY_FORMATS

static final int GL_SHADER_BINARY_FORMATS
See Also:
Constant Field Values

GL_NUM_SHADER_BINARY_FORMATS

static final int GL_NUM_SHADER_BINARY_FORMATS
See Also:
Constant Field Values

GL_LOW_FLOAT

static final int GL_LOW_FLOAT
See Also:
Constant Field Values

GL_MEDIUM_FLOAT

static final int GL_MEDIUM_FLOAT
See Also:
Constant Field Values

GL_HIGH_FLOAT

static final int GL_HIGH_FLOAT
See Also:
Constant Field Values

GL_LOW_INT

static final int GL_LOW_INT
See Also:
Constant Field Values

GL_MEDIUM_INT

static final int GL_MEDIUM_INT
See Also:
Constant Field Values

GL_HIGH_INT

static final int GL_HIGH_INT
See Also:
Constant Field Values

GL_FRAMEBUFFER

static final int GL_FRAMEBUFFER
See Also:
Constant Field Values

GL_RENDERBUFFER

static final int GL_RENDERBUFFER
See Also:
Constant Field Values

GL_RGBA4

static final int GL_RGBA4
See Also:
Constant Field Values

GL_RGB5_A1

static final int GL_RGB5_A1
See Also:
Constant Field Values

GL_RGB565

static final int GL_RGB565
See Also:
Constant Field Values

GL_DEPTH_COMPONENT16

static final int GL_DEPTH_COMPONENT16
See Also:
Constant Field Values

GL_STENCIL_INDEX

static final int GL_STENCIL_INDEX
See Also:
Constant Field Values

GL_STENCIL_INDEX8

static final int GL_STENCIL_INDEX8
See Also:
Constant Field Values

GL_RENDERBUFFER_WIDTH

static final int GL_RENDERBUFFER_WIDTH
See Also:
Constant Field Values

GL_RENDERBUFFER_HEIGHT

static final int GL_RENDERBUFFER_HEIGHT
See Also:
Constant Field Values

GL_RENDERBUFFER_INTERNAL_FORMAT

static final int GL_RENDERBUFFER_INTERNAL_FORMAT
See Also:
Constant Field Values

GL_RENDERBUFFER_RED_SIZE

static final int GL_RENDERBUFFER_RED_SIZE
See Also:
Constant Field Values

GL_RENDERBUFFER_GREEN_SIZE

static final int GL_RENDERBUFFER_GREEN_SIZE
See Also:
Constant Field Values

GL_RENDERBUFFER_BLUE_SIZE

static final int GL_RENDERBUFFER_BLUE_SIZE
See Also:
Constant Field Values

GL_RENDERBUFFER_ALPHA_SIZE

static final int GL_RENDERBUFFER_ALPHA_SIZE
See Also:
Constant Field Values

GL_RENDERBUFFER_DEPTH_SIZE

static final int GL_RENDERBUFFER_DEPTH_SIZE
See Also:
Constant Field Values

GL_RENDERBUFFER_STENCIL_SIZE

static final int GL_RENDERBUFFER_STENCIL_SIZE
See Also:
Constant Field Values

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE

static final int GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE
See Also:
Constant Field Values

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME

static final int GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME
See Also:
Constant Field Values

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL

static final int GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL
See Also:
Constant Field Values

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE

static final int GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE
See Also:
Constant Field Values

GL_COLOR_ATTACHMENT0

static final int GL_COLOR_ATTACHMENT0
See Also:
Constant Field Values

GL_DEPTH_ATTACHMENT

static final int GL_DEPTH_ATTACHMENT
See Also:
Constant Field Values

GL_STENCIL_ATTACHMENT

static final int GL_STENCIL_ATTACHMENT
See Also:
Constant Field Values

GL_NONE

static final int GL_NONE
See Also:
Constant Field Values

GL_FRAMEBUFFER_COMPLETE

static final int GL_FRAMEBUFFER_COMPLETE
See Also:
Constant Field Values

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT

static final int GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
See Also:
Constant Field Values

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT

static final int GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT
See Also:
Constant Field Values

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS

static final int GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS
See Also:
Constant Field Values

GL_FRAMEBUFFER_UNSUPPORTED

static final int GL_FRAMEBUFFER_UNSUPPORTED
See Also:
Constant Field Values

GL_FRAMEBUFFER_BINDING

static final int GL_FRAMEBUFFER_BINDING
See Also:
Constant Field Values

GL_RENDERBUFFER_BINDING

static final int GL_RENDERBUFFER_BINDING
See Also:
Constant Field Values

GL_MAX_RENDERBUFFER_SIZE

static final int GL_MAX_RENDERBUFFER_SIZE
See Also:
Constant Field Values

GL_INVALID_FRAMEBUFFER_OPERATION

static final int GL_INVALID_FRAMEBUFFER_OPERATION
See Also:
Constant Field Values
Method Detail

glAttachShader

void glAttachShader(int program,
                    int shader)

glBindAttribLocation

void glBindAttribLocation(int program,
                          int index,
                          java.lang.String name)

glBindBuffer

void glBindBuffer(int target,
                  int buffer)

glBindFramebuffer

void glBindFramebuffer(int target,
                       int framebuffer)

glBindRenderbuffer

void glBindRenderbuffer(int target,
                        int renderbuffer)

glBlendColor

void glBlendColor(float red,
                  float green,
                  float blue,
                  float alpha)

glBlendEquation

void glBlendEquation(int mode)

glBlendEquationSeparate

void glBlendEquationSeparate(int modeRGB,
                             int modeAlpha)

glBlendFuncSeparate

void glBlendFuncSeparate(int srcRGB,
                         int dstRGB,
                         int srcAlpha,
                         int dstAlpha)

glBufferData

void glBufferData(int target,
                  int size,
                  java.nio.Buffer data,
                  int usage)

glBufferSubData

void glBufferSubData(int target,
                     int offset,
                     int size,
                     java.nio.Buffer data)

glCheckFramebufferStatus

int glCheckFramebufferStatus(int target)

glCompileShader

void glCompileShader(int shader)

glCreateProgram

int glCreateProgram()

glCreateShader

int glCreateShader(int type)

glDeleteBuffers

void glDeleteBuffers(int n,
                     java.nio.IntBuffer buffers)

glDeleteFramebuffers

void glDeleteFramebuffers(int n,
                          java.nio.IntBuffer framebuffers)

glDeleteProgram

void glDeleteProgram(int program)

glDeleteRenderbuffers

void glDeleteRenderbuffers(int n,
                           java.nio.IntBuffer renderbuffers)

glDeleteShader

void glDeleteShader(int shader)

glDetachShader

void glDetachShader(int program,
                    int shader)

glDisableVertexAttribArray

void glDisableVertexAttribArray(int index)

glDrawElements

void glDrawElements(int mode,
                    int count,
                    int type,
                    int indices)

glEnableVertexAttribArray

void glEnableVertexAttribArray(int index)

glFramebufferRenderbuffer

void glFramebufferRenderbuffer(int target,
                               int attachment,
                               int renderbuffertarget,
                               int renderbuffer)

glFramebufferTexture2D

void glFramebufferTexture2D(int target,
                            int attachment,
                            int textarget,
                            int texture,
                            int level)

glGenBuffers

void glGenBuffers(int n,
                  java.nio.IntBuffer buffers)

glGenerateMipmap

void glGenerateMipmap(int target)

glGenFramebuffers

void glGenFramebuffers(int n,
                       java.nio.IntBuffer framebuffers)

glGenRenderbuffers

void glGenRenderbuffers(int n,
                        java.nio.IntBuffer renderbuffers)

glGetActiveAttrib

java.lang.String glGetActiveAttrib(int program,
                                   int index,
                                   java.nio.IntBuffer size,
                                   java.nio.Buffer type)

glGetActiveUniform

java.lang.String glGetActiveUniform(int program,
                                    int index,
                                    java.nio.IntBuffer size,
                                    java.nio.Buffer type)

glGetAttachedShaders

void glGetAttachedShaders(int program,
                          int maxcount,
                          java.nio.Buffer count,
                          java.nio.IntBuffer shaders)

glGetAttribLocation

int glGetAttribLocation(int program,
                        java.lang.String name)

glGetBooleanv

void glGetBooleanv(int pname,
                   java.nio.Buffer params)

glGetBufferParameteriv

void glGetBufferParameteriv(int target,
                            int pname,
                            java.nio.IntBuffer params)

glGetFloatv

void glGetFloatv(int pname,
                 java.nio.FloatBuffer params)

glGetFramebufferAttachmentParameteriv

void glGetFramebufferAttachmentParameteriv(int target,
                                           int attachment,
                                           int pname,
                                           java.nio.IntBuffer params)

glGetProgramiv

void glGetProgramiv(int program,
                    int pname,
                    java.nio.IntBuffer params)

glGetProgramInfoLog

java.lang.String glGetProgramInfoLog(int program)

glGetRenderbufferParameteriv

void glGetRenderbufferParameteriv(int target,
                                  int pname,
                                  java.nio.IntBuffer params)

glGetShaderiv

void glGetShaderiv(int shader,
                   int pname,
                   java.nio.IntBuffer params)

glGetShaderInfoLog

java.lang.String glGetShaderInfoLog(int shader)

glGetShaderPrecisionFormat

void glGetShaderPrecisionFormat(int shadertype,
                                int precisiontype,
                                java.nio.IntBuffer range,
                                java.nio.IntBuffer precision)

glGetShaderSource

void glGetShaderSource(int shader,
                       int bufsize,
                       java.nio.Buffer length,
                       java.lang.String source)

glGetTexParameterfv

void glGetTexParameterfv(int target,
                         int pname,
                         java.nio.FloatBuffer params)

glGetTexParameteriv

void glGetTexParameteriv(int target,
                         int pname,
                         java.nio.IntBuffer params)

glGetUniformfv

void glGetUniformfv(int program,
                    int location,
                    java.nio.FloatBuffer params)

glGetUniformiv

void glGetUniformiv(int program,
                    int location,
                    java.nio.IntBuffer params)

glGetUniformLocation

int glGetUniformLocation(int program,
                         java.lang.String name)

glGetVertexAttribfv

void glGetVertexAttribfv(int index,
                         int pname,
                         java.nio.FloatBuffer params)

glGetVertexAttribiv

void glGetVertexAttribiv(int index,
                         int pname,
                         java.nio.IntBuffer params)

glGetVertexAttribPointerv

void glGetVertexAttribPointerv(int index,
                               int pname,
                               java.nio.Buffer pointer)

glIsBuffer

boolean glIsBuffer(int buffer)

glIsEnabled

boolean glIsEnabled(int cap)

glIsFramebuffer

boolean glIsFramebuffer(int framebuffer)

glIsProgram

boolean glIsProgram(int program)

glIsRenderbuffer

boolean glIsRenderbuffer(int renderbuffer)

glIsShader

boolean glIsShader(int shader)

glIsTexture

boolean glIsTexture(int texture)

glLinkProgram

void glLinkProgram(int program)

glReleaseShaderCompiler

void glReleaseShaderCompiler()

glRenderbufferStorage

void glRenderbufferStorage(int target,
                           int internalformat,
                           int width,
                           int height)

glSampleCoverage

void glSampleCoverage(float value,
                      boolean invert)

glShaderBinary

void glShaderBinary(int n,
                    java.nio.IntBuffer shaders,
                    int binaryformat,
                    java.nio.Buffer binary,
                    int length)

glShaderSource

void glShaderSource(int shader,
                    java.lang.String string)

glStencilFuncSeparate

void glStencilFuncSeparate(int face,
                           int func,
                           int ref,
                           int mask)

glStencilMaskSeparate

void glStencilMaskSeparate(int face,
                           int mask)

glStencilOpSeparate

void glStencilOpSeparate(int face,
                         int fail,
                         int zfail,
                         int zpass)

glTexParameterfv

void glTexParameterfv(int target,
                      int pname,
                      java.nio.FloatBuffer params)

glTexParameteri

void glTexParameteri(int target,
                     int pname,
                     int param)

glTexParameteriv

void glTexParameteriv(int target,
                      int pname,
                      java.nio.IntBuffer params)

glUniform1f

void glUniform1f(int location,
                 float x)

glUniform1fv

void glUniform1fv(int location,
                  int count,
                  java.nio.FloatBuffer v)

glUniform1i

void glUniform1i(int location,
                 int x)

glUniform1iv

void glUniform1iv(int location,
                  int count,
                  java.nio.IntBuffer v)

glUniform2f

void glUniform2f(int location,
                 float x,
                 float y)

glUniform2fv

void glUniform2fv(int location,
                  int count,
                  java.nio.FloatBuffer v)

glUniform2i

void glUniform2i(int location,
                 int x,
                 int y)

glUniform2iv

void glUniform2iv(int location,
                  int count,
                  java.nio.IntBuffer v)

glUniform3f

void glUniform3f(int location,
                 float x,
                 float y,
                 float z)

glUniform3fv

void glUniform3fv(int location,
                  int count,
                  java.nio.FloatBuffer v)

glUniform3i

void glUniform3i(int location,
                 int x,
                 int y,
                 int z)

glUniform3iv

void glUniform3iv(int location,
                  int count,
                  java.nio.IntBuffer v)

glUniform4f

void glUniform4f(int location,
                 float x,
                 float y,
                 float z,
                 float w)

glUniform4fv

void glUniform4fv(int location,
                  int count,
                  java.nio.FloatBuffer v)

glUniform4i

void glUniform4i(int location,
                 int x,
                 int y,
                 int z,
                 int w)

glUniform4iv

void glUniform4iv(int location,
                  int count,
                  java.nio.IntBuffer v)

glUniformMatrix2fv

void glUniformMatrix2fv(int location,
                        int count,
                        boolean transpose,
                        java.nio.FloatBuffer value)

glUniformMatrix3fv

void glUniformMatrix3fv(int location,
                        int count,
                        boolean transpose,
                        java.nio.FloatBuffer value)

glUniformMatrix4fv

void glUniformMatrix4fv(int location,
                        int count,
                        boolean transpose,
                        java.nio.FloatBuffer value)

glUseProgram

void glUseProgram(int program)

glValidateProgram

void glValidateProgram(int program)

glVertexAttrib1f

void glVertexAttrib1f(int indx,
                      float x)

glVertexAttrib1fv

void glVertexAttrib1fv(int indx,
                       java.nio.FloatBuffer values)

glVertexAttrib2f

void glVertexAttrib2f(int indx,
                      float x,
                      float y)

glVertexAttrib2fv

void glVertexAttrib2fv(int indx,
                       java.nio.FloatBuffer values)

glVertexAttrib3f

void glVertexAttrib3f(int indx,
                      float x,
                      float y,
                      float z)

glVertexAttrib3fv

void glVertexAttrib3fv(int indx,
                       java.nio.FloatBuffer values)

glVertexAttrib4f

void glVertexAttrib4f(int indx,
                      float x,
                      float y,
                      float z,
                      float w)

glVertexAttrib4fv

void glVertexAttrib4fv(int indx,
                       java.nio.FloatBuffer values)

glVertexAttribPointer

void glVertexAttribPointer(int indx,
                           int size,
                           int type,
                           boolean normalized,
                           int stride,
                           java.nio.Buffer ptr)

glVertexAttribPointer

void glVertexAttribPointer(int indx,
                           int size,
                           int type,
                           boolean normalized,
                           int stride,
                           int ptr)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.graphics.GL20 (libgdx API)

Uses of Interface
com.badlogic.gdx.graphics.GL20

Packages that use GL20
com.badlogic.gdx

Uses of GL20 in com.badlogic.gdx

Fields in com.badlogic.gdx declared as GL20
static GL20 Gdx.gl20

Methods in com.badlogic.gdx that return GL20
 GL20 Graphics.getGL20()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


GLCommon (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Interface GLCommon

All Known Subinterfaces:
GL10, GL11, GL20
public interface GLCommon

This interface defines methods common to GL10, GL11 and GL20.

Author:
mzechner

Method Summary
void | glActiveTexture(int texture)
void | glBindTexture(int target, int texture)
void | glBlendFunc(int sfactor, int dfactor)
void | glClear(int mask)
void | glClearColor(float red, float green, float blue, float alpha)
void | glClearDepthf(float depth)
void | glClearStencil(int s)
void | glColorMask(boolean red, boolean green, boolean blue, boolean alpha)
void | glCompressedTexImage2D(int target, int level, int internalformat, int width, int height, int border, int imageSize, java.nio.Buffer data)
void | glCompressedTexSubImage2D(int target, int level, int xoffset, int yoffset, int width, int height, int format, int imageSize, java.nio.Buffer data)
void | glCopyTexImage2D(int target, int level, int internalformat, int x, int y, int width, int height, int border)
void | glCopyTexSubImage2D(int target, int level, int xoffset, int yoffset, int x, int y, int width, int height)
void | glCullFace(int mode)
void | glDeleteTextures(int n, java.nio.IntBuffer textures)
void | glDepthFunc(int func)
void | glDepthMask(boolean flag)
void | glDepthRangef(float zNear, float zFar)
void | glDisable(int cap)
void | glDrawArrays(int mode, int first, int count)
void | glDrawElements(int mode, int count, int type, java.nio.Buffer indices)
void | glEnable(int cap)
void | glFinish()
void | glFlush()
void | glFrontFace(int mode)
void | glGenTextures(int n, java.nio.IntBuffer textures)
int | glGetError()
void | glGetIntegerv(int pname, java.nio.IntBuffer params)
java.lang.String | glGetString(int name)
void | glHint(int target, int mode)
void | glLineWidth(float width)
void | glPixelStorei(int pname, int param)
void | glPolygonOffset(float factor, float units)
void | glReadPixels(int x, int y, int width, int height, int format, int type, java.nio.Buffer pixels)
void | glScissor(int x, int y, int width, int height)
void | glStencilFunc(int func, int ref, int mask)
void | glStencilMask(int mask)
void | glStencilOp(int fail, int zfail, int zpass)
void | glTexImage2D(int target, int level, int internalformat, int width, int height, int border, int format, int type, java.nio.Buffer pixels)
void | glTexParameterf(int target, int pname, float param)
void | glTexSubImage2D(int target, int level, int xoffset, int yoffset, int width, int height, int format, int type, java.nio.Buffer pixels)
void | glViewport(int x, int y, int width, int height)

Method Detail

glActiveTexture

void glActiveTexture(int texture)

glBindTexture

void glBindTexture(int target,
                   int texture)

glBlendFunc

void glBlendFunc(int sfactor,
                 int dfactor)

glClear

void glClear(int mask)

glClearColor

void glClearColor(float red,
                  float green,
                  float blue,
                  float alpha)

glClearDepthf

void glClearDepthf(float depth)

glClearStencil

void glClearStencil(int s)

glColorMask

void glColorMask(boolean red,
                 boolean green,
                 boolean blue,
                 boolean alpha)

glCompressedTexImage2D

void glCompressedTexImage2D(int target,
                            int level,
                            int internalformat,
                            int width,
                            int height,
                            int border,
                            int imageSize,
                            java.nio.Buffer data)

glCompressedTexSubImage2D

void glCompressedTexSubImage2D(int target,
                               int level,
                               int xoffset,
                               int yoffset,
                               int width,
                               int height,
                               int format,
                               int imageSize,
                               java.nio.Buffer data)

glCopyTexImage2D

void glCopyTexImage2D(int target,
                      int level,
                      int internalformat,
                      int x,
                      int y,
                      int width,
                      int height,
                      int border)

glCopyTexSubImage2D

void glCopyTexSubImage2D(int target,
                         int level,
                         int xoffset,
                         int yoffset,
                         int x,
                         int y,
                         int width,
                         int height)

glCullFace

void glCullFace(int mode)

glDeleteTextures

void glDeleteTextures(int n,
                      java.nio.IntBuffer textures)

glDepthFunc

void glDepthFunc(int func)

glDepthMask

void glDepthMask(boolean flag)

glDepthRangef

void glDepthRangef(float zNear,
                   float zFar)

glDisable

void glDisable(int cap)

glDrawArrays

void glDrawArrays(int mode,
                  int first,
                  int count)

glDrawElements

void glDrawElements(int mode,
                    int count,
                    int type,
                    java.nio.Buffer indices)

glEnable

void glEnable(int cap)

glFinish

void glFinish()

glFlush

void glFlush()

glFrontFace

void glFrontFace(int mode)

glGenTextures

void glGenTextures(int n,
                   java.nio.IntBuffer textures)

glGetError

int glGetError()

glGetIntegerv

void glGetIntegerv(int pname,
                   java.nio.IntBuffer params)

glGetString

java.lang.String glGetString(int name)

glHint

void glHint(int target,
            int mode)

glLineWidth

void glLineWidth(float width)

glPixelStorei

void glPixelStorei(int pname,
                   int param)

glPolygonOffset

void glPolygonOffset(float factor,
                     float units)

glReadPixels

void glReadPixels(int x,
                  int y,
                  int width,
                  int height,
                  int format,
                  int type,
                  java.nio.Buffer pixels)

glScissor

void glScissor(int x,
               int y,
               int width,
               int height)

glStencilFunc

void glStencilFunc(int func,
                   int ref,
                   int mask)

glStencilMask

void glStencilMask(int mask)

glStencilOp

void glStencilOp(int fail,
                 int zfail,
                 int zpass)

glTexImage2D

void glTexImage2D(int target,
                  int level,
                  int internalformat,
                  int width,
                  int height,
                  int border,
                  int format,
                  int type,
                  java.nio.Buffer pixels)

glTexParameterf

void glTexParameterf(int target,
                     int pname,
                     float param)

glTexSubImage2D

void glTexSubImage2D(int target,
                     int level,
                     int xoffset,
                     int yoffset,
                     int width,
                     int height,
                     int format,
                     int type,
                     java.nio.Buffer pixels)

glViewport

void glViewport(int x,
                int y,
                int width,
                int height)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.graphics.GLCommon (libgdx API)

Uses of Interface
com.badlogic.gdx.graphics.GLCommon

Packages that use GLCommon
com.badlogic.gdx
com.badlogic.gdx.graphics

Uses of GLCommon in com.badlogic.gdx

Fields in com.badlogic.gdx declared as GLCommon
static GLCommon Gdx.gl

Methods in com.badlogic.gdx that return GLCommon
 GLCommon Graphics.getGLCommon()

Uses of GLCommon in com.badlogic.gdx.graphics

Subinterfaces of GLCommon in com.badlogic.gdx.graphics
interface | GL10 Interface wrapping all standard OpenGL ES 1.0 methods.
interface | GL11 Interface wrapping all OpenGL ES 1.1 methods.
interface | GL20 Interface wrapping all the methods of OpenGL ES 2.0

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Graphics (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Interface Graphics

public interface Graphics

This interface encapsulates the communication with the graphics processor. It allows to retrieve GL10, GL11 and GL20 instances depending on the available hardware and configuration of the Application. Additionally it features methods to generate Pixmaps and Textures.

Textures can be either managed or not managed. Managed and Textures will be restored when the OpenGL context is lost. An OpenGL ES context loss happens when a user pauses the Application ( ApplicationListener.pause()) and switches to another application on Android. On the desktop there is no concept of context loss for OpenGL.

There are many more utility classes that are not directly generated by the Graphics interfaces. See VertexArray, VertexBufferObject, IndexBufferObject, Mesh, ShaderProgram and FrameBuffer, BitmapFont, SpriteBatch and so on. All these classes are managed, meaning they don't need to be reloaded on a context loss. Explore the com.badlogic.gdx.graphics package for more classes that might come in handy.

All graphical resources, be the generated by the Graphics interface or via a constructor must be disposed when no longer used!

Author:
mzechner

Nested Class Summary
static class Graphics.GraphicsType
Enumeration describing different types of Graphics implementations.
Method Summary
float | getDeltaTime()
int | getFramesPerSecond()
GL10 | getGL10()
GL11 | getGL11()
GL20 | getGL20()
GLCommon | getGLCommon()
int | getHeight()
float | getPpcX()
float | getPpcY()
float | getPpiX()
float | getPpiY()
Graphics.GraphicsType | getType()
int | getWidth()
boolean | isGL11Available() Returns whether OpenGL ES 1.1 is available.
boolean | isGL20Available() Returns whether OpenGL ES 2.0 is available.
Pixmap | newPixmap(FileHandle file) Creates a new Pixmap from the given file which is assumed to point to a bitmap in a readable format.
Pixmap | newPixmap(java.io.InputStream in) Creates a new Pixmap from the given InputStream which is assumed to point to a bitmap in a readable format.
Pixmap | newPixmap(int width, int height, Pixmap.Format format) Creates a new Pixmap with the specified dimensions and format.
Pixmap | newPixmap(java.lang.Object nativePixmap) Creates a new Pixmap from the given native pixmap.
Texture | newTexture(FileHandle file, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture from the given FileHandle using the specified minification and magnification filter and texture wraps in u and v.
Texture | newTexture(TextureData textureData, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture that loads its data from the given TextureData.
Texture | newUnmanagedTexture(int width, int height, Pixmap.Format format, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture with the specified dimensions, minification and magnification filters and texture wraps in u and v.
Texture | newUnmanagedTexture(Pixmap pixmap, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture from the given Pixmap using the specified minification and magnification filter and texture wraps in u and v.

Method Detail

isGL11Available

boolean isGL11Available()
Returns whether OpenGL ES 1.1 is available. If it is you can get an instance of GL11 via getGL11() to access OpenGL ES 1.1 functionality. This also implies that getGL10() will return an instance.

Returns:
whether OpenGL ES 1.1 is available

isGL20Available

boolean isGL20Available()
Returns whether OpenGL ES 2.0 is available. If it is you can get an instance of GL20 via getGL20() to access OpenGL ES 2.0 functionality. Note that this functionality will only be available if you instructed the Application instance to use OpenGL ES 2.0!

Returns:
whether OpenGL ES 2.0 is available

getGLCommon

GLCommon getGLCommon()
Returns:
a GLCommon instance

getGL10

GL10 getGL10()
Returns:
the GL10 instance or null if not supported

getGL11

GL11 getGL11()
Returns:
the GL11 instance or null if not supported

getGL20

GL20 getGL20()
Returns:
the GL20 instance or null if not supported

getWidth

int getWidth()
Returns:
the width in pixels of the display surface

getHeight

int getHeight()
Returns:
the height in pixels of the display surface

getDeltaTime

float getDeltaTime()
Returns:
the time span between the current frame and the last frame in seconds

getFramesPerSecond

int getFramesPerSecond()
Returns:
the average number of frames per second

newPixmap

Pixmap newPixmap(int width,
                 int height,
                 Pixmap.Format format)
Creates a new Pixmap with the specified dimensions and format.

Parameters:
width - the width in pixels
height - the height in pixels
format - the Pixmap.Format
Returns:
a new Pixmap
Throws:
GdxRuntimeException - in case the pixmap could not be created

newPixmap

Pixmap newPixmap(java.io.InputStream in)
Creates a new Pixmap from the given InputStream which is assumed to point to a bitmap in a readable format. Currently supported formats are PNG and JPEG. The InputStream is not closed.

Parameters:
in - the InputStream
Returns:
a new Pixmap
Throws:
GdxRuntimeException - in case the Pixmap could not be created.

newPixmap

Pixmap newPixmap(FileHandle file)
Creates a new Pixmap from the given file which is assumed to point to a bitmap in a readable format. Currently supported formats are PNG and JPEG.

Parameters:
file - the file to load the pixmap from
Returns:
a new Pixmap
Throws:
GdxRuntimeException - in case the Pixmap could not be created.

newPixmap

Pixmap newPixmap(java.lang.Object nativePixmap)
Creates a new Pixmap from the given native pixmap. The native pixmap is an instance of BufferedImage on the desktop or Bitmap on Android.

Parameters:
nativePixmap - the native pixmap
Returns:
a new Pixmap
Throws:
GdxRuntimeException - in case the pixmap could not be created

newUnmanagedTexture

Texture newUnmanagedTexture(int width,
                            int height,
                            Pixmap.Format format,
                            Texture.TextureFilter minFilter,
                            Texture.TextureFilter magFilter,
                            Texture.TextureWrap uWrap,
                            Texture.TextureWrap vWrap)
Creates a new Texture with the specified dimensions, minification and magnification filters and texture wraps in u and v. The Texture has to be disposed via the Texture.dispose() methods once it is no longer used. The width and height of the texture have to be a power of two! If mipmapping is specified the texture has to be square. Textures created via this method are not be managed and have to be recreated manually when the OpenGL context is lost.

Parameters:
width - the width in pixels, has to be a power of 2
height - the height in pixels, has to be a power of 2
format - the format of the texture
minFilter - the minification Texture.TextureFilter
magFilter - the magnification Texture.TextureFilter
uWrap - the Texture.TextureWrap in u
vWrap - the Texture.TextureWrap in v
Returns:
a new Texture
Throws:
GdxRuntimeException - in case the Texture could not be created

newUnmanagedTexture

Texture newUnmanagedTexture(Pixmap pixmap,
                            Texture.TextureFilter minFilter,
                            Texture.TextureFilter magFilter,
                            Texture.TextureWrap uWrap,
                            Texture.TextureWrap vWrap)
Creates a new Texture from the given Pixmap using the specified minification and magnification filter and texture wraps in u and v. If the minification filter is specified as Texture.TextureFilter#MipMap mipmaps will be created automatically. The Texture has to be disposed via the Texture.dispose() methods once it is no longer used. The Pixmap's width and height have to be a power of 2! If mipmaps are generated the texture must be square. Textures created via this method can not be managed and have to be recreated manually when the OpenGL context is lost.

Parameters:
pixmap - the pixmap
minFilter - the minification Texture.TextureFilter
magFilter - the magnification Texture.TextureFilter
uWrap - the Texture.TextureWrap in u
vWrap - the Texture.TextureWrap in v
Returns:
a new Texture
Throws:
GdxRuntimeException - in case the texture could not be created

newTexture

Texture newTexture(FileHandle file,
                   Texture.TextureFilter minFilter,
                   Texture.TextureFilter magFilter,
                   Texture.TextureWrap uWrap,
                   Texture.TextureWrap vWrap)
Creates a new Texture from the given FileHandle using the specified minification and magnification filter and texture wraps in u and v. If the minification filter is specified as Texture.TextureFilter#MipMap mipmaps will be created automatically. The Texture has to be disposed via the Texture.dispose() methods once it is no longer used. The FileHandle must point to a valid JPG or PNG file. The Pixmap's width and height have to be a power of 2! If mipmaps are generated the texture has to be square. Textures created via this method are managed and will be recreated automatically after the OpenGL context has been lost and recreated.

Parameters:
file - the FileHandle pointing to a JPG or PNG file.
minFilter - the minification Texture.TextureFilter
magFilter - the magnification Texture.TextureFilter
uWrap - the Texture.TextureWrap in u
vWrap - the Texture.TextureWrap in v
Returns:
a new Texture
Throws:
GdxRuntimeException - in case the texture could not be created

newTexture

Texture newTexture(TextureData textureData,
                   Texture.TextureFilter minFilter,
                   Texture.TextureFilter magFilter,
                   Texture.TextureWrap uWrap,
                   Texture.TextureWrap vWrap)
Creates a new Texture that loads its data from the given TextureData. The texture is managed and the TextureData may be asked to load the image data multiple times throughout the application's lifetime. If the minification filter is specified as Texture.TextureFilter#MipMap, mipmaps will not be created automatically and must be handled by the TextureData. The Texture must be disposed via the Texture.dispose() methods once it is no longer used. Textures created via this method are managed and will be recreated automatically after the OpenGL context has been lost and recreated.

Parameters:
textureData - Loads the texture data into GL.
Throws:
GdxRuntimeException - if the texture could not be created.

getType

Graphics.GraphicsType getType()
Returns:
the Graphics.GraphicsType of this Graphics instance

getPpiX

float getPpiX()
Returns:
the pixels per inch on the x-axis

getPpiY

float getPpiY()
Returns:
the pixels per inch on the y-axis

getPpcX

float getPpcX()
Returns:
the pixels per centimeter on the x-axis

getPpcY

float getPpcY()
Returns:
the pixels per centimeter on the y-axis.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.Graphics (libgdx API)

Uses of Interface
com.badlogic.gdx.Graphics

Packages that use Graphics
com.badlogic.gdx
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl

Uses of Graphics in com.badlogic.gdx

Fields in com.badlogic.gdx declared as Graphics
static Graphics Gdx.graphics

Methods in com.badlogic.gdx that return Graphics
 Graphics Application.getGraphics()

Uses of Graphics in com.badlogic.gdx.backends.android

Methods in com.badlogic.gdx.backends.android that return Graphics
 Graphics AndroidApplication.getGraphics()

Uses of Graphics in com.badlogic.gdx.backends.jogl

Methods in com.badlogic.gdx.backends.jogl that return Graphics
 Graphics JoglApplication.getGraphics()

Uses of Graphics in com.badlogic.gdx.backends.lwjgl

Methods in com.badlogic.gdx.backends.lwjgl that return Graphics
Graphics | LwjglApplication.getGraphics()
Graphics | LwjglCanvas.getGraphics()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Graphics.GraphicsType (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx
Enum Graphics.GraphicsType

java.lang.Object
    extended by  java.lang.Enum<Graphics.GraphicsType>
        extended by  com.badlogic.gdx.Graphics.GraphicsType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Graphics.GraphicsType>
Enclosing interface:
Graphics
public static enum Graphics.GraphicsType
extends java.lang.Enum<Graphics.GraphicsType>

Enumeration describing different types of Graphics implementations.

Author:
mzechner

Enum Constant Summary
AndroidGL
JoglGL
LWJGL
Method Summary
static Graphics.GraphicsType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Graphics.GraphicsType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

AndroidGL

public static final Graphics.GraphicsType AndroidGL

JoglGL

public static final Graphics.GraphicsType JoglGL

LWJGL

public static final Graphics.GraphicsType LWJGL
Method Detail

values

public static Graphics.GraphicsType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Graphics.GraphicsType c : Graphics.GraphicsType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Graphics.GraphicsType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.Graphics.GraphicsType (libgdx API)

Uses of Class
com.badlogic.gdx.Graphics.GraphicsType

Packages that use Graphics.GraphicsType
com.badlogic.gdx

Uses of Graphics.GraphicsType in com.badlogic.gdx

Methods in com.badlogic.gdx that return Graphics.GraphicsType
Graphics.GraphicsType | Graphics.getType()
static Graphics.GraphicsType | Graphics.GraphicsType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Graphics.GraphicsType[] | Graphics.GraphicsType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Group (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d
Class Group

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.Actor
        extended by  com.badlogic.gdx.scenes.scene2d.Group
Direct Known Subclasses:
BoundGroup
public class Group
extends Actor

A group is an Actor that contains other Actors (also other Groups which are Actors).

Author:
mzechner

Field Summary
protected java.util.List<Actor> | children
static boolean | debug
static Texture | debugTexture
Actor | focusedActor
protected java.util.List<Group> | groups
protected java.util.List<Actor> | immutableChildren
protected java.util.List<Group> | immutableGroups
Actor | lastTouchedChild
protected java.util.Map<java.lang.String,Actor> | namesToActors
protected Matrix4 | oldBatchTransform
protected Matrix3 | scenetransform
protected Matrix4 | tmp4
protected Matrix3 | transform
Fields inherited from class com.badlogic.gdx.scenes.scene2d.Actor
actions, color, height, name, originX, originY, parent, rotation, scaleX, scaleY, touchable, width, x, y
Constructor Summary
Group(java.lang.String name)
Creates a new Group with the given name.
Method Summary
protected void | act(float delta)
void | addActor(Actor actor) Adds an Actor to this Group.
static void | disableDebugging()
static void | enableDebugging(java.lang.String debugTextureFile)
Actor | findActor(java.lang.String name) Finds the Actor with the given name in this Group and its children.
void | focus(Actor actor) Sets the focus to the given child Actor.
java.util.List<Actor> | getActors()
java.util.List<Group> | getGroups()
Actor | hit(float x, float y)
void | removeActor(Actor actor) Removes an Actor from this Group.
protected void | render(SpriteBatch batch) Renders the Actor.
boolean | swapActor(Actor first, Actor second) Swap two actors' sort order by reference.
boolean | swapActor(int first, int second) Swap two actors' sort order by index.
static void | toChildCoordinates(Actor child, float x, float y, Vector2 out) Transforms the coordinates given in the child's parent coordinate system to the child Actor's coordinate system.
protected boolean | touchDown(float x, float y, int pointer)
protected boolean | touchDragged(float x, float y, int pointer)
protected boolean | touchUp(float x, float y, int pointer)
protected void | updateTransform()
Methods inherited from class com.badlogic.gdx.scenes.scene2d.Actor
action, clearActions, remove, toLocalCoordinates, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

debugTexture

public static Texture debugTexture

debug

public static boolean debug

tmp4

protected final Matrix4 tmp4

oldBatchTransform

protected final Matrix4 oldBatchTransform

transform

protected final Matrix3 transform

scenetransform

protected final Matrix3 scenetransform

children

protected final java.util.List<Actor> children

immutableChildren

protected final java.util.List<Actor> immutableChildren

groups

protected final java.util.List<Group> groups

immutableGroups

protected final java.util.List<Group> immutableGroups

namesToActors

protected final java.util.Map<java.lang.String,Actor> namesToActors

lastTouchedChild

public Actor lastTouchedChild

focusedActor

public Actor focusedActor
Constructor Detail

Group

public Group(java.lang.String name)
Creates a new Group with the given name.

Parameters:
name - the name of the group
Method Detail

updateTransform

protected void updateTransform()

act

protected void act(float delta)
Overrides:
act in class Actor

render

protected void render(SpriteBatch batch)
Description copied from class: Actor
Renders the Actor. The spriteBatch is configured so that the Actor can render in its parents coordinate system.

Specified by:
render in class Actor
Parameters:
batch - the spritebatch to render with

toChildCoordinates

public static void toChildCoordinates(Actor child,
                                      float x,
                                      float y,
                                      Vector2 out)
Transforms the coordinates given in the child's parent coordinate system to the child Actor's coordinate system.

Parameters:
child - the child Actor
x - the x-coordinate in the Group's coordinate system
y - the y-coordinate in the Group's coordinate system
out - the output Vector2

touchDown

protected boolean touchDown(float x,
                            float y,
                            int pointer)
Specified by:
touchDown in class Actor

touchUp

protected boolean touchUp(float x,
                          float y,
                          int pointer)
Specified by:
touchUp in class Actor

touchDragged

protected boolean touchDragged(float x,
                               float y,
                               int pointer)
Specified by:
touchDragged in class Actor

hit

public Actor hit(float x,
                 float y)
Specified by:
hit in class Actor

addActor

public void addActor(Actor actor)
Adds an Actor to this Group. The order Actors are added is reversed for hit testing and rendering.

Parameters:
actor - the Actor

removeActor

public void removeActor(Actor actor)
Removes an Actor from this Group.

Parameters:
actor -

findActor

public Actor findActor(java.lang.String name)
Finds the Actor with the given name in this Group and its children.

Parameters:
name - the name of the Actor
Returns:
the Actor or null

swapActor

public boolean swapActor(int first,
                         int second)
Swap two actors' sort order by index. 0 is lowest while getActors().size() - 1 is largest.

Parameters:
first - first Actor index
second - second Actor index
Returns:
false if indices are out of bound.

swapActor

public boolean swapActor(Actor first,
                         Actor second)
Swap two actors' sort order by reference.

Parameters:
first - first Actor
second - second Actor
Returns:
false if any of the Actors is not the child of this Group.

getActors

public java.util.List<Actor> getActors()
Returns:
all child Actors

getGroups

public java.util.List<Group> getGroups()
Returns:
all child Groups

focus

public void focus(Actor actor)
Sets the focus to the given child Actor. All subsequent touch events will be passed to this child Actor. To unset the focus simply pass null.

Parameters:
actor - the Actor

enableDebugging

public static void enableDebugging(java.lang.String debugTextureFile)

disableDebugging

public static void disableDebugging()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.Group (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.Group

Packages that use Group
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actors

Uses of Group in com.badlogic.gdx.scenes.scene2d

Fields in com.badlogic.gdx.scenes.scene2d declared as Group
 Group Actor.parent

Fields in com.badlogic.gdx.scenes.scene2d with type parameters of type Group
protected java.util.List<Group> | Group.groups
protected java.util.List<Group> | Group.immutableGroups

Methods in com.badlogic.gdx.scenes.scene2d that return Group
 Group Stage.getRoot()

Methods in com.badlogic.gdx.scenes.scene2d that return types with arguments of type Group
java.util.List<Group> | Group.getGroups()
java.util.List<Group> | Stage.getGroups()

Uses of Group in com.badlogic.gdx.scenes.scene2d.actors

Subclasses of Group in com.badlogic.gdx.scenes.scene2d.actors
class | BoundGroup This is a group that respects its width and height.
class | LinearGroup

Overview Package Class Use Tree Deprecated Index Help
libgdx API


API Help (libgdx API)

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Annotation Type

Each annotation type has its own separate page with the following sections:

  • Annotation Type declaration
  • Annotation Type description
  • Required Element Summary
  • Optional Element Summary
  • Element Detail

Enum

Each enum has its own separate page with the following sections:

  • Enum declaration
  • Enum description
  • Enum Constant Summary
  • Enum Constant Detail

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Image (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actors
Class Image

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.Actor
        extended by  com.badlogic.gdx.scenes.scene2d.actors.Image

public class Image
extends Actor

Field Summary
 TextureRegion region
Fields inherited from class com.badlogic.gdx.scenes.scene2d.Actor
actions, color, height, name, originX, originY, parent, rotation, scaleX, scaleY, touchable, width, x, y
Constructor Summary
Image(java.lang.String name)
Image(java.lang.String name, Texture texture)
Image(java.lang.String name, TextureRegion region)
Method Summary
Actor | hit(float x, float y)
protected void | render(SpriteBatch batch) Renders the Actor.
protected boolean | touchDown(float x, float y, int pointer)
protected boolean | touchDragged(float x, float y, int pointer)
protected boolean | touchUp(float x, float y, int pointer)
Methods inherited from class com.badlogic.gdx.scenes.scene2d.Actor
act, action, clearActions, remove, toLocalCoordinates, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

region

public final TextureRegion region
Constructor Detail

Image

public Image(java.lang.String name)

Image

public Image(java.lang.String name,
             Texture texture)

Image

public Image(java.lang.String name,
             TextureRegion region)
Method Detail

render

protected void render(SpriteBatch batch)
Description copied from class: Actor
Renders the Actor. The spriteBatch is configured so that the Actor can render in its parents coordinate system.

Specified by:
render in class Actor
Parameters:
batch - the spritebatch to render with

touchDown

protected boolean touchDown(float x,
                            float y,
                            int pointer)
Specified by:
touchDown in class Actor

touchUp

protected boolean touchUp(float x,
                          float y,
                          int pointer)
Specified by:
touchUp in class Actor

touchDragged

protected boolean touchDragged(float x,
                               float y,
                               int pointer)
Specified by:
touchDragged in class Actor

hit

public Actor hit(float x,
                 float y)
Specified by:
hit in class Actor
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actors.Image (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actors.Image

No usage of com.badlogic.gdx.scenes.scene2d.actors.Image

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ImmediateModeRenderer (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class ImmediateModeRenderer

java.lang.Object
    extended by  com.badlogic.gdx.graphics.ImmediateModeRenderer

public class ImmediateModeRenderer
extends java.lang.Object

An ImmediateModeRenderer allows you to perform immediate mode rendering as you were accustomed to in your desktop OpenGL environment. In order to draw something you first have to call begin(int) with the primitive type you want to render. Next you specify as many vertices as you want by first defining the vertex color, normal and texture coordinates followed by the vertex position which finalizes the definition of a single vertex. When you are done specifying the geometry you have to call end() to make the renderer render the geometry. Internally the renderer uses vertex arrays to render the provided geometry. This is not the best performing way to do this so use this class only for non performance critical low vertex count geometries while debugging. Note that this class of course only works with OpenGL ES 1.x.

Author:
mzechner

Constructor Summary
ImmediateModeRenderer()
Constructs a new ImmediateModeRenderer
Method Summary
void | begin(int primitiveType) Starts a new list of primitives.
void | color(float r, float g, float b, float a) Specifies the color of the current vertex
void | end() Renders the primitives just defined.
void | normal(float x, float y, float z) Specifies the normal of the current vertex
void | texCoord(float u, float v) Specifies the texture coordinates of the current vertex
void | vertex(float x, float y, float z) Specifies the position of the current vertex and finalizes it.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ImmediateModeRenderer

public ImmediateModeRenderer()
Constructs a new ImmediateModeRenderer

Method Detail

begin

public void begin(int primitiveType)
Starts a new list of primitives. The primitiveType specifies which primitives to draw. Can be any of GL10.GL_TRIANGLES, GL10.GL_LINES and so on. A maximum of 6000 vertices can be drawn at once.

Parameters:
primitiveType - the primitive type.

color

public void color(float r,
                  float g,
                  float b,
                  float a)
Specifies the color of the current vertex

Parameters:
r - the red component
g - the green component
b - the blue component
a - the alpha component

normal

public void normal(float x,
                   float y,
                   float z)
Specifies the normal of the current vertex

Parameters:
x - the x component
y - the y component
z - the z component

texCoord

public void texCoord(float u,
                     float v)
Specifies the texture coordinates of the current vertex

Parameters:
u - the u coordinate
v - the v coordinate

vertex

public void vertex(float x,
                   float y,
                   float z)
Specifies the position of the current vertex and finalizes it. After a call to this method you will effectively define a new vertex afterwards.

Parameters:
x - the x component
y - the y component
z - the z component

end

public void end()
Renders the primitives just defined.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.ImmediateModeRenderer (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.ImmediateModeRenderer

Packages that use ImmediateModeRenderer
com.badlogic.gdx.physics.box2d

Uses of ImmediateModeRenderer in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as ImmediateModeRenderer
protected  ImmediateModeRenderer Box2DDebugRenderer.renderer
the immediate mode renderer to output our debug drawings

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Index (libgdx API)

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

$

$(Action, float) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.Delay
$(float) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
$(float) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
$(float, float) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
$(Action) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.Forever
$(float, float, float) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
$(float, float, float) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
$(Action...) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.Parallel
$(Action, int) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
$(float, float) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
$(float, float) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
$(float, float, float) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
$(Action...) - Static method in class com.badlogic.gdx.scenes.scene2d.actions.Sequence

A

a - Variable in class com.badlogic.gdx.graphics.Color
the red, green, blue and alpha components
a - Variable in class com.badlogic.gdx.math.collision.Segment
the starting position
absolute(String) - Method in interface com.badlogic.gdx.Files
Convenience method that returns a Files.FileType.Absolute file handle.
accumulate(String, Object) - Method in class com.badlogic.gdx.utils.json.JSONObject
Accumulate values under a key.
act(float) - Method in interface com.badlogic.gdx.scenes.scene2d.Action
Apply the action.
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Delay
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Forever
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Parallel
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Sequence
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.Actor
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.Group
act(float) - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Calls the Actor.act(float) method of all contained Actors.
Action - Interface in com.badlogic.gdx.scenes.scene2d
An Action is used with an Actor and modifes the Actor's attributes over time.
action - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Delay
action - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Forever
action - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
action(Action) - Method in class com.badlogic.gdx.scenes.scene2d.Actor
Adds an Action to the Actor.
actions - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Parallel
actions - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Sequence
actions - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
active - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
Does this body start out active?
Actor - Class in com.badlogic.gdx.scenes.scene2d
An Actor is part of a Stage or a Group within a Stage.
Actor(String) - Constructor for class com.badlogic.gdx.scenes.scene2d.Actor
add(Color) - Method in class com.badlogic.gdx.graphics.Color
Adds the given color to this color.
add(Texture, float[], int, int) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified vertices to the cache.
add(Texture, float, float) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified texture to the cache.
add(Texture, float, float, int, int, float, float, float, float, float) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified texture to the cache.
add(Texture, float, float, int, int, int, int) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified texture to the cache.
add(Texture, float, float, float, float, int, int, int, int, boolean, boolean) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified texture to the cache.
add(Texture, float, float, float, float, float, float, float, float, float, int, int, int, int, boolean, boolean) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified texture to the cache.
add(TextureRegion, float, float) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified region to the cache.
add(TextureRegion, float, float, float, float) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified region to the cache.
add(TextureRegion, float, float, float, float, float, float, float, float, float) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified region to the cache.
add(Sprite) - Method in class com.badlogic.gdx.graphics.SpriteCache
Adds the specified sprite to the cache.
add(Vector3) - Method in class com.badlogic.gdx.math.CatmullRomSpline
Adds a new control point
add(Vector2) - Method in class com.badlogic.gdx.math.Vector2
Adds the given vector to this vector
add(float, float) - Method in class com.badlogic.gdx.math.Vector2
Adds the given components to this vector
add(Vector3) - Method in class com.badlogic.gdx.math.Vector3
Adds the given vector to this vector
add(float, float, float) - Method in class com.badlogic.gdx.math.Vector3
Adds the given vector to this component
add(float) - Method in class com.badlogic.gdx.math.Vector3
Adds the given value to all three components of the vector.
add(float) - Method in class com.badlogic.gdx.utils.FloatArray
add(float) - Method in class com.badlogic.gdx.utils.FloatBag
add(int) - Method in class com.badlogic.gdx.utils.IntArray
add(int) - Method in class com.badlogic.gdx.utils.IntBag
add(long) - Method in class com.badlogic.gdx.utils.LongArray
add(long) - Method in class com.badlogic.gdx.utils.LongBag
add(T) - Method in class com.badlogic.gdx.utils.PooledLinkedList
addActor(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actors.LinearGroup
addActor(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.Group
Adds an Actor to this Group.
addActor(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Adds an Actor to this stage
addAll(FloatArray) - Method in class com.badlogic.gdx.utils.FloatArray
addAll(FloatBag) - Method in class com.badlogic.gdx.utils.FloatArray
addAll(FloatBag) - Method in class com.badlogic.gdx.utils.FloatBag
addAll(FloatArray) - Method in class com.badlogic.gdx.utils.FloatBag
addAll(IntArray) - Method in class com.badlogic.gdx.utils.IntArray
addAll(IntBag) - Method in class com.badlogic.gdx.utils.IntArray
addAll(IntBag) - Method in class com.badlogic.gdx.utils.IntBag
addAll(IntArray) - Method in class com.badlogic.gdx.utils.IntBag
addAll(LongArray) - Method in class com.badlogic.gdx.utils.LongArray
addAll(LongBag) - Method in class com.badlogic.gdx.utils.LongArray
addAll(LongBag) - Method in class com.badlogic.gdx.utils.LongBag
addAll(LongArray) - Method in class com.badlogic.gdx.utils.LongBag
addParticle() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
addParticles(int) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
addPlane(Plane) - Method in class com.badlogic.gdx.math.Frustum
Adds a new Plane to the frustum
addProcessor(InputProcessor) - Method in class com.badlogic.gdx.InputMultiplexer
addr - Variable in class com.badlogic.gdx.physics.box2d.Body
the address of the body
addr - Variable in class com.badlogic.gdx.physics.box2d.Contact
the address
addr - Variable in class com.badlogic.gdx.physics.box2d.Fixture
the address of the fixture
addr - Variable in class com.badlogic.gdx.physics.box2d.Joint
the address of the joint
addr - Variable in class com.badlogic.gdx.physics.box2d.Shape
the address of the shape
addRegion(String, Texture, int, int, int, int) - Method in class com.badlogic.gdx.graphics.TextureAtlas
Adds a region to the atlas.
addRegion(String, TextureRegion) - Method in class com.badlogic.gdx.graphics.TextureAtlas
Adds a region to the atlas.
addValue(float) - Method in class com.badlogic.gdx.math.WindowedMean
adds a new sample to this mean.
alias - Variable in class com.badlogic.gdx.graphics.VertexAttribute
the alias for the attribute used in a ShaderProgram
allocateArrays() - Method in class com.badlogic.gdx.audio.analysis.DFT
allocateArrays() - Method in class com.badlogic.gdx.audio.analysis.FFT
allocateArrays() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
allocateFloatBuffer(int, int) - Static method in class com.badlogic.gdx.audio.analysis.AudioTools
Allcoates a direct buffer for the given number of samples and channels.
allocateShortBuffer(int, int) - Static method in class com.badlogic.gdx.audio.analysis.AudioTools
Allcoates a direct buffer for the given number of samples and channels.
allowCompletion() - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
allowSleep - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
Set this flag to false if this body should never fall asleep.
AndroidApplication - Class in com.badlogic.gdx.backends.android
An implementation of the Application interface for Android.
AndroidApplication() - Constructor for class com.badlogic.gdx.backends.android.AndroidApplication
angle - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
The world angle of the body in radians.
angularDamping - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
Angular damping is use to reduce the angular velocity.
angularVelocity - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
The angular velocity of the body.
ANY_KEY - Static variable in class com.badlogic.gdx.Input.Keys
app - Static variable in class com.badlogic.gdx.Gdx
append(String, Object) - Method in class com.badlogic.gdx.utils.json.JSONObject
Append values to the array under a key.
Application - Interface in com.badlogic.gdx
An Application is the main entry point of your project.
Application.ApplicationType - Enum in com.badlogic.gdx
Enumeration of possible Application types
ApplicationListener - Interface in com.badlogic.gdx
An ApplicationListener is called when the Application is created, resumed, rendering, paused or destroyed.
applyAngularImpulse(float) - Method in class com.badlogic.gdx.physics.box2d.Body
Apply an angular impulse.
applyForce(Vector2, Vector2) - Method in class com.badlogic.gdx.physics.box2d.Body
Apply a force at a world point.
applyLinearImpulse(Vector2, Vector2) - Method in class com.badlogic.gdx.physics.box2d.Body
Apply an impulse at a point.
applyTorque(float) - Method in class com.badlogic.gdx.physics.box2d.Body
Apply a torque.
array() - Method in class com.badlogic.gdx.utils.json.JSONWriter
Begin appending a new array.
aspect - Variable in class com.badlogic.gdx.math.Frustum
atan2(float, float) - Static method in class com.badlogic.gdx.utils.MathUtils
AtomicQueue<T> - Class in com.badlogic.gdx.utils
AtomicQueue() - Constructor for class com.badlogic.gdx.utils.AtomicQueue
Audio - Interface in com.badlogic.gdx
This interface encapsulates the creation and management of audio resources.
audio - Variable in class com.badlogic.gdx.backends.android.AndroidApplication
audio - Static variable in class com.badlogic.gdx.Gdx
AudioDevice - Interface in com.badlogic.gdx.audio
Encapsulates an audio device in 44.1khz mono or stereo mode.
AudioRecorder - Interface in com.badlogic.gdx.audio
An AudioRecorder allows to record input from an audio device.
AudioTools - Class in com.badlogic.gdx.audio.analysis
Class holding various static native methods for processing audio data.
AudioTools() - Constructor for class com.badlogic.gdx.audio.analysis.AudioTools
averages - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
avgPerOctave - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
avgSize() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Returns the number of averages currently being calculated.
awake - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
Is this body initially awake or sleeping?

B

b - Variable in class com.badlogic.gdx.graphics.Color
the red, green, blue and alpha components
b - Variable in class com.badlogic.gdx.math.collision.Segment
the ending position
back() - Method in class com.badlogic.gdx.utils.json.JSONTokener
Back up one character.
bandWidth - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
baseSkeleton - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Model
batch - Variable in class com.badlogic.gdx.physics.box2d.Box2DDebugRenderer
a spritebatch and a font for text rendering
begin() - Method in class com.badlogic.gdx.graphics.glutils.FrameBuffer
Makes the frame buffer current so everything gets drawn to it.
begin() - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Makes OpenGL ES 2.0 use this vertex and fragment shader pair.
begin(int) - Method in class com.badlogic.gdx.graphics.ImmediateModeRenderer
Starts a new list of primitives.
begin() - Method in class com.badlogic.gdx.graphics.SpriteBatch
Sets up the SpriteBatch for drawing.
begin() - Method in class com.badlogic.gdx.graphics.SpriteCache
Prepares the OpenGL state for SpriteCache rendering.
beginCache() - Method in class com.badlogic.gdx.graphics.SpriteCache
Starts the definition of a new cache, allowing the add and SpriteCache.endCache() methods to be called.
beginCache(int) - Method in class com.badlogic.gdx.graphics.SpriteCache
Starts the redefinition of an existing cache, allowing the add and SpriteCache.endCache() methods to be called.
beginContact(Contact) - Method in interface com.badlogic.gdx.physics.box2d.ContactListener
Called when two fixtures begin to touch.
bind() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObject
Binds this IndexBufferObject for rendering with glDrawElements.
bind() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
Binds this IndexBufferObject for rendering with glDrawElements.
bind() - Method in interface com.badlogic.gdx.graphics.glutils.IndexData
Binds this IndexBufferObject for rendering with glDrawElements.
bind() - Method in class com.badlogic.gdx.graphics.glutils.VertexArray
bind() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
Binds this VertexData for rendering via glDrawArrays or glDrawElements.
bind(ShaderProgram) - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
Binds this VertexBufferObject for rendering via glDrawArrays or glDrawElements
bind() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Binds this VertexData for rendering via glDrawArrays or glDrawElements.
bind(ShaderProgram) - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Binds this VertexBufferObject for rendering via glDrawArrays or glDrawElements
bind() - Method in interface com.badlogic.gdx.graphics.glutils.VertexData
Binds this VertexData for rendering via glDrawArrays or glDrawElements.
bind() - Method in class com.badlogic.gdx.graphics.Mesh
Binds the underlying VertexArray/VertexBufferObject and IndexBufferObject if indices were given.
bind(ShaderProgram) - Method in class com.badlogic.gdx.graphics.Mesh
Binds the underlying VertexBufferObject and IndexBufferObject if indices where given.
bind() - Method in interface com.badlogic.gdx.graphics.Texture
Binds this texture.
bitEqual(int, float) - Static method in class com.badlogic.gdx.utils.BufferUtils
BitmapFont - Class in com.badlogic.gdx.graphics
Renders bitmap fonts.
BitmapFont() - Constructor for class com.badlogic.gdx.graphics.BitmapFont
Creates a BitmapFont using the default 15pt Arial font included in the libgdx JAR file.
BitmapFont(FileHandle, TextureRegion, boolean) - Constructor for class com.badlogic.gdx.graphics.BitmapFont
Creates a BitmapFont with the glyphs relative to the specified region.
BitmapFont(FileHandle, boolean) - Constructor for class com.badlogic.gdx.graphics.BitmapFont
Creates a BitmapFont from a BMFont file.
BitmapFont(FileHandle, FileHandle, boolean) - Constructor for class com.badlogic.gdx.graphics.BitmapFont
Creates a BitmapFont from a BMFont file, using the specified image for glyphs.
BitmapFont.HAlignment - Enum in com.badlogic.gdx.graphics
BitmapFont.TextBounds - Class in com.badlogic.gdx.graphics
BitmapFont.TextBounds() - Constructor for class com.badlogic.gdx.graphics.BitmapFont.TextBounds
BitmapFontCache - Class in com.badlogic.gdx.graphics
Caches glyph geometry for a BitmapFont, providing a fast way to render static text.
BitmapFontCache(BitmapFont) - Constructor for class com.badlogic.gdx.graphics.BitmapFontCache
BLACK - Static variable in class com.badlogic.gdx.graphics.Color
BLUE - Static variable in class com.badlogic.gdx.graphics.Color
bodies - Variable in class com.badlogic.gdx.physics.box2d.World
all known bodies
Body - Class in com.badlogic.gdx.physics.box2d
A rigid body.
Body(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.Body
Constructs a new body with the given address
bodyA - Variable in class com.badlogic.gdx.physics.box2d.JointDef
The first attached body.
bodyB - Variable in class com.badlogic.gdx.physics.box2d.JointDef
The second attached body
BodyDef - Class in com.badlogic.gdx.physics.box2d
A body definition holds all the data needed to construct a rigid body.
BodyDef() - Constructor for class com.badlogic.gdx.physics.box2d.BodyDef
BodyDef.BodyType - Enum in com.badlogic.gdx.physics.box2d
The body type.
bottom() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
BoundGroup - Class in com.badlogic.gdx.scenes.scene2d.actors
This is a group that respects its width and height.
BoundGroup(String, float, float) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
BoundingBox - Class in com.badlogic.gdx.math.collision
Encapsulates an axis aligned bounding box represented by a minimum and a maximum Vector.
BoundingBox() - Constructor for class com.badlogic.gdx.math.collision.BoundingBox
Constructs a new bounding box with the minimum and maximum vector set to zeros.
BoundingBox(BoundingBox) - Constructor for class com.badlogic.gdx.math.collision.BoundingBox
Constructs a new bounding box from the given bounding box.
BoundingBox(Vector3, Vector3) - Constructor for class com.badlogic.gdx.math.collision.BoundingBox
Constructs the new bounding box using the given minimum and maximum vector.
bounds - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Animation
boundsInFrustum(BoundingBox) - Method in class com.badlogic.gdx.math.Frustum
Returns wheter the given BoundingBox is in the frustum.
Box2DDebugRenderer - Class in com.badlogic.gdx.physics.box2d
Box2DDebugRenderer() - Constructor for class com.badlogic.gdx.physics.box2d.Box2DDebugRenderer
BufferUtils - Class in com.badlogic.gdx.utils
Class with static helper methods to increase the speed of array/direct buffer and direct buffer/direct buffer transfers
BufferUtils() - Constructor for class com.badlogic.gdx.utils.BufferUtils
bullet - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
Is this a fast moving body that should be prevented from tunneling through other moving bodies? Note that all bodies are prevented from tunneling through kinematic and static bodies.
Button - Class in com.badlogic.gdx.scenes.scene2d.actors
A simple Button Actor, useful for simple UIs
Button(String) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.Button
Creates a new Button instance with the given name.
Button(String, Texture) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.Button
Creates a new Button instance with the given name, using the complete supplied texture for displaying the pressed and unpressed state of the button.
Button(String, TextureRegion) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.Button
Button(String, TextureRegion, TextureRegion) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.Button
Button.ClickListener - Interface in com.badlogic.gdx.scenes.scene2d.actors

C

calcAvg(float, float) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Calculate the average amplitude of the frequency band bounded by lowFreq and hiFreq, inclusive.
calculate(List<Float>) - Method in class com.badlogic.gdx.audio.analysis.ThresholdFunction
Returns the threshold function for a given spectral flux function.
calculatePickRay(float, float, float, float, Vector3, Vector3, Vector3) - Method in class com.badlogic.gdx.math.Frustum
Calculates the pick ray for the given window coordinates.
calculateVertices(float[], float[], float[], float[], int) - Static method in class com.badlogic.gdx.graphics.loaders.md5.MD5Jni
calculateVertices(MD5Joints, float[]) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
calculateVertices(MD5Joints, float[], float[], float[]) - Static method in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
calculateVerticesJni(MD5Joints, float[]) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
categoryBits - Variable in class com.badlogic.gdx.physics.box2d.Filter
The collision category bits.
CatmullRomSpline - Class in com.badlogic.gdx.math
Encapsulates a catmull rom spline with n control points, n >= 4.
CatmullRomSpline() - Constructor for class com.badlogic.gdx.math.CatmullRomSpline
ceil(float) - Static method in class com.badlogic.gdx.utils.MathUtils
center - Variable in class com.badlogic.gdx.math.collision.Sphere
the center of the sphere
center - Variable in class com.badlogic.gdx.physics.box2d.MassData
The position of the shape's centroid relative to the shape's origin.
centerX() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
centerY() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
child(String) - Method in class com.badlogic.gdx.files.FileHandle
Returns a handle to the child with the specified name.
child(String) - Method in class com.badlogic.gdx.files.FileHandleStream
children - Variable in class com.badlogic.gdx.scenes.scene2d.Group
CircleShape - Class in com.badlogic.gdx.physics.box2d
A circle shape.
CircleShape() - Constructor for class com.badlogic.gdx.physics.box2d.CircleShape
CircleShape(long) - Constructor for class com.badlogic.gdx.physics.box2d.CircleShape
clamp() - Method in class com.badlogic.gdx.graphics.Color
classpath(String) - Method in interface com.badlogic.gdx.Files
Convenience method that returns a Files.FileType.Classpath file handle.
clear() - Method in class com.badlogic.gdx.graphics.SpriteCache
Invalidates all cache IDs and resets the SpriteCache so new caches can be added.
clear() - Method in class com.badlogic.gdx.math.WindowedMean
clears this WindowedMean.
clear() - Method in class com.badlogic.gdx.twl.TWL
Removes all widgets from the GUI's root pane.
clear() - Method in class com.badlogic.gdx.utils.FloatArray
clear() - Method in class com.badlogic.gdx.utils.FloatBag
clear() - Method in class com.badlogic.gdx.utils.IntArray
clear() - Method in class com.badlogic.gdx.utils.IntBag
clear() - Method in class com.badlogic.gdx.utils.IntHashMap
clear() - Method in class com.badlogic.gdx.utils.LongArray
clear() - Method in class com.badlogic.gdx.utils.LongBag
clear() - Method in class com.badlogic.gdx.utils.LongHashMap
clear() - Method in class com.badlogic.gdx.utils.PooledLinkedList
clearActions() - Method in class com.badlogic.gdx.scenes.scene2d.Actor
Clears all actions of this Actor.
clearAllFrameBuffers() - Static method in class com.badlogic.gdx.graphics.glutils.FrameBuffer
clearAllMeshes() - Static method in class com.badlogic.gdx.graphics.Mesh
Will clear the managed mesh cache.
clearAllShaderPrograms() - Static method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
clearForces() - Method in class com.badlogic.gdx.physics.box2d.World
Call this after you are done with time steps to clear the forces.
clicked(Button) - Method in interface com.badlogic.gdx.scenes.scene2d.actors.Button.ClickListener
clickListener - Variable in class com.badlogic.gdx.scenes.scene2d.actors.Button
clr() - Method in class com.badlogic.gdx.math.collision.BoundingBox
Sets the minimum and maximum vector to zeros
COL1_X - Static variable in class com.badlogic.gdx.physics.box2d.Transform
COL1_Y - Static variable in class com.badlogic.gdx.physics.box2d.Transform
COL2_X - Static variable in class com.badlogic.gdx.physics.box2d.Transform
COL2_Y - Static variable in class com.badlogic.gdx.physics.box2d.Transform
collideConnected - Variable in class com.badlogic.gdx.physics.box2d.JointDef
Set this flag to true if the attached bodies should collide.
Color - Class in com.badlogic.gdx.graphics
A color class, holding the r, g, b and alpha component as floats in the range [0,1].
Color(float, float, float, float) - Constructor for class com.badlogic.gdx.graphics.Color
Constructor, sets the components of the color
Color(Color) - Constructor for class com.badlogic.gdx.graphics.Color
Constructs a new color using the given color
color(float, float, float, float) - Method in class com.badlogic.gdx.graphics.ImmediateModeRenderer
Specifies the color of the current vertex
Color - Static variable in class com.badlogic.gdx.graphics.VertexAttributes.Usage
color - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
ColorPacked - Static variable in class com.badlogic.gdx.graphics.VertexAttributes.Usage
com.badlogic.gdx - package com.badlogic.gdx
com.badlogic.gdx.audio - package com.badlogic.gdx.audio
com.badlogic.gdx.audio.analysis - package com.badlogic.gdx.audio.analysis
com.badlogic.gdx.audio.io - package com.badlogic.gdx.audio.io
com.badlogic.gdx.backends.android - package com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl - package com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl - package com.badlogic.gdx.backends.lwjgl
com.badlogic.gdx.files - package com.badlogic.gdx.files
com.badlogic.gdx.graphics - package com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils - package com.badlogic.gdx.graphics.glutils
com.badlogic.gdx.graphics.loaders - package com.badlogic.gdx.graphics.loaders
com.badlogic.gdx.graphics.loaders.md5 - package com.badlogic.gdx.graphics.loaders.md5
com.badlogic.gdx.graphics.particles - package com.badlogic.gdx.graphics.particles
com.badlogic.gdx.math - package com.badlogic.gdx.math
com.badlogic.gdx.math.collision - package com.badlogic.gdx.math.collision
com.badlogic.gdx.physics.box2d - package com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints - package com.badlogic.gdx.physics.box2d.joints
com.badlogic.gdx.scenes.scene2d - package com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actions - package com.badlogic.gdx.scenes.scene2d.actions
com.badlogic.gdx.scenes.scene2d.actors - package com.badlogic.gdx.scenes.scene2d.actors
com.badlogic.gdx.twl - package com.badlogic.gdx.twl
com.badlogic.gdx.utils - package com.badlogic.gdx.utils
com.badlogic.gdx.utils.json - package com.badlogic.gdx.utils.json
comb - Variable in class com.badlogic.gdx.graphics.PerspectiveCamera
computeVisibleGlpyhs(CharSequence, int, int, float) - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the number of glyphs from the substring that can be rendered in the specified width.
computeW() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
Contact - Class in com.badlogic.gdx.physics.box2d
The class manages contact between two shapes.
Contact(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.Contact
ContactFilter - Interface in com.badlogic.gdx.physics.box2d
Implement this class to provide collision filtering.
contactFilter - Variable in class com.badlogic.gdx.physics.box2d.World
Contact filter
ContactListener - Interface in com.badlogic.gdx.physics.box2d
contactListener - Variable in class com.badlogic.gdx.physics.box2d.World
Contact listener
contains(BoundingBox) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Returns wheter the given bounding box is contained in this bounding box.
contains(Vector3) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Returns wheter the given vector is contained in this bounding box.
contains(float) - Method in class com.badlogic.gdx.utils.FloatArray
contains(float) - Method in class com.badlogic.gdx.utils.FloatBag
contains(int) - Method in class com.badlogic.gdx.utils.IntArray
contains(int) - Method in class com.badlogic.gdx.utils.IntBag
contains(long) - Method in class com.badlogic.gdx.utils.LongArray
contains(long) - Method in class com.badlogic.gdx.utils.LongBag
containsKey(int) - Method in class com.badlogic.gdx.utils.IntHashMap
containsKey(long) - Method in class com.badlogic.gdx.utils.LongHashMap
containsValue(Object) - Method in class com.badlogic.gdx.utils.IntHashMap
Returns true if the specified value is in the map.
containsValue(Object) - Method in class com.badlogic.gdx.utils.LongHashMap
Returns true if the specified value is in the map.
convertToFloat(ShortBuffer, FloatBuffer, int) - Static method in class com.badlogic.gdx.audio.analysis.AudioTools
Converts the 16-bit signed PCM data given in source to 32-bit float PCM in the range [-1,1].
convertToMono(ShortBuffer, ShortBuffer, int) - Static method in class com.badlogic.gdx.audio.analysis.AudioTools
Converts the samples in source which are assumed to be interleaved left/right stereo samples to mono, writting the converted samples to target.
convertToMono(FloatBuffer, FloatBuffer, int) - Static method in class com.badlogic.gdx.audio.analysis.AudioTools
Converts the samples in source which are assumed to be interleaved left/right stereo samples to mono, writting the converted samples to target.
convertToShort(FloatBuffer, FloatBuffer, int) - Static method in class com.badlogic.gdx.audio.analysis.AudioTools
Converts the 32-bit float PCM data given in source to 16-bit signed PCM in the range [-1,1].
copy() - Method in interface com.badlogic.gdx.scenes.scene2d.Action
Creates a copy of this action.
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Delay
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Forever
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Parallel
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
copy() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Sequence
copy(float[], Buffer, int, int) - Static method in class com.badlogic.gdx.utils.BufferUtils
Copies numFloats floats from src starting at offset to dst.
copyTo(FileHandle) - Method in class com.badlogic.gdx.files.FileHandle
Copies this file to the specified file, overwriting the file if it already exists.
copyTo(FileHandle) - Method in class com.badlogic.gdx.files.FileHandleStream
cos - Static variable in class com.badlogic.gdx.utils.MathUtils
cos(float) - Static method in class com.badlogic.gdx.utils.MathUtils
cosDeg(float) - Static method in class com.badlogic.gdx.utils.MathUtils
cpy() - Method in class com.badlogic.gdx.math.collision.Ray
cpy() - Method in class com.badlogic.gdx.math.Matrix4
cpy() - Method in class com.badlogic.gdx.math.Quaternion
cpy() - Method in class com.badlogic.gdx.math.Vector2
cpy() - Method in class com.badlogic.gdx.math.Vector3
create() - Method in interface com.badlogic.gdx.ApplicationListener
Called when the Application is first created.
createBody(BodyDef) - Method in class com.badlogic.gdx.physics.box2d.World
Create a rigid body given a definition.
createFixture(FixtureDef) - Method in class com.badlogic.gdx.physics.box2d.Body
Creates a fixture and attach it to this body.
createFixture(Shape, float) - Method in class com.badlogic.gdx.physics.box2d.Body
Creates a fixture from a shape and attach it to this body.
createJoint(JointDef) - Method in class com.badlogic.gdx.physics.box2d.World
Create a joint to constrain bodies together.
createObject() - Method in interface com.badlogic.gdx.utils.LocklessThreadQueue.ObjectFactory
createObject() - Method in interface com.badlogic.gdx.utils.Pool.PoolObjectFactory
createVertexArray() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
crs(Vector3) - Method in class com.badlogic.gdx.math.Vector3
Sets this vector to the cross product between it and the other vector.
crs(float, float, float) - Method in class com.badlogic.gdx.math.Vector3
Sets this vector to the cross product between it and the other vector.
currAction - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Sequence

D

d - Variable in class com.badlogic.gdx.math.Plane
dampingRatio - Variable in class com.badlogic.gdx.physics.box2d.joints.DistanceJointDef
The damping ratio.
dampingRatio - Variable in class com.badlogic.gdx.physics.box2d.joints.MouseJointDef
The damping ratio.
debug - Static variable in class com.badlogic.gdx.scenes.scene2d.Group
debugTexture - Static variable in class com.badlogic.gdx.scenes.scene2d.Group
Decoder - Interface in com.badlogic.gdx.audio.io
Interface for audio decoders that return successive amplitude frames.
degreesToRadians - Static variable in class com.badlogic.gdx.utils.MathUtils
dehexchar(char) - Static method in class com.badlogic.gdx.utils.json.JSONTokener
Get the hex value of a character (base16).
Delay - Class in com.badlogic.gdx.scenes.scene2d.actions
Delay() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.Delay
delete() - Method in class com.badlogic.gdx.files.FileHandle
Deletes this file or empty directory and returns success.
delete() - Method in class com.badlogic.gdx.files.FileHandleStream
deleteDirectory() - Method in class com.badlogic.gdx.files.FileHandle
Deletes this file or directory and all children, recursively.
deleteDirectory() - Method in class com.badlogic.gdx.files.FileHandleStream
deltaAlpha - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
deltaAlpha - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
deltaAlpha - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
deltaRotation - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
deltaRotation - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
deltaScaleX - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
deltaScaleY - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
deltaX - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
deltaX - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
deltaY - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
deltaY - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
density - Variable in class com.badlogic.gdx.physics.box2d.FixtureDef
The density, usually in kg/m^2.
destroy() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplet
destroyBody(Body) - Method in class com.badlogic.gdx.physics.box2d.World
Destroy a rigid body given a definition.
destroyFixture(Fixture) - Method in class com.badlogic.gdx.physics.box2d.Body
Destroy a fixture.
destroyJoint(Joint) - Method in class com.badlogic.gdx.physics.box2d.World
Destroy a joint.
DestructionListener - Interface in com.badlogic.gdx.physics.box2d
det() - Method in class com.badlogic.gdx.math.Matrix3
det() - Method in class com.badlogic.gdx.math.Matrix4
DFT - Class in com.badlogic.gdx.audio.analysis
DFT stands for Discrete Fourier Transform and is the most widely used Fourier Transform.
DFT(int, float) - Constructor for class com.badlogic.gdx.audio.analysis.DFT
Constructs a DFT that expects audio buffers of length timeSize that have been recorded with a sample rate of sampleRate.
direction - Variable in class com.badlogic.gdx.math.collision.Ray
disableBlending() - Method in class com.badlogic.gdx.graphics.SpriteBatch
Disables blending for drawing sprites.
disableDebugging() - Static method in class com.badlogic.gdx.scenes.scene2d.Group
disableVertexAttribute(String) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Disables the vertex attribute with the given name
dispose() - Method in interface com.badlogic.gdx.ApplicationListener
Called when the Application is destroyed.
dispose() - Method in class com.badlogic.gdx.audio.analysis.KissFFT
Releases all resources of this object
dispose() - Method in class com.badlogic.gdx.audio.analysis.NativeFFT
dispose() - Method in interface com.badlogic.gdx.audio.AudioDevice
Frees all resources associated with this AudioDevice.
dispose() - Method in interface com.badlogic.gdx.audio.AudioRecorder
Disposes the AudioRecorder
dispose() - Method in interface com.badlogic.gdx.audio.io.Decoder
Disposes the decoder and frees all associated resources
dispose() - Method in class com.badlogic.gdx.audio.io.Mpg123Decoder
Disposes the decoder and frees all associated resources
dispose() - Method in class com.badlogic.gdx.audio.io.VorbisDecoder
Disposes the decoder and frees all associated resources
dispose() - Method in interface com.badlogic.gdx.audio.Music
Needs to be called when the Music is no longer needed.
dispose() - Method in interface com.badlogic.gdx.audio.Sound
Releases all the resources.
dispose() - Method in class com.badlogic.gdx.Game
dispose() - Method in class com.badlogic.gdx.graphics.BitmapFont
Disposes the texture used by this BitmapFont's region.
dispose() - Method in class com.badlogic.gdx.graphics.glutils.FrameBuffer
Releases all resources associated with the FrameBuffer.
dispose() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObject
Disposes this IndexBufferObject and all its associated OpenGL resources.
dispose() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
Disposes this IndexBufferObject and all its associated OpenGL resources.
dispose() - Method in interface com.badlogic.gdx.graphics.glutils.IndexData
Disposes this IndexDatat and all its associated OpenGL resources.
dispose() - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Disposes all resources associated with this shader.
dispose() - Method in class com.badlogic.gdx.graphics.glutils.VertexArray
Disposes this VertexData and all its associated OpenGL resources.
dispose() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
Disposes of all resources this VertexBufferObject uses.
dispose() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Disposes of all resources this VertexBufferObject uses.
dispose() - Method in interface com.badlogic.gdx.graphics.glutils.VertexData
Disposes this VertexData and all its associated OpenGL resources.
dispose() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Renderer
dispose() - Method in class com.badlogic.gdx.graphics.Mesh
Frees all resources associated with this Mesh
dispose() - Method in interface com.badlogic.gdx.graphics.Pixmap
Releases all resources associated with this Pixmap.
dispose() - Method in class com.badlogic.gdx.graphics.SpriteBatch
Disposes all resources associated with this SpriteBatch
dispose() - Method in class com.badlogic.gdx.graphics.SpriteCache
Releases all resources held by this SpriteCache.
dispose() - Method in interface com.badlogic.gdx.graphics.Texture
Disposes all resources associated with the texture
dispose() - Method in class com.badlogic.gdx.graphics.TextureAtlas
Releases all resources associated with this TextureAtlas instance.
dispose() - Method in class com.badlogic.gdx.physics.box2d.Box2DDebugRenderer
dispose() - Method in class com.badlogic.gdx.physics.box2d.Shape
Needs to be called when the shape is no longer used, e.g.
dispose() - Method in class com.badlogic.gdx.physics.box2d.World
dispose() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Disposes the stage
dispose() - Method in interface com.badlogic.gdx.Screen
Called when this screen should release all resources.
dispose() - Method in class com.badlogic.gdx.twl.TWL
dist2(Vector3) - Method in class com.badlogic.gdx.math.Vector3
distance(Vector3) - Method in class com.badlogic.gdx.math.Plane
Calculates the shortest signed distance between the plane and the given point.
DistanceJoint - Class in com.badlogic.gdx.physics.box2d.joints
A distance joint constrains two points on two bodies to remain at a fixed distance from each other.
DistanceJoint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.joints.DistanceJoint
DistanceJointDef - Class in com.badlogic.gdx.physics.box2d.joints
Distance joint definition.
DistanceJointDef() - Constructor for class com.badlogic.gdx.physics.box2d.joints.DistanceJointDef
distanceLinePoint(Vector2, Vector2, Vector2) - Static method in class com.badlogic.gdx.math.Intersector
Returns the distance between the given line segment and point.
div(float) - Method in class com.badlogic.gdx.math.Vector3
Divides all components of this vector by the given value
done - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
done - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
done - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
done - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
done - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
done - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
done - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
done - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
dot(MD5Quaternion) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
dot(Vector2) - Method in class com.badlogic.gdx.math.Vector2
dot(Vector3) - Method in class com.badlogic.gdx.math.Vector3
dot(float, float, float) - Method in class com.badlogic.gdx.math.Vector3
Returns the dot product between this and the given vector.
doubleToString(double) - Static method in class com.badlogic.gdx.utils.json.JSONObject
Produce a string from a double.
doWindow(float[]) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
draw(SpriteBatch, CharSequence, float, float) - Method in class com.badlogic.gdx.graphics.BitmapFont
Draws a string at the specified position and color.
draw(SpriteBatch, CharSequence, float, float, int, int) - Method in class com.badlogic.gdx.graphics.BitmapFont
Draws a substring at the specified position.
draw(SpriteBatch) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
draw(SpriteBatch, float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
draw(SpriteBatch, float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
draw(SpriteBatch) - Method in class com.badlogic.gdx.graphics.Sprite
draw(Texture, float, float, float, float, float, float, float, float, float, int, int, int, int, boolean, boolean) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
draw(Texture, float, float, float, float, int, int, int, int, boolean, boolean) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
draw(Texture, float, float, int, int, int, int) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
draw(Texture, float, float, float, float, float, float, float, float) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
draw(Texture, float, float) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Draws a rectangle with the top left corner at x,y having the width and height of the texture.
draw(Texture, float[], int, int) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Draws a rectangle using the given vertices.
draw(TextureRegion, float, float) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Draws a rectangle with the top left corner at x,y having the width and height of the region.
draw(TextureRegion, float, float, float, float) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Draws a rectangle with the top left corner at x,y and stretching the region to cover the given width and height.
draw(TextureRegion, float, float, float, float, float, float, float, float, float) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Draws a rectangle with the top left corner at x,y and stretching the region to cover the given width and height.
draw(int) - Method in class com.badlogic.gdx.graphics.SpriteCache
Draws all the images defined for the specified cache ID.
draw(int, int, int) - Method in class com.badlogic.gdx.graphics.SpriteCache
Draws a subset of images defined for the specified cache ID.
draw(Pixmap, int, int) - Method in interface com.badlogic.gdx.graphics.Texture
Draws the given Pixmap to the texture at position x, y.
drawCircle(int, int, int) - Method in interface com.badlogic.gdx.graphics.Pixmap
Draws a circle outline with the center at x,y and a radius using the current color and stroke width.
drawLine(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.Pixmap
Draws a line between the given coordinates using the currently set color and stroke width.
drawMultiLine(SpriteBatch, CharSequence, float, float) - Method in class com.badlogic.gdx.graphics.BitmapFont
Draws a string, which may contain newlines (\n), at the specified position.
drawMultiLine(SpriteBatch, CharSequence, float, float, float, BitmapFont.HAlignment) - Method in class com.badlogic.gdx.graphics.BitmapFont
Draws a string, which may contain newlines (\n), at the specified position and alignment.
drawPixmap(Pixmap, int, int, int, int, int, int) - Method in interface com.badlogic.gdx.graphics.Pixmap
Draws an area form another Pixmap to this Pixmap.
drawRectangle(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.Pixmap
Draws a rectangle outline starting at x, y extending by width to the right and by height downwards (y-axis points downwards) using the current color and stroke width.
drawWrapped(SpriteBatch, CharSequence, float, float, float) - Method in class com.badlogic.gdx.graphics.BitmapFont
Draws a string, which may contain newlines (\n), with the specified position and color.
drawWrapped(SpriteBatch, CharSequence, float, float, float, BitmapFont.HAlignment) - Method in class com.badlogic.gdx.graphics.BitmapFont
Draws a string, which may contain newlines (\n), with the specified position and color.
dst(Vector2) - Method in class com.badlogic.gdx.math.Vector2
dst(float, float) - Method in class com.badlogic.gdx.math.Vector2
dst(Vector3) - Method in class com.badlogic.gdx.math.Vector3
dst(float, float, float) - Method in class com.badlogic.gdx.math.Vector3
dst2(Vector2) - Method in class com.badlogic.gdx.math.Vector2
dst2(Vector3) - Method in class com.badlogic.gdx.math.Vector3
Returns the squared distance between this point and the given point
dst2(float, float, float) - Method in class com.badlogic.gdx.math.Vector3
Returns the squared distance between this point and the given point
duration - Variable in class com.badlogic.gdx.graphics.particles.ParticleEmitter
duration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Delay
duration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
duration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
duration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
duration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
duration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
duration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
duration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
duration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
durationTimer - Variable in class com.badlogic.gdx.graphics.particles.ParticleEmitter

E

EarCutTriangulator - Class in com.badlogic.gdx.math
A simple implementation of the ear cutting algorithm to triangulate simple polygons without holes.
EarCutTriangulator() - Constructor for class com.badlogic.gdx.math.EarCutTriangulator
enableBlending() - Method in class com.badlogic.gdx.graphics.SpriteBatch
Enables blending for sprites
enableDebugging(String) - Static method in class com.badlogic.gdx.scenes.scene2d.Group
enableLimit(boolean) - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Enable/disable the joint limit.
enableLimit - Variable in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
Enable/disable the joint limit.
enableLimit(boolean) - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Enable/disable the joint limit.
enableLimit - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
Enable/disable the joint limit.
enableLimit(boolean) - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Enable/disable the joint limit.
enableLimit - Variable in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
A flag to enable joint limits.
enableMotor(boolean) - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Enable/disable the joint motor.
enableMotor - Variable in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
Enable/disable the joint motor.
enableMotor(boolean) - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Enable/disable the joint motor.
enableMotor - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
Enable/disable the joint motor.
enableMotor(boolean) - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Enable/disable the joint motor.
enableMotor - Variable in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
A flag to enable the joint motor.
enableVertexAttribute(String) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Enables the vertex attribute with the given name
end() - Method in class com.badlogic.gdx.graphics.glutils.FrameBuffer
Unbinds the framebuffer, all drawing will be performed to the normal framebuffer from here on.
end() - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Disables this shader.
end() - Method in class com.badlogic.gdx.graphics.ImmediateModeRenderer
Renders the primitives just defined.
end() - Method in class com.badlogic.gdx.graphics.SpriteBatch
Finishes off rendering.
end() - Method in class com.badlogic.gdx.graphics.SpriteCache
Completes rendering for this SpriteCache.f
end() - Method in class com.badlogic.gdx.utils.json.JSONTokener
endArray() - Method in class com.badlogic.gdx.utils.json.JSONWriter
End an array.
endCache() - Method in class com.badlogic.gdx.graphics.SpriteCache
Ends the definition of a cache, returning the cache ID to be used with SpriteCache.draw(int).
endContact(Contact) - Method in interface com.badlogic.gdx.physics.box2d.ContactListener
Called when two fixtures cease to touch.
endObject() - Method in class com.badlogic.gdx.utils.json.JSONWriter
End an object.
ensureCapacity(int) - Method in class com.badlogic.gdx.utils.FloatArray
Increases the size of the backing array to acommodate the specified number of additional items.
ensureCapacity(int) - Method in class com.badlogic.gdx.utils.FloatBag
Increases the size of the backing array to acommodate the specified number of additional items.
ensureCapacity(int) - Method in class com.badlogic.gdx.utils.IntArray
Increases the size of the backing array to acommodate the specified number of additional items.
ensureCapacity(int) - Method in class com.badlogic.gdx.utils.IntBag
Increases the size of the backing array to acommodate the specified number of additional items.
ensureCapacity(int) - Method in class com.badlogic.gdx.utils.IntHashMap
Increases the size of the backing array to acommodate the specified number of additional items.
ensureCapacity(int) - Method in class com.badlogic.gdx.utils.LongArray
Increases the size of the backing array to acommodate the specified number of additional items.
ensureCapacity(int) - Method in class com.badlogic.gdx.utils.LongBag
Increases the size of the backing array to acommodate the specified number of additional items.
ensureCapacity(int) - Method in class com.badlogic.gdx.utils.LongHashMap
Increases the size of the backing array to acommodate the specified number of additional items.
entries() - Method in class com.badlogic.gdx.utils.IntHashMap
Returns an iterator for the entries in the map.
entries() - Method in class com.badlogic.gdx.utils.LongHashMap
Returns an iterator for the entries in the map.
equals(Object) - Method in class com.badlogic.gdx.graphics.Color
equals(Object) - Method in class com.badlogic.gdx.math.Vector3
exists() - Method in class com.badlogic.gdx.files.FileHandle
exists() - Method in class com.badlogic.gdx.files.FileHandleStream
ext(Vector3) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Extends the bounding box to incorporate the given Vector3.
ext(BoundingBox) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Extends this bounding box by the given bounding box.
ext(float, float, float) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Extends the bounding box by the given vector.
extension() - Method in class com.badlogic.gdx.files.FileHandle
external(String) - Method in interface com.badlogic.gdx.Files
Convenience method that returns a Files.FileType.External file handle.

F

FadeIn - Class in com.badlogic.gdx.scenes.scene2d.actions
FadeIn() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
FadeOut - Class in com.badlogic.gdx.scenes.scene2d.actions
FadeOut() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
FadeTo - Class in com.badlogic.gdx.scenes.scene2d.actions
FadeTo() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
far - Variable in class com.badlogic.gdx.math.Frustum
far_height - Variable in class com.badlogic.gdx.math.Frustum
far_width - Variable in class com.badlogic.gdx.math.Frustum
FFT - Class in com.badlogic.gdx.audio.analysis
FFT stands for Fast Fourier Transform.
FFT(int, float) - Constructor for class com.badlogic.gdx.audio.analysis.FFT
Constructs an FFT that will accept sample buffers that are timeSize long and have been recorded with a sample rate of sampleRate.
file - Variable in class com.badlogic.gdx.files.FileHandle
FileHandle - Class in com.badlogic.gdx.files
Represents a file or directory on the filesystem, classpath, Android SD card, or Android assets directory.
FileHandle() - Constructor for class com.badlogic.gdx.files.FileHandle
FileHandle(String, Files.FileType) - Constructor for class com.badlogic.gdx.files.FileHandle
FileHandle(File, Files.FileType) - Constructor for class com.badlogic.gdx.files.FileHandle
FileHandleStream - Class in com.badlogic.gdx.files
A FileHandle intended to be subclassed for the purpose of implemented FileHandleStream.read() and/or FileHandleStream.write(boolean).
FileHandleStream(String) - Constructor for class com.badlogic.gdx.files.FileHandleStream
files - Variable in class com.badlogic.gdx.backends.android.AndroidApplication
Files - Interface in com.badlogic.gdx
Provides standard access to the filesystem, classpath, Android SD card, and Android assets directory.
files - Static variable in class com.badlogic.gdx.Gdx
Files.FileType - Enum in com.badlogic.gdx
Indicates how to resolve a path to a file.
fill() - Method in interface com.badlogic.gdx.graphics.Pixmap
Fills the complete bitmap with the currently set color.
fillCircle(int, int, int) - Method in interface com.badlogic.gdx.graphics.Pixmap
Fills a circle with the center at x,y and a radius using the current color.
fillRectangle(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.Pixmap
Fills a rectangle starting at x, y extending by width to the right and by height downwards (y-axis points downwards) using the current color.
fillSpectrum() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Filter - Class in com.badlogic.gdx.physics.box2d
This holds contact filtering data.
Filter() - Constructor for class com.badlogic.gdx.physics.box2d.Filter
filter - Variable in class com.badlogic.gdx.physics.box2d.FixtureDef
Contact filtering data.
findActor(String) - Method in class com.badlogic.gdx.scenes.scene2d.Group
Finds the Actor with the given name in this Group and its children.
findActor(String) - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Finds the Actor with the given name in the stage hierarchy.
finish() - Method in interface com.badlogic.gdx.scenes.scene2d.Action
Called by the owner of the action when it can release all its resources, e.g.
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Delay
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Forever
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Parallel
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
finish() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Sequence
finishedTimes - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
firstResume - Variable in class com.badlogic.gdx.backends.android.AndroidApplication
fixedRotation - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
Should this body be prevented from rotating? Useful for characters.
Fixture - Class in com.badlogic.gdx.physics.box2d
Fixture(Body, long) - Constructor for class com.badlogic.gdx.physics.box2d.Fixture
Constructs a new fixture
FixtureDef - Class in com.badlogic.gdx.physics.box2d
A fixture definition is used to create a fixture.
FixtureDef() - Constructor for class com.badlogic.gdx.physics.box2d.FixtureDef
fixtures - Variable in class com.badlogic.gdx.physics.box2d.World
all known fixtures
flip(boolean, boolean) - Method in class com.badlogic.gdx.graphics.Sprite
flip(boolean, boolean) - Method in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
flip(boolean, boolean) - Method in class com.badlogic.gdx.graphics.TextureRegion
float2int(float) - Static method in class com.badlogic.gdx.utils.BufferUtils
FloatArray - Class in com.badlogic.gdx.utils
An ordered, resizable float array.
FloatArray() - Constructor for class com.badlogic.gdx.utils.FloatArray
FloatArray(int) - Constructor for class com.badlogic.gdx.utils.FloatArray
FloatArray(FloatArray) - Constructor for class com.badlogic.gdx.utils.FloatArray
FloatArray(FloatBag) - Constructor for class com.badlogic.gdx.utils.FloatArray
FloatBag - Class in com.badlogic.gdx.utils
An unordered, resizable int array.
FloatBag() - Constructor for class com.badlogic.gdx.utils.FloatBag
FloatBag(int) - Constructor for class com.badlogic.gdx.utils.FloatBag
FloatBag(FloatBag) - Constructor for class com.badlogic.gdx.utils.FloatBag
FloatBag(FloatArray) - Constructor for class com.badlogic.gdx.utils.FloatBag
floor(float) - Static method in class com.badlogic.gdx.utils.MathUtils
flush() - Method in class com.badlogic.gdx.graphics.SpriteBatch
Causes any pending sprites to be rendered, without ending the SpriteBatch.
focus(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.Group
Sets the focus to the given child Actor.
focusedActor - Variable in class com.badlogic.gdx.scenes.scene2d.Group
forceVBO - Static variable in class com.badlogic.gdx.graphics.Mesh
used for benchmarking
Forever - Class in com.badlogic.gdx.scenes.scene2d.actions
Forever() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.Forever
forward(float[]) - Method in class com.badlogic.gdx.audio.analysis.DFT
forward(float[]) - Method in class com.badlogic.gdx.audio.analysis.FFT
forward(float[], float[]) - Method in class com.badlogic.gdx.audio.analysis.FFT
Performs a forward transform on the passed buffers.
forward(float[]) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Performs a forward transform on buffer.
forward(float[], int) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Performs a forward transform on values in buffer.
FourierTransform - Class in com.badlogic.gdx.audio.analysis
A Fourier Transform is an algorithm that transforms a signal in the time domain, such as a sample buffer, into a signal in the frequency domain, often called the spectrum.
fov - Variable in class com.badlogic.gdx.math.Frustum
FrameBuffer - Class in com.badlogic.gdx.graphics.glutils
Encapsulates OpenGL ES 2.0 frame buffer objects.
FrameBuffer(Pixmap.Format, int, int, boolean) - Constructor for class com.badlogic.gdx.graphics.glutils.FrameBuffer
Creates a new FrameBuffer having the given dimensions and potentially a depth buffer attached.
frameRate - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Animation
frames - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Animation
free(T) - Method in class com.badlogic.gdx.utils.Pool
Frees the given object and returns it to the pool.
freqToIndex(float) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Returns the index of the frequency band that contains the requested frequency.
frequencyHz - Variable in class com.badlogic.gdx.physics.box2d.joints.DistanceJointDef
The mass-spring-damper frequency in Hertz.
frequencyHz - Variable in class com.badlogic.gdx.physics.box2d.joints.MouseJointDef
The response speed.
friction - Variable in class com.badlogic.gdx.physics.box2d.FixtureDef
The friction coefficient, usually in the range [0,1].
FrictionJoint - Class in com.badlogic.gdx.physics.box2d.joints
Friction joint.
FrictionJoint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.joints.FrictionJoint
FrictionJointDef - Class in com.badlogic.gdx.physics.box2d.joints
Friction joint definition.
FrictionJointDef() - Constructor for class com.badlogic.gdx.physics.box2d.joints.FrictionJointDef
Frustum - Class in com.badlogic.gdx.math
Encapsulates a view frustum based on clipping planes.
Frustum() - Constructor for class com.badlogic.gdx.math.Frustum

G

g - Variable in class com.badlogic.gdx.graphics.Color
the red, green, blue and alpha components
Game - Class in com.badlogic.gdx
An ApplicationListener that delegates to a Screen.
Game() - Constructor for class com.badlogic.gdx.Game
Gdx - Class in com.badlogic.gdx
Environment class holding references to the Application, Graphics, Audio, Files and Input instances.
Gdx() - Constructor for class com.badlogic.gdx.Gdx
GdxNativesLoader - Class in com.badlogic.gdx.utils
GdxNativesLoader() - Constructor for class com.badlogic.gdx.utils.GdxNativesLoader
GdxRuntimeException - Exception in com.badlogic.gdx.utils
Typed runtime exception used throughout libgdx
GdxRuntimeException(String) - Constructor for exception com.badlogic.gdx.utils.GdxRuntimeException
GdxRuntimeException(Throwable) - Constructor for exception com.badlogic.gdx.utils.GdxRuntimeException
GdxRuntimeException(String, Throwable) - Constructor for exception com.badlogic.gdx.utils.GdxRuntimeException
GearJoint - Class in com.badlogic.gdx.physics.box2d.joints
A gear joint is used to connect two joints together.
GearJoint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.joints.GearJoint
GearJointDef - Class in com.badlogic.gdx.physics.box2d.joints
Gear joint definition.
GearJointDef() - Constructor for class com.badlogic.gdx.physics.box2d.joints.GearJointDef
Generic - Static variable in class com.badlogic.gdx.graphics.VertexAttributes.Usage
get(int) - Method in class com.badlogic.gdx.graphics.VertexAttributes
get(int) - Method in class com.badlogic.gdx.utils.FloatArray
get(int) - Method in class com.badlogic.gdx.utils.FloatBag
get(int) - Method in class com.badlogic.gdx.utils.IntArray
get(int) - Method in class com.badlogic.gdx.utils.IntBag
get(int) - Method in class com.badlogic.gdx.utils.IntHashMap
get(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the object value associated with an index.
get(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get the value object associated with a key.
get(int) - Method in class com.badlogic.gdx.utils.LongArray
get(int) - Method in class com.badlogic.gdx.utils.LongBag
get(long) - Method in class com.badlogic.gdx.utils.LongHashMap
getAccelerometerX() - Method in interface com.badlogic.gdx.Input
getAccelerometerY() - Method in interface com.badlogic.gdx.Input
getAccelerometerZ() - Method in interface com.badlogic.gdx.Input
getActiveCount() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getActors() - Method in class com.badlogic.gdx.scenes.scene2d.Group
getActors() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
getAnchorA() - Method in class com.badlogic.gdx.physics.box2d.Joint
getAnchorB() - Method in class com.badlogic.gdx.physics.box2d.Joint
getAngle() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getAngle() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the angle in radians.
getAngularDamping() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the angular damping of the body.
getAngularVelocity() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the angular velocity.
getAscent() - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the ascent, which is the distance from the cap height to the top of the tallest glyph.
getAttributes() - Method in class com.badlogic.gdx.graphics.glutils.VertexArray
getAttributes() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
getAttributes() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
getAttributes() - Method in interface com.badlogic.gdx.graphics.glutils.VertexData
getAudio() - Method in interface com.badlogic.gdx.Application
getAudio() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
getAudio() - Method in class com.badlogic.gdx.backends.jogl.JoglApplication
getAudio() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
getAudio() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
getAutoClearForces() - Method in class com.badlogic.gdx.physics.box2d.World
Get the flag that controls automatic clearing of forces after each time step.
getAverageCenterFrequency(int) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Returns the center frequency of the ith average band.
getAvg(int) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Gets the value of the ith average.
getBand(int) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Returns the amplitude of the requested frequency band.
getBandWidth() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Returns the width of each frequency band in the spectrum (in Hz).
getBodies() - Method in class com.badlogic.gdx.physics.box2d.World
getBody() - Method in class com.badlogic.gdx.physics.box2d.Fixture
Get the parent body of this fixture.
getBodyA() - Method in class com.badlogic.gdx.physics.box2d.Joint
Get the first body attached to this joint.
getBodyB() - Method in class com.badlogic.gdx.physics.box2d.Joint
Get the second body attached to this joint.
getBodyCount() - Method in class com.badlogic.gdx.physics.box2d.World
Get the number of bodies.
getBoolean(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the boolean value associated with an index.
getBoolean(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get the boolean value associated with a key.
getBounds(CharSequence) - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the size of the specified string.
getBounds(CharSequence, int, int) - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the size of the specified substring.
getBounds() - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Returns the size of the cached string.
getBuffer() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObject
Returns the underlying ShortBuffer.
getBuffer() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
Returns the underlying ShortBuffer.
getBuffer() - Method in interface com.badlogic.gdx.graphics.glutils.IndexData
Returns the underlying ShortBuffer.
getBuffer() - Method in class com.badlogic.gdx.graphics.glutils.VertexArray
Returns the underlying FloatBuffer.
getBuffer() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
Returns the underlying FloatBuffer.
getBuffer() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Returns the underlying FloatBuffer.
getBuffer() - Method in interface com.badlogic.gdx.graphics.glutils.VertexData
Returns the underlying FloatBuffer.
getBufferHandle() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Returns the VBO handle
getCanvas() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
getCapHeight() - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the cap height, which is the distance from the top of most uppercase characters to the basline.
getCause() - Method in exception com.badlogic.gdx.utils.json.JSONException
getCenter() - Method in class com.badlogic.gdx.math.collision.BoundingBox
getColor() - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the color of this font.
getColor(float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
getColor() - Method in class com.badlogic.gdx.graphics.Sprite
Returns the color of this sprite.
getColor() - Method in class com.badlogic.gdx.graphics.SpriteBatch
getColor() - Method in class com.badlogic.gdx.graphics.SpriteCache
getColorBufferTexture() - Method in class com.badlogic.gdx.graphics.glutils.FrameBuffer
getColors() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
getCombinedMatrix() - Method in class com.badlogic.gdx.graphics.OrthographicCamera
getCombinedMatrix() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getContactCount() - Method in class com.badlogic.gdx.physics.box2d.World
Get the number of contacts (each may have 0 or more contact points).
getContactList() - Method in class com.badlogic.gdx.physics.box2d.World
getControlPoints() - Method in class com.badlogic.gdx.math.CatmullRomSpline
getCorners() - Method in class com.badlogic.gdx.math.collision.BoundingBox
getCurrentFrame() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo
getD() - Method in class com.badlogic.gdx.math.Plane
getDampingRatio() - Method in class com.badlogic.gdx.physics.box2d.joints.DistanceJoint
Set/get damping ratio.
getDampingRatio() - Method in class com.badlogic.gdx.physics.box2d.joints.MouseJoint
Set/get the damping ratio (dimensionless).
getDelay() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getDeltaTime() - Method in interface com.badlogic.gdx.Graphics
getDensity() - Method in class com.badlogic.gdx.physics.box2d.Fixture
Get the density of this fixture.
getDimensions() - Method in class com.badlogic.gdx.math.collision.BoundingBox
getDirection() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getDouble(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the double value associated with an index.
getDouble(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get the double value associated with a key.
getDrawCount() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getDuration() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getEmission() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getEmitters() - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
getEndPoint(float) - Method in class com.badlogic.gdx.math.collision.Ray
Returns and endpoint given the distance.
getExternalStoragePath() - Method in interface com.badlogic.gdx.Files
Returns the external storage path directory.
getFar() - Method in class com.badlogic.gdx.graphics.OrthographicCamera
getFar() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getFileHandle(String, Files.FileType) - Method in interface com.badlogic.gdx.Files
Returns a handle representing a file or directory.
getFiles() - Method in interface com.badlogic.gdx.Application
getFiles() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
getFiles() - Method in class com.badlogic.gdx.backends.jogl.JoglApplication
getFiles() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
getFiles() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
getFilterData() - Method in class com.badlogic.gdx.physics.box2d.Fixture
getFixtureA() - Method in class com.badlogic.gdx.physics.box2d.Contact
Get the first fixture in this contact.
getFixtureB() - Method in class com.badlogic.gdx.physics.box2d.Contact
Get the second fixture in this contact.
getFixtureList() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the list of all fixtures attached to this body.
getFov() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getFramesPerSecond() - Method in interface com.badlogic.gdx.Graphics
getFreq(float) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Gets the amplitude of the requested frequency in the spectrum.
getFrequency() - Method in class com.badlogic.gdx.physics.box2d.joints.DistanceJoint
Set/get frequency in Hz.
getFrequency() - Method in class com.badlogic.gdx.physics.box2d.joints.MouseJoint
Set/get the frequency in Hertz.
getFriction() - Method in class com.badlogic.gdx.physics.box2d.Fixture
Get the coefficient of friction.
getFrustum() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getGL10() - Method in interface com.badlogic.gdx.Graphics
getGL11() - Method in interface com.badlogic.gdx.Graphics
getGL20() - Method in interface com.badlogic.gdx.Graphics
getGLCommon() - Method in interface com.badlogic.gdx.Graphics
getGraphics() - Method in interface com.badlogic.gdx.Application
getGraphics() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
getGraphics() - Method in class com.badlogic.gdx.backends.jogl.JoglApplication
getGraphics() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
getGraphics() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
getGravity() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getGravity() - Method in class com.badlogic.gdx.physics.box2d.World
getGroundAnchorA() - Method in class com.badlogic.gdx.physics.box2d.joints.PulleyJoint
getGroundAnchorB() - Method in class com.badlogic.gdx.physics.box2d.joints.PulleyJoint
getGroups() - Method in class com.badlogic.gdx.scenes.scene2d.Group
getGroups() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
getGUI() - Method in class com.badlogic.gdx.twl.TWL
Returns the GUI instance, which is the root of the TWL UI hierachy and manages timing, inputs, etc.
getHeight() - Method in interface com.badlogic.gdx.Graphics
getHeight() - Method in class com.badlogic.gdx.graphics.glutils.FrameBuffer
getHeight() - Method in interface com.badlogic.gdx.graphics.Pixmap
getHeight() - Method in class com.badlogic.gdx.graphics.Sprite
getHeight() - Method in interface com.badlogic.gdx.graphics.Texture
getHeight() - Method in interface com.badlogic.gdx.graphics.TextureData
Returns the height of the texture, which must be a power of two.
getHeight() - Method in class com.badlogic.gdx.math.Rectangle
getHighMax() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
getHighMin() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
getImagePath() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getImaginaryPart() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
getImagPart(ShortBuffer) - Method in class com.badlogic.gdx.audio.analysis.KissFFT
getIndices() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
getIndicesBuffer() - Method in class com.badlogic.gdx.graphics.Mesh
getInertia() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the rotational inertia of the body about the local origin.
getInput() - Method in interface com.badlogic.gdx.Application
getInput() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
getInput() - Method in class com.badlogic.gdx.backends.jogl.JoglApplication
getInput() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
getInput() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
getInt(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the int value associated with an index.
getInt(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get the int value associated with a key.
getInterpolation() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo
getJavaHeap() - Method in interface com.badlogic.gdx.Application
getJavaHeap() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
getJavaHeap() - Method in class com.badlogic.gdx.backends.jogl.JoglApplication
getJavaHeap() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
getJavaHeap() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
getJointAngle() - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Get the current joint angle in radians.
getJointCount() - Method in class com.badlogic.gdx.physics.box2d.World
Get the number of joints.
getJointList() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the list of all joints attached to this body.
getJoints() - Method in class com.badlogic.gdx.physics.box2d.World
getJointSpeed() - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Get the current joint translation speed, usually in meters per second.
getJointSpeed() - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Get the current joint translation speed, usually in meters per second.
getJointSpeed() - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Get the current joint angle speed in radians per second.
getJointTranslation() - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Get the current joint translation, usually in meters.
getJointTranslation() - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Get the current joint translation, usually in meters.
getJSONArray(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the JSONArray associated with an index.
getJSONArray(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get the JSONArray value associated with a key.
getJSONObject(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the JSONObject associated with an index.
getJSONObject(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get the JSONObject value associated with a key.
getLastTouchedChild() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
getLatest() - Method in class com.badlogic.gdx.math.WindowedMean
getLength() - Method in interface com.badlogic.gdx.audio.io.Decoder
getLength() - Method in class com.badlogic.gdx.audio.io.Mpg123Decoder
getLength() - Method in class com.badlogic.gdx.audio.io.VorbisDecoder
getLength() - Method in class com.badlogic.gdx.physics.box2d.joints.DistanceJoint
Set/get the natural length.
getLength1() - Method in class com.badlogic.gdx.physics.box2d.joints.PulleyJoint
Get the current length of the segment attached to body1.
getLength2() - Method in class com.badlogic.gdx.physics.box2d.joints.PulleyJoint
Get the current length of the segment attached to body2.
getLibraryPrefix() - Static method in class com.badlogic.gdx.utils.GdxNativesLoader
getLibrarySuffix() - Static method in class com.badlogic.gdx.utils.GdxNativesLoader
getLife() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getLifeOffset() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getLinearDamping() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the linear damping of the body.
getLinearVelocity() - Method in class com.badlogic.gdx.physics.box2d.Body
getLinearVelocityFromLocalPoint(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Body
Get the world velocity of a local point.
getLinearVelocityFromWorldPoint(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Body
Get the world linear velocity of a world point attached to this body.
getLineHeight() - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the line height, which is the distance from one line of text to the next.
getLocalCenter() - Method in class com.badlogic.gdx.physics.box2d.Body
getLocalPoint(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Body
Gets a local point relative to the body's origin given a world point.
getLocalVector(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Body
Gets a local vector given a world vector.
getLog() - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
getLong(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the long value associated with an index.
getLong(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get the long value associated with a key.
getLowerLimit() - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Get the lower joint limit, usually in meters.
getLowerLimit() - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Get the lower joint limit, usually in meters.
getLowerLimit() - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Get the lower joint limit in radians.
getLowestPositiveRoot(float, float, float) - Static method in class com.badlogic.gdx.math.Intersector
Returns the lowest positive root of the quadric equation given by a* x * x + b * x + c = 0.
getLowMax() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
getLowMin() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
getMass() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the total mass of the body.
getMassData() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the mass data of the body.
getMax() - Method in class com.badlogic.gdx.math.collision.BoundingBox
getMaxForce() - Method in class com.badlogic.gdx.physics.box2d.joints.FrictionJoint
Get the maximum friction force in N.
getMaxForce() - Method in class com.badlogic.gdx.physics.box2d.joints.MouseJoint
Set/get the maximum force in Newtons.
getMaxIndices() - Method in class com.badlogic.gdx.graphics.Mesh
getMaxMotorForce() - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Set/Get the maximum motor force, usually in N.
getMaxParticleCount() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getMaxTorque() - Method in class com.badlogic.gdx.physics.box2d.joints.FrictionJoint
Get the maximum friction torque in N*m.
getMaxVertices() - Method in class com.badlogic.gdx.graphics.Mesh
getMean() - Method in class com.badlogic.gdx.math.WindowedMean
returns the mean of the samples added to this instance.
getMin() - Method in class com.badlogic.gdx.math.collision.BoundingBox
getMinParticleCount() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getModelviewMatrix() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getMotorForce() - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Get the current motor force, usually in N.
getMotorForce() - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Get the current motor force, usually in N.
getMotorSpeed() - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Get the motor speed, usually in meters per second.
getMotorSpeed() - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Get the motor speed, usually in meters per second.
getMotorSpeed() - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Get the motor speed in radians per second.
getMotorTorque() - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Get the current motor torque, usually in N-m.
getMultiLineBounds(CharSequence) - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the size of the specified string, which may contain newlines.
getName() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getNames(JSONObject) - Static method in class com.badlogic.gdx.utils.json.JSONObject
Get an array of field names from a JSONObject.
getNames(Object) - Static method in class com.badlogic.gdx.utils.json.JSONObject
Get an array of field names from an Object.
getNativeHeap() - Method in interface com.badlogic.gdx.Application
getNativeHeap() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
getNativeHeap() - Method in class com.badlogic.gdx.backends.jogl.JoglApplication
getNativeHeap() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
getNativeHeap() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
getNativePixmap() - Method in interface com.badlogic.gdx.graphics.Pixmap
getNear() - Method in class com.badlogic.gdx.graphics.OrthographicCamera
getNear() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getNextFrame() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo
getNormal() - Method in class com.badlogic.gdx.math.Plane
getNormal() - Method in class com.badlogic.gdx.physics.box2d.WorldManifold
Returns the normal of this manifold
getNumberOfContactPoints() - Method in class com.badlogic.gdx.physics.box2d.WorldManifold
getNumChannels() - Method in interface com.badlogic.gdx.audio.io.Decoder
getNumChannels() - Method in class com.badlogic.gdx.audio.io.Mpg123Decoder
getNumChannels() - Method in class com.badlogic.gdx.audio.io.VorbisDecoder
getNumIndices() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObject
getNumIndices() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
getNumIndices() - Method in interface com.badlogic.gdx.graphics.glutils.IndexData
getNumIndices() - Method in class com.badlogic.gdx.graphics.Mesh
getNumMaxIndices() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObject
getNumMaxIndices() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
getNumMaxIndices() - Method in interface com.badlogic.gdx.graphics.glutils.IndexData
getNumMaxVertices() - Method in class com.badlogic.gdx.graphics.glutils.VertexArray
getNumMaxVertices() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
getNumMaxVertices() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
getNumMaxVertices() - Method in interface com.badlogic.gdx.graphics.glutils.VertexData
getNumTriangles() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Model
getNumVertices() - Method in class com.badlogic.gdx.graphics.glutils.VertexArray
getNumVertices() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
getNumVertices() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
getNumVertices() - Method in interface com.badlogic.gdx.graphics.glutils.VertexData
getNumVertices() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Model
getNumVertices() - Method in class com.badlogic.gdx.graphics.Mesh
getOldest() - Method in class com.badlogic.gdx.math.WindowedMean
getOriginX() - Method in class com.badlogic.gdx.graphics.Sprite
getOriginY() - Method in class com.badlogic.gdx.graphics.Sprite
getPath(int) - Method in class com.badlogic.gdx.math.CatmullRomSpline
Returns a path, between every two control points numPoints are generated and the control points themselves are added too.
getPercentComplete() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getPickRay(int, int) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Returns a ray in world space form the given screen coordinates.
getPickRay(int, int) - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
Returns a ray in world space form the given screen coordinates.
getPixel(int, int) - Method in interface com.badlogic.gdx.graphics.Pixmap
Returns the 32-bit argb value of the pixel at x, y
getPixelRow(int[], int) - Method in interface com.badlogic.gdx.graphics.Pixmap
Returns the yth row of pixels form the Pixmap in the provided pixels array.
getPlanes() - Method in class com.badlogic.gdx.math.Frustum
getPoints() - Method in class com.badlogic.gdx.physics.box2d.WorldManifold
Returns the contact points of this manifold.
getPosition() - Method in class com.badlogic.gdx.graphics.OrthographicCamera
getPosition() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getPosition() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the world body origin position.
getPosition() - Method in class com.badlogic.gdx.physics.box2d.CircleShape
getPosition() - Method in class com.badlogic.gdx.physics.box2d.Transform
getPpcX() - Method in interface com.badlogic.gdx.Graphics
getPpcY() - Method in interface com.badlogic.gdx.Graphics
getPpiX() - Method in interface com.badlogic.gdx.Graphics
getPpiY() - Method in interface com.badlogic.gdx.Graphics
getProjectionMatrix() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getProjectionMatrix() - Method in class com.badlogic.gdx.graphics.SpriteBatch
Returns the current projection matrix.
getProjectionMatrix() - Method in class com.badlogic.gdx.graphics.SpriteCache
getProxyCount() - Method in class com.badlogic.gdx.physics.box2d.World
Get the number of broad-phase proxies.
getRadius() - Method in class com.badlogic.gdx.physics.box2d.Shape
Returns the radius of this shape
getRate() - Method in interface com.badlogic.gdx.audio.io.Decoder
getRate() - Method in class com.badlogic.gdx.audio.io.Mpg123Decoder
getRate() - Method in class com.badlogic.gdx.audio.io.VorbisDecoder
getRatio() - Method in class com.badlogic.gdx.physics.box2d.joints.GearJoint
Set/Get the gear ratio.
getRatio() - Method in class com.badlogic.gdx.physics.box2d.joints.PulleyJoint
Get the pulley ratio.
getReactionForce(float) - Method in class com.badlogic.gdx.physics.box2d.Joint
getReactionTorque(float) - Method in class com.badlogic.gdx.physics.box2d.Joint
Get the reaction torque on body2 in N*m.
getRealPart() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
getRealPart(ShortBuffer) - Method in class com.badlogic.gdx.audio.analysis.KissFFT
getRegion() - Method in class com.badlogic.gdx.graphics.BitmapFont
getRegion(String) - Method in class com.badlogic.gdx.graphics.TextureAtlas
Returns the first region found with the specified name.
getRegionHeight() - Method in class com.badlogic.gdx.graphics.TextureRegion
Returns the region's height.
getRegions() - Method in class com.badlogic.gdx.graphics.TextureAtlas
Returns all regions in the atlas.
getRegions(String) - Method in class com.badlogic.gdx.graphics.TextureAtlas
Returns all regions with the specified name, ordered by smallest to largest index.
getRegionWidth() - Method in class com.badlogic.gdx.graphics.TextureRegion
Returns the region's width.
getRegionX() - Method in class com.badlogic.gdx.graphics.TextureRegion
getRegionY() - Method in class com.badlogic.gdx.graphics.TextureRegion
getRestitution() - Method in class com.badlogic.gdx.physics.box2d.Fixture
Get the coefficient of restitution.
getRight() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getRoot() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
getRotation() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getRotation() - Method in class com.badlogic.gdx.graphics.Sprite
getScale() - Method in class com.badlogic.gdx.graphics.OrthographicCamera
getScale() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getScale(float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
getScaleX() - Method in class com.badlogic.gdx.graphics.Sprite
getScaleY() - Method in class com.badlogic.gdx.graphics.Sprite
getScaling() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
getScreen() - Method in class com.badlogic.gdx.Game
getScreenToWorld(float, float, Vector2) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Calculates the world coordinates of the given screen coordinates and stores the result in world
getScreenToWorldX(float) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Returns the given screen x-coordinates as a world x-coordinate
getScreenToWorldY(float) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Returns the given screen y-coordinates as a world y-coordinate
getShape() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
getShape() - Method in class com.badlogic.gdx.physics.box2d.Fixture
Returns the shape of this fixture
getSide() - Method in class com.badlogic.gdx.graphics.OrthographicCamera
getSide() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
getSpaceWidth() - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the width of the space character.
getSpawnHeight() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getSpawnShape() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getSpawnWidth() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getSpectrum() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
getSprite() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getSprite(String) - Method in class com.badlogic.gdx.graphics.TextureAtlas
Returns the first region found with the specified name as a sprite.
getSpriteBatch() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
getSprites() - Method in class com.badlogic.gdx.graphics.TextureAtlas
Returns all regions in the atlas as sprites.
getSprites(String) - Method in class com.badlogic.gdx.graphics.TextureAtlas
Returns all regions with the specified name as sprites, ordered by smallest to largest index.
getString(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the string associated with an index.
getString(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get the string associated with a key.
getTangentNormals(int, Vector3) - Method in class com.badlogic.gdx.math.CatmullRomSpline
Returns the tangent's normals using the tangent and provided up vector doing a cross product.
getTangentNormals(int, List<Vector3>) - Method in class com.badlogic.gdx.math.CatmullRomSpline
getTangentNormals2D(int) - Method in class com.badlogic.gdx.math.CatmullRomSpline
Returns all tangent's normals in 2D space for the points in a path.
getTangents(int) - Method in class com.badlogic.gdx.math.CatmullRomSpline
Returns all tangents for the points in a path.
getTarget() - Method in class com.badlogic.gdx.physics.box2d.joints.MouseJoint
getTextInput(Input.TextInputListener, String, String) - Method in interface com.badlogic.gdx.Input
System dependent method to input a string of text.
getTexture() - Method in class com.badlogic.gdx.graphics.TextureRegion
getTextureObjectHandle() - Method in interface com.badlogic.gdx.graphics.Texture
getThemeURL(String, Files.FileType) - Static method in class com.badlogic.gdx.twl.TWL
Returns a URL to a theme file, which can be used with ThemeManager to create a theme for GUI#applyTheme(ThemeManager).
getTimeline() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
getTimeline() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
getTint() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getTransform() - Method in class com.badlogic.gdx.physics.box2d.Body
getTransformMatrix() - Method in class com.badlogic.gdx.graphics.SpriteBatch
Returns the current transform matrix.
getTransformMatrix() - Method in class com.badlogic.gdx.graphics.SpriteCache
getTransparency() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getTwlKeyCode(int) - Static method in class com.badlogic.gdx.twl.TWL
getType() - Method in interface com.badlogic.gdx.Application
getType() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
getType() - Method in class com.badlogic.gdx.backends.jogl.JoglApplication
getType() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
getType() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
getType() - Method in interface com.badlogic.gdx.Graphics
getType() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the type of this body.
getType() - Method in class com.badlogic.gdx.physics.box2d.CircleShape
Get the type of this shape.
getType() - Method in class com.badlogic.gdx.physics.box2d.Fixture
Get the type of the child shape.
getType() - Method in class com.badlogic.gdx.physics.box2d.Joint
Get the type of the concrete joint.
getType() - Method in class com.badlogic.gdx.physics.box2d.PolygonShape
Get the type of this shape.
getType() - Method in class com.badlogic.gdx.physics.box2d.Shape
Get the type of this shape.
getU() - Method in class com.badlogic.gdx.graphics.TextureRegion
getU2() - Method in class com.badlogic.gdx.graphics.TextureRegion
getUp() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getUpperLimit() - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Get the upper joint limit, usually in meters.
getUpperLimit() - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Get the upper joint limit, usually in meters.
getUpperLimit() - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Get the upper joint limit in radians.
getUserData() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the user data
getUserData() - Method in class com.badlogic.gdx.physics.box2d.Fixture
getV() - Method in class com.badlogic.gdx.graphics.TextureRegion
getV2() - Method in class com.badlogic.gdx.graphics.TextureRegion
getValue() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue
getValue() - Method in enum com.badlogic.gdx.physics.box2d.BodyDef.BodyType
getValue() - Method in enum com.badlogic.gdx.physics.box2d.JointDef.JointType
getValues() - Method in class com.badlogic.gdx.math.Matrix3
getValues() - Method in class com.badlogic.gdx.math.Matrix4
getVelocity() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getVersion() - Method in interface com.badlogic.gdx.Application
getVersion() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
getVersion() - Method in class com.badlogic.gdx.backends.jogl.JoglApplication
getVersion() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
getVersion() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
getVertex(int, Vector2) - Method in class com.badlogic.gdx.physics.box2d.PolygonShape
Returns the vertex at the given position.
getVertexAttribute(int) - Method in class com.badlogic.gdx.graphics.Mesh
Returns the first VertexAttribute having the given VertexAttributes.Usage.
getVertexAttributes() - Method in class com.badlogic.gdx.graphics.Mesh
getVertexCount() - Method in class com.badlogic.gdx.physics.box2d.PolygonShape
getVertexSize() - Method in class com.badlogic.gdx.graphics.Mesh
getVertices() - Method in class com.badlogic.gdx.graphics.Sprite
Returns the packed vertices, colors, and texture coordinates for this sprite.
getVerticesBuffer() - Method in class com.badlogic.gdx.graphics.Mesh
getViewportWidth() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
getWidth() - Method in interface com.badlogic.gdx.Graphics
getWidth() - Method in class com.badlogic.gdx.graphics.glutils.FrameBuffer
getWidth() - Method in interface com.badlogic.gdx.graphics.Pixmap
getWidth() - Method in class com.badlogic.gdx.graphics.Sprite
getWidth() - Method in interface com.badlogic.gdx.graphics.Texture
getWidth() - Method in interface com.badlogic.gdx.graphics.TextureData
Returns the width of the texture, which must be a power of two.
getWidth() - Method in class com.badlogic.gdx.math.Rectangle
getWind() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getWorld() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the parent world of this body.
getWorldCenter() - Method in class com.badlogic.gdx.physics.box2d.Body
GetWorldManifold() - Method in class com.badlogic.gdx.physics.box2d.Contact
getWorldPoint(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Body
Get the world coordinates of a point given the local coordinates.
getWorldToScreen(float, float, Vector2) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Calculates the screen coordinates of the given world coordinates
getWorldToScreenX(float) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Returns the given world x-coordinate as a screen x-coordinate
getWorldToScreenY(float) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Returns the given world y-coordinate as a screen x-coordinate
getWorldVector(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Body
Get the world coordinates of a vector given the local coordinates.
getWrappedBounds(CharSequence, float) - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the size of the specified string, which may contain newlines and is wrapped to keep it within a rectangle of the specified width.
getX() - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Returns the x position of the cached string, relative to the position when the string was cached.
getX() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getX() - Method in class com.badlogic.gdx.graphics.Sprite
getX() - Method in interface com.badlogic.gdx.Input
getX(int) - Method in interface com.badlogic.gdx.Input
Returns the x coordinate in screen coordinates of the given pointer.
getX() - Method in class com.badlogic.gdx.math.Rectangle
getXHeight() - Method in class com.badlogic.gdx.graphics.BitmapFont
Returns the x-height, which is the distance from the top of most lowercase characters to the basline.
getXOffsetValue() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getY() - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Returns the y position of the cached string, relative to the position when the string was cached.
getY() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
getY() - Method in class com.badlogic.gdx.graphics.Sprite
getY() - Method in interface com.badlogic.gdx.Input
getY(int) - Method in interface com.badlogic.gdx.Input
Returns the y coordinate in screen coordinates of the given pointer.
getY() - Method in class com.badlogic.gdx.math.Rectangle
getYOffsetValue() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
gl - Static variable in class com.badlogic.gdx.Gdx
gl10 - Static variable in class com.badlogic.gdx.Gdx
GL10 - Interface in com.badlogic.gdx.graphics
Interface wrapping all standard OpenGL ES 1.0 methods.
gl11 - Static variable in class com.badlogic.gdx.Gdx
GL11 - Interface in com.badlogic.gdx.graphics
Interface wrapping all OpenGL ES 1.1 methods.
gl20 - Static variable in class com.badlogic.gdx.Gdx
GL20 - Interface in com.badlogic.gdx.graphics
Interface wrapping all the methods of OpenGL ES 2.0
GL_ACTIVE_ATTRIBUTE_MAX_LENGTH - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ACTIVE_ATTRIBUTES - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ACTIVE_TEXTURE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ACTIVE_TEXTURE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ACTIVE_UNIFORM_MAX_LENGTH - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ACTIVE_UNIFORMS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ADD - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ADD_SIGNED - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ALIASED_LINE_WIDTH_RANGE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ALIASED_LINE_WIDTH_RANGE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ALIASED_POINT_SIZE_RANGE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ALIASED_POINT_SIZE_RANGE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ALPHA_BITS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ALPHA_BITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ALPHA_SCALE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ALPHA_TEST - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ALPHA_TEST_FUNC - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ALPHA_TEST_REF - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ALWAYS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ALWAYS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_AMBIENT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_AMBIENT_AND_DIFFUSE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_AND - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_AND_INVERTED - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_AND_REVERSE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ARRAY_BUFFER - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ARRAY_BUFFER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ARRAY_BUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ARRAY_BUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ATTACHED_SHADERS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BACK - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_BACK - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLEND - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_BLEND - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLEND_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLEND_DST - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_BLEND_DST_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLEND_DST_RGB - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLEND_EQUATION - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLEND_EQUATION_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLEND_EQUATION_RGB - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLEND_SRC - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_BLEND_SRC_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLEND_SRC_RGB - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BLUE_BITS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_BLUE_BITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BOOL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BOOL_VEC2 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BOOL_VEC3 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BOOL_VEC4 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BUFFER_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_BUFFER_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BUFFER_USAGE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_BUFFER_USAGE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_BYTE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_BYTE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_CCW - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_CCW - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_CLAMP_TO_EDGE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_CLAMP_TO_EDGE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_CLEAR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_CLIENT_ACTIVE_TEXTURE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CLIP_PLANE0 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CLIP_PLANE1 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CLIP_PLANE2 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CLIP_PLANE3 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CLIP_PLANE4 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CLIP_PLANE5 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COLOR_ARRAY - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_COLOR_ARRAY_BUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COLOR_ARRAY_POINTER - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COLOR_ARRAY_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COLOR_ARRAY_STRIDE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COLOR_ARRAY_TYPE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COLOR_ATTACHMENT0 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_COLOR_BUFFER_BIT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_COLOR_BUFFER_BIT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_COLOR_CLEAR_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COLOR_CLEAR_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_COLOR_LOGIC_OP - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_COLOR_MATERIAL - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_COLOR_WRITEMASK - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COLOR_WRITEMASK - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_COMBINE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COMBINE_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COMBINE_RGB - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COMPILE_STATUS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_COMPRESSED_TEXTURE_FORMATS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_COMPRESSED_TEXTURE_FORMATS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_CONSTANT - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CONSTANT_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_CONSTANT_ATTENUATION - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_CONSTANT_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_COORD_REPLACE_OES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_COPY - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_COPY_INVERTED - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_CULL_FACE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_CULL_FACE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_CULL_FACE_MODE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CULL_FACE_MODE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_CURRENT_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CURRENT_NORMAL - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CURRENT_PROGRAM - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_CURRENT_TEXTURE_COORDS - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_CURRENT_VERTEX_ATTRIB - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_CW - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_CW - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DECAL - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DECR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DECR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DECR_WRAP - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DELETE_STATUS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_ATTACHMENT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_BITS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DEPTH_BITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_BUFFER_BIT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DEPTH_BUFFER_BIT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_CLEAR_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_DEPTH_CLEAR_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_COMPONENT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_COMPONENT16 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_FUNC - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_DEPTH_FUNC - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_RANGE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_DEPTH_RANGE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_TEST - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DEPTH_TEST - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DEPTH_WRITEMASK - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_DEPTH_WRITEMASK - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DIFFUSE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DITHER - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DITHER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DONT_CARE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DONT_CARE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DOT3_RGB - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_DOT3_RGBA - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_DST_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DST_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DST_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_DST_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_DYNAMIC_DRAW - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_DYNAMIC_DRAW - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ELEMENT_ARRAY_BUFFER - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ELEMENT_ARRAY_BUFFER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ELEMENT_ARRAY_BUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ELEMENT_ARRAY_BUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_EMISSION - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_EQUAL - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_EQUAL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_EQUIV - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ES_VERSION_2_0 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_EXP - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_EXP2 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_EXTENSIONS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_EXTENSIONS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FALSE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FALSE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FASTEST - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FASTEST - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FILL - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FIXED - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FLAT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FLOAT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FLOAT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FLOAT_MAT2 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FLOAT_MAT3 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FLOAT_MAT4 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FLOAT_VEC2 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FLOAT_VEC3 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FLOAT_VEC4 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FOG - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FOG_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FOG_DENSITY - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FOG_END - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FOG_HINT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FOG_MODE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FOG_START - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FRAGMENT_SHADER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_COMPLETE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRAMEBUFFER_UNSUPPORTED - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRONT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FRONT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRONT_AND_BACK - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_FRONT_AND_BACK - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FRONT_FACE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_FRONT_FACE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FUNC_ADD - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FUNC_REVERSE_SUBTRACT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_FUNC_SUBTRACT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_GENERATE_MIPMAP - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_GENERATE_MIPMAP_HINT - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_GENERATE_MIPMAP_HINT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_GEQUAL - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_GEQUAL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_GREATER - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_GREATER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_GREEN_BITS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_GREEN_BITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_HIGH_FLOAT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_HIGH_INT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_IMPLEMENTATION_COLOR_READ_FORMAT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_IMPLEMENTATION_COLOR_READ_FORMAT_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_IMPLEMENTATION_COLOR_READ_TYPE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_IMPLEMENTATION_COLOR_READ_TYPE_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_INCR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_INCR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INCR_WRAP - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INFO_LOG_LENGTH - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INT_VEC2 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INT_VEC3 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INT_VEC4 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INTERPOLATE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_INVALID_ENUM - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_INVALID_ENUM - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INVALID_FRAMEBUFFER_OPERATION - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INVALID_OPERATION - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_INVALID_OPERATION - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INVALID_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_INVALID_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_INVERT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_INVERT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_KEEP - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_KEEP - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LEQUAL - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LEQUAL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LESS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LESS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LIGHT0 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHT1 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHT2 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHT3 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHT4 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHT5 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHT6 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHT7 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHT_MODEL_AMBIENT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHT_MODEL_TWO_SIDE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LIGHTING - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINE_LOOP - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINE_LOOP - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LINE_SMOOTH - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINE_SMOOTH_HINT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINE_STRIP - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINE_STRIP - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LINE_WIDTH - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_LINE_WIDTH - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LINEAR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINEAR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LINEAR_ATTENUATION - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINEAR_MIPMAP_LINEAR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINEAR_MIPMAP_LINEAR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LINEAR_MIPMAP_NEAREST - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINEAR_MIPMAP_NEAREST - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LINES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LINES - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LINK_STATUS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LOGIC_OP_MODE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_LOW_FLOAT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LOW_INT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LUMINANCE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LUMINANCE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_LUMINANCE_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_LUMINANCE_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MATRIX_MODE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_MAX_CLIP_PLANES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_CUBE_MAP_TEXTURE_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_ELEMENTS_INDICES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MAX_ELEMENTS_INDICES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_MAX_ELEMENTS_VERTICES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MAX_ELEMENTS_VERTICES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_MAX_FRAGMENT_UNIFORM_VECTORS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_LIGHTS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MAX_MODELVIEW_STACK_DEPTH - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MAX_PROJECTION_STACK_DEPTH - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MAX_RENDERBUFFER_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_TEXTURE_IMAGE_UNITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_TEXTURE_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MAX_TEXTURE_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_TEXTURE_STACK_DEPTH - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MAX_TEXTURE_UNITS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MAX_VARYING_VECTORS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_VERTEX_ATTRIBS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_VERTEX_UNIFORM_VECTORS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MAX_VIEWPORT_DIMS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MAX_VIEWPORT_DIMS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MEDIUM_FLOAT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MEDIUM_INT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MIRRORED_REPEAT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_MODELVIEW - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MODELVIEW_MATRIX - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_MODELVIEW_STACK_DEPTH - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_MODULATE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_MULTISAMPLE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NAND - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NEAREST - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NEAREST - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_NEAREST_MIPMAP_LINEAR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NEAREST_MIPMAP_LINEAR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_NEAREST_MIPMAP_NEAREST - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NEAREST_MIPMAP_NEAREST - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_NEVER - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NEVER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_NICEST - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NICEST - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_NO_ERROR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NO_ERROR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_NONE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_NOOP - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NOR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NORMAL_ARRAY - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NORMAL_ARRAY_BUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_NORMAL_ARRAY_POINTER - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_NORMAL_ARRAY_STRIDE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_NORMAL_ARRAY_TYPE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_NORMALIZE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NOTEQUAL - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NOTEQUAL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_NUM_COMPRESSED_TEXTURE_FORMATS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_NUM_COMPRESSED_TEXTURE_FORMATS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_NUM_SHADER_BINARY_FORMATS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_OES_compressed_paletted_texture - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_OES_point_size_array - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_OES_point_sprite - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_OES_read_format - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_OES_VERSION_1_0 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_OES_VERSION_1_0 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_ONE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ONE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ONE_MINUS_CONSTANT_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ONE_MINUS_CONSTANT_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ONE_MINUS_DST_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ONE_MINUS_DST_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ONE_MINUS_DST_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ONE_MINUS_DST_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ONE_MINUS_SRC_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ONE_MINUS_SRC_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_ONE_MINUS_SRC_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ONE_MINUS_SRC_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_OPERAND0_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_OPERAND0_RGB - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_OPERAND1_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_OPERAND1_RGB - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_OPERAND2_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_OPERAND2_RGB - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_OR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_OR_INVERTED - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_OR_REVERSE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_OUT_OF_MEMORY - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_OUT_OF_MEMORY - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_PACK_ALIGNMENT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PACK_ALIGNMENT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_PALETTE4_R5_G6_B5_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PALETTE4_RGB5_A1_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PALETTE4_RGB8_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PALETTE4_RGBA4_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PALETTE4_RGBA8_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PALETTE8_R5_G6_B5_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PALETTE8_RGB5_A1_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PALETTE8_RGB8_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PALETTE8_RGBA4_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PALETTE8_RGBA8_OES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PERSPECTIVE_CORRECTION_HINT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_POINT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_POINT_DISTANCE_ATTENUATION - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_FADE_THRESHOLD_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_SIZE_ARRAY_BUFFER_BINDING_OES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_SIZE_ARRAY_OES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_SIZE_ARRAY_POINTER_OES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_SIZE_ARRAY_STRIDE_OES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_SIZE_ARRAY_TYPE_OES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_SIZE_MAX - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_SIZE_MIN - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINT_SMOOTH - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_POINT_SMOOTH_HINT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_POINT_SPRITE_OES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POINTS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_POINTS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_POLYGON_OFFSET_FACTOR - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POLYGON_OFFSET_FACTOR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_POLYGON_OFFSET_FILL - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_POLYGON_OFFSET_FILL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_POLYGON_OFFSET_UNITS - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POLYGON_OFFSET_UNITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_POLYGON_SMOOTH_HINT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_POLYGON_SMOOTH_HINT - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_POSITION - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PREVIOUS - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_PRIMARY_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_PROJECTION - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_PROJECTION_MATRIX - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_PROJECTION_STACK_DEPTH - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_QUADRATIC_ATTENUATION - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_RED_BITS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_RED_BITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_ALPHA_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_BLUE_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_DEPTH_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_GREEN_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_HEIGHT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_INTERNAL_FORMAT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_RED_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_STENCIL_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERBUFFER_WIDTH - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RENDERER - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_RENDERER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_REPEAT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_REPEAT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_REPLACE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_REPLACE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RESCALE_NORMAL - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_RGB - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_RGB - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RGB565 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RGB5_A1 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RGB_SCALE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_RGBA - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_RGBA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_RGBA4 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SAMPLE_ALPHA_TO_COVERAGE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SAMPLE_ALPHA_TO_COVERAGE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SAMPLE_ALPHA_TO_ONE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SAMPLE_BUFFERS - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SAMPLE_BUFFERS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SAMPLE_COVERAGE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SAMPLE_COVERAGE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SAMPLE_COVERAGE_INVERT - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SAMPLE_COVERAGE_INVERT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SAMPLE_COVERAGE_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SAMPLE_COVERAGE_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SAMPLER_2D - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SAMPLER_CUBE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SAMPLES - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SAMPLES - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SCISSOR_BOX - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SCISSOR_BOX - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SCISSOR_TEST - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SCISSOR_TEST - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SET - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SHADE_MODEL - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SHADER_BINARY_FORMATS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SHADER_COMPILER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SHADER_SOURCE_LENGTH - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SHADER_TYPE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SHADING_LANGUAGE_VERSION - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SHININESS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SHORT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SHORT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SMOOTH - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SMOOTH_LINE_WIDTH_RANGE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SMOOTH_POINT_SIZE_RANGE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SPECULAR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SPOT_CUTOFF - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SPOT_DIRECTION - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SPOT_EXPONENT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SRC0_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SRC0_RGB - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SRC1_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SRC1_RGB - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SRC2_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SRC2_RGB - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_SRC_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SRC_ALPHA - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SRC_ALPHA_SATURATE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SRC_ALPHA_SATURATE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SRC_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SRC_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STACK_OVERFLOW - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_STACK_UNDERFLOW - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_STATIC_DRAW - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_STATIC_DRAW - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_ATTACHMENT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_BACK_FAIL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_BACK_FUNC - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_BACK_PASS_DEPTH_FAIL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_BACK_PASS_DEPTH_PASS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_BACK_REF - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_BACK_VALUE_MASK - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_BACK_WRITEMASK - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_BITS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_STENCIL_BITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_BUFFER_BIT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_STENCIL_BUFFER_BIT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_CLEAR_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_STENCIL_CLEAR_VALUE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_FAIL - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_STENCIL_FAIL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_FUNC - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_STENCIL_FUNC - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_INDEX - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_INDEX8 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_PASS_DEPTH_FAIL - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_STENCIL_PASS_DEPTH_FAIL - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_PASS_DEPTH_PASS - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_STENCIL_PASS_DEPTH_PASS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_REF - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_STENCIL_REF - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_TEST - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_STENCIL_TEST - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_VALUE_MASK - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_STENCIL_VALUE_MASK - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STENCIL_WRITEMASK - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_STENCIL_WRITEMASK - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_STREAM_DRAW - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SUBPIXEL_BITS - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_SUBPIXEL_BITS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_SUBTRACT - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_TEXTURE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE0 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE0 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE1 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE1 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE10 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE10 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE11 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE11 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE12 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE12 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE13 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE13 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE14 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE14 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE15 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE15 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE16 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE16 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE17 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE17 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE18 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE18 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE19 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE19 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE2 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE2 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE20 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE20 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE21 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE21 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE22 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE22 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE23 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE23 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE24 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE24 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE25 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE25 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE26 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE26 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE27 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE27 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE28 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE28 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE29 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE29 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE3 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE3 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE30 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE30 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE31 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE31 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE4 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE4 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE5 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE5 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE6 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE6 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE7 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE7 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE8 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE8 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE9 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE9 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_2D - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE_2D - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_BINDING_2D - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_TEXTURE_BINDING_2D - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_BINDING_CUBE_MAP - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_COORD_ARRAY - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_TEXTURE_COORD_ARRAY_POINTER - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_TEXTURE_COORD_ARRAY_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_TEXTURE_COORD_ARRAY_STRIDE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_TEXTURE_COORD_ARRAY_TYPE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_TEXTURE_CUBE_MAP - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_CUBE_MAP_NEGATIVE_X - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_CUBE_MAP_NEGATIVE_Y - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_CUBE_MAP_NEGATIVE_Z - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_CUBE_MAP_POSITIVE_X - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_CUBE_MAP_POSITIVE_Y - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_CUBE_MAP_POSITIVE_Z - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_ENV - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE_ENV_COLOR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE_ENV_MODE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE_MAG_FILTER - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE_MAG_FILTER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_MATRIX - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_TEXTURE_MIN_FILTER - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE_MIN_FILTER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_STACK_DEPTH - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_TEXTURE_WRAP_S - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE_WRAP_S - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TEXTURE_WRAP_T - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TEXTURE_WRAP_T - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TRIANGLE_FAN - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TRIANGLE_FAN - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TRIANGLE_STRIP - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TRIANGLE_STRIP - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TRIANGLES - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TRIANGLES - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_TRUE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_TRUE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_UNPACK_ALIGNMENT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_UNPACK_ALIGNMENT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_UNSIGNED_BYTE - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_UNSIGNED_BYTE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_UNSIGNED_INT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_UNSIGNED_SHORT - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_UNSIGNED_SHORT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_UNSIGNED_SHORT_4_4_4_4 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_UNSIGNED_SHORT_4_4_4_4 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_UNSIGNED_SHORT_5_5_5_1 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_UNSIGNED_SHORT_5_5_5_1 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_UNSIGNED_SHORT_5_6_5 - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_UNSIGNED_SHORT_5_6_5 - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VALIDATE_STATUS - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VENDOR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_VENDOR - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VERSION - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_VERSION - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VERSION_ES_CL_1_0 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VERSION_ES_CL_1_1 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VERSION_ES_CM_1_0 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VERSION_ES_CM_1_1 - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VERTEX_ARRAY - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_VERTEX_ARRAY_BUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VERTEX_ARRAY_POINTER - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VERTEX_ARRAY_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VERTEX_ARRAY_STRIDE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VERTEX_ARRAY_TYPE - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VERTEX_ATTRIB_ARRAY_ENABLED - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VERTEX_ATTRIB_ARRAY_NORMALIZED - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VERTEX_ATTRIB_ARRAY_POINTER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VERTEX_ATTRIB_ARRAY_SIZE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VERTEX_ATTRIB_ARRAY_STRIDE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VERTEX_ATTRIB_ARRAY_TYPE - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VERTEX_SHADER - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_VIEWPORT - Static variable in interface com.badlogic.gdx.graphics.GL11
GL_VIEWPORT - Static variable in interface com.badlogic.gdx.graphics.GL20
GL_XOR - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ZERO - Static variable in interface com.badlogic.gdx.graphics.GL10
GL_ZERO - Static variable in interface com.badlogic.gdx.graphics.GL20
glActiveTexture(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glAlphaFunc(int, float) - Method in interface com.badlogic.gdx.graphics.GL10
glAttachShader(int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glBindAttribLocation(int, int, String) - Method in interface com.badlogic.gdx.graphics.GL20
glBindBuffer(int, int) - Method in interface com.badlogic.gdx.graphics.GL11
glBindBuffer(int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glBindFramebuffer(int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glBindRenderbuffer(int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glBindTexture(int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glBlendColor(float, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL20
glBlendEquation(int) - Method in interface com.badlogic.gdx.graphics.GL20
glBlendEquationSeparate(int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glBlendFunc(int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glBlendFuncSeparate(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glBufferData(int, int, Buffer, int) - Method in interface com.badlogic.gdx.graphics.GL11
glBufferData(int, int, Buffer, int) - Method in interface com.badlogic.gdx.graphics.GL20
glBufferSubData(int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL11
glBufferSubData(int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL20
glCheckFramebufferStatus(int) - Method in interface com.badlogic.gdx.graphics.GL20
glClear(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glClearColor(float, float, float, float) - Method in interface com.badlogic.gdx.graphics.GLCommon
glClearDepthf(float) - Method in interface com.badlogic.gdx.graphics.GLCommon
glClearStencil(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glClientActiveTexture(int) - Method in interface com.badlogic.gdx.graphics.GL10
glClipPlanef(int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glClipPlanef(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glColor4f(float, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL10
glColor4ub(byte, byte, byte, byte) - Method in interface com.badlogic.gdx.graphics.GL11
glColorMask(boolean, boolean, boolean, boolean) - Method in interface com.badlogic.gdx.graphics.GLCommon
glColorPointer(int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL10
glColorPointer(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL11
GLCommon - Interface in com.badlogic.gdx.graphics
This interface defines methods common to GL10, GL11 and GL20.
glCompileShader(int) - Method in interface com.badlogic.gdx.graphics.GL20
glCompressedTexImage2D(int, int, int, int, int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GLCommon
glCompressedTexSubImage2D(int, int, int, int, int, int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GLCommon
glCopyTexImage2D(int, int, int, int, int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glCopyTexSubImage2D(int, int, int, int, int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glCreateProgram() - Method in interface com.badlogic.gdx.graphics.GL20
glCreateShader(int) - Method in interface com.badlogic.gdx.graphics.GL20
glCullFace(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glDeleteBuffers(int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glDeleteBuffers(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glDeleteBuffers(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glDeleteFramebuffers(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glDeleteProgram(int) - Method in interface com.badlogic.gdx.graphics.GL20
glDeleteRenderbuffers(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glDeleteShader(int) - Method in interface com.badlogic.gdx.graphics.GL20
glDeleteTextures(int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glDeleteTextures(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GLCommon
glDepthFunc(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glDepthMask(boolean) - Method in interface com.badlogic.gdx.graphics.GLCommon
glDepthRangef(float, float) - Method in interface com.badlogic.gdx.graphics.GLCommon
glDetachShader(int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glDisable(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glDisableClientState(int) - Method in interface com.badlogic.gdx.graphics.GL10
glDisableVertexAttribArray(int) - Method in interface com.badlogic.gdx.graphics.GL20
glDrawArrays(int, int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glDrawElements(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL11
glDrawElements(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glDrawElements(int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GLCommon
glEnable(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glEnableClientState(int) - Method in interface com.badlogic.gdx.graphics.GL10
glEnableVertexAttribArray(int) - Method in interface com.badlogic.gdx.graphics.GL20
glFinish() - Method in interface com.badlogic.gdx.graphics.GLCommon
glFlush() - Method in interface com.badlogic.gdx.graphics.GLCommon
glFogf(int, float) - Method in interface com.badlogic.gdx.graphics.GL10
glFogfv(int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glFogfv(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL10
glFramebufferRenderbuffer(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glFramebufferTexture2D(int, int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glFrontFace(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glFrustumf(float, float, float, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL10
glGenBuffers(int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGenBuffers(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGenBuffers(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGenerateMipmap(int) - Method in interface com.badlogic.gdx.graphics.GL20
glGenFramebuffers(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGenRenderbuffers(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGenTextures(int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glGenTextures(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GLCommon
glGetActiveAttrib(int, int, IntBuffer, Buffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetActiveUniform(int, int, IntBuffer, Buffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetAttachedShaders(int, int, Buffer, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetAttribLocation(int, String) - Method in interface com.badlogic.gdx.graphics.GL20
glGetBooleanv(int, boolean[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGetBooleanv(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGetBooleanv(int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetBufferParameteriv(int, int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGetBufferParameteriv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGetBufferParameteriv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetClipPlanef(int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGetClipPlanef(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGetError() - Method in interface com.badlogic.gdx.graphics.GLCommon
glGetFloatv(int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGetFloatv(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGetFloatv(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetFramebufferAttachmentParameteriv(int, int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetIntegerv(int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glGetIntegerv(int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GLCommon
glGetLightfv(int, int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGetLightfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGetMaterialfv(int, int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGetMaterialfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGetPointerv(int, Buffer[]) - Method in interface com.badlogic.gdx.graphics.GL11
glGetProgramInfoLog(int) - Method in interface com.badlogic.gdx.graphics.GL20
glGetProgramiv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetRenderbufferParameteriv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetShaderInfoLog(int) - Method in interface com.badlogic.gdx.graphics.GL20
glGetShaderiv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetShaderPrecisionFormat(int, int, IntBuffer, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetShaderSource(int, int, Buffer, String) - Method in interface com.badlogic.gdx.graphics.GL20
glGetString(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glGetTexEnviv(int, int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGetTexEnviv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGetTexParameterfv(int, int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGetTexParameterfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGetTexParameterfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetTexParameteriv(int, int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glGetTexParameteriv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glGetTexParameteriv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetUniformfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetUniformiv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetUniformLocation(int, String) - Method in interface com.badlogic.gdx.graphics.GL20
glGetVertexAttribfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetVertexAttribiv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glGetVertexAttribPointerv(int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL20
glHint(int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glIsBuffer(int) - Method in interface com.badlogic.gdx.graphics.GL11
glIsBuffer(int) - Method in interface com.badlogic.gdx.graphics.GL20
glIsEnabled(int) - Method in interface com.badlogic.gdx.graphics.GL11
glIsEnabled(int) - Method in interface com.badlogic.gdx.graphics.GL20
glIsFramebuffer(int) - Method in interface com.badlogic.gdx.graphics.GL20
glIsProgram(int) - Method in interface com.badlogic.gdx.graphics.GL20
glIsRenderbuffer(int) - Method in interface com.badlogic.gdx.graphics.GL20
glIsShader(int) - Method in interface com.badlogic.gdx.graphics.GL20
glIsTexture(int) - Method in interface com.badlogic.gdx.graphics.GL11
glIsTexture(int) - Method in interface com.badlogic.gdx.graphics.GL20
glLightf(int, int, float) - Method in interface com.badlogic.gdx.graphics.GL10
glLightfv(int, int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glLightfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL10
glLightModelf(int, float) - Method in interface com.badlogic.gdx.graphics.GL10
glLightModelfv(int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glLightModelfv(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL10
glLineWidth(float) - Method in interface com.badlogic.gdx.graphics.GLCommon
glLinkProgram(int) - Method in interface com.badlogic.gdx.graphics.GL20
glLoadIdentity() - Method in interface com.badlogic.gdx.graphics.GL10
glLoadMatrixf(float[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glLoadMatrixf(FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL10
glLogicOp(int) - Method in interface com.badlogic.gdx.graphics.GL10
glMaterialf(int, int, float) - Method in interface com.badlogic.gdx.graphics.GL10
glMaterialfv(int, int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glMaterialfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL10
glMatrixMode(int) - Method in interface com.badlogic.gdx.graphics.GL10
glMultiTexCoord4f(int, float, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL10
glMultMatrixf(float[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glMultMatrixf(FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL10
glNormal3f(float, float, float) - Method in interface com.badlogic.gdx.graphics.GL10
glNormalPointer(int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL10
glNormalPointer(int, int, int) - Method in interface com.badlogic.gdx.graphics.GL11
glOrthof(float, float, float, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL10
glPixelStorei(int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glPointParameterf(int, float) - Method in interface com.badlogic.gdx.graphics.GL11
glPointParameterfv(int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glPointParameterfv(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glPointSize(float) - Method in interface com.badlogic.gdx.graphics.GL10
glPointSizePointerOES(int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL11
glPolygonMode(int, int) - Method in interface com.badlogic.gdx.graphics.GL10
glPolygonOffset(float, float) - Method in interface com.badlogic.gdx.graphics.GLCommon
glPopMatrix() - Method in interface com.badlogic.gdx.graphics.GL10
glPushMatrix() - Method in interface com.badlogic.gdx.graphics.GL10
glReadPixels(int, int, int, int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GLCommon
glReleaseShaderCompiler() - Method in interface com.badlogic.gdx.graphics.GL20
glRenderbufferStorage(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glRotatef(float, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL10
glSampleCoverage(float, boolean) - Method in interface com.badlogic.gdx.graphics.GL10
glSampleCoverage(float, boolean) - Method in interface com.badlogic.gdx.graphics.GL20
glScalef(float, float, float) - Method in interface com.badlogic.gdx.graphics.GL10
glScissor(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glShadeModel(int) - Method in interface com.badlogic.gdx.graphics.GL10
glShaderBinary(int, IntBuffer, int, Buffer, int) - Method in interface com.badlogic.gdx.graphics.GL20
glShaderSource(int, String) - Method in interface com.badlogic.gdx.graphics.GL20
glStencilFunc(int, int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glStencilFuncSeparate(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glStencilMask(int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glStencilMaskSeparate(int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glStencilOp(int, int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
glStencilOpSeparate(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glTexCoordPointer(int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL10
glTexCoordPointer(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL11
glTexEnvf(int, int, float) - Method in interface com.badlogic.gdx.graphics.GL10
glTexEnvfv(int, int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL10
glTexEnvfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL10
glTexEnvi(int, int, int) - Method in interface com.badlogic.gdx.graphics.GL11
glTexEnviv(int, int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glTexEnviv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glTexImage2D(int, int, int, int, int, int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GLCommon
glTexParameterf(int, int, float) - Method in interface com.badlogic.gdx.graphics.GLCommon
glTexParameterfv(int, int, float[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glTexParameterfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glTexParameterfv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glTexParameteri(int, int, int) - Method in interface com.badlogic.gdx.graphics.GL11
glTexParameteri(int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glTexParameteriv(int, int, int[], int) - Method in interface com.badlogic.gdx.graphics.GL11
glTexParameteriv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL11
glTexParameteriv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glTexSubImage2D(int, int, int, int, int, int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GLCommon
glTranslatef(float, float, float) - Method in interface com.badlogic.gdx.graphics.GL10
glUniform1f(int, float) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform1fv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform1i(int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform1iv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform2f(int, float, float) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform2fv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform2i(int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform2iv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform3f(int, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform3fv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform3i(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform3iv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform4f(int, float, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform4fv(int, int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform4i(int, int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glUniform4iv(int, int, IntBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniformMatrix2fv(int, int, boolean, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniformMatrix3fv(int, int, boolean, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUniformMatrix4fv(int, int, boolean, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glUseProgram(int) - Method in interface com.badlogic.gdx.graphics.GL20
glValidateProgram(int) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttrib1f(int, float) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttrib1fv(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttrib2f(int, float, float) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttrib2fv(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttrib3f(int, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttrib3fv(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttrib4f(int, float, float, float, float) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttrib4fv(int, FloatBuffer) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttribPointer(int, int, int, boolean, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexAttribPointer(int, int, int, boolean, int, int) - Method in interface com.badlogic.gdx.graphics.GL20
glVertexPointer(int, int, int, Buffer) - Method in interface com.badlogic.gdx.graphics.GL10
glVertexPointer(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GL11
glViewport(int, int, int, int) - Method in interface com.badlogic.gdx.graphics.GLCommon
graphics - Variable in class com.badlogic.gdx.backends.android.AndroidApplication
graphics - Static variable in class com.badlogic.gdx.Gdx
Graphics - Interface in com.badlogic.gdx
This interface encapsulates the communication with the graphics processor.
Graphics.GraphicsType - Enum in com.badlogic.gdx
Enumeration describing different types of Graphics implementations.
graphToString() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
GREEN - Static variable in class com.badlogic.gdx.graphics.Color
groundAnchorA - Variable in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
The first ground anchor in world coordinates.
groundAnchorB - Variable in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
The second ground anchor in world coordinates.
Group - Class in com.badlogic.gdx.scenes.scene2d
A group is an Actor that contains other Actors (also other Groups which are Actors).
Group(String) - Constructor for class com.badlogic.gdx.scenes.scene2d.Group
Creates a new Group with the given name.
groupIndex - Variable in class com.badlogic.gdx.physics.box2d.Filter
Collision groups allow a certain group of objects to never collide (negative) or always collide (positive).
groups - Variable in class com.badlogic.gdx.scenes.scene2d.Group

H

HAMMING - Static variable in class com.badlogic.gdx.audio.analysis.FourierTransform
A constant indicating a Hamming window should be used on sample buffers.
hamming(float[]) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
handle - Variable in class com.badlogic.gdx.audio.io.Mpg123Decoder
handler - Variable in class com.badlogic.gdx.backends.android.AndroidApplication
has(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Determine if the JSONObject contains a specific key.
hasEnoughData() - Method in class com.badlogic.gdx.math.WindowedMean
hashCode() - Method in class com.badlogic.gdx.graphics.Color
hashCode() - Method in class com.badlogic.gdx.math.Vector3
head - Variable in class com.badlogic.gdx.utils.LocklessThreadQueue
height - Variable in class com.badlogic.gdx.graphics.BitmapFont.TextBounds
height - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
height() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
hide() - Method in interface com.badlogic.gdx.Screen
Called when this screen is no longer the current screen for a Game.
hit(float, float) - Method in class com.badlogic.gdx.scenes.scene2d.Actor
hit(float, float) - Method in class com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
hit(float, float) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Button
hit(float, float) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Image
hit(float, float) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Label
hit(float, float) - Method in class com.badlogic.gdx.scenes.scene2d.Group
hit(float, float) - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Returns the Actor intersecting with the point (x,y) in stage coordinates.

I

I - Variable in class com.badlogic.gdx.physics.box2d.MassData
The rotational inertia of the shape about the local origin.
idt() - Method in class com.badlogic.gdx.math.Matrix3
Sets this matrix to the identity matrix
idt() - Method in class com.badlogic.gdx.math.Matrix4
Sets the matrix to an identity matrix
idt(Vector3) - Method in class com.badlogic.gdx.math.Vector3
imag - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
Image - Class in com.badlogic.gdx.scenes.scene2d.actors
Image(String) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.Image
Image(String, Texture) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.Image
Image(String, TextureRegion) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.Image
ImmediateModeRenderer - Class in com.badlogic.gdx.graphics
An ImmediateModeRenderer allows you to perform immediate mode rendering as you were accustomed to in your desktop OpenGL environment.
ImmediateModeRenderer() - Constructor for class com.badlogic.gdx.graphics.ImmediateModeRenderer
Constructs a new ImmediateModeRenderer
immutableChildren - Variable in class com.badlogic.gdx.scenes.scene2d.Group
immutableGroups - Variable in class com.badlogic.gdx.scenes.scene2d.Group
increment(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Increment a property of a JSONObject.
index - Variable in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
The number at the end of the original image file name, or Integer.MAX_VALUE if none.

When sprites are packed, if the original file name ends with a number, it is stored as the index and is not considered as part of the sprite's name.
IndexBufferObject - Class in com.badlogic.gdx.graphics.glutils
In IndexBufferObject wraps OpenGL's index buffer functionality to be used in conjunction with VBOs.
IndexBufferObject(boolean, int) - Constructor for class com.badlogic.gdx.graphics.glutils.IndexBufferObject
Creates a new IndexBufferObject.
IndexBufferObject(int) - Constructor for class com.badlogic.gdx.graphics.glutils.IndexBufferObject
Creates a new IndexBufferObject to be used with vertex arrays.
IndexBufferObjectSubData - Class in com.badlogic.gdx.graphics.glutils
In IndexBufferObject wraps OpenGL's index buffer functionality to be used in conjunction with VBOs.
IndexBufferObjectSubData(boolean, int) - Constructor for class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
Creates a new IndexBufferObject.
IndexBufferObjectSubData(int) - Constructor for class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
Creates a new IndexBufferObject to be used with vertex arrays.
IndexData - Interface in com.badlogic.gdx.graphics.glutils
An IndexData instance holds index data.
indexOf(float) - Method in class com.badlogic.gdx.utils.FloatArray
indexOf(float) - Method in class com.badlogic.gdx.utils.FloatBag
indexOf(int) - Method in class com.badlogic.gdx.utils.IntArray
indexOf(int) - Method in class com.badlogic.gdx.utils.IntBag
indexOf(long) - Method in class com.badlogic.gdx.utils.LongArray
indexOf(long) - Method in class com.badlogic.gdx.utils.LongBag
indexToFreq(int) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Returns the middle frequency of the ith band.
indices - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
idx 1, idx 2, idx 3
inertiaScale - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
Experimental: scales the inertia tensor.
inf() - Method in class com.badlogic.gdx.math.collision.BoundingBox
Sets the minimum and maximum vector to positive and negative infinity.
initialize(ApplicationListener, boolean) - Method in class com.badlogic.gdx.backends.android.AndroidApplication
This method has to be called in the Activity#onCreate(Bundle) method.
initialize(ApplicationListener, boolean, int) - Method in class com.badlogic.gdx.backends.android.AndroidApplication
This method has to be called in the Activity#onCreate(Bundle) method.
initialize(Body, Body, Vector2, Vector2) - Method in class com.badlogic.gdx.physics.box2d.joints.DistanceJointDef
Initialize the bodies, anchors, and length using the world anchors.
initialize(Body, Body, Vector2) - Method in class com.badlogic.gdx.physics.box2d.joints.FrictionJointDef
Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
initialize(Body, Body, Vector2, Vector2) - Method in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
initialize(Body, Body, Vector2, Vector2) - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
initialize(Body, Body, Vector2, Vector2, Vector2, Vector2, float) - Method in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
Initialize the bodies, anchors, lengths, max lengths, and ratio using the world anchors.
initialize(Body, Body, Vector2) - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
Initialize the bodies, anchors, and reference angle using a world anchor point.
initialize(Body, Body, Vector2) - Method in class com.badlogic.gdx.physics.box2d.joints.WeldJointDef
initializeForView(ApplicationListener, boolean, int) - Method in class com.badlogic.gdx.backends.android.AndroidApplication
This method has to be called in the Activity#onCreate(Bundle) method.
input - Variable in class com.badlogic.gdx.backends.android.AndroidApplication
input - Static variable in class com.badlogic.gdx.Gdx
Input - Interface in com.badlogic.gdx
Interface to the input facilities.
input(String) - Method in interface com.badlogic.gdx.Input.TextInputListener
Input.Keys - Class in com.badlogic.gdx
Keys.
Input.Keys() - Constructor for class com.badlogic.gdx.Input.Keys
Input.TextInputListener - Interface in com.badlogic.gdx
Callback interface for Input.getTextInput(TextInputListener, String, String)
InputAdapter - Class in com.badlogic.gdx
An adapter class for InputProcessor.
InputAdapter() - Constructor for class com.badlogic.gdx.InputAdapter
InputMultiplexer - Class in com.badlogic.gdx
An InputProcessor that delegates to an ordered list of other InputProcessors.
InputMultiplexer() - Constructor for class com.badlogic.gdx.InputMultiplexer
InputProcessor - Interface in com.badlogic.gdx
An InputProcessor is used to receive input events from the keyboard and the touch screen (mouse on the desktop).
insert(int, float) - Method in class com.badlogic.gdx.utils.FloatArray
insert(int, int) - Method in class com.badlogic.gdx.utils.IntArray
insert(int, long) - Method in class com.badlogic.gdx.utils.LongArray
int2float(int) - Static method in class com.badlogic.gdx.utils.BufferUtils
IntArray - Class in com.badlogic.gdx.utils
An ordered, resizable int array.
IntArray() - Constructor for class com.badlogic.gdx.utils.IntArray
IntArray(int) - Constructor for class com.badlogic.gdx.utils.IntArray
IntArray(IntArray) - Constructor for class com.badlogic.gdx.utils.IntArray
IntArray(IntBag) - Constructor for class com.badlogic.gdx.utils.IntArray
IntBag - Class in com.badlogic.gdx.utils
An unordered, resizable int array.
IntBag() - Constructor for class com.badlogic.gdx.utils.IntBag
IntBag(int) - Constructor for class com.badlogic.gdx.utils.IntBag
IntBag(IntBag) - Constructor for class com.badlogic.gdx.utils.IntBag
IntBag(IntArray) - Constructor for class com.badlogic.gdx.utils.IntBag
internal(String) - Method in interface com.badlogic.gdx.Files
Convenience method that returns a Files.FileType.Internal file handle.
interpolate(MD5Joints, MD5Joints, MD5Joints, float) - Static method in class com.badlogic.gdx.graphics.loaders.md5.MD5Animation
intersectLines(Vector2, Vector2, Vector2, Vector2, Vector2) - Static method in class com.badlogic.gdx.math.Intersector
Intersects the two lines and returns the intersection point in intersection.
Intersector - Class in com.badlogic.gdx.math
Class offering various static methods for intersection testing between different geometric objects.
Intersector() - Constructor for class com.badlogic.gdx.math.Intersector
intersectRayBoundsFast(Ray, BoundingBox) - Static method in class com.badlogic.gdx.math.Intersector
Quick check wheter the given Ray and BoundingBox intersect.
intersectRayPlane(Ray, Plane, Vector3) - Static method in class com.badlogic.gdx.math.Intersector
Intersects a Ray and a Plane.
intersectRaySphere(Ray, Vector3, float, Vector3) - Static method in class com.badlogic.gdx.math.Intersector
Intersects a Ray and a sphere, returning the intersection point in intersection.
intersectRayTriangle(Ray, Vector3, Vector3, Vector3, Vector3) - Static method in class com.badlogic.gdx.math.Intersector
Intersect a Ray and a triangle, returning the intersection point in intersection.
intersectRayTriangles(Ray, float[], Vector3) - Static method in class com.badlogic.gdx.math.Intersector
Intersects the given ray with list of triangles.
intersectRayTriangles(Ray, float[], short[], int, Vector3) - Static method in class com.badlogic.gdx.math.Intersector
Intersects the given ray with list of triangles.
intersectRayTriangles(Ray, List<Vector3>, Vector3) - Static method in class com.badlogic.gdx.math.Intersector
Intersects the given ray with list of triangles.
intersectRectangles(Rectangle, Rectangle) - Static method in class com.badlogic.gdx.math.Intersector
Returns wheter the two rectangles intersect
intersectSegmentCircle(Vector2, Vector2, Vector2, float) - Static method in class com.badlogic.gdx.math.Intersector
Returns wheter the given line segment intersects the given circle.
intersectSegmentCircleDisplace(Vector2, Vector2, Vector2, float, Vector2) - Static method in class com.badlogic.gdx.math.Intersector
Checks wheter the line segment and the circle intersect and returns by how much and in what direction the line has to move away from the circle to not intersect.
intersectSegmentPlane(Vector3, Vector3, Plane, Vector3) - Static method in class com.badlogic.gdx.math.Intersector
intersectSegments(Vector2, Vector2, Vector2, Vector2, Vector2) - Static method in class com.badlogic.gdx.math.Intersector
Intersects the two line segments and returns the intersection point in intersection.
IntHashMap<T> - Class in com.badlogic.gdx.utils
An unordered map that uses int keys.
IntHashMap() - Constructor for class com.badlogic.gdx.utils.IntHashMap
IntHashMap(int) - Constructor for class com.badlogic.gdx.utils.IntHashMap
IntHashMap(int, float) - Constructor for class com.badlogic.gdx.utils.IntHashMap
IntHashMap.Entry<T> - Class in com.badlogic.gdx.utils
An entry in the map.
inv() - Method in class com.badlogic.gdx.math.Matrix3
Inverts this matrix given that the determinant is != 0
inv() - Method in class com.badlogic.gdx.math.Matrix4
Inverts the matrix.
invalidate() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObject
Invalidates the IndexBufferObject so a new OpenGL buffer handle is created.
invalidate() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
Invalidates the IndexBufferObject so a new OpenGL buffer handle is created.
invalidate() - Method in interface com.badlogic.gdx.graphics.glutils.IndexData
Invalidates the IndexBufferObject so a new OpenGL buffer handle is created.
invalidate() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
Invalidates the VertexBufferObject so a new OpenGL buffer handle is created.
invalidate() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Invalidates the VertexBufferObject so a new OpenGL buffer handle is created.
invalidateAllFrameBuffers() - Static method in class com.badlogic.gdx.graphics.glutils.FrameBuffer
Invalidates all frame buffers.
invalidateAllMeshes() - Static method in class com.badlogic.gdx.graphics.Mesh
Invalidates all meshes so the next time they are rendered new VBO handles are generated.
invalidateAllShaderPrograms() - Static method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Invalidates all shaders so the next time they are used new handles are generated
invDuration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
invDuration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
invDuration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
invDuration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
invDuration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
invDuration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
invDuration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
invDuration - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
inverse(float[]) - Method in class com.badlogic.gdx.audio.analysis.DFT
inverse(float[]) - Method in class com.badlogic.gdx.audio.analysis.FFT
inverse(float[]) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Performs an inverse transform of the frequency spectrum and places the result in buffer.
inverse(float[], float[], float[]) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Performs an inverse transform of the frequency spectrum represented by freqReal and freqImag and places the result in buffer.
is64Bit() - Static method in class com.badlogic.gdx.utils.GdxNativesLoader
isAccelerometerAvailable() - Method in interface com.badlogic.gdx.Input
isActive() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
isActive() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the active state of the body.
isActive() - Method in class com.badlogic.gdx.physics.box2d.Joint
Short-cut function to determine if either body is inactive.
isAdditive() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
isAligned() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
isAlwaysActive() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
isAttached() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
isAwake() - Method in class com.badlogic.gdx.physics.box2d.Body
Get the sleeping state of this body.
isBehind() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
isBlendingEnabled() - Method in class com.badlogic.gdx.graphics.SpriteBatch
isBullet() - Method in class com.badlogic.gdx.physics.box2d.Body
Is this body treated like a bullet for continuous collision detection?
isCompiled() - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
isComplete() - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
isComplete() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
isContinuous() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
isDirectory() - Method in class com.badlogic.gdx.files.FileHandle
Returns true if this file is a directory.
isDirectory() - Method in class com.badlogic.gdx.files.FileHandleStream
isDone() - Method in interface com.badlogic.gdx.scenes.scene2d.Action
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Delay
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Forever
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Parallel
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
isDone() - Method in class com.badlogic.gdx.scenes.scene2d.actions.Sequence
isEdges() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
isEnabled() - Method in class com.badlogic.gdx.physics.box2d.Contact
Has this contact been disabled?
isExternalStorageAvailable() - Method in interface com.badlogic.gdx.Files
Returns true if the external storage is ready for file IO.
isFixedRotation() - Method in class com.badlogic.gdx.physics.box2d.Body
Does this body have fixed rotation?
isFrontFacing(Vector3) - Method in class com.badlogic.gdx.math.Plane
Returns whether the plane is facing the direction vector.
isGL11Available() - Method in interface com.badlogic.gdx.Graphics
Returns whether OpenGL ES 1.1 is available.
isGL20Available() - Method in interface com.badlogic.gdx.Graphics
Returns whether OpenGL ES 2.0 is available.
isJniUsed() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Renderer
isKeyPressed(int) - Method in interface com.badlogic.gdx.Input
Returns whether the key is pressed.
isLimitEnabled() - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Is the joint limit enabled?
isLimitEnabled() - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Is the joint limit enabled?
isLimitEnabled() - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Is the joint limit enabled?
isLocked() - Method in class com.badlogic.gdx.physics.box2d.World
Is the world locked (in the middle of a time step).
isLooping() - Method in interface com.badlogic.gdx.audio.Music
isManaged() - Method in interface com.badlogic.gdx.graphics.Texture
isMipMap(Texture.TextureFilter) - Static method in enum com.badlogic.gdx.graphics.Texture.TextureFilter
isMono() - Method in interface com.badlogic.gdx.audio.AudioDevice
isMotorEnabled() - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Is the joint motor enabled?
isMotorEnabled() - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Is the joint motor enabled?
isMotorEnabled() - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Is the joint motor enabled?
isNull(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Determine if the value is null.
isNull(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Determine if the value associated with the key is null or if there is no value.
isPaused() - Method in class com.badlogic.gdx.utils.PauseableThread
isPlaying() - Method in interface com.badlogic.gdx.audio.Music
isPointInPolygon(List<Vector2>, Vector2) - Static method in class com.badlogic.gdx.math.Intersector
Checks wheter the given point is in the polygon.
isPointInTriangle(Vector3, Vector3, Vector3, Vector3) - Static method in class com.badlogic.gdx.math.Intersector
Returns whether the given point is inside the triangle.
isPowerOfTwo(int) - Static method in class com.badlogic.gdx.utils.MathUtils
isRelative() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
isSensor() - Method in class com.badlogic.gdx.physics.box2d.Fixture
Is this fixture a sensor (non-solid)?
isSensor - Variable in class com.badlogic.gdx.physics.box2d.FixtureDef
A sensor shape collects contact information but never generates a collision response.
isSleepingAllowed() - Method in class com.badlogic.gdx.physics.box2d.Body
Is this body allowed to sleep
isStretched() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
isTouched() - Method in interface com.badlogic.gdx.Input
isTouched(int) - Method in interface com.badlogic.gdx.Input
Whether the screen is currently touched by the pointer with the given index.
isTouching() - Method in class com.badlogic.gdx.physics.box2d.Contact
isUnit() - Method in class com.badlogic.gdx.math.Vector3
isValid() - Method in class com.badlogic.gdx.math.collision.BoundingBox
Returns wheter this bounding box is valid.
isZero() - Method in class com.badlogic.gdx.math.Vector3
items - Variable in class com.badlogic.gdx.utils.FloatArray
items - Variable in class com.badlogic.gdx.utils.FloatBag
items - Variable in class com.badlogic.gdx.utils.IntArray
items - Variable in class com.badlogic.gdx.utils.IntBag
items - Variable in class com.badlogic.gdx.utils.LongArray
items - Variable in class com.badlogic.gdx.utils.LongBag
iter() - Method in class com.badlogic.gdx.utils.PooledLinkedList
Starts iterating over the lists items

J

jniGetType(long) - Static method in class com.badlogic.gdx.physics.box2d.Shape
JoglApplication - Class in com.badlogic.gdx.backends.jogl
An implemenation of the Application interface based on Jogl for Windows, Linux and Mac.
JoglApplication(ApplicationListener, String, int, int, boolean) - Constructor for class com.badlogic.gdx.backends.jogl.JoglApplication
Creates a new JoglApplication with the given title and dimensions.
join(String) - Method in class com.badlogic.gdx.utils.json.JSONArray
Make a string from the contents of this JSONArray.
Joint - Class in com.badlogic.gdx.physics.box2d
Joint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.Joint
Constructs a new joint
joint - Variable in class com.badlogic.gdx.physics.box2d.JointEdge
joint1 - Variable in class com.badlogic.gdx.physics.box2d.joints.GearJointDef
The first revolute/prismatic joint attached to the gear joint.
joint2 - Variable in class com.badlogic.gdx.physics.box2d.joints.GearJointDef
The second revolute/prismatic joint attached to the gear joint.
JointDef - Class in com.badlogic.gdx.physics.box2d
JointDef() - Constructor for class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType - Enum in com.badlogic.gdx.physics.box2d
JointEdge - Class in com.badlogic.gdx.physics.box2d
A joint edge is used to connect bodies and joints together in a joint graph where each body is a node and each joint is an edge.
JointEdge(Body, Joint) - Constructor for class com.badlogic.gdx.physics.box2d.JointEdge
jointEdgeA - Variable in class com.badlogic.gdx.physics.box2d.Joint
joint edge a
jointEdgeB - Variable in class com.badlogic.gdx.physics.box2d.Joint
joint edge b
joints - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Joints
(0) parent, (1) pos.x, (2) pos.y, (3) pos.z, (4) orient.x, (5) orient.y, (6) orient.z, (7) orient.w
joints - Variable in class com.badlogic.gdx.physics.box2d.Body
Joints of this body
joints - Variable in class com.badlogic.gdx.physics.box2d.World
all known joints
JSONArray - Class in com.badlogic.gdx.utils.json
A JSONArray is an ordered sequence of values.
JSONArray() - Constructor for class com.badlogic.gdx.utils.json.JSONArray
Construct an empty JSONArray.
JSONArray(JSONTokener) - Constructor for class com.badlogic.gdx.utils.json.JSONArray
Construct a JSONArray from a JSONTokener.
JSONArray(String) - Constructor for class com.badlogic.gdx.utils.json.JSONArray
Construct a JSONArray from a source JSON text.
JSONArray(Collection) - Constructor for class com.badlogic.gdx.utils.json.JSONArray
Construct a JSONArray from a Collection.
JSONArray(Object) - Constructor for class com.badlogic.gdx.utils.json.JSONArray
Construct a JSONArray from an array
JSONException - Exception in com.badlogic.gdx.utils.json
The JSONException is thrown by the JSON.org classes when things are amiss.
JSONException(String) - Constructor for exception com.badlogic.gdx.utils.json.JSONException
Constructs a JSONException with an explanatory message.
JSONException(Throwable) - Constructor for exception com.badlogic.gdx.utils.json.JSONException
JSONObject - Class in com.badlogic.gdx.utils.json
A JSONObject is an unordered collection of name/value pairs.
JSONObject() - Constructor for class com.badlogic.gdx.utils.json.JSONObject
Construct an empty JSONObject.
JSONObject(JSONObject, String[]) - Constructor for class com.badlogic.gdx.utils.json.JSONObject
Construct a JSONObject from a subset of another JSONObject.
JSONObject(JSONTokener) - Constructor for class com.badlogic.gdx.utils.json.JSONObject
Construct a JSONObject from a JSONTokener.
JSONObject(Map) - Constructor for class com.badlogic.gdx.utils.json.JSONObject
Construct a JSONObject from a Map.
JSONObject(Object) - Constructor for class com.badlogic.gdx.utils.json.JSONObject
Construct a JSONObject from an Object using bean getters.
JSONObject(Object, String[]) - Constructor for class com.badlogic.gdx.utils.json.JSONObject
Construct a JSONObject from an Object, using reflection to find the public members.
JSONObject(String) - Constructor for class com.badlogic.gdx.utils.json.JSONObject
Construct a JSONObject from a source JSON text string.
JSONString - Interface in com.badlogic.gdx.utils.json
The JSONString interface allows a toJSONString() method so that a class can change the behavior of JSONObject.toString(), JSONArray.toString(), and JSONWriter.value(Object).
JSONStringer - Class in com.badlogic.gdx.utils.json
JSONStringer provides a quick and convenient way of producing JSON text.
JSONStringer() - Constructor for class com.badlogic.gdx.utils.json.JSONStringer
Make a fresh JSONStringer.
JSONTokener - Class in com.badlogic.gdx.utils.json
A JSONTokener takes a source string and extracts characters and tokens from it.
JSONTokener(Reader) - Constructor for class com.badlogic.gdx.utils.json.JSONTokener
Construct a JSONTokener from a reader.
JSONTokener(String) - Constructor for class com.badlogic.gdx.utils.json.JSONTokener
Construct a JSONTokener from a string.
JSONWriter - Class in com.badlogic.gdx.utils.json
JSONWriter provides a quick and convenient way of producing JSON text.
JSONWriter(Writer) - Constructor for class com.badlogic.gdx.utils.json.JSONWriter
Make a fresh JSONWriter.

K

key - Variable in class com.badlogic.gdx.utils.IntHashMap.Entry
key(String) - Method in class com.badlogic.gdx.utils.json.JSONWriter
Append a key.
key - Variable in class com.badlogic.gdx.utils.LongHashMap.Entry
KEYCODE_0 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_1 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_2 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_3 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_4 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_5 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_6 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_7 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_8 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_9 - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_A - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_ALT_LEFT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_ALT_RIGHT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_APOSTROPHE - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_AT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_B - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_BACK - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_BACKSLASH - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_C - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_CALL - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_CAMERA - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_CLEAR - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_COMMA - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_D - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_DEL - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_DPAD_CENTER - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_DPAD_DOWN - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_DPAD_LEFT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_DPAD_RIGHT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_DPAD_UP - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_E - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_ENDCALL - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_ENTER - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_ENVELOPE - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_EQUALS - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_EXPLORER - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_F - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_FOCUS - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_G - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_GRAVE - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_H - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_HEADSETHOOK - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_HOME - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_I - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_J - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_K - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_L - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_LEFT_BRACKET - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_M - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_MEDIA_FAST_FORWARD - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_MEDIA_NEXT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_MEDIA_PLAY_PAUSE - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_MEDIA_PREVIOUS - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_MEDIA_REWIND - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_MEDIA_STOP - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_MENU - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_MINUS - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_MUTE - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_N - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_NOTIFICATION - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_NUM - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_O - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_P - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_PERIOD - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_PLUS - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_POUND - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_POWER - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_Q - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_R - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_RIGHT_BRACKET - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_S - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_SEARCH - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_SEMICOLON - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_SHIFT_LEFT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_SHIFT_RIGHT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_SLASH - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_SOFT_LEFT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_SOFT_RIGHT - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_SPACE - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_STAR - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_SYM - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_T - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_TAB - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_U - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_UNKNOWN - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_V - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_VOLUME_DOWN - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_VOLUME_UP - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_W - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_X - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_Y - Static variable in class com.badlogic.gdx.Input.Keys
KEYCODE_Z - Static variable in class com.badlogic.gdx.Input.Keys
keyDown(int) - Method in class com.badlogic.gdx.InputAdapter
keyDown(int) - Method in class com.badlogic.gdx.InputMultiplexer
keyDown(int) - Method in interface com.badlogic.gdx.InputProcessor
Called when a key was pressed
keyDown(int) - Method in class com.badlogic.gdx.twl.TWL
keys() - Method in class com.badlogic.gdx.utils.IntHashMap
Returns an iterator for the keys in the map.
keys() - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an enumeration of the keys of the JSONObject.
keys() - Method in class com.badlogic.gdx.utils.LongHashMap
Returns an iterator for the keys in the map.
keyTyped(char) - Method in class com.badlogic.gdx.InputAdapter
keyTyped(char) - Method in class com.badlogic.gdx.InputMultiplexer
keyTyped(char) - Method in interface com.badlogic.gdx.InputProcessor
Called when a key was typed
keyTyped(char) - Method in class com.badlogic.gdx.twl.TWL
keyUp(int) - Method in class com.badlogic.gdx.InputAdapter
keyUp(int) - Method in class com.badlogic.gdx.InputMultiplexer
keyUp(int) - Method in interface com.badlogic.gdx.InputProcessor
Called when a key was released
keyUp(int) - Method in class com.badlogic.gdx.twl.TWL
KissFFT - Class in com.badlogic.gdx.audio.analysis
A class for spectral analysis using native KissFFT
KissFFT(int) - Constructor for class com.badlogic.gdx.audio.analysis.KissFFT
Creates a new fft instance that can analyse numSamples samples.

L

Label - Class in com.badlogic.gdx.scenes.scene2d.actors
Label(String, Object, String) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.Label
lastTouchedChild - Variable in class com.badlogic.gdx.scenes.scene2d.Group
layout - Variable in class com.badlogic.gdx.scenes.scene2d.actors.LinearGroup
layout() - Method in class com.badlogic.gdx.scenes.scene2d.actors.LinearGroup
left() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
len() - Method in class com.badlogic.gdx.math.Quaternion
len() - Method in class com.badlogic.gdx.math.Vector2
len() - Method in class com.badlogic.gdx.math.Vector3
len2() - Method in class com.badlogic.gdx.math.Vector2
len2() - Method in class com.badlogic.gdx.math.Vector3
length() - Method in class com.badlogic.gdx.files.FileHandle
Returns the length in bytes of this file, or 0 if this file is a directory or does not exist.
length() - Method in class com.badlogic.gdx.files.FileHandleStream
length - Variable in class com.badlogic.gdx.physics.box2d.joints.DistanceJointDef
The natural length between the anchor points.
length() - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the number of elements in the JSONArray, included nulls.
length() - Method in class com.badlogic.gdx.utils.json.JSONObject
Get the number of keys stored in the JSONObject.
lengthA - Variable in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
The a reference length for the segment attached to bodyA.
lengthB - Variable in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
The a reference length for the segment attached to bodyB.
lerp(Matrix4, float) - Method in class com.badlogic.gdx.math.Matrix4
Linearly interpolates between this matrix and the given matrix mixing by alpha
lerp(Vector3, float) - Method in class com.badlogic.gdx.math.Vector3
Linearly interpolates between this vector and the target vector by alpha which is in the range [0,1].
linAverages(int) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Sets the number of averages used when computing the spectrum and spaces the averages in a linear manner.
LINAVG - Static variable in class com.badlogic.gdx.audio.analysis.FourierTransform
linearDamping - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
Linear damping is use to reduce the linear velocity.
LinearGroup - Class in com.badlogic.gdx.scenes.scene2d.actors
LinearGroup(String, int, int, LinearGroup.LinearGroupLayout) - Constructor for class com.badlogic.gdx.scenes.scene2d.actors.LinearGroup
LinearGroup.LinearGroupLayout - Enum in com.badlogic.gdx.scenes.scene2d.actors
linearVelocity - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
The linear velocity of the body's origin in world co-ordinates.
LineJoint - Class in com.badlogic.gdx.physics.box2d.joints
A line joint.
LineJoint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.joints.LineJoint
LineJointDef - Class in com.badlogic.gdx.physics.box2d.joints
Line joint definition.
LineJointDef() - Constructor for class com.badlogic.gdx.physics.box2d.joints.LineJointDef
linVelLoc - Variable in class com.badlogic.gdx.physics.box2d.Body
linVelWorld - Variable in class com.badlogic.gdx.physics.box2d.Body
list() - Method in class com.badlogic.gdx.files.FileHandle
Returns the paths to the children of this directory.
list() - Method in class com.badlogic.gdx.files.FileHandleStream
listener - Variable in class com.badlogic.gdx.backends.android.AndroidApplication
LittleEndianInputStream - Class in com.badlogic.gdx.utils
Taken from http://www.javafaq.nu/java-example-code-1079.html
LittleEndianInputStream(InputStream) - Constructor for class com.badlogic.gdx.utils.LittleEndianInputStream
load(FileHandle, FileHandle) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
load(FileHandle, TextureAtlas) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
load(BufferedReader) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
load(ParticleEmitter.GradientColorValue) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
load(BufferedReader) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
load(BufferedReader) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue
load(ParticleEmitter.NumericValue) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue
load(BufferedReader) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
load(ParticleEmitter.ParticleValue) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
load(BufferedReader) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
load(ParticleEmitter.RangedNumericValue) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
load(BufferedReader) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
load(ParticleEmitter.ScaledNumericValue) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
load(BufferedReader) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
load(ParticleEmitter.SpawnShapeValue) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
load() - Method in interface com.badlogic.gdx.graphics.TextureData
Loads the image data into the currently bound texture.
loadAnimation(InputStream) - Static method in class com.badlogic.gdx.graphics.loaders.md5.MD5Loader
loadEmitterImages(TextureAtlas) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
loadEmitterImages(FileHandle) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
loadEmitters(FileHandle) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
loadLibraries() - Static method in class com.badlogic.gdx.utils.GdxNativesLoader
loads the necessary libraries depending on the operating system
loadLibrary(String, String, String) - Static method in class com.badlogic.gdx.utils.GdxNativesLoader
loadLibrary() - Static method in class com.badlogic.gdx.Version
loadModel(InputStream) - Static method in class com.badlogic.gdx.graphics.loaders.md5.MD5Loader
loadObj(InputStream) - Static method in class com.badlogic.gdx.graphics.loaders.ObjLoader
Loads a Wavefront OBJ file from the given input stream.
loadObj(InputStream) - Static method in class com.badlogic.gdx.graphics.ModelLoader
Loads a Wavefront OBJ file from the given InputStream.
loadObjFromString(String) - Static method in class com.badlogic.gdx.graphics.loaders.ObjLoader
Loads a mesh from the given string in Wavefront OBJ format
loadTexture(FileHandle) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
localAnchorA - Variable in class com.badlogic.gdx.physics.box2d.joints.DistanceJointDef
The local anchor point relative to body1's origin.
localAnchorA - Variable in class com.badlogic.gdx.physics.box2d.joints.FrictionJointDef
The local anchor point relative to bodyA's origin.
localAnchorA - Variable in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
The local anchor point relative to body1's origin.
localAnchorA - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
The local anchor point relative to body1's origin.
localAnchorA - Variable in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
The local anchor point relative to bodyA's origin.
localAnchorA - Variable in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
The local anchor point relative to body1's origin.
localAnchorA - Variable in class com.badlogic.gdx.physics.box2d.joints.WeldJointDef
localAnchorB - Variable in class com.badlogic.gdx.physics.box2d.joints.DistanceJointDef
The local anchor point relative to body2's origin.
localAnchorB - Variable in class com.badlogic.gdx.physics.box2d.joints.FrictionJointDef
The local anchor point relative to bodyB's origin.
localAnchorB - Variable in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
The local anchor point relative to body2's origin.
localAnchorB - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
The local anchor point relative to body2's origin.
localAnchorB - Variable in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
The local anchor point relative to bodyB's origin.
localAnchorB - Variable in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
The local anchor point relative to body2's origin.
localAnchorB - Variable in class com.badlogic.gdx.physics.box2d.joints.WeldJointDef
localAxis1 - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
The local translation axis in body1.
localAxisA - Variable in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
The local translation axis in body1.
localPoint2 - Variable in class com.badlogic.gdx.physics.box2d.Body
localVector - Variable in class com.badlogic.gdx.physics.box2d.Body
LocklessThreadQueue<T> - Class in com.badlogic.gdx.utils
A specialized lockless thread queue class template for doing single direction message passing from one thread to another.
LocklessThreadQueue(LocklessThreadQueue.ObjectFactory<T>, int) - Constructor for class com.badlogic.gdx.utils.LocklessThreadQueue
Constructor.
LocklessThreadQueue.ObjectFactory<T> - Interface in com.badlogic.gdx.utils
Interface for an Object Factory for the initial buffer creation.
log(String, String) - Method in interface com.badlogic.gdx.Application
Logs a message to the console or logcat
log(String, String) - Method in class com.badlogic.gdx.backends.android.AndroidApplication
Logs a message to the console or logcat
log(String, String) - Method in class com.badlogic.gdx.backends.jogl.JoglApplication
log(String, String) - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
log(String, String) - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
logAverages(int, int) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Sets the number of averages used when computing the spectrum based on the minimum bandwidth for an octave and the number of bands per octave.
LOGAVG - Static variable in class com.badlogic.gdx.audio.analysis.FourierTransform
LongArray - Class in com.badlogic.gdx.utils
An ordered, resizable long array.
LongArray() - Constructor for class com.badlogic.gdx.utils.LongArray
LongArray(int) - Constructor for class com.badlogic.gdx.utils.LongArray
LongArray(LongArray) - Constructor for class com.badlogic.gdx.utils.LongArray
LongArray(LongBag) - Constructor for class com.badlogic.gdx.utils.LongArray
LongBag - Class in com.badlogic.gdx.utils
An unordered, resizable long array.
LongBag() - Constructor for class com.badlogic.gdx.utils.LongBag
LongBag(int) - Constructor for class com.badlogic.gdx.utils.LongBag
LongBag(LongBag) - Constructor for class com.badlogic.gdx.utils.LongBag
LongBag(LongArray) - Constructor for class com.badlogic.gdx.utils.LongBag
LongHashMap<T> - Class in com.badlogic.gdx.utils
An unordered map that uses long keys.
LongHashMap() - Constructor for class com.badlogic.gdx.utils.LongHashMap
LongHashMap(int) - Constructor for class com.badlogic.gdx.utils.LongHashMap
LongHashMap(int, float) - Constructor for class com.badlogic.gdx.utils.LongHashMap
LongHashMap.Entry<T> - Class in com.badlogic.gdx.utils
An entry in the map.
lowerAngle - Variable in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
The lower angle for the joint limit (radians).
lowerTranslation - Variable in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
The lower translation limit, usually in meters.
lowerTranslation - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
The lower translation limit, usually in meters.
LwjglApplet - Class in com.badlogic.gdx.backends.lwjgl
An OpenGL surface in an applet.
LwjglApplet(ApplicationListener, boolean) - Constructor for class com.badlogic.gdx.backends.lwjgl.LwjglApplet
LwjglApplication - Class in com.badlogic.gdx.backends.lwjgl
An OpenGL surface fullscreen or in a lightweight window.
LwjglApplication(ApplicationListener, String, int, int, boolean) - Constructor for class com.badlogic.gdx.backends.lwjgl.LwjglApplication
LwjglApplication(ApplicationListener, boolean, Canvas) - Constructor for class com.badlogic.gdx.backends.lwjgl.LwjglApplication
LwjglCanvas - Class in com.badlogic.gdx.backends.lwjgl
An OpenGL surface on an AWT Canvas, allowing OpenGL to be embedded in a Swing application.
LwjglCanvas(ApplicationListener, boolean) - Constructor for class com.badlogic.gdx.backends.lwjgl.LwjglCanvas

M

M00 - Static variable in class com.badlogic.gdx.math.Matrix4
M01 - Static variable in class com.badlogic.gdx.math.Matrix4
M02 - Static variable in class com.badlogic.gdx.math.Matrix4
M03 - Static variable in class com.badlogic.gdx.math.Matrix4
M10 - Static variable in class com.badlogic.gdx.math.Matrix4
M11 - Static variable in class com.badlogic.gdx.math.Matrix4
M12 - Static variable in class com.badlogic.gdx.math.Matrix4
M13 - Static variable in class com.badlogic.gdx.math.Matrix4
M20 - Static variable in class com.badlogic.gdx.math.Matrix4
M21 - Static variable in class com.badlogic.gdx.math.Matrix4
M22 - Static variable in class com.badlogic.gdx.math.Matrix4
M23 - Static variable in class com.badlogic.gdx.math.Matrix4
M30 - Static variable in class com.badlogic.gdx.math.Matrix4
M31 - Static variable in class com.badlogic.gdx.math.Matrix4
M32 - Static variable in class com.badlogic.gdx.math.Matrix4
M33 - Static variable in class com.badlogic.gdx.math.Matrix4
main(String[]) - Static method in class com.badlogic.gdx.audio.analysis.FFT
main(String[]) - Static method in class com.badlogic.gdx.audio.analysis.KissFFT
main(String[]) - Static method in class com.badlogic.gdx.backends.jogl.JoglApplication
main(String[]) - Static method in class com.badlogic.gdx.math.Matrix3
main(String[]) - Static method in class com.badlogic.gdx.utils.PooledLinkedList
maskBits - Variable in class com.badlogic.gdx.physics.box2d.Filter
The collision mask bits.
mass - Variable in class com.badlogic.gdx.physics.box2d.MassData
The mass of the shape, usually in kilograms.
MassData - Class in com.badlogic.gdx.physics.box2d
This holds the mass data computed for a shape.
MassData() - Constructor for class com.badlogic.gdx.physics.box2d.MassData
MathUtils - Class in com.badlogic.gdx.utils
Utility and fast math functions.
MathUtils() - Constructor for class com.badlogic.gdx.utils.MathUtils
Matrix3 - Class in com.badlogic.gdx.math
A 3x3 column major matrix for 2D transforms.
Matrix3() - Constructor for class com.badlogic.gdx.math.Matrix3
Matrix4 - Class in com.badlogic.gdx.math
Encapsulates a column major 4 by 4 matrix.
Matrix4() - Constructor for class com.badlogic.gdx.math.Matrix4
Constructs an identity matrix
Matrix4(Matrix4) - Constructor for class com.badlogic.gdx.math.Matrix4
Constructs a matrix from the given matrix
Matrix4(float[]) - Constructor for class com.badlogic.gdx.math.Matrix4
Constructs a matrix from the given float array.
Matrix4(Quaternion) - Constructor for class com.badlogic.gdx.math.Matrix4
Constructs a rotation matrix from the given Quaternion
max - Variable in class com.badlogic.gdx.math.collision.BoundingBox
maxForce - Variable in class com.badlogic.gdx.physics.box2d.joints.FrictionJointDef
The maximum friction force in N.
maxForce - Variable in class com.badlogic.gdx.physics.box2d.joints.MouseJointDef
The maximum constraint force that can be exerted to move the candidate body.
maxLengthA - Variable in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
The maximum length of the segment attached to bodyA.
maxLengthB - Variable in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
The maximum length of the segment attached to bodyB.
maxMotorForce - Variable in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
The maximum motor torque, usually in N-m.
maxMotorForce - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
The maximum motor torque, usually in N-m.
maxMotorTorque - Variable in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
The maximum motor torque used to achieve the desired motor speed.
maxSpritesInBatch - Variable in class com.badlogic.gdx.graphics.SpriteBatch
the maximum number of sprites rendered in one batch so far
maxTorque - Variable in class com.badlogic.gdx.physics.box2d.joints.FrictionJointDef
The maximum friction torque in N-m.
MD5Animation - Class in com.badlogic.gdx.graphics.loaders.md5
MD5Animation() - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Animation
MD5AnimationInfo - Class in com.badlogic.gdx.graphics.loaders.md5
MD5AnimationInfo(int, float) - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo
MD5Jni - Class in com.badlogic.gdx.graphics.loaders.md5
MD5Jni() - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Jni
MD5Joints - Class in com.badlogic.gdx.graphics.loaders.md5
MD5Joints() - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Joints
MD5Loader - Class in com.badlogic.gdx.graphics.loaders.md5
MD5Loader() - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Loader
MD5Mesh - Class in com.badlogic.gdx.graphics.loaders.md5
MD5Mesh() - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
MD5Model - Class in com.badlogic.gdx.graphics.loaders.md5
MD5Model() - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Model
MD5Quaternion - Class in com.badlogic.gdx.graphics.loaders.md5
MD5Quaternion() - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
MD5Quaternion(float, float, float) - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
MD5Quaternion(float, float, float, float) - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
MD5Renderer - Class in com.badlogic.gdx.graphics.loaders.md5
MD5Renderer(MD5Model, boolean) - Constructor for class com.badlogic.gdx.graphics.loaders.md5.MD5Renderer
Mesh - Class in com.badlogic.gdx.graphics
A Mesh holds vertices composed of attributes specified by a VertexAttributes instance.
Mesh(boolean, int, int, VertexAttribute...) - Constructor for class com.badlogic.gdx.graphics.Mesh
Creates a new Mesh with the given attributes.
Mesh(Mesh.VertexDataType, boolean, int, int, VertexAttribute...) - Constructor for class com.badlogic.gdx.graphics.Mesh
Creates a new Mesh with the given attributes.
Mesh.VertexDataType - Enum in com.badlogic.gdx.graphics
meshes - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Model
META_ALT_LEFT_ON - Static variable in class com.badlogic.gdx.Input.Keys
META_ALT_ON - Static variable in class com.badlogic.gdx.Input.Keys
META_ALT_RIGHT_ON - Static variable in class com.badlogic.gdx.Input.Keys
META_SHIFT_LEFT_ON - Static variable in class com.badlogic.gdx.Input.Keys
META_SHIFT_ON - Static variable in class com.badlogic.gdx.Input.Keys
META_SHIFT_RIGHT_ON - Static variable in class com.badlogic.gdx.Input.Keys
META_SYM_ON - Static variable in class com.badlogic.gdx.Input.Keys
min - Variable in class com.badlogic.gdx.math.collision.BoundingBox
mkdirs() - Method in class com.badlogic.gdx.files.FileHandle
mkdirs() - Method in class com.badlogic.gdx.files.FileHandleStream
mode - Variable in class com.badlogic.gdx.utils.json.JSONWriter
The current mode.
model - Variable in class com.badlogic.gdx.graphics.PerspectiveCamera
ModelLoader - Class in com.badlogic.gdx.graphics
A class for loading various model formats such as Wavefront OBJ.
ModelLoader() - Constructor for class com.badlogic.gdx.graphics.ModelLoader
more() - Method in class com.badlogic.gdx.utils.json.JSONTokener
Determine if the source string still contains characters that next() can consume.
motorSpeed - Variable in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
The desired motor speed in radians per second.
motorSpeed - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
The desired motor speed in radians per second.
motorSpeed - Variable in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
The desired motor speed.
MouseJoint - Class in com.badlogic.gdx.physics.box2d.joints
A mouse joint is used to make a point on a body track a specified world point.
MouseJoint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.joints.MouseJoint
MouseJointDef - Class in com.badlogic.gdx.physics.box2d.joints
Mouse joint definition.
MouseJointDef() - Constructor for class com.badlogic.gdx.physics.box2d.joints.MouseJointDef
MoveBy - Class in com.badlogic.gdx.scenes.scene2d.actions
MoveBy() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
moveTo(FileHandle) - Method in class com.badlogic.gdx.files.FileHandle
Moves this file to the specified file, overwriting the file if it already exists.
moveTo(FileHandle) - Method in class com.badlogic.gdx.files.FileHandleStream
MoveTo - Class in com.badlogic.gdx.scenes.scene2d.actions
MoveTo() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
Mpg123Decoder - Class in com.badlogic.gdx.audio.io
A Decoder implementation that decodes MP3 files via libmpg123 natively.
Mpg123Decoder(String) - Constructor for class com.badlogic.gdx.audio.io.Mpg123Decoder
Opens the given file for mp3 decoding.
mul(Color) - Method in class com.badlogic.gdx.graphics.Color
Multiplies the this color and the given color
mul(float) - Method in class com.badlogic.gdx.graphics.Color
Multiplies all components of this Color with the given value.
mul(Matrix4) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Multiplies the bounding box by the given matrix.
mul(Matrix4) - Method in class com.badlogic.gdx.math.collision.Ray
Multiplies the ray by the given matrix.
mul(Matrix3) - Method in class com.badlogic.gdx.math.Matrix3
Multiplies this matrix with the other matrix in the order this * m.
mul(Matrix4) - Method in class com.badlogic.gdx.math.Matrix4
Multiplies this matrix with the given matrix, storing the result in this matrix.
mul(float) - Method in class com.badlogic.gdx.math.Vector2
Multiplies this vector by a scalar
mul(Matrix3) - Method in class com.badlogic.gdx.math.Vector2
Multiplies this vector by the given matrix
mul(float) - Method in class com.badlogic.gdx.math.Vector3
Multiplies all components of this vector by the given value
mul(Matrix4) - Method in class com.badlogic.gdx.math.Vector3
Multiplies the vector by the given matrix.
mul(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Transform
Transforms the given vector by this transform
multiply(MD5Quaternion) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
multiply(Vector3) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
Music - Interface in com.badlogic.gdx.audio
A Music instance represents a streamed audio file.

N

name() - Method in class com.badlogic.gdx.files.FileHandle
name - Variable in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
The name of the original image file, with any trailing numbers or special flags removed.
name - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
names - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Joints
names() - Method in class com.badlogic.gdx.utils.json.JSONObject
Produce a JSONArray containing the names of the elements of this JSONObject.
namesToActors - Variable in class com.badlogic.gdx.scenes.scene2d.Group
nameWithoutExtension() - Method in class com.badlogic.gdx.files.FileHandle
NativeFFT - Class in com.badlogic.gdx.audio.analysis
A native implementation of the Fast Fourier Transform, directly ported from the FFT class.
NativeFFT(int, int) - Constructor for class com.badlogic.gdx.audio.analysis.NativeFFT
near - Variable in class com.badlogic.gdx.math.Frustum
near_height - Variable in class com.badlogic.gdx.math.Frustum
near_width - Variable in class com.badlogic.gdx.math.Frustum
newAudioDevice(boolean) - Method in interface com.badlogic.gdx.Audio
Creates a new AudioDevice either in 44.1khz mono or stereo mode.
newAudioRecoder(int, boolean) - Method in interface com.badlogic.gdx.Audio
Creates a new AudioRecorder.
newByteBuffer(int) - Static method in class com.badlogic.gdx.utils.BufferUtils
newFloatBuffer(int) - Static method in class com.badlogic.gdx.utils.BufferUtils
newHighValue() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
newIntBuffer(int) - Static method in class com.badlogic.gdx.utils.BufferUtils
newLowValue() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
newMusic(FileHandle) - Method in interface com.badlogic.gdx.Audio
Creates a new Music instance which is used to play back a music stream from a file.
newObject() - Method in class com.badlogic.gdx.utils.Pool
Creates a new object either by taking it from the free object pool or by creating a new one if there are no free objects yet.
newPixmap(int, int, Pixmap.Format) - Method in interface com.badlogic.gdx.Graphics
Creates a new Pixmap with the specified dimensions and format.
newPixmap(InputStream) - Method in interface com.badlogic.gdx.Graphics
Creates a new Pixmap from the given InputStream which is assumed to point to a bitmap in a readable format.
newPixmap(FileHandle) - Method in interface com.badlogic.gdx.Graphics
Creates a new Pixmap from the given file which is assumed to point to a bitmap in a readable format.
newPixmap(Object) - Method in interface com.badlogic.gdx.Graphics
Creates a new Pixmap from the given native pixmap.
newShortBuffer(int) - Static method in class com.badlogic.gdx.utils.BufferUtils
newSound(FileHandle) - Method in interface com.badlogic.gdx.Audio
Creates a new Sound which is used to play back audio effects such as gun shots or explosions.
newTexture(FileHandle, Texture.TextureFilter, Texture.TextureFilter, Texture.TextureWrap, Texture.TextureWrap) - Method in interface com.badlogic.gdx.Graphics
Creates a new Texture from the given FileHandle using the specified minification and magnification filter and texture wraps in u and v.
newTexture(TextureData, Texture.TextureFilter, Texture.TextureFilter, Texture.TextureWrap, Texture.TextureWrap) - Method in interface com.badlogic.gdx.Graphics
Creates a new Texture that loads its data from the given TextureData.
newUnmanagedTexture(int, int, Pixmap.Format, Texture.TextureFilter, Texture.TextureFilter, Texture.TextureWrap, Texture.TextureWrap) - Method in interface com.badlogic.gdx.Graphics
Creates a new Texture with the specified dimensions, minification and magnification filters and texture wraps in u and v.
newUnmanagedTexture(Pixmap, Texture.TextureFilter, Texture.TextureFilter, Texture.TextureWrap, Texture.TextureWrap) - Method in interface com.badlogic.gdx.Graphics
Creates a new Texture from the given Pixmap using the specified minification and magnification filter and texture wraps in u and v.
next() - Method in class com.badlogic.gdx.utils.json.JSONTokener
Get the next character in the source string.
next(char) - Method in class com.badlogic.gdx.utils.json.JSONTokener
Consume the next character, and check that it matches a specified character.
next(int) - Method in class com.badlogic.gdx.utils.json.JSONTokener
Get the next n characters.
next() - Method in class com.badlogic.gdx.utils.PooledLinkedList
Gets the next item in the list
nextClean() - Method in class com.badlogic.gdx.utils.json.JSONTokener
Get the next char in the string, skipping whitespace.
nextPowerOfTwo(int) - Static method in class com.badlogic.gdx.utils.MathUtils
nextString(char) - Method in class com.badlogic.gdx.utils.json.JSONTokener
Return the characters up to the next close quote character.
nextTo(char) - Method in class com.badlogic.gdx.utils.json.JSONTokener
Get the text up but not including the specified character or the end of line, whichever comes first.
nextTo(String) - Method in class com.badlogic.gdx.utils.json.JSONTokener
Get the text up but not including one of the specified delimiter characters or the end of line, whichever comes first.
nextValue() - Method in class com.badlogic.gdx.utils.json.JSONTokener
Get the next value.
noAverages() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Sets the object to not compute averages.
NOAVG - Static variable in class com.badlogic.gdx.audio.analysis.FourierTransform
NONE - Static variable in class com.badlogic.gdx.audio.analysis.FourierTransform
A constant indicating no window should be used on sample buffers.
nor() - Method in class com.badlogic.gdx.math.Quaternion
Normalizes the quaternion.
nor() - Method in class com.badlogic.gdx.math.Vector2
Normalizes this vector
nor() - Method in class com.badlogic.gdx.math.Vector3
Normalizes this vector to unit length
normal(float, float, float) - Method in class com.badlogic.gdx.graphics.ImmediateModeRenderer
Specifies the normal of the current vertex
Normal - Static variable in class com.badlogic.gdx.graphics.VertexAttributes.Usage
normal - Variable in class com.badlogic.gdx.math.Plane
normal - Variable in class com.badlogic.gdx.physics.box2d.WorldManifold
normalize() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
NULL - Static variable in class com.badlogic.gdx.utils.json.JSONObject
It is sometimes more convenient and less ambiguous to have a NULL object than to use Java's null value.
numberToString(Number) - Static method in class com.badlogic.gdx.utils.json.JSONObject
Produce a string from a Number.
numComponents - Variable in class com.badlogic.gdx.graphics.VertexAttribute
the number of components this attribute has
numContactPoints - Variable in class com.badlogic.gdx.physics.box2d.WorldManifold
numJoints - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Joints
numJoints - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Model
numTriangles - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
numVertices - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
numWeights - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh

O

object() - Method in class com.badlogic.gdx.utils.json.JSONWriter
Begin appending a new object.
ObjLoader - Class in com.badlogic.gdx.graphics.loaders
Loads Wavefront OBJ files, ignores material files.
ObjLoader() - Constructor for class com.badlogic.gdx.graphics.loaders.ObjLoader
octaves - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
offset - Variable in class com.badlogic.gdx.graphics.VertexAttribute
the offset of this attribute in bytes, don't change this!
offsetX - Variable in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
The offset from the left of the original image to the left of the packed image, after whitespace was removed for packing.
offsetY - Variable in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
The offset from the bottom of the original image to the bottom of the packed image, after whitespace was removed for packing.
oldBatchTransform - Variable in class com.badlogic.gdx.scenes.scene2d.Group
onDestroy() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
onPause() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
onPause() - Method in class com.badlogic.gdx.utils.PauseableThread
Pauses the thread.
onResume() - Method in class com.badlogic.gdx.backends.android.AndroidApplication
onResume() - Method in class com.badlogic.gdx.utils.PauseableThread
Resumes the thread.
opt(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional object value associated with an index.
opt(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional value associated with a key.
optBoolean(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional boolean value associated with an index.
optBoolean(int, boolean) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional boolean value associated with an index.
optBoolean(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional boolean associated with a key.
optBoolean(String, boolean) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional boolean associated with a key.
optDouble(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional double value associated with an index.
optDouble(int, double) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional double value associated with an index.
optDouble(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional double associated with a key, or NaN if there is no such key or if its value is not a number.
optDouble(String, double) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional double associated with a key, or the defaultValue if there is no such key or if its value is not a number.
optInt(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional int value associated with an index.
optInt(int, int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional int value associated with an index.
optInt(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional int value associated with a key, or zero if there is no such key or if the value is not a number.
optInt(String, int) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional int value associated with a key, or the default if there is no such key or if the value is not a number.
optJSONArray(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional JSONArray associated with an index.
optJSONArray(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional JSONArray associated with a key.
optJSONObject(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional JSONObject associated with an index.
optJSONObject(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional JSONObject associated with a key.
optLong(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional long value associated with an index.
optLong(int, long) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional long value associated with an index.
optLong(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional long value associated with a key, or zero if there is no such key or if the value is not a number.
optLong(String, long) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional long value associated with a key, or the default if there is no such key or if the value is not a number.
optString(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional string value associated with an index.
optString(int, String) - Method in class com.badlogic.gdx.utils.json.JSONArray
Get the optional string associated with an index.
optString(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional string associated with a key.
optString(String, String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an optional string associated with a key.
origin - Variable in class com.badlogic.gdx.math.collision.Ray
originalHeight - Variable in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
The height of the image, before whitespace was removed for packing.
originalWidth - Variable in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
The width of the image, before whitespace was removed for packing.
originX - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
originY - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
OrthographicCamera - Class in com.badlogic.gdx.graphics
An orthographic camera having a position and a scale value for zooming.
OrthographicCamera() - Constructor for class com.badlogic.gdx.graphics.OrthographicCamera
Constructor, sets side to OrthographicCamera.Side.FRONT
OrthographicCamera.Side - Enum in com.badlogic.gdx.graphics
other - Variable in class com.badlogic.gdx.physics.box2d.JointEdge

P

packedHeight - Variable in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
The height of the image, after whitespace was removed for packing.
packedWidth - Variable in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
The width of the image, after whitespace was removed for packing.
Parallel - Class in com.badlogic.gdx.scenes.scene2d.actions
Parallel() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.Parallel
parent() - Method in class com.badlogic.gdx.files.FileHandle
parent() - Method in class com.badlogic.gdx.files.FileHandleStream
parent - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
ParticleEffect - Class in com.badlogic.gdx.graphics.particles
ParticleEffect() - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEffect
ParticleEmitter - Class in com.badlogic.gdx.graphics.particles
ParticleEmitter() - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEmitter
ParticleEmitter(BufferedReader) - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEmitter
ParticleEmitter(ParticleEmitter) - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEmitter
ParticleEmitter.GradientColorValue - Class in com.badlogic.gdx.graphics.particles
ParticleEmitter.GradientColorValue() - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
ParticleEmitter.NumericValue - Class in com.badlogic.gdx.graphics.particles
ParticleEmitter.NumericValue() - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue
ParticleEmitter.ParticleValue - Class in com.badlogic.gdx.graphics.particles
ParticleEmitter.ParticleValue() - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
ParticleEmitter.RangedNumericValue - Class in com.badlogic.gdx.graphics.particles
ParticleEmitter.RangedNumericValue() - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
ParticleEmitter.ScaledNumericValue - Class in com.badlogic.gdx.graphics.particles
ParticleEmitter.ScaledNumericValue() - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
ParticleEmitter.SpawnEllipseSide - Enum in com.badlogic.gdx.graphics.particles
ParticleEmitter.SpawnShape - Enum in com.badlogic.gdx.graphics.particles
ParticleEmitter.SpawnShapeValue - Class in com.badlogic.gdx.graphics.particles
ParticleEmitter.SpawnShapeValue() - Constructor for class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
path() - Method in class com.badlogic.gdx.files.FileHandle
pause() - Method in interface com.badlogic.gdx.ApplicationListener
Called when the Application is paused.
pause() - Method in interface com.badlogic.gdx.audio.Music
Pauses the play back.
pause() - Method in class com.badlogic.gdx.Game
pause() - Method in interface com.badlogic.gdx.Screen
PauseableThread - Class in com.badlogic.gdx.utils
A pausable thread.
PauseableThread(Runnable) - Constructor for class com.badlogic.gdx.utils.PauseableThread
Constructs a new thread setting the runnable which will be called repeatadly in a loop.
PerspectiveCamera - Class in com.badlogic.gdx.graphics
A perspective camera, having a position, a direction an up vector, a near plane, a far plane and a field of view.
PerspectiveCamera() - Constructor for class com.badlogic.gdx.graphics.PerspectiveCamera
PI - Static variable in class com.badlogic.gdx.utils.MathUtils
Pixmap - Interface in com.badlogic.gdx.graphics
A Pixmap represents a platform specific bitmap.
Pixmap.Format - Enum in com.badlogic.gdx.graphics
Different pixel formats.
Plane - Class in com.badlogic.gdx.math
A plane defined via a unit length normal and the distance from the origin, as you learned in your math class.
Plane(Vector3, float) - Constructor for class com.badlogic.gdx.math.Plane
Constructs a new plane based on the normal and distance to the origin.
Plane(Vector3, Vector3) - Constructor for class com.badlogic.gdx.math.Plane
Constructs a new plane based on the normal and a point on the plane.
Plane(Vector3, Vector3, Vector3) - Constructor for class com.badlogic.gdx.math.Plane
Constructs a new plane out of the three given points that are considered to be on the plane.
Plane.PlaneSide - Enum in com.badlogic.gdx.math
Enum specifying on which side a point lies respective to the plane and it's normal.
planes - Variable in class com.badlogic.gdx.math.Frustum
play() - Method in interface com.badlogic.gdx.audio.Music
Starts the play back of the music stream.
play() - Method in interface com.badlogic.gdx.audio.Sound
Plays the sound, you can call this repeatedly to play the same sound a couple of times with a bit of lag introduced.
play(float) - Method in interface com.badlogic.gdx.audio.Sound
Plays the sound, you can call this repeatedly to play the same sound a couple of times with a bit of lag introduced.
pointInFrustum(Vector3) - Method in class com.badlogic.gdx.math.Frustum
Returns wheter the point is in the frustum.
points - Variable in class com.badlogic.gdx.physics.box2d.WorldManifold
poll() - Method in class com.badlogic.gdx.utils.AtomicQueue
polygonClockwise(List<Vector2>) - Method in class com.badlogic.gdx.math.EarCutTriangulator
PolygonShape - Class in com.badlogic.gdx.physics.box2d
PolygonShape() - Constructor for class com.badlogic.gdx.physics.box2d.PolygonShape
Constructs a new polygon
PolygonShape(long) - Constructor for class com.badlogic.gdx.physics.box2d.PolygonShape
Pool<T> - Class in com.badlogic.gdx.utils
A pool implementation used for object instances that should get reused instead of being collected by the garbage collector.
Pool(Pool.PoolObjectFactory<T>, int) - Constructor for class com.badlogic.gdx.utils.Pool
Pool.PoolObjectFactory<T> - Interface in com.badlogic.gdx.utils
Interface for an Object Factory to be used with this Pool
PooledLinkedList<T> - Class in com.badlogic.gdx.utils
A simple linked list that pools its nodes.
PooledLinkedList(int) - Constructor for class com.badlogic.gdx.utils.PooledLinkedList
pop() - Method in class com.badlogic.gdx.utils.FloatArray
Removes and returns the last item.
pop(int) - Method in class com.badlogic.gdx.utils.FloatArray
Removes and returns the specified item.
pop() - Method in class com.badlogic.gdx.utils.FloatBag
Removes and returns the last item.
pop(int) - Method in class com.badlogic.gdx.utils.FloatBag
Removes and returns the specified item.
pop() - Method in class com.badlogic.gdx.utils.IntArray
Removes and returns the last item.
pop(int) - Method in class com.badlogic.gdx.utils.IntArray
Removes and returns the specified item.
pop() - Method in class com.badlogic.gdx.utils.IntBag
Removes and returns the last item.
pop(int) - Method in class com.badlogic.gdx.utils.IntBag
Removes and returns the specified item.
pop() - Method in class com.badlogic.gdx.utils.LocklessThreadQueue
Returns null or the next queued object in the queue list
pop() - Method in class com.badlogic.gdx.utils.LongArray
Removes and returns the last item.
pop(int) - Method in class com.badlogic.gdx.utils.LongArray
Removes and returns the specified item.
pop() - Method in class com.badlogic.gdx.utils.LongBag
Removes and returns the last item.
pop(int) - Method in class com.badlogic.gdx.utils.LongBag
Removes and returns the specified item.
POS_X - Static variable in class com.badlogic.gdx.physics.box2d.Transform
POS_Y - Static variable in class com.badlogic.gdx.physics.box2d.Transform
Position - Static variable in class com.badlogic.gdx.graphics.VertexAttributes.Usage
position - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
The world position of the body.
prepare() - Method in class com.badlogic.gdx.utils.LocklessThreadQueue
Returns the next available preallocated object for preparation.
pressed - Variable in class com.badlogic.gdx.scenes.scene2d.actors.Button
pressedRegion - Variable in class com.badlogic.gdx.scenes.scene2d.actors.Button
PrismaticJoint - Class in com.badlogic.gdx.physics.box2d.joints
A prismatic joint.
PrismaticJoint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
PrismaticJointDef - Class in com.badlogic.gdx.physics.box2d.joints
Prismatic joint definition.
PrismaticJointDef() - Constructor for class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
prj(Matrix4) - Method in class com.badlogic.gdx.math.Vector3
Multiplies this vector by the given matrix dividing by w.
proj - Variable in class com.badlogic.gdx.graphics.PerspectiveCamera
project(Vector3) - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
Projects the given vector in world space to screen space, overwritting the x- and y-coordinate of the provided vector.
PulleyJoint - Class in com.badlogic.gdx.physics.box2d.joints
The pulley joint is connected to two bodies and two fixed ground points.
PulleyJoint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.joints.PulleyJoint
PulleyJointDef - Class in com.badlogic.gdx.physics.box2d.joints
Pulley joint definition.
PulleyJointDef() - Constructor for class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
push() - Method in class com.badlogic.gdx.utils.LocklessThreadQueue
Push the next available object to the queue.
put(T) - Method in class com.badlogic.gdx.utils.AtomicQueue
put(int, T) - Method in class com.badlogic.gdx.utils.IntHashMap
put(boolean) - Method in class com.badlogic.gdx.utils.json.JSONArray
Append a boolean value.
put(Collection) - Method in class com.badlogic.gdx.utils.json.JSONArray
Put a value in the JSONArray, where the value will be a JSONArray which is produced from a Collection.
put(double) - Method in class com.badlogic.gdx.utils.json.JSONArray
Append a double value.
put(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Append an int value.
put(long) - Method in class com.badlogic.gdx.utils.json.JSONArray
Append an long value.
put(Map) - Method in class com.badlogic.gdx.utils.json.JSONArray
Put a value in the JSONArray, where the value will be a JSONObject which is produced from a Map.
put(Object) - Method in class com.badlogic.gdx.utils.json.JSONArray
Append an object value.
put(int, boolean) - Method in class com.badlogic.gdx.utils.json.JSONArray
Put or replace a boolean value in the JSONArray.
put(int, Collection) - Method in class com.badlogic.gdx.utils.json.JSONArray
Put a value in the JSONArray, where the value will be a JSONArray which is produced from a Collection.
put(int, double) - Method in class com.badlogic.gdx.utils.json.JSONArray
Put or replace a double value.
put(int, int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Put or replace an int value.
put(int, long) - Method in class com.badlogic.gdx.utils.json.JSONArray
Put or replace a long value.
put(int, Map) - Method in class com.badlogic.gdx.utils.json.JSONArray
Put a value in the JSONArray, where the value will be a JSONObject which is produced from a Map.
put(int, Object) - Method in class com.badlogic.gdx.utils.json.JSONArray
Put or replace an object value in the JSONArray.
put(String, boolean) - Method in class com.badlogic.gdx.utils.json.JSONObject
Put a key/boolean pair in the JSONObject.
put(String, Collection) - Method in class com.badlogic.gdx.utils.json.JSONObject
Put a key/value pair in the JSONObject, where the value will be a JSONArray which is produced from a Collection.
put(String, double) - Method in class com.badlogic.gdx.utils.json.JSONObject
Put a key/double pair in the JSONObject.
put(String, int) - Method in class com.badlogic.gdx.utils.json.JSONObject
Put a key/int pair in the JSONObject.
put(String, long) - Method in class com.badlogic.gdx.utils.json.JSONObject
Put a key/long pair in the JSONObject.
put(String, Map) - Method in class com.badlogic.gdx.utils.json.JSONObject
Put a key/value pair in the JSONObject, where the value will be a JSONObject which is produced from a Map.
put(String, Object) - Method in class com.badlogic.gdx.utils.json.JSONObject
Put a key/value pair in the JSONObject.
put(long, T) - Method in class com.badlogic.gdx.utils.LongHashMap
putOnce(String, Object) - Method in class com.badlogic.gdx.utils.json.JSONObject
Put a key/value pair in the JSONObject, but only if the key and the value are both non-null, and only if there is not already a member with that name.
putOpt(String, Object) - Method in class com.badlogic.gdx.utils.json.JSONObject
Put a key/value pair in the JSONObject, but only if the key and the value are both non-null.

Q

Quaternion - Class in com.badlogic.gdx.math
A simple quaternion class.
Quaternion(float, float, float, float) - Constructor for class com.badlogic.gdx.math.Quaternion
Constructor, sets the four components of the quaternion.
Quaternion(Quaternion) - Constructor for class com.badlogic.gdx.math.Quaternion
Constructor, sets the quaternion components from the given quaternion.
Quaternion(Vector3, float) - Constructor for class com.badlogic.gdx.math.Quaternion
Constructor, sets the quaternion from the given axis vector and the angle around that axis in degrees.
QueryAABB(QueryCallback, float, float, float, float) - Method in class com.badlogic.gdx.physics.box2d.World
Query the world for all fixtures that potentially overlap the provided AABB.
QueryCallback - Interface in com.badlogic.gdx.physics.box2d
Callback class for AABB queries.
queueBuffer - Variable in class com.badlogic.gdx.utils.LocklessThreadQueue
queueSize - Variable in class com.badlogic.gdx.utils.LocklessThreadQueue
quote(String) - Static method in class com.badlogic.gdx.utils.json.JSONObject
Produce a string in double quotes with backslash sequences in all the right places.

R

r - Variable in class com.badlogic.gdx.graphics.Color
the red, green, blue and alpha components
radiansToDegrees - Static variable in class com.badlogic.gdx.utils.MathUtils
radius - Variable in class com.badlogic.gdx.math.collision.Sphere
the radius of the sphere
random(int) - Static method in class com.badlogic.gdx.utils.MathUtils
Returns a random number between 0 (inclusive) and the specified value (inclusive).
random(int, int) - Static method in class com.badlogic.gdx.utils.MathUtils
random() - Static method in class com.badlogic.gdx.utils.MathUtils
random(float) - Static method in class com.badlogic.gdx.utils.MathUtils
random(float, float) - Static method in class com.badlogic.gdx.utils.MathUtils
randomBoolean() - Static method in class com.badlogic.gdx.utils.MathUtils
ratio - Variable in class com.badlogic.gdx.physics.box2d.joints.GearJointDef
The gear ratio.
ratio - Variable in class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
The pulley ratio, used to simulate a block-and-tackle.
Ray - Class in com.badlogic.gdx.math.collision
Encapsulates a ray having a starting position and a unit length direction.
Ray(Vector3, Vector3) - Constructor for class com.badlogic.gdx.math.collision.Ray
Constructor, sets the starting position of the ray and the direction.
read(short[], int, int) - Method in interface com.badlogic.gdx.audio.AudioRecorder
Reads in numSamples samples into the array samples starting at offset.
read() - Method in class com.badlogic.gdx.files.FileHandle
Returns a stream for reading this file.
read() - Method in class com.badlogic.gdx.files.FileHandleStream
readBoolean() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readByte(int) - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readChar() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readDouble() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readFloat() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readInt() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readLong() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readSamples(ShortBuffer) - Method in interface com.badlogic.gdx.audio.io.Decoder
Reads in samples.capacity() samples in 16-bit signed PCM format from the decoder.
readSamples(ShortBuffer) - Method in class com.badlogic.gdx.audio.io.Mpg123Decoder
Reads in samples.capacity() samples in 16-bit signed PCM format from the decoder.
readSamples(ShortBuffer) - Method in class com.badlogic.gdx.audio.io.VorbisDecoder
Reads in samples.capacity() samples in 16-bit signed PCM format from the decoder.
readShort() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readUnsignedByte() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readUnsignedShort() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
readUTF() - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
real - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
Rectangle - Class in com.badlogic.gdx.math
Encapsulates a 2D rectangle defined by it's bottom corner point and its extends in x (width) and y (height).
Rectangle() - Constructor for class com.badlogic.gdx.math.Rectangle
Constructs a new rectangle with all values set to zero
Rectangle(float, float, float, float) - Constructor for class com.badlogic.gdx.math.Rectangle
Constructs a new rectangle with the given corner point in the bottom left and dimensions.
Rectangle(Rectangle) - Constructor for class com.badlogic.gdx.math.Rectangle
Constructs a rectangle based on the given rectangle
RED - Static variable in class com.badlogic.gdx.graphics.Color
referenceAngle - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
The constrained angle between the bodies: body2_angle - body1_angle.
referenceAngle - Variable in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
The body2 angle minus body1 angle in the reference state (radians).
referenceAngle - Variable in class com.badlogic.gdx.physics.box2d.joints.WeldJointDef
region - Variable in class com.badlogic.gdx.scenes.scene2d.actors.Image
remove() - Method in class com.badlogic.gdx.scenes.scene2d.Actor
Removes this actor from the Stage
remove(int) - Method in class com.badlogic.gdx.utils.IntHashMap
remove(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Remove an index and close the hole.
remove(String) - Method in class com.badlogic.gdx.utils.json.JSONObject
Remove a name and its value, if present.
remove(long) - Method in class com.badlogic.gdx.utils.LongHashMap
remove() - Method in class com.badlogic.gdx.utils.PooledLinkedList
Removs the current list item based on the iterator position.
removeActor(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actors.LinearGroup
removeActor(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.Group
Removes an Actor from this Group.
removeIndex(int) - Method in class com.badlogic.gdx.utils.FloatArray
removeIndex(int) - Method in class com.badlogic.gdx.utils.FloatBag
removeIndex(int) - Method in class com.badlogic.gdx.utils.IntArray
removeIndex(int) - Method in class com.badlogic.gdx.utils.IntBag
removeIndex(int) - Method in class com.badlogic.gdx.utils.LongArray
removeIndex(int) - Method in class com.badlogic.gdx.utils.LongBag
removeProcessor(InputProcessor) - Method in class com.badlogic.gdx.InputMultiplexer
removeValue(float) - Method in class com.badlogic.gdx.utils.FloatArray
removeValue(float) - Method in class com.badlogic.gdx.utils.FloatBag
removeValue(int) - Method in class com.badlogic.gdx.utils.IntArray
removeValue(int) - Method in class com.badlogic.gdx.utils.IntBag
removeValue(long) - Method in class com.badlogic.gdx.utils.LongArray
removeValue(long) - Method in class com.badlogic.gdx.utils.LongBag
render() - Method in interface com.badlogic.gdx.ApplicationListener
Called when the Application should render itself.
render() - Method in class com.badlogic.gdx.Game
render() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Renderer
render(int) - Method in class com.badlogic.gdx.graphics.Mesh
Renders the mesh using the given primitive type.
render(int, int, int) - Method in class com.badlogic.gdx.graphics.Mesh
Renders the mesh using the given primitive type.
render(ShaderProgram, int) - Method in class com.badlogic.gdx.graphics.Mesh
Renders the mesh using the given primitive type.
render(ShaderProgram, int, int, int) - Method in class com.badlogic.gdx.graphics.Mesh
Renders the mesh using the given primitive type.
render(World) - Method in class com.badlogic.gdx.physics.box2d.Box2DDebugRenderer
This assumes that the projection matrix has already been set.
render(SpriteBatch) - Method in class com.badlogic.gdx.scenes.scene2d.Actor
Renders the Actor.
render(SpriteBatch) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Button
render(SpriteBatch) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Image
render(SpriteBatch) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Label
render(SpriteBatch) - Method in class com.badlogic.gdx.scenes.scene2d.Group
render() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Renders the stage
render(float) - Method in interface com.badlogic.gdx.Screen
Called when the screen should render itself.
render() - Method in class com.badlogic.gdx.twl.TWL
Draws the TWL UI.
renderCalls - Variable in class com.badlogic.gdx.graphics.SpriteBatch
number of render calls
renderer - Variable in class com.badlogic.gdx.physics.box2d.Box2DDebugRenderer
the immediate mode renderer to output our debug drawings
Repeat - Class in com.badlogic.gdx.scenes.scene2d.actions
Repeat() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.Repeat
reportFixture(Fixture) - Method in interface com.badlogic.gdx.physics.box2d.QueryCallback
Called for each fixture found in the query AABB.
reset() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo
reset(int, float) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo
reset() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
resetMassData() - Method in class com.badlogic.gdx.physics.box2d.Body
This resets the mass properties to the sum of the mass properties of the fixtures.
resize(int, int) - Method in interface com.badlogic.gdx.ApplicationListener
Called when the Application is resized.
resize(int, int) - Method in class com.badlogic.gdx.Game
resize(int, int) - Method in interface com.badlogic.gdx.Screen
restitution - Variable in class com.badlogic.gdx.physics.box2d.FixtureDef
The restitution (elasticity) usually in the range [0,1].
resume() - Method in interface com.badlogic.gdx.ApplicationListener
Called when the Application is resumed from a paused state.
resume() - Method in class com.badlogic.gdx.Game
resume() - Method in interface com.badlogic.gdx.Screen
RevoluteJoint - Class in com.badlogic.gdx.physics.box2d.joints
A revolute joint constrains two bodies to share a common point while they are free to rotate about the point.
RevoluteJoint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
RevoluteJointDef - Class in com.badlogic.gdx.physics.box2d.joints
Revolute joint definition.
RevoluteJointDef() - Constructor for class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
right() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
rot(Matrix4) - Method in class com.badlogic.gdx.math.Vector3
Multiplies this vector by the first three columns of the matrix, essentially only applying rotation and scaling.
rotate(Vector3) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
rotate(float) - Method in class com.badlogic.gdx.graphics.Sprite
Sets the sprite's rotation relative to the current rotation.
rotate - Variable in class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
If true, the region has been rotated 90 degrees counter clockwise.
rotate90(boolean) - Method in class com.badlogic.gdx.graphics.Sprite
Rotates this sprite 90 degrees in-place by rotating the texture coordinates.
RotateBy - Class in com.badlogic.gdx.scenes.scene2d.actions
RotateBy() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
RotateTo - Class in com.badlogic.gdx.scenes.scene2d.actions
RotateTo() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
rotation - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
rotation - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
rotation - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
run() - Method in class com.badlogic.gdx.utils.PauseableThread

S

sampleRate - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
save(File) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
save(Writer) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
save(Writer) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue
save(Writer) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
save(Writer) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
save(Writer) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
save(Writer) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
save(Writer) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
scale(float) - Method in class com.badlogic.gdx.graphics.Sprite
Sets the sprite's scale relative to the current scale.
scale(float, float, float) - Method in class com.badlogic.gdx.math.Vector3
Scales the vector components by the given scalars.
scaleBand(int, float) - Method in class com.badlogic.gdx.audio.analysis.DFT
Not currently implemented.
scaleBand(int, float) - Method in class com.badlogic.gdx.audio.analysis.FFT
scaleBand(int, float) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Scales the amplitude of the ith frequency band by s.
scaleFreq(float, float) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Scales the amplitude of the requested frequency by a.
ScaleTo - Class in com.badlogic.gdx.scenes.scene2d.actions
ScaleTo() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
scaleX - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
scaleX - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
scaleY - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
scaleY - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
scenetransform - Variable in class com.badlogic.gdx.scenes.scene2d.Group
Screen - Interface in com.badlogic.gdx
Represents one of many application screens, such as a main menu, a settings menu, the game screen and so on.
scroll(float, float) - Method in class com.badlogic.gdx.graphics.Sprite
scroll(float, float) - Method in class com.badlogic.gdx.graphics.TextureRegion
Offsets the region relative to the current region.
secondsPerFrame - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Animation
Segment - Class in com.badlogic.gdx.math.collision
A Segment is a line in 3-space having a staring and an ending position.
Segment(Vector3, Vector3) - Constructor for class com.badlogic.gdx.math.collision.Segment
Constructs a new Segment from the two points given.
Segment(float, float, float, float, float, float) - Constructor for class com.badlogic.gdx.math.collision.Segment
Constructs a new Segment from the two points given.
Sequence - Class in com.badlogic.gdx.scenes.scene2d.actions
Sequence() - Constructor for class com.badlogic.gdx.scenes.scene2d.actions.Sequence
set(Color) - Method in class com.badlogic.gdx.graphics.Color
Sets this color to the given color.
set(float, float, float, float) - Method in class com.badlogic.gdx.graphics.Color
set(MD5Quaternion) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
set(Sprite) - Method in class com.badlogic.gdx.graphics.Sprite
set(BoundingBox) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Sets the given bounding box.
set(Vector3, Vector3) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Sets the given minimum and maximum vector.
set(Vector3[]) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Sets the bounding box minimum and maximum vector from the given points.
set(List<Vector3>) - Method in class com.badlogic.gdx.math.collision.BoundingBox
Sets the bounding box minimum and maximum vector from the given points.
set(Vector3, Vector3) - Method in class com.badlogic.gdx.math.collision.Ray
Sets the starting position and the direction of this ray.
set(float, float, float, float, float, float) - Method in class com.badlogic.gdx.math.collision.Ray
Sets this ray from the given starting position and direction.
set(Ray) - Method in class com.badlogic.gdx.math.collision.Ray
Sets the starting position and direction from the given ray
set(Matrix3) - Method in class com.badlogic.gdx.math.Matrix3
set(Matrix4) - Method in class com.badlogic.gdx.math.Matrix4
Sets the matrix to the given matrix.
set(float[]) - Method in class com.badlogic.gdx.math.Matrix4
Sets the matrix to the given matrix as a float array.
set(Quaternion) - Method in class com.badlogic.gdx.math.Matrix4
Sets the matrix to a rotation matrix representing the quaternion.
set(Vector3, Vector3, Vector3, Vector3) - Method in class com.badlogic.gdx.math.Matrix4
Sets the four columns of the matrix which correspond to the x-, y- and z-axis of the vector space this matrix creates as well as the 4th column representing the translation of any point that is multiplied by this matrix.
set(Matrix3) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to the given 3x3 matrix.
set(Vector3, Vector3, Vector3) - Method in class com.badlogic.gdx.math.Plane
Sets the plane normal and distance to the origin based on the three given points which are considered to be on the plane.
set(float, float, float, float) - Method in class com.badlogic.gdx.math.Plane
Sets the plane normal and distance
set(Vector3, Vector3) - Method in class com.badlogic.gdx.math.Plane
Sets the plane to the given point and normal.
set(Plane) - Method in class com.badlogic.gdx.math.Plane
Sets this plane from the given plane
set(float, float, float, float) - Method in class com.badlogic.gdx.math.Quaternion
Sets the components of the quaternion
set(Quaternion) - Method in class com.badlogic.gdx.math.Quaternion
Sets the quaternion components from the given quaternion.
set(Vector3, float) - Method in class com.badlogic.gdx.math.Quaternion
Sets the quaternion components from the given axis and angle around that axis.
set(Vector2) - Method in class com.badlogic.gdx.math.Vector2
Sets this vector from the given vector
set(float, float) - Method in class com.badlogic.gdx.math.Vector2
Sets the components of this vector
set(float, float, float) - Method in class com.badlogic.gdx.math.Vector3
Sets the vector to the given components
set(Vector3) - Method in class com.badlogic.gdx.math.Vector3
Sets the components of the given vector
set(float[]) - Method in class com.badlogic.gdx.math.Vector3
Sets the components from the array.
set(Vector2[]) - Method in class com.badlogic.gdx.physics.box2d.PolygonShape
Copy vertices.
set(int, float) - Method in class com.badlogic.gdx.utils.FloatArray
set(int, int) - Method in class com.badlogic.gdx.utils.IntArray
set(int, long) - Method in class com.badlogic.gdx.utils.LongArray
setActive(boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
setActive(boolean) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the active state of the body.
setAdditive(boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setAligned(boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setAlwaysActive(boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
setAngularDamping(float) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the angular damping of the body.
setAngularVelocity(float) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the angular velocity.
setAsBox(float, float) - Method in class com.badlogic.gdx.physics.box2d.PolygonShape
Build vertices to represent an axis-aligned box.
setAsBox(float, float, Vector2, float) - Method in class com.badlogic.gdx.physics.box2d.PolygonShape
Build vertices to represent an oriented box.
setAsEdge(Vector2, Vector2) - Method in class com.badlogic.gdx.physics.box2d.PolygonShape
Set this as a single edge.
setAttached(boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setAttributef(String, float, float, float, float) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the given attribute
setAutoBind(boolean) - Method in class com.badlogic.gdx.graphics.Mesh
Sets whether to bind the underlying VertexArray or VertexBufferObject automatically on a call to one of the Mesh.render(int) methods or not.
setAutoClearForces(boolean) - Method in class com.badlogic.gdx.physics.box2d.World
Set flag to control automatic clearing of forces after each time step.
setAwake(boolean) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the sleep state of the body.
setBand(int, float) - Method in class com.badlogic.gdx.audio.analysis.DFT
Not currently implemented.
setBand(int, float) - Method in class com.badlogic.gdx.audio.analysis.FFT
setBand(int, float) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Sets the amplitude of the ith frequency band to a.
setBehind(boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setBlendFunction(int, int) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Sets the blending function to be used when rendering sprites.
setBounds(float, float, float, float) - Method in class com.badlogic.gdx.graphics.Sprite
Sets the position and size of the sprite when drawn, before scaling and rotation are applied.
setBullet(boolean) - Method in class com.badlogic.gdx.physics.box2d.Body
Should this body be treated like a bullet for continuous collision detection?
setCameraOrientation(Vector3, Vector3, Vector3) - Method in class com.badlogic.gdx.math.Frustum
Sets the camera orientation.
setCameraParameters(float, float, float, float) - Method in class com.badlogic.gdx.math.Frustum
Sets the camera parameters.
setCatchBackKey(boolean) - Method in interface com.badlogic.gdx.Input
Sets whether the BACK button on Android should be caught.
setColor(Color) - Method in class com.badlogic.gdx.graphics.BitmapFont
setColor(float, float, float, float) - Method in class com.badlogic.gdx.graphics.BitmapFont
setColor(Color) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
setColor(float, float, float, float) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
setColor(float, float, float, float) - Method in interface com.badlogic.gdx.graphics.Pixmap
Sets the color for the following drawing operations.
setColor(Color) - Method in class com.badlogic.gdx.graphics.Sprite
setColor(float, float, float, float) - Method in class com.badlogic.gdx.graphics.Sprite
setColor(Color) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Sets the color used to tint images when they are added to the SpriteBatch.
setColor(float, float, float, float) - Method in class com.badlogic.gdx.graphics.SpriteBatch
setColor(float) - Method in class com.badlogic.gdx.graphics.SpriteBatch
setColor(Color) - Method in class com.badlogic.gdx.graphics.SpriteCache
Sets the color used to tint images when they are added to the SpriteCache.
setColor(float, float, float, float) - Method in class com.badlogic.gdx.graphics.SpriteCache
setColor(float) - Method in class com.badlogic.gdx.graphics.SpriteCache
setColors(float[]) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
setComplex(float[], float[]) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
setContactFilter(ContactFilter) - Method in class com.badlogic.gdx.physics.box2d.World
Register a contact filter to provide specific control over collision.
setContactListener(ContactListener) - Method in class com.badlogic.gdx.physics.box2d.World
Register a contact event listener.
setContinuous(boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setContinuousPhysics(boolean) - Method in class com.badlogic.gdx.physics.box2d.World
Enable/disable continuous physics.
setDampingRatio(float) - Method in class com.badlogic.gdx.physics.box2d.joints.DistanceJoint
Set/get damping ratio.
setDampingRatio(float) - Method in class com.badlogic.gdx.physics.box2d.joints.MouseJoint
Set/get the damping ratio (dimensionless).
setDensity(float) - Method in class com.badlogic.gdx.physics.box2d.Fixture
Set the density of this fixture.
setDestructionListener(DestructionListener) - Method in class com.badlogic.gdx.physics.box2d.World
Register a destruction listener.
setDuration(int) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
setEdges(boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
setEnabled(boolean) - Method in class com.badlogic.gdx.physics.box2d.Contact
Enable/disable this contact.
setEulerAngles(float, float, float) - Method in class com.badlogic.gdx.math.Quaternion
Sets the quaternion to the given euler angles.
setFar(float) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Sets the far plane
setFar(float) - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
Sets the far plane
setFilterData(Filter) - Method in class com.badlogic.gdx.physics.box2d.Fixture
Set the contact filtering data.
setFixedRotation(boolean) - Method in class com.badlogic.gdx.physics.box2d.Body
Set this body to have fixed rotation.
setFixedWidthGlyphs(CharSequence) - Method in class com.badlogic.gdx.graphics.BitmapFont
Makes the specified glyphs fixed width.
setFlip(boolean, boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setFov(float) - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
Sets the field of view in degrees
setFreq(float, float) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Sets the amplitude of the requested frequency in the spectrum to a.
setFrequency(float) - Method in class com.badlogic.gdx.physics.box2d.joints.DistanceJoint
Set/get frequency in Hz.
setFrequency(float) - Method in class com.badlogic.gdx.physics.box2d.joints.MouseJoint
Set/get the frequency in Hertz.
setFriction(float) - Method in class com.badlogic.gdx.physics.box2d.Fixture
Set the coefficient of friction.
setFromEulerAngles(float, float, float) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to a rotation matrix from the given euler angles.
setGravity(Vector2) - Method in class com.badlogic.gdx.physics.box2d.World
Change the global gravity vector.
setHeight(float) - Method in class com.badlogic.gdx.math.Rectangle
Sets the height of this rectangle
setHigh(float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
setHigh(float, float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
setHighMax(float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
setHighMin(float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
setImagePath(String) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setIndices(short[], int, int) - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObject
Sets the indices of this IndexBufferObject, discarding the old indices.
setIndices(short[], int, int) - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
Sets the indices of this IndexBufferObject, discarding the old indices.
setIndices(short[], int, int) - Method in interface com.badlogic.gdx.graphics.glutils.IndexData
Sets the indices of this IndexBufferObject, discarding the old indices.
setIndices(short[]) - Method in class com.badlogic.gdx.graphics.Mesh
Sets the indices of this Mesh
setIndices(short[], int, int) - Method in class com.badlogic.gdx.graphics.Mesh
Sets the indices of this Mesh.
setInputProcessor(InputProcessor) - Method in interface com.badlogic.gdx.Input
Sets the InputProcessor that will receive all touch and key input events.
setLength(float) - Method in class com.badlogic.gdx.physics.box2d.joints.DistanceJoint
Set/get the natural length.
setLimits(float, float) - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Set the joint limits, usually in meters.
setLimits(float, float) - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Set the joint limits, usually in meters.
setLimits(float, float) - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Set the joint limits in radians.
setLinearDamping(float) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the linear damping of the body.
setLinearVelocity(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the linear velocity of the center of mass.
setLooping(boolean) - Method in interface com.badlogic.gdx.audio.Music
Sets whether the music stream is looping or not.
setLow(float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
setLow(float, float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
setLowMax(float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
setLowMin(float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
setMassData(MassData) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the mass properties to override the mass properties of the fixtures.
setMatrices() - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Sets the projection matrix that also incorporates the camera's scale and position and loads an identity to the model view matrix of OpenGL ES 1.x.
setMatrices() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
Sets the projection and model view matrix of OpenGL ES 1.x to this camera's projection and model view matrix.
setMaxForce(float) - Method in class com.badlogic.gdx.physics.box2d.joints.FrictionJoint
Set the maximum friction force in N.
setMaxForce(float) - Method in class com.badlogic.gdx.physics.box2d.joints.MouseJoint
Set/get the maximum force in Newtons.
setMaxMotorForce(float) - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Set/Get the maximum motor force, usually in N.
setMaxMotorForce(float) - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Set the maximum motor force, usually in N.
setMaxMotorTorque(float) - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Set the maximum motor torque, usually in N-m.
setMaxParticleCount(int) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setMaxTorque(float) - Method in class com.badlogic.gdx.physics.box2d.joints.FrictionJoint
Set the maximum friction torque in N*m.
setMinParticleCount(int) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setMotorSpeed(float) - Method in class com.badlogic.gdx.physics.box2d.joints.LineJoint
Set the motor speed, usually in meters per second.
setMotorSpeed(float) - Method in class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
Set the motor speed, usually in meters per second.
setMotorSpeed(float) - Method in class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
Set the motor speed in radians per second.
setMultiLineText(CharSequence, float, float) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Caches a string, which may contain newlines (\n), with the specified position.
setMultiLineText(CharSequence, float, float, float, BitmapFont.HAlignment) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Caches a string, which may contain newlines (\n), with the specified position and alignment.
setName(String) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setNear(float) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Sets the near plane.
setNear(float) - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
Sets the near plane.
setOnscreenKeyboardVisible(boolean) - Method in interface com.badlogic.gdx.Input
Sets the on-screen keyboard visible if available.
setOrigin(float, float) - Method in class com.badlogic.gdx.graphics.Sprite
Sets the origin in relation to the sprite's position for scaling and rotation.
setPosition(float, float) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Sets the position of the text, relative to the position when the cached text was created.
setPosition(float, float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
setPosition(float, float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setPosition(float, float) - Method in class com.badlogic.gdx.graphics.Sprite
Sets the position where the sprite will be drawn.
setPosition(Vector2) - Method in class com.badlogic.gdx.physics.box2d.CircleShape
Sets the position of the shape
setPosition(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Transform
Sets the position of this transform
setProjectionMatrix(Matrix4) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Sets the projection matrix to be used by this SpriteBatch.
setProjectionMatrix(Matrix4) - Method in class com.badlogic.gdx.graphics.SpriteCache
setRadius(float) - Method in class com.badlogic.gdx.physics.box2d.Shape
Sets the radius of this shape
setRatio(float) - Method in class com.badlogic.gdx.physics.box2d.joints.GearJoint
Set/Get the gear ratio.
setRegion(float, float, float, float) - Method in class com.badlogic.gdx.graphics.Sprite
setRegion(Texture) - Method in class com.badlogic.gdx.graphics.TextureRegion
Sets the texture and sets the coordinates to the size of the specified texture.
setRegion(int, int, int, int) - Method in class com.badlogic.gdx.graphics.TextureRegion
setRegion(float, float, float, float) - Method in class com.badlogic.gdx.graphics.TextureRegion
setRegion(TextureRegion) - Method in class com.badlogic.gdx.graphics.TextureRegion
Sets the texture and coordinates to the specified region.
setRegion(TextureRegion, int, int, int, int) - Method in class com.badlogic.gdx.graphics.TextureRegion
Sets the texture to that of the specified region and sets the coordinates relative to the specified region.
setRegionHeight(int) - Method in class com.badlogic.gdx.graphics.TextureRegion
setRegionWidth(int) - Method in class com.badlogic.gdx.graphics.TextureRegion
setRegionX(int) - Method in class com.badlogic.gdx.graphics.TextureRegion
setRegionY(int) - Method in class com.badlogic.gdx.graphics.TextureRegion
setRelative(boolean) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
setRestitution(float) - Method in class com.badlogic.gdx.physics.box2d.Fixture
Set the coefficient of restitution.
setRotation(float) - Method in class com.badlogic.gdx.graphics.Sprite
setRotation(float) - Method in class com.badlogic.gdx.physics.box2d.Transform
Sets the rotation of this transform
setScale(float) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
setScale(float) - Method in class com.badlogic.gdx.graphics.Sprite
setScale(float, float) - Method in class com.badlogic.gdx.graphics.Sprite
setScaling(float[]) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
setScreen(Screen) - Method in class com.badlogic.gdx.Game
Sets the current screen.
setSensor(boolean) - Method in class com.badlogic.gdx.physics.box2d.Fixture
Set if this fixture is a sensor.
setShape(ParticleEmitter.SpawnShape) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
setSide(OrthographicCamera.Side) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Sets the side the camera looks at.
setSide(ParticleEmitter.SpawnEllipseSide) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
setSize(float, float) - Method in class com.badlogic.gdx.graphics.Sprite
Sets the size of the sprite when drawn, before scaling and rotation are applied.
setSkeleton(MD5Joints) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Renderer
setSleepingAllowed(boolean) - Method in class com.badlogic.gdx.physics.box2d.Body
You can disable sleeping on this body.
setSprite(Sprite) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
setStrokeWidth(int) - Method in interface com.badlogic.gdx.graphics.Pixmap
Sets the width in pixels of strokes.
setTarget(Vector2) - Method in class com.badlogic.gdx.physics.box2d.joints.MouseJoint
Use this to update the target point.
setTarget(Actor) - Method in interface com.badlogic.gdx.scenes.scene2d.Action
Sets the Actor of this action.
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Delay
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Forever
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Parallel
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
setTarget(Actor) - Method in class com.badlogic.gdx.scenes.scene2d.actions.Sequence
setText(CharSequence, float, float) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Caches a string with the specified position.
setText(CharSequence, float, float, int, int) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Caches a substring with the specified position.
setTexture(Texture) - Method in class com.badlogic.gdx.graphics.TextureRegion
setTimeline(float[]) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
setTimeline(float[]) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
setToLookAt(Vector3, Vector3) - Method in class com.badlogic.gdx.math.Matrix4
Sets the matrix to a look at matrix with a direction and an up vector.
setToLookAt(Vector3, Vector3, Vector3) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to a look at matrix with the given position, target and up vector.
setToOrtho(float, float, float, float, float, float) - Method in class com.badlogic.gdx.math.Matrix4
Sets the matrix to an orthographic projection like glOrtho (http://www.opengl.org/sdk/docs/man/xhtml/glOrtho.xml) following the OpenGL equivalent
setToOrtho2D(float, float, float, float) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to an orthographic projection matrix with the origin at (x,y) extending by width and height.
setToOrtho2D(float, float, float, float, float, float) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to an orthographic projection matrix with the origin at (x,y) extending by width and height, having a near and far plane.
setToProjection(float, float, float, float) - Method in class com.badlogic.gdx.math.Matrix4
Sets the matrix to a projection matrix with a near- and far plane, a field of view in degrees and an aspect ratio.
setToRotation(float) - Method in class com.badlogic.gdx.math.Matrix3
Sets this matrix to a rotation matrix that will rotate any vector in counter clockwise order around the z-axis.
setToRotation(Vector3, float) - Method in class com.badlogic.gdx.math.Matrix4
Sets the matrix to a rotation matrix around the given axis.
setToScaling(float, float) - Method in class com.badlogic.gdx.math.Matrix3
Sets this matrix to a scaling matrix
setToScaling(Vector3) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to a scaling matrix
setToScaling(float, float, float) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to a scaling matrix
setToTranslation(float, float) - Method in class com.badlogic.gdx.math.Matrix3
Sets this matrix to a translation matrix.
setToTranslation(Vector3) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to a translation matrix, overwriting it first by an identity matrix and then setting the 4th column to the translation vector.
setToTranslation(float, float, float) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to a translation matrix, overwriting it first by an identity matrix and then setting the 4th column to the translation vector.
setToTranslationAndScaling(Vector3, Vector3) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to a translation and scaling matrix by first overwritting it with an identity and then setting the translation vector in the 4th column and the scaling vector in the diagonal.
setToTranslationAndScaling(float, float, float, float, float, float) - Method in class com.badlogic.gdx.math.Matrix4
Sets this matrix to a translation and scaling matrix by first overwritting it with an identity and then setting the translation vector in the 4th column and the scaling vector in the diagonal.
setToWorld(Vector3, Vector3, Vector3) - Method in class com.badlogic.gdx.math.Matrix4
setTransform(Vector2, float) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the position of the body's origin and rotation.
setTransformMatrix(Matrix4) - Method in class com.badlogic.gdx.graphics.SpriteBatch
Sets the transform matrix to be used by this SpriteBatch.
setTransformMatrix(Matrix4) - Method in class com.badlogic.gdx.graphics.SpriteCache
setType(BodyDef.BodyType) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the type of this body.
setU(float) - Method in class com.badlogic.gdx.graphics.Sprite
setU(float) - Method in class com.badlogic.gdx.graphics.TextureRegion
setU2(float) - Method in class com.badlogic.gdx.graphics.Sprite
setU2(float) - Method in class com.badlogic.gdx.graphics.TextureRegion
setUniformf(String, float) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the uniform with the given name.
setUniformf(String, float, float) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the uniform with the given name.
setUniformf(String, float, float, float) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the uniform with the given name.
setUniformf(String, float, float, float, float) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the uniform with the given name.
setUniformi(String, int) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the uniform with the given name.
setUniformi(String, int, int) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the uniform with the given name.
setUniformi(String, int, int, int) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the uniform with the given name.
setUniformi(String, int, int, int, int) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the uniform with the given name.
setUniformMatrix(String, Matrix4) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the uniform matrix with the given name.
setUseJni(boolean) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Renderer
setUserData(Object) - Method in class com.badlogic.gdx.physics.box2d.Body
Set the user data
setUserData(Object) - Method in class com.badlogic.gdx.physics.box2d.Fixture
Sets custom user data.
setV(float) - Method in class com.badlogic.gdx.graphics.Sprite
setV(float) - Method in class com.badlogic.gdx.graphics.TextureRegion
setV2(float) - Method in class com.badlogic.gdx.graphics.Sprite
setV2(float) - Method in class com.badlogic.gdx.graphics.TextureRegion
setValue(float) - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue
setVertexAttribute(String, int, int, boolean, int, FloatBuffer) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the vertex attribute with the given name.
setVertexAttribute(String, int, int, boolean, int, int) - Method in class com.badlogic.gdx.graphics.glutils.ShaderProgram
Sets the vertex attribute with the given name.
setVertices(float[], int, int) - Method in class com.badlogic.gdx.graphics.glutils.VertexArray
Sets the vertices of this VertexData, discarding the old vertex data.
setVertices(float[], int, int) - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
Sets the vertices of this VertexData, discarding the old vertex data.
setVertices(float[], int, int) - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Sets the vertices of this VertexData, discarding the old vertex data.
setVertices(float[], int, int) - Method in interface com.badlogic.gdx.graphics.glutils.VertexData
Sets the vertices of this VertexData, discarding the old vertex data.
setVertices(float[]) - Method in class com.badlogic.gdx.graphics.Mesh
Sets the vertices of this Mesh.
setVertices(float[], int, int) - Method in class com.badlogic.gdx.graphics.Mesh
Sets the vertices of this Mesh.
setViewport(float, float) - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Sets the viewport
setViewport(float, float) - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
Sets the viewport dimensions.
setViewport(float, float, boolean) - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Sets the viewport dimensions in device independent pixels.
setVolume(float) - Method in interface com.badlogic.gdx.audio.Music
Sets the volume of this music stream.
setWarmStarting(boolean) - Method in class com.badlogic.gdx.physics.box2d.World
Enable/disable warm starting.
setWidget(Widget) - Method in class com.badlogic.gdx.twl.TWL
Sets the widget in the GUI's root pane.
setWidth(float) - Method in class com.badlogic.gdx.math.Rectangle
Sets the width of this rectangle
setWrap(Texture.TextureWrap, Texture.TextureWrap) - Method in interface com.badlogic.gdx.graphics.Texture
setWrappedText(CharSequence, float, float, float) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Caches a string, which may contain newlines (\n), with the specified position.
setWrappedText(CharSequence, float, float, float, BitmapFont.HAlignment) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Caches a string, which may contain newlines (\n), with the specified position.
setX(float) - Method in class com.badlogic.gdx.math.Rectangle
Sets the x-coordinate of the bottom left corner
setY(float) - Method in class com.badlogic.gdx.math.Rectangle
Sets the y-coordinate of the bottom left corner
shader - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
ShaderProgram - Class in com.badlogic.gdx.graphics.glutils
A shader program encapsulates a vertex and fragment shader pair linked to form a shader program useable with OpenGL ES 2.0.
ShaderProgram(String, String) - Constructor for class com.badlogic.gdx.graphics.glutils.ShaderProgram
Construcs a new JOglShaderProgram and immediatly compiles it.
shape - Variable in class com.badlogic.gdx.physics.box2d.Fixture
the shape, initialized lazy
shape - Variable in class com.badlogic.gdx.physics.box2d.FixtureDef
The shape, this must be set.
Shape - Class in com.badlogic.gdx.physics.box2d
A shape is used for collision detection.
Shape() - Constructor for class com.badlogic.gdx.physics.box2d.Shape
Shape.Type - Enum in com.badlogic.gdx.physics.box2d
Enum describing the type of a shape
shouldCollide(Fixture, Fixture) - Method in interface com.badlogic.gdx.physics.box2d.ContactFilter
show() - Method in interface com.badlogic.gdx.Screen
Called when this screen becomes the current screen for a Game.
shrink() - Method in class com.badlogic.gdx.utils.FloatArray
Reduces the size of the backing array to the size of the actual items.
shrink() - Method in class com.badlogic.gdx.utils.FloatBag
Reduces the size of the backing array to the size of the actual items.
shrink() - Method in class com.badlogic.gdx.utils.IntArray
Reduces the size of the backing array to the size of the actual items.
shrink() - Method in class com.badlogic.gdx.utils.IntBag
Reduces the size of the backing array to the size of the actual items.
shrink() - Method in class com.badlogic.gdx.utils.LongArray
Reduces the size of the backing array to the size of the actual items.
shrink() - Method in class com.badlogic.gdx.utils.LongBag
Reduces the size of the backing array to the size of the actual items.
sin - Static variable in class com.badlogic.gdx.utils.MathUtils
sin(float) - Static method in class com.badlogic.gdx.utils.MathUtils
sinDeg(float) - Static method in class com.badlogic.gdx.utils.MathUtils
size() - Method in class com.badlogic.gdx.graphics.VertexAttributes
size - Variable in class com.badlogic.gdx.utils.FloatArray
size - Variable in class com.badlogic.gdx.utils.FloatBag
size - Variable in class com.badlogic.gdx.utils.IntArray
size - Variable in class com.badlogic.gdx.utils.IntBag
size - Variable in class com.badlogic.gdx.utils.IntHashMap
size - Variable in class com.badlogic.gdx.utils.LongArray
size - Variable in class com.badlogic.gdx.utils.LongBag
size - Variable in class com.badlogic.gdx.utils.LongHashMap
skipBytes(int) - Method in class com.badlogic.gdx.utils.LittleEndianInputStream
skipSamples(int) - Method in interface com.badlogic.gdx.audio.io.Decoder
Skips numSamples samples.
skipSamples(int) - Method in class com.badlogic.gdx.audio.io.Mpg123Decoder
Skips numSamples samples.
skipSamples(int) - Method in class com.badlogic.gdx.audio.io.VorbisDecoder
Skips numSamples samples.
skipTo(char) - Method in class com.badlogic.gdx.utils.json.JSONTokener
Skip characters until the next character is the requested character.
slerp(MD5Quaternion, float) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
slerp(Vector3, float) - Method in class com.badlogic.gdx.math.Vector3
Spherically interpolates between this vector and the target vector by alpha which is in the range [0,1].
sortedKeys() - Method in class com.badlogic.gdx.utils.json.JSONObject
Get an enumeration of the keys of the JSONObject.
Sound - Interface in com.badlogic.gdx.audio
A Sound is a short audio clip that can be played numerous times in parallel.
specSize() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Returns the size of the spectrum created by this transform.
spectralFlux(FloatBuffer, FloatBuffer, int) - Static method in class com.badlogic.gdx.audio.analysis.AudioTools
Calculates the spectral flux between the two given spectra.
spectrum - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
spectrum(ShortBuffer, FloatBuffer) - Method in class com.badlogic.gdx.audio.analysis.KissFFT
Calculates the frequency spectrum of the given samples.
spectrum(FloatBuffer, FloatBuffer, int) - Method in class com.badlogic.gdx.audio.analysis.NativeFFT
Sphere - Class in com.badlogic.gdx.math.collision
Encapsulates a 3D sphere with a center and a radius
Sphere(Vector3, float) - Constructor for class com.badlogic.gdx.math.collision.Sphere
Constructs a sphere with the given center and radius
sphereInFrustum(Vector3, float) - Method in class com.badlogic.gdx.math.Frustum
Returns wheter the given sphere is in the frustum.
sphereInFrustumWithoutNearFar(Vector3, float) - Method in class com.badlogic.gdx.math.Frustum
Returns wheter the given sphere is in the frustum not checking wheter it is behind the near and far clipping plane.
Sprite - Class in com.badlogic.gdx.graphics
Holds the geometry, color, and texture information for drawing 2D sprites using SpriteBatch.
Sprite() - Constructor for class com.badlogic.gdx.graphics.Sprite
Creates an uninitialized sprite.
Sprite(Texture) - Constructor for class com.badlogic.gdx.graphics.Sprite
Creates a sprite with width, height, and texture region equal to the size of the texture.
Sprite(Texture, int, int) - Constructor for class com.badlogic.gdx.graphics.Sprite
Creates a sprite with width, height, and texture region equal to the specified size.
Sprite(Texture, int, int, int, int) - Constructor for class com.badlogic.gdx.graphics.Sprite
Creates a sprite with width, height, and texture region equal to the specified size.
Sprite(TextureRegion) - Constructor for class com.badlogic.gdx.graphics.Sprite
Sprite(TextureRegion, int, int, int, int) - Constructor for class com.badlogic.gdx.graphics.Sprite
Creates a sprite with width, height, and texture region equal to the specified size, relative to specified sprite's texture region.
Sprite(Sprite) - Constructor for class com.badlogic.gdx.graphics.Sprite
Creates a sprite that is a copy in every way of the specified sprite.
SpriteBatch - Class in com.badlogic.gdx.graphics
A SpriteBatch is used to draw 2D rectangles that reference a texture (region).
SpriteBatch() - Constructor for class com.badlogic.gdx.graphics.SpriteBatch
Constructs a new SpriteBatch.
SpriteBatch(int) - Constructor for class com.badlogic.gdx.graphics.SpriteBatch
Constructs a new SpriteBatch.
SpriteBatch(int, int) - Constructor for class com.badlogic.gdx.graphics.SpriteBatch
Constructs a new SpriteBatch.
SpriteCache - Class in com.badlogic.gdx.graphics
Draws 2D images, optimized for geometry that does not change.
SpriteCache() - Constructor for class com.badlogic.gdx.graphics.SpriteCache
Creates a cache that uses indexed geometry and can contain up to 1000 images.
SpriteCache(int, boolean) - Constructor for class com.badlogic.gdx.graphics.SpriteCache
Creates a cache with the specified size, using a default shader if OpenGL ES 2.0 is being used.
SpriteCache(int, ShaderProgram, boolean) - Constructor for class com.badlogic.gdx.graphics.SpriteCache
Creates a cache with the specified size and OpenGL ES 2.0 shader.
Stage - Class in com.badlogic.gdx.scenes.scene2d
A Stage is a container for Actors and handles distributing touch events, animating Actors and asking them to render themselves.
Stage(float, float, boolean) - Constructor for class com.badlogic.gdx.scenes.scene2d.Stage
Constructs a new Stage object with the given dimensions.
standardDeviation() - Method in class com.badlogic.gdx.math.WindowedMean
start() - Method in class com.badlogic.gdx.graphics.particles.ParticleEffect
start() - Method in class com.badlogic.gdx.graphics.particles.ParticleEmitter
startAlpha - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
startAlpha - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
startAlpha - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
startRotation - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
startRotation - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
startScaleX - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
startScaleY - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
startX - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
startX - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
startY - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
startY - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
step(float, int, int) - Method in class com.badlogic.gdx.physics.box2d.World
Take a time step.
stop() - Method in interface com.badlogic.gdx.audio.Music
Stops a playing or paused Music instance.
stop() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglApplication
stop() - Method in class com.badlogic.gdx.backends.lwjgl.LwjglCanvas
stopThread() - Method in class com.badlogic.gdx.utils.PauseableThread
Stops this thread
stringToValue(String) - Static method in class com.badlogic.gdx.utils.json.JSONObject
Try to convert a string into a number, boolean, or null.
sub(Color) - Method in class com.badlogic.gdx.graphics.Color
Subtracts the given color from this color
sub(Vector2) - Method in class com.badlogic.gdx.math.Vector2
Substracts the given vector from this vector.
sub(float, float) - Method in class com.badlogic.gdx.math.Vector2
Substracts the other vector from this vector.
sub(Vector3) - Method in class com.badlogic.gdx.math.Vector3
Subtracts the given vector from this vector
sub(float, float, float) - Method in class com.badlogic.gdx.math.Vector3
Subtracts the other vector from this vector.
sub(float) - Method in class com.badlogic.gdx.math.Vector3
Subtracts the given value from all components of this vector
supportsMultitouch() - Method in interface com.badlogic.gdx.Input
Returns whether multitouch is supported by the device.
supportsOnscreenKeyboard() - Method in interface com.badlogic.gdx.Input
swapActor(int, int) - Method in class com.badlogic.gdx.scenes.scene2d.Group
Swap two actors' sort order by index.
swapActor(Actor, Actor) - Method in class com.badlogic.gdx.scenes.scene2d.Group
Swap two actors' sort order by reference.
syntaxError(String) - Method in class com.badlogic.gdx.utils.json.JSONTokener
Make a JSONException to signal a syntax error.

T

tail - Variable in class com.badlogic.gdx.utils.LocklessThreadQueue
taken - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Delay
taken - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
taken - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
taken - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
taken - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
taken - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
taken - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
taken - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
taken - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
tang - Variable in class com.badlogic.gdx.math.Frustum
target - Variable in class com.badlogic.gdx.physics.box2d.joints.MouseJointDef
The initial world target point.
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeIn
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeOut
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Forever
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateBy
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.RotateTo
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
target - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Sequence
testPoint(Vector3) - Method in class com.badlogic.gdx.math.Plane
Returns on which side the given point lies relative to the plane and its normal.
testPoint(Vector2) - Method in class com.badlogic.gdx.physics.box2d.Fixture
Test a point for containment in this fixture.
texCoord(float, float) - Method in class com.badlogic.gdx.graphics.ImmediateModeRenderer
Specifies the texture coordinates of the current vertex
text - Variable in class com.badlogic.gdx.scenes.scene2d.actors.Label
Texture - Interface in com.badlogic.gdx.graphics
A Texture wraps a standard OpenGL ES texture.
Texture.TextureFilter - Enum in com.badlogic.gdx.graphics
Texture filter enum
Texture.TextureWrap - Enum in com.badlogic.gdx.graphics
Texture wrap enum
TextureAtlas - Class in com.badlogic.gdx.graphics
Loads images from texture atlases created by TexturePacker.

A TextureAtlas must be disposed to free up the resources consumed by the backing textures.
TextureAtlas() - Constructor for class com.badlogic.gdx.graphics.TextureAtlas
Creates an empty atlas to which regions can be added.
TextureAtlas(FileHandle) - Constructor for class com.badlogic.gdx.graphics.TextureAtlas
Loads a pack file named "pack" in the specified directory and also looks there for page images named in the pack file.
TextureAtlas(FileHandle, boolean) - Constructor for class com.badlogic.gdx.graphics.TextureAtlas
TextureAtlas(FileHandle, FileHandle) - Constructor for class com.badlogic.gdx.graphics.TextureAtlas
TextureAtlas(FileHandle, FileHandle, boolean) - Constructor for class com.badlogic.gdx.graphics.TextureAtlas
TextureAtlas.AtlasRegion - Class in com.badlogic.gdx.graphics
Describes the region of a packed image and provides extra information, such as the original image size before any whitespace was stripped.
TextureCoordinates - Static variable in class com.badlogic.gdx.graphics.VertexAttributes.Usage
TextureData - Interface in com.badlogic.gdx.graphics
Loads image data for a texture.
TextureRegion - Class in com.badlogic.gdx.graphics
Defines a rectangular area of a texture.
TextureRegion() - Constructor for class com.badlogic.gdx.graphics.TextureRegion
Constructs a region with no texture and no coordinates defined.
TextureRegion(Texture) - Constructor for class com.badlogic.gdx.graphics.TextureRegion
Constructs a region the size of the specified texture.
TextureRegion(Texture, int, int, int, int) - Constructor for class com.badlogic.gdx.graphics.TextureRegion
TextureRegion(Texture, float, float, float, float) - Constructor for class com.badlogic.gdx.graphics.TextureRegion
TextureRegion(TextureRegion) - Constructor for class com.badlogic.gdx.graphics.TextureRegion
Constructs a region with the same texture and coordinates of the specified region.
TextureRegion(TextureRegion, int, int, int, int) - Constructor for class com.badlogic.gdx.graphics.TextureRegion
Constructs a region with the same texture as the specified region and sets the coordinates relative to the specified region.
ThresholdFunction - Class in com.badlogic.gdx.audio.analysis
Calculates a threshold function based on the spectral flux.
ThresholdFunction(int, float) - Constructor for class com.badlogic.gdx.audio.analysis.ThresholdFunction
Consturctor, sets the history size in number of spectra to take into account to calculate the average spectral flux at a specific position.
times - Variable in class com.badlogic.gdx.scenes.scene2d.actions.Repeat
timeSize - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
timeSize() - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Returns the length of the time domain signal expected by this transform.
tmp - Variable in class com.badlogic.gdx.graphics.PerspectiveCamera
tmp - Variable in class com.badlogic.gdx.math.Matrix4
tmp() - Method in class com.badlogic.gdx.math.Vector2
tmp() - Method in class com.badlogic.gdx.math.Vector3
NEVER EVER SAVE THIS REFERENCE!
tmp2() - Method in class com.badlogic.gdx.math.Vector3
NEVER EVER SAVE THIS REFERENCE!
tmp4 - Variable in class com.badlogic.gdx.scenes.scene2d.Group
toAlpha - Variable in class com.badlogic.gdx.scenes.scene2d.actions.FadeTo
toChildCoordinates(Actor, float, float, Vector2) - Static method in class com.badlogic.gdx.scenes.scene2d.Group
Transforms the coordinates given in the child's parent coordinate system to the child Actor's coordinate system.
toFloatBits(int, int, int, int) - Static method in class com.badlogic.gdx.graphics.Color
Packs the four color components which should be in the range 0-255 into a 32-bit integer and then converts it to a float.
toFloatBits() - Method in class com.badlogic.gdx.graphics.Color
Packs the 4 components of this color into a 32-bit int and returns it as a float.
toFloatBits(float, float, float, float) - Static method in class com.badlogic.gdx.graphics.Color
Packs the 4 components of this color into a 32-bit int and returns it as a float.
toIntBits(int, int, int, int) - Static method in class com.badlogic.gdx.graphics.Color
Packs the four color components which should be in the range 0-255 into a 32-bit.
toIntBits() - Method in class com.badlogic.gdx.graphics.Color
Packs the 4 components of this color into a 32-bit int.
toJSONArray(JSONArray) - Method in class com.badlogic.gdx.utils.json.JSONObject
Produce a JSONArray containing the values of the members of this JSONObject.
toJSONObject(JSONArray) - Method in class com.badlogic.gdx.utils.json.JSONArray
Produce a JSONObject by combining a JSONArray of names with the values of this JSONArray.
toJSONString() - Method in interface com.badlogic.gdx.utils.json.JSONString
The toJSONString method allows a class to produce its own JSON serialization.
toLocalCoordinates(Vector2) - Method in class com.badlogic.gdx.scenes.scene2d.Actor
Transforms the given point in stage coordinates to the Actor's local coordinate system.
top() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
toStageCoordinates(int, int, Vector2) - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Transforms the given screen coordinates to stage coordinates
toString() - Method in class com.badlogic.gdx.files.FileHandle
toString() - Method in class com.badlogic.gdx.graphics.Color
toString() - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
toString() - Method in class com.badlogic.gdx.math.collision.BoundingBox
toString() - Method in class com.badlogic.gdx.math.collision.Ray
toString() - Method in class com.badlogic.gdx.math.Frustum
toString() - Method in class com.badlogic.gdx.math.Matrix3
toString() - Method in class com.badlogic.gdx.math.Matrix4
toString() - Method in class com.badlogic.gdx.math.Plane
toString() - Method in class com.badlogic.gdx.math.Quaternion
toString() - Method in class com.badlogic.gdx.math.Vector2
toString() - Method in class com.badlogic.gdx.math.Vector3
toString() - Method in class com.badlogic.gdx.scenes.scene2d.Actor
toString() - Method in class com.badlogic.gdx.utils.FloatArray
toString() - Method in class com.badlogic.gdx.utils.FloatBag
toString() - Method in class com.badlogic.gdx.utils.IntArray
toString() - Method in class com.badlogic.gdx.utils.IntBag
toString() - Method in class com.badlogic.gdx.utils.IntHashMap.Entry
toString() - Method in class com.badlogic.gdx.utils.IntHashMap
toString() - Method in class com.badlogic.gdx.utils.json.JSONArray
Make a JSON text of this JSONArray.
toString(int) - Method in class com.badlogic.gdx.utils.json.JSONArray
Make a prettyprinted JSON text of this JSONArray.
toString() - Method in class com.badlogic.gdx.utils.json.JSONObject
Make a JSON text of this JSONObject.
toString(int) - Method in class com.badlogic.gdx.utils.json.JSONObject
Make a prettyprinted JSON text of this JSONObject.
toString() - Method in class com.badlogic.gdx.utils.json.JSONStringer
Return the JSON text.
toString() - Method in class com.badlogic.gdx.utils.json.JSONTokener
Make a printable string of this JSONTokener.
toString() - Method in class com.badlogic.gdx.utils.LongArray
toString() - Method in class com.badlogic.gdx.utils.LongBag
toString() - Method in class com.badlogic.gdx.utils.LongHashMap.Entry
toString() - Method in class com.badlogic.gdx.utils.LongHashMap
touchable - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
touchDown(int, int, int) - Method in class com.badlogic.gdx.InputAdapter
touchDown(int, int, int) - Method in class com.badlogic.gdx.InputMultiplexer
touchDown(int, int, int) - Method in interface com.badlogic.gdx.InputProcessor
Called when the screen was touched or a mouse button was pressed.
touchDown(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.Actor
touchDown(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
touchDown(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Button
touchDown(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Image
touchDown(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Label
touchDown(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.Group
touchDown(int, int, int) - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Call this to distribute a touch down event to the stage.
touchDown(int, int, int) - Method in class com.badlogic.gdx.twl.TWL
touchDragged(int, int, int) - Method in class com.badlogic.gdx.InputAdapter
touchDragged(int, int, int) - Method in class com.badlogic.gdx.InputMultiplexer
touchDragged(int, int, int) - Method in interface com.badlogic.gdx.InputProcessor
Called when a finger or the mouse was dragged.
touchDragged(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.Actor
touchDragged(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
touchDragged(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Button
touchDragged(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Image
touchDragged(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Label
touchDragged(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.Group
touchDragged(int, int, int) - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Call this to distribute a touch dragged event to the stage.
touchDragged(int, int, int) - Method in class com.badlogic.gdx.twl.TWL
touchUp(int, int, int) - Method in class com.badlogic.gdx.InputAdapter
touchUp(int, int, int) - Method in class com.badlogic.gdx.InputMultiplexer
touchUp(int, int, int) - Method in interface com.badlogic.gdx.InputProcessor
Called when a finger was lifted or a mouse button was released.
touchUp(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.Actor
touchUp(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
touchUp(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Button
touchUp(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Image
touchUp(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.actors.Label
touchUp(float, float, int) - Method in class com.badlogic.gdx.scenes.scene2d.Group
touchUp(int, int, int) - Method in class com.badlogic.gdx.scenes.scene2d.Stage
Call this to distribute a touch Up event to the stage.
touchUp(int, int, int) - Method in class com.badlogic.gdx.twl.TWL
tra() - Method in class com.badlogic.gdx.math.Matrix4
Transposes the matrix
Transform - Class in com.badlogic.gdx.physics.box2d
Encodes a Box2D transform.
Transform() - Constructor for class com.badlogic.gdx.physics.box2d.Transform
Transform(Vector2, float) - Constructor for class com.badlogic.gdx.physics.box2d.Transform
Constructs a new Transform instance with the given position and angle
transform - Variable in class com.badlogic.gdx.scenes.scene2d.Group
translate(float, float) - Method in class com.badlogic.gdx.graphics.BitmapFontCache
Sets the position of the text, relative to its current position.
translate(float, float) - Method in class com.badlogic.gdx.graphics.Sprite
Sets the position relative to the current position where the sprite will be drawn.
triangulate(List<Vector2>) - Method in class com.badlogic.gdx.math.EarCutTriangulator
Triangulates the list of points and returns an array of Vector3 triples that each form a single triangle.
trn(Vector3) - Method in class com.badlogic.gdx.math.Matrix4
Adds a translational component to the matrix in the 4th column.
trn(float, float, float) - Method in class com.badlogic.gdx.math.Matrix4
Adds a translational component to the matrix in the 4th column.
TWL - Class in com.badlogic.gdx.twl
Convenience class for using TWL.
TWL(String, Files.FileType, Widget) - Constructor for class com.badlogic.gdx.twl.TWL
Creates a new TWL instance with the specified theme file.
TWL(String, Files.FileType) - Constructor for class com.badlogic.gdx.twl.TWL
Creates a new TWL instance with the specified theme file.
TWO_PI - Static variable in class com.badlogic.gdx.audio.analysis.FourierTransform
type - Variable in class com.badlogic.gdx.files.FileHandle
type() - Method in class com.badlogic.gdx.files.FileHandle
type - Variable in class com.badlogic.gdx.physics.box2d.BodyDef
The body type: static, kinematic, or dynamic.
type - Variable in class com.badlogic.gdx.physics.box2d.JointDef
The joint type is set automatically for concrete joint types.

U

unbind() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObject
Unbinds this IndexBufferObject.
unbind() - Method in class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
Unbinds this IndexBufferObject.
unbind() - Method in interface com.badlogic.gdx.graphics.glutils.IndexData
Unbinds this IndexBufferObject.
unbind() - Method in class com.badlogic.gdx.graphics.glutils.VertexArray
unbind() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
Unbinds this VertexData.
unbind(ShaderProgram) - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObject
Unbinds this VertexBufferObject.
unbind() - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Unbinds this VertexData.
unbind(ShaderProgram) - Method in class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Unbinds this VertexBufferObject.
unbind() - Method in interface com.badlogic.gdx.graphics.glutils.VertexData
Unbinds this VertexData.
unbind() - Method in class com.badlogic.gdx.graphics.Mesh
Unbinds the underlying VertexArray/VertexBufferObject and IndexBufferObject is indices were given.
unbind(ShaderProgram) - Method in class com.badlogic.gdx.graphics.Mesh
Unbinds the underlying VertexBufferObject and IndexBufferObject is indices were given.
unpressedRegion - Variable in class com.badlogic.gdx.scenes.scene2d.actors.Button
update(float) - Method in class com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo
update() - Method in class com.badlogic.gdx.graphics.OrthographicCamera
Updates the frustum as well as the matrices of the camera based on the near and far plane, the position, the side and the scale.
update() - Method in class com.badlogic.gdx.graphics.PerspectiveCamera
Updates all matrices as well as the Frustum based on the last set parameters for position, direction, up vector, field of view, near and far plane and viewport.
updateCorners() - Method in class com.badlogic.gdx.math.collision.BoundingBox
updateTransform() - Method in class com.badlogic.gdx.scenes.scene2d.Group
upperAngle - Variable in class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
The upper angle for the joint limit (radians).
upperTranslation - Variable in class com.badlogic.gdx.physics.box2d.joints.LineJointDef
The upper translation limit, usually in meters.
upperTranslation - Variable in class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
The upper translation limit, usually in meters.
usage - Variable in class com.badlogic.gdx.graphics.VertexAttribute
the attribute VertexAttributes.Usage
userData - Variable in class com.badlogic.gdx.physics.box2d.Fixture
user specified data

V

val - Variable in class com.badlogic.gdx.math.Matrix4
vals - Variable in class com.badlogic.gdx.physics.box2d.Transform
value - Variable in class com.badlogic.gdx.utils.IntHashMap.Entry
value(boolean) - Method in class com.badlogic.gdx.utils.json.JSONWriter
Append either the value true or the value false.
value(double) - Method in class com.badlogic.gdx.utils.json.JSONWriter
Append a double value.
value(long) - Method in class com.badlogic.gdx.utils.json.JSONWriter
Append a long value.
value(Object) - Method in class com.badlogic.gdx.utils.json.JSONWriter
Append an object value.
value - Variable in class com.badlogic.gdx.utils.LongHashMap.Entry
valueOf(String) - Static method in enum com.badlogic.gdx.Application.ApplicationType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.Files.FileType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.graphics.BitmapFont.HAlignment
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.Graphics.GraphicsType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.graphics.Mesh.VertexDataType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.graphics.OrthographicCamera.Side
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnEllipseSide
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShape
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.graphics.Pixmap.Format
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.graphics.Texture.TextureFilter
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.graphics.Texture.TextureWrap
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.math.Plane.PlaneSide
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.physics.box2d.BodyDef.BodyType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.physics.box2d.JointDef.JointType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.physics.box2d.Shape.Type
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.badlogic.gdx.scenes.scene2d.actors.LinearGroup.LinearGroupLayout
Returns the enum constant of this type with the specified name.
values() - Static method in enum com.badlogic.gdx.Application.ApplicationType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.Files.FileType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.graphics.BitmapFont.HAlignment
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.Graphics.GraphicsType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.graphics.Mesh.VertexDataType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.graphics.OrthographicCamera.Side
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnEllipseSide
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShape
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.graphics.Pixmap.Format
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.graphics.Texture.TextureFilter
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.graphics.Texture.TextureWrap
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.math.Plane.PlaneSide
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.physics.box2d.BodyDef.BodyType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.physics.box2d.JointDef.JointType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.physics.box2d.Shape.Type
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.badlogic.gdx.scenes.scene2d.actors.LinearGroup.LinearGroupLayout
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class com.badlogic.gdx.utils.IntHashMap
Returns an iterator for the values in the map.
values() - Method in class com.badlogic.gdx.utils.LongHashMap
Returns an iterator for the values in the map.
valueTypes - Static variable in enum com.badlogic.gdx.physics.box2d.JointDef.JointType
Vector2 - Class in com.badlogic.gdx.math
Encapsulates a 2D vector.
Vector2() - Constructor for class com.badlogic.gdx.math.Vector2
Constructs a new vector at (0,0)
Vector2(float, float) - Constructor for class com.badlogic.gdx.math.Vector2
Constructs a vector with the given components
Vector2(Vector2) - Constructor for class com.badlogic.gdx.math.Vector2
Constructs a vector from the given vector
Vector3 - Class in com.badlogic.gdx.math
Encapsulates a 3D vector.
Vector3() - Constructor for class com.badlogic.gdx.math.Vector3
Constructs a vector at (0,0,0)
Vector3(float, float, float) - Constructor for class com.badlogic.gdx.math.Vector3
Creates a vector with the given components
Vector3(Vector3) - Constructor for class com.badlogic.gdx.math.Vector3
Creates a vector from the given vector
Vector3(float[]) - Constructor for class com.badlogic.gdx.math.Vector3
Creates a vector from the given array.
Version - Class in com.badlogic.gdx
The version of libgdx
Version() - Constructor for class com.badlogic.gdx.Version
VERSION - Static variable in class com.badlogic.gdx.Version
the current version of libgdx in the major.minor format
vertex(float, float, float) - Method in class com.badlogic.gdx.graphics.ImmediateModeRenderer
Specifies the position of the current vertex and finalizes it.
VertexArray - Class in com.badlogic.gdx.graphics.glutils
Convenience class for working with OpenGL vertex arrays.
VertexArray(int, VertexAttribute...) - Constructor for class com.badlogic.gdx.graphics.glutils.VertexArray
Constructs a new interleaved VertexArray
VertexAttribute - Class in com.badlogic.gdx.graphics
A single vertex attribute defined by its VertexAttributes.Usage, its number of components and its shader alias.
VertexAttribute(int, int, String) - Constructor for class com.badlogic.gdx.graphics.VertexAttribute
Constructs a new VertexAttribute.
VertexAttributes - Class in com.badlogic.gdx.graphics
Instances of this class specify the vertex attributes of a mesh.
VertexAttributes(VertexAttribute...) - Constructor for class com.badlogic.gdx.graphics.VertexAttributes
Constructor, sets the vertex attributes in a specific order
VertexAttributes.Usage - Class in com.badlogic.gdx.graphics
The usage of a vertex attribute.
VertexAttributes.Usage() - Constructor for class com.badlogic.gdx.graphics.VertexAttributes.Usage
VertexBufferObject - Class in com.badlogic.gdx.graphics.glutils
A VertexData implementation based on OpenGL vertex buffer objects.
VertexBufferObject(boolean, int, VertexAttribute...) - Constructor for class com.badlogic.gdx.graphics.glutils.VertexBufferObject
Constructs a new interleaved VertexBufferObject.
VertexBufferObjectSubData - Class in com.badlogic.gdx.graphics.glutils
A VertexData implementation based on OpenGL vertex buffer objects.
VertexBufferObjectSubData(boolean, int, VertexAttribute...) - Constructor for class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
Constructs a new interleaved VertexBufferObject.
VertexData - Interface in com.badlogic.gdx.graphics.glutils
A VertexData instance holds vertices for rendering with OpenGL.
vertexSize - Variable in class com.badlogic.gdx.graphics.VertexAttributes
the size of a single vertex in bytes
vertices - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
s, t, start, count
VorbisDecoder - Class in com.badlogic.gdx.audio.io
A Decoder implementation that decodes OGG Vorbis files using tremor
VorbisDecoder(String) - Constructor for class com.badlogic.gdx.audio.io.VorbisDecoder
Opens the given file for ogg decoding.

W

w - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
w - Variable in class com.badlogic.gdx.math.Quaternion
weights - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
joint, bias, pos.x, pos.y, pos.z
WeldJoint - Class in com.badlogic.gdx.physics.box2d.joints
A weld joint essentially glues two bodies together.
WeldJoint(World, long) - Constructor for class com.badlogic.gdx.physics.box2d.joints.WeldJoint
WeldJointDef - Class in com.badlogic.gdx.physics.box2d.joints
WeldJointDef() - Constructor for class com.badlogic.gdx.physics.box2d.joints.WeldJointDef
whichAverage - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
whichWindow - Variable in class com.badlogic.gdx.audio.analysis.FourierTransform
WHITE - Static variable in class com.badlogic.gdx.graphics.Color
width - Variable in class com.badlogic.gdx.graphics.BitmapFont.TextBounds
width - Variable in class com.badlogic.gdx.scenes.scene2d.Actor
width() - Method in class com.badlogic.gdx.scenes.scene2d.Stage
window(int) - Method in class com.badlogic.gdx.audio.analysis.FourierTransform
Sets the window to use on the samples before taking the forward transform.
WindowedMean - Class in com.badlogic.gdx.math
A simple class keeping track of the mean of a stream of values within a certain window.
WindowedMean(int) - Constructor for class com.badlogic.gdx.math.WindowedMean
constructor, window_size specifies the number of samples we will continuously get the mean and variance from.
world - Variable in class com.badlogic.gdx.physics.box2d.Contact
the world
World - Class in com.badlogic.gdx.physics.box2d
The world class manages all physics entities, dynamic simulation, and asynchronous queries.
World(Vector2, boolean) - Constructor for class com.badlogic.gdx.physics.box2d.World
Construct a world object.
worldManifold - Variable in class com.badlogic.gdx.physics.box2d.Contact
the world manifold
WorldManifold - Class in com.badlogic.gdx.physics.box2d
This is used to compute the current state of a contact manifold.
WorldManifold() - Constructor for class com.badlogic.gdx.physics.box2d.WorldManifold
write(boolean) - Method in class com.badlogic.gdx.files.FileHandle
Returns a stream for writing to this file.
write(boolean) - Method in class com.badlogic.gdx.files.FileHandleStream
write(Writer) - Method in class com.badlogic.gdx.utils.json.JSONArray
Write the contents of the JSONArray as JSON text to a writer.
write(Writer) - Method in class com.badlogic.gdx.utils.json.JSONObject
Write the contents of the JSONObject as JSON text to a writer.
writer - Variable in class com.badlogic.gdx.utils.json.JSONWriter
The writer that will receive the output.
writeSamples(short[], int, int) - Method in interface com.badlogic.gdx.audio.AudioDevice
Writes the array of 16-bit signed PCM samples to the audio device and blocks until they have been processed.
writeSamples(float[], int, int) - Method in interface com.badlogic.gdx.audio.AudioDevice
Writes the array of float PCM samples to the audio device and blocks until they have been processed.

X

x - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
x - Variable in class com.badlogic.gdx.math.Quaternion
x - Variable in class com.badlogic.gdx.math.Vector2
the x-component of this vector
x - Variable in class com.badlogic.gdx.math.Vector3
the x-component of this vector
x - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
x - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
x - Variable in class com.badlogic.gdx.scenes.scene2d.Actor

Y

y - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
y - Variable in class com.badlogic.gdx.math.Quaternion
y - Variable in class com.badlogic.gdx.math.Vector2
the y-component of this vector
y - Variable in class com.badlogic.gdx.math.Vector3
the x-component of this vector
y - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveBy
y - Variable in class com.badlogic.gdx.scenes.scene2d.actions.MoveTo
y - Variable in class com.badlogic.gdx.scenes.scene2d.Actor

Z

z - Variable in class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
z - Variable in class com.badlogic.gdx.math.Quaternion
z - Variable in class com.badlogic.gdx.math.Vector3
the x-component of this vector
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Overview Package Class Use Tree Deprecated Index Help
libgdx API


IndexBufferObject (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.glutils
Class IndexBufferObject

java.lang.Object
    extended by  com.badlogic.gdx.graphics.glutils.IndexBufferObject
All Implemented Interfaces:
IndexData
public class IndexBufferObject
extends java.lang.Object
implements IndexData

In IndexBufferObject wraps OpenGL's index buffer functionality to be used in conjunction with VBOs. This class can be seamlessly used with OpenGL ES 1.x and 2.0.

Uses indirect Buffers on Android 1.5/1.6 to fix GC invocation due to leaking PlatformAddress instances.

You can also use this to store indices for vertex arrays. Do not call bind() or unbind() in this case but rather use getBuffer() to use the buffer directly with glDrawElements. You must also create the IndexBufferObject with the second constructor and specify isDirect as true as glDrawElements in conjunction with vertex arrays needs direct buffers.

VertexBufferObjects must be disposed via the dispose() method when no longer needed

Author:
mzechner

Constructor Summary
IndexBufferObject(boolean isStatic, int maxIndices)
Creates a new IndexBufferObject.
IndexBufferObject(int maxIndices)
Creates a new IndexBufferObject to be used with vertex arrays.
Method Summary
void | bind() Binds this IndexBufferObject for rendering with glDrawElements.
void | dispose() Disposes this IndexBufferObject and all its associated OpenGL resources.
java.nio.ShortBuffer | getBuffer() Returns the underlying ShortBuffer.
int | getNumIndices()
int | getNumMaxIndices()
void | invalidate() Invalidates the IndexBufferObject so a new OpenGL buffer handle is created.
void | setIndices(short[] indices, int offset, int count) Sets the indices of this IndexBufferObject, discarding the old indices.
void | unbind() Unbinds this IndexBufferObject.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IndexBufferObject

public IndexBufferObject(boolean isStatic,
                         int maxIndices)
Creates a new IndexBufferObject.

Parameters:
isStatic - whether the index buffer is static
maxIndices - the maximum number of indices this buffer can hold

IndexBufferObject

public IndexBufferObject(int maxIndices)
Creates a new IndexBufferObject to be used with vertex arrays.

Parameters:
maxIndices - the maximum number of indices this buffer can hold
Method Detail

getNumIndices

public int getNumIndices()
Specified by:
getNumIndices in interface IndexData
Returns:
the number of indices currently stored in this buffer

getNumMaxIndices

public int getNumMaxIndices()
Specified by:
getNumMaxIndices in interface IndexData
Returns:
the maximum number of indices this IndexBufferObject can store.

setIndices

public void setIndices(short[] indices,
                       int offset,
                       int count)

Sets the indices of this IndexBufferObject, discarding the old indices. The count must equal the number of indices to be copied to this IndexBufferObject.

This can be called in between calls to bind() and unbind(). The index data will be updated instantly.

Specified by:
setIndices in interface IndexData
Parameters:
indices - the vertex data
offset - the offset to start copying the data from
count - the number of floats to copy

getBuffer

public java.nio.ShortBuffer getBuffer()

Returns the underlying ShortBuffer. If you modify the buffer contents they wil be uploaded on the call to bind(). If you need immediate uploading use setIndices(short[], int, int).

Specified by:
getBuffer in interface IndexData
Returns:
the underlying short buffer.

bind

public void bind()
Binds this IndexBufferObject for rendering with glDrawElements.

Specified by:
bind in interface IndexData

unbind

public void unbind()
Unbinds this IndexBufferObject.

Specified by:
unbind in interface IndexData

invalidate

public void invalidate()
Invalidates the IndexBufferObject so a new OpenGL buffer handle is created. Use this in case of a context loss.

Specified by:
invalidate in interface IndexData

dispose

public void dispose()
Disposes this IndexBufferObject and all its associated OpenGL resources.

Specified by:
dispose in interface IndexData
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.glutils.IndexBufferObject (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.glutils.IndexBufferObject

No usage of com.badlogic.gdx.graphics.glutils.IndexBufferObject

Overview Package Class Use Tree Deprecated Index Help
libgdx API


IndexBufferObjectSubData (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.glutils
Class IndexBufferObjectSubData

java.lang.Object
    extended by  com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData
All Implemented Interfaces:
IndexData
public class IndexBufferObjectSubData
extends java.lang.Object
implements IndexData

In IndexBufferObject wraps OpenGL's index buffer functionality to be used in conjunction with VBOs. This class can be seamlessly used with OpenGL ES 1.x and 2.0.

Uses indirect Buffers on Android 1.5/1.6 to fix GC invocation due to leaking PlatformAddress instances.

You can also use this to store indices for vertex arrays. Do not call bind() or unbind() in this case but rather use getBuffer() to use the buffer directly with glDrawElements. You must also create the IndexBufferObject with the second constructor and specify isDirect as true as glDrawElements in conjunction with vertex arrays needs direct buffers.

VertexBufferObjects must be disposed via the dispose() method when no longer needed

Author:
mzechner

Constructor Summary
IndexBufferObjectSubData(boolean isStatic, int maxIndices)
Creates a new IndexBufferObject.
IndexBufferObjectSubData(int maxIndices)
Creates a new IndexBufferObject to be used with vertex arrays.
Method Summary
void | bind() Binds this IndexBufferObject for rendering with glDrawElements.
void | dispose() Disposes this IndexBufferObject and all its associated OpenGL resources.
java.nio.ShortBuffer | getBuffer() Returns the underlying ShortBuffer.
int | getNumIndices()
int | getNumMaxIndices()
void | invalidate() Invalidates the IndexBufferObject so a new OpenGL buffer handle is created.
void | setIndices(short[] indices, int offset, int count) Sets the indices of this IndexBufferObject, discarding the old indices.
void | unbind() Unbinds this IndexBufferObject.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IndexBufferObjectSubData

public IndexBufferObjectSubData(boolean isStatic,
                                int maxIndices)
Creates a new IndexBufferObject.

Parameters:
isStatic - whether the index buffer is static
maxIndices - the maximum number of indices this buffer can hold

IndexBufferObjectSubData

public IndexBufferObjectSubData(int maxIndices)
Creates a new IndexBufferObject to be used with vertex arrays.

Parameters:
maxIndices - the maximum number of indices this buffer can hold
Method Detail

getNumIndices

public int getNumIndices()
Specified by:
getNumIndices in interface IndexData
Returns:
the number of indices currently stored in this buffer

getNumMaxIndices

public int getNumMaxIndices()
Specified by:
getNumMaxIndices in interface IndexData
Returns:
the maximum number of indices this IndexBufferObject can store.

setIndices

public void setIndices(short[] indices,
                       int offset,
                       int count)

Sets the indices of this IndexBufferObject, discarding the old indices. The count must equal the number of indices to be copied to this IndexBufferObject.

This can be called in between calls to bind() and unbind(). The index data will be updated instantly.

Specified by:
setIndices in interface IndexData
Parameters:
indices - the vertex data
offset - the offset to start copying the data from
count - the number of floats to copy

getBuffer

public java.nio.ShortBuffer getBuffer()

Returns the underlying ShortBuffer. If you modify the buffer contents they wil be uploaded on the call to bind(). If you need immediate uploading use setIndices(short[], int, int).

Specified by:
getBuffer in interface IndexData
Returns:
the underlying short buffer.

bind

public void bind()
Binds this IndexBufferObject for rendering with glDrawElements.

Specified by:
bind in interface IndexData

unbind

public void unbind()
Unbinds this IndexBufferObject.

Specified by:
unbind in interface IndexData

invalidate

public void invalidate()
Invalidates the IndexBufferObject so a new OpenGL buffer handle is created. Use this in case of a context loss.

Specified by:
invalidate in interface IndexData

dispose

public void dispose()
Disposes this IndexBufferObject and all its associated OpenGL resources.

Specified by:
dispose in interface IndexData
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData

No usage of com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData

Overview Package Class Use Tree Deprecated Index Help
libgdx API


IndexData (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.glutils
Interface IndexData

All Known Implementing Classes:
IndexBufferObject, IndexBufferObjectSubData
public interface IndexData

An IndexData instance holds index data. Can be either a plain short buffer or an OpenGL buffer object.

Author:
mzechner

Method Summary
void | bind() Binds this IndexBufferObject for rendering with glDrawElements.
void | dispose() Disposes this IndexDatat and all its associated OpenGL resources.
java.nio.ShortBuffer | getBuffer() Returns the underlying ShortBuffer.
int | getNumIndices()
int | getNumMaxIndices()
void | invalidate() Invalidates the IndexBufferObject so a new OpenGL buffer handle is created.
void | setIndices(short[] indices, int offset, int count) Sets the indices of this IndexBufferObject, discarding the old indices.
void | unbind() Unbinds this IndexBufferObject.

Method Detail

getNumIndices

int getNumIndices()
Returns:
the number of indices currently stored in this buffer

getNumMaxIndices

int getNumMaxIndices()
Returns:
the maximum number of indices this IndexBufferObject can store.

setIndices

void setIndices(short[] indices,
                int offset,
                int count)

Sets the indices of this IndexBufferObject, discarding the old indices. The count must equal the number of indices to be copied to this IndexBufferObject.

This can be called in between calls to bind() and unbind(). The index data will be updated instantly.

Parameters:
indices - the vertex data
offset - the offset to start copying the data from
count - the number of floats to copy

getBuffer

java.nio.ShortBuffer getBuffer()

Returns the underlying ShortBuffer. If you modify the buffer contents they wil be uploaded on the call to bind(). If you need immediate uploading use setIndices(short[], int, int).

Returns:
the underlying short buffer.

bind

void bind()
Binds this IndexBufferObject for rendering with glDrawElements.

unbind

void unbind()
Unbinds this IndexBufferObject.

invalidate

void invalidate()
Invalidates the IndexBufferObject so a new OpenGL buffer handle is created. Use this in case of a context loss.

dispose

void dispose()
Disposes this IndexDatat and all its associated OpenGL resources.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.graphics.glutils.IndexData (libgdx API)

Uses of Interface
com.badlogic.gdx.graphics.glutils.IndexData

Packages that use IndexData
com.badlogic.gdx.graphics.glutils

Uses of IndexData in com.badlogic.gdx.graphics.glutils

Classes in com.badlogic.gdx.graphics.glutils that implement IndexData
class | IndexBufferObject In IndexBufferObject wraps OpenGL's index buffer functionality to be used in conjunction with VBOs.
class | IndexBufferObjectSubData In IndexBufferObject wraps OpenGL's index buffer functionality to be used in conjunction with VBOs.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Input (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Interface Input

public interface Input

Interface to the input facilities. This allows to poll the state of the keyboard, touch screen and accelerometer. On the desktop the touch screen is replaced by mouse input, the accelerometer is of course not available.

Additionally one can process events with an InputProcessor with this module. You can set the InputProcessor via the setInputProcessor(InputProcessor) method. It will be called before the ApplicationListener.render() method in each frame.

Keyboard keys are translated to the constants in Input.Keys transparantely on all systems. Do not use system specific key constants.

Author:
mzechner

Nested Class Summary
static class | Input.Keys Keys.
static interface | Input.TextInputListener Callback interface for getTextInput(TextInputListener, String, String)
Method Summary
float | getAccelerometerX()
float | getAccelerometerY()
float | getAccelerometerZ()
void | getTextInput(Input.TextInputListener listener, java.lang.String title, java.lang.String text) System dependent method to input a string of text.
int | getX()
int | getX(int pointer) Returns the x coordinate in screen coordinates of the given pointer.
int | getY()
int | getY(int pointer) Returns the y coordinate in screen coordinates of the given pointer.
boolean | isAccelerometerAvailable()
boolean | isKeyPressed(int key) Returns whether the key is pressed.
boolean | isTouched()
boolean | isTouched(int pointer) Whether the screen is currently touched by the pointer with the given index.
void | setCatchBackKey(boolean catchBack) Sets whether the BACK button on Android should be caught.
void | setInputProcessor(InputProcessor processor) Sets the InputProcessor that will receive all touch and key input events.
void | setOnscreenKeyboardVisible(boolean visible) Sets the on-screen keyboard visible if available.
boolean | supportsMultitouch() Returns whether multitouch is supported by the device.
boolean | supportsOnscreenKeyboard()

Method Detail

isAccelerometerAvailable

boolean isAccelerometerAvailable()
Returns:
whether an accelerometer is available

getAccelerometerX

float getAccelerometerX()
Returns:
The value of the accelerometer on its x-axis. ranges between [-10,10].

getAccelerometerY

float getAccelerometerY()
Returns:
The value of the accelerometer on its y-axis. ranges between [-10,10].

getAccelerometerZ

float getAccelerometerZ()
Returns:
The value of the accelerometer on its y-axis. ranges between [-10,10].

getX

int getX()
Returns:
the last touch x coordinate in screen coordinates. The screen origin is the top left corner.

getX

int getX(int pointer)
Returns the x coordinate in screen coordinates of the given pointer. Pointers are indexed from 0 to n. The pointer id identifies the order in which the fingers went down on the screen, e.g. 0 is the first finger, 1 is the second and so on. When two fingers are touched down and the first one is lifted the second one keeps its index. If another finger is placed on the touch screen the first free index will be used.

Parameters:
pointer - the pointer id.
Returns:
the x coordinate

getY

int getY()
Returns:
the last touch y coordinate in screen coordinates. The screen origin is the top left corner.

getY

int getY(int pointer)
Returns the y coordinate in screen coordinates of the given pointer. Pointers are indexed from 0 to n. The pointer id identifies the order in which the fingers went down on the screen, e.g. 0 is the first finger, 1 is the second and so on. When two fingers are touched down and the first one is lifted the second one keeps its index. If another finger is placed on the touch screen the first free index will be used.

Parameters:
pointer - the pointer id.
Returns:
the y coordinate

isTouched

boolean isTouched()
Returns:
whether the screen is currently touched.

isTouched

boolean isTouched(int pointer)
Whether the screen is currently touched by the pointer with the given index. Pointers are indexed from 0 to n. The pointer id identifies the order in which the fingers went down on the screen, e.g. 0 is the first finger, 1 is the second and so on. When two fingers are touched down and the first one is lifted the second one keeps its index. If another finger is placed on the touch screen the first free index will be used.

Parameters:
pointer - the pointer
Returns:
whether the screen is touched by the pointer

isKeyPressed

boolean isKeyPressed(int key)
Returns whether the key is pressed.

Parameters:
key - The key code as found in Input.Keys.
Returns:
true or false.

getTextInput

void getTextInput(Input.TextInputListener listener,
                  java.lang.String title,
                  java.lang.String text)
System dependent method to input a string of text. A dialog box will be created with the given title and the given text as a message for the user. Once the dialog has been closed the provided Input.TextInputListener will be called but not necessarily in the rendering thread in which all the ApplicationListener methods are called. You have to synchronize this yourself.

Parameters:
listener - The TextInputListener.
title - The title of the text input dialog.
text - The message presented to the user.

setOnscreenKeyboardVisible

void setOnscreenKeyboardVisible(boolean visible)
Sets the on-screen keyboard visible if available.

Parameters:
visible - visible or not

supportsOnscreenKeyboard

boolean supportsOnscreenKeyboard()
Returns:
whether an on-screen keyboard is available or not

supportsMultitouch

boolean supportsMultitouch()
Returns whether multitouch is supported by the device. Note that this also includes the "broken" multitouch on the Droid or Nexus One!

Returns:
whether multitouch is supported

setCatchBackKey

void setCatchBackKey(boolean catchBack)
Sets whether the BACK button on Android should be caught. This will prevent the app from being paused. Will have no effect on the desktop.

Parameters:
catchBack - whether to catch the back button

setInputProcessor

void setInputProcessor(InputProcessor processor)
Sets the InputProcessor that will receive all touch and key input events. It will be called before the ApplicationListener.render() method each frame.

Parameters:
processor - the InputProcessor
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.Input (libgdx API)

Uses of Interface
com.badlogic.gdx.Input

Packages that use Input
com.badlogic.gdx
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl

Uses of Input in com.badlogic.gdx

Fields in com.badlogic.gdx declared as Input
static Input Gdx.input

Methods in com.badlogic.gdx that return Input
 Input Application.getInput()

Uses of Input in com.badlogic.gdx.backends.android

Methods in com.badlogic.gdx.backends.android that return Input
 Input AndroidApplication.getInput()

Uses of Input in com.badlogic.gdx.backends.jogl

Methods in com.badlogic.gdx.backends.jogl that return Input
 Input JoglApplication.getInput()

Uses of Input in com.badlogic.gdx.backends.lwjgl

Methods in com.badlogic.gdx.backends.lwjgl that return Input
Input | LwjglApplication.getInput()
Input | LwjglCanvas.getInput()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Input.Keys (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Class Input.Keys

java.lang.Object
    extended by  com.badlogic.gdx.Input.Keys
Enclosing interface:
Input
public static class Input.Keys
extends java.lang.Object

Keys.

Author:
mzechner

Field Summary
static int | ANY_KEY
static int | KEYCODE_0
static int | KEYCODE_1
static int | KEYCODE_2
static int | KEYCODE_3
static int | KEYCODE_4
static int | KEYCODE_5
static int | KEYCODE_6
static int | KEYCODE_7
static int | KEYCODE_8
static int | KEYCODE_9
static int | KEYCODE_A
static int | KEYCODE_ALT_LEFT
static int | KEYCODE_ALT_RIGHT
static int | KEYCODE_APOSTROPHE
static int | KEYCODE_AT
static int | KEYCODE_B
static int | KEYCODE_BACK
static int | KEYCODE_BACKSLASH
static int | KEYCODE_C
static int | KEYCODE_CALL
static int | KEYCODE_CAMERA
static int | KEYCODE_CLEAR
static int | KEYCODE_COMMA
static int | KEYCODE_D
static int | KEYCODE_DEL
static int | KEYCODE_DPAD_CENTER
static int | KEYCODE_DPAD_DOWN
static int | KEYCODE_DPAD_LEFT
static int | KEYCODE_DPAD_RIGHT
static int | KEYCODE_DPAD_UP
static int | KEYCODE_E
static int | KEYCODE_ENDCALL
static int | KEYCODE_ENTER
static int | KEYCODE_ENVELOPE
static int | KEYCODE_EQUALS
static int | KEYCODE_EXPLORER
static int | KEYCODE_F
static int | KEYCODE_FOCUS
static int | KEYCODE_G
static int | KEYCODE_GRAVE
static int | KEYCODE_H
static int | KEYCODE_HEADSETHOOK
static int | KEYCODE_HOME
static int | KEYCODE_I
static int | KEYCODE_J
static int | KEYCODE_K
static int | KEYCODE_L
static int | KEYCODE_LEFT_BRACKET
static int | KEYCODE_M
static int | KEYCODE_MEDIA_FAST_FORWARD
static int | KEYCODE_MEDIA_NEXT
static int | KEYCODE_MEDIA_PLAY_PAUSE
static int | KEYCODE_MEDIA_PREVIOUS
static int | KEYCODE_MEDIA_REWIND
static int | KEYCODE_MEDIA_STOP
static int | KEYCODE_MENU
static int | KEYCODE_MINUS
static int | KEYCODE_MUTE
static int | KEYCODE_N
static int | KEYCODE_NOTIFICATION
static int | KEYCODE_NUM
static int | KEYCODE_O
static int | KEYCODE_P
static int | KEYCODE_PERIOD
static int | KEYCODE_PLUS
static int | KEYCODE_POUND
static int | KEYCODE_POWER
static int | KEYCODE_Q
static int | KEYCODE_R
static int | KEYCODE_RIGHT_BRACKET
static int | KEYCODE_S
static int | KEYCODE_SEARCH
static int | KEYCODE_SEMICOLON
static int | KEYCODE_SHIFT_LEFT
static int | KEYCODE_SHIFT_RIGHT
static int | KEYCODE_SLASH
static int | KEYCODE_SOFT_LEFT
static int | KEYCODE_SOFT_RIGHT
static int | KEYCODE_SPACE
static int | KEYCODE_STAR
static int | KEYCODE_SYM
static int | KEYCODE_T
static int | KEYCODE_TAB
static int | KEYCODE_U
static int | KEYCODE_UNKNOWN
static int | KEYCODE_V
static int | KEYCODE_VOLUME_DOWN
static int | KEYCODE_VOLUME_UP
static int | KEYCODE_W
static int | KEYCODE_X
static int | KEYCODE_Y
static int | KEYCODE_Z
static int | META_ALT_LEFT_ON
static int | META_ALT_ON
static int | META_ALT_RIGHT_ON
static int | META_SHIFT_LEFT_ON
static int | META_SHIFT_ON
static int | META_SHIFT_RIGHT_ON
static int | META_SYM_ON
Constructor Summary
Input.Keys()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ANY_KEY

public static final int ANY_KEY
See Also:
Constant Field Values

KEYCODE_0

public static final int KEYCODE_0
See Also:
Constant Field Values

KEYCODE_1

public static final int KEYCODE_1
See Also:
Constant Field Values

KEYCODE_2

public static final int KEYCODE_2
See Also:
Constant Field Values

KEYCODE_3

public static final int KEYCODE_3
See Also:
Constant Field Values

KEYCODE_4

public static final int KEYCODE_4
See Also:
Constant Field Values

KEYCODE_5

public static final int KEYCODE_5
See Also:
Constant Field Values

KEYCODE_6

public static final int KEYCODE_6
See Also:
Constant Field Values

KEYCODE_7

public static final int KEYCODE_7
See Also:
Constant Field Values

KEYCODE_8

public static final int KEYCODE_8
See Also:
Constant Field Values

KEYCODE_9

public static final int KEYCODE_9
See Also:
Constant Field Values

KEYCODE_A

public static final int KEYCODE_A
See Also:
Constant Field Values

KEYCODE_ALT_LEFT

public static final int KEYCODE_ALT_LEFT
See Also:
Constant Field Values

KEYCODE_ALT_RIGHT

public static final int KEYCODE_ALT_RIGHT
See Also:
Constant Field Values

KEYCODE_APOSTROPHE

public static final int KEYCODE_APOSTROPHE
See Also:
Constant Field Values

KEYCODE_AT

public static final int KEYCODE_AT
See Also:
Constant Field Values

KEYCODE_B

public static final int KEYCODE_B
See Also:
Constant Field Values

KEYCODE_BACK

public static final int KEYCODE_BACK
See Also:
Constant Field Values

KEYCODE_BACKSLASH

public static final int KEYCODE_BACKSLASH
See Also:
Constant Field Values

KEYCODE_C

public static final int KEYCODE_C
See Also:
Constant Field Values

KEYCODE_CALL

public static final int KEYCODE_CALL
See Also:
Constant Field Values

KEYCODE_CAMERA

public static final int KEYCODE_CAMERA
See Also:
Constant Field Values

KEYCODE_CLEAR

public static final int KEYCODE_CLEAR
See Also:
Constant Field Values

KEYCODE_COMMA

public static final int KEYCODE_COMMA
See Also:
Constant Field Values

KEYCODE_D

public static final int KEYCODE_D
See Also:
Constant Field Values

KEYCODE_DEL

public static final int KEYCODE_DEL
See Also:
Constant Field Values

KEYCODE_DPAD_CENTER

public static final int KEYCODE_DPAD_CENTER
See Also:
Constant Field Values

KEYCODE_DPAD_DOWN

public static final int KEYCODE_DPAD_DOWN
See Also:
Constant Field Values

KEYCODE_DPAD_LEFT

public static final int KEYCODE_DPAD_LEFT
See Also:
Constant Field Values

KEYCODE_DPAD_RIGHT

public static final int KEYCODE_DPAD_RIGHT
See Also:
Constant Field Values

KEYCODE_DPAD_UP

public static final int KEYCODE_DPAD_UP
See Also:
Constant Field Values

KEYCODE_E

public static final int KEYCODE_E
See Also:
Constant Field Values

KEYCODE_ENDCALL

public static final int KEYCODE_ENDCALL
See Also:
Constant Field Values

KEYCODE_ENTER

public static final int KEYCODE_ENTER
See Also:
Constant Field Values

KEYCODE_ENVELOPE

public static final int KEYCODE_ENVELOPE
See Also:
Constant Field Values

KEYCODE_EQUALS

public static final int KEYCODE_EQUALS
See Also:
Constant Field Values

KEYCODE_EXPLORER

public static final int KEYCODE_EXPLORER
See Also:
Constant Field Values

KEYCODE_F

public static final int KEYCODE_F
See Also:
Constant Field Values

KEYCODE_FOCUS

public static final int KEYCODE_FOCUS
See Also:
Constant Field Values

KEYCODE_G

public static final int KEYCODE_G
See Also:
Constant Field Values

KEYCODE_GRAVE

public static final int KEYCODE_GRAVE
See Also:
Constant Field Values

KEYCODE_H

public static final int KEYCODE_H
See Also:
Constant Field Values

KEYCODE_HEADSETHOOK

public static final int KEYCODE_HEADSETHOOK
See Also:
Constant Field Values

KEYCODE_HOME

public static final int KEYCODE_HOME
See Also:
Constant Field Values

KEYCODE_I

public static final int KEYCODE_I
See Also:
Constant Field Values

KEYCODE_J

public static final int KEYCODE_J
See Also:
Constant Field Values

KEYCODE_K

public static final int KEYCODE_K
See Also:
Constant Field Values

KEYCODE_L

public static final int KEYCODE_L
See Also:
Constant Field Values

KEYCODE_LEFT_BRACKET

public static final int KEYCODE_LEFT_BRACKET
See Also:
Constant Field Values

KEYCODE_M

public static final int KEYCODE_M
See Also:
Constant Field Values

KEYCODE_MEDIA_FAST_FORWARD

public static final int KEYCODE_MEDIA_FAST_FORWARD
See Also:
Constant Field Values

KEYCODE_MEDIA_NEXT

public static final int KEYCODE_MEDIA_NEXT
See Also:
Constant Field Values

KEYCODE_MEDIA_PLAY_PAUSE

public static final int KEYCODE_MEDIA_PLAY_PAUSE
See Also:
Constant Field Values

KEYCODE_MEDIA_PREVIOUS

public static final int KEYCODE_MEDIA_PREVIOUS
See Also:
Constant Field Values

KEYCODE_MEDIA_REWIND

public static final int KEYCODE_MEDIA_REWIND
See Also:
Constant Field Values

KEYCODE_MEDIA_STOP

public static final int KEYCODE_MEDIA_STOP
See Also:
Constant Field Values

KEYCODE_MENU

public static final int KEYCODE_MENU
See Also:
Constant Field Values

KEYCODE_MINUS

public static final int KEYCODE_MINUS
See Also:
Constant Field Values

KEYCODE_MUTE

public static final int KEYCODE_MUTE
See Also:
Constant Field Values

KEYCODE_N

public static final int KEYCODE_N
See Also:
Constant Field Values

KEYCODE_NOTIFICATION

public static final int KEYCODE_NOTIFICATION
See Also:
Constant Field Values

KEYCODE_NUM

public static final int KEYCODE_NUM
See Also:
Constant Field Values

KEYCODE_O

public static final int KEYCODE_O
See Also:
Constant Field Values

KEYCODE_P

public static final int KEYCODE_P
See Also:
Constant Field Values

KEYCODE_PERIOD

public static final int KEYCODE_PERIOD
See Also:
Constant Field Values

KEYCODE_PLUS

public static final int KEYCODE_PLUS
See Also:
Constant Field Values

KEYCODE_POUND

public static final int KEYCODE_POUND
See Also:
Constant Field Values

KEYCODE_POWER

public static final int KEYCODE_POWER
See Also:
Constant Field Values

KEYCODE_Q

public static final int KEYCODE_Q
See Also:
Constant Field Values

KEYCODE_R

public static final int KEYCODE_R
See Also:
Constant Field Values

KEYCODE_RIGHT_BRACKET

public static final int KEYCODE_RIGHT_BRACKET
See Also:
Constant Field Values

KEYCODE_S

public static final int KEYCODE_S
See Also:
Constant Field Values

KEYCODE_SEARCH

public static final int KEYCODE_SEARCH
See Also:
Constant Field Values

KEYCODE_SEMICOLON

public static final int KEYCODE_SEMICOLON
See Also:
Constant Field Values

KEYCODE_SHIFT_LEFT

public static final int KEYCODE_SHIFT_LEFT
See Also:
Constant Field Values

KEYCODE_SHIFT_RIGHT

public static final int KEYCODE_SHIFT_RIGHT
See Also:
Constant Field Values

KEYCODE_SLASH

public static final int KEYCODE_SLASH
See Also:
Constant Field Values

KEYCODE_SOFT_LEFT

public static final int KEYCODE_SOFT_LEFT
See Also:
Constant Field Values

KEYCODE_SOFT_RIGHT

public static final int KEYCODE_SOFT_RIGHT
See Also:
Constant Field Values

KEYCODE_SPACE

public static final int KEYCODE_SPACE
See Also:
Constant Field Values

KEYCODE_STAR

public static final int KEYCODE_STAR
See Also:
Constant Field Values

KEYCODE_SYM

public static final int KEYCODE_SYM
See Also:
Constant Field Values

KEYCODE_T

public static final int KEYCODE_T
See Also:
Constant Field Values

KEYCODE_TAB

public static final int KEYCODE_TAB
See Also:
Constant Field Values

KEYCODE_U

public static final int KEYCODE_U
See Also:
Constant Field Values

KEYCODE_UNKNOWN

public static final int KEYCODE_UNKNOWN
See Also:
Constant Field Values

KEYCODE_V

public static final int KEYCODE_V
See Also:
Constant Field Values

KEYCODE_VOLUME_DOWN

public static final int KEYCODE_VOLUME_DOWN
See Also:
Constant Field Values

KEYCODE_VOLUME_UP

public static final int KEYCODE_VOLUME_UP
See Also:
Constant Field Values

KEYCODE_W

public static final int KEYCODE_W
See Also:
Constant Field Values

KEYCODE_X

public static final int KEYCODE_X
See Also:
Constant Field Values

KEYCODE_Y

public static final int KEYCODE_Y
See Also:
Constant Field Values

KEYCODE_Z

public static final int KEYCODE_Z
See Also:
Constant Field Values

META_ALT_LEFT_ON

public static final int META_ALT_LEFT_ON
See Also:
Constant Field Values

META_ALT_ON

public static final int META_ALT_ON
See Also:
Constant Field Values

META_ALT_RIGHT_ON

public static final int META_ALT_RIGHT_ON
See Also:
Constant Field Values

META_SHIFT_LEFT_ON

public static final int META_SHIFT_LEFT_ON
See Also:
Constant Field Values

META_SHIFT_ON

public static final int META_SHIFT_ON
See Also:
Constant Field Values

META_SHIFT_RIGHT_ON

public static final int META_SHIFT_RIGHT_ON
See Also:
Constant Field Values

META_SYM_ON

public static final int META_SYM_ON
See Also:
Constant Field Values
Constructor Detail

Input.Keys

public Input.Keys()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.Input.Keys (libgdx API)

Uses of Class
com.badlogic.gdx.Input.Keys

No usage of com.badlogic.gdx.Input.Keys

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Input.TextInputListener (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Interface Input.TextInputListener

Enclosing interface:
Input
public static interface Input.TextInputListener

Callback interface for Input.getTextInput(TextInputListener, String, String)

Author:
mzechner

Method Summary
 void input(java.lang.String text)

Method Detail

input

void input(java.lang.String text)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.Input.TextInputListener (libgdx API)

Uses of Interface
com.badlogic.gdx.Input.TextInputListener

Packages that use Input.TextInputListener
com.badlogic.gdx

Uses of Input.TextInputListener in com.badlogic.gdx

Methods in com.badlogic.gdx with parameters of type Input.TextInputListener
 void Input.getTextInput(Input.TextInputListener listener, java.lang.String title, java.lang.String text)
System dependent method to input a string of text.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


InputAdapter (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Class InputAdapter

java.lang.Object
    extended by  com.badlogic.gdx.InputAdapter
All Implemented Interfaces:
InputProcessor
Direct Known Subclasses:
Stage
public class InputAdapter
extends java.lang.Object
implements InputProcessor

An adapter class for InputProcessor. You can derive from this and only override what you are interested in.

Author:
mzechner

Constructor Summary
InputAdapter()
Method Summary
boolean | keyDown(int keycode) Called when a key was pressed
boolean | keyTyped(char character) Called when a key was typed
boolean | keyUp(int keycode) Called when a key was released
boolean | touchDown(int x, int y, int pointer) Called when the screen was touched or a mouse button was pressed.
boolean | touchDragged(int x, int y, int pointer) Called when a finger or the mouse was dragged.
boolean | touchUp(int x, int y, int pointer) Called when a finger was lifted or a mouse button was released.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InputAdapter

public InputAdapter()
Method Detail

keyDown

public boolean keyDown(int keycode)
Description copied from interface: InputProcessor
Called when a key was pressed

Specified by:
keyDown in interface InputProcessor
Parameters:
keycode - one of the constants in Input.Keys
Returns:
whether the input was processed

keyUp

public boolean keyUp(int keycode)
Description copied from interface: InputProcessor
Called when a key was released

Specified by:
keyUp in interface InputProcessor
Parameters:
keycode - one of the constants in Input.Keys
Returns:
whether the input was processed

keyTyped

public boolean keyTyped(char character)
Description copied from interface: InputProcessor
Called when a key was typed

Specified by:
keyTyped in interface InputProcessor
Parameters:
character - The character
Returns:
whether the input was processed

touchDown

public boolean touchDown(int x,
                         int y,
                         int pointer)
Description copied from interface: InputProcessor
Called when the screen was touched or a mouse button was pressed.

Specified by:
touchDown in interface InputProcessor
Parameters:
x - The x coordinate, origin is in the upper left corner
y - The y coordinate, origin is in the upper left corner
pointer - the pointer for the event.
Returns:
whether the input was processed

touchUp

public boolean touchUp(int x,
                       int y,
                       int pointer)
Description copied from interface: InputProcessor
Called when a finger was lifted or a mouse button was released.

Specified by:
touchUp in interface InputProcessor
Parameters:
x - The x coordinate
y - The y coordinate
pointer - the pointer for the event.
Returns:
whether the input was processed

touchDragged

public boolean touchDragged(int x,
                            int y,
                            int pointer)
Description copied from interface: InputProcessor
Called when a finger or the mouse was dragged.

Specified by:
touchDragged in interface InputProcessor
Parameters:
x - The x coordinate
y - The y coordinate
pointer - the pointer for the event.
Returns:
whether the input was processed
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.InputAdapter (libgdx API)

Uses of Class
com.badlogic.gdx.InputAdapter

Packages that use InputAdapter
com.badlogic.gdx.scenes.scene2d

Uses of InputAdapter in com.badlogic.gdx.scenes.scene2d

Subclasses of InputAdapter in com.badlogic.gdx.scenes.scene2d
 class Stage
A Stage is a container for Actors and handles distributing touch events, animating Actors and asking them to render themselves.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


InputMultiplexer (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Class InputMultiplexer

java.lang.Object
    extended by  com.badlogic.gdx.InputMultiplexer
All Implemented Interfaces:
InputProcessor
public class InputMultiplexer
extends java.lang.Object
implements InputProcessor

An InputProcessor that delegates to an ordered list of other InputProcessors. Delegation for an event stops if a processor returns true, which indicates that the event was handled.

Author:
Nathan Sweet

Constructor Summary
InputMultiplexer()
Method Summary
void | addProcessor(InputProcessor processor)
boolean | keyDown(int keycode) Called when a key was pressed
boolean | keyTyped(char character) Called when a key was typed
boolean | keyUp(int keycode) Called when a key was released
void | removeProcessor(InputProcessor processor)
boolean | touchDown(int x, int y, int pointer) Called when the screen was touched or a mouse button was pressed.
boolean | touchDragged(int x, int y, int pointer) Called when a finger or the mouse was dragged.
boolean | touchUp(int x, int y, int pointer) Called when a finger was lifted or a mouse button was released.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InputMultiplexer

public InputMultiplexer()
Method Detail

addProcessor

public void addProcessor(InputProcessor processor)

removeProcessor

public void removeProcessor(InputProcessor processor)

keyDown

public boolean keyDown(int keycode)
Description copied from interface: InputProcessor
Called when a key was pressed

Specified by:
keyDown in interface InputProcessor
Parameters:
keycode - one of the constants in Input.Keys
Returns:
whether the input was processed

keyUp

public boolean keyUp(int keycode)
Description copied from interface: InputProcessor
Called when a key was released

Specified by:
keyUp in interface InputProcessor
Parameters:
keycode - one of the constants in Input.Keys
Returns:
whether the input was processed

keyTyped

public boolean keyTyped(char character)
Description copied from interface: InputProcessor
Called when a key was typed

Specified by:
keyTyped in interface InputProcessor
Parameters:
character - The character
Returns:
whether the input was processed

touchDown

public boolean touchDown(int x,
                         int y,
                         int pointer)
Description copied from interface: InputProcessor
Called when the screen was touched or a mouse button was pressed.

Specified by:
touchDown in interface InputProcessor
Parameters:
x - The x coordinate, origin is in the upper left corner
y - The y coordinate, origin is in the upper left corner
pointer - the pointer for the event.
Returns:
whether the input was processed

touchUp

public boolean touchUp(int x,
                       int y,
                       int pointer)
Description copied from interface: InputProcessor
Called when a finger was lifted or a mouse button was released.

Specified by:
touchUp in interface InputProcessor
Parameters:
x - The x coordinate
y - The y coordinate
pointer - the pointer for the event.
Returns:
whether the input was processed

touchDragged

public boolean touchDragged(int x,
                            int y,
                            int pointer)
Description copied from interface: InputProcessor
Called when a finger or the mouse was dragged.

Specified by:
touchDragged in interface InputProcessor
Parameters:
x - The x coordinate
y - The y coordinate
pointer - the pointer for the event.
Returns:
whether the input was processed
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.InputMultiplexer (libgdx API)

Uses of Class
com.badlogic.gdx.InputMultiplexer

No usage of com.badlogic.gdx.InputMultiplexer

Overview Package Class Use Tree Deprecated Index Help
libgdx API


InputProcessor (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Interface InputProcessor

All Known Implementing Classes:
InputAdapter, InputMultiplexer, Stage, TWL
public interface InputProcessor

An InputProcessor is used to receive input events from the keyboard and the touch screen (mouse on the desktop). For this it has to be registered with the Input.setInputProcessor(InputProcessor) method. It will be called each frame before the call to ApplicationListener.render(). The methods return a* boolean in case you want to write a multiplexing InputProcessor that has a chain of child processors that signal whether they processed the event. The InputMultiplexer offers you exactly this functionality.

Author:
badlogicgames@gmail.com

Method Summary
boolean | keyDown(int keycode) Called when a key was pressed
boolean | keyTyped(char character) Called when a key was typed
boolean | keyUp(int keycode) Called when a key was released
boolean | touchDown(int x, int y, int pointer) Called when the screen was touched or a mouse button was pressed.
boolean | touchDragged(int x, int y, int pointer) Called when a finger or the mouse was dragged.
boolean | touchUp(int x, int y, int pointer) Called when a finger was lifted or a mouse button was released.

Method Detail

keyDown

boolean keyDown(int keycode)
Called when a key was pressed

Parameters:
keycode - one of the constants in Input.Keys
Returns:
whether the input was processed

keyUp

boolean keyUp(int keycode)
Called when a key was released

Parameters:
keycode - one of the constants in Input.Keys
Returns:
whether the input was processed

keyTyped

boolean keyTyped(char character)
Called when a key was typed

Parameters:
character - The character
Returns:
whether the input was processed

touchDown

boolean touchDown(int x,
                  int y,
                  int pointer)
Called when the screen was touched or a mouse button was pressed.

Parameters:
x - The x coordinate, origin is in the upper left corner
y - The y coordinate, origin is in the upper left corner
pointer - the pointer for the event.
Returns:
whether the input was processed

touchUp

boolean touchUp(int x,
                int y,
                int pointer)
Called when a finger was lifted or a mouse button was released.

Parameters:
x - The x coordinate
y - The y coordinate
pointer - the pointer for the event.
Returns:
whether the input was processed

touchDragged

boolean touchDragged(int x,
                     int y,
                     int pointer)
Called when a finger or the mouse was dragged.

Parameters:
x - The x coordinate
y - The y coordinate
pointer - the pointer for the event.
Returns:
whether the input was processed
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.InputProcessor (libgdx API)

Uses of Interface
com.badlogic.gdx.InputProcessor

Packages that use InputProcessor
com.badlogic.gdx
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.twl

Uses of InputProcessor in com.badlogic.gdx

Classes in com.badlogic.gdx that implement InputProcessor
class | InputAdapter An adapter class for InputProcessor.
class | InputMultiplexer An InputProcessor that delegates to an ordered list of other InputProcessors.

Methods in com.badlogic.gdx with parameters of type InputProcessor
void | InputMultiplexer.addProcessor(InputProcessor processor)
void | InputMultiplexer.removeProcessor(InputProcessor processor)
void | Input.setInputProcessor(InputProcessor processor) Sets the InputProcessor that will receive all touch and key input events.

Uses of InputProcessor in com.badlogic.gdx.scenes.scene2d

Classes in com.badlogic.gdx.scenes.scene2d that implement InputProcessor
 class Stage
A Stage is a container for Actors and handles distributing touch events, animating Actors and asking them to render themselves.

Uses of InputProcessor in com.badlogic.gdx.twl

Classes in com.badlogic.gdx.twl that implement InputProcessor
 class TWL
Convenience class for using TWL.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


IntArray (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class IntArray

java.lang.Object
    extended by  com.badlogic.gdx.utils.IntArray

public class IntArray
extends java.lang.Object

An ordered, resizable int array. Avoids the boxing that occurs with ArrayList.

Author:
Matthias Mann, Nathan Sweet

Field Summary
int[] | items
int | size
Constructor Summary
IntArray()
IntArray(int capacity)
IntArray(IntArray array)
IntArray(IntBag bag)
Method Summary
void | add(int value)
void | addAll(IntArray array)
void | addAll(IntBag bag)
void | clear()
boolean | contains(int value)
void | ensureCapacity(int additionalCapacity) Increases the size of the backing array to acommodate the specified number of additional items.
int | get(int index)
int | indexOf(int value)
void | insert(int index, int value)
int | pop() Removes and returns the last item.
int | pop(int index) Removes and returns the specified item.
void | removeIndex(int index)
boolean | removeValue(int value)
void | set(int index, int value)
void | shrink() Reduces the size of the backing array to the size of the actual items.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

items

public int[] items

size

public int size
Constructor Detail

IntArray

public IntArray()

IntArray

public IntArray(int capacity)

IntArray

public IntArray(IntArray array)

IntArray

public IntArray(IntBag bag)
Method Detail

add

public void add(int value)

addAll

public void addAll(IntArray array)

addAll

public void addAll(IntBag bag)

set

public void set(int index,
                int value)

insert

public void insert(int index,
                   int value)

get

public int get(int index)

contains

public boolean contains(int value)

indexOf

public int indexOf(int value)

removeValue

public boolean removeValue(int value)

removeIndex

public void removeIndex(int index)

pop

public int pop()
Removes and returns the last item.

pop

public int pop(int index)
Removes and returns the specified item.

clear

public void clear()

shrink

public void shrink()
Reduces the size of the backing array to the size of the actual items. This is useful to release memory when many items have been removed, or if it is known the more items will not be added.

ensureCapacity

public void ensureCapacity(int additionalCapacity)
Increases the size of the backing array to acommodate the specified number of additional items. Useful before adding many items to avoid multiple backing array resizes.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.IntArray (libgdx API)

Uses of Class
com.badlogic.gdx.utils.IntArray

Packages that use IntArray
com.badlogic.gdx.utils

Uses of IntArray in com.badlogic.gdx.utils

Methods in com.badlogic.gdx.utils with parameters of type IntArray
void | IntArray.addAll(IntArray array)
void | IntBag.addAll(IntArray array)

Constructors in com.badlogic.gdx.utils with parameters of type IntArray
IntArray(IntArray array)
IntBag(IntArray array)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


IntBag (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class IntBag

java.lang.Object
    extended by  com.badlogic.gdx.utils.IntBag

public class IntBag
extends java.lang.Object

An unordered, resizable int array. Avoids the boxing that occurs with ArrayList. Avoids a memory copy when removing elements (the last element is moved to the removed element's position).

Author:
Riven, Nathan Sweet

Field Summary
int[] | items
int | size
Constructor Summary
IntBag()
IntBag(int capacity)
IntBag(IntArray array)
IntBag(IntBag bag)
Method Summary
void | add(int value)
void | addAll(IntArray array)
void | addAll(IntBag bag)
void | clear()
boolean | contains(int value)
void | ensureCapacity(int additionalCapacity) Increases the size of the backing array to acommodate the specified number of additional items.
int | get(int index)
int | indexOf(int value)
int | pop() Removes and returns the last item.
int | pop(int index) Removes and returns the specified item.
void | removeIndex(int index)
boolean | removeValue(int value)
void | shrink() Reduces the size of the backing array to the size of the actual items.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

items

public int[] items

size

public int size
Constructor Detail

IntBag

public IntBag()

IntBag

public IntBag(int capacity)

IntBag

public IntBag(IntBag bag)

IntBag

public IntBag(IntArray array)
Method Detail

add

public void add(int value)

addAll

public void addAll(IntBag bag)

addAll

public void addAll(IntArray array)

get

public int get(int index)

contains

public boolean contains(int value)

indexOf

public int indexOf(int value)

removeValue

public boolean removeValue(int value)

removeIndex

public void removeIndex(int index)

pop

public int pop()
Removes and returns the last item.

pop

public int pop(int index)
Removes and returns the specified item.

clear

public void clear()

shrink

public void shrink()
Reduces the size of the backing array to the size of the actual items. This is useful to release memory when many items have been removed, or if it is known the more items will not be added.

ensureCapacity

public void ensureCapacity(int additionalCapacity)
Increases the size of the backing array to acommodate the specified number of additional items. Useful before adding many items to avoid multiple backing array resizes.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.IntBag (libgdx API)

Uses of Class
com.badlogic.gdx.utils.IntBag

Packages that use IntBag
com.badlogic.gdx.utils

Uses of IntBag in com.badlogic.gdx.utils

Methods in com.badlogic.gdx.utils with parameters of type IntBag
void | IntArray.addAll(IntBag bag)
void | IntBag.addAll(IntBag bag)

Constructors in com.badlogic.gdx.utils with parameters of type IntBag
IntArray(IntBag bag)
IntBag(IntBag bag)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Intersector (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class Intersector

java.lang.Object
    extended by  com.badlogic.gdx.math.Intersector

public final class Intersector
extends java.lang.Object

Class offering various static methods for intersection testing between different geometric objects.

Author:
badlogicgames@gmail.com

Constructor Summary
Intersector()
Method Summary
static float | distanceLinePoint(Vector2 start, Vector2 end, Vector2 point) Returns the distance between the given line segment and point.
static float | getLowestPositiveRoot(float a, float b, float c) Returns the lowest positive root of the quadric equation given by a* x * x + b * x + c = 0.
static boolean | intersectLines(Vector2 p1, Vector2 p2, Vector2 p3, Vector2 p4, Vector2 intersection) Intersects the two lines and returns the intersection point in intersection.
static boolean | intersectRayBoundsFast(Ray ray, BoundingBox bounds) Quick check wheter the given Ray and BoundingBox intersect.
static boolean | intersectRayPlane(Ray ray, Plane plane, Vector3 intersection) Intersects a Ray and a Plane.
static boolean | intersectRaySphere(Ray ray, Vector3 center, float radius, Vector3 intersection) Intersects a Ray and a sphere, returning the intersection point in intersection.
static boolean | intersectRayTriangle(Ray ray, Vector3 t1, Vector3 t2, Vector3 t3, Vector3 intersection) Intersect a Ray and a triangle, returning the intersection point in intersection.
static boolean | intersectRayTriangles(Ray ray, float[] vertices, short[] indices, int vertexSize, Vector3 intersection) Intersects the given ray with list of triangles.
static boolean | intersectRayTriangles(Ray ray, float[] triangles, Vector3 intersection) Intersects the given ray with list of triangles.
static boolean | intersectRayTriangles(Ray ray, java.util.List<Vector3> triangles, Vector3 intersection) Intersects the given ray with list of triangles.
static boolean | intersectRectangles(Rectangle a, Rectangle b) Returns wheter the two rectangles intersect
static boolean | intersectSegmentCircle(Vector2 start, Vector2 end, Vector2 center, float squareRadius) Returns wheter the given line segment intersects the given circle.
static float | intersectSegmentCircleDisplace(Vector2 start, Vector2 end, Vector2 point, float radius, Vector2 displacement) Checks wheter the line segment and the circle intersect and returns by how much and in what direction the line has to move away from the circle to not intersect.
static boolean | intersectSegmentPlane(Vector3 start, Vector3 end, Plane plane, Vector3 intersection)
static boolean | intersectSegments(Vector2 p1, Vector2 p2, Vector2 p3, Vector2 p4, Vector2 intersection) Intersects the two line segments and returns the intersection point in intersection.
static boolean | isPointInPolygon(java.util.List<Vector2> polygon, Vector2 point) Checks wheter the given point is in the polygon.
static boolean | isPointInTriangle(Vector3 point, Vector3 t1, Vector3 t2, Vector3 t3) Returns whether the given point is inside the triangle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Intersector

public Intersector()
Method Detail

getLowestPositiveRoot

public static float getLowestPositiveRoot(float a,
                                          float b,
                                          float c)
Returns the lowest positive root of the quadric equation given by a* x * x + b * x + c = 0. If no solution is given Float.Nan is returned.

Parameters:
a - the first coefficient of the quadric equation
b - the second coefficient of the quadric equation
c - the third coefficient of the quadric equation
Returns:
the lowest positive root or Float.Nan

isPointInTriangle

public static boolean isPointInTriangle(Vector3 point,
                                        Vector3 t1,
                                        Vector3 t2,
                                        Vector3 t3)
Returns whether the given point is inside the triangle. This assumes that the point is on the plane of the triangle. No check is performed that this is the case.

Parameters:
point - the point
t1 - the first vertex of the triangle
t2 - the second vertex of the triangle
t3 - the third vertex of the triangle
Returns:
whether the point is in the triangle

intersectSegmentPlane

public static boolean intersectSegmentPlane(Vector3 start,
                                            Vector3 end,
                                            Plane plane,
                                            Vector3 intersection)

isPointInPolygon

public static boolean isPointInPolygon(java.util.List<Vector2> polygon,
                                       Vector2 point)
Checks wheter the given point is in the polygon. Only the x and y coordinates of the provided Vector3s are used.

Parameters:
polygon - The polygon vertices
point - The point
Returns:
Wheter the point is in the polygon

distanceLinePoint

public static float distanceLinePoint(Vector2 start,
                                      Vector2 end,
                                      Vector2 point)
Returns the distance between the given line segment and point.

Parameters:
start - The line start point
end - The line end point
point - The point
Returns:
The distance between the line segment and the point.

intersectSegmentCircle

public static boolean intersectSegmentCircle(Vector2 start,
                                             Vector2 end,
                                             Vector2 center,
                                             float squareRadius)
Returns wheter the given line segment intersects the given circle.

Parameters:
start - The start point of the line segment
end - The end point of the line segment
center - The center of the circle
squareRadius - The squared radius of the circle
Returns:
Wheter the line segment and the circle intersect

intersectSegmentCircleDisplace

public static float intersectSegmentCircleDisplace(Vector2 start,
                                                   Vector2 end,
                                                   Vector2 point,
                                                   float radius,
                                                   Vector2 displacement)
Checks wheter the line segment and the circle intersect and returns by how much and in what direction the line has to move away from the circle to not intersect.

Parameters:
start - The line segment starting point
end - The line segment end point
point - The center of the circle
radius - The radius of the circle
displacement - The displacement vector set by the method having unit length
Returns:
The displacement or Float.POSITIVE_INFINITY if no intersection is present

intersectRayPlane

public static boolean intersectRayPlane(Ray ray,
                                        Plane plane,
                                        Vector3 intersection)
Intersects a Ray and a Plane. The intersection point is stored in intersection in case an intersection is present.

Parameters:
ray - The ray
plane - The plane
intersection - The vector the intersection point is written to
Returns:
Wheter an intersection is present.

intersectRayTriangle

public static boolean intersectRayTriangle(Ray ray,
                                           Vector3 t1,
                                           Vector3 t2,
                                           Vector3 t3,
                                           Vector3 intersection)
Intersect a Ray and a triangle, returning the intersection point in intersection.

Parameters:
ray - The ray
t1 - The first vertex of the triangle
t2 - The second vertex of the triangle
t3 - The third vertex of the triangle
intersection - The intersection point
Returns:
True in case an intersection is present.

intersectRaySphere

public static boolean intersectRaySphere(Ray ray,
                                         Vector3 center,
                                         float radius,
                                         Vector3 intersection)
Intersects a Ray and a sphere, returning the intersection point in intersection.

Parameters:
ray - The ray
center - The center of the sphere
radius - The radius of the sphere
intersection - The intersection point
Returns:
Wheter an interesection is present.

intersectRayBoundsFast

public static boolean intersectRayBoundsFast(Ray ray,
                                             BoundingBox bounds)
Quick check wheter the given Ray and BoundingBox intersect.

Parameters:
ray - The ray
bounds - The bounding box
Returns:
Wheter the ray and the bounding box intersect.

intersectRayTriangles

public static boolean intersectRayTriangles(Ray ray,
                                            float[] triangles,
                                            Vector3 intersection)
Intersects the given ray with list of triangles. Returns the nearest intersection point in intersection

Parameters:
ray - The ray
triangles - The triangles, each succesive 3 elements from a vertex
intersection - The nearest intersection point
Returns:
Wheter the ray and the triangles intersect.

intersectRayTriangles

public static boolean intersectRayTriangles(Ray ray,
                                            float[] vertices,
                                            short[] indices,
                                            int vertexSize,
                                            Vector3 intersection)
Intersects the given ray with list of triangles. Returns the nearest intersection point in intersection

Parameters:
ray - The ray
vertices - the vertices
indices - the indices, each successive 3 shorts index the 3 vertices of a triangle
vertexSize - the size of a vertex in floats
intersection - The nearest intersection point
Returns:
Wheter the ray and the triangles intersect.

intersectRayTriangles

public static boolean intersectRayTriangles(Ray ray,
                                            java.util.List<Vector3> triangles,
                                            Vector3 intersection)
Intersects the given ray with list of triangles. Returns the nearest intersection point in intersection

Parameters:
ray - The ray
triangles - The triangles
intersection - The nearest intersection point
Returns:
Wheter the ray and the triangles intersect.

intersectRectangles

public static boolean intersectRectangles(Rectangle a,
                                          Rectangle b)
Returns wheter the two rectangles intersect

Parameters:
a - The first rectangle
b - The second rectangle
Returns:
Wheter the two rectangles intersect

intersectLines

public static boolean intersectLines(Vector2 p1,
                                     Vector2 p2,
                                     Vector2 p3,
                                     Vector2 p4,
                                     Vector2 intersection)
Intersects the two lines and returns the intersection point in intersection.

Parameters:
p1 - The first point of the first line
p2 - The second point of the first line
p3 - The first point of the second line
p4 - The second point of the second line
intersection - The intersection point
Returns:
Wheter the two lines intersect

intersectSegments

public static boolean intersectSegments(Vector2 p1,
                                        Vector2 p2,
                                        Vector2 p3,
                                        Vector2 p4,
                                        Vector2 intersection)
Intersects the two line segments and returns the intersection point in intersection.

Parameters:
p1 - The first point of the first line segment
p2 - The second point of the first line segment
p3 - The first point of the second line segment
p4 - The second point of the second line segment
intersection - The intersection point
Returns:
Wheter the two line segments intersect
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.Intersector (libgdx API)

Uses of Class
com.badlogic.gdx.math.Intersector

No usage of com.badlogic.gdx.math.Intersector

Overview Package Class Use Tree Deprecated Index Help
libgdx API


IntHashMap (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class IntHashMap<T>

java.lang.Object
    extended by  com.badlogic.gdx.utils.IntHashMap<T>

public class IntHashMap<T>
extends java.lang.Object

An unordered map that uses int keys. Avoids the boxing that occurs with HashMap.

Author:
Nathan Sweet , christop widulle

Nested Class Summary
static class IntHashMap.Entry<T>
An entry in the map.
Field Summary
 int size
Constructor Summary
IntHashMap()
IntHashMap(int initialCapacity)
IntHashMap(int initialCapacity, float loadFactor)
Method Summary
void | clear()
boolean | containsKey(int key)
boolean | containsValue(java.lang.Object value) Returns true if the specified value is in the map.
void | ensureCapacity(int additionalCapacity) Increases the size of the backing array to acommodate the specified number of additional items.
java.util.Iterator | entries() Returns an iterator for the entries in the map.
T | get(int key)
com.badlogic.gdx.utils.IntHashMap.Keys | keys() Returns an iterator for the keys in the map.
T | put(int key, T value)
T | remove(int key)
java.lang.String | toString()
java.util.Iterator | values() Returns an iterator for the values in the map.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

size

public int size
Constructor Detail

IntHashMap

public IntHashMap()

IntHashMap

public IntHashMap(int initialCapacity)

IntHashMap

public IntHashMap(int initialCapacity,
                  float loadFactor)
Method Detail

put

public T put(int key,
             T value)

get

public T get(int key)

entries

public java.util.Iterator entries()
Returns an iterator for the entries in the map. Remove is supported. Note that the same iterator instance is reused each time this method is called.

values

public java.util.Iterator values()
Returns an iterator for the values in the map. Remove is supported. Note that the same iterator instance is reused each time this method is called.

keys

public com.badlogic.gdx.utils.IntHashMap.Keys keys()
Returns an iterator for the keys in the map. Remove is supported. Note that the same iterator instance is reused each time this method is called.

containsValue

public boolean containsValue(java.lang.Object value)
Returns true if the specified value is in the map. Note this traverses the entire map and calls equals on every value, which may be an expensive operation.

containsKey

public boolean containsKey(int key)

remove

public T remove(int key)

clear

public void clear()

ensureCapacity

public void ensureCapacity(int additionalCapacity)
Increases the size of the backing array to acommodate the specified number of additional items. Useful before adding many items to avoid multiple backing array resizes.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.IntHashMap (libgdx API)

Uses of Class
com.badlogic.gdx.utils.IntHashMap

No usage of com.badlogic.gdx.utils.IntHashMap

Overview Package Class Use Tree Deprecated Index Help
libgdx API


IntHashMap.Entry (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class IntHashMap.Entry<T>

java.lang.Object
    extended by  com.badlogic.gdx.utils.IntHashMap.Entry<T>
Enclosing class:
IntHashMap<T>
public static class IntHashMap.Entry<T>
extends java.lang.Object

An entry in the map. The value may be changed directly.

Field Summary
int | key
T | value
Method Summary
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

key

public final int key

value

public T value
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.IntHashMap.Entry (libgdx API)

Uses of Class
com.badlogic.gdx.utils.IntHashMap.Entry

No usage of com.badlogic.gdx.utils.IntHashMap.Entry

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JoglApplication (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.backends.jogl
Class JoglApplication

java.lang.Object
    extended by  com.badlogic.gdx.backends.jogl.JoglApplication
All Implemented Interfaces:
Application
public final class JoglApplication
extends java.lang.Object
implements Application

An implemenation of the Application interface based on Jogl for Windows, Linux and Mac. Instantiate this class with apropriate parameters and then register ApplicationListener or InputProcessor instances.

Author:
mzechner

Nested Class Summary
Nested classes/interfaces inherited from interface com.badlogic.gdx.Application
Application.ApplicationType
Constructor Summary
JoglApplication(ApplicationListener listener, java.lang.String title, int width, int height, boolean useGL20IfAvailable)
Creates a new JoglApplication with the given title and dimensions.
Method Summary
Audio | getAudio()
Files | getFiles()
Graphics | getGraphics()
Input | getInput()
long | getJavaHeap()
long | getNativeHeap()
Application.ApplicationType | getType()
int | getVersion()
void | log(java.lang.String tag, java.lang.String message) Logs a message to the console or logcat
static void | main(java.lang.String[] argv)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JoglApplication

public JoglApplication(ApplicationListener listener,
                       java.lang.String title,
                       int width,
                       int height,
                       boolean useGL20IfAvailable)
Creates a new JoglApplication with the given title and dimensions. If useGL20IfAvailable is set the JoglApplication will try to create an OpenGL 2.0 context which can then be used via JoglApplication.getGraphics().getGL20(). To query whether enabling OpenGL 2.0 was successful use the JoglApplication.getGraphics().isGL20Available() method.

Parameters:
listener - the ApplicationListener implementing the program logic
title - the title of the application
width - the width of the surface in pixels
height - the height of the surface in pixels
useGL20IfAvailable - wheter to use OpenGL 2.0 if it is available or not
Method Detail

getAudio

public Audio getAudio()

Specified by:
getAudio in interface Application
Returns:
the Audio instance

getFiles

public Files getFiles()

Specified by:
getFiles in interface Application
Returns:
the Files instance

getGraphics

public Graphics getGraphics()

Specified by:
getGraphics in interface Application
Returns:
the Graphics instance

getInput

public Input getInput()

Specified by:
getInput in interface Application
Returns:
the Input instance

log

public void log(java.lang.String tag,
                java.lang.String message)
Description copied from interface: Application
Logs a message to the console or logcat

Specified by:
log in interface Application

getType

public Application.ApplicationType getType()

Specified by:
getType in interface Application
Returns:
what Application.ApplicationType this application has, e.g. Android or Desktop

getVersion

public int getVersion()
Specified by:
getVersion in interface Application
Returns:
the Android API level on Android or 0 on the desktop.

main

public static void main(java.lang.String[] argv)

getJavaHeap

public long getJavaHeap()
Specified by:
getJavaHeap in interface Application
Returns:
the Java heap memory use in bytes

getNativeHeap

public long getNativeHeap()
Specified by:
getNativeHeap in interface Application
Returns:
the Native heap memory use in bytes
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.backends.jogl.JoglApplication (libgdx API)

Uses of Class
com.badlogic.gdx.backends.jogl.JoglApplication

No usage of com.badlogic.gdx.backends.jogl.JoglApplication

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Joint (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class Joint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
Direct Known Subclasses:
DistanceJoint, FrictionJoint, GearJoint, LineJoint, MouseJoint, PrismaticJoint, PulleyJoint, RevoluteJoint, WeldJoint
public abstract class Joint
extends java.lang.Object

Field Summary
protected long | addr the address of the joint
protected JointEdge | jointEdgeA joint edge a
protected JointEdge | jointEdgeB joint edge b
Constructor Summary
protected Joint(World world, long addr)
Constructs a new joint
Method Summary
Vector2 | getAnchorA()
Vector2 | getAnchorB()
Body | getBodyA() Get the first body attached to this joint.
Body | getBodyB() Get the second body attached to this joint.
Vector2 | getReactionForce(float inv_dt)
float | getReactionTorque(float inv_dt) Get the reaction torque on body2 in N*m.
JointDef.JointType | getType() Get the type of the concrete joint.
boolean | isActive() Short-cut function to determine if either body is inactive.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

addr

protected long addr
the address of the joint

jointEdgeA

protected JointEdge jointEdgeA
joint edge a

jointEdgeB

protected JointEdge jointEdgeB
joint edge b

Constructor Detail

Joint

protected Joint(World world,
                long addr)
Constructs a new joint

Parameters:
addr - the address of the joint
Method Detail

getType

public JointDef.JointType getType()
Get the type of the concrete joint.

getBodyA

public Body getBodyA()
Get the first body attached to this joint.

getBodyB

public Body getBodyB()
Get the second body attached to this joint.

getAnchorA

public Vector2 getAnchorA()

getAnchorB

public Vector2 getAnchorB()

getReactionForce

public Vector2 getReactionForce(float inv_dt)

getReactionTorque

public float getReactionTorque(float inv_dt)
Get the reaction torque on body2 in N*m.

isActive

public boolean isActive()
Short-cut function to determine if either body is inactive.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.Joint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.Joint

Packages that use Joint
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints

Uses of Joint in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as Joint
 Joint JointEdge.joint

Fields in com.badlogic.gdx.physics.box2d with type parameters of type Joint
protected  LongHashMap<Joint> World.joints
all known joints

Methods in com.badlogic.gdx.physics.box2d that return Joint
 Joint World.createJoint(JointDef def)
Create a joint to constrain bodies together.

Methods in com.badlogic.gdx.physics.box2d that return types with arguments of type Joint
 java.util.Iterator<Joint> World.getJoints()

Methods in com.badlogic.gdx.physics.box2d with parameters of type Joint
 void World.destroyJoint(Joint joint)
Destroy a joint.

Constructors in com.badlogic.gdx.physics.box2d with parameters of type Joint
JointEdge(Body other, Joint joint)

Uses of Joint in com.badlogic.gdx.physics.box2d.joints

Subclasses of Joint in com.badlogic.gdx.physics.box2d.joints
class | DistanceJoint A distance joint constrains two points on two bodies to remain at a fixed distance from each other.
class | FrictionJoint Friction joint.
class | GearJoint A gear joint is used to connect two joints together.
class | LineJoint A line joint.
class | MouseJoint A mouse joint is used to make a point on a body track a specified world point.
class | PrismaticJoint A prismatic joint.
class | PulleyJoint The pulley joint is connected to two bodies and two fixed ground points.
class | RevoluteJoint A revolute joint constrains two bodies to share a common point while they are free to rotate about the point.
class | WeldJoint A weld joint essentially glues two bodies together.

Fields in com.badlogic.gdx.physics.box2d.joints declared as Joint
Joint | GearJointDef.joint1 The first revolute/prismatic joint attached to the gear joint.
Joint | GearJointDef.joint2 The second revolute/prismatic joint attached to the gear joint.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JointDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class JointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
Direct Known Subclasses:
DistanceJointDef, FrictionJointDef, GearJointDef, LineJointDef, MouseJointDef, PrismaticJointDef, PulleyJointDef, RevoluteJointDef, WeldJointDef
public class JointDef
extends java.lang.Object

Nested Class Summary
static class JointDef.JointType
Field Summary
Body | bodyA The first attached body.
Body | bodyB The second attached body
boolean | collideConnected Set this flag to true if the attached bodies should collide.
JointDef.JointType | type The joint type is set automatically for concrete joint types.
Constructor Summary
JointDef()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

type

public JointDef.JointType type
The joint type is set automatically for concrete joint types.

bodyA

public Body bodyA
The first attached body.

bodyB

public Body bodyB
The second attached body

collideConnected

public boolean collideConnected
Set this flag to true if the attached bodies should collide.

Constructor Detail

JointDef

public JointDef()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.JointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.JointDef

Packages that use JointDef
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints

Uses of JointDef in com.badlogic.gdx.physics.box2d

Methods in com.badlogic.gdx.physics.box2d with parameters of type JointDef
 Joint World.createJoint(JointDef def)
Create a joint to constrain bodies together.

Uses of JointDef in com.badlogic.gdx.physics.box2d.joints

Subclasses of JointDef in com.badlogic.gdx.physics.box2d.joints
class | DistanceJointDef Distance joint definition.
class | FrictionJointDef Friction joint definition.
class | GearJointDef Gear joint definition.
class | LineJointDef Line joint definition.
class | MouseJointDef Mouse joint definition.
class | PrismaticJointDef Prismatic joint definition.
class | PulleyJointDef Pulley joint definition.
class | RevoluteJointDef Revolute joint definition.
class | WeldJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JointDef.JointType (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.physics.box2d
Enum JointDef.JointType

java.lang.Object
    extended by  java.lang.Enum<JointDef.JointType>
        extended by  com.badlogic.gdx.physics.box2d.JointDef.JointType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<JointDef.JointType>
Enclosing class:
JointDef
public static enum JointDef.JointType
extends java.lang.Enum<JointDef.JointType>

Enum Constant Summary
DistanceJoint
FrictionJoint
GearJoint
LineJoint
MouseJoint
PrismaticJoint
PulleyJoint
RevoluteJoint
Unknown
WeldJoint
Field Summary
static JointDef.JointType[] valueTypes
Method Summary
int | getValue()
static JointDef.JointType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static JointDef.JointType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

Unknown

public static final JointDef.JointType Unknown

RevoluteJoint

public static final JointDef.JointType RevoluteJoint

PrismaticJoint

public static final JointDef.JointType PrismaticJoint

DistanceJoint

public static final JointDef.JointType DistanceJoint

PulleyJoint

public static final JointDef.JointType PulleyJoint

MouseJoint

public static final JointDef.JointType MouseJoint

GearJoint

public static final JointDef.JointType GearJoint

LineJoint

public static final JointDef.JointType LineJoint

WeldJoint

public static final JointDef.JointType WeldJoint

FrictionJoint

public static final JointDef.JointType FrictionJoint
Field Detail

valueTypes

public static JointDef.JointType[] valueTypes
Method Detail

values

public static JointDef.JointType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (JointDef.JointType c : JointDef.JointType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static JointDef.JointType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getValue

public int getValue()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.JointDef.JointType (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.JointDef.JointType

Packages that use JointDef.JointType
com.badlogic.gdx.physics.box2d

Uses of JointDef.JointType in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as JointDef.JointType
JointDef.JointType | JointDef.type The joint type is set automatically for concrete joint types.
static JointDef.JointType[] | JointDef.JointType.valueTypes

Methods in com.badlogic.gdx.physics.box2d that return JointDef.JointType
JointDef.JointType | Joint.getType() Get the type of the concrete joint.
static JointDef.JointType | JointDef.JointType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static JointDef.JointType[] | JointDef.JointType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JointEdge (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class JointEdge

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointEdge

public class JointEdge
extends java.lang.Object

A joint edge is used to connect bodies and joints together in a joint graph where each body is a node and each joint is an edge. A joint edge belongs to a doubly linked list maintained in each attached body. Each joint has two joint nodes, one for each attached body.

Field Summary
Joint | joint
Body | other
Constructor Summary
protected JointEdge(Body other, Joint joint)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

other

public final Body other

joint

public final Joint joint
Constructor Detail

JointEdge

protected JointEdge(Body other,
                    Joint joint)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.JointEdge (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.JointEdge

Packages that use JointEdge
com.badlogic.gdx.physics.box2d

Uses of JointEdge in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as JointEdge
protected JointEdge | Joint.jointEdgeA joint edge a
protected JointEdge | Joint.jointEdgeB joint edge b

Fields in com.badlogic.gdx.physics.box2d with type parameters of type JointEdge
protected  java.util.ArrayList<JointEdge> Body.joints
Joints of this body

Methods in com.badlogic.gdx.physics.box2d that return types with arguments of type JointEdge
 java.util.ArrayList<JointEdge> Body.getJointList()
Get the list of all joints attached to this body.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JSONArray (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils.json
Class JSONArray

java.lang.Object
    extended by  com.badlogic.gdx.utils.json.JSONArray

public class JSONArray
extends java.lang.Object

A JSONArray is an ordered sequence of values. Its external text form is a string wrapped in square brackets with commas separating the values. The internal form is an object having get and opt methods for accessing the values by index, and put methods for adding or replacing values. The values can be any of these types: Boolean, JSONArray, JSONObject, Number, String, or the JSONObject.NULL object.

The constructor can convert a JSON text into a Java object. The toString method converts to JSON text.

A get method returns a value if one can be found, and throws an exception if one cannot be found. An opt method returns a default value instead of throwing an exception, and so is useful for obtaining optional values.

The generic get() and opt() methods return an object which you can cast or query for type. There are also typed get and opt methods that do type checking and type coercion for you.

The texts produced by the toString methods strictly conform to JSON syntax rules. The constructors are more forgiving in the texts they will accept:

  • An extra , (comma) may appear just before the closing bracket.
  • The null value will be inserted when there is , (comma) elision.
  • Strings may be quoted with ' (single quote).
  • Strings do not need to be quoted at all if they do not begin with a quote or single quote, and if they do not contain leading or trailing spaces, and if they do not contain any of these characters: { } [ ] / \ : , = ; # and if they do not look like numbers and if they are not the reserved words true, false, or null.
  • Values can be separated by ; (semicolon) as well as by , (comma).
  • Numbers may have the 0x- (hex) prefix.

Version:
2009-04-14
Author:
JSON.org

Constructor Summary
JSONArray()
Construct an empty JSONArray.
JSONArray(java.util.Collection collection)
Construct a JSONArray from a Collection.
JSONArray(JSONTokener x)
Construct a JSONArray from a JSONTokener.
JSONArray(java.lang.Object array)
Construct a JSONArray from an array
JSONArray(java.lang.String source)
Construct a JSONArray from a source JSON text.
Method Summary
java.lang.Object | get(int index) Get the object value associated with an index.
boolean | getBoolean(int index) Get the boolean value associated with an index.
double | getDouble(int index) Get the double value associated with an index.
int | getInt(int index) Get the int value associated with an index.
JSONArray | getJSONArray(int index) Get the JSONArray associated with an index.
JSONObject | getJSONObject(int index) Get the JSONObject associated with an index.
long | getLong(int index) Get the long value associated with an index.
java.lang.String | getString(int index) Get the string associated with an index.
boolean | isNull(int index) Determine if the value is null.
java.lang.String | join(java.lang.String separator) Make a string from the contents of this JSONArray.
int | length() Get the number of elements in the JSONArray, included nulls.
java.lang.Object | opt(int index) Get the optional object value associated with an index.
boolean | optBoolean(int index) Get the optional boolean value associated with an index.
boolean | optBoolean(int index, boolean defaultValue) Get the optional boolean value associated with an index.
double | optDouble(int index) Get the optional double value associated with an index.
double | optDouble(int index, double defaultValue) Get the optional double value associated with an index.
int | optInt(int index) Get the optional int value associated with an index.
int | optInt(int index, int defaultValue) Get the optional int value associated with an index.
JSONArray | optJSONArray(int index) Get the optional JSONArray associated with an index.
JSONObject | optJSONObject(int index) Get the optional JSONObject associated with an index.
long | optLong(int index) Get the optional long value associated with an index.
long | optLong(int index, long defaultValue) Get the optional long value associated with an index.
java.lang.String | optString(int index) Get the optional string value associated with an index.
java.lang.String | optString(int index, java.lang.String defaultValue) Get the optional string associated with an index.
JSONArray | put(boolean value) Append a boolean value.
JSONArray | put(java.util.Collection value) Put a value in the JSONArray, where the value will be a JSONArray which is produced from a Collection.
JSONArray | put(double value) Append a double value.
JSONArray | put(int value) Append an int value.
JSONArray | put(int index, boolean value) Put or replace a boolean value in the JSONArray.
JSONArray | put(int index, java.util.Collection value) Put a value in the JSONArray, where the value will be a JSONArray which is produced from a Collection.
JSONArray | put(int index, double value) Put or replace a double value.
JSONArray | put(int index, int value) Put or replace an int value.
JSONArray | put(int index, long value) Put or replace a long value.
JSONArray | put(int index, java.util.Map value) Put a value in the JSONArray, where the value will be a JSONObject which is produced from a Map.
JSONArray | put(int index, java.lang.Object value) Put or replace an object value in the JSONArray.
JSONArray | put(long value) Append an long value.
JSONArray | put(java.util.Map value) Put a value in the JSONArray, where the value will be a JSONObject which is produced from a Map.
JSONArray | put(java.lang.Object value) Append an object value.
java.lang.Object | remove(int index) Remove an index and close the hole.
JSONObject | toJSONObject(JSONArray names) Produce a JSONObject by combining a JSONArray of names with the values of this JSONArray.
java.lang.String | toString() Make a JSON text of this JSONArray.
java.lang.String | toString(int indentFactor) Make a prettyprinted JSON text of this JSONArray.
java.io.Writer | write(java.io.Writer writer) Write the contents of the JSONArray as JSON text to a writer.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JSONArray

public JSONArray()
Construct an empty JSONArray.

JSONArray

public JSONArray(JSONTokener x)
          throws JSONException
Construct a JSONArray from a JSONTokener.

Parameters:
x - A JSONTokener
Throws:
JSONException - If there is a syntax error.

JSONArray

public JSONArray(java.lang.String source)
          throws JSONException
Construct a JSONArray from a source JSON text.

Parameters:
source - A string that begins with [ (left bracket) and ends with ] (right bracket).
Throws:
JSONException - If there is a syntax error.

JSONArray

public JSONArray(java.util.Collection collection)
Construct a JSONArray from a Collection.

Parameters:
collection - A Collection.

JSONArray

public JSONArray(java.lang.Object array)
          throws JSONException
Construct a JSONArray from an array

Throws:
JSONException - If not an array.
Method Detail

get

public java.lang.Object get(int index)
                     throws JSONException
Get the object value associated with an index.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
An object value.
Throws:
JSONException - If there is no value for the index.

getBoolean

public boolean getBoolean(int index)
                   throws JSONException
Get the boolean value associated with an index. The string values "true" and "false" are converted to boolean.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
The truth.
Throws:
JSONException - If there is no value for the index or if the value is not convertable to boolean.

getDouble

public double getDouble(int index)
                 throws JSONException
Get the double value associated with an index.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
The value.
Throws:
JSONException - If the key is not found or if the value cannot be converted to a number.

getInt

public int getInt(int index)
           throws JSONException
Get the int value associated with an index.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
The value.
Throws:
JSONException - If the key is not found or if the value cannot be converted to a number. if the value cannot be converted to a number.

getJSONArray

public JSONArray getJSONArray(int index)
                       throws JSONException
Get the JSONArray associated with an index.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
A JSONArray value.
Throws:
JSONException - If there is no value for the index. or if the value is not a JSONArray

getJSONObject

public JSONObject getJSONObject(int index)
                         throws JSONException
Get the JSONObject associated with an index.

Parameters:
index - subscript
Returns:
A JSONObject value.
Throws:
JSONException - If there is no value for the index or if the value is not a JSONObject

getLong

public long getLong(int index)
             throws JSONException
Get the long value associated with an index.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
The value.
Throws:
JSONException - If the key is not found or if the value cannot be converted to a number.

getString

public java.lang.String getString(int index)
                           throws JSONException
Get the string associated with an index.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
A string value.
Throws:
JSONException - If there is no value for the index.

isNull

public boolean isNull(int index)
Determine if the value is null.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
true if the value at the index is null, or if there is no value.

join

public java.lang.String join(java.lang.String separator)
                      throws JSONException
Make a string from the contents of this JSONArray. The separator string is inserted between each element. Warning: This method assumes that the data structure is acyclical.

Parameters:
separator - A string that will be inserted between the elements.
Returns:
a string.
Throws:
JSONException - If the array contains an invalid number.

length

public int length()
Get the number of elements in the JSONArray, included nulls.

Returns:
The length (or size).

opt

public java.lang.Object opt(int index)
Get the optional object value associated with an index.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
An object value, or null if there is no object at that index.

optBoolean

public boolean optBoolean(int index)
Get the optional boolean value associated with an index. It returns false if there is no value at that index, or if the value is not Boolean.TRUE or the String "true".

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
The truth.

optBoolean

public boolean optBoolean(int index,
                          boolean defaultValue)
Get the optional boolean value associated with an index. It returns the defaultValue if there is no value at that index or if it is not a Boolean or the String "true" or "false" (case insensitive).

Parameters:
index - The index must be between 0 and length() - 1.
defaultValue - A boolean default.
Returns:
The truth.

optDouble

public double optDouble(int index)
Get the optional double value associated with an index. NaN is returned if there is no value for the index, or if the value is not a number and cannot be converted to a number.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
The value.

optDouble

public double optDouble(int index,
                        double defaultValue)
Get the optional double value associated with an index. The defaultValue is returned if there is no value for the index, or if the value is not a number and cannot be converted to a number.

Parameters:
index - subscript
defaultValue - The default value.
Returns:
The value.

optInt

public int optInt(int index)
Get the optional int value associated with an index. Zero is returned if there is no value for the index, or if the value is not a number and cannot be converted to a number.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
The value.

optInt

public int optInt(int index,
                  int defaultValue)
Get the optional int value associated with an index. The defaultValue is returned if there is no value for the index, or if the value is not a number and cannot be converted to a number.

Parameters:
index - The index must be between 0 and length() - 1.
defaultValue - The default value.
Returns:
The value.

optJSONArray

public JSONArray optJSONArray(int index)
Get the optional JSONArray associated with an index.

Parameters:
index - subscript
Returns:
A JSONArray value, or null if the index has no value, or if the value is not a JSONArray.

optJSONObject

public JSONObject optJSONObject(int index)
Get the optional JSONObject associated with an index. Null is returned if the key is not found, or null if the index has no value, or if the value is not a JSONObject.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
A JSONObject value.

optLong

public long optLong(int index)
Get the optional long value associated with an index. Zero is returned if there is no value for the index, or if the value is not a number and cannot be converted to a number.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
The value.

optLong

public long optLong(int index,
                    long defaultValue)
Get the optional long value associated with an index. The defaultValue is returned if there is no value for the index, or if the value is not a number and cannot be converted to a number.

Parameters:
index - The index must be between 0 and length() - 1.
defaultValue - The default value.
Returns:
The value.

optString

public java.lang.String optString(int index)
Get the optional string value associated with an index. It returns an empty string if there is no value at that index. If the value is not a string and is not null, then it is coverted to a string.

Parameters:
index - The index must be between 0 and length() - 1.
Returns:
A String value.

optString

public java.lang.String optString(int index,
                                  java.lang.String defaultValue)
Get the optional string associated with an index. The defaultValue is returned if the key is not found.

Parameters:
index - The index must be between 0 and length() - 1.
defaultValue - The default value.
Returns:
A String value.

put

public JSONArray put(boolean value)
Append a boolean value. This increases the array's length by one.

Parameters:
value - A boolean value.
Returns:
this.

put

public JSONArray put(java.util.Collection value)
Put a value in the JSONArray, where the value will be a JSONArray which is produced from a Collection.

Parameters:
value - A Collection value.
Returns:
this.

put

public JSONArray put(double value)
              throws JSONException
Append a double value. This increases the array's length by one.

Parameters:
value - A double value.
Returns:
this.
Throws:
JSONException - if the value is not finite.

put

public JSONArray put(int value)
Append an int value. This increases the array's length by one.

Parameters:
value - An int value.
Returns:
this.

put

public JSONArray put(long value)
Append an long value. This increases the array's length by one.

Parameters:
value - A long value.
Returns:
this.

put

public JSONArray put(java.util.Map value)
Put a value in the JSONArray, where the value will be a JSONObject which is produced from a Map.

Parameters:
value - A Map value.
Returns:
this.

put

public JSONArray put(java.lang.Object value)
Append an object value. This increases the array's length by one.

Parameters:
value - An object value. The value should be a Boolean, Double, Integer, JSONArray, JSONObject, Long, or String, or the JSONObject.NULL object.
Returns:
this.

put

public JSONArray put(int index,
                     boolean value)
              throws JSONException
Put or replace a boolean value in the JSONArray. If the index is greater than the length of the JSONArray, then null elements will be added as necessary to pad it out.

Parameters:
index - The subscript.
value - A boolean value.
Returns:
this.
Throws:
JSONException - If the index is negative.

put

public JSONArray put(int index,
                     java.util.Collection value)
              throws JSONException
Put a value in the JSONArray, where the value will be a JSONArray which is produced from a Collection.

Parameters:
index - The subscript.
value - A Collection value.
Returns:
this.
Throws:
JSONException - If the index is negative or if the value is not finite.

put

public JSONArray put(int index,
                     double value)
              throws JSONException
Put or replace a double value. If the index is greater than the length of the JSONArray, then null elements will be added as necessary to pad it out.

Parameters:
index - The subscript.
value - A double value.
Returns:
this.
Throws:
JSONException - If the index is negative or if the value is not finite.

put

public JSONArray put(int index,
                     int value)
              throws JSONException
Put or replace an int value. If the index is greater than the length of the JSONArray, then null elements will be added as necessary to pad it out.

Parameters:
index - The subscript.
value - An int value.
Returns:
this.
Throws:
JSONException - If the index is negative.

put

public JSONArray put(int index,
                     long value)
              throws JSONException
Put or replace a long value. If the index is greater than the length of the JSONArray, then null elements will be added as necessary to pad it out.

Parameters:
index - The subscript.
value - A long value.
Returns:
this.
Throws:
JSONException - If the index is negative.

put

public JSONArray put(int index,
                     java.util.Map value)
              throws JSONException
Put a value in the JSONArray, where the value will be a JSONObject which is produced from a Map.

Parameters:
index - The subscript.
value - The Map value.
Returns:
this.
Throws:
JSONException - If the index is negative or if the the value is an invalid number.

put

public JSONArray put(int index,
                     java.lang.Object value)
              throws JSONException
Put or replace an object value in the JSONArray. If the index is greater than the length of the JSONArray, then null elements will be added as necessary to pad it out.

Parameters:
index - The subscript.
value - The value to put into the array. The value should be a Boolean, Double, Integer, JSONArray, JSONObject, Long, or String, or the JSONObject.NULL object.
Returns:
this.
Throws:
JSONException - If the index is negative or if the the value is an invalid number.

remove

public java.lang.Object remove(int index)
Remove an index and close the hole.

Parameters:
index - The index of the element to be removed.
Returns:
The value that was associated with the index, or null if there was no value.

toJSONObject

public JSONObject toJSONObject(JSONArray names)
                        throws JSONException
Produce a JSONObject by combining a JSONArray of names with the values of this JSONArray.

Parameters:
names - A JSONArray containing a list of key strings. These will be paired with the values.
Returns:
A JSONObject, or null if there are no names or if this JSONArray has no values.
Throws:
JSONException - If any of the names are null.

toString

public java.lang.String toString()
Make a JSON text of this JSONArray. For compactness, no unnecessary whitespace is added. If it is not possible to produce a syntactically correct JSON text then null will be returned instead. This could occur if the array contains an invalid number.

Warning: This method assumes that the data structure is acyclical.

Overrides:
toString in class java.lang.Object
Returns:
a printable, displayable, transmittable representation of the array.

toString

public java.lang.String toString(int indentFactor)
                          throws JSONException
Make a prettyprinted JSON text of this JSONArray. Warning: This method assumes that the data structure is acyclical.

Parameters:
indentFactor - The number of spaces to add to each level of indentation.
Returns:
a printable, displayable, transmittable representation of the object, beginning with [ (left bracket) and ending with ] (right bracket).
Throws:
JSONException

write

public java.io.Writer write(java.io.Writer writer)
                     throws JSONException
Write the contents of the JSONArray as JSON text to a writer. For compactness, no whitespace is added.

Warning: This method assumes that the data structure is acyclical.

Returns:
The writer.
Throws:
JSONException
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.json.JSONArray (libgdx API)

Uses of Class
com.badlogic.gdx.utils.json.JSONArray

Packages that use JSONArray
com.badlogic.gdx.utils.json

Uses of JSONArray in com.badlogic.gdx.utils.json

Methods in com.badlogic.gdx.utils.json that return JSONArray
JSONArray | JSONArray.getJSONArray(int index) Get the JSONArray associated with an index.
JSONArray | JSONObject.getJSONArray(java.lang.String key) Get the JSONArray value associated with a key.
JSONArray | JSONObject.names() Produce a JSONArray containing the names of the elements of this JSONObject.
JSONArray | JSONArray.optJSONArray(int index) Get the optional JSONArray associated with an index.
JSONArray | JSONObject.optJSONArray(java.lang.String key) Get an optional JSONArray associated with a key.
JSONArray | JSONArray.put(boolean value) Append a boolean value.
JSONArray | JSONArray.put(java.util.Collection value) Put a value in the JSONArray, where the value will be a JSONArray which is produced from a Collection.
JSONArray | JSONArray.put(double value) Append a double value.
JSONArray | JSONArray.put(int value) Append an int value.
JSONArray | JSONArray.put(int index, boolean value) Put or replace a boolean value in the JSONArray.
JSONArray | JSONArray.put(int index, java.util.Collection value) Put a value in the JSONArray, where the value will be a JSONArray which is produced from a Collection.
JSONArray | JSONArray.put(int index, double value) Put or replace a double value.
JSONArray | JSONArray.put(int index, int value) Put or replace an int value.
JSONArray | JSONArray.put(int index, long value) Put or replace a long value.
JSONArray | JSONArray.put(int index, java.util.Map value) Put a value in the JSONArray, where the value will be a JSONObject which is produced from a Map.
JSONArray | JSONArray.put(int index, java.lang.Object value) Put or replace an object value in the JSONArray.
JSONArray | JSONArray.put(long value) Append an long value.
JSONArray | JSONArray.put(java.util.Map value) Put a value in the JSONArray, where the value will be a JSONObject which is produced from a Map.
JSONArray | JSONArray.put(java.lang.Object value) Append an object value.
JSONArray | JSONObject.toJSONArray(JSONArray names) Produce a JSONArray containing the values of the members of this JSONObject.

Methods in com.badlogic.gdx.utils.json with parameters of type JSONArray
JSONArray | JSONObject.toJSONArray(JSONArray names) Produce a JSONArray containing the values of the members of this JSONObject.
JSONObject | JSONArray.toJSONObject(JSONArray names) Produce a JSONObject by combining a JSONArray of names with the values of this JSONArray.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JSONException (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils.json
Class JSONException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  com.badlogic.gdx.utils.json.JSONException
All Implemented Interfaces:
java.io.Serializable
public class JSONException
extends java.lang.Exception

The JSONException is thrown by the JSON.org classes when things are amiss.

Version:
2008-09-18
Author:
JSON.org
See Also:
Serialized Form

Constructor Summary
JSONException(java.lang.String message)
Constructs a JSONException with an explanatory message.
JSONException(java.lang.Throwable t)
Method Summary
 java.lang.Throwable getCause()
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JSONException

public JSONException(java.lang.String message)
Constructs a JSONException with an explanatory message.

Parameters:
message - Detail about the reason for the exception.

JSONException

public JSONException(java.lang.Throwable t)
Method Detail

getCause

public java.lang.Throwable getCause()
Overrides:
getCause in class java.lang.Throwable
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.json.JSONException (libgdx API)

Uses of Class
com.badlogic.gdx.utils.json.JSONException

Packages that use JSONException
com.badlogic.gdx.utils.json

Uses of JSONException in com.badlogic.gdx.utils.json

Methods in com.badlogic.gdx.utils.json that return JSONException
 JSONException JSONTokener.syntaxError(java.lang.String message)
Make a JSONException to signal a syntax error.

Methods in com.badlogic.gdx.utils.json that throw JSONException
 JSONObject JSONObject.accumulate(java.lang.String key, java.lang.Object value)
Accumulate values under a key.
 JSONObject JSONObject.append(java.lang.String key, java.lang.Object value)
Append values to the array under a key.
 JSONWriter JSONWriter.array()
Begin appending a new array.
 void JSONTokener.back()
Back up one character.
 JSONWriter JSONWriter.endArray()
End an array.
 JSONWriter JSONWriter.endObject()
End an object.
 java.lang.Object JSONArray.get(int index)
Get the object value associated with an index.
 java.lang.Object JSONObject.get(java.lang.String key)
Get the value object associated with a key.
 boolean JSONArray.getBoolean(int index)
Get the boolean value associated with an index.
 boolean JSONObject.getBoolean(java.lang.String key)
Get the boolean value associated with a key.
 double JSONArray.getDouble(int index)
Get the double value associated with an index.
 double JSONObject.getDouble(java.lang.String key)
Get the double value associated with a key.
 int JSONArray.getInt(int index)
Get the int value associated with an index.
 int JSONObject.getInt(java.lang.String key)
Get the int value associated with a key.
 JSONArray JSONArray.getJSONArray(int index)
Get the JSONArray associated with an index.
 JSONArray JSONObject.getJSONArray(java.lang.String key)
Get the JSONArray value associated with a key.
 JSONObject JSONArray.getJSONObject(int index)
Get the JSONObject associated with an index.
 JSONObject JSONObject.getJSONObject(java.lang.String key)
Get the JSONObject value associated with a key.
 long JSONArray.getLong(int index)
Get the long value associated with an index.
 long JSONObject.getLong(java.lang.String key)
Get the long value associated with a key.
 java.lang.String JSONArray.getString(int index)
Get the string associated with an index.
 java.lang.String JSONObject.getString(java.lang.String key)
Get the string associated with a key.
 JSONObject JSONObject.increment(java.lang.String key)
Increment a property of a JSONObject.
 java.lang.String JSONArray.join(java.lang.String separator)
Make a string from the contents of this JSONArray.
 JSONWriter JSONWriter.key(java.lang.String s)
Append a key.
 boolean JSONTokener.more()
Determine if the source string still contains characters that next() can consume.
 char JSONTokener.next()
Get the next character in the source string.
 char JSONTokener.next(char c)
Consume the next character, and check that it matches a specified character.
 java.lang.String JSONTokener.next(int n)
Get the next n characters.
 char JSONTokener.nextClean()
Get the next char in the string, skipping whitespace.
 java.lang.String JSONTokener.nextString(char quote)
Return the characters up to the next close quote character.
 java.lang.String JSONTokener.nextTo(char d)
Get the text up but not including the specified character or the end of line, whichever comes first.
 java.lang.String JSONTokener.nextTo(java.lang.String delimiters)
Get the text up but not including one of the specified delimiter characters or the end of line, whichever comes first.
 java.lang.Object JSONTokener.nextValue()
Get the next value.
static java.lang.String JSONObject.numberToString(java.lang.Number n)
Produce a string from a Number.
 JSONWriter JSONWriter.object()
Begin appending a new object.
 JSONArray JSONArray.put(double value)
Append a double value.
 JSONArray JSONArray.put(int index, boolean value)
Put or replace a boolean value in the JSONArray.
 JSONArray JSONArray.put(int index, java.util.Collection value)
Put a value in the JSONArray, where the value will be a JSONArray which is produced from a Collection.
 JSONArray JSONArray.put(int index, double value)
Put or replace a double value.
 JSONArray JSONArray.put(int index, int value)
Put or replace an int value.
 JSONArray JSONArray.put(int index, long value)
Put or replace a long value.
 JSONArray JSONArray.put(int index, java.util.Map value)
Put a value in the JSONArray, where the value will be a JSONObject which is produced from a Map.
 JSONArray JSONArray.put(int index, java.lang.Object value)
Put or replace an object value in the JSONArray.
 JSONObject JSONObject.put(java.lang.String key, boolean value)
Put a key/boolean pair in the JSONObject.
 JSONObject JSONObject.put(java.lang.String key, java.util.Collection value)
Put a key/value pair in the JSONObject, where the value will be a JSONArray which is produced from a Collection.
 JSONObject JSONObject.put(java.lang.String key, double value)
Put a key/double pair in the JSONObject.
 JSONObject JSONObject.put(java.lang.String key, int value)
Put a key/int pair in the JSONObject.
 JSONObject JSONObject.put(java.lang.String key, long value)
Put a key/long pair in the JSONObject.
 JSONObject JSONObject.put(java.lang.String key, java.util.Map value)
Put a key/value pair in the JSONObject, where the value will be a JSONObject which is produced from a Map.
 JSONObject JSONObject.put(java.lang.String key, java.lang.Object value)
Put a key/value pair in the JSONObject.
 JSONObject JSONObject.putOnce(java.lang.String key, java.lang.Object value)
Put a key/value pair in the JSONObject, but only if the key and the value are both non-null, and only if there is not already a member with that name.
 JSONObject JSONObject.putOpt(java.lang.String key, java.lang.Object value)
Put a key/value pair in the JSONObject, but only if the key and the value are both non-null.
 char JSONTokener.skipTo(char to)
Skip characters until the next character is the requested character.
 JSONArray JSONObject.toJSONArray(JSONArray names)
Produce a JSONArray containing the values of the members of this JSONObject.
 JSONObject JSONArray.toJSONObject(JSONArray names)
Produce a JSONObject by combining a JSONArray of names with the values of this JSONArray.
 java.lang.String JSONArray.toString(int indentFactor)
Make a prettyprinted JSON text of this JSONArray.
 java.lang.String JSONObject.toString(int indentFactor)
Make a prettyprinted JSON text of this JSONObject.
 JSONWriter JSONWriter.value(boolean b)
Append either the value true or the value false.
 JSONWriter JSONWriter.value(double d)
Append a double value.
 JSONWriter JSONWriter.value(long l)
Append a long value.
 JSONWriter JSONWriter.value(java.lang.Object o)
Append an object value.
 java.io.Writer JSONArray.write(java.io.Writer writer)
Write the contents of the JSONArray as JSON text to a writer.
 java.io.Writer JSONObject.write(java.io.Writer writer)
Write the contents of the JSONObject as JSON text to a writer.

Constructors in com.badlogic.gdx.utils.json that throw JSONException
JSONArray(JSONTokener x)
Construct a JSONArray from a JSONTokener.
JSONArray(java.lang.Object array)
Construct a JSONArray from an array
JSONArray(java.lang.String source)
Construct a JSONArray from a source JSON text.
JSONObject(JSONTokener x)
Construct a JSONObject from a JSONTokener.
JSONObject(java.lang.String source)
Construct a JSONObject from a source JSON text string.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JSONObject (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils.json
Class JSONObject

java.lang.Object
    extended by  com.badlogic.gdx.utils.json.JSONObject

public class JSONObject
extends java.lang.Object

A JSONObject is an unordered collection of name/value pairs. Its external form is a string wrapped in curly braces with colons between the names and values, and commas between the values and names. The internal form is an object having get and opt methods for accessing the values by name, and put methods for adding or replacing values by name. The values can be any of these types: Boolean, JSONArray, JSONObject, Number, String, or the JSONObject.NULL object. A JSONObject constructor can be used to convert an external form JSON text into an internal form whose values can be retrieved with the get and opt methods, or to convert values into a JSON text using the put and toString methods. A get method returns a value if one can be found, and throws an exception if one cannot be found. An opt method returns a default value instead of throwing an exception, and so is useful for obtaining optional values.

The generic get() and opt() methods return an object, which you can cast or query for type. There are also typed get and opt methods that do type checking and type coercion for you.

The put methods adds values to an object. For example,

 myString = new JSONObject().put("JSON", "Hello, World!").toString();
produces the string {"JSON": "Hello, World"}.

The texts produced by the toString methods strictly conform to the JSON syntax rules. The constructors are more forgiving in the texts they will accept:

  • An extra , (comma) may appear just before the closing brace.
  • Strings may be quoted with ' (single quote).
  • Strings do not need to be quoted at all if they do not begin with a quote or single quote, and if they do not contain leading or trailing spaces, and if they do not contain any of these characters: { } [ ] / \ : , = ; # and if they do not look like numbers and if they are not the reserved words true, false, or null.
  • Keys can be followed by = or => as well as by :.
  • Values can be followed by ; (semicolon) as well as by , (comma).
  • Numbers may have the 0x- (hex) prefix.

Version:
2010-05-17
Author:
JSON.org

Field Summary
static java.lang.Object NULL
It is sometimes more convenient and less ambiguous to have a NULL object than to use Java's null value.
Constructor Summary
JSONObject()
Construct an empty JSONObject.
JSONObject(JSONObject jo, java.lang.String[] names)
Construct a JSONObject from a subset of another JSONObject.
JSONObject(JSONTokener x)
Construct a JSONObject from a JSONTokener.
JSONObject(java.util.Map map)
Construct a JSONObject from a Map.
JSONObject(java.lang.Object bean)
Construct a JSONObject from an Object using bean getters.
JSONObject(java.lang.Object object, java.lang.String[] names)
Construct a JSONObject from an Object, using reflection to find the public members.
JSONObject(java.lang.String source)
Construct a JSONObject from a source JSON text string.
Method Summary
JSONObject | accumulate(java.lang.String key, java.lang.Object value) Accumulate values under a key.
JSONObject | append(java.lang.String key, java.lang.Object value) Append values to the array under a key.
static java.lang.String | doubleToString(double d) Produce a string from a double.
java.lang.Object | get(java.lang.String key) Get the value object associated with a key.
boolean | getBoolean(java.lang.String key) Get the boolean value associated with a key.
double | getDouble(java.lang.String key) Get the double value associated with a key.
int | getInt(java.lang.String key) Get the int value associated with a key.
JSONArray | getJSONArray(java.lang.String key) Get the JSONArray value associated with a key.
JSONObject | getJSONObject(java.lang.String key) Get the JSONObject value associated with a key.
long | getLong(java.lang.String key) Get the long value associated with a key.
static java.lang.String[] | getNames(JSONObject jo) Get an array of field names from a JSONObject.
static java.lang.String[] | getNames(java.lang.Object object) Get an array of field names from an Object.
java.lang.String | getString(java.lang.String key) Get the string associated with a key.
boolean | has(java.lang.String key) Determine if the JSONObject contains a specific key.
JSONObject | increment(java.lang.String key) Increment a property of a JSONObject.
boolean | isNull(java.lang.String key) Determine if the value associated with the key is null or if there is no value.
java.util.Iterator | keys() Get an enumeration of the keys of the JSONObject.
int | length() Get the number of keys stored in the JSONObject.
JSONArray | names() Produce a JSONArray containing the names of the elements of this JSONObject.
static java.lang.String | numberToString(java.lang.Number n) Produce a string from a Number.
java.lang.Object | opt(java.lang.String key) Get an optional value associated with a key.
boolean | optBoolean(java.lang.String key) Get an optional boolean associated with a key.
boolean | optBoolean(java.lang.String key, boolean defaultValue) Get an optional boolean associated with a key.
double | optDouble(java.lang.String key) Get an optional double associated with a key, or NaN if there is no such key or if its value is not a number.
double | optDouble(java.lang.String key, double defaultValue) Get an optional double associated with a key, or the defaultValue if there is no such key or if its value is not a number.
int | optInt(java.lang.String key) Get an optional int value associated with a key, or zero if there is no such key or if the value is not a number.
int | optInt(java.lang.String key, int defaultValue) Get an optional int value associated with a key, or the default if there is no such key or if the value is not a number.
JSONArray | optJSONArray(java.lang.String key) Get an optional JSONArray associated with a key.
JSONObject | optJSONObject(java.lang.String key) Get an optional JSONObject associated with a key.
long | optLong(java.lang.String key) Get an optional long value associated with a key, or zero if there is no such key or if the value is not a number.
long | optLong(java.lang.String key, long defaultValue) Get an optional long value associated with a key, or the default if there is no such key or if the value is not a number.
java.lang.String | optString(java.lang.String key) Get an optional string associated with a key.
java.lang.String | optString(java.lang.String key, java.lang.String defaultValue) Get an optional string associated with a key.
JSONObject | put(java.lang.String key, boolean value) Put a key/boolean pair in the JSONObject.
JSONObject | put(java.lang.String key, java.util.Collection value) Put a key/value pair in the JSONObject, where the value will be a JSONArray which is produced from a Collection.
JSONObject | put(java.lang.String key, double value) Put a key/double pair in the JSONObject.
JSONObject | put(java.lang.String key, int value) Put a key/int pair in the JSONObject.
JSONObject | put(java.lang.String key, long value) Put a key/long pair in the JSONObject.
JSONObject | put(java.lang.String key, java.util.Map value) Put a key/value pair in the JSONObject, where the value will be a JSONObject which is produced from a Map.
JSONObject | put(java.lang.String key, java.lang.Object value) Put a key/value pair in the JSONObject.
JSONObject | putOnce(java.lang.String key, java.lang.Object value) Put a key/value pair in the JSONObject, but only if the key and the value are both non-null, and only if there is not already a member with that name.
JSONObject | putOpt(java.lang.String key, java.lang.Object value) Put a key/value pair in the JSONObject, but only if the key and the value are both non-null.
static java.lang.String | quote(java.lang.String string) Produce a string in double quotes with backslash sequences in all the right places.
java.lang.Object | remove(java.lang.String key) Remove a name and its value, if present.
java.util.Iterator | sortedKeys() Get an enumeration of the keys of the JSONObject.
static java.lang.Object | stringToValue(java.lang.String s) Try to convert a string into a number, boolean, or null.
JSONArray | toJSONArray(JSONArray names) Produce a JSONArray containing the values of the members of this JSONObject.
java.lang.String | toString() Make a JSON text of this JSONObject.
java.lang.String | toString(int indentFactor) Make a prettyprinted JSON text of this JSONObject.
java.io.Writer | write(java.io.Writer writer) Write the contents of the JSONObject as JSON text to a writer.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NULL

public static final java.lang.Object NULL
It is sometimes more convenient and less ambiguous to have a NULL object than to use Java's null value. JSONObject.NULL.equals(null) returns true. JSONObject.NULL.toString() returns "null".

Constructor Detail

JSONObject

public JSONObject()
Construct an empty JSONObject.

JSONObject

public JSONObject(JSONObject jo,
                  java.lang.String[] names)
Construct a JSONObject from a subset of another JSONObject. An array of strings is used to identify the keys that should be copied. Missing keys are ignored.

Parameters:
jo - A JSONObject.
names - An array of strings.

JSONObject

public JSONObject(JSONTokener x)
           throws JSONException
Construct a JSONObject from a JSONTokener.

Parameters:
x - A JSONTokener object containing the source string.
Throws:
JSONException - If there is a syntax error in the source string or a duplicated key.

JSONObject

public JSONObject(java.util.Map map)
Construct a JSONObject from a Map.

Parameters:
map - A map object that can be used to initialize the contents of the JSONObject.

JSONObject

public JSONObject(java.lang.Object bean)
Construct a JSONObject from an Object using bean getters. It reflects on all of the public methods of the object. For each of the methods with no parameters and a name starting with "get" or "is" followed by an uppercase letter, the method is invoked, and a key and the value returned from the getter method are put into the new JSONObject. The key is formed by removing the "get" or "is" prefix. If the second remaining character is not upper case, then the first character is converted to lower case. For example, if an object has a method named "getName", and if the result of calling object.getName() is "Larry Fine", then the JSONObject will contain "name": "Larry Fine".

Parameters:
bean - An object that has getter methods that should be used to make a JSONObject.

JSONObject

public JSONObject(java.lang.Object object,
                  java.lang.String[] names)
Construct a JSONObject from an Object, using reflection to find the public members. The resulting JSONObject's keys will be the strings from the names array, and the values will be the field values associated with those keys in the object. If a key is not found or not visible, then it will not be copied into the new JSONObject.

Parameters:
object - An object that has fields that should be used to make a JSONObject.
names - An array of strings, the names of the fields to be obtained from the object.

JSONObject

public JSONObject(java.lang.String source)
           throws JSONException
Construct a JSONObject from a source JSON text string. This is the most commonly used JSONObject constructor.

Parameters:
source - A string beginning with { (left brace) and ending with } (right brace).
Throws:
JSONException - If there is a syntax error in the source string or a duplicated key.
Method Detail

accumulate

public JSONObject accumulate(java.lang.String key,
                             java.lang.Object value)
                      throws JSONException
Accumulate values under a key. It is similar to the put method except that if there is already an object stored under the key then a JSONArray is stored under the key to hold all of the accumulated values. If there is already a JSONArray, then the new value is appended to it. In contrast, the put method replaces the previous value.

Parameters:
key - A key string.
value - An object to be accumulated under the key.
Returns:
this.
Throws:
JSONException - If the value is an invalid number or if the key is null.

append

public JSONObject append(java.lang.String key,
                         java.lang.Object value)
                  throws JSONException
Append values to the array under a key. If the key does not exist in the JSONObject, then the key is put in the JSONObject with its value being a JSONArray containing the value parameter. If the key was already associated with a JSONArray, then the value parameter is appended to it.

Parameters:
key - A key string.
value - An object to be accumulated under the key.
Returns:
this.
Throws:
JSONException - If the key is null or if the current value associated with the key is not a JSONArray.

doubleToString

public static java.lang.String doubleToString(double d)
Produce a string from a double. The string "null" will be returned if the number is not finite.

Parameters:
d - A double.
Returns:
A String.

get

public java.lang.Object get(java.lang.String key)
                     throws JSONException
Get the value object associated with a key.

Parameters:
key - A key string.
Returns:
The object associated with the key.
Throws:
JSONException - if the key is not found.

getBoolean

public boolean getBoolean(java.lang.String key)
                   throws JSONException
Get the boolean value associated with a key.

Parameters:
key - A key string.
Returns:
The truth.
Throws:
JSONException - if the value is not a Boolean or the String "true" or "false".

getDouble

public double getDouble(java.lang.String key)
                 throws JSONException
Get the double value associated with a key.

Parameters:
key - A key string.
Returns:
The numeric value.
Throws:
JSONException - if the key is not found or if the value is not a Number object and cannot be converted to a number.

getInt

public int getInt(java.lang.String key)
           throws JSONException
Get the int value associated with a key.

Parameters:
key - A key string.
Returns:
The integer value.
Throws:
JSONException - if the key is not found or if the value cannot be converted to an integer.

getJSONArray

public JSONArray getJSONArray(java.lang.String key)
                       throws JSONException
Get the JSONArray value associated with a key.

Parameters:
key - A key string.
Returns:
A JSONArray which is the value.
Throws:
JSONException - if the key is not found or if the value is not a JSONArray.

getJSONObject

public JSONObject getJSONObject(java.lang.String key)
                         throws JSONException
Get the JSONObject value associated with a key.

Parameters:
key - A key string.
Returns:
A JSONObject which is the value.
Throws:
JSONException - if the key is not found or if the value is not a JSONObject.

getLong

public long getLong(java.lang.String key)
             throws JSONException
Get the long value associated with a key.

Parameters:
key - A key string.
Returns:
The long value.
Throws:
JSONException - if the key is not found or if the value cannot be converted to a long.

getNames

public static java.lang.String[] getNames(JSONObject jo)
Get an array of field names from a JSONObject.

Returns:
An array of field names, or null if there are no names.

getNames

public static java.lang.String[] getNames(java.lang.Object object)
Get an array of field names from an Object.

Returns:
An array of field names, or null if there are no names.

getString

public java.lang.String getString(java.lang.String key)
                           throws JSONException
Get the string associated with a key.

Parameters:
key - A key string.
Returns:
A string which is the value.
Throws:
JSONException - if the key is not found.

has

public boolean has(java.lang.String key)
Determine if the JSONObject contains a specific key.

Parameters:
key - A key string.
Returns:
true if the key exists in the JSONObject.

increment

public JSONObject increment(java.lang.String key)
                     throws JSONException
Increment a property of a JSONObject. If there is no such property, create one with a value of 1. If there is such a property, and if it is an Integer, Long, Double, or Float, then add one to it.

Parameters:
key - A key string.
Returns:
this.
Throws:
JSONException - If there is already a property with this name that is not an Integer, Long, Double, or Float.

isNull

public boolean isNull(java.lang.String key)
Determine if the value associated with the key is null or if there is no value.

Parameters:
key - A key string.
Returns:
true if there is no value associated with the key or if the value is the JSONObject.NULL object.

keys

public java.util.Iterator keys()
Get an enumeration of the keys of the JSONObject.

Returns:
An iterator of the keys.

length

public int length()
Get the number of keys stored in the JSONObject.

Returns:
The number of keys in the JSONObject.

names

public JSONArray names()
Produce a JSONArray containing the names of the elements of this JSONObject.

Returns:
A JSONArray containing the key strings, or null if the JSONObject is empty.

numberToString

public static java.lang.String numberToString(java.lang.Number n)
                                       throws JSONException
Produce a string from a Number.

Parameters:
n - A Number
Returns:
A String.
Throws:
JSONException - If n is a non-finite number.

opt

public java.lang.Object opt(java.lang.String key)
Get an optional value associated with a key.

Parameters:
key - A key string.
Returns:
An object which is the value, or null if there is no value.

optBoolean

public boolean optBoolean(java.lang.String key)
Get an optional boolean associated with a key. It returns false if there is no such key, or if the value is not Boolean.TRUE or the String "true".

Parameters:
key - A key string.
Returns:
The truth.

optBoolean

public boolean optBoolean(java.lang.String key,
                          boolean defaultValue)
Get an optional boolean associated with a key. It returns the defaultValue if there is no such key, or if it is not a Boolean or the String "true" or "false" (case insensitive).

Parameters:
key - A key string.
defaultValue - The default.
Returns:
The truth.

optDouble

public double optDouble(java.lang.String key)
Get an optional double associated with a key, or NaN if there is no such key or if its value is not a number. If the value is a string, an attempt will be made to evaluate it as a number.

Parameters:
key - A string which is the key.
Returns:
An object which is the value.

optDouble

public double optDouble(java.lang.String key,
                        double defaultValue)
Get an optional double associated with a key, or the defaultValue if there is no such key or if its value is not a number. If the value is a string, an attempt will be made to evaluate it as a number.

Parameters:
key - A key string.
defaultValue - The default.
Returns:
An object which is the value.

optInt

public int optInt(java.lang.String key)
Get an optional int value associated with a key, or zero if there is no such key or if the value is not a number. If the value is a string, an attempt will be made to evaluate it as a number.

Parameters:
key - A key string.
Returns:
An object which is the value.

optInt

public int optInt(java.lang.String key,
                  int defaultValue)
Get an optional int value associated with a key, or the default if there is no such key or if the value is not a number. If the value is a string, an attempt will be made to evaluate it as a number.

Parameters:
key - A key string.
defaultValue - The default.
Returns:
An object which is the value.

optJSONArray

public JSONArray optJSONArray(java.lang.String key)
Get an optional JSONArray associated with a key. It returns null if there is no such key, or if its value is not a JSONArray.

Parameters:
key - A key string.
Returns:
A JSONArray which is the value.

optJSONObject

public JSONObject optJSONObject(java.lang.String key)
Get an optional JSONObject associated with a key. It returns null if there is no such key, or if its value is not a JSONObject.

Parameters:
key - A key string.
Returns:
A JSONObject which is the value.

optLong

public long optLong(java.lang.String key)
Get an optional long value associated with a key, or zero if there is no such key or if the value is not a number. If the value is a string, an attempt will be made to evaluate it as a number.

Parameters:
key - A key string.
Returns:
An object which is the value.

optLong

public long optLong(java.lang.String key,
                    long defaultValue)
Get an optional long value associated with a key, or the default if there is no such key or if the value is not a number. If the value is a string, an attempt will be made to evaluate it as a number.

Parameters:
key - A key string.
defaultValue - The default.
Returns:
An object which is the value.

optString

public java.lang.String optString(java.lang.String key)
Get an optional string associated with a key. It returns an empty string if there is no such key. If the value is not a string and is not null, then it is coverted to a string.

Parameters:
key - A key string.
Returns:
A string which is the value.

optString

public java.lang.String optString(java.lang.String key,
                                  java.lang.String defaultValue)
Get an optional string associated with a key. It returns the defaultValue if there is no such key.

Parameters:
key - A key string.
defaultValue - The default.
Returns:
A string which is the value.

put

public JSONObject put(java.lang.String key,
                      boolean value)
               throws JSONException
Put a key/boolean pair in the JSONObject.

Parameters:
key - A key string.
value - A boolean which is the value.
Returns:
this.
Throws:
JSONException - If the key is null.

put

public JSONObject put(java.lang.String key,
                      java.util.Collection value)
               throws JSONException
Put a key/value pair in the JSONObject, where the value will be a JSONArray which is produced from a Collection.

Parameters:
key - A key string.
value - A Collection value.
Returns:
this.
Throws:
JSONException

put

public JSONObject put(java.lang.String key,
                      double value)
               throws JSONException
Put a key/double pair in the JSONObject.

Parameters:
key - A key string.
value - A double which is the value.
Returns:
this.
Throws:
JSONException - If the key is null or if the number is invalid.

put

public JSONObject put(java.lang.String key,
                      int value)
               throws JSONException
Put a key/int pair in the JSONObject.

Parameters:
key - A key string.
value - An int which is the value.
Returns:
this.
Throws:
JSONException - If the key is null.

put

public JSONObject put(java.lang.String key,
                      long value)
               throws JSONException
Put a key/long pair in the JSONObject.

Parameters:
key - A key string.
value - A long which is the value.
Returns:
this.
Throws:
JSONException - If the key is null.

put

public JSONObject put(java.lang.String key,
                      java.util.Map value)
               throws JSONException
Put a key/value pair in the JSONObject, where the value will be a JSONObject which is produced from a Map.

Parameters:
key - A key string.
value - A Map value.
Returns:
this.
Throws:
JSONException

put

public JSONObject put(java.lang.String key,
                      java.lang.Object value)
               throws JSONException
Put a key/value pair in the JSONObject. If the value is null, then the key will be removed from the JSONObject if it is present.

Parameters:
key - A key string.
value - An object which is the value. It should be of one of these types: Boolean, Double, Integer, JSONArray, JSONObject, Long, String, or the JSONObject.NULL object.
Returns:
this.
Throws:
JSONException - If the value is non-finite number or if the key is null.

putOnce

public JSONObject putOnce(java.lang.String key,
                          java.lang.Object value)
                   throws JSONException
Put a key/value pair in the JSONObject, but only if the key and the value are both non-null, and only if there is not already a member with that name.

Parameters:
key -
value -
Returns:
his.
Throws:
JSONException - if the key is a duplicate

putOpt

public JSONObject putOpt(java.lang.String key,
                         java.lang.Object value)
                  throws JSONException
Put a key/value pair in the JSONObject, but only if the key and the value are both non-null.

Parameters:
key - A key string.
value - An object which is the value. It should be of one of these types: Boolean, Double, Integer, JSONArray, JSONObject, Long, String, or the JSONObject.NULL object.
Returns:
this.
Throws:
JSONException - If the value is a non-finite number.

quote

public static java.lang.String quote(java.lang.String string)
Produce a string in double quotes with backslash sequences in all the right places. A backslash will be inserted within
Parameters:
string - A String
Returns:
A String correctly formatted for insertion in a JSON text.

remove

public java.lang.Object remove(java.lang.String key)
Remove a name and its value, if present.

Parameters:
key - The name to be removed.
Returns:
The value that was associated with the name, or null if there was no value.

sortedKeys

public java.util.Iterator sortedKeys()
Get an enumeration of the keys of the JSONObject. The keys will be sorted alphabetically.

Returns:
An iterator of the keys.

stringToValue

public static java.lang.Object stringToValue(java.lang.String s)
Try to convert a string into a number, boolean, or null. If the string can't be converted, return the string.

Parameters:
s - A String.
Returns:
A simple JSON value.

toJSONArray

public JSONArray toJSONArray(JSONArray names)
                      throws JSONException
Produce a JSONArray containing the values of the members of this JSONObject.

Parameters:
names - A JSONArray containing a list of key strings. This determines the sequence of the values in the result.
Returns:
A JSONArray of values.
Throws:
JSONException - If any of the values are non-finite numbers.

toString

public java.lang.String toString()
Make a JSON text of this JSONObject. For compactness, no whitespace is added. If this would not result in a syntactically correct JSON text, then null will be returned instead.

Warning: This method assumes that the data structure is acyclical.

Overrides:
toString in class java.lang.Object
Returns:
a printable, displayable, portable, transmittable representation of the object, beginning with { (left brace) and ending with } (right brace).

toString

public java.lang.String toString(int indentFactor)
                          throws JSONException
Make a prettyprinted JSON text of this JSONObject.

Warning: This method assumes that the data structure is acyclical.

Parameters:
indentFactor - The number of spaces to add to each level of indentation.
Returns:
a printable, displayable, portable, transmittable representation of the object, beginning with { (left brace) and ending with } (right brace).
Throws:
JSONException - If the object contains an invalid number.

write

public java.io.Writer write(java.io.Writer writer)
                     throws JSONException
Write the contents of the JSONObject as JSON text to a writer. For compactness, no whitespace is added.

Warning: This method assumes that the data structure is acyclical.

Returns:
The writer.
Throws:
JSONException
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.json.JSONObject (libgdx API)

Uses of Class
com.badlogic.gdx.utils.json.JSONObject

Packages that use JSONObject
com.badlogic.gdx.utils.json

Uses of JSONObject in com.badlogic.gdx.utils.json

Methods in com.badlogic.gdx.utils.json that return JSONObject
JSONObject | JSONObject.accumulate(java.lang.String key, java.lang.Object value) Accumulate values under a key.
JSONObject | JSONObject.append(java.lang.String key, java.lang.Object value) Append values to the array under a key.
JSONObject | JSONArray.getJSONObject(int index) Get the JSONObject associated with an index.
JSONObject | JSONObject.getJSONObject(java.lang.String key) Get the JSONObject value associated with a key.
JSONObject | JSONObject.increment(java.lang.String key) Increment a property of a JSONObject.
JSONObject | JSONArray.optJSONObject(int index) Get the optional JSONObject associated with an index.
JSONObject | JSONObject.optJSONObject(java.lang.String key) Get an optional JSONObject associated with a key.
JSONObject | JSONObject.put(java.lang.String key, boolean value) Put a key/boolean pair in the JSONObject.
JSONObject | JSONObject.put(java.lang.String key, java.util.Collection value) Put a key/value pair in the JSONObject, where the value will be a JSONArray which is produced from a Collection.
JSONObject | JSONObject.put(java.lang.String key, double value) Put a key/double pair in the JSONObject.
JSONObject | JSONObject.put(java.lang.String key, int value) Put a key/int pair in the JSONObject.
JSONObject | JSONObject.put(java.lang.String key, long value) Put a key/long pair in the JSONObject.
JSONObject | JSONObject.put(java.lang.String key, java.util.Map value) Put a key/value pair in the JSONObject, where the value will be a JSONObject which is produced from a Map.
JSONObject | JSONObject.put(java.lang.String key, java.lang.Object value) Put a key/value pair in the JSONObject.
JSONObject | JSONObject.putOnce(java.lang.String key, java.lang.Object value) Put a key/value pair in the JSONObject, but only if the key and the value are both non-null, and only if there is not already a member with that name.
JSONObject | JSONObject.putOpt(java.lang.String key, java.lang.Object value) Put a key/value pair in the JSONObject, but only if the key and the value are both non-null.
JSONObject | JSONArray.toJSONObject(JSONArray names) Produce a JSONObject by combining a JSONArray of names with the values of this JSONArray.

Methods in com.badlogic.gdx.utils.json with parameters of type JSONObject
static java.lang.String[] JSONObject.getNames(JSONObject jo)
Get an array of field names from a JSONObject.

Constructors in com.badlogic.gdx.utils.json with parameters of type JSONObject
JSONObject(JSONObject jo, java.lang.String[] names)
Construct a JSONObject from a subset of another JSONObject.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JSONString (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils.json
Interface JSONString

public interface JSONString

The JSONString interface allows a toJSONString() method so that a class can change the behavior of JSONObject.toString(), JSONArray.toString(), and JSONWriter.value(Object). The toJSONString method will be used instead of the default behavior of using the Object's toString() method and quoting the result.

Method Summary
 java.lang.String toJSONString()
The toJSONString method allows a class to produce its own JSON serialization.

Method Detail

toJSONString

java.lang.String toJSONString()
The toJSONString method allows a class to produce its own JSON serialization.

Returns:
A strictly syntactically correct JSON text.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.utils.json.JSONString (libgdx API)

Uses of Interface
com.badlogic.gdx.utils.json.JSONString

No usage of com.badlogic.gdx.utils.json.JSONString

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JSONStringer (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils.json
Class JSONStringer

java.lang.Object
    extended by  com.badlogic.gdx.utils.json.JSONWriter
        extended by  com.badlogic.gdx.utils.json.JSONStringer

public class JSONStringer
extends JSONWriter

JSONStringer provides a quick and convenient way of producing JSON text. The texts produced strictly conform to JSON syntax rules. No whitespace is added, so the results are ready for transmission or storage. Each instance of JSONStringer can produce one JSON text.

A JSONStringer instance provides a value method for appending values to the text, and a key method for adding keys before values in objects. There are array and endArray methods that make and bound array values, and object and endObject methods which make and bound object values. All of these methods return the JSONWriter instance, permitting cascade style. For example,

 myString = new JSONStringer().object().key("JSON").value("Hello, World!").endObject().toString();
which produces the string
 {"JSON":"Hello, World!"}

The first method called must be array or object. There are no methods for adding commas or colons. JSONStringer adds them for you. Objects and arrays can be nested up to 20 levels deep.

This can sometimes be easier than using a JSONObject to build a string.

Version:
2008-09-18
Author:
JSON.org

Field Summary
Fields inherited from class com.badlogic.gdx.utils.json.JSONWriter
mode, writer
Constructor Summary
JSONStringer()
Make a fresh JSONStringer.
Method Summary
 java.lang.String toString()
Return the JSON text.
Methods inherited from class com.badlogic.gdx.utils.json.JSONWriter
array, endArray, endObject, key, object, value, value, value, value
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JSONStringer

public JSONStringer()
Make a fresh JSONStringer. It can be used to build one JSON text.

Method Detail

toString

public java.lang.String toString()
Return the JSON text. This method is used to obtain the product of the JSONStringer instance. It will return null if there was a problem in the construction of the JSON text (such as the calls to array were not properly balanced with calls to endArray).

Overrides:
toString in class java.lang.Object
Returns:
The JSON text.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.json.JSONStringer (libgdx API)

Uses of Class
com.badlogic.gdx.utils.json.JSONStringer

No usage of com.badlogic.gdx.utils.json.JSONStringer

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JSONTokener (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils.json
Class JSONTokener

java.lang.Object
    extended by  com.badlogic.gdx.utils.json.JSONTokener

public class JSONTokener
extends java.lang.Object

A JSONTokener takes a source string and extracts characters and tokens from it. It is used by the JSONObject and JSONArray constructors to parse JSON source strings.

Version:
2010-02-02
Author:
JSON.org

Constructor Summary
JSONTokener(java.io.Reader reader)
Construct a JSONTokener from a reader.
JSONTokener(java.lang.String s)
Construct a JSONTokener from a string.
Method Summary
 void back()
Back up one character.
static int dehexchar(char c)
Get the hex value of a character (base16).
 boolean end()
 boolean more()
Determine if the source string still contains characters that next() can consume.
 char next()
Get the next character in the source string.
 char next(char c)
Consume the next character, and check that it matches a specified character.
 java.lang.String next(int n)
Get the next n characters.
 char nextClean()
Get the next char in the string, skipping whitespace.
 java.lang.String nextString(char quote)
Return the characters up to the next close quote character.
 java.lang.String nextTo(char d)
Get the text up but not including the specified character or the end of line, whichever comes first.
 java.lang.String nextTo(java.lang.String delimiters)
Get the text up but not including one of the specified delimiter characters or the end of line, whichever comes first.
 java.lang.Object nextValue()
Get the next value.
 char skipTo(char to)
Skip characters until the next character is the requested character.
 JSONException syntaxError(java.lang.String message)
Make a JSONException to signal a syntax error.
 java.lang.String toString()
Make a printable string of this JSONTokener.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JSONTokener

public JSONTokener(java.io.Reader reader)
Construct a JSONTokener from a reader.

Parameters:
reader - A reader.

JSONTokener

public JSONTokener(java.lang.String s)
Construct a JSONTokener from a string.

Parameters:
s - A source string.
Method Detail

back

public void back()
          throws JSONException
Back up one character. This provides a sort of lookahead capability, so that you can test for a digit or letter before attempting to parse the next number or identifier.

Throws:
JSONException

dehexchar

public static int dehexchar(char c)
Get the hex value of a character (base16).

Parameters:
c - A character between '0' and '9' or between 'A' and 'F' or between 'a' and 'f'.
Returns:
An int between 0 and 15, or -1 if c was not a hex digit.

end

public boolean end()

more

public boolean more()
             throws JSONException
Determine if the source string still contains characters that next() can consume.

Returns:
true if not yet at the end of the source.
Throws:
JSONException

next

public char next()
          throws JSONException
Get the next character in the source string.

Returns:
The next character, or 0 if past the end of the source string.
Throws:
JSONException

next

public char next(char c)
          throws JSONException
Consume the next character, and check that it matches a specified character.

Parameters:
c - The character to match.
Returns:
The character.
Throws:
JSONException - if the character does not match.

next

public java.lang.String next(int n)
                      throws JSONException
Get the next n characters.

Parameters:
n - The number of characters to take.
Returns:
A string of n characters.
Throws:
JSONException - Substring bounds error if there are not n characters remaining in the source string.

nextClean

public char nextClean()
               throws JSONException
Get the next char in the string, skipping whitespace.

Returns:
A character, or 0 if there are no more characters.
Throws:
JSONException

nextString

public java.lang.String nextString(char quote)
                            throws JSONException
Return the characters up to the next close quote character. Backslash processing is done. The formal JSON format does not allow strings in single quotes, but an implementation is allowed to accept them.

Parameters:
quote - The quoting character, either " (double quote) or ' (single quote).
Returns:
A String.
Throws:
JSONException - Unterminated string.

nextTo

public java.lang.String nextTo(char d)
                        throws JSONException
Get the text up but not including the specified character or the end of line, whichever comes first.

Parameters:
d - A delimiter character.
Returns:
A string.
Throws:
JSONException

nextTo

public java.lang.String nextTo(java.lang.String delimiters)
                        throws JSONException
Get the text up but not including one of the specified delimiter characters or the end of line, whichever comes first.

Parameters:
delimiters - A set of delimiter characters.
Returns:
A string, trimmed.
Throws:
JSONException

nextValue

public java.lang.Object nextValue()
                           throws JSONException
Get the next value. The value can be a Boolean, Double, Integer, JSONArray, JSONObject, Long, or String, or the JSONObject.NULL object.

Returns:
An object.
Throws:
JSONException - If syntax error.

skipTo

public char skipTo(char to)
            throws JSONException
Skip characters until the next character is the requested character. If the requested character is not found, no characters are skipped.

Parameters:
to - A character to skip to.
Returns:
The requested character, or zero if the requested character is not found.
Throws:
JSONException

syntaxError

public JSONException syntaxError(java.lang.String message)
Make a JSONException to signal a syntax error.

Parameters:
message - The error message.
Returns:
A JSONException object, suitable for throwing

toString

public java.lang.String toString()
Make a printable string of this JSONTokener.

Overrides:
toString in class java.lang.Object
Returns:
" at {index} [character {character} line {line}]"
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.json.JSONTokener (libgdx API)

Uses of Class
com.badlogic.gdx.utils.json.JSONTokener

Packages that use JSONTokener
com.badlogic.gdx.utils.json

Uses of JSONTokener in com.badlogic.gdx.utils.json

Constructors in com.badlogic.gdx.utils.json with parameters of type JSONTokener
JSONArray(JSONTokener x)
Construct a JSONArray from a JSONTokener.
JSONObject(JSONTokener x)
Construct a JSONObject from a JSONTokener.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


JSONWriter (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils.json
Class JSONWriter

java.lang.Object
    extended by  com.badlogic.gdx.utils.json.JSONWriter
Direct Known Subclasses:
JSONStringer
public class JSONWriter
extends java.lang.Object

JSONWriter provides a quick and convenient way of producing JSON text. The texts produced strictly conform to JSON syntax rules. No whitespace is added, so the results are ready for transmission or storage. Each instance of JSONWriter can produce one JSON text.

A JSONWriter instance provides a value method for appending values to the text, and a key method for adding keys before values in objects. There are array and endArray methods that make and bound array values, and object and endObject methods which make and bound object values. All of these methods return the JSONWriter instance, permitting a cascade style. For example,

 new JSONWriter(myWriter).object().key("JSON").value("Hello, World!").endObject();
which writes
 {"JSON":"Hello, World!"}

The first method called must be array or object. There are no methods for adding commas or colons. JSONWriter adds them for you. Objects and arrays can be nested up to 20 levels deep.

This can sometimes be easier than using a JSONObject to build a string.

Version:
2010-03-11
Author:
JSON.org

Field Summary
protected char | mode The current mode.
protected java.io.Writer | writer The writer that will receive the output.
Constructor Summary
JSONWriter(java.io.Writer w)
Make a fresh JSONWriter.
Method Summary
JSONWriter | array() Begin appending a new array.
JSONWriter | endArray() End an array.
JSONWriter | endObject() End an object.
JSONWriter | key(java.lang.String s) Append a key.
JSONWriter | object() Begin appending a new object.
JSONWriter | value(boolean b) Append either the value true or the value false.
JSONWriter | value(double d) Append a double value.
JSONWriter | value(long l) Append a long value.
JSONWriter | value(java.lang.Object o) Append an object value.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

mode

protected char mode
The current mode. Values: 'a' (array), 'd' (done), 'i' (initial), 'k' (key), 'o' (object).

writer

protected java.io.Writer writer
The writer that will receive the output.

Constructor Detail

JSONWriter

public JSONWriter(java.io.Writer w)
Make a fresh JSONWriter. It can be used to build one JSON text.

Method Detail

array

public JSONWriter array()
                 throws JSONException
Begin appending a new array. All values until the balancing endArray will be appended to this array. The endArray method must be called to mark the array's end.

Returns:
this
Throws:
JSONException - If the nesting is too deep, or if the object is started in the wrong place (for example as a key or after the end of the outermost array or object).

endArray

public JSONWriter endArray()
                    throws JSONException
End an array. This method most be called to balance calls to array.

Returns:
this
Throws:
JSONException - If incorrectly nested.

endObject

public JSONWriter endObject()
                     throws JSONException
End an object. This method most be called to balance calls to object.

Returns:
this
Throws:
JSONException - If incorrectly nested.

key

public JSONWriter key(java.lang.String s)
               throws JSONException
Append a key. The key will be associated with the next value. In an object, every value must be preceded by a key.

Parameters:
s - A key string.
Returns:
this
Throws:
JSONException - If the key is out of place. For example, keys do not belong in arrays or if the key is null.

object

public JSONWriter object()
                  throws JSONException
Begin appending a new object. All keys and values until the balancing endObject will be appended to this object. The endObject method must be called to mark the object's end.

Returns:
this
Throws:
JSONException - If the nesting is too deep, or if the object is started in the wrong place (for example as a key or after the end of the outermost array or object).

value

public JSONWriter value(boolean b)
                 throws JSONException
Append either the value true or the value false.

Parameters:
b - A boolean.
Returns:
this
Throws:
JSONException

value

public JSONWriter value(double d)
                 throws JSONException
Append a double value.

Parameters:
d - A double.
Returns:
this
Throws:
JSONException - If the number is not finite.

value

public JSONWriter value(long l)
                 throws JSONException
Append a long value.

Parameters:
l - A long.
Returns:
this
Throws:
JSONException

value

public JSONWriter value(java.lang.Object o)
                 throws JSONException
Append an object value.

Parameters:
o - The object to append. It can be null, or a Boolean, Number, String, JSONObject, or JSONArray, or an object with a toJSONString() method.
Returns:
this
Throws:
JSONException - If the value is out of sequence.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.json.JSONWriter (libgdx API)

Uses of Class
com.badlogic.gdx.utils.json.JSONWriter

Packages that use JSONWriter
com.badlogic.gdx.utils.json

Uses of JSONWriter in com.badlogic.gdx.utils.json

Subclasses of JSONWriter in com.badlogic.gdx.utils.json
 class JSONStringer
JSONStringer provides a quick and convenient way of producing JSON text.

Methods in com.badlogic.gdx.utils.json that return JSONWriter
JSONWriter | JSONWriter.array() Begin appending a new array.
JSONWriter | JSONWriter.endArray() End an array.
JSONWriter | JSONWriter.endObject() End an object.
JSONWriter | JSONWriter.key(java.lang.String s) Append a key.
JSONWriter | JSONWriter.object() Begin appending a new object.
JSONWriter | JSONWriter.value(boolean b) Append either the value true or the value false.
JSONWriter | JSONWriter.value(double d) Append a double value.
JSONWriter | JSONWriter.value(long l) Append a long value.
JSONWriter | JSONWriter.value(java.lang.Object o) Append an object value.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


KissFFT (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.analysis
Class KissFFT

java.lang.Object
    extended by  com.badlogic.gdx.audio.analysis.KissFFT

public class KissFFT
extends java.lang.Object

A class for spectral analysis using native KissFFT

Author:
mzechner

Constructor Summary
KissFFT(int numSamples)
Creates a new fft instance that can analyse numSamples samples.
Method Summary
void | dispose() Releases all resources of this object
void | getImagPart(java.nio.ShortBuffer imag)
void | getRealPart(java.nio.ShortBuffer real)
static void | main(java.lang.String[] argv)
void | spectrum(java.nio.ShortBuffer samples, java.nio.FloatBuffer spectrum) Calculates the frequency spectrum of the given samples.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

KissFFT

public KissFFT(int numSamples)
Creates a new fft instance that can analyse numSamples samples. timeSize must be a power of two.

Parameters:
numSamples - the number of samples to be analysed.
Method Detail

spectrum

public void spectrum(java.nio.ShortBuffer samples,
                     java.nio.FloatBuffer spectrum)
Calculates the frequency spectrum of the given samples. There must be as many samples as specified in the constructor of this class. Spectrum must hold timeSize / 2 + 1 elements

Parameters:
samples - the samples
spectrum - the spectrum

dispose

public void dispose()
Releases all resources of this object

getRealPart

public void getRealPart(java.nio.ShortBuffer real)

getImagPart

public void getImagPart(java.nio.ShortBuffer imag)

main

public static void main(java.lang.String[] argv)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.audio.analysis.KissFFT (libgdx API)

Uses of Class
com.badlogic.gdx.audio.analysis.KissFFT

No usage of com.badlogic.gdx.audio.analysis.KissFFT

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Label (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actors
Class Label

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.Actor
        extended by  com.badlogic.gdx.scenes.scene2d.actors.Label

public class Label
extends Actor

Field Summary
 java.lang.String text
Fields inherited from class com.badlogic.gdx.scenes.scene2d.Actor
actions, color, height, name, originX, originY, parent, rotation, scaleX, scaleY, touchable, width, x, y
Constructor Summary
Label(java.lang.String name, java.lang.Object font, java.lang.String text)
Method Summary
Actor | hit(float x, float y)
protected void | render(SpriteBatch batch) Renders the Actor.
protected boolean | touchDown(float x, float y, int pointer)
protected boolean | touchDragged(float x, float y, int pointer)
protected boolean | touchUp(float x, float y, int pointer)
Methods inherited from class com.badlogic.gdx.scenes.scene2d.Actor
act, action, clearActions, remove, toLocalCoordinates, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

text

public java.lang.String text
Constructor Detail

Label

public Label(java.lang.String name,
             java.lang.Object font,
             java.lang.String text)
Method Detail

render

protected void render(SpriteBatch batch)
Description copied from class: Actor
Renders the Actor. The spriteBatch is configured so that the Actor can render in its parents coordinate system.

Specified by:
render in class Actor
Parameters:
batch - the spritebatch to render with

touchDown

protected boolean touchDown(float x,
                            float y,
                            int pointer)
Specified by:
touchDown in class Actor

touchUp

protected boolean touchUp(float x,
                          float y,
                          int pointer)
Specified by:
touchUp in class Actor

touchDragged

protected boolean touchDragged(float x,
                               float y,
                               int pointer)
Specified by:
touchDragged in class Actor

hit

public Actor hit(float x,
                 float y)
Specified by:
hit in class Actor
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actors.Label (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actors.Label

No usage of com.badlogic.gdx.scenes.scene2d.actors.Label

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LinearGroup (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actors
Class LinearGroup

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.Actor
        extended by  com.badlogic.gdx.scenes.scene2d.Group
            extended by  com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
                extended by  com.badlogic.gdx.scenes.scene2d.actors.LinearGroup

public class LinearGroup
extends BoundGroup

Nested Class Summary
static class LinearGroup.LinearGroupLayout
Field Summary
protected  LinearGroup.LinearGroupLayout layout
Fields inherited from class com.badlogic.gdx.scenes.scene2d.Group
children, debug, debugTexture, focusedActor, groups, immutableChildren, immutableGroups, lastTouchedChild, namesToActors, oldBatchTransform, scenetransform, tmp4, transform
Fields inherited from class com.badlogic.gdx.scenes.scene2d.Actor
actions, color, height, name, originX, originY, parent, rotation, scaleX, scaleY, touchable, width, x, y
Constructor Summary
LinearGroup(java.lang.String name, int width, int height, LinearGroup.LinearGroupLayout layout)
Method Summary
void | addActor(Actor actor) Adds an Actor to this Group.
protected void | layout()
void | removeActor(Actor actor) Removes an Actor from this Group.
Methods inherited from class com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
hit, touchDown, touchDragged, touchUp
Methods inherited from class com.badlogic.gdx.scenes.scene2d.Group
act, disableDebugging, enableDebugging, findActor, focus, getActors, getGroups, render, swapActor, swapActor, toChildCoordinates, updateTransform
Methods inherited from class com.badlogic.gdx.scenes.scene2d.Actor
action, clearActions, remove, toLocalCoordinates, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

layout

protected final LinearGroup.LinearGroupLayout layout
Constructor Detail

LinearGroup

public LinearGroup(java.lang.String name,
                   int width,
                   int height,
                   LinearGroup.LinearGroupLayout layout)
Method Detail

addActor

public void addActor(Actor actor)
Description copied from class: Group
Adds an Actor to this Group. The order Actors are added is reversed for hit testing and rendering.

Overrides:
addActor in class Group
Parameters:
actor - the Actor

removeActor

public void removeActor(Actor actor)
Description copied from class: Group
Removes an Actor from this Group.

Overrides:
removeActor in class Group

layout

protected void layout()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actors.LinearGroup (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actors.LinearGroup

No usage of com.badlogic.gdx.scenes.scene2d.actors.LinearGroup

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LinearGroup.LinearGroupLayout (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.scenes.scene2d.actors
Enum LinearGroup.LinearGroupLayout

java.lang.Object
    extended by  java.lang.Enum<LinearGroup.LinearGroupLayout>
        extended by  com.badlogic.gdx.scenes.scene2d.actors.LinearGroup.LinearGroupLayout
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<LinearGroup.LinearGroupLayout>
Enclosing class:
LinearGroup
public static enum LinearGroup.LinearGroupLayout
extends java.lang.Enum<LinearGroup.LinearGroupLayout>

Enum Constant Summary
Horizontal
Vertical
Method Summary
static LinearGroup.LinearGroupLayout | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LinearGroup.LinearGroupLayout[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

Vertical

public static final LinearGroup.LinearGroupLayout Vertical

Horizontal

public static final LinearGroup.LinearGroupLayout Horizontal
Method Detail

values

public static LinearGroup.LinearGroupLayout[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (LinearGroup.LinearGroupLayout c : LinearGroup.LinearGroupLayout.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LinearGroup.LinearGroupLayout valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actors.LinearGroup.LinearGroupLayout (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actors.LinearGroup.LinearGroupLayout

Packages that use LinearGroup.LinearGroupLayout
com.badlogic.gdx.scenes.scene2d.actors

Uses of LinearGroup.LinearGroupLayout in com.badlogic.gdx.scenes.scene2d.actors

Fields in com.badlogic.gdx.scenes.scene2d.actors declared as LinearGroup.LinearGroupLayout
protected  LinearGroup.LinearGroupLayout LinearGroup.layout

Methods in com.badlogic.gdx.scenes.scene2d.actors that return LinearGroup.LinearGroupLayout
static LinearGroup.LinearGroupLayout | LinearGroup.LinearGroupLayout.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static LinearGroup.LinearGroupLayout[] | LinearGroup.LinearGroupLayout.values() Returns an array containing the constants of this enum type, in the order they are declared.

Constructors in com.badlogic.gdx.scenes.scene2d.actors with parameters of type LinearGroup.LinearGroupLayout
LinearGroup(java.lang.String name, int width, int height, LinearGroup.LinearGroupLayout layout)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LineJoint (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class LineJoint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
        extended by  com.badlogic.gdx.physics.box2d.joints.LineJoint

public class LineJoint
extends Joint

A line joint. This joint provides two degrees of freedom: translation along an axis fixed in body1 and rotation in the plane. You can use a joint limit to restrict the range of motion and a joint motor to drive the motion or to model joint friction.

Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Joint
addr, jointEdgeA, jointEdgeB
Constructor Summary
LineJoint(World world, long addr)
Method Summary
void | enableLimit(boolean flag) Enable/disable the joint limit.
void | enableMotor(boolean flag) Enable/disable the joint motor.
float | getJointSpeed() Get the current joint translation speed, usually in meters per second.
float | getJointTranslation() Get the current joint translation, usually in meters.
float | getLowerLimit() Get the lower joint limit, usually in meters.
float | getMaxMotorForce() Set/Get the maximum motor force, usually in N.
float | getMotorForce() Get the current motor force, usually in N.
float | getMotorSpeed() Get the motor speed, usually in meters per second.
float | getUpperLimit() Get the upper joint limit, usually in meters.
boolean | isLimitEnabled() Is the joint limit enabled?
boolean | isMotorEnabled() Is the joint motor enabled?
void | setLimits(float lower, float upper) Set the joint limits, usually in meters.
void | setMaxMotorForce(float force) Set/Get the maximum motor force, usually in N.
void | setMotorSpeed(float speed) Set the motor speed, usually in meters per second.
Methods inherited from class com.badlogic.gdx.physics.box2d.Joint
getAnchorA, getAnchorB, getBodyA, getBodyB, getReactionForce, getReactionTorque, getType, isActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LineJoint

public LineJoint(World world,
                 long addr)
Method Detail

getJointTranslation

public float getJointTranslation()
Get the current joint translation, usually in meters.

getJointSpeed

public float getJointSpeed()
Get the current joint translation speed, usually in meters per second.

isLimitEnabled

public boolean isLimitEnabled()
Is the joint limit enabled?

enableLimit

public void enableLimit(boolean flag)
Enable/disable the joint limit.

getLowerLimit

public float getLowerLimit()
Get the lower joint limit, usually in meters.

getUpperLimit

public float getUpperLimit()
Get the upper joint limit, usually in meters.

setLimits

public void setLimits(float lower,
                      float upper)
Set the joint limits, usually in meters.

isMotorEnabled

public boolean isMotorEnabled()
Is the joint motor enabled?

enableMotor

public void enableMotor(boolean flag)
Enable/disable the joint motor.

setMotorSpeed

public void setMotorSpeed(float speed)
Set the motor speed, usually in meters per second.

getMotorSpeed

public float getMotorSpeed()
Get the motor speed, usually in meters per second.

setMaxMotorForce

public void setMaxMotorForce(float force)
Set/Get the maximum motor force, usually in N.

getMaxMotorForce

public float getMaxMotorForce()
Set/Get the maximum motor force, usually in N. FIXME returns 0 at the moment due to a linking problem.

getMotorForce

public float getMotorForce()
Get the current motor force, usually in N.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.LineJoint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.LineJoint

No usage of com.badlogic.gdx.physics.box2d.joints.LineJoint

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LineJointDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class LineJointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
        extended by  com.badlogic.gdx.physics.box2d.joints.LineJointDef

public class LineJointDef
extends JointDef

Line joint definition. This requires defining a line of motion using an axis and an anchor point. The definition uses local anchor points and a local axis so that the initial configuration can violate the constraint slightly. The joint translation is zero when the local anchor points coincide in world space. Using local anchors and a local axis helps when saving and loading a game.

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType
Field Summary
boolean | enableLimit Enable/disable the joint limit.
boolean | enableMotor Enable/disable the joint motor.
Vector2 | localAnchorA The local anchor point relative to body1's origin.
Vector2 | localAnchorB The local anchor point relative to body2's origin.
Vector2 | localAxisA The local translation axis in body1.
float | lowerTranslation The lower translation limit, usually in meters.
float | maxMotorForce The maximum motor torque, usually in N-m.
float | motorSpeed The desired motor speed in radians per second.
float | upperTranslation The upper translation limit, usually in meters.
Fields inherited from class com.badlogic.gdx.physics.box2d.JointDef
bodyA, bodyB, collideConnected, type
Constructor Summary
LineJointDef()
Method Summary
 void initialize(Body bodyA, Body bodyB, Vector2 anchor, Vector2 axis)
Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

localAnchorA

public final Vector2 localAnchorA
The local anchor point relative to body1's origin.

localAnchorB

public final Vector2 localAnchorB
The local anchor point relative to body2's origin.

localAxisA

public final Vector2 localAxisA
The local translation axis in body1.

enableLimit

public boolean enableLimit
Enable/disable the joint limit.

lowerTranslation

public float lowerTranslation
The lower translation limit, usually in meters.

upperTranslation

public float upperTranslation
The upper translation limit, usually in meters.

enableMotor

public boolean enableMotor
Enable/disable the joint motor.

maxMotorForce

public float maxMotorForce
The maximum motor torque, usually in N-m.

motorSpeed

public float motorSpeed
The desired motor speed in radians per second.

Constructor Detail

LineJointDef

public LineJointDef()
Method Detail

initialize

public void initialize(Body bodyA,
                       Body bodyB,
                       Vector2 anchor,
                       Vector2 axis)
Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.LineJointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.LineJointDef

No usage of com.badlogic.gdx.physics.box2d.joints.LineJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LittleEndianInputStream (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class LittleEndianInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  java.io.FilterInputStream
            extended by  com.badlogic.gdx.utils.LittleEndianInputStream
All Implemented Interfaces:
java.io.Closeable
public class LittleEndianInputStream
extends java.io.FilterInputStream

Taken from http://www.javafaq.nu/java-example-code-1079.html

Author:
mzechner

Field Summary
Fields inherited from class java.io.FilterInputStream
in
Constructor Summary
LittleEndianInputStream(java.io.InputStream in)
Method Summary
boolean | readBoolean()
byte | readByte(int b)
char | readChar()
double | readDouble()
float | readFloat()
int | readInt()
long | readLong()
short | readShort()
int | readUnsignedByte()
int | readUnsignedShort()
java.lang.String | readUTF()
int | skipBytes(int n)
Methods inherited from class java.io.FilterInputStream
available, close, mark, markSupported, read, read, read, reset, skip
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LittleEndianInputStream

public LittleEndianInputStream(java.io.InputStream in)
Method Detail

readBoolean

public boolean readBoolean()
                    throws java.io.IOException
Throws:
java.io.IOException

readByte

public byte readByte(int b)
              throws java.io.IOException
Throws:
java.io.IOException

readUnsignedByte

public int readUnsignedByte()
                     throws java.io.IOException
Throws:
java.io.IOException

readShort

public short readShort()
                throws java.io.IOException
Throws:
java.io.IOException

readUnsignedShort

public int readUnsignedShort()
                      throws java.io.IOException
Throws:
java.io.IOException

readChar

public char readChar()
              throws java.io.IOException
Throws:
java.io.IOException

readInt

public int readInt()
            throws java.io.IOException
Throws:
java.io.IOException

readLong

public long readLong()
              throws java.io.IOException
Throws:
java.io.IOException

readUTF

public java.lang.String readUTF()
                         throws java.io.IOException
Throws:
java.io.IOException

readDouble

public final double readDouble()
                        throws java.io.IOException
Throws:
java.io.IOException

readFloat

public final float readFloat()
                      throws java.io.IOException
Throws:
java.io.IOException

skipBytes

public final int skipBytes(int n)
                    throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.LittleEndianInputStream (libgdx API)

Uses of Class
com.badlogic.gdx.utils.LittleEndianInputStream

No usage of com.badlogic.gdx.utils.LittleEndianInputStream

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LocklessThreadQueue (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class LocklessThreadQueue<T>

java.lang.Object
    extended by  com.badlogic.gdx.utils.LocklessThreadQueue<T>

public class LocklessThreadQueue<T>
extends java.lang.Object

A specialized lockless thread queue class template for doing single direction message passing from one thread to another. This queue class does NOT use the Synchronized method. However it is designed with atomic queue passing which makes it very nice for non blocking event passing. This queue class keeps a fixed sized queue buffer which must be defined during initialization. If the queue buffer gets filled up, any new queue request will get dropped. This queue class also handles object pooling such that no extra allocation will be used. This prevents bad GC trashing.

Nested Class Summary
static interface LocklessThreadQueue.ObjectFactory<T>
Interface for an Object Factory for the initial buffer creation.
Field Summary
protected java.util.concurrent.atomic.AtomicInteger | head
protected java.util.List<T> | queueBuffer
protected int | queueSize
protected java.util.concurrent.atomic.AtomicInteger | tail
Constructor Summary
LocklessThreadQueue(LocklessThreadQueue.ObjectFactory<T> factory, int size)
Constructor.
Method Summary
T | pop() Returns null or the next queued object in the queue list
T | prepare() Returns the next available preallocated object for preparation.
void | push() Push the next available object to the queue.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

queueBuffer

protected java.util.List<T> queueBuffer

head

protected java.util.concurrent.atomic.AtomicInteger head

tail

protected java.util.concurrent.atomic.AtomicInteger tail

queueSize

protected int queueSize
Constructor Detail

LocklessThreadQueue

public LocklessThreadQueue(LocklessThreadQueue.ObjectFactory<T> factory,
                           int size)
Constructor.

Parameters:
factory - Object factory for pre-buffered queue pool allocation.
size - Number of queue objects allowed before dropping queue request.
Method Detail

prepare

public T prepare()
Returns the next available preallocated object for preparation.

push

public void push()
Push the next available object to the queue. This must be called after prepare is called for preparation. If it prepare() was not called, this will simply push the object unchanged from it's last queued state.

pop

public T pop()
Returns null or the next queued object in the queue list

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.LocklessThreadQueue (libgdx API)

Uses of Class
com.badlogic.gdx.utils.LocklessThreadQueue

No usage of com.badlogic.gdx.utils.LocklessThreadQueue

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LocklessThreadQueue.ObjectFactory (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Interface LocklessThreadQueue.ObjectFactory<T>

Type Parameters:
T - the type
Enclosing class:
LocklessThreadQueue<T>
public static interface LocklessThreadQueue.ObjectFactory<T>

Interface for an Object Factory for the initial buffer creation.

Method Summary
 T createObject()

Method Detail

createObject

T createObject()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.utils.LocklessThreadQueue.ObjectFactory (libgdx API)

Uses of Interface
com.badlogic.gdx.utils.LocklessThreadQueue.ObjectFactory

Packages that use LocklessThreadQueue.ObjectFactory
com.badlogic.gdx.utils

Uses of LocklessThreadQueue.ObjectFactory in com.badlogic.gdx.utils

Constructors in com.badlogic.gdx.utils with parameters of type LocklessThreadQueue.ObjectFactory
LocklessThreadQueue(LocklessThreadQueue.ObjectFactory<T> factory, int size)
Constructor.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LongArray (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class LongArray

java.lang.Object
    extended by  com.badlogic.gdx.utils.LongArray

public class LongArray
extends java.lang.Object

An ordered, resizable long array. Avoids the boxing that occurs with ArrayList.

Author:
Matthias Mann, Nathan Sweet

Field Summary
long[] | items
int | size
Constructor Summary
LongArray()
LongArray(int capacity)
LongArray(LongArray array)
LongArray(LongBag bag)
Method Summary
void | add(long value)
void | addAll(LongArray array)
void | addAll(LongBag bag)
void | clear()
boolean | contains(long value)
void | ensureCapacity(int additionalCapacity) Increases the size of the backing array to acommodate the specified number of additional items.
long | get(int index)
int | indexOf(long value)
void | insert(int index, long value)
long | pop() Removes and returns the last item.
long | pop(int index) Removes and returns the specified item.
void | removeIndex(int index)
boolean | removeValue(long value)
void | set(int index, long value)
void | shrink() Reduces the size of the backing array to the size of the actual items.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

items

public long[] items

size

public int size
Constructor Detail

LongArray

public LongArray()

LongArray

public LongArray(int capacity)

LongArray

public LongArray(LongArray array)

LongArray

public LongArray(LongBag bag)
Method Detail

add

public void add(long value)

addAll

public void addAll(LongArray array)

addAll

public void addAll(LongBag bag)

set

public void set(int index,
                long value)

insert

public void insert(int index,
                   long value)

get

public long get(int index)

contains

public boolean contains(long value)

indexOf

public int indexOf(long value)

removeValue

public boolean removeValue(long value)

removeIndex

public void removeIndex(int index)

pop

public long pop()
Removes and returns the last item.

pop

public long pop(int index)
Removes and returns the specified item.

clear

public void clear()

shrink

public void shrink()
Reduces the size of the backing array to the size of the actual items. This is useful to release memory when many items have been removed, or if it is known the more items will not be added.

ensureCapacity

public void ensureCapacity(int additionalCapacity)
Increases the size of the backing array to acommodate the specified number of additional items. Useful before adding many items to avoid multiple backing array resizes.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.LongArray (libgdx API)

Uses of Class
com.badlogic.gdx.utils.LongArray

Packages that use LongArray
com.badlogic.gdx.utils

Uses of LongArray in com.badlogic.gdx.utils

Methods in com.badlogic.gdx.utils with parameters of type LongArray
void | LongArray.addAll(LongArray array)
void | LongBag.addAll(LongArray array)

Constructors in com.badlogic.gdx.utils with parameters of type LongArray
LongArray(LongArray array)
LongBag(LongArray array)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LongBag (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class LongBag

java.lang.Object
    extended by  com.badlogic.gdx.utils.LongBag

public class LongBag
extends java.lang.Object

An unordered, resizable long array. Avoids the boxing that occurs with ArrayList. Avoids a memory copy when removing elements (the last element is moved to the removed element's position).

Author:
Riven, Nathan Sweet

Field Summary
long[] | items
int | size
Constructor Summary
LongBag()
LongBag(int capacity)
LongBag(LongArray array)
LongBag(LongBag bag)
Method Summary
void | add(long value)
void | addAll(LongArray array)
void | addAll(LongBag bag)
void | clear()
boolean | contains(long value)
void | ensureCapacity(int additionalCapacity) Increases the size of the backing array to acommodate the specified number of additional items.
long | get(int index)
int | indexOf(long value)
long | pop() Removes and returns the last item.
long | pop(int index) Removes and returns the specified item.
void | removeIndex(int index)
boolean | removeValue(long value)
void | shrink() Reduces the size of the backing array to the size of the actual items.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

items

public long[] items

size

public int size
Constructor Detail

LongBag

public LongBag()

LongBag

public LongBag(int capacity)

LongBag

public LongBag(LongBag bag)

LongBag

public LongBag(LongArray array)
Method Detail

add

public void add(long value)

addAll

public void addAll(LongBag bag)

addAll

public void addAll(LongArray array)

get

public long get(int index)

contains

public boolean contains(long value)

indexOf

public int indexOf(long value)

removeValue

public boolean removeValue(long value)

removeIndex

public void removeIndex(int index)

pop

public long pop()
Removes and returns the last item.

pop

public long pop(int index)
Removes and returns the specified item.

clear

public void clear()

shrink

public void shrink()
Reduces the size of the backing array to the size of the actual items. This is useful to release memory when many items have been removed, or if it is known the more items will not be added.

ensureCapacity

public void ensureCapacity(int additionalCapacity)
Increases the size of the backing array to acommodate the specified number of additional items. Useful before adding many items to avoid multiple backing array resizes.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.LongBag (libgdx API)

Uses of Class
com.badlogic.gdx.utils.LongBag

Packages that use LongBag
com.badlogic.gdx.utils

Uses of LongBag in com.badlogic.gdx.utils

Methods in com.badlogic.gdx.utils with parameters of type LongBag
void | LongArray.addAll(LongBag bag)
void | LongBag.addAll(LongBag bag)

Constructors in com.badlogic.gdx.utils with parameters of type LongBag
LongArray(LongBag bag)
LongBag(LongBag bag)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LongHashMap (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class LongHashMap<T>

java.lang.Object
    extended by  com.badlogic.gdx.utils.LongHashMap<T>

public class LongHashMap<T>
extends java.lang.Object

An unordered map that uses long keys. Avoids the boxing that occurs with HashMap.

Author:
Nathan Sweet , christop widulle

Nested Class Summary
static class LongHashMap.Entry<T>
An entry in the map.
Field Summary
 int size
Constructor Summary
LongHashMap()
LongHashMap(int initialCapacity)
LongHashMap(int initialCapacity, float loadFactor)
Method Summary
void | clear()
boolean | containsKey(long key)
boolean | containsValue(java.lang.Object value) Returns true if the specified value is in the map.
void | ensureCapacity(int additionalCapacity) Increases the size of the backing array to acommodate the specified number of additional items.
java.util.Iterator | entries() Returns an iterator for the entries in the map.
T | get(long key)
com.badlogic.gdx.utils.LongHashMap.Keys | keys() Returns an iterator for the keys in the map.
T | put(long key, T value)
T | remove(long key)
java.lang.String | toString()
java.util.Iterator | values() Returns an iterator for the values in the map.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

size

public int size
Constructor Detail

LongHashMap

public LongHashMap()

LongHashMap

public LongHashMap(int initialCapacity)

LongHashMap

public LongHashMap(int initialCapacity,
                   float loadFactor)
Method Detail

put

public T put(long key,
             T value)

get

public T get(long key)

entries

public java.util.Iterator entries()
Returns an iterator for the entries in the map. Remove is supported. Note that the same iterator instance is reused each time this method is called.

values

public java.util.Iterator values()
Returns an iterator for the values in the map. Remove is supported. Note that the same iterator instance is reused each time this method is called.

keys

public com.badlogic.gdx.utils.LongHashMap.Keys keys()
Returns an iterator for the keys in the map. Remove is supported. Note that the same iterator instance is reused each time this method is called.

containsValue

public boolean containsValue(java.lang.Object value)
Returns true if the specified value is in the map. Note this traverses the entire map and calls equals on every value, which may be an expensive operation.

containsKey

public boolean containsKey(long key)

remove

public T remove(long key)

clear

public void clear()

ensureCapacity

public void ensureCapacity(int additionalCapacity)
Increases the size of the backing array to acommodate the specified number of additional items. Useful before adding many items to avoid multiple backing array resizes.

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.LongHashMap (libgdx API)

Uses of Class
com.badlogic.gdx.utils.LongHashMap

Packages that use LongHashMap
com.badlogic.gdx.physics.box2d

Uses of LongHashMap in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as LongHashMap
protected LongHashMap<Body> | World.bodies all known bodies
protected LongHashMap<Fixture> | World.fixtures all known fixtures
protected LongHashMap<Joint> | World.joints all known joints

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LongHashMap.Entry (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class LongHashMap.Entry<T>

java.lang.Object
    extended by  com.badlogic.gdx.utils.LongHashMap.Entry<T>
Enclosing class:
LongHashMap<T>
public static class LongHashMap.Entry<T>
extends java.lang.Object

An entry in the map. The value may be changed directly.

Field Summary
long | key
T | value
Method Summary
 java.lang.String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

key

public final long key

value

public T value
Method Detail

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.LongHashMap.Entry (libgdx API)

Uses of Class
com.badlogic.gdx.utils.LongHashMap.Entry

No usage of com.badlogic.gdx.utils.LongHashMap.Entry

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LwjglApplet (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.backends.lwjgl
Class LwjglApplet

java.lang.Object
    extended by  java.awt.Component
        extended by  java.awt.Container
            extended by  java.awt.Panel
                extended by  java.applet.Applet
                    extended by  com.badlogic.gdx.backends.lwjgl.LwjglApplet
All Implemented Interfaces:
java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable, javax.accessibility.Accessible
public class LwjglApplet
extends java.applet.Applet

An OpenGL surface in an applet.

Author:
Nathan Sweet
See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from class java.applet.Applet
java.applet.Applet.AccessibleApplet
Nested classes/interfaces inherited from class java.awt.Panel
java.awt.Panel.AccessibleAWTPanel
Nested classes/interfaces inherited from class java.awt.Container
java.awt.Container.AccessibleAWTContainer
Nested classes/interfaces inherited from class java.awt.Component
java.awt.Component.AccessibleAWTComponent, java.awt.Component.BaselineResizeBehavior, java.awt.Component.BltBufferStrategy, java.awt.Component.FlipBufferStrategy
Field Summary
Fields inherited from class java.awt.Component
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
Fields inherited from interface java.awt.image.ImageObserver
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
Constructor Summary
LwjglApplet(ApplicationListener listener, boolean useGL2)
Method Summary
 void destroy()
Methods inherited from class java.applet.Applet
getAccessibleContext, getAppletContext, getAppletInfo, getAudioClip, getAudioClip, getCodeBase, getDocumentBase, getImage, getImage, getLocale, getParameter, getParameterInfo, init, isActive, newAudioClip, play, play, resize, resize, setStub, showStatus, start, stop
Methods inherited from class java.awt.Panel
addNotify
Methods inherited from class java.awt.Container
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
Methods inherited from class java.awt.Component
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusUpCycle
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LwjglApplet

public LwjglApplet(ApplicationListener listener,
                   boolean useGL2)
Method Detail

destroy

public void destroy()
Overrides:
destroy in class java.applet.Applet
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.backends.lwjgl.LwjglApplet (libgdx API)

Uses of Class
com.badlogic.gdx.backends.lwjgl.LwjglApplet

No usage of com.badlogic.gdx.backends.lwjgl.LwjglApplet

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LwjglApplication (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.backends.lwjgl
Class LwjglApplication

java.lang.Object
    extended by  com.badlogic.gdx.backends.lwjgl.LwjglApplication
All Implemented Interfaces:
Application
public class LwjglApplication
extends java.lang.Object
implements Application

An OpenGL surface fullscreen or in a lightweight window.

Nested Class Summary
Nested classes/interfaces inherited from interface com.badlogic.gdx.Application
Application.ApplicationType
Constructor Summary
LwjglApplication(ApplicationListener listener, boolean useGL2, java.awt.Canvas canvas)
LwjglApplication(ApplicationListener listener, java.lang.String title, int width, int height, boolean useGL2)
Method Summary
Audio | getAudio()
Files | getFiles()
Graphics | getGraphics()
Input | getInput()
long | getJavaHeap()
long | getNativeHeap()
Application.ApplicationType | getType()
int | getVersion()
void | log(java.lang.String tag, java.lang.String message) Logs a message to the console or logcat
void | stop()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LwjglApplication

public LwjglApplication(ApplicationListener listener,
                        java.lang.String title,
                        int width,
                        int height,
                        boolean useGL2)

LwjglApplication

public LwjglApplication(ApplicationListener listener,
                        boolean useGL2,
                        java.awt.Canvas canvas)
Method Detail

getAudio

public Audio getAudio()
Specified by:
getAudio in interface Application
Returns:
the Audio instance

getFiles

public Files getFiles()
Specified by:
getFiles in interface Application
Returns:
the Files instance

getGraphics

public Graphics getGraphics()
Specified by:
getGraphics in interface Application
Returns:
the Graphics instance

getInput

public Input getInput()
Specified by:
getInput in interface Application
Returns:
the Input instance

getType

public Application.ApplicationType getType()
Specified by:
getType in interface Application
Returns:
what Application.ApplicationType this application has, e.g. Android or Desktop

getVersion

public int getVersion()
Specified by:
getVersion in interface Application
Returns:
the Android API level on Android or 0 on the desktop.

log

public void log(java.lang.String tag,
                java.lang.String message)
Description copied from interface: Application
Logs a message to the console or logcat

Specified by:
log in interface Application

stop

public void stop()

getJavaHeap

public long getJavaHeap()
Specified by:
getJavaHeap in interface Application
Returns:
the Java heap memory use in bytes

getNativeHeap

public long getNativeHeap()
Specified by:
getNativeHeap in interface Application
Returns:
the Native heap memory use in bytes
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.backends.lwjgl.LwjglApplication (libgdx API)

Uses of Class
com.badlogic.gdx.backends.lwjgl.LwjglApplication

No usage of com.badlogic.gdx.backends.lwjgl.LwjglApplication

Overview Package Class Use Tree Deprecated Index Help
libgdx API


LwjglCanvas (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.backends.lwjgl
Class LwjglCanvas

java.lang.Object
    extended by  com.badlogic.gdx.backends.lwjgl.LwjglCanvas
All Implemented Interfaces:
Application
public class LwjglCanvas
extends java.lang.Object
implements Application

An OpenGL surface on an AWT Canvas, allowing OpenGL to be embedded in a Swing application. All OpenGL calls are done on the EDT. This is slightly less efficient then a dedicated thread, but greatly simplifies synchronization.

Author:
Nathan Sweet

Nested Class Summary
Nested classes/interfaces inherited from interface com.badlogic.gdx.Application
Application.ApplicationType
Constructor Summary
LwjglCanvas(ApplicationListener listener, boolean useGL2)
Method Summary
Audio | getAudio()
java.awt.Canvas | getCanvas()
Files | getFiles()
Graphics | getGraphics()
Input | getInput()
long | getJavaHeap()
long | getNativeHeap()
Application.ApplicationType | getType()
int | getVersion()
void | log(java.lang.String tag, java.lang.String message) Logs a message to the console or logcat
void | stop()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LwjglCanvas

public LwjglCanvas(ApplicationListener listener,
                   boolean useGL2)
Method Detail

getCanvas

public java.awt.Canvas getCanvas()

getAudio

public Audio getAudio()
Specified by:
getAudio in interface Application
Returns:
the Audio instance

getFiles

public Files getFiles()
Specified by:
getFiles in interface Application
Returns:
the Files instance

getGraphics

public Graphics getGraphics()
Specified by:
getGraphics in interface Application
Returns:
the Graphics instance

getInput

public Input getInput()
Specified by:
getInput in interface Application
Returns:
the Input instance

getType

public Application.ApplicationType getType()
Specified by:
getType in interface Application
Returns:
what Application.ApplicationType this application has, e.g. Android or Desktop

getVersion

public int getVersion()
Specified by:
getVersion in interface Application
Returns:
the Android API level on Android or 0 on the desktop.

log

public void log(java.lang.String tag,
                java.lang.String message)
Description copied from interface: Application
Logs a message to the console or logcat

Specified by:
log in interface Application

stop

public void stop()

getJavaHeap

public long getJavaHeap()
Specified by:
getJavaHeap in interface Application
Returns:
the Java heap memory use in bytes

getNativeHeap

public long getNativeHeap()
Specified by:
getNativeHeap in interface Application
Returns:
the Native heap memory use in bytes
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.backends.lwjgl.LwjglCanvas (libgdx API)

Uses of Class
com.badlogic.gdx.backends.lwjgl.LwjglCanvas

No usage of com.badlogic.gdx.backends.lwjgl.LwjglCanvas

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MassData (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class MassData

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.MassData

public class MassData
extends java.lang.Object

This holds the mass data computed for a shape.

Author:
mzechner

Field Summary
Vector2 | center The position of the shape's centroid relative to the shape's origin.
float | I The rotational inertia of the shape about the local origin.
float | mass The mass of the shape, usually in kilograms.
Constructor Summary
MassData()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

mass

public float mass
The mass of the shape, usually in kilograms.

center

public final Vector2 center
The position of the shape's centroid relative to the shape's origin.

I

public float I
The rotational inertia of the shape about the local origin.

Constructor Detail

MassData

public MassData()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.MassData (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.MassData

Packages that use MassData
com.badlogic.gdx.physics.box2d

Uses of MassData in com.badlogic.gdx.physics.box2d

Methods in com.badlogic.gdx.physics.box2d that return MassData
 MassData Body.getMassData()
Get the mass data of the body.

Methods in com.badlogic.gdx.physics.box2d with parameters of type MassData
 void Body.setMassData(MassData data)
Set the mass properties to override the mass properties of the fixtures.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MathUtils (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class MathUtils

java.lang.Object
    extended by  com.badlogic.gdx.utils.MathUtils

public class MathUtils
extends java.lang.Object

Utility and fast math functions. Thanks to:
Riven on JavaGaming.org for sin/cos/atan2/floor/ceil.
Roquen on JavaGaming.org for random numbers.

Field Summary
static float[] | cos
static float | degreesToRadians
static float | PI
static float | radiansToDegrees
static float[] | sin
Constructor Summary
MathUtils()
Method Summary
static float | atan2(float y, float x)
static int | ceil(float x)
static float | cos(float rad)
static float | cosDeg(float deg)
static int | floor(float x)
static boolean | isPowerOfTwo(int value)
static int | nextPowerOfTwo(int value)
static float | random()
static float | random(float range)
static float | random(float start, float end)
static int | random(int range) Returns a random number between 0 (inclusive) and the specified value (inclusive).
static int | random(int start, int end)
static boolean | randomBoolean()
static float | sin(float rad)
static float | sinDeg(float deg)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PI

public static final float PI
See Also:
Constant Field Values

radiansToDegrees

public static final float radiansToDegrees
See Also:
Constant Field Values

degreesToRadians

public static final float degreesToRadians
See Also:
Constant Field Values

sin

public static final float[] sin

cos

public static final float[] cos
Constructor Detail

MathUtils

public MathUtils()
Method Detail

sin

public static final float sin(float rad)

cos

public static final float cos(float rad)

sinDeg

public static final float sinDeg(float deg)

cosDeg

public static final float cosDeg(float deg)

atan2

public static final float atan2(float y,
                                float x)

random

public static final int random(int range)
Returns a random number between 0 (inclusive) and the specified value (inclusive).

Parameters:
range - Must be >= 0.

random

public static final int random(int start,
                               int end)

randomBoolean

public static final boolean randomBoolean()

random

public static final float random()

random

public static final float random(float range)

random

public static final float random(float start,
                                 float end)

nextPowerOfTwo

public static int nextPowerOfTwo(int value)

isPowerOfTwo

public static boolean isPowerOfTwo(int value)

floor

public static int floor(float x)

ceil

public static int ceil(float x)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.MathUtils (libgdx API)

Uses of Class
com.badlogic.gdx.utils.MathUtils

No usage of com.badlogic.gdx.utils.MathUtils

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Matrix3 (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class Matrix3

java.lang.Object
    extended by  com.badlogic.gdx.math.Matrix3

public class Matrix3
extends java.lang.Object

A 3x3 column major matrix for 2D transforms.

Author:
mzechner

Constructor Summary
Matrix3()
Method Summary
float | det()
float[] | getValues()
Matrix3 | idt() Sets this matrix to the identity matrix
Matrix3 | inv() Inverts this matrix given that the determinant is != 0
static void | main(java.lang.String[] argv)
Matrix3 | mul(Matrix3 m) Multiplies this matrix with the other matrix in the order this * m.
Matrix3 | set(Matrix3 mat)
Matrix3 | setToRotation(float angle) Sets this matrix to a rotation matrix that will rotate any vector in counter clockwise order around the z-axis.
Matrix3 | setToScaling(float sx, float sy) Sets this matrix to a scaling matrix
Matrix3 | setToTranslation(float x, float y) Sets this matrix to a translation matrix.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Matrix3

public Matrix3()
Method Detail

idt

public Matrix3 idt()
Sets this matrix to the identity matrix

Returns:
this matrix

mul

public Matrix3 mul(Matrix3 m)
Multiplies this matrix with the other matrix in the order this * m.

Returns:
this matrix

setToRotation

public Matrix3 setToRotation(float angle)
Sets this matrix to a rotation matrix that will rotate any vector in counter clockwise order around the z-axis.

Parameters:
angle - the angle in degrees.
Returns:
this matrix

setToTranslation

public Matrix3 setToTranslation(float x,
                                float y)
Sets this matrix to a translation matrix.

Parameters:
x - the translation in x
y - the translation in y
Returns:
this matrix

setToScaling

public Matrix3 setToScaling(float sx,
                            float sy)
Sets this matrix to a scaling matrix

Parameters:
sx - the scale in x
sy - the scale in y
Returns:
this matrix

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

det

public float det()
Returns:
the determinant of this matrix

inv

public Matrix3 inv()
Inverts this matrix given that the determinant is != 0

Returns:
this matrix

main

public static void main(java.lang.String[] argv)

set

public Matrix3 set(Matrix3 mat)

getValues

public float[] getValues()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.Matrix3 (libgdx API)

Uses of Class
com.badlogic.gdx.math.Matrix3

Packages that use Matrix3
com.badlogic.gdx.math
com.badlogic.gdx.scenes.scene2d

Uses of Matrix3 in com.badlogic.gdx.math

Methods in com.badlogic.gdx.math that return Matrix3
Matrix3 | Matrix3.idt() Sets this matrix to the identity matrix
Matrix3 | Matrix3.inv() Inverts this matrix given that the determinant is != 0
Matrix3 | Matrix3.mul(Matrix3 m) Multiplies this matrix with the other matrix in the order this * m.
Matrix3 | Matrix3.set(Matrix3 mat)
Matrix3 | Matrix3.setToRotation(float angle) Sets this matrix to a rotation matrix that will rotate any vector in counter clockwise order around the z-axis.
Matrix3 | Matrix3.setToScaling(float sx, float sy) Sets this matrix to a scaling matrix
Matrix3 | Matrix3.setToTranslation(float x, float y) Sets this matrix to a translation matrix.

Methods in com.badlogic.gdx.math with parameters of type Matrix3
Matrix3 | Matrix3.mul(Matrix3 m) Multiplies this matrix with the other matrix in the order this * m.
Vector2 | Vector2.mul(Matrix3 mat) Multiplies this vector by the given matrix
Matrix3 | Matrix3.set(Matrix3 mat)
Matrix4 | Matrix4.set(Matrix3 mat) Sets this matrix to the given 3x3 matrix.

Uses of Matrix3 in com.badlogic.gdx.scenes.scene2d

Fields in com.badlogic.gdx.scenes.scene2d declared as Matrix3
protected Matrix3 | Group.scenetransform
protected Matrix3 | Group.transform

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Matrix4 (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class Matrix4

java.lang.Object
    extended by  com.badlogic.gdx.math.Matrix4

public final class Matrix4
extends java.lang.Object

Encapsulates a column major 4 by 4 matrix. You can access the linear array for use with OpenGL via the public val member. Like the Vector3 class it allows to chain methods by returning a reference to itself.

Author:
badlogicgames@gmail.com

Field Summary
static int | M00
static int | M01
static int | M02
static int | M03
static int | M10
static int | M11
static int | M12
static int | M13
static int | M20
static int | M21
static int | M22
static int | M23
static int | M30
static int | M31
static int | M32
static int | M33
float[] | tmp
float[] | val
Constructor Summary
Matrix4()
Constructs an identity matrix
Matrix4(float[] values)
Constructs a matrix from the given float array.
Matrix4(Matrix4 matrix)
Constructs a matrix from the given matrix
Matrix4(Quaternion quaternion)
Constructs a rotation matrix from the given Quaternion
Method Summary
Matrix4 | cpy()
float | det()
float[] | getValues()
Matrix4 | idt() Sets the matrix to an identity matrix
Matrix4 | inv() Inverts the matrix.
void | lerp(Matrix4 matrix, float alpha) Linearly interpolates between this matrix and the given matrix mixing by alpha
Matrix4 | mul(Matrix4 matrix) Multiplies this matrix with the given matrix, storing the result in this matrix.
Matrix4 | set(float[] values) Sets the matrix to the given matrix as a float array.
Matrix4 | set(Matrix3 mat) Sets this matrix to the given 3x3 matrix.
Matrix4 | set(Matrix4 matrix) Sets the matrix to the given matrix.
Matrix4 | set(Quaternion quaternion) Sets the matrix to a rotation matrix representing the quaternion.
void | set(Vector3 xAxis, Vector3 yAxis, Vector3 zAxis, Vector3 pos) Sets the four columns of the matrix which correspond to the x-, y- and z-axis of the vector space this matrix creates as well as the 4th column representing the translation of any point that is multiplied by this matrix.
Matrix4 | setFromEulerAngles(float yaw, float pitch, float roll) Sets this matrix to a rotation matrix from the given euler angles.
Matrix4 | setToLookAt(Vector3 direction, Vector3 up) Sets the matrix to a look at matrix with a direction and an up vector.
Matrix4 | setToLookAt(Vector3 position, Vector3 target, Vector3 up) Sets this matrix to a look at matrix with the given position, target and up vector.
Matrix4 | setToOrtho(float left, float right, float bottom, float top, float near, float far) Sets the matrix to an orthographic projection like glOrtho (http://www.opengl.org/sdk/docs/man/xhtml/glOrtho.xml) following the OpenGL equivalent
Matrix4 | setToOrtho2D(float x, float y, float width, float height) Sets this matrix to an orthographic projection matrix with the origin at (x,y) extending by width and height.
Matrix4 | setToOrtho2D(float x, float y, float width, float height, float near, float far) Sets this matrix to an orthographic projection matrix with the origin at (x,y) extending by width and height, having a near and far plane.
Matrix4 | setToProjection(float near, float far, float fov, float aspectRatio) Sets the matrix to a projection matrix with a near- and far plane, a field of view in degrees and an aspect ratio.
Matrix4 | setToRotation(Vector3 axis, float angle) Sets the matrix to a rotation matrix around the given axis.
Matrix4 | setToScaling(float x, float y, float z) Sets this matrix to a scaling matrix
Matrix4 | setToScaling(Vector3 vector) Sets this matrix to a scaling matrix
Matrix4 | setToTranslation(float x, float y, float z) Sets this matrix to a translation matrix, overwriting it first by an identity matrix and then setting the 4th column to the translation vector.
Matrix4 | setToTranslation(Vector3 vector) Sets this matrix to a translation matrix, overwriting it first by an identity matrix and then setting the 4th column to the translation vector.
Matrix4 | setToTranslationAndScaling(float translationX, float translationY, float translationZ, float scalingX, float scalingY, float scalingZ) Sets this matrix to a translation and scaling matrix by first overwritting it with an identity and then setting the translation vector in the 4th column and the scaling vector in the diagonal.
Matrix4 | setToTranslationAndScaling(Vector3 translation, Vector3 scaling) Sets this matrix to a translation and scaling matrix by first overwritting it with an identity and then setting the translation vector in the 4th column and the scaling vector in the diagonal.
Matrix4 | setToWorld(Vector3 position, Vector3 forward, Vector3 up)
java.lang.String | toString()
Matrix4 | tra() Transposes the matrix
Matrix4 | trn(float x, float y, float z) Adds a translational component to the matrix in the 4th column.
Matrix4 | trn(Vector3 vector) Adds a translational component to the matrix in the 4th column.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

M00

public static final int M00
See Also:
Constant Field Values

M01

public static final int M01
See Also:
Constant Field Values

M02

public static final int M02
See Also:
Constant Field Values

M03

public static final int M03
See Also:
Constant Field Values

M10

public static final int M10
See Also:
Constant Field Values

M11

public static final int M11
See Also:
Constant Field Values

M12

public static final int M12
See Also:
Constant Field Values

M13

public static final int M13
See Also:
Constant Field Values

M20

public static final int M20
See Also:
Constant Field Values

M21

public static final int M21
See Also:
Constant Field Values

M22

public static final int M22
See Also:
Constant Field Values

M23

public static final int M23
See Also:
Constant Field Values

M30

public static final int M30
See Also:
Constant Field Values

M31

public static final int M31
See Also:
Constant Field Values

M32

public static final int M32
See Also:
Constant Field Values

M33

public static final int M33
See Also:
Constant Field Values

tmp

public final float[] tmp

val

public final float[] val
Constructor Detail

Matrix4

public Matrix4()
Constructs an identity matrix

Matrix4

public Matrix4(Matrix4 matrix)
Constructs a matrix from the given matrix

Parameters:
matrix - The matrix

Matrix4

public Matrix4(float[] values)
Constructs a matrix from the given float array. The array must have at least 16 elements

Parameters:
values - The float array

Matrix4

public Matrix4(Quaternion quaternion)
Constructs a rotation matrix from the given Quaternion

Parameters:
quaternion - The quaternion
Method Detail

set

public Matrix4 set(Matrix4 matrix)
Sets the matrix to the given matrix.

Parameters:
matrix - The matrix
Returns:
This matrix for chaining

set

public Matrix4 set(float[] values)
Sets the matrix to the given matrix as a float array. The float array must have at least 16 elements.

Parameters:
values - The matrix
Returns:
This matrix for chaining

set

public Matrix4 set(Quaternion quaternion)
Sets the matrix to a rotation matrix representing the quaternion.

Parameters:
quaternion - The quaternion
Returns:
This matrix for chaining

set

public void set(Vector3 xAxis,
                Vector3 yAxis,
                Vector3 zAxis,
                Vector3 pos)
Sets the four columns of the matrix which correspond to the x-, y- and z-axis of the vector space this matrix creates as well as the 4th column representing the translation of any point that is multiplied by this matrix.

Parameters:
xAxis - The x-axis
yAxis - The y-axis
zAxis - The z-axis
pos - The translation vector

cpy

public Matrix4 cpy()
Returns:
a copy of this matrix

trn

public Matrix4 trn(Vector3 vector)
Adds a translational component to the matrix in the 4th column. The other columns are untouched.

Parameters:
vector - The translation vector
Returns:
This matrix for chaining

trn

public Matrix4 trn(float x,
                   float y,
                   float z)
Adds a translational component to the matrix in the 4th column. The other columns are untouched.

Parameters:
x - The x-component of the translation vector
y - The y-component of the translation vector
z - The z-component of the translation vector
Returns:
This matrix for chaining

getValues

public float[] getValues()
Returns:
the backing float array

mul

public Matrix4 mul(Matrix4 matrix)
Multiplies this matrix with the given matrix, storing the result in this matrix.

Parameters:
matrix - The other matrix
Returns:
This matrix for chaining.

tra

public Matrix4 tra()
Transposes the matrix

Returns:
This matrix for chaining

idt

public Matrix4 idt()
Sets the matrix to an identity matrix

Returns:
This matrix for chaining

inv

public Matrix4 inv()
Inverts the matrix. Throws a RuntimeException in case the matrix is not invertible. Stores the result in this matrix

Returns:
This matrix for chaining

det

public float det()
Returns:
The determinant of this matrix

setToProjection

public Matrix4 setToProjection(float near,
                               float far,
                               float fov,
                               float aspectRatio)
Sets the matrix to a projection matrix with a near- and far plane, a field of view in degrees and an aspect ratio.

Parameters:
near - The near plane
far - The far plane
fov - The field of view in degrees
aspectRatio - The aspect ratio
Returns:
This matrix for chaining

setToOrtho2D

public Matrix4 setToOrtho2D(float x,
                            float y,
                            float width,
                            float height)
Sets this matrix to an orthographic projection matrix with the origin at (x,y) extending by width and height. The near plane is set to 0, the far plane is set to 1.

Parameters:
x - The x-coordinate of the origin
y - The y-coordinate of the origin
width - The width
height - The height
Returns:
This matrix for chaining

setToOrtho2D

public Matrix4 setToOrtho2D(float x,
                            float y,
                            float width,
                            float height,
                            float near,
                            float far)
Sets this matrix to an orthographic projection matrix with the origin at (x,y) extending by width and height, having a near and far plane.

Parameters:
x - The x-coordinate of the origin
y - The y-coordinate of the origin
width - The width
height - The height
near - The near plane
far - The far plane
Returns:
This matrix for chaining

setToOrtho

public Matrix4 setToOrtho(float left,
                          float right,
                          float bottom,
                          float top,
                          float near,
                          float far)
Sets the matrix to an orthographic projection like glOrtho (http://www.opengl.org/sdk/docs/man/xhtml/glOrtho.xml) following the OpenGL equivalent

Parameters:
left - The left clipping plane
right - The right clipping plane
bottom - The bottom clipping plane
top - The top clipping plane
near - The near clipping plane
far - The far clipping plane
Returns:
This matrix for chaining

setToTranslation

public Matrix4 setToTranslation(Vector3 vector)
Sets this matrix to a translation matrix, overwriting it first by an identity matrix and then setting the 4th column to the translation vector.

Parameters:
vector - The translation vector
Returns:
This matrix for chaining

setToTranslation

public Matrix4 setToTranslation(float x,
                                float y,
                                float z)
Sets this matrix to a translation matrix, overwriting it first by an identity matrix and then setting the 4th column to the translation vector.

Parameters:
x - The x-component of the translation vector
y - The y-component of the translation vector
z - The z-component of the translation vector
Returns:
This matrix for chaining

setToTranslationAndScaling

public Matrix4 setToTranslationAndScaling(Vector3 translation,
                                          Vector3 scaling)
Sets this matrix to a translation and scaling matrix by first overwritting it with an identity and then setting the translation vector in the 4th column and the scaling vector in the diagonal.

Parameters:
translation - The translation vector
scaling - The scaling vector
Returns:
This matrix for chaining

setToTranslationAndScaling

public Matrix4 setToTranslationAndScaling(float translationX,
                                          float translationY,
                                          float translationZ,
                                          float scalingX,
                                          float scalingY,
                                          float scalingZ)
Sets this matrix to a translation and scaling matrix by first overwritting it with an identity and then setting the translation vector in the 4th column and the scaling vector in the diagonal.

Parameters:
translationX - The x-component of the translation vector
translationY - The y-component of the translation vector
translationZ - The z-component of the translation vector
scalingX - The x-component of the scaling vector
scalingY - The x-component of the scaling vector
scalingZ - The x-component of the scaling vector
Returns:
This matrix for chaining

setToRotation

public Matrix4 setToRotation(Vector3 axis,
                             float angle)
Sets the matrix to a rotation matrix around the given axis.

Parameters:
axis - The axis
angle - The angle in degrees
Returns:
This matrix for chaining

setFromEulerAngles

public Matrix4 setFromEulerAngles(float yaw,
                                  float pitch,
                                  float roll)
Sets this matrix to a rotation matrix from the given euler angles.

Parameters:
yaw - the yaw in degrees
pitch - the pitch in degress
roll - the roll in degrees
Returns:
this matrix

setToScaling

public Matrix4 setToScaling(Vector3 vector)
Sets this matrix to a scaling matrix

Parameters:
vector - The scaling vector
Returns:
This matrix for chaining.

setToScaling

public Matrix4 setToScaling(float x,
                            float y,
                            float z)
Sets this matrix to a scaling matrix

Parameters:
x - The x-component of the scaling vector
y - The y-component of the scaling vector
z - The z-component of the scaling vector
Returns:
This matrix for chaining.

setToLookAt

public Matrix4 setToLookAt(Vector3 direction,
                           Vector3 up)
Sets the matrix to a look at matrix with a direction and an up vector. Multiply with a translation matrix to get a camera model view matrix.

Parameters:
direction - The direction vector
up - The up vector
Returns:
This matrix for chaining

setToLookAt

public Matrix4 setToLookAt(Vector3 position,
                           Vector3 target,
                           Vector3 up)
Sets this matrix to a look at matrix with the given position, target and up vector.

Parameters:
position - the position
target - the target
up - the up vector
Returns:
this matrix

setToWorld

public Matrix4 setToWorld(Vector3 position,
                          Vector3 forward,
                          Vector3 up)

toString

public java.lang.String toString()

Overrides:
toString in class java.lang.Object

lerp

public void lerp(Matrix4 matrix,
                 float alpha)
Linearly interpolates between this matrix and the given matrix mixing by alpha

Parameters:
matrix - the matrix
alpha - the alpha value in the range [0,1]

set

public Matrix4 set(Matrix3 mat)
Sets this matrix to the given 3x3 matrix. The third column of this matrix is set to (0,0,1,0).

Parameters:
mat - the matrix
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.Matrix4 (libgdx API)

Uses of Class
com.badlogic.gdx.math.Matrix4

Packages that use Matrix4
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils
com.badlogic.gdx.math
com.badlogic.gdx.math.collision
com.badlogic.gdx.scenes.scene2d

Uses of Matrix4 in com.badlogic.gdx.graphics

Fields in com.badlogic.gdx.graphics declared as Matrix4
protected Matrix4 | PerspectiveCamera.comb
protected Matrix4 | PerspectiveCamera.model
protected Matrix4 | PerspectiveCamera.proj
protected Matrix4 | PerspectiveCamera.tmp

Methods in com.badlogic.gdx.graphics that return Matrix4
Matrix4 | OrthographicCamera.getCombinedMatrix()
Matrix4 | PerspectiveCamera.getCombinedMatrix()
Matrix4 | PerspectiveCamera.getModelviewMatrix()
Matrix4 | PerspectiveCamera.getProjectionMatrix()
Matrix4 | SpriteBatch.getProjectionMatrix() Returns the current projection matrix.
Matrix4 | SpriteCache.getProjectionMatrix()
Matrix4 | SpriteBatch.getTransformMatrix() Returns the current transform matrix.
Matrix4 | SpriteCache.getTransformMatrix()

Methods in com.badlogic.gdx.graphics with parameters of type Matrix4
void | SpriteBatch.setProjectionMatrix(Matrix4 projection) Sets the projection matrix to be used by this SpriteBatch.
void | SpriteCache.setProjectionMatrix(Matrix4 projection)
void | SpriteBatch.setTransformMatrix(Matrix4 transform) Sets the transform matrix to be used by this SpriteBatch.
void | SpriteCache.setTransformMatrix(Matrix4 transform)

Uses of Matrix4 in com.badlogic.gdx.graphics.glutils

Methods in com.badlogic.gdx.graphics.glutils with parameters of type Matrix4
 void ShaderProgram.setUniformMatrix(java.lang.String name, Matrix4 matrix)
Sets the uniform matrix with the given name.

Uses of Matrix4 in com.badlogic.gdx.math

Methods in com.badlogic.gdx.math that return Matrix4
Matrix4 | Matrix4.cpy()
Matrix4 | Matrix4.idt() Sets the matrix to an identity matrix
Matrix4 | Matrix4.inv() Inverts the matrix.
Matrix4 | Matrix4.mul(Matrix4 matrix) Multiplies this matrix with the given matrix, storing the result in this matrix.
Matrix4 | Matrix4.set(float[] values) Sets the matrix to the given matrix as a float array.
Matrix4 | Matrix4.set(Matrix3 mat) Sets this matrix to the given 3x3 matrix.
Matrix4 | Matrix4.set(Matrix4 matrix) Sets the matrix to the given matrix.
Matrix4 | Matrix4.set(Quaternion quaternion) Sets the matrix to a rotation matrix representing the quaternion.
Matrix4 | Matrix4.setFromEulerAngles(float yaw, float pitch, float roll) Sets this matrix to a rotation matrix from the given euler angles.
Matrix4 | Matrix4.setToLookAt(Vector3 direction, Vector3 up) Sets the matrix to a look at matrix with a direction and an up vector.
Matrix4 | Matrix4.setToLookAt(Vector3 position, Vector3 target, Vector3 up) Sets this matrix to a look at matrix with the given position, target and up vector.
Matrix4 | Matrix4.setToOrtho(float left, float right, float bottom, float top, float near, float far) Sets the matrix to an orthographic projection like glOrtho (http://www.opengl.org/sdk/docs/man/xhtml/glOrtho.xml) following the OpenGL equivalent
Matrix4 | Matrix4.setToOrtho2D(float x, float y, float width, float height) Sets this matrix to an orthographic projection matrix with the origin at (x,y) extending by width and height.
Matrix4 | Matrix4.setToOrtho2D(float x, float y, float width, float height, float near, float far) Sets this matrix to an orthographic projection matrix with the origin at (x,y) extending by width and height, having a near and far plane.
Matrix4 | Matrix4.setToProjection(float near, float far, float fov, float aspectRatio) Sets the matrix to a projection matrix with a near- and far plane, a field of view in degrees and an aspect ratio.
Matrix4 | Matrix4.setToRotation(Vector3 axis, float angle) Sets the matrix to a rotation matrix around the given axis.
Matrix4 | Matrix4.setToScaling(float x, float y, float z) Sets this matrix to a scaling matrix
Matrix4 | Matrix4.setToScaling(Vector3 vector) Sets this matrix to a scaling matrix
Matrix4 | Matrix4.setToTranslation(float x, float y, float z) Sets this matrix to a translation matrix, overwriting it first by an identity matrix and then setting the 4th column to the translation vector.
Matrix4 | Matrix4.setToTranslation(Vector3 vector) Sets this matrix to a translation matrix, overwriting it first by an identity matrix and then setting the 4th column to the translation vector.
Matrix4 | Matrix4.setToTranslationAndScaling(float translationX, float translationY, float translationZ, float scalingX, float scalingY, float scalingZ) Sets this matrix to a translation and scaling matrix by first overwritting it with an identity and then setting the translation vector in the 4th column and the scaling vector in the diagonal.
Matrix4 | Matrix4.setToTranslationAndScaling(Vector3 translation, Vector3 scaling) Sets this matrix to a translation and scaling matrix by first overwritting it with an identity and then setting the translation vector in the 4th column and the scaling vector in the diagonal.
Matrix4 | Matrix4.setToWorld(Vector3 position, Vector3 forward, Vector3 up)
Matrix4 | Matrix4.tra() Transposes the matrix
Matrix4 | Matrix4.trn(float x, float y, float z) Adds a translational component to the matrix in the 4th column.
Matrix4 | Matrix4.trn(Vector3 vector) Adds a translational component to the matrix in the 4th column.

Methods in com.badlogic.gdx.math with parameters of type Matrix4
void | Matrix4.lerp(Matrix4 matrix, float alpha) Linearly interpolates between this matrix and the given matrix mixing by alpha
Matrix4 | Matrix4.mul(Matrix4 matrix) Multiplies this matrix with the given matrix, storing the result in this matrix.
Vector3 | Vector3.mul(Matrix4 matrix) Multiplies the vector by the given matrix.
Vector3 | Vector3.prj(Matrix4 matrix) Multiplies this vector by the given matrix dividing by w.
Vector3 | Vector3.rot(Matrix4 matrix) Multiplies this vector by the first three columns of the matrix, essentially only applying rotation and scaling.
Matrix4 | Matrix4.set(Matrix4 matrix) Sets the matrix to the given matrix.

Constructors in com.badlogic.gdx.math with parameters of type Matrix4
Matrix4(Matrix4 matrix)
Constructs a matrix from the given matrix

Uses of Matrix4 in com.badlogic.gdx.math.collision

Methods in com.badlogic.gdx.math.collision with parameters of type Matrix4
BoundingBox | BoundingBox.mul(Matrix4 matrix) Multiplies the bounding box by the given matrix.
Ray | Ray.mul(Matrix4 matrix) Multiplies the ray by the given matrix.

Uses of Matrix4 in com.badlogic.gdx.scenes.scene2d

Fields in com.badlogic.gdx.scenes.scene2d declared as Matrix4
protected Matrix4 | Group.oldBatchTransform
protected Matrix4 | Group.tmp4

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MD5Animation (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders.md5
Class MD5Animation

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.md5.MD5Animation

public class MD5Animation
extends java.lang.Object

Field Summary
BoundingBox[] | bounds
int | frameRate
MD5Joints[] | frames
float | secondsPerFrame
Constructor Summary
MD5Animation()
Method Summary
static void interpolate(MD5Joints skeletonA, MD5Joints skeletonB, MD5Joints skeletonOut, float t)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

frameRate

public int frameRate

secondsPerFrame

public float secondsPerFrame

frames

public MD5Joints[] frames

bounds

public BoundingBox[] bounds
Constructor Detail

MD5Animation

public MD5Animation()
Method Detail

interpolate

public static void interpolate(MD5Joints skeletonA,
                               MD5Joints skeletonB,
                               MD5Joints skeletonOut,
                               float t)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.md5.MD5Animation (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.md5.MD5Animation

Packages that use MD5Animation
com.badlogic.gdx.graphics.loaders.md5

Uses of MD5Animation in com.badlogic.gdx.graphics.loaders.md5

Methods in com.badlogic.gdx.graphics.loaders.md5 that return MD5Animation
static MD5Animation MD5Loader.loadAnimation(java.io.InputStream in)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MD5AnimationInfo (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders.md5
Class MD5AnimationInfo

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo

public class MD5AnimationInfo
extends java.lang.Object

Constructor Summary
MD5AnimationInfo(int maxFrame, float maxTime)
Method Summary
int | getCurrentFrame()
float | getInterpolation()
int | getNextFrame()
void | reset()
void | reset(int maxFrame, float maxTime)
void | update(float delta)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MD5AnimationInfo

public MD5AnimationInfo(int maxFrame,
                        float maxTime)
Method Detail

reset

public void reset()

reset

public void reset(int maxFrame,
                  float maxTime)

update

public void update(float delta)

getCurrentFrame

public int getCurrentFrame()

getNextFrame

public int getNextFrame()

getInterpolation

public float getInterpolation()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo

No usage of com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MD5Jni (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders.md5
Class MD5Jni

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.md5.MD5Jni

public class MD5Jni
extends java.lang.Object

Constructor Summary
MD5Jni()
Method Summary
static void calculateVertices(float[] skeleton, float[] weights, float[] verticesIn, float[] verticesOut, int numVertices)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MD5Jni

public MD5Jni()
Method Detail

calculateVertices

public static void calculateVertices(float[] skeleton,
                                     float[] weights,
                                     float[] verticesIn,
                                     float[] verticesOut,
                                     int numVertices)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.md5.MD5Jni (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.md5.MD5Jni

No usage of com.badlogic.gdx.graphics.loaders.md5.MD5Jni

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MD5Joints (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders.md5
Class MD5Joints

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.md5.MD5Joints

public class MD5Joints
extends java.lang.Object

Field Summary
float[] | joints (0) parent, (1) pos.x, (2) pos.y, (3) pos.z, (4) orient.x, (5) orient.y, (6) orient.z, (7) orient.w
java.lang.String[] | names
int | numJoints
Constructor Summary
MD5Joints()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

names

public java.lang.String[] names

numJoints

public int numJoints

joints

public float[] joints
(0) parent, (1) pos.x, (2) pos.y, (3) pos.z, (4) orient.x, (5) orient.y, (6) orient.z, (7) orient.w

Constructor Detail

MD5Joints

public MD5Joints()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.md5.MD5Joints (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.md5.MD5Joints

Packages that use MD5Joints
com.badlogic.gdx.graphics.loaders.md5

Uses of MD5Joints in com.badlogic.gdx.graphics.loaders.md5

Fields in com.badlogic.gdx.graphics.loaders.md5 declared as MD5Joints
MD5Joints | MD5Model.baseSkeleton
MD5Joints[] | MD5Animation.frames

Methods in com.badlogic.gdx.graphics.loaders.md5 with parameters of type MD5Joints
void | MD5Mesh.calculateVertices(MD5Joints skeleton, float[] verts)
static void | MD5Mesh.calculateVertices(MD5Joints skeleton, float[] weights, float[] vertices, float[] verts)
void | MD5Mesh.calculateVerticesJni(MD5Joints skeleton, float[] verts)
static void | MD5Animation.interpolate(MD5Joints skeletonA, MD5Joints skeletonB, MD5Joints skeletonOut, float t)
void | MD5Renderer.setSkeleton(MD5Joints skeleton)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MD5Loader (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders.md5
Class MD5Loader

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.md5.MD5Loader

public class MD5Loader
extends java.lang.Object

Constructor Summary
MD5Loader()
Method Summary
static MD5Animation | loadAnimation(java.io.InputStream in)
static MD5Model | loadModel(java.io.InputStream in)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MD5Loader

public MD5Loader()
Method Detail

loadModel

public static MD5Model loadModel(java.io.InputStream in)

loadAnimation

public static MD5Animation loadAnimation(java.io.InputStream in)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.md5.MD5Loader (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.md5.MD5Loader

No usage of com.badlogic.gdx.graphics.loaders.md5.MD5Loader

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MD5Mesh (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders.md5
Class MD5Mesh

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.md5.MD5Mesh

public class MD5Mesh
extends java.lang.Object

Field Summary
short[] | indices idx 1, idx 2, idx 3
int | numTriangles
int | numVertices
int | numWeights
java.lang.String | shader
float[] | vertices s, t, start, count
float[] | weights joint, bias, pos.x, pos.y, pos.z
Constructor Summary
MD5Mesh()
Method Summary
void | calculateVertices(MD5Joints skeleton, float[] verts)
static void | calculateVertices(MD5Joints skeleton, float[] weights, float[] vertices, float[] verts)
void | calculateVerticesJni(MD5Joints skeleton, float[] verts)
float[] | createVertexArray()
short[] | getIndices()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

shader

public java.lang.String shader

numVertices

public int numVertices

numWeights

public int numWeights

numTriangles

public int numTriangles

vertices

public float[] vertices
s, t, start, count

weights

public float[] weights
joint, bias, pos.x, pos.y, pos.z

indices

public short[] indices
idx 1, idx 2, idx 3

Constructor Detail

MD5Mesh

public MD5Mesh()
Method Detail

createVertexArray

public float[] createVertexArray()

getIndices

public short[] getIndices()

calculateVertices

public void calculateVertices(MD5Joints skeleton,
                              float[] verts)

calculateVertices

public static void calculateVertices(MD5Joints skeleton,
                                     float[] weights,
                                     float[] vertices,
                                     float[] verts)

calculateVerticesJni

public void calculateVerticesJni(MD5Joints skeleton,
                                 float[] verts)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.md5.MD5Mesh (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.md5.MD5Mesh

Packages that use MD5Mesh
com.badlogic.gdx.graphics.loaders.md5

Uses of MD5Mesh in com.badlogic.gdx.graphics.loaders.md5

Fields in com.badlogic.gdx.graphics.loaders.md5 declared as MD5Mesh
 MD5Mesh[] MD5Model.meshes

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MD5Model (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders.md5
Class MD5Model

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.md5.MD5Model

public class MD5Model
extends java.lang.Object

Field Summary
MD5Joints | baseSkeleton
MD5Mesh[] | meshes
int | numJoints
Constructor Summary
MD5Model()
Method Summary
int | getNumTriangles()
int | getNumVertices()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

numJoints

public int numJoints

baseSkeleton

public MD5Joints baseSkeleton

meshes

public MD5Mesh[] meshes
Constructor Detail

MD5Model

public MD5Model()
Method Detail

getNumVertices

public int getNumVertices()

getNumTriangles

public int getNumTriangles()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.md5.MD5Model (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.md5.MD5Model

Packages that use MD5Model
com.badlogic.gdx.graphics.loaders.md5

Uses of MD5Model in com.badlogic.gdx.graphics.loaders.md5

Methods in com.badlogic.gdx.graphics.loaders.md5 that return MD5Model
static MD5Model MD5Loader.loadModel(java.io.InputStream in)

Constructors in com.badlogic.gdx.graphics.loaders.md5 with parameters of type MD5Model
MD5Renderer(MD5Model model, boolean useJni)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MD5Quaternion (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders.md5
Class MD5Quaternion

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion

public class MD5Quaternion
extends java.lang.Object

Field Summary
float | w
float | x
float | y
float | z
Constructor Summary
MD5Quaternion()
MD5Quaternion(float x, float y, float z)
MD5Quaternion(float x, float y, float z, float w)
Method Summary
void | computeW()
float | dot(MD5Quaternion q)
void | multiply(MD5Quaternion q)
void | multiply(Vector3 v)
void | normalize()
void | rotate(Vector3 vec)
void | set(MD5Quaternion q)
void | slerp(MD5Quaternion q, float t)
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

x

public float x

y

public float y

z

public float z

w

public float w
Constructor Detail

MD5Quaternion

public MD5Quaternion()

MD5Quaternion

public MD5Quaternion(float x,
                     float y,
                     float z)

MD5Quaternion

public MD5Quaternion(float x,
                     float y,
                     float z,
                     float w)
Method Detail

set

public void set(MD5Quaternion q)

computeW

public void computeW()

normalize

public void normalize()

multiply

public void multiply(MD5Quaternion q)

multiply

public void multiply(Vector3 v)

rotate

public void rotate(Vector3 vec)

dot

public float dot(MD5Quaternion q)

slerp

public void slerp(MD5Quaternion q,
                  float t)

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion

Packages that use MD5Quaternion
com.badlogic.gdx.graphics.loaders.md5

Uses of MD5Quaternion in com.badlogic.gdx.graphics.loaders.md5

Methods in com.badlogic.gdx.graphics.loaders.md5 with parameters of type MD5Quaternion
float | MD5Quaternion.dot(MD5Quaternion q)
void | MD5Quaternion.multiply(MD5Quaternion q)
void | MD5Quaternion.set(MD5Quaternion q)
void | MD5Quaternion.slerp(MD5Quaternion q, float t)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MD5Renderer (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders.md5
Class MD5Renderer

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.md5.MD5Renderer

public class MD5Renderer
extends java.lang.Object

Constructor Summary
MD5Renderer(MD5Model model, boolean useJni)
Method Summary
void | dispose()
boolean | isJniUsed()
void | render()
void | setSkeleton(MD5Joints skeleton)
void | setUseJni(boolean useJni)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MD5Renderer

public MD5Renderer(MD5Model model,
                   boolean useJni)
Method Detail

setSkeleton

public void setSkeleton(MD5Joints skeleton)

setUseJni

public void setUseJni(boolean useJni)

render

public void render()

dispose

public void dispose()

isJniUsed

public boolean isJniUsed()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.md5.MD5Renderer (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.md5.MD5Renderer

No usage of com.badlogic.gdx.graphics.loaders.md5.MD5Renderer

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Mesh (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class Mesh

java.lang.Object
    extended by  com.badlogic.gdx.graphics.Mesh

public class Mesh
extends java.lang.Object

A Mesh holds vertices composed of attributes specified by a VertexAttributes instance. The vertices are held either in VRAM in form of vertex buffer objects or in RAM in form of vertex arrays. The former variant is more performant and is prefered over vertex arrays if hardware supports it.

Meshes are automatically managed. If the OpenGL context is lost all vertex buffer objects get invalidated and must be reloaded when the context is recreated. This only happens on Android when a user switches to another application or receives an incoming call. A managed Mesh will be reloaded automagically so you don't have to do this manually.

A Mesh consists of vertices and optionally indices which specify which vertices define a triangle. Each vertex is composed of attributes such as position, normal, color or texture coordinate. Note that not all of this attributes must be given, except for position which is non-optional. Each attribute has an alias which is used when rendering a Mesh in OpenGL ES 2.0. The alias is used to bind a specific vertex attribute to a shader attribute. The shader source and the alias of the attribute must match exactly for this to work. For OpenGL ES 1.x rendering this aliases are irrelevant.

Meshes can be used with either OpenGL ES 1.x or OpenGL ES 2.0.

Author:
mzechner

Nested Class Summary
static class Mesh.VertexDataType
Field Summary
static boolean forceVBO
used for benchmarking
Constructor Summary
Mesh(boolean isStatic, int maxVertices, int maxIndices, VertexAttribute... attributes)
Creates a new Mesh with the given attributes.
Mesh(Mesh.VertexDataType type, boolean isStatic, int maxVertices, int maxIndices, VertexAttribute... attributes)
Creates a new Mesh with the given attributes.
Method Summary
void | bind() Binds the underlying VertexArray/VertexBufferObject and IndexBufferObject if indices were given.
void | bind(ShaderProgram shader) Binds the underlying VertexBufferObject and IndexBufferObject if indices where given.
static void | clearAllMeshes() Will clear the managed mesh cache.
void | dispose() Frees all resources associated with this Mesh
java.nio.ShortBuffer | getIndicesBuffer()
int | getMaxIndices()
int | getMaxVertices()
int | getNumIndices()
int | getNumVertices()
VertexAttribute | getVertexAttribute(int usage) Returns the first VertexAttribute having the given VertexAttributes.Usage.
VertexAttributes | getVertexAttributes()
int | getVertexSize()
java.nio.FloatBuffer | getVerticesBuffer()
static void | invalidateAllMeshes() Invalidates all meshes so the next time they are rendered new VBO handles are generated.
void | render(int primitiveType) Renders the mesh using the given primitive type.
void | render(int primitiveType, int offset, int count) Renders the mesh using the given primitive type.
void | render(ShaderProgram shader, int primitiveType) Renders the mesh using the given primitive type.
void | render(ShaderProgram shader, int primitiveType, int offset, int count) Renders the mesh using the given primitive type.
void | setAutoBind(boolean autoBind) Sets whether to bind the underlying VertexArray or VertexBufferObject automatically on a call to one of the render(int) methods or not.
void | setIndices(short[] indices) Sets the indices of this Mesh
void | setIndices(short[] indices, int offset, int count) Sets the indices of this Mesh.
void | setVertices(float[] vertices) Sets the vertices of this Mesh.
void | setVertices(float[] vertices, int offset, int count) Sets the vertices of this Mesh.
void | unbind() Unbinds the underlying VertexArray/VertexBufferObject and IndexBufferObject is indices were given.
void | unbind(ShaderProgram shader) Unbinds the underlying VertexBufferObject and IndexBufferObject is indices were given.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

forceVBO

public static boolean forceVBO
used for benchmarking

Constructor Detail

Mesh

public Mesh(boolean isStatic,
            int maxVertices,
            int maxIndices,
            VertexAttribute... attributes)
Creates a new Mesh with the given attributes.

Parameters:
isStatic - whether this mesh is static or not. Allows for internal optimizations.
maxVertices - the maximum number of vertices this mesh can hold
maxIndices - the maximum number of indices this mesh can hold
attributes - the VertexAttributes. Each vertex attribute defines one property of a vertex such as position, normal or texture coordinate

Mesh

public Mesh(Mesh.VertexDataType type,
            boolean isStatic,
            int maxVertices,
            int maxIndices,
            VertexAttribute... attributes)
Creates a new Mesh with the given attributes. This is an expert method with no error checking. Use at your own risk.

Parameters:
type - the Mesh.VertexDataType to be used, VBO or VA.
isStatic - whether this mesh is static or not. Allows for internal optimizations.
maxVertices - the maximum number of vertices this mesh can hold
maxIndices - the maximum number of indices this mesh can hold
attributes - the VertexAttributes. Each vertex attribute defines one property of a vertex such as position, normal or texture coordinate
Method Detail

setVertices

public void setVertices(float[] vertices)
Sets the vertices of this Mesh. The attributes are assumed to be given in float format. If this mesh is configured to use fixed point an IllegalArgumentException will be thrown.

Parameters:
vertices - the vertices.

setVertices

public void setVertices(float[] vertices,
                        int offset,
                        int count)
Sets the vertices of this Mesh. The attributes are assumed to be given in float format. If this mesh is configured to use fixed point an IllegalArgumentException will be thrown.

Parameters:
vertices - the vertices.
offset - the offset into the vertices array
count - the number of floats to use

setIndices

public void setIndices(short[] indices)
Sets the indices of this Mesh

Parameters:
indices - the indices

setIndices

public void setIndices(short[] indices,
                       int offset,
                       int count)
Sets the indices of this Mesh.

Parameters:
indices - the indices
offset - the offset into the indices array
count - the number of indices to copy

getNumIndices

public int getNumIndices()
Returns:
the number of defined indices

getNumVertices

public int getNumVertices()
Returns:
the number of defined vertices

getMaxVertices

public int getMaxVertices()
Returns:
the maximum number of vertices this mesh can hold

getMaxIndices

public int getMaxIndices()
Returns:
the maximum number of indices this mesh can hold

getVertexSize

public int getVertexSize()
Returns:
the size of a single vertex in bytes

setAutoBind

public void setAutoBind(boolean autoBind)
Sets whether to bind the underlying VertexArray or VertexBufferObject automatically on a call to one of the render(int) methods or not. Usually you want to use autobind. Manual binding is an expert functionality. There is a driver bug on the MSM720xa chips that will fuck up memory if you manipulate the vertices and indices of a Mesh multiple times while it is bound. Keep this in mind.

Parameters:
autoBind - whether to autobind meshes.

bind

public void bind()
Binds the underlying VertexArray/VertexBufferObject and IndexBufferObject if indices were given. Use this with OpenGL ES 1.x and when auto-bind is disabled.

unbind

public void unbind()
Unbinds the underlying VertexArray/VertexBufferObject and IndexBufferObject is indices were given. Use this with OpenGL ES 1.x and when auto-bind is disabled.

bind

public void bind(ShaderProgram shader)
Binds the underlying VertexBufferObject and IndexBufferObject if indices where given. Use this with OpenGL ES 2.0 and when auto-bind is disabled.

Parameters:
shader - the shader (does not bind the shader)

unbind

public void unbind(ShaderProgram shader)
Unbinds the underlying VertexBufferObject and IndexBufferObject is indices were given. Use this with OpenGL ES 1.x and when auto-bind is disabled.

Parameters:
shader - the shader (does not unbind the shader)

render

public void render(int primitiveType)

Renders the mesh using the given primitive type. If indices are set for this mesh then getNumIndices() / #vertices per primitive primitives are rendered. If no indices are set then getNumVertices() / #vertices per primitive are rendered.

This method is intended for use with OpenGL ES 1.x and will throw an IllegalStateException when OpenGL ES 2.0 is used.

Parameters:
primitiveType - the primitive type

render

public void render(int primitiveType,
                   int offset,
                   int count)

Renders the mesh using the given primitive type. offset specifies the offset into vertex buffer and is ignored for the index buffer. Count specifies the number of vertices or indices to use thus count / #vertices per primitive primitives are rendered.

This method is intended for use with OpenGL ES 1.x and will throw an IllegalStateException when OpenGL ES 2.0 is used.

Parameters:
primitiveType - the primitive type
offset - the offset into the vertex buffer, ignored for indexed rendering
count - number of vertices or indices to use

render

public void render(ShaderProgram shader,
                   int primitiveType)

Renders the mesh using the given primitive type. If indices are set for this mesh then getNumIndices() / #vertices per primitive primitives are rendered. If no indices are set then getNumVertices() / #vertices per primitive are rendered.

This method will automatically bind each vertex attribute as specified at construction time via VertexAttributes to the respective shader attributes. The binding is based on the alias defined for each VertexAttribute.

This method must only be called after the ShaderProgram.begin() method has been called!

This method is intended for use with OpenGL ES 2.0 and will throw an IllegalStateException when OpenGL ES 1.x is used.

Parameters:
primitiveType - the primitive type

render

public void render(ShaderProgram shader,
                   int primitiveType,
                   int offset,
                   int count)

Renders the mesh using the given primitive type. offset specifies the offset into either the vertex buffer or the index buffer depending on whether indices are defined. count specifies the number of vertices or indices to use thus count / #vertices per primitive primitives are rendered.

This method will automatically bind each vertex attribute as specified at construction time via VertexAttributes to the respective shader attributes. The binding is based on the alias defined for each VertexAttribute.

This method must only be called after the ShaderProgram.begin() method has been called!

This method is intended for use with OpenGL ES 2.0 and will throw an IllegalStateException when OpenGL ES 1.x is used.

Parameters:
shader - the shader to be used
primitiveType - the primitive type
offset - the offset into the vertex or index buffer
count - number of vertices or indices to use

dispose

public void dispose()
Frees all resources associated with this Mesh

getVertexAttribute

public VertexAttribute getVertexAttribute(int usage)
Returns the first VertexAttribute having the given VertexAttributes.Usage.

Parameters:
usage - the Usage.
Returns:
the VertexAttribute or null if no attribute with that usage was found.

getVertexAttributes

public VertexAttributes getVertexAttributes()
Returns:
the vertex attributes of this Mesh

getVerticesBuffer

public java.nio.FloatBuffer getVerticesBuffer()
Returns:
the backing FloatBuffer holding the vertices. Does not have to be a direct buffer on Android!

getIndicesBuffer

public java.nio.ShortBuffer getIndicesBuffer()
Returns:
the backing shortbuffer holding the indices. Does not have to be a direct buffer on Android!

invalidateAllMeshes

public static void invalidateAllMeshes()
Invalidates all meshes so the next time they are rendered new VBO handles are generated.

clearAllMeshes

public static void clearAllMeshes()
Will clear the managed mesh cache. I wouldn't use this if i was you :)

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.Mesh (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.Mesh

Packages that use Mesh
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.loaders

Uses of Mesh in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Mesh
static Mesh ModelLoader.loadObj(java.io.InputStream in)
Loads a Wavefront OBJ file from the given InputStream.

Uses of Mesh in com.badlogic.gdx.graphics.loaders

Methods in com.badlogic.gdx.graphics.loaders that return Mesh
static Mesh | ObjLoader.loadObj(java.io.InputStream in) Loads a Wavefront OBJ file from the given input stream.
static Mesh | ObjLoader.loadObjFromString(java.lang.String obj) Loads a mesh from the given string in Wavefront OBJ format

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Mesh.VertexDataType (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.graphics
Enum Mesh.VertexDataType

java.lang.Object
    extended by  java.lang.Enum<Mesh.VertexDataType>
        extended by  com.badlogic.gdx.graphics.Mesh.VertexDataType
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Mesh.VertexDataType>
Enclosing class:
Mesh
public static enum Mesh.VertexDataType
extends java.lang.Enum<Mesh.VertexDataType>

Enum Constant Summary
VertexArray
VertexBufferObject
VertexBufferObjectSubData
Method Summary
static Mesh.VertexDataType | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Mesh.VertexDataType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

VertexArray

public static final Mesh.VertexDataType VertexArray

VertexBufferObject

public static final Mesh.VertexDataType VertexBufferObject

VertexBufferObjectSubData

public static final Mesh.VertexDataType VertexBufferObjectSubData
Method Detail

values

public static Mesh.VertexDataType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Mesh.VertexDataType c : Mesh.VertexDataType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Mesh.VertexDataType valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.graphics.Mesh.VertexDataType (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.Mesh.VertexDataType

Packages that use Mesh.VertexDataType
com.badlogic.gdx.graphics

Uses of Mesh.VertexDataType in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Mesh.VertexDataType
static Mesh.VertexDataType | Mesh.VertexDataType.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Mesh.VertexDataType[] | Mesh.VertexDataType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Constructors in com.badlogic.gdx.graphics with parameters of type Mesh.VertexDataType
Mesh(Mesh.VertexDataType type, boolean isStatic, int maxVertices, int maxIndices, VertexAttribute... attributes)
Creates a new Mesh with the given attributes.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ModelLoader (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class ModelLoader

java.lang.Object
    extended by  com.badlogic.gdx.graphics.ModelLoader

public class ModelLoader
extends java.lang.Object

A class for loading various model formats such as Wavefront OBJ. Ties in all the loaders from the loaders package.

Author:
mzechner

Constructor Summary
ModelLoader()
Method Summary
static Mesh loadObj(java.io.InputStream in)
Loads a Wavefront OBJ file from the given InputStream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ModelLoader

public ModelLoader()
Method Detail

loadObj

public static Mesh loadObj(java.io.InputStream in)
Loads a Wavefront OBJ file from the given InputStream. The OBJ file must only contain triangulated meshes. Materials are ignored.

Parameters:
in - the InputStream
Returns:
a Mesh holding the OBJ data or null in case something went wrong.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.ModelLoader (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.ModelLoader

No usage of com.badlogic.gdx.graphics.ModelLoader

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MouseJoint (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class MouseJoint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
        extended by  com.badlogic.gdx.physics.box2d.joints.MouseJoint

public class MouseJoint
extends Joint

A mouse joint is used to make a point on a body track a specified world point. This a soft constraint with a maximum force. This allows the constraint to stretch and without applying huge forces. NOTE: this joint is not documented in the manual because it was developed to be used in the testbed. If you want to learn how to use the mouse joint, look at the testbed.

Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Joint
addr, jointEdgeA, jointEdgeB
Constructor Summary
MouseJoint(World world, long addr)
Method Summary
float | getDampingRatio() Set/get the damping ratio (dimensionless).
float | getFrequency() Set/get the frequency in Hertz.
float | getMaxForce() Set/get the maximum force in Newtons.
Vector2 | getTarget()
void | setDampingRatio(float ratio) Set/get the damping ratio (dimensionless).
void | setFrequency(float hz) Set/get the frequency in Hertz.
void | setMaxForce(float force) Set/get the maximum force in Newtons.
void | setTarget(Vector2 target) Use this to update the target point.
Methods inherited from class com.badlogic.gdx.physics.box2d.Joint
getAnchorA, getAnchorB, getBodyA, getBodyB, getReactionForce, getReactionTorque, getType, isActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MouseJoint

public MouseJoint(World world,
                  long addr)
Method Detail

setTarget

public void setTarget(Vector2 target)
Use this to update the target point.

getTarget

public Vector2 getTarget()

setMaxForce

public void setMaxForce(float force)
Set/get the maximum force in Newtons.

getMaxForce

public float getMaxForce()
Set/get the maximum force in Newtons.

setFrequency

public void setFrequency(float hz)
Set/get the frequency in Hertz.

getFrequency

public float getFrequency()
Set/get the frequency in Hertz.

setDampingRatio

public void setDampingRatio(float ratio)
Set/get the damping ratio (dimensionless).

getDampingRatio

public float getDampingRatio()
Set/get the damping ratio (dimensionless).

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.MouseJoint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.MouseJoint

No usage of com.badlogic.gdx.physics.box2d.joints.MouseJoint

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MouseJointDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class MouseJointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
        extended by  com.badlogic.gdx.physics.box2d.joints.MouseJointDef

public class MouseJointDef
extends JointDef

Mouse joint definition. This requires a world target point, tuning parameters, and the time step.

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType
Field Summary
float | dampingRatio The damping ratio.
float | frequencyHz The response speed.
float | maxForce The maximum constraint force that can be exerted to move the candidate body.
Vector2 | target The initial world target point.
Fields inherited from class com.badlogic.gdx.physics.box2d.JointDef
bodyA, bodyB, collideConnected, type
Constructor Summary
MouseJointDef()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

target

public final Vector2 target
The initial world target point. This is assumed to coincide with the body anchor initially.

maxForce

public float maxForce
The maximum constraint force that can be exerted to move the candidate body. Usually you will express as some multiple of the weight (multiplier * mass * gravity).

frequencyHz

public float frequencyHz
The response speed.

dampingRatio

public float dampingRatio
The damping ratio. 0 = no damping, 1 = critical damping.

Constructor Detail

MouseJointDef

public MouseJointDef()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.MouseJointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.MouseJointDef

No usage of com.badlogic.gdx.physics.box2d.joints.MouseJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MoveBy (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class MoveBy

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.MoveBy
All Implemented Interfaces:
Action
public class MoveBy
extends java.lang.Object
implements Action

Field Summary
protected float | deltaX
protected float | deltaY
protected boolean | done
protected float | duration
protected float | invDuration
protected float | startX
protected float | startY
protected float | taken
protected Actor | target
protected float | x
protected float | y
Constructor Summary
MoveBy()
Method Summary
static MoveBy | $(float x, float y, float duration)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

x

protected float x

y

protected float y

startX

protected float startX

startY

protected float startY

deltaX

protected float deltaX

deltaY

protected float deltaY

duration

protected float duration

invDuration

protected float invDuration

taken

protected float taken

target

protected Actor target

done

protected boolean done
Constructor Detail

MoveBy

public MoveBy()
Method Detail

$

public static MoveBy $(float x,
                       float y,
                       float duration)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.MoveBy (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.MoveBy

Packages that use MoveBy
com.badlogic.gdx.scenes.scene2d.actions

Uses of MoveBy in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return MoveBy
static MoveBy MoveBy.$(float x, float y, float duration)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


MoveTo (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class MoveTo

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.MoveTo
All Implemented Interfaces:
Action
public class MoveTo
extends java.lang.Object
implements Action

Field Summary
protected float | deltaX
protected float | deltaY
protected boolean | done
protected float | duration
protected float | invDuration
protected float | startX
protected float | startY
protected float | taken
protected Actor | target
protected float | x
protected float | y
Constructor Summary
MoveTo()
Method Summary
static MoveTo | $(float x, float y, float duration)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

x

protected float x

y

protected float y

startX

protected float startX

startY

protected float startY

deltaX

protected float deltaX

deltaY

protected float deltaY

duration

protected float duration

invDuration

protected float invDuration

taken

protected float taken

target

protected Actor target

done

protected boolean done
Constructor Detail

MoveTo

public MoveTo()
Method Detail

$

public static MoveTo $(float x,
                       float y,
                       float duration)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.MoveTo (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.MoveTo

Packages that use MoveTo
com.badlogic.gdx.scenes.scene2d.actions

Uses of MoveTo in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return MoveTo
static MoveTo MoveTo.$(float x, float y, float duration)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Mpg123Decoder (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.io
Class Mpg123Decoder

java.lang.Object
    extended by  com.badlogic.gdx.audio.io.Mpg123Decoder
All Implemented Interfaces:
Decoder
public class Mpg123Decoder
extends java.lang.Object
implements Decoder

A Decoder implementation that decodes MP3 files via libmpg123 natively.

Author:
mzechner

Field Summary
 long handle
Constructor Summary
Mpg123Decoder(java.lang.String filename)
Opens the given file for mp3 decoding.
Method Summary
 void dispose()
Disposes the decoder and frees all associated resources
 float getLength()
 int getNumChannels()
 int getRate()
 int readSamples(java.nio.ShortBuffer samples)
Reads in samples.capacity() samples in 16-bit signed PCM format from the decoder.
 int skipSamples(int numSamples)
Skips numSamples samples.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

handle

public final long handle
Constructor Detail

Mpg123Decoder

public Mpg123Decoder(java.lang.String filename)
Opens the given file for mp3 decoding. Throws an IllegalArugmentException in case the file could not be opened.

Parameters:
filename - the filename
Method Detail

readSamples

public int readSamples(java.nio.ShortBuffer samples)
Reads in samples.capacity() samples in 16-bit signed PCM format from the decoder. Returns the actual number read in. If this number is smaller than the capacity of the buffer then the end of stream has been reached. The provided ShortBuffer must be a direct buffer.

Specified by:
readSamples in interface Decoder
Parameters:
samples - The number of read samples.

skipSamples

public int skipSamples(int numSamples)
Skips numSamples samples. If the decoded file is in stereo the left and right channel samples are counted as 2 samples.

Specified by:
skipSamples in interface Decoder
Parameters:
numSamples - the number of samples to skip
Returns:
the number of samples actually skipped. If this is < numSamples then the end of the file has been reached.

getNumChannels

public int getNumChannels()

Specified by:
getNumChannels in interface Decoder
Returns:
the number of channels

getRate

public int getRate()

Specified by:
getRate in interface Decoder
Returns:
the sampling rate in herz, e.g. 44100

getLength

public float getLength()

Specified by:
getLength in interface Decoder
Returns:
the length of the file in seconds

dispose

public void dispose()
Disposes the decoder and frees all associated resources

Specified by:
dispose in interface Decoder
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.audio.io.Mpg123Decoder (libgdx API)

Uses of Class
com.badlogic.gdx.audio.io.Mpg123Decoder

No usage of com.badlogic.gdx.audio.io.Mpg123Decoder

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Music (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio
Interface Music

public interface Music

A Music instance represents a streamed audio file. The interface supports setting the play back position, pausing and resuming and so on. When you are done with using the Music instance you have to dispose it via the dispose() method.

Music instances are created via Audio.newMusic(FileHandle).

Music instances are automatically paused and resumed when an Application is paused or resumed. See ApplicationListener.

Author:
mzechner

Method Summary
void | dispose() Needs to be called when the Music is no longer needed.
boolean | isLooping()
boolean | isPlaying()
void | pause() Pauses the play back.
void | play() Starts the play back of the music stream.
void | setLooping(boolean isLooping) Sets whether the music stream is looping or not.
void | setVolume(float volume) Sets the volume of this music stream.
void | stop() Stops a playing or paused Music instance.

Method Detail

play

void play()
Starts the play back of the music stream. In case the stream was paused this will resume the play back. In case the music stream is finished playing this will restart the play back.

pause

void pause()
Pauses the play back. If the music stream has not been started yet or has finished playing a call to this method will be ignored.

stop

void stop()
Stops a playing or paused Music instance. Next time play() is invoked the Music will start from the beginning.

isPlaying

boolean isPlaying()
Returns:
whether this music stream is playing or not

setLooping

void setLooping(boolean isLooping)
Sets whether the music stream is looping or not. This can be called at any time, whether the stream is playing or not.

Parameters:
isLooping - whether to loop the stream or not

isLooping

boolean isLooping()
Returns:
whether the music stream is playing or not.

setVolume

void setVolume(float volume)
Sets the volume of this music stream. The volume must be given in the range [0,1] with 0 being silent and 1 being the maximum volume.

Parameters:
volume -

dispose

void dispose()
Needs to be called when the Music is no longer needed.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.audio.Music (libgdx API)

Uses of Interface
com.badlogic.gdx.audio.Music

Packages that use Music
com.badlogic.gdx

Uses of Music in com.badlogic.gdx

Methods in com.badlogic.gdx that return Music
 Music Audio.newMusic(FileHandle file)
Creates a new Music instance which is used to play back a music stream from a file.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


NativeFFT (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.analysis
Class NativeFFT

java.lang.Object
    extended by  com.badlogic.gdx.audio.analysis.NativeFFT

public class NativeFFT
extends java.lang.Object

A native implementation of the Fast Fourier Transform, directly ported from the FFT class.

Author:
mzechner

Constructor Summary
NativeFFT(int timeSize, int sampleRate)
Method Summary
void | dispose()
void | spectrum(java.nio.FloatBuffer samples, java.nio.FloatBuffer spectrum, int numSamples)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NativeFFT

public NativeFFT(int timeSize,
                 int sampleRate)
Method Detail

spectrum

public void spectrum(java.nio.FloatBuffer samples,
                     java.nio.FloatBuffer spectrum,
                     int numSamples)

dispose

public void dispose()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.audio.analysis.NativeFFT (libgdx API)

Uses of Class
com.badlogic.gdx.audio.analysis.NativeFFT

No usage of com.badlogic.gdx.audio.analysis.NativeFFT

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ObjLoader (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.loaders
Class ObjLoader

java.lang.Object
    extended by  com.badlogic.gdx.graphics.loaders.ObjLoader

public class ObjLoader
extends java.lang.Object

Loads Wavefront OBJ files, ignores material files.

Author:
mzechner

Constructor Summary
ObjLoader()
Method Summary
static Mesh | loadObj(java.io.InputStream in) Loads a Wavefront OBJ file from the given input stream.
static Mesh | loadObjFromString(java.lang.String obj) Loads a mesh from the given string in Wavefront OBJ format
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjLoader

public ObjLoader()
Method Detail

loadObj

public static Mesh loadObj(java.io.InputStream in)
Loads a Wavefront OBJ file from the given input stream.

Parameters:
in - the InputStream

loadObjFromString

public static Mesh loadObjFromString(java.lang.String obj)
Loads a mesh from the given string in Wavefront OBJ format

Parameters:
obj - The string
Returns:
The Mesh
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.loaders.ObjLoader (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.loaders.ObjLoader

No usage of com.badlogic.gdx.graphics.loaders.ObjLoader

Overview Package Class Use Tree Deprecated Index Help
libgdx API


OrthographicCamera (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class OrthographicCamera

java.lang.Object
    extended by  com.badlogic.gdx.graphics.OrthographicCamera

public final class OrthographicCamera
extends java.lang.Object

An orthographic camera having a position and a scale value for zooming. Looks at one of the sides given in the OrthographicCamera.Side enums, default is front, looking along the z-Axis. Generally you will want to alter the camera's scale and position and then set its matrices via a call to setMatrices() to set the OpenGL perspective and modelview matrices. You can get a picking ray via a call to getPickRay(int, int) . For OpenGL ES 2.0 you can get the matrices via getCombinedMatrix() to set them as a uniform. For this you have to call update() before you retrieve the matrices.

Author:
badlogicgames@gmail.com

Nested Class Summary
static class OrthographicCamera.Side
Constructor Summary
OrthographicCamera()
Constructor, sets side to OrthographicCamera.Side.FRONT
Method Summary
Matrix4 | getCombinedMatrix()
float | getFar()
float | getNear()
Ray | getPickRay(int screenX, int screenY) Returns a ray in world space form the given screen coordinates.
Vector3 | getPosition()
float | getScale()
void | getScreenToWorld(float screenX, float screenY, Vector2 world) Calculates the world coordinates of the given screen coordinates and stores the result in world
float | getScreenToWorldX(float screenX) Returns the given screen x-coordinates as a world x-coordinate
float | getScreenToWorldY(float screenY) Returns the given screen y-coordinates as a world y-coordinate
OrthographicCamera.Side | getSide()
void | getWorldToScreen(float worldX, float worldY, Vector2 screen) Calculates the screen coordinates of the given world coordinates
int | getWorldToScreenX(float worldX) Returns the given world x-coordinate as a screen x-coordinate
int | getWorldToScreenY(float worldY) Returns the given world y-coordinate as a screen x-coordinate
void | setFar(float far) Sets the far plane
void | setMatrices() Sets the projection matrix that also incorporates the camera's scale and position and loads an identity to the model view matrix of OpenGL ES 1.x.
void | setNear(float near) Sets the near plane.
void | setScale(float scale)
void | setSide(OrthographicCamera.Side side) Sets the side the camera looks at.
void | setViewport(float width, float height) Sets the viewport
void | update() Updates the frustum as well as the matrices of the camera based on the near and far plane, the position, the side and the scale.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OrthographicCamera

public OrthographicCamera()
Constructor, sets side to OrthographicCamera.Side.FRONT

Method Detail

getSide

public OrthographicCamera.Side getSide()
Returns:
Which side the camera looks at

setSide

public void setSide(OrthographicCamera.Side side)
Sets the side the camera looks at.

Parameters:
side - The side.

getNear

public float getNear()
Returns:
The near plane.

setNear

public void setNear(float near)
Sets the near plane.

Parameters:
near - The near plane

getFar

public float getFar()
Returns:
The far plane.

setFar

public void setFar(float far)
Sets the far plane

Parameters:
far - the far plane

getScale

public float getScale()
Returns:
The scale

setScale

public void setScale(float scale)
Parameters:
scale - Sets the scale

getPosition

public Vector3 getPosition()
Returns:
The position

setViewport

public void setViewport(float width,
                        float height)
Sets the viewport

Parameters:
width - The viewport width in pixels
height - The viewport height in pixels

update

public void update()
Updates the frustum as well as the matrices of the camera based on the near and far plane, the position, the side and the scale.

setMatrices

public void setMatrices()
Sets the projection matrix that also incorporates the camera's scale and position and loads an identity to the model view matrix of OpenGL ES 1.x. The current matrices get overwritten. The matrix mode will be left in the model view state after a call to this.

getScreenToWorld

public void getScreenToWorld(float screenX,
                             float screenY,
                             Vector2 world)
Calculates the world coordinates of the given screen coordinates and stores the result in world

Parameters:
screenX - the x-coordinate of the screen position
screenY - the y-coordinate of the screen position
world - the vector to store the result in

getWorldToScreen

public void getWorldToScreen(float worldX,
                             float worldY,
                             Vector2 screen)
Calculates the screen coordinates of the given world coordinates

Parameters:
worldX - world x-coordinate
worldY - world y-coordinate
screen - the screen coordinates get stored here

getScreenToWorldX

public float getScreenToWorldX(float screenX)
Returns the given screen x-coordinates as a world x-coordinate

Parameters:
screenX - The screen x-coordinate
Returns:
The world x-coordinate

getWorldToScreenX

public int getWorldToScreenX(float worldX)
Returns the given world x-coordinate as a screen x-coordinate

Parameters:
worldX - The world x-coordinate
Returns:
The screen x-coordinate

getScreenToWorldY

public float getScreenToWorldY(float screenY)
Returns the given screen y-coordinates as a world y-coordinate

Parameters:
screenY - The screen y-coordinate
Returns:
The world y-coordinate

getWorldToScreenY

public int getWorldToScreenY(float worldY)
Returns the given world y-coordinate as a screen x-coordinate

Parameters:
worldY - The world y-coordinate
Returns:
The screen y-coordinate

getPickRay

public Ray getPickRay(int screenX,
                      int screenY)
Returns a ray in world space form the given screen coordinates. This can be used for picking. The returned Ray is an internal member of this class to reduce memory allocations. Do not reuse it outside of this class.

Parameters:
screenX - The screen x-coordinate
screenY - The screen y-coordinate
Returns:
The picking ray.

getCombinedMatrix

public Matrix4 getCombinedMatrix()
Returns:
The combined matrix.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.OrthographicCamera (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.OrthographicCamera

No usage of com.badlogic.gdx.graphics.OrthographicCamera

Overview Package Class Use Tree Deprecated Index Help
libgdx API


OrthographicCamera.Side (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.graphics
Enum OrthographicCamera.Side

java.lang.Object
    extended by  java.lang.Enum<OrthographicCamera.Side>
        extended by  com.badlogic.gdx.graphics.OrthographicCamera.Side
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<OrthographicCamera.Side>
Enclosing class:
OrthographicCamera
public static enum OrthographicCamera.Side
extends java.lang.Enum<OrthographicCamera.Side>

Enum Constant Summary
BACK
BOTTOM
FRONT
LEFT
RIGHT
TOP
Method Summary
static OrthographicCamera.Side | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OrthographicCamera.Side[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

FRONT

public static final OrthographicCamera.Side FRONT

BACK

public static final OrthographicCamera.Side BACK

TOP

public static final OrthographicCamera.Side TOP

BOTTOM

public static final OrthographicCamera.Side BOTTOM

LEFT

public static final OrthographicCamera.Side LEFT

RIGHT

public static final OrthographicCamera.Side RIGHT
Method Detail

values

public static OrthographicCamera.Side[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (OrthographicCamera.Side c : OrthographicCamera.Side.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static OrthographicCamera.Side valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.graphics.OrthographicCamera.Side (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.OrthographicCamera.Side

Packages that use OrthographicCamera.Side
com.badlogic.gdx.graphics

Uses of OrthographicCamera.Side in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return OrthographicCamera.Side
OrthographicCamera.Side | OrthographicCamera.getSide()
static OrthographicCamera.Side | OrthographicCamera.Side.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static OrthographicCamera.Side[] | OrthographicCamera.Side.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.badlogic.gdx.graphics with parameters of type OrthographicCamera.Side
 void OrthographicCamera.setSide(OrthographicCamera.Side side)
Sets the side the camera looks at.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Overview List (libgdx API)

All Classes

Packages
com.badlogic.gdx
com.badlogic.gdx.audio
com.badlogic.gdx.audio.analysis
com.badlogic.gdx.audio.io
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl
com.badlogic.gdx.files
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils
com.badlogic.gdx.graphics.loaders
com.badlogic.gdx.graphics.loaders.md5
com.badlogic.gdx.graphics.particles
com.badlogic.gdx.math
com.badlogic.gdx.math.collision
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actions
com.badlogic.gdx.scenes.scene2d.actors
com.badlogic.gdx.twl
com.badlogic.gdx.utils
com.badlogic.gdx.utils.json


Overview (libgdx API)

libgdx API

Packages
com.badlogic.gdx
com.badlogic.gdx.audio
com.badlogic.gdx.audio.analysis
com.badlogic.gdx.audio.io
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl
com.badlogic.gdx.files
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils
com.badlogic.gdx.graphics.loaders
com.badlogic.gdx.graphics.loaders.md5
com.badlogic.gdx.graphics.particles
com.badlogic.gdx.math
com.badlogic.gdx.math.collision
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actions
com.badlogic.gdx.scenes.scene2d.actors
com.badlogic.gdx.twl
com.badlogic.gdx.utils
com.badlogic.gdx.utils.json

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Class Hierarchy (libgdx API)

Hierarchy For All Packages

Package Hierarchies:
com.badlogic.gdx, com.badlogic.gdx.audio, com.badlogic.gdx.audio.analysis, com.badlogic.gdx.audio.io, com.badlogic.gdx.backends.android, com.badlogic.gdx.backends.jogl, com.badlogic.gdx.backends.lwjgl, com.badlogic.gdx.files, com.badlogic.gdx.graphics, com.badlogic.gdx.graphics.glutils, com.badlogic.gdx.graphics.loaders, com.badlogic.gdx.graphics.loaders.md5, com.badlogic.gdx.graphics.particles, com.badlogic.gdx.math, com.badlogic.gdx.math.collision, com.badlogic.gdx.physics.box2d, com.badlogic.gdx.physics.box2d.joints, com.badlogic.gdx.scenes.scene2d, com.badlogic.gdx.scenes.scene2d.actions, com.badlogic.gdx.scenes.scene2d.actors, com.badlogic.gdx.twl, com.badlogic.gdx.utils, com.badlogic.gdx.utils.json

Class Hierarchy

  • java.lang.Object
    • Activity
      • com.badlogic.gdx.backends.android.AndroidApplication (implements com.badlogic.gdx.Application)
    • com.badlogic.gdx.scenes.scene2d.Actor
      • com.badlogic.gdx.scenes.scene2d.actors.Button
      • com.badlogic.gdx.scenes.scene2d.Group
        • com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
          • com.badlogic.gdx.scenes.scene2d.actors.LinearGroup
      • com.badlogic.gdx.scenes.scene2d.actors.Image
      • com.badlogic.gdx.scenes.scene2d.actors.Label
    • com.badlogic.gdx.utils.AtomicQueue<T>
    • com.badlogic.gdx.audio.analysis.AudioTools
    • com.badlogic.gdx.graphics.BitmapFont
    • com.badlogic.gdx.graphics.BitmapFont.TextBounds
    • com.badlogic.gdx.graphics.BitmapFontCache
    • com.badlogic.gdx.physics.box2d.Body
    • com.badlogic.gdx.physics.box2d.BodyDef
    • com.badlogic.gdx.math.collision.BoundingBox
    • com.badlogic.gdx.physics.box2d.Box2DDebugRenderer
    • com.badlogic.gdx.utils.BufferUtils
    • com.badlogic.gdx.math.CatmullRomSpline
    • com.badlogic.gdx.graphics.Color
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet
            • com.badlogic.gdx.backends.lwjgl.LwjglApplet
    • com.badlogic.gdx.physics.box2d.Contact
    • com.badlogic.gdx.scenes.scene2d.actions.Delay (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.math.EarCutTriangulator
    • com.badlogic.gdx.scenes.scene2d.actions.FadeIn (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.FadeOut (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.FadeTo (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.files.FileHandle
      • com.badlogic.gdx.files.FileHandleStream
    • com.badlogic.gdx.physics.box2d.Filter
    • com.badlogic.gdx.physics.box2d.Fixture
    • com.badlogic.gdx.physics.box2d.FixtureDef
    • com.badlogic.gdx.utils.FloatArray
    • com.badlogic.gdx.utils.FloatBag
    • com.badlogic.gdx.scenes.scene2d.actions.Forever (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.audio.analysis.FourierTransform
      • com.badlogic.gdx.audio.analysis.DFT
      • com.badlogic.gdx.audio.analysis.FFT
    • com.badlogic.gdx.graphics.glutils.FrameBuffer
    • com.badlogic.gdx.math.Frustum
    • com.badlogic.gdx.Game (implements com.badlogic.gdx.ApplicationListener)
    • com.badlogic.gdx.Gdx
    • com.badlogic.gdx.utils.GdxNativesLoader
    • com.badlogic.gdx.graphics.ImmediateModeRenderer
    • com.badlogic.gdx.graphics.glutils.IndexBufferObject (implements com.badlogic.gdx.graphics.glutils.IndexData)
    • com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData (implements com.badlogic.gdx.graphics.glutils.IndexData)
    • com.badlogic.gdx.Input.Keys
    • com.badlogic.gdx.InputAdapter (implements com.badlogic.gdx.InputProcessor)
      • com.badlogic.gdx.scenes.scene2d.Stage
    • com.badlogic.gdx.InputMultiplexer (implements com.badlogic.gdx.InputProcessor)
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • com.badlogic.gdx.utils.LittleEndianInputStream
    • com.badlogic.gdx.utils.IntArray
    • com.badlogic.gdx.utils.IntBag
    • com.badlogic.gdx.math.Intersector
    • com.badlogic.gdx.utils.IntHashMap<T>
    • com.badlogic.gdx.utils.IntHashMap.Entry<T>
    • com.badlogic.gdx.backends.jogl.JoglApplication (implements com.badlogic.gdx.Application)
    • com.badlogic.gdx.physics.box2d.Joint
      • com.badlogic.gdx.physics.box2d.joints.DistanceJoint
      • com.badlogic.gdx.physics.box2d.joints.FrictionJoint
      • com.badlogic.gdx.physics.box2d.joints.GearJoint
      • com.badlogic.gdx.physics.box2d.joints.LineJoint
      • com.badlogic.gdx.physics.box2d.joints.MouseJoint
      • com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
      • com.badlogic.gdx.physics.box2d.joints.PulleyJoint
      • com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
      • com.badlogic.gdx.physics.box2d.joints.WeldJoint
    • com.badlogic.gdx.physics.box2d.JointDef
      • com.badlogic.gdx.physics.box2d.joints.DistanceJointDef
      • com.badlogic.gdx.physics.box2d.joints.FrictionJointDef
      • com.badlogic.gdx.physics.box2d.joints.GearJointDef
      • com.badlogic.gdx.physics.box2d.joints.LineJointDef
      • com.badlogic.gdx.physics.box2d.joints.MouseJointDef
      • com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
      • com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
      • com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
      • com.badlogic.gdx.physics.box2d.joints.WeldJointDef
    • com.badlogic.gdx.physics.box2d.JointEdge
    • com.badlogic.gdx.utils.json.JSONArray
    • com.badlogic.gdx.utils.json.JSONObject
    • com.badlogic.gdx.utils.json.JSONTokener
    • com.badlogic.gdx.utils.json.JSONWriter
      • com.badlogic.gdx.utils.json.JSONStringer
    • com.badlogic.gdx.audio.analysis.KissFFT
    • com.badlogic.gdx.utils.LocklessThreadQueue<T>
    • com.badlogic.gdx.utils.LongArray
    • com.badlogic.gdx.utils.LongBag
    • com.badlogic.gdx.utils.LongHashMap<T>
    • com.badlogic.gdx.utils.LongHashMap.Entry<T>
    • com.badlogic.gdx.backends.lwjgl.LwjglApplication (implements com.badlogic.gdx.Application)
    • com.badlogic.gdx.backends.lwjgl.LwjglCanvas (implements com.badlogic.gdx.Application)
    • com.badlogic.gdx.physics.box2d.MassData
    • com.badlogic.gdx.utils.MathUtils
    • com.badlogic.gdx.math.Matrix3
    • com.badlogic.gdx.math.Matrix4
    • com.badlogic.gdx.graphics.loaders.md5.MD5Animation
    • com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo
    • com.badlogic.gdx.graphics.loaders.md5.MD5Jni
    • com.badlogic.gdx.graphics.loaders.md5.MD5Joints
    • com.badlogic.gdx.graphics.loaders.md5.MD5Loader
    • com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
    • com.badlogic.gdx.graphics.loaders.md5.MD5Model
    • com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
    • com.badlogic.gdx.graphics.loaders.md5.MD5Renderer
    • com.badlogic.gdx.graphics.Mesh
    • com.badlogic.gdx.graphics.ModelLoader
    • com.badlogic.gdx.scenes.scene2d.actions.MoveBy (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.MoveTo (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.audio.io.Mpg123Decoder (implements com.badlogic.gdx.audio.io.Decoder)
    • com.badlogic.gdx.audio.analysis.NativeFFT
    • com.badlogic.gdx.graphics.loaders.ObjLoader
    • com.badlogic.gdx.graphics.OrthographicCamera
    • com.badlogic.gdx.scenes.scene2d.actions.Parallel (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.graphics.particles.ParticleEffect
    • com.badlogic.gdx.graphics.particles.ParticleEmitter
    • com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
        • com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
    • com.badlogic.gdx.graphics.PerspectiveCamera
    • com.badlogic.gdx.math.Plane
    • com.badlogic.gdx.utils.Pool<T>
    • com.badlogic.gdx.utils.PooledLinkedList<T>
    • com.badlogic.gdx.math.Quaternion (implements java.io.Serializable)
    • com.badlogic.gdx.math.collision.Ray
    • com.badlogic.gdx.math.Rectangle
    • com.badlogic.gdx.scenes.scene2d.actions.Repeat (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.RotateBy (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.RotateTo (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.ScaleTo (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.math.collision.Segment
    • com.badlogic.gdx.scenes.scene2d.actions.Sequence (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.graphics.glutils.ShaderProgram
    • com.badlogic.gdx.physics.box2d.Shape
      • com.badlogic.gdx.physics.box2d.CircleShape
      • com.badlogic.gdx.physics.box2d.PolygonShape
    • com.badlogic.gdx.math.collision.Sphere
    • com.badlogic.gdx.graphics.SpriteBatch
    • com.badlogic.gdx.graphics.SpriteCache
    • com.badlogic.gdx.graphics.TextureAtlas
    • com.badlogic.gdx.graphics.TextureRegion
      • com.badlogic.gdx.graphics.Sprite
      • com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
    • java.lang.Thread (implements java.lang.Runnable)
      • com.badlogic.gdx.utils.PauseableThread
    • com.badlogic.gdx.audio.analysis.ThresholdFunction
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.badlogic.gdx.utils.json.JSONException
        • java.lang.RuntimeException
          • com.badlogic.gdx.utils.GdxRuntimeException
    • com.badlogic.gdx.physics.box2d.Transform
    • com.badlogic.gdx.twl.TWL (implements com.badlogic.gdx.InputProcessor)
    • com.badlogic.gdx.math.Vector2
    • com.badlogic.gdx.math.Vector3
    • com.badlogic.gdx.Version
    • com.badlogic.gdx.graphics.glutils.VertexArray (implements com.badlogic.gdx.graphics.glutils.VertexData)
    • com.badlogic.gdx.graphics.VertexAttribute
    • com.badlogic.gdx.graphics.VertexAttributes
    • com.badlogic.gdx.graphics.VertexAttributes.Usage
    • com.badlogic.gdx.graphics.glutils.VertexBufferObject (implements com.badlogic.gdx.graphics.glutils.VertexData)
    • com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData (implements com.badlogic.gdx.graphics.glutils.VertexData)
    • com.badlogic.gdx.audio.io.VorbisDecoder (implements com.badlogic.gdx.audio.io.Decoder)
    • com.badlogic.gdx.math.WindowedMean
    • com.badlogic.gdx.physics.box2d.World
    • com.badlogic.gdx.physics.box2d.WorldManifold

Interface Hierarchy

  • com.badlogic.gdx.scenes.scene2d.Action
  • com.badlogic.gdx.Application
  • com.badlogic.gdx.ApplicationListener
  • com.badlogic.gdx.Audio
  • com.badlogic.gdx.audio.AudioDevice
  • com.badlogic.gdx.audio.AudioRecorder
  • com.badlogic.gdx.scenes.scene2d.actors.Button.ClickListener
  • com.badlogic.gdx.physics.box2d.ContactFilter
  • com.badlogic.gdx.physics.box2d.ContactListener
  • com.badlogic.gdx.audio.io.Decoder
  • com.badlogic.gdx.physics.box2d.DestructionListener
  • com.badlogic.gdx.Files
  • com.badlogic.gdx.graphics.GLCommon
    • com.badlogic.gdx.graphics.GL10
      • com.badlogic.gdx.graphics.GL11
    • com.badlogic.gdx.graphics.GL11
    • com.badlogic.gdx.graphics.GL20
  • com.badlogic.gdx.Graphics
  • com.badlogic.gdx.graphics.glutils.IndexData
  • com.badlogic.gdx.Input
  • com.badlogic.gdx.Input.TextInputListener
  • com.badlogic.gdx.InputProcessor
  • com.badlogic.gdx.utils.json.JSONString
  • com.badlogic.gdx.utils.LocklessThreadQueue.ObjectFactory<T>
  • com.badlogic.gdx.audio.Music
  • com.badlogic.gdx.graphics.Pixmap
  • com.badlogic.gdx.utils.Pool.PoolObjectFactory<T>
  • com.badlogic.gdx.physics.box2d.QueryCallback
  • com.badlogic.gdx.Screen
  • com.badlogic.gdx.audio.Sound
  • com.badlogic.gdx.graphics.Texture
  • com.badlogic.gdx.graphics.TextureData
  • com.badlogic.gdx.graphics.glutils.VertexData

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.badlogic.gdx.Application.ApplicationType
      • com.badlogic.gdx.Files.FileType
      • com.badlogic.gdx.Graphics.GraphicsType
      • com.badlogic.gdx.graphics.BitmapFont.HAlignment
      • com.badlogic.gdx.graphics.Mesh.VertexDataType
      • com.badlogic.gdx.graphics.OrthographicCamera.Side
      • com.badlogic.gdx.graphics.Pixmap.Format
      • com.badlogic.gdx.graphics.Texture.TextureFilter
      • com.badlogic.gdx.graphics.Texture.TextureWrap
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShape
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnEllipseSide
      • com.badlogic.gdx.math.Plane.PlaneSide
      • com.badlogic.gdx.physics.box2d.BodyDef.BodyType
      • com.badlogic.gdx.physics.box2d.JointDef.JointType
      • com.badlogic.gdx.physics.box2d.Shape.Type
      • com.badlogic.gdx.scenes.scene2d.actors.LinearGroup.LinearGroupLayout
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx (libgdx API)

 com.badlogic.gdx
Interfaces
Application
ApplicationListener
Audio
Files
Graphics
Input
Input.TextInputListener
InputProcessor
Screen
Classes
Game
Gdx
Input.Keys
InputAdapter
InputMultiplexer
Version
Enums
Application.ApplicationType
Files.FileType
Graphics.GraphicsType


com.badlogic.gdx.audio (libgdx API)

 com.badlogic.gdx.audio
Interfaces
AudioDevice
AudioRecorder
Music
Sound


com.badlogic.gdx.audio.analysis (libgdx API)

 com.badlogic.gdx.audio.analysis
Classes
AudioTools
DFT
FFT
FourierTransform
KissFFT
NativeFFT
ThresholdFunction


com.badlogic.gdx.audio.io (libgdx API)

 com.badlogic.gdx.audio.io
Interfaces
Decoder
Classes
Mpg123Decoder
VorbisDecoder


com.badlogic.gdx.backends.android (libgdx API)

 com.badlogic.gdx.backends.android
Classes
AndroidApplication


com.badlogic.gdx.backends.jogl (libgdx API)

 com.badlogic.gdx.backends.jogl
Classes
JoglApplication


com.badlogic.gdx.backends.lwjgl (libgdx API)

 com.badlogic.gdx.backends.lwjgl
Classes
LwjglApplet
LwjglApplication
LwjglCanvas


com.badlogic.gdx.files (libgdx API)

 com.badlogic.gdx.files
Classes
FileHandle
FileHandleStream


com.badlogic.gdx.graphics (libgdx API)

 com.badlogic.gdx.graphics
Interfaces
GL10
GL11
GL20
GLCommon
Pixmap
Texture
TextureData
Classes
BitmapFont
BitmapFont.TextBounds
BitmapFontCache
Color
ImmediateModeRenderer
Mesh
ModelLoader
OrthographicCamera
PerspectiveCamera
Sprite
SpriteBatch
SpriteCache
TextureAtlas
TextureAtlas.AtlasRegion
TextureRegion
VertexAttribute
VertexAttributes
Enums
BitmapFont.HAlignment
Mesh.VertexDataType
OrthographicCamera.Side
Pixmap.Format
Texture.TextureFilter
Texture.TextureWrap


com.badlogic.gdx.graphics.glutils (libgdx API)

 com.badlogic.gdx.graphics.glutils
Interfaces
IndexData
VertexData
Classes
FrameBuffer
IndexBufferObject
IndexBufferObjectSubData
ShaderProgram
VertexArray
VertexBufferObject
VertexBufferObjectSubData


com.badlogic.gdx.graphics.loaders (libgdx API)

 com.badlogic.gdx.graphics.loaders
Classes
ObjLoader


com.badlogic.gdx.graphics.loaders.md5 (libgdx API)

 com.badlogic.gdx.graphics.loaders.md5
Classes
MD5Animation
MD5AnimationInfo
MD5Jni
MD5Joints
MD5Loader
MD5Mesh
MD5Model
MD5Quaternion
MD5Renderer


com.badlogic.gdx.graphics.particles (libgdx API)

 com.badlogic.gdx.graphics.particles
Classes
ParticleEffect
ParticleEmitter
ParticleEmitter.GradientColorValue
ParticleEmitter.NumericValue
ParticleEmitter.ParticleValue
ParticleEmitter.RangedNumericValue
ParticleEmitter.ScaledNumericValue
ParticleEmitter.SpawnShapeValue
Enums
ParticleEmitter.SpawnEllipseSide
ParticleEmitter.SpawnShape


com.badlogic.gdx.math (libgdx API)

 com.badlogic.gdx.math
Classes
CatmullRomSpline
EarCutTriangulator
Frustum
Intersector
Matrix3
Matrix4
Plane
Quaternion
Rectangle
Vector2
Vector3
WindowedMean
Enums
Plane.PlaneSide


com.badlogic.gdx.math.collision (libgdx API)

 com.badlogic.gdx.math.collision
Classes
BoundingBox
Ray
Segment
Sphere


com.badlogic.gdx.physics.box2d (libgdx API)

 com.badlogic.gdx.physics.box2d
Interfaces
ContactFilter
ContactListener
DestructionListener
QueryCallback
Classes
Body
BodyDef
Box2DDebugRenderer
CircleShape
Contact
Filter
Fixture
FixtureDef
Joint
JointDef
JointEdge
MassData
PolygonShape
Shape
Transform
World
WorldManifold
Enums
BodyDef.BodyType
JointDef.JointType
Shape.Type


com.badlogic.gdx.physics.box2d.joints (libgdx API)

 com.badlogic.gdx.physics.box2d.joints
Classes
DistanceJoint
DistanceJointDef
FrictionJoint
FrictionJointDef
GearJoint
GearJointDef
LineJoint
LineJointDef
MouseJoint
MouseJointDef
PrismaticJoint
PrismaticJointDef
PulleyJoint
PulleyJointDef
RevoluteJoint
RevoluteJointDef
WeldJoint
WeldJointDef


com.badlogic.gdx.scenes.scene2d (libgdx API)

 com.badlogic.gdx.scenes.scene2d
Interfaces
Action
Classes
Actor
Group
Stage


com.badlogic.gdx.scenes.scene2d.actions (libgdx API)

 com.badlogic.gdx.scenes.scene2d.actions
Classes
Delay
FadeIn
FadeOut
FadeTo
Forever
MoveBy
MoveTo
Parallel
Repeat
RotateBy
RotateTo
ScaleTo
Sequence


com.badlogic.gdx.scenes.scene2d.actors (libgdx API)

 com.badlogic.gdx.scenes.scene2d.actors
Interfaces
Button.ClickListener
Classes
BoundGroup
Button
Image
Label
LinearGroup
Enums
LinearGroup.LinearGroupLayout


com.badlogic.gdx.twl (libgdx API)

 com.badlogic.gdx.twl
Classes
TWL


com.badlogic.gdx.utils (libgdx API)

 com.badlogic.gdx.utils
Interfaces
LocklessThreadQueue.ObjectFactory
Pool.PoolObjectFactory
Classes
AtomicQueue
BufferUtils
FloatArray
FloatBag
GdxNativesLoader
IntArray
IntBag
IntHashMap
IntHashMap.Entry
LittleEndianInputStream
LocklessThreadQueue
LongArray
LongBag
LongHashMap
LongHashMap.Entry
MathUtils
PauseableThread
Pool
PooledLinkedList
Exceptions
GdxRuntimeException


com.badlogic.gdx.utils.json (libgdx API)

 com.badlogic.gdx.utils.json
Interfaces
JSONString
Classes
JSONArray
JSONObject
JSONStringer
JSONTokener
JSONWriter
Exceptions
JSONException


com.badlogic.gdx (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx

Interface Summary
Application | An Application is the main entry point of your project.
ApplicationListener | An ApplicationListener is called when the Application is created, resumed, rendering, paused or destroyed.
Audio | This interface encapsulates the creation and management of audio resources.
Files | Provides standard access to the filesystem, classpath, Android SD card, and Android assets directory.
Graphics | This interface encapsulates the communication with the graphics processor.
Input | Interface to the input facilities.
Input.TextInputListener | Callback interface for Input.getTextInput(TextInputListener, String, String)
InputProcessor | An InputProcessor is used to receive input events from the keyboard and the touch screen (mouse on the desktop).
Screen | Represents one of many application screens, such as a main menu, a settings menu, the game screen and so on.

Class Summary
Game | An ApplicationListener that delegates to a Screen.
Gdx | Environment class holding references to the Application, Graphics, Audio, Files and Input instances.
Input.Keys | Keys.
InputAdapter | An adapter class for InputProcessor.
InputMultiplexer | An InputProcessor that delegates to an ordered list of other InputProcessors.
Version | The version of libgdx

Enum Summary
Application.ApplicationType | Enumeration of possible Application types
Files.FileType | Indicates how to resolve a path to a file.
Graphics.GraphicsType | Enumeration describing different types of Graphics implementations.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.audio (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.audio

Interface Summary
AudioDevice | Encapsulates an audio device in 44.1khz mono or stereo mode.
AudioRecorder | An AudioRecorder allows to record input from an audio device.
Music | A Music instance represents a streamed audio file.
Sound | A Sound is a short audio clip that can be played numerous times in parallel.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.audio.analysis (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.audio.analysis

Class Summary
AudioTools | Class holding various static native methods for processing audio data.
DFT | DFT stands for Discrete Fourier Transform and is the most widely used Fourier Transform.
FFT | FFT stands for Fast Fourier Transform.
FourierTransform | A Fourier Transform is an algorithm that transforms a signal in the time domain, such as a sample buffer, into a signal in the frequency domain, often called the spectrum.
KissFFT | A class for spectral analysis using native KissFFT
NativeFFT | A native implementation of the Fast Fourier Transform, directly ported from the FFT class.
ThresholdFunction | Calculates a threshold function based on the spectral flux.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.audio.io (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.audio.io

Interface Summary
Decoder Interface for audio decoders that return successive amplitude frames.

Class Summary
Mpg123Decoder | A Decoder implementation that decodes MP3 files via libmpg123 natively.
VorbisDecoder | A Decoder implementation that decodes OGG Vorbis files using tremor

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.backends.android (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.backends.android

Class Summary
AndroidApplication An implementation of the Application interface for Android.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.backends.jogl (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.backends.jogl

Class Summary
JoglApplication An implemenation of the Application interface based on Jogl for Windows, Linux and Mac.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.backends.lwjgl (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.backends.lwjgl

Class Summary
LwjglApplet | An OpenGL surface in an applet.
LwjglApplication | An OpenGL surface fullscreen or in a lightweight window.
LwjglCanvas | An OpenGL surface on an AWT Canvas, allowing OpenGL to be embedded in a Swing application.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.files (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.files

Class Summary
FileHandle | Represents a file or directory on the filesystem, classpath, Android SD card, or Android assets directory.
FileHandleStream | A FileHandle intended to be subclassed for the purpose of implemented FileHandleStream.read() and/or FileHandleStream.write(boolean).

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.graphics (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.graphics

Interface Summary
GL10 | Interface wrapping all standard OpenGL ES 1.0 methods.
GL11 | Interface wrapping all OpenGL ES 1.1 methods.
GL20 | Interface wrapping all the methods of OpenGL ES 2.0
GLCommon | This interface defines methods common to GL10, GL11 and GL20.
Pixmap | A Pixmap represents a platform specific bitmap.
Texture | A Texture wraps a standard OpenGL ES texture.
TextureData | Loads image data for a texture.

Class Summary
BitmapFont | Renders bitmap fonts.
BitmapFont.TextBounds |
BitmapFontCache | Caches glyph geometry for a BitmapFont, providing a fast way to render static text.
Color | A color class, holding the r, g, b and alpha component as floats in the range [0,1].
ImmediateModeRenderer | An ImmediateModeRenderer allows you to perform immediate mode rendering as you were accustomed to in your desktop OpenGL environment.
Mesh | A Mesh holds vertices composed of attributes specified by a VertexAttributes instance.
ModelLoader | A class for loading various model formats such as Wavefront OBJ.
OrthographicCamera | An orthographic camera having a position and a scale value for zooming.
PerspectiveCamera | A perspective camera, having a position, a direction an up vector, a near plane, a far plane and a field of view.
Sprite | Holds the geometry, color, and texture information for drawing 2D sprites using SpriteBatch.
SpriteBatch | A SpriteBatch is used to draw 2D rectangles that reference a texture (region).
SpriteCache | Draws 2D images, optimized for geometry that does not change.
TextureAtlas | Loads images from texture atlases created by TexturePacker. A TextureAtlas must be disposed to free up the resources consumed by the backing textures.
TextureAtlas.AtlasRegion | Describes the region of a packed image and provides extra information, such as the original image size before any whitespace was stripped.
TextureRegion | Defines a rectangular area of a texture.
VertexAttribute | A single vertex attribute defined by its VertexAttributes.Usage, its number of components and its shader alias.
VertexAttributes | Instances of this class specify the vertex attributes of a mesh.

Enum Summary
BitmapFont.HAlignment |
Mesh.VertexDataType |
OrthographicCamera.Side |
Pixmap.Format | Different pixel formats.
Texture.TextureFilter | Texture filter enum
Texture.TextureWrap | Texture wrap enum

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.graphics.glutils (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.graphics.glutils

Interface Summary
IndexData | An IndexData instance holds index data.
VertexData | A VertexData instance holds vertices for rendering with OpenGL.

Class Summary
FrameBuffer | Encapsulates OpenGL ES 2.0 frame buffer objects.
IndexBufferObject | In IndexBufferObject wraps OpenGL's index buffer functionality to be used in conjunction with VBOs.
IndexBufferObjectSubData | In IndexBufferObject wraps OpenGL's index buffer functionality to be used in conjunction with VBOs.
ShaderProgram | A shader program encapsulates a vertex and fragment shader pair linked to form a shader program useable with OpenGL ES 2.0.
VertexArray | Convenience class for working with OpenGL vertex arrays.
VertexBufferObject | A VertexData implementation based on OpenGL vertex buffer objects.
VertexBufferObjectSubData | A VertexData implementation based on OpenGL vertex buffer objects.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.graphics.loaders (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.graphics.loaders

Class Summary
ObjLoader Loads Wavefront OBJ files, ignores material files.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.graphics.loaders.md5 (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.graphics.loaders.md5

Class Summary
MD5Animation
MD5AnimationInfo
MD5Jni
MD5Joints
MD5Loader
MD5Mesh
MD5Model
MD5Quaternion
MD5Renderer

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.graphics.particles (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.graphics.particles

Class Summary
ParticleEffect
ParticleEmitter
ParticleEmitter.GradientColorValue
ParticleEmitter.NumericValue
ParticleEmitter.ParticleValue
ParticleEmitter.RangedNumericValue
ParticleEmitter.ScaledNumericValue
ParticleEmitter.SpawnShapeValue

Enum Summary
ParticleEmitter.SpawnEllipseSide
ParticleEmitter.SpawnShape

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.math (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.math

Class Summary
CatmullRomSpline | Encapsulates a catmull rom spline with n control points, n >= 4.
EarCutTriangulator | A simple implementation of the ear cutting algorithm to triangulate simple polygons without holes.
Frustum | Encapsulates a view frustum based on clipping planes.
Intersector | Class offering various static methods for intersection testing between different geometric objects.
Matrix3 | A 3x3 column major matrix for 2D transforms.
Matrix4 | Encapsulates a column major 4 by 4 matrix.
Plane | A plane defined via a unit length normal and the distance from the origin, as you learned in your math class.
Quaternion | A simple quaternion class.
Rectangle | Encapsulates a 2D rectangle defined by it's bottom corner point and its extends in x (width) and y (height).
Vector2 | Encapsulates a 2D vector.
Vector3 | Encapsulates a 3D vector.
WindowedMean | A simple class keeping track of the mean of a stream of values within a certain window.

Enum Summary
Plane.PlaneSide Enum specifying on which side a point lies respective to the plane and it's normal.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.math.collision (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.math.collision

Class Summary
BoundingBox | Encapsulates an axis aligned bounding box represented by a minimum and a maximum Vector.
Ray | Encapsulates a ray having a starting position and a unit length direction.
Segment | A Segment is a line in 3-space having a staring and an ending position.
Sphere | Encapsulates a 3D sphere with a center and a radius

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.physics.box2d (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.physics.box2d

Interface Summary
ContactFilter | Implement this class to provide collision filtering.
ContactListener |
DestructionListener |
QueryCallback | Callback class for AABB queries.

Class Summary
Body | A rigid body.
BodyDef | A body definition holds all the data needed to construct a rigid body.
Box2DDebugRenderer |
CircleShape | A circle shape.
Contact | The class manages contact between two shapes.
Filter | This holds contact filtering data.
Fixture |
FixtureDef | A fixture definition is used to create a fixture.
Joint |
JointDef |
JointEdge | A joint edge is used to connect bodies and joints together in a joint graph where each body is a node and each joint is an edge.
MassData | This holds the mass data computed for a shape.
PolygonShape |
Shape | A shape is used for collision detection.
Transform | Encodes a Box2D transform.
World | The world class manages all physics entities, dynamic simulation, and asynchronous queries.
WorldManifold | This is used to compute the current state of a contact manifold.

Enum Summary
BodyDef.BodyType | The body type.
JointDef.JointType |
Shape.Type | Enum describing the type of a shape

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.physics.box2d.joints (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.physics.box2d.joints

Class Summary
DistanceJoint | A distance joint constrains two points on two bodies to remain at a fixed distance from each other.
DistanceJointDef | Distance joint definition.
FrictionJoint | Friction joint.
FrictionJointDef | Friction joint definition.
GearJoint | A gear joint is used to connect two joints together.
GearJointDef | Gear joint definition.
LineJoint | A line joint.
LineJointDef | Line joint definition.
MouseJoint | A mouse joint is used to make a point on a body track a specified world point.
MouseJointDef | Mouse joint definition.
PrismaticJoint | A prismatic joint.
PrismaticJointDef | Prismatic joint definition.
PulleyJoint | The pulley joint is connected to two bodies and two fixed ground points.
PulleyJointDef | Pulley joint definition.
RevoluteJoint | A revolute joint constrains two bodies to share a common point while they are free to rotate about the point.
RevoluteJointDef | Revolute joint definition.
WeldJoint | A weld joint essentially glues two bodies together.
WeldJointDef |

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.scenes.scene2d (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.scenes.scene2d

Interface Summary
Action An Action is used with an Actor and modifes the Actor's attributes over time.

Class Summary
Actor | An Actor is part of a Stage or a Group within a Stage.
Group | A group is an Actor that contains other Actors (also other Groups which are Actors).
Stage | A Stage is a container for Actors and handles distributing touch events, animating Actors and asking them to render themselves.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.scenes.scene2d.actions (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.scenes.scene2d.actions

Class Summary
Delay
FadeIn
FadeOut
FadeTo
Forever
MoveBy
MoveTo
Parallel
Repeat
RotateBy
RotateTo
ScaleTo
Sequence

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.scenes.scene2d.actors (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.scenes.scene2d.actors

Interface Summary
Button.ClickListener

Class Summary
BoundGroup | This is a group that respects its width and height.
Button | A simple Button Actor, useful for simple UIs
Image |
Label |
LinearGroup |

Enum Summary
LinearGroup.LinearGroupLayout

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.twl (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.twl

Class Summary
TWL Convenience class for using TWL.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.utils (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.utils

Interface Summary
LocklessThreadQueue.ObjectFactory<T> | Interface for an Object Factory for the initial buffer creation.
Pool.PoolObjectFactory<T> | Interface for an Object Factory to be used with this Pool

Class Summary
AtomicQueue<T> |
BufferUtils | Class with static helper methods to increase the speed of array/direct buffer and direct buffer/direct buffer transfers
FloatArray | An ordered, resizable float array.
FloatBag | An unordered, resizable int array.
GdxNativesLoader |
IntArray | An ordered, resizable int array.
IntBag | An unordered, resizable int array.
IntHashMap<T> | An unordered map that uses int keys.
IntHashMap.Entry<T> | An entry in the map.
LittleEndianInputStream | Taken from http://www.javafaq.nu/java-example-code-1079.html
LocklessThreadQueue<T> | A specialized lockless thread queue class template for doing single direction message passing from one thread to another.
LongArray | An ordered, resizable long array.
LongBag | An unordered, resizable long array.
LongHashMap<T> | An unordered map that uses long keys.
LongHashMap.Entry<T> | An entry in the map.
MathUtils | Utility and fast math functions.
PauseableThread | A pausable thread.
Pool<T> | A pool implementation used for object instances that should get reused instead of being collected by the garbage collector.
PooledLinkedList<T> | A simple linked list that pools its nodes.

Exception Summary
GdxRuntimeException Typed runtime exception used throughout libgdx

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.utils.json (libgdx API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.badlogic.gdx.utils.json

Interface Summary
JSONString The JSONString interface allows a toJSONString() method so that a class can change the behavior of JSONObject.toString(), JSONArray.toString(), and JSONWriter.value(Object).

Class Summary
JSONArray | A JSONArray is an ordered sequence of values.
JSONObject | A JSONObject is an unordered collection of name/value pairs.
JSONStringer | JSONStringer provides a quick and convenient way of producing JSON text.
JSONTokener | A JSONTokener takes a source string and extracts characters and tokens from it.
JSONWriter | JSONWriter provides a quick and convenient way of producing JSON text.

Exception Summary
JSONException The JSONException is thrown by the JSON.org classes when things are amiss.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.badlogic.gdx.scenes.scene2d Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.scenes.scene2d

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.scenes.scene2d.Actor
      • com.badlogic.gdx.scenes.scene2d.Group
    • com.badlogic.gdx.InputAdapter (implements com.badlogic.gdx.InputProcessor)
      • com.badlogic.gdx.scenes.scene2d.Stage

Interface Hierarchy

  • com.badlogic.gdx.scenes.scene2d.Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.Game (implements com.badlogic.gdx.ApplicationListener)
    • com.badlogic.gdx.Gdx
    • com.badlogic.gdx.Input.Keys
    • com.badlogic.gdx.InputAdapter (implements com.badlogic.gdx.InputProcessor)
    • com.badlogic.gdx.InputMultiplexer (implements com.badlogic.gdx.InputProcessor)
    • com.badlogic.gdx.Version

Interface Hierarchy

  • com.badlogic.gdx.Application
  • com.badlogic.gdx.ApplicationListener
  • com.badlogic.gdx.Audio
  • com.badlogic.gdx.Files
  • com.badlogic.gdx.Graphics
  • com.badlogic.gdx.Input
  • com.badlogic.gdx.Input.TextInputListener
  • com.badlogic.gdx.InputProcessor
  • com.badlogic.gdx.Screen

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.badlogic.gdx.Files.FileType
      • com.badlogic.gdx.Graphics.GraphicsType
      • com.badlogic.gdx.Application.ApplicationType
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.backends.android Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.backends.android

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • Activity
      • com.badlogic.gdx.backends.android.AndroidApplication (implements com.badlogic.gdx.Application)
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.utils Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.utils

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.utils.AtomicQueue<T>
    • com.badlogic.gdx.utils.BufferUtils
    • com.badlogic.gdx.utils.FloatArray
    • com.badlogic.gdx.utils.FloatBag
    • com.badlogic.gdx.utils.GdxNativesLoader
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • com.badlogic.gdx.utils.LittleEndianInputStream
    • com.badlogic.gdx.utils.IntArray
    • com.badlogic.gdx.utils.IntBag
    • com.badlogic.gdx.utils.IntHashMap<T>
    • com.badlogic.gdx.utils.IntHashMap.Entry<T>
    • com.badlogic.gdx.utils.LocklessThreadQueue<T>
    • com.badlogic.gdx.utils.LongArray
    • com.badlogic.gdx.utils.LongBag
    • com.badlogic.gdx.utils.LongHashMap<T>
    • com.badlogic.gdx.utils.LongHashMap.Entry<T>
    • com.badlogic.gdx.utils.MathUtils
    • com.badlogic.gdx.utils.Pool<T>
    • com.badlogic.gdx.utils.PooledLinkedList<T>
    • java.lang.Thread (implements java.lang.Runnable)
      • com.badlogic.gdx.utils.PauseableThread
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.badlogic.gdx.utils.GdxRuntimeException

Interface Hierarchy

  • com.badlogic.gdx.utils.LocklessThreadQueue.ObjectFactory<T>
  • com.badlogic.gdx.utils.Pool.PoolObjectFactory<T>
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.audio Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.audio

Package Hierarchies:
All Packages

Interface Hierarchy

  • com.badlogic.gdx.audio.AudioDevice
  • com.badlogic.gdx.audio.AudioRecorder
  • com.badlogic.gdx.audio.Music
  • com.badlogic.gdx.audio.Sound
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.audio.analysis Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.audio.analysis

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.audio.analysis.AudioTools
    • com.badlogic.gdx.audio.analysis.FourierTransform
      • com.badlogic.gdx.audio.analysis.DFT
      • com.badlogic.gdx.audio.analysis.FFT
    • com.badlogic.gdx.audio.analysis.KissFFT
    • com.badlogic.gdx.audio.analysis.NativeFFT
    • com.badlogic.gdx.audio.analysis.ThresholdFunction
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.graphics Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.graphics

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.graphics.BitmapFont
    • com.badlogic.gdx.graphics.BitmapFont.TextBounds
    • com.badlogic.gdx.graphics.BitmapFontCache
    • com.badlogic.gdx.graphics.Color
    • com.badlogic.gdx.graphics.ImmediateModeRenderer
    • com.badlogic.gdx.graphics.Mesh
    • com.badlogic.gdx.graphics.ModelLoader
    • com.badlogic.gdx.graphics.OrthographicCamera
    • com.badlogic.gdx.graphics.PerspectiveCamera
    • com.badlogic.gdx.graphics.SpriteBatch
    • com.badlogic.gdx.graphics.SpriteCache
    • com.badlogic.gdx.graphics.TextureAtlas
    • com.badlogic.gdx.graphics.TextureRegion
      • com.badlogic.gdx.graphics.Sprite
      • com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
    • com.badlogic.gdx.graphics.VertexAttribute
    • com.badlogic.gdx.graphics.VertexAttributes
    • com.badlogic.gdx.graphics.VertexAttributes.Usage

Interface Hierarchy

  • com.badlogic.gdx.graphics.GLCommon
    • com.badlogic.gdx.graphics.GL10
      • com.badlogic.gdx.graphics.GL11
    • com.badlogic.gdx.graphics.GL20
  • com.badlogic.gdx.graphics.Pixmap
  • com.badlogic.gdx.graphics.Texture
  • com.badlogic.gdx.graphics.TextureData

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.badlogic.gdx.graphics.Texture.TextureWrap
      • com.badlogic.gdx.graphics.BitmapFont.HAlignment
      • com.badlogic.gdx.graphics.Mesh.VertexDataType
      • com.badlogic.gdx.graphics.OrthographicCamera.Side
      • com.badlogic.gdx.graphics.Texture.TextureFilter
      • com.badlogic.gdx.graphics.Pixmap.Format
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.physics.box2d Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.physics.box2d

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.physics.box2d.Body
    • com.badlogic.gdx.physics.box2d.BodyDef
    • com.badlogic.gdx.physics.box2d.Box2DDebugRenderer
    • com.badlogic.gdx.physics.box2d.Contact
    • com.badlogic.gdx.physics.box2d.Filter
    • com.badlogic.gdx.physics.box2d.Fixture
    • com.badlogic.gdx.physics.box2d.FixtureDef
    • com.badlogic.gdx.physics.box2d.Joint
    • com.badlogic.gdx.physics.box2d.JointDef
    • com.badlogic.gdx.physics.box2d.JointEdge
    • com.badlogic.gdx.physics.box2d.MassData
    • com.badlogic.gdx.physics.box2d.Shape
      • com.badlogic.gdx.physics.box2d.CircleShape
      • com.badlogic.gdx.physics.box2d.PolygonShape
    • com.badlogic.gdx.physics.box2d.Transform
    • com.badlogic.gdx.physics.box2d.World
    • com.badlogic.gdx.physics.box2d.WorldManifold

Interface Hierarchy

  • com.badlogic.gdx.physics.box2d.ContactFilter
  • com.badlogic.gdx.physics.box2d.ContactListener
  • com.badlogic.gdx.physics.box2d.DestructionListener
  • com.badlogic.gdx.physics.box2d.QueryCallback

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.badlogic.gdx.physics.box2d.JointDef.JointType
      • com.badlogic.gdx.physics.box2d.Shape.Type
      • com.badlogic.gdx.physics.box2d.BodyDef.BodyType
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.scenes.scene2d.actors Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.scenes.scene2d.actors

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.scenes.scene2d.Actor
      • com.badlogic.gdx.scenes.scene2d.actors.Button
      • com.badlogic.gdx.scenes.scene2d.Group
        • com.badlogic.gdx.scenes.scene2d.actors.BoundGroup
          • com.badlogic.gdx.scenes.scene2d.actors.LinearGroup
      • com.badlogic.gdx.scenes.scene2d.actors.Image
      • com.badlogic.gdx.scenes.scene2d.actors.Label

Interface Hierarchy

  • com.badlogic.gdx.scenes.scene2d.actors.Button.ClickListener

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.badlogic.gdx.scenes.scene2d.actors.LinearGroup.LinearGroupLayout
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.math.collision Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.math.collision

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.math.collision.BoundingBox
    • com.badlogic.gdx.math.collision.Ray
    • com.badlogic.gdx.math.collision.Segment
    • com.badlogic.gdx.math.collision.Sphere
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.math Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.math

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.math.CatmullRomSpline
    • com.badlogic.gdx.math.EarCutTriangulator
    • com.badlogic.gdx.math.Frustum
    • com.badlogic.gdx.math.Intersector
    • com.badlogic.gdx.math.Matrix3
    • com.badlogic.gdx.math.Matrix4
    • com.badlogic.gdx.math.Plane
    • com.badlogic.gdx.math.Quaternion (implements java.io.Serializable)
    • com.badlogic.gdx.math.Rectangle
    • com.badlogic.gdx.math.Vector2
    • com.badlogic.gdx.math.Vector3
    • com.badlogic.gdx.math.WindowedMean

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.badlogic.gdx.math.Plane.PlaneSide
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.audio.io Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.audio.io

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.audio.io.Mpg123Decoder (implements com.badlogic.gdx.audio.io.Decoder)
    • com.badlogic.gdx.audio.io.VorbisDecoder (implements com.badlogic.gdx.audio.io.Decoder)

Interface Hierarchy

  • com.badlogic.gdx.audio.io.Decoder
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.scenes.scene2d.actions Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.scenes.scene2d.actions

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.scenes.scene2d.actions.Delay (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.FadeIn (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.FadeOut (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.FadeTo (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.Forever (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.MoveBy (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.MoveTo (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.Parallel (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.Repeat (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.RotateBy (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.RotateTo (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.ScaleTo (implements com.badlogic.gdx.scenes.scene2d.Action)
    • com.badlogic.gdx.scenes.scene2d.actions.Sequence (implements com.badlogic.gdx.scenes.scene2d.Action)
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.physics.box2d.joints Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.physics.box2d.joints

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.physics.box2d.Joint
      • com.badlogic.gdx.physics.box2d.joints.DistanceJoint
      • com.badlogic.gdx.physics.box2d.joints.FrictionJoint
      • com.badlogic.gdx.physics.box2d.joints.GearJoint
      • com.badlogic.gdx.physics.box2d.joints.LineJoint
      • com.badlogic.gdx.physics.box2d.joints.MouseJoint
      • com.badlogic.gdx.physics.box2d.joints.PrismaticJoint
      • com.badlogic.gdx.physics.box2d.joints.PulleyJoint
      • com.badlogic.gdx.physics.box2d.joints.RevoluteJoint
      • com.badlogic.gdx.physics.box2d.joints.WeldJoint
    • com.badlogic.gdx.physics.box2d.JointDef
      • com.badlogic.gdx.physics.box2d.joints.DistanceJointDef
      • com.badlogic.gdx.physics.box2d.joints.FrictionJointDef
      • com.badlogic.gdx.physics.box2d.joints.GearJointDef
      • com.badlogic.gdx.physics.box2d.joints.LineJointDef
      • com.badlogic.gdx.physics.box2d.joints.MouseJointDef
      • com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef
      • com.badlogic.gdx.physics.box2d.joints.PulleyJointDef
      • com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef
      • com.badlogic.gdx.physics.box2d.joints.WeldJointDef
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.files Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.files

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.files.FileHandle
      • com.badlogic.gdx.files.FileHandleStream
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.graphics.glutils Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.graphics.glutils

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.graphics.glutils.FrameBuffer
    • com.badlogic.gdx.graphics.glutils.IndexBufferObject (implements com.badlogic.gdx.graphics.glutils.IndexData)
    • com.badlogic.gdx.graphics.glutils.IndexBufferObjectSubData (implements com.badlogic.gdx.graphics.glutils.IndexData)
    • com.badlogic.gdx.graphics.glutils.ShaderProgram
    • com.badlogic.gdx.graphics.glutils.VertexArray (implements com.badlogic.gdx.graphics.glutils.VertexData)
    • com.badlogic.gdx.graphics.glutils.VertexBufferObject (implements com.badlogic.gdx.graphics.glutils.VertexData)
    • com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData (implements com.badlogic.gdx.graphics.glutils.VertexData)

Interface Hierarchy

  • com.badlogic.gdx.graphics.glutils.IndexData
  • com.badlogic.gdx.graphics.glutils.VertexData
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.backends.jogl Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.backends.jogl

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.backends.jogl.JoglApplication (implements com.badlogic.gdx.Application)
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.utils.json Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.utils.json

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.utils.json.JSONArray
    • com.badlogic.gdx.utils.json.JSONObject
    • com.badlogic.gdx.utils.json.JSONTokener
    • com.badlogic.gdx.utils.json.JSONWriter
      • com.badlogic.gdx.utils.json.JSONStringer
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.badlogic.gdx.utils.json.JSONException

Interface Hierarchy

  • com.badlogic.gdx.utils.json.JSONString
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.backends.lwjgl Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.backends.lwjgl

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet
            • com.badlogic.gdx.backends.lwjgl.LwjglApplet
    • com.badlogic.gdx.backends.lwjgl.LwjglApplication (implements com.badlogic.gdx.Application)
    • com.badlogic.gdx.backends.lwjgl.LwjglCanvas (implements com.badlogic.gdx.Application)
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.graphics.loaders.md5 Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.graphics.loaders.md5

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.graphics.loaders.md5.MD5Animation
    • com.badlogic.gdx.graphics.loaders.md5.MD5AnimationInfo
    • com.badlogic.gdx.graphics.loaders.md5.MD5Jni
    • com.badlogic.gdx.graphics.loaders.md5.MD5Joints
    • com.badlogic.gdx.graphics.loaders.md5.MD5Loader
    • com.badlogic.gdx.graphics.loaders.md5.MD5Mesh
    • com.badlogic.gdx.graphics.loaders.md5.MD5Model
    • com.badlogic.gdx.graphics.loaders.md5.MD5Quaternion
    • com.badlogic.gdx.graphics.loaders.md5.MD5Renderer
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.graphics.loaders Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.graphics.loaders

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.graphics.loaders.ObjLoader
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.graphics.particles Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.graphics.particles

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.graphics.particles.ParticleEffect
    • com.badlogic.gdx.graphics.particles.ParticleEmitter
    • com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
        • com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnEllipseSide
      • com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShape
Overview Package Class Use Tree Deprecated Index Help
libgdx API


com.badlogic.gdx.twl Class Hierarchy (libgdx API)

Hierarchy For Package com.badlogic.gdx.twl

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.badlogic.gdx.twl.TWL (implements com.badlogic.gdx.InputProcessor)
Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.audio (libgdx API)

Uses of Package
com.badlogic.gdx.audio

Packages that use com.badlogic.gdx.audio
com.badlogic.gdx

Classes in com.badlogic.gdx.audio used by com.badlogic.gdx
AudioDevice
Encapsulates an audio device in 44.1khz mono or stereo mode.
AudioRecorder
An AudioRecorder allows to record input from an audio device.
Music
A Music instance represents a streamed audio file.
Sound
A Sound is a short audio clip that can be played numerous times in parallel.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx (libgdx API)

Uses of Package
com.badlogic.gdx

Packages that use com.badlogic.gdx
com.badlogic.gdx
com.badlogic.gdx.backends.android
com.badlogic.gdx.backends.jogl
com.badlogic.gdx.backends.lwjgl
com.badlogic.gdx.files
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.twl

Classes in com.badlogic.gdx used by com.badlogic.gdx
Application
An Application is the main entry point of your project.
Application.ApplicationType
Enumeration of possible Application types
ApplicationListener
An ApplicationListener is called when the Application is created, resumed, rendering, paused or destroyed.
Audio
This interface encapsulates the creation and management of audio resources.
Files
Provides standard access to the filesystem, classpath, Android SD card, and Android assets directory.
Files.FileType
Indicates how to resolve a path to a file.
Graphics
This interface encapsulates the communication with the graphics processor.
Graphics.GraphicsType
Enumeration describing different types of Graphics implementations.
Input
Interface to the input facilities.
Input.TextInputListener
Callback interface for Input.getTextInput(TextInputListener, String, String)
InputProcessor
An InputProcessor is used to receive input events from the keyboard and the touch screen (mouse on the desktop).
Screen
Represents one of many application screens, such as a main menu, a settings menu, the game screen and so on.

Classes in com.badlogic.gdx used by com.badlogic.gdx.backends.android
Application
An Application is the main entry point of your project.
Application.ApplicationType
Enumeration of possible Application types
ApplicationListener
An ApplicationListener is called when the Application is created, resumed, rendering, paused or destroyed.
Audio
This interface encapsulates the creation and management of audio resources.
Files
Provides standard access to the filesystem, classpath, Android SD card, and Android assets directory.
Graphics
This interface encapsulates the communication with the graphics processor.
Input
Interface to the input facilities.

Classes in com.badlogic.gdx used by com.badlogic.gdx.backends.jogl
Application
An Application is the main entry point of your project.
Application.ApplicationType
Enumeration of possible Application types
ApplicationListener
An ApplicationListener is called when the Application is created, resumed, rendering, paused or destroyed.
Audio
This interface encapsulates the creation and management of audio resources.
Files
Provides standard access to the filesystem, classpath, Android SD card, and Android assets directory.
Graphics
This interface encapsulates the communication with the graphics processor.
Input
Interface to the input facilities.

Classes in com.badlogic.gdx used by com.badlogic.gdx.backends.lwjgl
Application
An Application is the main entry point of your project.
Application.ApplicationType
Enumeration of possible Application types
ApplicationListener
An ApplicationListener is called when the Application is created, resumed, rendering, paused or destroyed.
Audio
This interface encapsulates the creation and management of audio resources.
Files
Provides standard access to the filesystem, classpath, Android SD card, and Android assets directory.
Graphics
This interface encapsulates the communication with the graphics processor.
Input
Interface to the input facilities.

Classes in com.badlogic.gdx used by com.badlogic.gdx.files
Files.FileType
Indicates how to resolve a path to a file.

Classes in com.badlogic.gdx used by com.badlogic.gdx.scenes.scene2d
InputAdapter
An adapter class for InputProcessor.
InputProcessor
An InputProcessor is used to receive input events from the keyboard and the touch screen (mouse on the desktop).

Classes in com.badlogic.gdx used by com.badlogic.gdx.twl
Files.FileType
Indicates how to resolve a path to a file.
InputProcessor
An InputProcessor is used to receive input events from the keyboard and the touch screen (mouse on the desktop).

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.audio.analysis (libgdx API)

Uses of Package
com.badlogic.gdx.audio.analysis

Packages that use com.badlogic.gdx.audio.analysis
com.badlogic.gdx.audio.analysis

Classes in com.badlogic.gdx.audio.analysis used by com.badlogic.gdx.audio.analysis
FourierTransform
A Fourier Transform is an algorithm that transforms a signal in the time domain, such as a sample buffer, into a signal in the frequency domain, often called the spectrum.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.audio.io (libgdx API)

Uses of Package
com.badlogic.gdx.audio.io

Packages that use com.badlogic.gdx.audio.io
com.badlogic.gdx.audio.io

Classes in com.badlogic.gdx.audio.io used by com.badlogic.gdx.audio.io
Decoder
Interface for audio decoders that return successive amplitude frames.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.backends.android (libgdx API)

Uses of Package
com.badlogic.gdx.backends.android

No usage of com.badlogic.gdx.backends.android

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.backends.jogl (libgdx API)

Uses of Package
com.badlogic.gdx.backends.jogl

No usage of com.badlogic.gdx.backends.jogl

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.files (libgdx API)

Uses of Package
com.badlogic.gdx.files

Packages that use com.badlogic.gdx.files
com.badlogic.gdx
com.badlogic.gdx.files
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.particles

Classes in com.badlogic.gdx.files used by com.badlogic.gdx
FileHandle
Represents a file or directory on the filesystem, classpath, Android SD card, or Android assets directory.

Classes in com.badlogic.gdx.files used by com.badlogic.gdx.files
FileHandle
Represents a file or directory on the filesystem, classpath, Android SD card, or Android assets directory.

Classes in com.badlogic.gdx.files used by com.badlogic.gdx.graphics
FileHandle
Represents a file or directory on the filesystem, classpath, Android SD card, or Android assets directory.

Classes in com.badlogic.gdx.files used by com.badlogic.gdx.graphics.particles
FileHandle
Represents a file or directory on the filesystem, classpath, Android SD card, or Android assets directory.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.backends.lwjgl (libgdx API)

Uses of Package
com.badlogic.gdx.backends.lwjgl

No usage of com.badlogic.gdx.backends.lwjgl

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.graphics (libgdx API)

Uses of Package
com.badlogic.gdx.graphics

Packages that use com.badlogic.gdx.graphics
com.badlogic.gdx
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils
com.badlogic.gdx.graphics.loaders
com.badlogic.gdx.graphics.particles
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actors

Classes in com.badlogic.gdx.graphics used by com.badlogic.gdx
GL10
Interface wrapping all standard OpenGL ES 1.0 methods.
GL11
Interface wrapping all OpenGL ES 1.1 methods.
GL20
Interface wrapping all the methods of OpenGL ES 2.0
GLCommon
This interface defines methods common to GL10, GL11 and GL20.
Pixmap
A Pixmap represents a platform specific bitmap.
Pixmap.Format
Different pixel formats.
Texture
A Texture wraps a standard OpenGL ES texture.
Texture.TextureFilter
Texture filter enum
Texture.TextureWrap
Texture wrap enum
TextureData
Loads image data for a texture.

Classes in com.badlogic.gdx.graphics used by com.badlogic.gdx.graphics
BitmapFont
Renders bitmap fonts.
BitmapFont.HAlignment
BitmapFont.TextBounds
Color
A color class, holding the r, g, b and alpha component as floats in the range [0,1].
GL10
Interface wrapping all standard OpenGL ES 1.0 methods.
GLCommon
This interface defines methods common to GL10, GL11 and GL20.
Mesh
A Mesh holds vertices composed of attributes specified by a VertexAttributes instance.
Mesh.VertexDataType
OrthographicCamera.Side
Pixmap
A Pixmap represents a platform specific bitmap.
Pixmap.Format
Different pixel formats.
Sprite
Holds the geometry, color, and texture information for drawing 2D sprites using SpriteBatch.
SpriteBatch
A SpriteBatch is used to draw 2D rectangles that reference a texture (region).
Texture
A Texture wraps a standard OpenGL ES texture.
Texture.TextureFilter
Texture filter enum
Texture.TextureWrap
Texture wrap enum
TextureAtlas.AtlasRegion
Describes the region of a packed image and provides extra information, such as the original image size before any whitespace was stripped.
TextureRegion
Defines a rectangular area of a texture.
VertexAttribute
A single vertex attribute defined by its VertexAttributes.Usage, its number of components and its shader alias.
VertexAttributes
Instances of this class specify the vertex attributes of a mesh.

Classes in com.badlogic.gdx.graphics used by com.badlogic.gdx.graphics.glutils
Pixmap.Format
Different pixel formats.
Texture
A Texture wraps a standard OpenGL ES texture.
VertexAttribute
A single vertex attribute defined by its VertexAttributes.Usage, its number of components and its shader alias.
VertexAttributes
Instances of this class specify the vertex attributes of a mesh.

Classes in com.badlogic.gdx.graphics used by com.badlogic.gdx.graphics.loaders
Mesh
A Mesh holds vertices composed of attributes specified by a VertexAttributes instance.

Classes in com.badlogic.gdx.graphics used by com.badlogic.gdx.graphics.particles
Sprite
Holds the geometry, color, and texture information for drawing 2D sprites using SpriteBatch.
SpriteBatch
A SpriteBatch is used to draw 2D rectangles that reference a texture (region).
Texture
A Texture wraps a standard OpenGL ES texture.
TextureAtlas
Loads images from texture atlases created by TexturePacker.

A TextureAtlas must be disposed to free up the resources consumed by the backing textures.

Classes in com.badlogic.gdx.graphics used by com.badlogic.gdx.physics.box2d
ImmediateModeRenderer
An ImmediateModeRenderer allows you to perform immediate mode rendering as you were accustomed to in your desktop OpenGL environment.
SpriteBatch
A SpriteBatch is used to draw 2D rectangles that reference a texture (region).

Classes in com.badlogic.gdx.graphics used by com.badlogic.gdx.scenes.scene2d
Color
A color class, holding the r, g, b and alpha component as floats in the range [0,1].
SpriteBatch
A SpriteBatch is used to draw 2D rectangles that reference a texture (region).
Texture
A Texture wraps a standard OpenGL ES texture.

Classes in com.badlogic.gdx.graphics used by com.badlogic.gdx.scenes.scene2d.actors
SpriteBatch
A SpriteBatch is used to draw 2D rectangles that reference a texture (region).
Texture
A Texture wraps a standard OpenGL ES texture.
TextureRegion
Defines a rectangular area of a texture.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.graphics.glutils (libgdx API)

Uses of Package
com.badlogic.gdx.graphics.glutils

Packages that use com.badlogic.gdx.graphics.glutils
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils

Classes in com.badlogic.gdx.graphics.glutils used by com.badlogic.gdx.graphics
ShaderProgram
A shader program encapsulates a vertex and fragment shader pair linked to form a shader program useable with OpenGL ES 2.0.

Classes in com.badlogic.gdx.graphics.glutils used by com.badlogic.gdx.graphics.glutils
IndexData
An IndexData instance holds index data.
ShaderProgram
A shader program encapsulates a vertex and fragment shader pair linked to form a shader program useable with OpenGL ES 2.0.
VertexData
A VertexData instance holds vertices for rendering with OpenGL.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.graphics.loaders (libgdx API)

Uses of Package
com.badlogic.gdx.graphics.loaders

No usage of com.badlogic.gdx.graphics.loaders

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.graphics.loaders.md5 (libgdx API)

Uses of Package
com.badlogic.gdx.graphics.loaders.md5

Packages that use com.badlogic.gdx.graphics.loaders.md5
com.badlogic.gdx.graphics.loaders.md5

Classes in com.badlogic.gdx.graphics.loaders.md5 used by com.badlogic.gdx.graphics.loaders.md5
MD5Animation
MD5Joints
MD5Mesh
MD5Model
MD5Quaternion

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.math (libgdx API)

Uses of Package
com.badlogic.gdx.math

Packages that use com.badlogic.gdx.math
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils
com.badlogic.gdx.graphics.loaders.md5
com.badlogic.gdx.math
com.badlogic.gdx.math.collision
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints
com.badlogic.gdx.scenes.scene2d

Classes in com.badlogic.gdx.math used by com.badlogic.gdx.graphics
Frustum
Encapsulates a view frustum based on clipping planes.
Matrix4
Encapsulates a column major 4 by 4 matrix.
Vector2
Encapsulates a 2D vector.
Vector3
Encapsulates a 3D vector.

Classes in com.badlogic.gdx.math used by com.badlogic.gdx.graphics.glutils
Matrix4
Encapsulates a column major 4 by 4 matrix.

Classes in com.badlogic.gdx.math used by com.badlogic.gdx.graphics.loaders.md5
Vector3
Encapsulates a 3D vector.

Classes in com.badlogic.gdx.math used by com.badlogic.gdx.math
Matrix3
A 3x3 column major matrix for 2D transforms.
Matrix4
Encapsulates a column major 4 by 4 matrix.
Plane
A plane defined via a unit length normal and the distance from the origin, as you learned in your math class.
Plane.PlaneSide
Enum specifying on which side a point lies respective to the plane and it's normal.
Quaternion
A simple quaternion class.
Rectangle
Encapsulates a 2D rectangle defined by it's bottom corner point and its extends in x (width) and y (height).
Vector2
Encapsulates a 2D vector.
Vector3
Encapsulates a 3D vector.

Classes in com.badlogic.gdx.math used by com.badlogic.gdx.math.collision
Matrix4
Encapsulates a column major 4 by 4 matrix.
Vector3
Encapsulates a 3D vector.

Classes in com.badlogic.gdx.math used by com.badlogic.gdx.physics.box2d
Vector2
Encapsulates a 2D vector.

Classes in com.badlogic.gdx.math used by com.badlogic.gdx.physics.box2d.joints
Vector2
Encapsulates a 2D vector.

Classes in com.badlogic.gdx.math used by com.badlogic.gdx.scenes.scene2d
Matrix3
A 3x3 column major matrix for 2D transforms.
Matrix4
Encapsulates a column major 4 by 4 matrix.
Vector2
Encapsulates a 2D vector.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.math.collision (libgdx API)

Uses of Package
com.badlogic.gdx.math.collision

Packages that use com.badlogic.gdx.math.collision
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.loaders.md5
com.badlogic.gdx.math
com.badlogic.gdx.math.collision

Classes in com.badlogic.gdx.math.collision used by com.badlogic.gdx.graphics
Ray
Encapsulates a ray having a starting position and a unit length direction.

Classes in com.badlogic.gdx.math.collision used by com.badlogic.gdx.graphics.loaders.md5
BoundingBox
Encapsulates an axis aligned bounding box represented by a minimum and a maximum Vector.

Classes in com.badlogic.gdx.math.collision used by com.badlogic.gdx.math
BoundingBox
Encapsulates an axis aligned bounding box represented by a minimum and a maximum Vector.
Ray
Encapsulates a ray having a starting position and a unit length direction.

Classes in com.badlogic.gdx.math.collision used by com.badlogic.gdx.math.collision
BoundingBox
Encapsulates an axis aligned bounding box represented by a minimum and a maximum Vector.
Ray
Encapsulates a ray having a starting position and a unit length direction.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.graphics.particles (libgdx API)

Uses of Package
com.badlogic.gdx.graphics.particles

Packages that use com.badlogic.gdx.graphics.particles
com.badlogic.gdx.graphics.particles

Classes in com.badlogic.gdx.graphics.particles used by com.badlogic.gdx.graphics.particles
ParticleEmitter
ParticleEmitter.GradientColorValue
ParticleEmitter.NumericValue
ParticleEmitter.ParticleValue
ParticleEmitter.RangedNumericValue
ParticleEmitter.ScaledNumericValue
ParticleEmitter.SpawnEllipseSide
ParticleEmitter.SpawnShape
ParticleEmitter.SpawnShapeValue

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.physics.box2d.joints (libgdx API)

Uses of Package
com.badlogic.gdx.physics.box2d.joints

No usage of com.badlogic.gdx.physics.box2d.joints

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.scenes.scene2d (libgdx API)

Uses of Package
com.badlogic.gdx.scenes.scene2d

Packages that use com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actions
com.badlogic.gdx.scenes.scene2d.actors

Classes in com.badlogic.gdx.scenes.scene2d used by com.badlogic.gdx.scenes.scene2d
Action
An Action is used with an Actor and modifes the Actor's attributes over time.
Actor
An Actor is part of a Stage or a Group within a Stage.
Group
A group is an Actor that contains other Actors (also other Groups which are Actors).

Classes in com.badlogic.gdx.scenes.scene2d used by com.badlogic.gdx.scenes.scene2d.actions
Action
An Action is used with an Actor and modifes the Actor's attributes over time.
Actor
An Actor is part of a Stage or a Group within a Stage.

Classes in com.badlogic.gdx.scenes.scene2d used by com.badlogic.gdx.scenes.scene2d.actors
Actor
An Actor is part of a Stage or a Group within a Stage.
Group
A group is an Actor that contains other Actors (also other Groups which are Actors).

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.physics.box2d (libgdx API)

Uses of Package
com.badlogic.gdx.physics.box2d

Packages that use com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints

Classes in com.badlogic.gdx.physics.box2d used by com.badlogic.gdx.physics.box2d
Body
A rigid body.
BodyDef
A body definition holds all the data needed to construct a rigid body.
BodyDef.BodyType
The body type.
Contact
The class manages contact between two shapes.
ContactFilter
Implement this class to provide collision filtering.
ContactListener
DestructionListener
Filter
This holds contact filtering data.
Fixture
FixtureDef
A fixture definition is used to create a fixture.
Joint
JointDef
JointDef.JointType
JointEdge
A joint edge is used to connect bodies and joints together in a joint graph where each body is a node and each joint is an edge.
MassData
This holds the mass data computed for a shape.
QueryCallback
Callback class for AABB queries.
Shape
A shape is used for collision detection.
Shape.Type
Enum describing the type of a shape
Transform
Encodes a Box2D transform.
World
The world class manages all physics entities, dynamic simulation, and asynchronous queries.
WorldManifold
This is used to compute the current state of a contact manifold.

Classes in com.badlogic.gdx.physics.box2d used by com.badlogic.gdx.physics.box2d.joints
Body
A rigid body.
Joint
JointDef
World
The world class manages all physics entities, dynamic simulation, and asynchronous queries.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.scenes.scene2d.actions (libgdx API)

Uses of Package
com.badlogic.gdx.scenes.scene2d.actions

Packages that use com.badlogic.gdx.scenes.scene2d.actions
com.badlogic.gdx.scenes.scene2d.actions

Classes in com.badlogic.gdx.scenes.scene2d.actions used by com.badlogic.gdx.scenes.scene2d.actions
Delay
FadeIn
FadeOut
FadeTo
Forever
MoveBy
MoveTo
Parallel
Repeat
RotateBy
RotateTo
ScaleTo
Sequence

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.scenes.scene2d.actors (libgdx API)

Uses of Package
com.badlogic.gdx.scenes.scene2d.actors

Packages that use com.badlogic.gdx.scenes.scene2d.actors
com.badlogic.gdx.scenes.scene2d.actors

Classes in com.badlogic.gdx.scenes.scene2d.actors used by com.badlogic.gdx.scenes.scene2d.actors
BoundGroup
This is a group that respects its width and height.
Button
A simple Button Actor, useful for simple UIs
Button.ClickListener
LinearGroup.LinearGroupLayout

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.twl (libgdx API)

Uses of Package
com.badlogic.gdx.twl

No usage of com.badlogic.gdx.twl

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.utils.json (libgdx API)

Uses of Package
com.badlogic.gdx.utils.json

Packages that use com.badlogic.gdx.utils.json
com.badlogic.gdx.utils.json

Classes in com.badlogic.gdx.utils.json used by com.badlogic.gdx.utils.json
JSONArray
A JSONArray is an ordered sequence of values.
JSONException
The JSONException is thrown by the JSON.org classes when things are amiss.
JSONObject
A JSONObject is an unordered collection of name/value pairs.
JSONTokener
A JSONTokener takes a source string and extracts characters and tokens from it.
JSONWriter
JSONWriter provides a quick and convenient way of producing JSON text.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Uses of Package com.badlogic.gdx.utils (libgdx API)

Uses of Package
com.badlogic.gdx.utils

Packages that use com.badlogic.gdx.utils
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.utils

Classes in com.badlogic.gdx.utils used by com.badlogic.gdx.physics.box2d
LongHashMap
An unordered map that uses long keys.

Classes in com.badlogic.gdx.utils used by com.badlogic.gdx.scenes.scene2d
PooledLinkedList
A simple linked list that pools its nodes.

Classes in com.badlogic.gdx.utils used by com.badlogic.gdx.utils
FloatArray
An ordered, resizable float array.
FloatBag
An unordered, resizable int array.
IntArray
An ordered, resizable int array.
IntBag
An unordered, resizable int array.
LocklessThreadQueue.ObjectFactory
Interface for an Object Factory for the initial buffer creation.
LongArray
An ordered, resizable long array.
LongBag
An unordered, resizable long array.
Pool.PoolObjectFactory
Interface for an Object Factory to be used with this Pool

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Parallel (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class Parallel

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.Parallel
All Implemented Interfaces:
Action
public class Parallel
extends java.lang.Object
implements Action

Field Summary
protected  java.util.List<Action> actions
Constructor Summary
Parallel()
Method Summary
static Parallel | $(Action... actions)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

actions

protected final java.util.List<Action> actions
Constructor Detail

Parallel

public Parallel()
Method Detail

$

public static Parallel $(Action... actions)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.Parallel (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.Parallel

Packages that use Parallel
com.badlogic.gdx.scenes.scene2d.actions

Uses of Parallel in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return Parallel
static Parallel Parallel.$(Action... actions)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEffect (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.particles
Class ParticleEffect

java.lang.Object
    extended by  com.badlogic.gdx.graphics.particles.ParticleEffect

public class ParticleEffect
extends java.lang.Object

Constructor Summary
ParticleEffect()
Method Summary
void | allowCompletion()
void | draw(SpriteBatch spriteBatch, float delta)
java.util.ArrayList<ParticleEmitter> | getEmitters()
boolean | isComplete()
void | load(FileHandle effectFile, FileHandle imagesDir)
void | load(FileHandle effectFile, TextureAtlas atlas)
void | loadEmitterImages(FileHandle imagesDir)
void | loadEmitterImages(TextureAtlas atlas)
void | loadEmitters(FileHandle effectFile)
protected Texture | loadTexture(FileHandle file)
void | save(java.io.File file)
void | setDuration(int duration)
void | setPosition(float x, float y)
void | start()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParticleEffect

public ParticleEffect()
Method Detail

start

public void start()

draw

public void draw(SpriteBatch spriteBatch,
                 float delta)

allowCompletion

public void allowCompletion()

isComplete

public boolean isComplete()

setDuration

public void setDuration(int duration)

setPosition

public void setPosition(float x,
                        float y)

getEmitters

public java.util.ArrayList<ParticleEmitter> getEmitters()

save

public void save(java.io.File file)

load

public void load(FileHandle effectFile,
                 FileHandle imagesDir)

load

public void load(FileHandle effectFile,
                 TextureAtlas atlas)

loadEmitters

public void loadEmitters(FileHandle effectFile)

loadEmitterImages

public void loadEmitterImages(TextureAtlas atlas)

loadEmitterImages

public void loadEmitterImages(FileHandle imagesDir)

loadTexture

protected Texture loadTexture(FileHandle file)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEffect (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEffect

No usage of com.badlogic.gdx.graphics.particles.ParticleEffect

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEmitter (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.particles
Class ParticleEmitter

java.lang.Object
    extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter

public class ParticleEmitter
extends java.lang.Object

Nested Class Summary
static class | ParticleEmitter.GradientColorValue
static class | ParticleEmitter.NumericValue
static class | ParticleEmitter.ParticleValue
static class | ParticleEmitter.RangedNumericValue
static class | ParticleEmitter.ScaledNumericValue
static class | ParticleEmitter.SpawnEllipseSide
static class | ParticleEmitter.SpawnShape
static class | ParticleEmitter.SpawnShapeValue
Field Summary
float | duration
float | durationTimer
Constructor Summary
ParticleEmitter()
ParticleEmitter(java.io.BufferedReader reader)
ParticleEmitter(ParticleEmitter emitter)
Method Summary
void | addParticle()
void | addParticles(int count)
void | draw(SpriteBatch spriteBatch, float delta)
int | getActiveCount()
ParticleEmitter.ScaledNumericValue | getAngle()
ParticleEmitter.RangedNumericValue | getDelay()
int | getDrawCount()
ParticleEmitter.RangedNumericValue | getDuration()
ParticleEmitter.ScaledNumericValue | getEmission()
ParticleEmitter.ScaledNumericValue | getGravity()
java.lang.String | getImagePath()
ParticleEmitter.ScaledNumericValue | getLife()
ParticleEmitter.ScaledNumericValue | getLifeOffset()
int | getMaxParticleCount()
int | getMinParticleCount()
java.lang.String | getName()
float | getPercentComplete()
ParticleEmitter.ScaledNumericValue | getRotation()
ParticleEmitter.ScaledNumericValue | getScale()
ParticleEmitter.ScaledNumericValue | getSpawnHeight()
ParticleEmitter.SpawnShapeValue | getSpawnShape()
ParticleEmitter.ScaledNumericValue | getSpawnWidth()
Sprite | getSprite()
ParticleEmitter.GradientColorValue | getTint()
ParticleEmitter.ScaledNumericValue | getTransparency()
ParticleEmitter.ScaledNumericValue | getVelocity()
ParticleEmitter.ScaledNumericValue | getWind()
float | getX()
ParticleEmitter.RangedNumericValue | getXOffsetValue()
float | getY()
ParticleEmitter.RangedNumericValue | getYOffsetValue()
boolean | isAdditive()
boolean | isAligned()
boolean | isAttached()
boolean | isBehind()
boolean | isComplete()
boolean | isContinuous()
void | load(java.io.BufferedReader reader)
void | reset()
void | save(java.io.Writer output)
void | setAdditive(boolean additive)
void | setAligned(boolean aligned)
void | setAttached(boolean attached)
void | setBehind(boolean behind)
void | setContinuous(boolean continuous)
void | setFlip(boolean flipX, boolean flipY)
void | setImagePath(java.lang.String imagePath)
void | setMaxParticleCount(int maxParticleCount)
void | setMinParticleCount(int minParticleCount)
void | setName(java.lang.String name)
void | setPosition(float x, float y)
void | setSprite(Sprite sprite)
void | start()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

duration

public float duration

durationTimer

public float durationTimer
Constructor Detail

ParticleEmitter

public ParticleEmitter()

ParticleEmitter

public ParticleEmitter(java.io.BufferedReader reader)
                throws java.io.IOException
Throws:
java.io.IOException

ParticleEmitter

public ParticleEmitter(ParticleEmitter emitter)
Method Detail

setMaxParticleCount

public void setMaxParticleCount(int maxParticleCount)

addParticle

public void addParticle()

addParticles

public void addParticles(int count)

draw

public void draw(SpriteBatch spriteBatch,
                 float delta)

start

public void start()

reset

public void reset()

setPosition

public void setPosition(float x,
                        float y)

setSprite

public void setSprite(Sprite sprite)

getSprite

public Sprite getSprite()

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getLife

public ParticleEmitter.ScaledNumericValue getLife()

getScale

public ParticleEmitter.ScaledNumericValue getScale()

getRotation

public ParticleEmitter.ScaledNumericValue getRotation()

getTint

public ParticleEmitter.GradientColorValue getTint()

getVelocity

public ParticleEmitter.ScaledNumericValue getVelocity()

getWind

public ParticleEmitter.ScaledNumericValue getWind()

getGravity

public ParticleEmitter.ScaledNumericValue getGravity()

getAngle

public ParticleEmitter.ScaledNumericValue getAngle()

getEmission

public ParticleEmitter.ScaledNumericValue getEmission()

getTransparency

public ParticleEmitter.ScaledNumericValue getTransparency()

getDuration

public ParticleEmitter.RangedNumericValue getDuration()

getDelay

public ParticleEmitter.RangedNumericValue getDelay()

getLifeOffset

public ParticleEmitter.ScaledNumericValue getLifeOffset()

getXOffsetValue

public ParticleEmitter.RangedNumericValue getXOffsetValue()

getYOffsetValue

public ParticleEmitter.RangedNumericValue getYOffsetValue()

getSpawnWidth

public ParticleEmitter.ScaledNumericValue getSpawnWidth()

getSpawnHeight

public ParticleEmitter.ScaledNumericValue getSpawnHeight()

getSpawnShape

public ParticleEmitter.SpawnShapeValue getSpawnShape()

isAttached

public boolean isAttached()

setAttached

public void setAttached(boolean attached)

isContinuous

public boolean isContinuous()

setContinuous

public void setContinuous(boolean continuous)

isAligned

public boolean isAligned()

setAligned

public void setAligned(boolean aligned)

isAdditive

public boolean isAdditive()

setAdditive

public void setAdditive(boolean additive)

isBehind

public boolean isBehind()

setBehind

public void setBehind(boolean behind)

getMinParticleCount

public int getMinParticleCount()

setMinParticleCount

public void setMinParticleCount(int minParticleCount)

getMaxParticleCount

public int getMaxParticleCount()

isComplete

public boolean isComplete()

getPercentComplete

public float getPercentComplete()

getX

public float getX()

getY

public float getY()

getActiveCount

public int getActiveCount()

getDrawCount

public int getDrawCount()

getImagePath

public java.lang.String getImagePath()

setImagePath

public void setImagePath(java.lang.String imagePath)

setFlip

public void setFlip(boolean flipX,
                    boolean flipY)

save

public void save(java.io.Writer output)
          throws java.io.IOException
Throws:
java.io.IOException

load

public void load(java.io.BufferedReader reader)
          throws java.io.IOException
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEmitter (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEmitter

Packages that use ParticleEmitter
com.badlogic.gdx.graphics.particles

Uses of ParticleEmitter in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles that return types with arguments of type ParticleEmitter
 java.util.ArrayList<ParticleEmitter> ParticleEffect.getEmitters()

Constructors in com.badlogic.gdx.graphics.particles with parameters of type ParticleEmitter
ParticleEmitter(ParticleEmitter emitter)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEmitter.GradientColorValue (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.particles
Class ParticleEmitter.GradientColorValue

java.lang.Object
    extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
        extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue
Enclosing class:
ParticleEmitter
public static class ParticleEmitter.GradientColorValue
extends ParticleEmitter.ParticleValue

Constructor Summary
ParticleEmitter.GradientColorValue()
Method Summary
float[] | getColor(float percent)
float[] | getColors()
float[] | getTimeline()
void | load(java.io.BufferedReader reader)
void | load(ParticleEmitter.GradientColorValue value)
void | save(java.io.Writer output)
void | setColors(float[] colors)
void | setTimeline(float[] timeline)
Methods inherited from class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
isActive, isAlwaysActive, load, setActive, setAlwaysActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParticleEmitter.GradientColorValue

public ParticleEmitter.GradientColorValue()
Method Detail

getTimeline

public float[] getTimeline()

setTimeline

public void setTimeline(float[] timeline)

getColors

public float[] getColors()

setColors

public void setColors(float[] colors)

getColor

public float[] getColor(float percent)

save

public void save(java.io.Writer output)
          throws java.io.IOException
Overrides:
save in class ParticleEmitter.ParticleValue
Throws:
java.io.IOException

load

public void load(java.io.BufferedReader reader)
          throws java.io.IOException
Overrides:
load in class ParticleEmitter.ParticleValue
Throws:
java.io.IOException

load

public void load(ParticleEmitter.GradientColorValue value)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEmitter.GradientColorValue

Packages that use ParticleEmitter.GradientColorValue
com.badlogic.gdx.graphics.particles

Uses of ParticleEmitter.GradientColorValue in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles that return ParticleEmitter.GradientColorValue
 ParticleEmitter.GradientColorValue ParticleEmitter.getTint()

Methods in com.badlogic.gdx.graphics.particles with parameters of type ParticleEmitter.GradientColorValue
 void ParticleEmitter.GradientColorValue.load(ParticleEmitter.GradientColorValue value)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEmitter.NumericValue (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.particles
Class ParticleEmitter.NumericValue

java.lang.Object
    extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
        extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue
Enclosing class:
ParticleEmitter
public static class ParticleEmitter.NumericValue
extends ParticleEmitter.ParticleValue

Constructor Summary
ParticleEmitter.NumericValue()
Method Summary
float | getValue()
void | load(java.io.BufferedReader reader)
void | load(ParticleEmitter.NumericValue value)
void | save(java.io.Writer output)
void | setValue(float value)
Methods inherited from class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
isActive, isAlwaysActive, load, setActive, setAlwaysActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParticleEmitter.NumericValue

public ParticleEmitter.NumericValue()
Method Detail

getValue

public float getValue()

setValue

public void setValue(float value)

save

public void save(java.io.Writer output)
          throws java.io.IOException
Overrides:
save in class ParticleEmitter.ParticleValue
Throws:
java.io.IOException

load

public void load(java.io.BufferedReader reader)
          throws java.io.IOException
Overrides:
load in class ParticleEmitter.ParticleValue
Throws:
java.io.IOException

load

public void load(ParticleEmitter.NumericValue value)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEmitter.NumericValue

Packages that use ParticleEmitter.NumericValue
com.badlogic.gdx.graphics.particles

Uses of ParticleEmitter.NumericValue in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles with parameters of type ParticleEmitter.NumericValue
 void ParticleEmitter.NumericValue.load(ParticleEmitter.NumericValue value)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEmitter.ParticleValue (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.particles
Class ParticleEmitter.ParticleValue

java.lang.Object
    extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
Direct Known Subclasses:
ParticleEmitter.GradientColorValue, ParticleEmitter.NumericValue, ParticleEmitter.RangedNumericValue, ParticleEmitter.SpawnShapeValue
Enclosing class:
ParticleEmitter
public static class ParticleEmitter.ParticleValue
extends java.lang.Object

Constructor Summary
ParticleEmitter.ParticleValue()
Method Summary
boolean | isActive()
boolean | isAlwaysActive()
void | load(java.io.BufferedReader reader)
void | load(ParticleEmitter.ParticleValue value)
void | save(java.io.Writer output)
void | setActive(boolean active)
void | setAlwaysActive(boolean alwaysActive)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParticleEmitter.ParticleValue

public ParticleEmitter.ParticleValue()
Method Detail

setAlwaysActive

public void setAlwaysActive(boolean alwaysActive)

isAlwaysActive

public boolean isAlwaysActive()

isActive

public boolean isActive()

setActive

public void setActive(boolean active)

save

public void save(java.io.Writer output)
          throws java.io.IOException
Throws:
java.io.IOException

load

public void load(java.io.BufferedReader reader)
          throws java.io.IOException
Throws:
java.io.IOException

load

public void load(ParticleEmitter.ParticleValue value)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue

Packages that use ParticleEmitter.ParticleValue
com.badlogic.gdx.graphics.particles

Uses of ParticleEmitter.ParticleValue in com.badlogic.gdx.graphics.particles

Subclasses of ParticleEmitter.ParticleValue in com.badlogic.gdx.graphics.particles
static class | ParticleEmitter.GradientColorValue
static class | ParticleEmitter.NumericValue
static class | ParticleEmitter.RangedNumericValue
static class | ParticleEmitter.ScaledNumericValue
static class | ParticleEmitter.SpawnShapeValue

Methods in com.badlogic.gdx.graphics.particles with parameters of type ParticleEmitter.ParticleValue
 void ParticleEmitter.ParticleValue.load(ParticleEmitter.ParticleValue value)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEmitter.RangedNumericValue (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.particles
Class ParticleEmitter.RangedNumericValue

java.lang.Object
    extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
        extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
Direct Known Subclasses:
ParticleEmitter.ScaledNumericValue
Enclosing class:
ParticleEmitter
public static class ParticleEmitter.RangedNumericValue
extends ParticleEmitter.ParticleValue

Constructor Summary
ParticleEmitter.RangedNumericValue()
Method Summary
float | getLowMax()
float | getLowMin()
void | load(java.io.BufferedReader reader)
void | load(ParticleEmitter.RangedNumericValue value)
float | newLowValue()
void | save(java.io.Writer output)
void | setLow(float value)
void | setLow(float min, float max)
void | setLowMax(float lowMax)
void | setLowMin(float lowMin)
Methods inherited from class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
isActive, isAlwaysActive, load, setActive, setAlwaysActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParticleEmitter.RangedNumericValue

public ParticleEmitter.RangedNumericValue()
Method Detail

newLowValue

public float newLowValue()

setLow

public void setLow(float value)

setLow

public void setLow(float min,
                   float max)

getLowMin

public float getLowMin()

setLowMin

public void setLowMin(float lowMin)

getLowMax

public float getLowMax()

setLowMax

public void setLowMax(float lowMax)

save

public void save(java.io.Writer output)
          throws java.io.IOException
Overrides:
save in class ParticleEmitter.ParticleValue
Throws:
java.io.IOException

load

public void load(java.io.BufferedReader reader)
          throws java.io.IOException
Overrides:
load in class ParticleEmitter.ParticleValue
Throws:
java.io.IOException

load

public void load(ParticleEmitter.RangedNumericValue value)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue

Packages that use ParticleEmitter.RangedNumericValue
com.badlogic.gdx.graphics.particles

Uses of ParticleEmitter.RangedNumericValue in com.badlogic.gdx.graphics.particles

Subclasses of ParticleEmitter.RangedNumericValue in com.badlogic.gdx.graphics.particles
static class ParticleEmitter.ScaledNumericValue

Methods in com.badlogic.gdx.graphics.particles that return ParticleEmitter.RangedNumericValue
ParticleEmitter.RangedNumericValue | ParticleEmitter.getDelay()
ParticleEmitter.RangedNumericValue | ParticleEmitter.getDuration()
ParticleEmitter.RangedNumericValue | ParticleEmitter.getXOffsetValue()
ParticleEmitter.RangedNumericValue | ParticleEmitter.getYOffsetValue()

Methods in com.badlogic.gdx.graphics.particles with parameters of type ParticleEmitter.RangedNumericValue
 void ParticleEmitter.RangedNumericValue.load(ParticleEmitter.RangedNumericValue value)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEmitter.ScaledNumericValue (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.particles
Class ParticleEmitter.ScaledNumericValue

java.lang.Object
    extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
        extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
            extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue
Enclosing class:
ParticleEmitter
public static class ParticleEmitter.ScaledNumericValue
extends ParticleEmitter.RangedNumericValue

Constructor Summary
ParticleEmitter.ScaledNumericValue()
Method Summary
float | getHighMax()
float | getHighMin()
float | getScale(float percent)
float[] | getScaling()
float[] | getTimeline()
boolean | isRelative()
void | load(java.io.BufferedReader reader)
void | load(ParticleEmitter.ScaledNumericValue value)
float | newHighValue()
void | save(java.io.Writer output)
void | setHigh(float value)
void | setHigh(float min, float max)
void | setHighMax(float highMax)
void | setHighMin(float highMin)
void | setRelative(boolean relative)
void | setScaling(float[] values)
void | setTimeline(float[] timeline)
Methods inherited from class com.badlogic.gdx.graphics.particles.ParticleEmitter.RangedNumericValue
getLowMax, getLowMin, load, newLowValue, setLow, setLow, setLowMax, setLowMin
Methods inherited from class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
isActive, isAlwaysActive, load, setActive, setAlwaysActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParticleEmitter.ScaledNumericValue

public ParticleEmitter.ScaledNumericValue()
Method Detail

newHighValue

public float newHighValue()

setHigh

public void setHigh(float value)

setHigh

public void setHigh(float min,
                    float max)

getHighMin

public float getHighMin()

setHighMin

public void setHighMin(float highMin)

getHighMax

public float getHighMax()

setHighMax

public void setHighMax(float highMax)

getScaling

public float[] getScaling()

setScaling

public void setScaling(float[] values)

getTimeline

public float[] getTimeline()

setTimeline

public void setTimeline(float[] timeline)

isRelative

public boolean isRelative()

setRelative

public void setRelative(boolean relative)

getScale

public float getScale(float percent)

save

public void save(java.io.Writer output)
          throws java.io.IOException
Overrides:
save in class ParticleEmitter.RangedNumericValue
Throws:
java.io.IOException

load

public void load(java.io.BufferedReader reader)
          throws java.io.IOException
Overrides:
load in class ParticleEmitter.RangedNumericValue
Throws:
java.io.IOException

load

public void load(ParticleEmitter.ScaledNumericValue value)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEmitter.ScaledNumericValue

Packages that use ParticleEmitter.ScaledNumericValue
com.badlogic.gdx.graphics.particles

Uses of ParticleEmitter.ScaledNumericValue in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles that return ParticleEmitter.ScaledNumericValue
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getAngle()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getEmission()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getGravity()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getLife()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getLifeOffset()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getRotation()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getScale()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getSpawnHeight()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getSpawnWidth()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getTransparency()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getVelocity()
ParticleEmitter.ScaledNumericValue | ParticleEmitter.getWind()

Methods in com.badlogic.gdx.graphics.particles with parameters of type ParticleEmitter.ScaledNumericValue
 void ParticleEmitter.ScaledNumericValue.load(ParticleEmitter.ScaledNumericValue value)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEmitter.SpawnEllipseSide (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.graphics.particles
Enum ParticleEmitter.SpawnEllipseSide

java.lang.Object
    extended by  java.lang.Enum<ParticleEmitter.SpawnEllipseSide>
        extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnEllipseSide
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<ParticleEmitter.SpawnEllipseSide>
Enclosing class:
ParticleEmitter
public static enum ParticleEmitter.SpawnEllipseSide
extends java.lang.Enum<ParticleEmitter.SpawnEllipseSide>

Enum Constant Summary
both
bottom
top
Method Summary
static ParticleEmitter.SpawnEllipseSide | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static ParticleEmitter.SpawnEllipseSide[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

both

public static final ParticleEmitter.SpawnEllipseSide both

top

public static final ParticleEmitter.SpawnEllipseSide top

bottom

public static final ParticleEmitter.SpawnEllipseSide bottom
Method Detail

values

public static ParticleEmitter.SpawnEllipseSide[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (ParticleEmitter.SpawnEllipseSide c : ParticleEmitter.SpawnEllipseSide.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ParticleEmitter.SpawnEllipseSide valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnEllipseSide (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnEllipseSide

Packages that use ParticleEmitter.SpawnEllipseSide
com.badlogic.gdx.graphics.particles

Uses of ParticleEmitter.SpawnEllipseSide in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles that return ParticleEmitter.SpawnEllipseSide
ParticleEmitter.SpawnEllipseSide | ParticleEmitter.SpawnShapeValue.getSide()
static ParticleEmitter.SpawnEllipseSide | ParticleEmitter.SpawnEllipseSide.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static ParticleEmitter.SpawnEllipseSide[] | ParticleEmitter.SpawnEllipseSide.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.badlogic.gdx.graphics.particles with parameters of type ParticleEmitter.SpawnEllipseSide
 void ParticleEmitter.SpawnShapeValue.setSide(ParticleEmitter.SpawnEllipseSide side)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEmitter.SpawnShape (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.graphics.particles
Enum ParticleEmitter.SpawnShape

java.lang.Object
    extended by  java.lang.Enum<ParticleEmitter.SpawnShape>
        extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShape
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<ParticleEmitter.SpawnShape>
Enclosing class:
ParticleEmitter
public static enum ParticleEmitter.SpawnShape
extends java.lang.Enum<ParticleEmitter.SpawnShape>

Enum Constant Summary
ellipse
line
point
square
Method Summary
static ParticleEmitter.SpawnShape | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static ParticleEmitter.SpawnShape[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

point

public static final ParticleEmitter.SpawnShape point

line

public static final ParticleEmitter.SpawnShape line

square

public static final ParticleEmitter.SpawnShape square

ellipse

public static final ParticleEmitter.SpawnShape ellipse
Method Detail

values

public static ParticleEmitter.SpawnShape[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (ParticleEmitter.SpawnShape c : ParticleEmitter.SpawnShape.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ParticleEmitter.SpawnShape valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShape (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShape

Packages that use ParticleEmitter.SpawnShape
com.badlogic.gdx.graphics.particles

Uses of ParticleEmitter.SpawnShape in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles that return ParticleEmitter.SpawnShape
ParticleEmitter.SpawnShape | ParticleEmitter.SpawnShapeValue.getShape()
static ParticleEmitter.SpawnShape | ParticleEmitter.SpawnShape.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static ParticleEmitter.SpawnShape[] | ParticleEmitter.SpawnShape.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.badlogic.gdx.graphics.particles with parameters of type ParticleEmitter.SpawnShape
 void ParticleEmitter.SpawnShapeValue.setShape(ParticleEmitter.SpawnShape shape)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ParticleEmitter.SpawnShapeValue (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.particles
Class ParticleEmitter.SpawnShapeValue

java.lang.Object
    extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
        extended by  com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue
Enclosing class:
ParticleEmitter
public static class ParticleEmitter.SpawnShapeValue
extends ParticleEmitter.ParticleValue

Constructor Summary
ParticleEmitter.SpawnShapeValue()
Method Summary
ParticleEmitter.SpawnShape | getShape()
ParticleEmitter.SpawnEllipseSide | getSide()
boolean | isEdges()
void | load(java.io.BufferedReader reader)
void | load(ParticleEmitter.SpawnShapeValue value)
void | save(java.io.Writer output)
void | setEdges(boolean edges)
void | setShape(ParticleEmitter.SpawnShape shape)
void | setSide(ParticleEmitter.SpawnEllipseSide side)
Methods inherited from class com.badlogic.gdx.graphics.particles.ParticleEmitter.ParticleValue
isActive, isAlwaysActive, load, setActive, setAlwaysActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParticleEmitter.SpawnShapeValue

public ParticleEmitter.SpawnShapeValue()
Method Detail

getShape

public ParticleEmitter.SpawnShape getShape()

setShape

public void setShape(ParticleEmitter.SpawnShape shape)

isEdges

public boolean isEdges()

setEdges

public void setEdges(boolean edges)

getSide

public ParticleEmitter.SpawnEllipseSide getSide()

setSide

public void setSide(ParticleEmitter.SpawnEllipseSide side)

save

public void save(java.io.Writer output)
          throws java.io.IOException
Overrides:
save in class ParticleEmitter.ParticleValue
Throws:
java.io.IOException

load

public void load(java.io.BufferedReader reader)
          throws java.io.IOException
Overrides:
load in class ParticleEmitter.ParticleValue
Throws:
java.io.IOException

load

public void load(ParticleEmitter.SpawnShapeValue value)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.particles.ParticleEmitter.SpawnShapeValue

Packages that use ParticleEmitter.SpawnShapeValue
com.badlogic.gdx.graphics.particles

Uses of ParticleEmitter.SpawnShapeValue in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles that return ParticleEmitter.SpawnShapeValue
 ParticleEmitter.SpawnShapeValue ParticleEmitter.getSpawnShape()

Methods in com.badlogic.gdx.graphics.particles with parameters of type ParticleEmitter.SpawnShapeValue
 void ParticleEmitter.SpawnShapeValue.load(ParticleEmitter.SpawnShapeValue value)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


PauseableThread (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class PauseableThread

java.lang.Object
    extended by  java.lang.Thread
        extended by  com.badlogic.gdx.utils.PauseableThread
All Implemented Interfaces:
java.lang.Runnable
public class PauseableThread
extends java.lang.Thread

A pausable thread. The runnable must not execute an inifite loop but should return control to the thread as often as possible so that the thread can actually pause.

Author:
mzechner

Nested Class Summary
Nested classes/interfaces inherited from class java.lang.Thread
java.lang.Thread.State, java.lang.Thread.UncaughtExceptionHandler
Field Summary
Fields inherited from class java.lang.Thread
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
Constructor Summary
PauseableThread(java.lang.Runnable runnable)
Constructs a new thread setting the runnable which will be called repeatadly in a loop.
Method Summary
boolean | isPaused()
void | onPause() Pauses the thread.
void | onResume() Resumes the thread.
void | run()
void | stopThread() Stops this thread
Methods inherited from class java.lang.Thread
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, stop, stop, suspend, toString, yield
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PauseableThread

public PauseableThread(java.lang.Runnable runnable)
Constructs a new thread setting the runnable which will be called repeatadly in a loop.

Parameters:
runnable - the runnable.
Method Detail

run

public void run()
Specified by:
run in interface java.lang.Runnable
Overrides:
run in class java.lang.Thread

onPause

public void onPause()
Pauses the thread. This call is non-blocking

onResume

public void onResume()
Resumes the thread. This call is non-blocking

isPaused

public boolean isPaused()
Returns:
whether this thread is paused or not

stopThread

public void stopThread()
Stops this thread

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.PauseableThread (libgdx API)

Uses of Class
com.badlogic.gdx.utils.PauseableThread

No usage of com.badlogic.gdx.utils.PauseableThread

Overview Package Class Use Tree Deprecated Index Help
libgdx API


PerspectiveCamera (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class PerspectiveCamera

java.lang.Object
    extended by  com.badlogic.gdx.graphics.PerspectiveCamera

public final class PerspectiveCamera
extends java.lang.Object

A perspective camera, having a position, a direction an up vector, a near plane, a far plane and a field of view. Use the setViewport(float, float) method to set the viewport from which the aspect ratio is derrived from, then call update() to update all the camera matrices as well as the Frustum. The combined matrix (projection, modelview) can be retrieved via a call to getCombinedMatrix() and directly passed to OpenGL. A convenience method called setMatrices() exists for OpenGL ES 1.x that will update the OpenGL perspective and modelview. You can also get a picking ray via getPickRay(int, int).

Author:
badlogicgames@gmail.com

Field Summary
protected Matrix4 | comb
protected Matrix4 | model
protected Matrix4 | proj
protected Matrix4 | tmp
Constructor Summary
PerspectiveCamera()
Method Summary
Matrix4 | getCombinedMatrix()
Vector3 | getDirection()
float | getFar()
float | getFov()
Frustum | getFrustum()
Matrix4 | getModelviewMatrix()
float | getNear()
Ray | getPickRay(int screenX, int screenY) Returns a ray in world space form the given screen coordinates.
Vector3 | getPosition()
Matrix4 | getProjectionMatrix()
Vector3 | getRight()
Vector3 | getUp()
float | getViewportWidth()
void | project(Vector3 pos) Projects the given vector in world space to screen space, overwritting the x- and y-coordinate of the provided vector.
void | setFar(float far) Sets the far plane
void | setFov(float fov) Sets the field of view in degrees
void | setMatrices() Sets the projection and model view matrix of OpenGL ES 1.x to this camera's projection and model view matrix.
void | setNear(float near) Sets the near plane.
void | setViewport(float viewportWidth, float viewportHeight) Sets the viewport dimensions.
void | update() Updates all matrices as well as the Frustum based on the last set parameters for position, direction, up vector, field of view, near and far plane and viewport.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

tmp

protected Matrix4 tmp

proj

protected Matrix4 proj

model

protected Matrix4 model

comb

protected Matrix4 comb
Constructor Detail

PerspectiveCamera

public PerspectiveCamera()
Method Detail

getNear

public float getNear()
Returns:
The near plane.

setNear

public void setNear(float near)
Sets the near plane.

Parameters:
near - The near plane

getFar

public float getFar()
Returns:
The far plane

setFar

public void setFar(float far)
Sets the far plane

Parameters:
far - The far plane

getFov

public float getFov()
Returns:
The field of view in degrees

setFov

public void setFov(float fov)
Sets the field of view in degrees

Parameters:
fov - The field of view

getViewportWidth

public float getViewportWidth()
Returns:
The viewport height

setViewport

public void setViewport(float viewportWidth,
                        float viewportHeight)
Sets the viewport dimensions.

Parameters:
viewportWidth - The viewport width in pixels.
viewportHeight - The viewport height in pixels.

getProjectionMatrix

public Matrix4 getProjectionMatrix()
Returns:
The projection matrix.

getModelviewMatrix

public Matrix4 getModelviewMatrix()
Returns:
The modelview matrix.

getCombinedMatrix

public Matrix4 getCombinedMatrix()
Returns:
The combined matrix, projection * modelview

getFrustum

public Frustum getFrustum()
Returns:
The Frustum

update

public void update()
Updates all matrices as well as the Frustum based on the last set parameters for position, direction, up vector, field of view, near and far plane and viewport.

setMatrices

public void setMatrices()
Sets the projection and model view matrix of OpenGL ES 1.x to this camera's projection and model view matrix. Any previously set matrices are overwritten. Upon returning from this method the matrix mode will be GL10.GL_MODELVIEW.

getDirection

public Vector3 getDirection()
Returns:
The direction vector.

getRight

public Vector3 getRight()
Returns:
The right vector

getUp

public Vector3 getUp()
Returns:
The up vector.

getPosition

public Vector3 getPosition()
Returns:
The position.

getPickRay

public Ray getPickRay(int screenX,
                      int screenY)
Returns a ray in world space form the given screen coordinates. This can be used for picking. The returned Ray is an internal member of this class to reduce memory allocations. Do not reuse it outside of this class.

Parameters:
screenX - The screen x-coordinate
screenY - The screen y-coordinate
Returns:
The picking ray

project

public void project(Vector3 pos)
Projects the given vector in world space to screen space, overwritting the x- and y-coordinate of the provided vector.

Parameters:
pos - The vector to project
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.PerspectiveCamera (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.PerspectiveCamera

No usage of com.badlogic.gdx.graphics.PerspectiveCamera

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Pixmap (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Interface Pixmap

public interface Pixmap

A Pixmap represents a platform specific bitmap. On Android it encapsulates a Bitmap on the desktop it encapsulates a BufferedImage. Various methods are available to manipulate the Pixmap. This uses the common bitmap coordinate system with the origin being in the top left corner and the y-axis pointing downwards. Bitmaps can be disposed to free all related resources. Use after disposing will result in nasty exceptions.

Author:
badlogicgames@gmail.com

Nested Class Summary
static class Pixmap.Format
Different pixel formats.
Method Summary
void | dispose() Releases all resources associated with this Pixmap.
void | drawCircle(int x, int y, int radius) Draws a circle outline with the center at x,y and a radius using the current color and stroke width.
void | drawLine(int x, int y, int x2, int y2) Draws a line between the given coordinates using the currently set color and stroke width.
void | drawPixmap(Pixmap pixmap, int x, int y, int srcx, int srcy, int srcWidth, int srcHeight) Draws an area form another Pixmap to this Pixmap.
void | drawRectangle(int x, int y, int width, int height) Draws a rectangle outline starting at x, y extending by width to the right and by height downwards (y-axis points downwards) using the current color and stroke width.
void | fill() Fills the complete bitmap with the currently set color.
void | fillCircle(int x, int y, int radius) Fills a circle with the center at x,y and a radius using the current color.
void | fillRectangle(int x, int y, int width, int height) Fills a rectangle starting at x, y extending by width to the right and by height downwards (y-axis points downwards) using the current color.
int | getHeight()
java.lang.Object | getNativePixmap()
int | getPixel(int x, int y) Returns the 32-bit argb value of the pixel at x, y
void | getPixelRow(int[] pixels, int y) Returns the yth row of pixels form the Pixmap in the provided pixels array.
int | getWidth()
void | setColor(float r, float g, float b, float a) Sets the color for the following drawing operations.
void | setStrokeWidth(int width) Sets the width in pixels of strokes.

Method Detail

setColor

void setColor(float r,
              float g,
              float b,
              float a)
Sets the color for the following drawing operations.

Parameters:
r - The red component.
g - The green component.
b - The blue component.
a - The alpha component.

fill

void fill()
Fills the complete bitmap with the currently set color.

setStrokeWidth

void setStrokeWidth(int width)
Sets the width in pixels of strokes.

Parameters:
width - The stroke width in pixels.

drawLine

void drawLine(int x,
              int y,
              int x2,
              int y2)
Draws a line between the given coordinates using the currently set color and stroke width.

Parameters:
x - The x-coodinate of the first point
y - The y-coordinate of the first point
x2 - The x-coordinate of the first point
y2 - The y-coordinate of the first point

drawRectangle

void drawRectangle(int x,
                   int y,
                   int width,
                   int height)
Draws a rectangle outline starting at x, y extending by width to the right and by height downwards (y-axis points downwards) using the current color and stroke width.

Parameters:
x - The x coordinate
y - The y coordinate
width - The width in pixels
height - The height in pixels

drawPixmap

void drawPixmap(Pixmap pixmap,
                int x,
                int y,
                int srcx,
                int srcy,
                int srcWidth,
                int srcHeight)
Draws an area form another Pixmap to this Pixmap.

Parameters:
pixmap - The other Pixmap
x - The target x-coordinate
y - The target y-coordinate
srcx - The source x-coordinate
srcy - The source y-coordinate
srcWidth - The width of the area form the other Pixmap in pixels
srcHeight - The height of the area form the other Pixmap in pixles

fillRectangle

void fillRectangle(int x,
                   int y,
                   int width,
                   int height)
Fills a rectangle starting at x, y extending by width to the right and by height downwards (y-axis points downwards) using the current color.

Parameters:
x - The x coordinate
y - The y coordinate
width - The width in pixels
height - The height in pixels

drawCircle

void drawCircle(int x,
                int y,
                int radius)
Draws a circle outline with the center at x,y and a radius using the current color and stroke width.

Parameters:
x - The x-coordinate of the center
y - The y-coordinate of the center
radius - The radius in pixels

fillCircle

void fillCircle(int x,
                int y,
                int radius)
Fills a circle with the center at x,y and a radius using the current color.

Parameters:
x - The x-coordinate of the center
y - The y-coordinate of the center
radius - The radius in pixels

getPixel

int getPixel(int x,
             int y)
Returns the 32-bit argb value of the pixel at x, y

Parameters:
x - The x-coordinate
y - The y-coordinate
Returns:
The pixel color in 32-bit argb format.

getPixelRow

void getPixelRow(int[] pixels,
                 int y)
Returns the yth row of pixels form the Pixmap in the provided pixels array. The pixels array must have at least Pixmap.getWidth() elements. The values are returned as 32-bit argb values.

Parameters:
pixels - The array to store the pixels in.
y - The y-coordinate of the row.

getNativePixmap

java.lang.Object getNativePixmap()
Returns:
The native bitmap object that backs this interface, Bitmap on Android, BufferedImage on PC

getWidth

int getWidth()
Returns:
The width of the Pixmap in pixels.

getHeight

int getHeight()
Returns:
The height of the Pixmap in pixels.

dispose

void dispose()
Releases all resources associated with this Pixmap.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.graphics.Pixmap (libgdx API)

Uses of Interface
com.badlogic.gdx.graphics.Pixmap

Packages that use Pixmap
com.badlogic.gdx
com.badlogic.gdx.graphics

Uses of Pixmap in com.badlogic.gdx

Methods in com.badlogic.gdx that return Pixmap
Pixmap | Graphics.newPixmap(FileHandle file) Creates a new Pixmap from the given file which is assumed to point to a bitmap in a readable format.
Pixmap | Graphics.newPixmap(java.io.InputStream in) Creates a new Pixmap from the given InputStream which is assumed to point to a bitmap in a readable format.
Pixmap | Graphics.newPixmap(int width, int height, Pixmap.Format format) Creates a new Pixmap with the specified dimensions and format.
Pixmap | Graphics.newPixmap(java.lang.Object nativePixmap) Creates a new Pixmap from the given native pixmap.

Methods in com.badlogic.gdx with parameters of type Pixmap
 Texture Graphics.newUnmanagedTexture(Pixmap pixmap, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap)
Creates a new Texture from the given Pixmap using the specified minification and magnification filter and texture wraps in u and v.

Uses of Pixmap in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics with parameters of type Pixmap
void | Texture.draw(Pixmap pixmap, int x, int y) Draws the given Pixmap to the texture at position x, y.
void | Pixmap.drawPixmap(Pixmap pixmap, int x, int y, int srcx, int srcy, int srcWidth, int srcHeight) Draws an area form another Pixmap to this Pixmap.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Pixmap.Format (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.graphics
Enum Pixmap.Format

java.lang.Object
    extended by  java.lang.Enum<Pixmap.Format>
        extended by  com.badlogic.gdx.graphics.Pixmap.Format
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Pixmap.Format>
Enclosing interface:
Pixmap
public static enum Pixmap.Format
extends java.lang.Enum<Pixmap.Format>

Different pixel formats.

Author:
mzechner

Enum Constant Summary
Alpha
RGB565
RGBA4444
RGBA8888
Method Summary
static Pixmap.Format | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Pixmap.Format[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

Alpha

public static final Pixmap.Format Alpha

RGB565

public static final Pixmap.Format RGB565

RGBA4444

public static final Pixmap.Format RGBA4444

RGBA8888

public static final Pixmap.Format RGBA8888
Method Detail

values

public static Pixmap.Format[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Pixmap.Format c : Pixmap.Format.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Pixmap.Format valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.graphics.Pixmap.Format (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.Pixmap.Format

Packages that use Pixmap.Format
com.badlogic.gdx
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils

Uses of Pixmap.Format in com.badlogic.gdx

Methods in com.badlogic.gdx with parameters of type Pixmap.Format
Pixmap | Graphics.newPixmap(int width, int height, Pixmap.Format format) Creates a new Pixmap with the specified dimensions and format.
Texture | Graphics.newUnmanagedTexture(int width, int height, Pixmap.Format format, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture with the specified dimensions, minification and magnification filters and texture wraps in u and v.

Uses of Pixmap.Format in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Pixmap.Format
static Pixmap.Format | Pixmap.Format.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Pixmap.Format[] | Pixmap.Format.values() Returns an array containing the constants of this enum type, in the order they are declared.

Uses of Pixmap.Format in com.badlogic.gdx.graphics.glutils

Constructors in com.badlogic.gdx.graphics.glutils with parameters of type Pixmap.Format
FrameBuffer(Pixmap.Format format, int width, int height, boolean hasDepth)
Creates a new FrameBuffer having the given dimensions and potentially a depth buffer attached.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Plane (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class Plane

java.lang.Object
    extended by  com.badlogic.gdx.math.Plane

public final class Plane
extends java.lang.Object

A plane defined via a unit length normal and the distance from the origin, as you learned in your math class.

Author:
badlogicgames@gmail.com

Nested Class Summary
static class Plane.PlaneSide
Enum specifying on which side a point lies respective to the plane and it's normal.
Field Summary
float | d
Vector3 | normal
Constructor Summary
Plane(Vector3 normal, float d)
Constructs a new plane based on the normal and distance to the origin.
Plane(Vector3 normal, Vector3 point)
Constructs a new plane based on the normal and a point on the plane.
Plane(Vector3 point1, Vector3 point2, Vector3 point3)
Constructs a new plane out of the three given points that are considered to be on the plane.
Method Summary
float | distance(Vector3 point) Calculates the shortest signed distance between the plane and the given point.
float | getD()
Vector3 | getNormal()
boolean | isFrontFacing(Vector3 direction) Returns whether the plane is facing the direction vector.
void | set(float nx, float ny, float nz, float d) Sets the plane normal and distance
void | set(Plane plane) Sets this plane from the given plane
void | set(Vector3 point, Vector3 normal) Sets the plane to the given point and normal.
void | set(Vector3 point1, Vector3 point2, Vector3 point3) Sets the plane normal and distance to the origin based on the three given points which are considered to be on the plane.
Plane.PlaneSide | testPoint(Vector3 point) Returns on which side the given point lies relative to the plane and its normal.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

normal

public final Vector3 normal

d

public float d
Constructor Detail

Plane

public Plane(Vector3 normal,
             float d)
Constructs a new plane based on the normal and distance to the origin.

Parameters:
normal - The plane normal
d - The distance to the origin

Plane

public Plane(Vector3 normal,
             Vector3 point)
Constructs a new plane based on the normal and a point on the plane.

Parameters:
normal - The normal
point - The point on the plane

Plane

public Plane(Vector3 point1,
             Vector3 point2,
             Vector3 point3)
Constructs a new plane out of the three given points that are considered to be on the plane. The normal is calculated via a cross product between (point1-point2)x(point2-point3)

Parameters:
point1 - The first point
point2 - The second point
point3 - The third point
Method Detail

set

public void set(Vector3 point1,
                Vector3 point2,
                Vector3 point3)
Sets the plane normal and distance to the origin based on the three given points which are considered to be on the plane. The normal is calculated via a cross product between (point1-point2)x(point2-point3)

Parameters:
point1 -
point2 -
point3 -

set

public void set(float nx,
                float ny,
                float nz,
                float d)
Sets the plane normal and distance

Parameters:
nx - normal x-component
ny - normal y-component
nz - normal z-component
d - distance to origin

distance

public float distance(Vector3 point)
Calculates the shortest signed distance between the plane and the given point.

Parameters:
point - The point
Returns:
the shortest signed distance between the plane and the point

testPoint

public Plane.PlaneSide testPoint(Vector3 point)
Returns on which side the given point lies relative to the plane and its normal. PlaneSide.Front refers to the side the plane normal points to.

Parameters:
point - The point
Returns:
The side the point lies relative to the plane

isFrontFacing

public boolean isFrontFacing(Vector3 direction)
Returns whether the plane is facing the direction vector. Think of the direction vector as the direction a camera looks in. This method will return true if the front side of the plane determined by its normal faces the camera.

Parameters:
direction - the direction
Returns:
whether the plane is front facing

getNormal

public Vector3 getNormal()
Returns:
The normal

getD

public float getD()
Returns:
The distance to the origin

set

public void set(Vector3 point,
                Vector3 normal)
Sets the plane to the given point and normal.

Parameters:
point - the point on the plane
normal - the normal of the plane

set

public void set(Plane plane)
Sets this plane from the given plane

Parameters:
plane - the plane

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.Plane (libgdx API)

Uses of Class
com.badlogic.gdx.math.Plane

Packages that use Plane
com.badlogic.gdx.math

Uses of Plane in com.badlogic.gdx.math

Fields in com.badlogic.gdx.math with type parameters of type Plane
protected  java.util.List<Plane> Frustum.planes

Methods in com.badlogic.gdx.math that return types with arguments of type Plane
 java.util.List<Plane> Frustum.getPlanes()

Methods in com.badlogic.gdx.math with parameters of type Plane
void | Frustum.addPlane(Plane plane) Adds a new Plane to the frustum
static boolean | Intersector.intersectRayPlane(Ray ray, Plane plane, Vector3 intersection) Intersects a Ray and a Plane.
static boolean | Intersector.intersectSegmentPlane(Vector3 start, Vector3 end, Plane plane, Vector3 intersection)
void | Plane.set(Plane plane) Sets this plane from the given plane

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Plane.PlaneSide (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.math
Enum Plane.PlaneSide

java.lang.Object
    extended by  java.lang.Enum<Plane.PlaneSide>
        extended by  com.badlogic.gdx.math.Plane.PlaneSide
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Plane.PlaneSide>
Enclosing class:
Plane
public static enum Plane.PlaneSide
extends java.lang.Enum<Plane.PlaneSide>

Enum specifying on which side a point lies respective to the plane and it's normal. Front is the side to which the normal points.

Author:
mzechner

Enum Constant Summary
Back
Front
OnPlane
Method Summary
static Plane.PlaneSide | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Plane.PlaneSide[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

OnPlane

public static final Plane.PlaneSide OnPlane

Back

public static final Plane.PlaneSide Back

Front

public static final Plane.PlaneSide Front
Method Detail

values

public static Plane.PlaneSide[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Plane.PlaneSide c : Plane.PlaneSide.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Plane.PlaneSide valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.math.Plane.PlaneSide (libgdx API)

Uses of Class
com.badlogic.gdx.math.Plane.PlaneSide

Packages that use Plane.PlaneSide
com.badlogic.gdx.math

Uses of Plane.PlaneSide in com.badlogic.gdx.math

Methods in com.badlogic.gdx.math that return Plane.PlaneSide
Plane.PlaneSide | Plane.testPoint(Vector3 point) Returns on which side the given point lies relative to the plane and its normal.
static Plane.PlaneSide | Plane.PlaneSide.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Plane.PlaneSide[] | Plane.PlaneSide.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


PolygonShape (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class PolygonShape

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Shape
        extended by  com.badlogic.gdx.physics.box2d.PolygonShape

public class PolygonShape
extends Shape

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.Shape
Shape.Type
Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Shape
addr
Constructor Summary
 | PolygonShape() Constructs a new polygon
protected | PolygonShape(long addr)
Method Summary
Shape.Type | getType() Get the type of this shape.
void | getVertex(int index, Vector2 vertex) Returns the vertex at the given position.
int | getVertexCount()
void | set(Vector2[] vertices) Copy vertices.
void | setAsBox(float hx, float hy) Build vertices to represent an axis-aligned box.
void | setAsBox(float hx, float hy, Vector2 center, float angle) Build vertices to represent an oriented box.
void | setAsEdge(Vector2 v1, Vector2 v2) Set this as a single edge.
Methods inherited from class com.badlogic.gdx.physics.box2d.Shape
dispose, getRadius, jniGetType, setRadius
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PolygonShape

public PolygonShape()
Constructs a new polygon

PolygonShape

protected PolygonShape(long addr)
Method Detail

getType

public Shape.Type getType()
Get the type of this shape. You can use this to down cast to the concrete shape.

Specified by:
getType in class Shape
Returns:
the shape type.

set

public void set(Vector2[] vertices)
Copy vertices. This assumes the vertices define a convex polygon. It is assumed that the exterior is the the right of each edge.

setAsBox

public void setAsBox(float hx,
                     float hy)
Build vertices to represent an axis-aligned box.

Parameters:
hx - the half-width.
hy - the half-height.

setAsBox

public void setAsBox(float hx,
                     float hy,
                     Vector2 center,
                     float angle)
Build vertices to represent an oriented box.

Parameters:
hx - the half-width.
hy - the half-height.
center - the center of the box in local coordinates.
angle - the rotation of the box in local coordinates.

setAsEdge

public void setAsEdge(Vector2 v1,
                      Vector2 v2)
Set this as a single edge.

getVertexCount

public int getVertexCount()
Returns:
the number of vertices

getVertex

public void getVertex(int index,
                      Vector2 vertex)
Returns the vertex at the given position.

Parameters:
index - the index of the vertex 0 <= index < getVertexCount( )
vertex - vertex
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.PolygonShape (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.PolygonShape

No usage of com.badlogic.gdx.physics.box2d.PolygonShape

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Pool (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class Pool<T>

java.lang.Object
    extended by  com.badlogic.gdx.utils.Pool<T>
Type Parameters:
T - the type
public class Pool<T>
extends java.lang.Object

A pool implementation used for object instances that should get reused instead of being collected by the garbage collector. Note that you should not hold on to the references of objects from this Pool once they've been marked as free by calling free(Object).

Author:
mzechner

Nested Class Summary
static interface Pool.PoolObjectFactory<T>
Interface for an Object Factory to be used with this Pool
Constructor Summary
Pool(Pool.PoolObjectFactory<T> factory, int maxSize)
Method Summary
void | free(T object) Frees the given object and returns it to the pool.
T | newObject() Creates a new object either by taking it from the free object pool or by creating a new one if there are no free objects yet.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Pool

public Pool(Pool.PoolObjectFactory<T> factory,
            int maxSize)
Method Detail

newObject

public T newObject()
Creates a new object either by taking it from the free object pool or by creating a new one if there are no free objects yet.

Returns:
the object

free

public void free(T object)
Frees the given object and returns it to the pool.

Parameters:
object - the object
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.Pool (libgdx API)

Uses of Class
com.badlogic.gdx.utils.Pool

No usage of com.badlogic.gdx.utils.Pool

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Pool.PoolObjectFactory (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Interface Pool.PoolObjectFactory<T>

Type Parameters:
T - the type
Enclosing class:
Pool<T>
public static interface Pool.PoolObjectFactory<T>

Interface for an Object Factory to be used with this Pool

Author:
mzechner

Method Summary
 T createObject()

Method Detail

createObject

T createObject()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.utils.Pool.PoolObjectFactory (libgdx API)

Uses of Interface
com.badlogic.gdx.utils.Pool.PoolObjectFactory

Packages that use Pool.PoolObjectFactory
com.badlogic.gdx.utils

Uses of Pool.PoolObjectFactory in com.badlogic.gdx.utils

Constructors in com.badlogic.gdx.utils with parameters of type Pool.PoolObjectFactory
Pool(Pool.PoolObjectFactory<T> factory, int maxSize)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


PooledLinkedList (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.utils
Class PooledLinkedList<T>

java.lang.Object
    extended by  com.badlogic.gdx.utils.PooledLinkedList<T>

public class PooledLinkedList<T>
extends java.lang.Object

A simple linked list that pools its nodes. This is a highly specialized class used in a couple of 2D scene graph classes. I wouldn't use it if i was you :)

Author:
mzechner

Constructor Summary
PooledLinkedList(int maxPoolSize)
Method Summary
void | add(T object)
void | clear()
void | iter() Starts iterating over the lists items
static void | main(java.lang.String[] argv)
T | next() Gets the next item in the list
void | remove() Removs the current list item based on the iterator position.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PooledLinkedList

public PooledLinkedList(int maxPoolSize)
Method Detail

add

public void add(T object)

iter

public void iter()
Starts iterating over the lists items

next

public T next()
Gets the next item in the list

Returns:
the next item in the list or null if there are no more items

remove

public void remove()
Removs the current list item based on the iterator position.

main

public static void main(java.lang.String[] argv)

clear

public void clear()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.utils.PooledLinkedList (libgdx API)

Uses of Class
com.badlogic.gdx.utils.PooledLinkedList

Packages that use PooledLinkedList
com.badlogic.gdx.scenes.scene2d

Uses of PooledLinkedList in com.badlogic.gdx.scenes.scene2d

Fields in com.badlogic.gdx.scenes.scene2d declared as PooledLinkedList
protected  PooledLinkedList<Action> Actor.actions

Overview Package Class Use Tree Deprecated Index Help
libgdx API


PrismaticJoint (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class PrismaticJoint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
        extended by  com.badlogic.gdx.physics.box2d.joints.PrismaticJoint

public class PrismaticJoint
extends Joint

A prismatic joint. This joint provides one degree of freedom: translation along an axis fixed in body1. Relative rotation is prevented. You can use a joint limit to restrict the range of motion and a joint motor to drive the motion or to model joint friction.

Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Joint
addr, jointEdgeA, jointEdgeB
Constructor Summary
PrismaticJoint(World world, long addr)
Method Summary
void | enableLimit(boolean flag) Enable/disable the joint limit.
void | enableMotor(boolean flag) Enable/disable the joint motor.
float | getJointSpeed() Get the current joint translation speed, usually in meters per second.
float | getJointTranslation() Get the current joint translation, usually in meters.
float | getLowerLimit() Get the lower joint limit, usually in meters.
float | getMotorForce() Get the current motor force, usually in N.
float | getMotorSpeed() Get the motor speed, usually in meters per second.
float | getUpperLimit() Get the upper joint limit, usually in meters.
boolean | isLimitEnabled() Is the joint limit enabled?
boolean | isMotorEnabled() Is the joint motor enabled?
void | setLimits(float lower, float upper) Set the joint limits, usually in meters.
void | setMaxMotorForce(float force) Set the maximum motor force, usually in N.
void | setMotorSpeed(float speed) Set the motor speed, usually in meters per second.
Methods inherited from class com.badlogic.gdx.physics.box2d.Joint
getAnchorA, getAnchorB, getBodyA, getBodyB, getReactionForce, getReactionTorque, getType, isActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PrismaticJoint

public PrismaticJoint(World world,
                      long addr)
Method Detail

getJointTranslation

public float getJointTranslation()
Get the current joint translation, usually in meters.

getJointSpeed

public float getJointSpeed()
Get the current joint translation speed, usually in meters per second.

isLimitEnabled

public boolean isLimitEnabled()
Is the joint limit enabled?

enableLimit

public void enableLimit(boolean flag)
Enable/disable the joint limit.

getLowerLimit

public float getLowerLimit()
Get the lower joint limit, usually in meters.

getUpperLimit

public float getUpperLimit()
Get the upper joint limit, usually in meters.

setLimits

public void setLimits(float lower,
                      float upper)
Set the joint limits, usually in meters.

isMotorEnabled

public boolean isMotorEnabled()
Is the joint motor enabled?

enableMotor

public void enableMotor(boolean flag)
Enable/disable the joint motor.

setMotorSpeed

public void setMotorSpeed(float speed)
Set the motor speed, usually in meters per second.

getMotorSpeed

public float getMotorSpeed()
Get the motor speed, usually in meters per second.

setMaxMotorForce

public void setMaxMotorForce(float force)
Set the maximum motor force, usually in N.

getMotorForce

public float getMotorForce()
Get the current motor force, usually in N.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.PrismaticJoint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.PrismaticJoint

No usage of com.badlogic.gdx.physics.box2d.joints.PrismaticJoint

Overview Package Class Use Tree Deprecated Index Help
libgdx API


PrismaticJointDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class PrismaticJointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
        extended by  com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef

public class PrismaticJointDef
extends JointDef

Prismatic joint definition. This requires defining a line of motion using an axis and an anchor point. The definition uses local anchor points and a local axis so that the initial configuration can violate the constraint slightly. The joint translation is zero when the local anchor points coincide in world space. Using local anchors and a local axis helps when saving and loading a game.

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType
Field Summary
boolean | enableLimit Enable/disable the joint limit.
boolean | enableMotor Enable/disable the joint motor.
Vector2 | localAnchorA The local anchor point relative to body1's origin.
Vector2 | localAnchorB The local anchor point relative to body2's origin.
Vector2 | localAxis1 The local translation axis in body1.
float | lowerTranslation The lower translation limit, usually in meters.
float | maxMotorForce The maximum motor torque, usually in N-m.
float | motorSpeed The desired motor speed in radians per second.
float | referenceAngle The constrained angle between the bodies: body2_angle - body1_angle.
float | upperTranslation The upper translation limit, usually in meters.
Fields inherited from class com.badlogic.gdx.physics.box2d.JointDef
bodyA, bodyB, collideConnected, type
Constructor Summary
PrismaticJointDef()
Method Summary
 void initialize(Body bodyA, Body bodyB, Vector2 anchor, Vector2 axis)
Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

localAnchorA

public final Vector2 localAnchorA
The local anchor point relative to body1's origin.

localAnchorB

public final Vector2 localAnchorB
The local anchor point relative to body2's origin.

localAxis1

public final Vector2 localAxis1
The local translation axis in body1.

referenceAngle

public float referenceAngle
The constrained angle between the bodies: body2_angle - body1_angle.

enableLimit

public boolean enableLimit
Enable/disable the joint limit.

lowerTranslation

public float lowerTranslation
The lower translation limit, usually in meters.

upperTranslation

public float upperTranslation
The upper translation limit, usually in meters.

enableMotor

public boolean enableMotor
Enable/disable the joint motor.

maxMotorForce

public float maxMotorForce
The maximum motor torque, usually in N-m.

motorSpeed

public float motorSpeed
The desired motor speed in radians per second.

Constructor Detail

PrismaticJointDef

public PrismaticJointDef()
Method Detail

initialize

public void initialize(Body bodyA,
                       Body bodyB,
                       Vector2 anchor,
                       Vector2 axis)
Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef

No usage of com.badlogic.gdx.physics.box2d.joints.PrismaticJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


PulleyJoint (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class PulleyJoint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
        extended by  com.badlogic.gdx.physics.box2d.joints.PulleyJoint

public class PulleyJoint
extends Joint

The pulley joint is connected to two bodies and two fixed ground points. The pulley supports a ratio such that: length1 + ratio * length2 <= constant Yes, the force transmitted is scaled by the ratio. The pulley also enforces a maximum length limit on both sides. This is useful to prevent one side of the pulley hitting the top.

Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Joint
addr, jointEdgeA, jointEdgeB
Constructor Summary
PulleyJoint(World world, long addr)
Method Summary
Vector2 | getGroundAnchorA()
Vector2 | getGroundAnchorB()
float | getLength1() Get the current length of the segment attached to body1.
float | getLength2() Get the current length of the segment attached to body2.
float | getRatio() Get the pulley ratio.
Methods inherited from class com.badlogic.gdx.physics.box2d.Joint
getAnchorA, getAnchorB, getBodyA, getBodyB, getReactionForce, getReactionTorque, getType, isActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PulleyJoint

public PulleyJoint(World world,
                   long addr)
Method Detail

getGroundAnchorA

public Vector2 getGroundAnchorA()

getGroundAnchorB

public Vector2 getGroundAnchorB()

getLength1

public float getLength1()
Get the current length of the segment attached to body1.

getLength2

public float getLength2()
Get the current length of the segment attached to body2.

getRatio

public float getRatio()
Get the pulley ratio.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.PulleyJoint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.PulleyJoint

No usage of com.badlogic.gdx.physics.box2d.joints.PulleyJoint

Overview Package Class Use Tree Deprecated Index Help
libgdx API


PulleyJointDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class PulleyJointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
        extended by  com.badlogic.gdx.physics.box2d.joints.PulleyJointDef

public class PulleyJointDef
extends JointDef

Pulley joint definition. This requires two ground anchors, two dynamic body anchor points, max lengths for each side, and a pulley ratio.

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType
Field Summary
Vector2 | groundAnchorA The first ground anchor in world coordinates.
Vector2 | groundAnchorB The second ground anchor in world coordinates.
float | lengthA The a reference length for the segment attached to bodyA.
float | lengthB The a reference length for the segment attached to bodyB.
Vector2 | localAnchorA The local anchor point relative to bodyA's origin.
Vector2 | localAnchorB The local anchor point relative to bodyB's origin.
float | maxLengthA The maximum length of the segment attached to bodyA.
float | maxLengthB The maximum length of the segment attached to bodyB.
float | ratio The pulley ratio, used to simulate a block-and-tackle.
Fields inherited from class com.badlogic.gdx.physics.box2d.JointDef
bodyA, bodyB, collideConnected, type
Constructor Summary
PulleyJointDef()
Method Summary
 void initialize(Body bodyA, Body bodyB, Vector2 groundAnchorA, Vector2 groundAnchorB, Vector2 anchorA, Vector2 anchorB, float ratio)
Initialize the bodies, anchors, lengths, max lengths, and ratio using the world anchors.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

groundAnchorA

public final Vector2 groundAnchorA
The first ground anchor in world coordinates. This point never moves.

groundAnchorB

public final Vector2 groundAnchorB
The second ground anchor in world coordinates. This point never moves.

localAnchorA

public final Vector2 localAnchorA
The local anchor point relative to bodyA's origin.

localAnchorB

public final Vector2 localAnchorB
The local anchor point relative to bodyB's origin.

lengthA

public float lengthA
The a reference length for the segment attached to bodyA.

maxLengthA

public float maxLengthA
The maximum length of the segment attached to bodyA.

lengthB

public float lengthB
The a reference length for the segment attached to bodyB.

maxLengthB

public float maxLengthB
The maximum length of the segment attached to bodyB.

ratio

public float ratio
The pulley ratio, used to simulate a block-and-tackle.

Constructor Detail

PulleyJointDef

public PulleyJointDef()
Method Detail

initialize

public void initialize(Body bodyA,
                       Body bodyB,
                       Vector2 groundAnchorA,
                       Vector2 groundAnchorB,
                       Vector2 anchorA,
                       Vector2 anchorB,
                       float ratio)
Initialize the bodies, anchors, lengths, max lengths, and ratio using the world anchors.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.PulleyJointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.PulleyJointDef

No usage of com.badlogic.gdx.physics.box2d.joints.PulleyJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Quaternion (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class Quaternion

java.lang.Object
    extended by  com.badlogic.gdx.math.Quaternion
All Implemented Interfaces:
java.io.Serializable
public final class Quaternion
extends java.lang.Object
implements java.io.Serializable

A simple quaternion class. See http://en.wikipedia.org/wiki/Quaternion for more information.

Author:
badlogicgames@gmail.com
See Also:
Serialized Form

Field Summary
float | w
float | x
float | y
float | z
Constructor Summary
Quaternion(float x, float y, float z, float w)
Constructor, sets the four components of the quaternion.
Quaternion(Quaternion quaternion)
Constructor, sets the quaternion components from the given quaternion.
Quaternion(Vector3 axis, float angle)
Constructor, sets the quaternion from the given axis vector and the angle around that axis in degrees.
Method Summary
Quaternion | cpy()
float | len()
Quaternion | nor() Normalizes the quaternion.
Quaternion | set(float x, float y, float z, float w) Sets the components of the quaternion
Quaternion | set(Quaternion quaternion) Sets the quaternion components from the given quaternion.
Quaternion | set(Vector3 axis, float angle) Sets the quaternion components from the given axis and angle around that axis.
Quaternion | setEulerAngles(float yaw, float pitch, float roll) Sets the quaternion to the given euler angles.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

x

public float x

y

public float y

z

public float z

w

public float w
Constructor Detail

Quaternion

public Quaternion(float x,
                  float y,
                  float z,
                  float w)
Constructor, sets the four components of the quaternion.

Parameters:
x - The x-component
y - The y-component
z - The z-component
w - The w-component

Quaternion

public Quaternion(Quaternion quaternion)
Constructor, sets the quaternion components from the given quaternion.

Parameters:
quaternion - The quaternion to copy.

Quaternion

public Quaternion(Vector3 axis,
                  float angle)
Constructor, sets the quaternion from the given axis vector and the angle around that axis in degrees.

Parameters:
axis - The axis
angle - The angle in degrees.
Method Detail

set

public Quaternion set(float x,
                      float y,
                      float z,
                      float w)
Sets the components of the quaternion

Parameters:
x - The x-component
y - The y-component
z - The z-component
w - The w-component
Returns:
This quaternion for chaining

set

public Quaternion set(Quaternion quaternion)
Sets the quaternion components from the given quaternion.

Parameters:
quaternion - The quaternion.
Returns:
This quaternion for chaining.

set

public Quaternion set(Vector3 axis,
                      float angle)
Sets the quaternion components from the given axis and angle around that axis.

Parameters:
axis - The axis
angle - The angle in degrees
Returns:
This quaternion for chaining.

cpy

public Quaternion cpy()
Returns:
a copy of this quaternion

len

public float len()
Returns:
the euclidian length of this quaternion

nor

public Quaternion nor()
Normalizes the quaternion.

Returns:
This quaternion for chaining.

toString

public java.lang.String toString()

Overrides:
toString in class java.lang.Object

setEulerAngles

public Quaternion setEulerAngles(float yaw,
                                 float pitch,
                                 float roll)
Sets the quaternion to the given euler angles.

Parameters:
yaw - the yaw in degrees
pitch - the pitch in degress
roll - the roll in degess
Returns:
this quaternion
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.Quaternion (libgdx API)

Uses of Class
com.badlogic.gdx.math.Quaternion

Packages that use Quaternion
com.badlogic.gdx.math

Uses of Quaternion in com.badlogic.gdx.math

Methods in com.badlogic.gdx.math that return Quaternion
Quaternion | Quaternion.cpy()
Quaternion | Quaternion.nor() Normalizes the quaternion.
Quaternion | Quaternion.set(float x, float y, float z, float w) Sets the components of the quaternion
Quaternion | Quaternion.set(Quaternion quaternion) Sets the quaternion components from the given quaternion.
Quaternion | Quaternion.set(Vector3 axis, float angle) Sets the quaternion components from the given axis and angle around that axis.
Quaternion | Quaternion.setEulerAngles(float yaw, float pitch, float roll) Sets the quaternion to the given euler angles.

Methods in com.badlogic.gdx.math with parameters of type Quaternion
Matrix4 | Matrix4.set(Quaternion quaternion) Sets the matrix to a rotation matrix representing the quaternion.
Quaternion | Quaternion.set(Quaternion quaternion) Sets the quaternion components from the given quaternion.

Constructors in com.badlogic.gdx.math with parameters of type Quaternion
Matrix4(Quaternion quaternion)
Constructs a rotation matrix from the given Quaternion
Quaternion(Quaternion quaternion)
Constructor, sets the quaternion components from the given quaternion.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


QueryCallback (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Interface QueryCallback

public interface QueryCallback

Callback class for AABB queries.

Method Summary
 boolean reportFixture(Fixture fixture)
Called for each fixture found in the query AABB.

Method Detail

reportFixture

boolean reportFixture(Fixture fixture)
Called for each fixture found in the query AABB.

Returns:
false to terminate the query.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.physics.box2d.QueryCallback (libgdx API)

Uses of Interface
com.badlogic.gdx.physics.box2d.QueryCallback

Packages that use QueryCallback
com.badlogic.gdx.physics.box2d

Uses of QueryCallback in com.badlogic.gdx.physics.box2d

Methods in com.badlogic.gdx.physics.box2d with parameters of type QueryCallback
 void World.QueryAABB(QueryCallback callback, float lowerX, float lowerY, float upperX, float upperY)
Query the world for all fixtures that potentially overlap the provided AABB.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Ray (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math.collision
Class Ray

java.lang.Object
    extended by  com.badlogic.gdx.math.collision.Ray

public final class Ray
extends java.lang.Object

Encapsulates a ray having a starting position and a unit length direction.

Author:
badlogicgames@gmail.com

Field Summary
Vector3 | direction
Vector3 | origin
Constructor Summary
Ray(Vector3 origin, Vector3 direction)
Constructor, sets the starting position of the ray and the direction.
Method Summary
Ray | cpy()
Vector3 | getEndPoint(float distance) Returns and endpoint given the distance.
Ray | mul(Matrix4 matrix) Multiplies the ray by the given matrix.
Ray | set(float x, float y, float z, float dx, float dy, float dz) Sets this ray from the given starting position and direction.
Ray | set(Ray ray) Sets the starting position and direction from the given ray
Ray | set(Vector3 origin, Vector3 direction) Sets the starting position and the direction of this ray.
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

origin

public final Vector3 origin

direction

public final Vector3 direction
Constructor Detail

Ray

public Ray(Vector3 origin,
           Vector3 direction)
Constructor, sets the starting position of the ray and the direction.

Parameters:
origin - The starting position
direction - The direction
Method Detail

cpy

public Ray cpy()
Returns:
a copy of this ray.

getEndPoint

public Vector3 getEndPoint(float distance)
Returns and endpoint given the distance. This is calculated as startpoint + distance * direction.

Parameters:
distance - The distance from the end point to the start point.
Returns:
The end point

mul

public Ray mul(Matrix4 matrix)
Multiplies the ray by the given matrix. Use this to transform a ray into another coordinate system.

Parameters:
matrix - The matrix
Returns:
This ray for chaining.

toString

public java.lang.String toString()

Overrides:
toString in class java.lang.Object

set

public Ray set(Vector3 origin,
               Vector3 direction)
Sets the starting position and the direction of this ray.

Parameters:
origin - The starting position
direction - The direction
Returns:
this ray for chaining

set

public Ray set(float x,
               float y,
               float z,
               float dx,
               float dy,
               float dz)
Sets this ray from the given starting position and direction.

Parameters:
x - The x-component of the starting position
y - The y-component of the starting position
z - The z-component of the starting position
dx - The x-component of the direction
dy - The y-component of the direction
dz - The z-component of the direction
Returns:
this ray for chaining

set

public Ray set(Ray ray)
Sets the starting position and direction from the given ray

Parameters:
ray - The ray
Returns:
This ray for chaining
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.collision.Ray (libgdx API)

Uses of Class
com.badlogic.gdx.math.collision.Ray

Packages that use Ray
com.badlogic.gdx.graphics
com.badlogic.gdx.math
com.badlogic.gdx.math.collision

Uses of Ray in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Ray
Ray | OrthographicCamera.getPickRay(int screenX, int screenY) Returns a ray in world space form the given screen coordinates.
Ray | PerspectiveCamera.getPickRay(int screenX, int screenY) Returns a ray in world space form the given screen coordinates.

Uses of Ray in com.badlogic.gdx.math

Methods in com.badlogic.gdx.math that return Ray
 Ray Frustum.calculatePickRay(float screen_width, float screen_height, float mouse_x, float mouse_y, Vector3 pos, Vector3 dir, Vector3 up)
Calculates the pick ray for the given window coordinates.

Methods in com.badlogic.gdx.math with parameters of type Ray
static boolean | Intersector.intersectRayBoundsFast(Ray ray, BoundingBox bounds) Quick check wheter the given Ray and BoundingBox intersect.
static boolean | Intersector.intersectRayPlane(Ray ray, Plane plane, Vector3 intersection) Intersects a Ray and a Plane.
static boolean | Intersector.intersectRaySphere(Ray ray, Vector3 center, float radius, Vector3 intersection) Intersects a Ray and a sphere, returning the intersection point in intersection.
static boolean | Intersector.intersectRayTriangle(Ray ray, Vector3 t1, Vector3 t2, Vector3 t3, Vector3 intersection) Intersect a Ray and a triangle, returning the intersection point in intersection.
static boolean | Intersector.intersectRayTriangles(Ray ray, float[] vertices, short[] indices, int vertexSize, Vector3 intersection) Intersects the given ray with list of triangles.
static boolean | Intersector.intersectRayTriangles(Ray ray, float[] triangles, Vector3 intersection) Intersects the given ray with list of triangles.
static boolean | Intersector.intersectRayTriangles(Ray ray, java.util.List<Vector3> triangles, Vector3 intersection) Intersects the given ray with list of triangles.

Uses of Ray in com.badlogic.gdx.math.collision

Methods in com.badlogic.gdx.math.collision that return Ray
Ray | Ray.cpy()
Ray | Ray.mul(Matrix4 matrix) Multiplies the ray by the given matrix.
Ray | Ray.set(float x, float y, float z, float dx, float dy, float dz) Sets this ray from the given starting position and direction.
Ray | Ray.set(Ray ray) Sets the starting position and direction from the given ray
Ray | Ray.set(Vector3 origin, Vector3 direction) Sets the starting position and the direction of this ray.

Methods in com.badlogic.gdx.math.collision with parameters of type Ray
 Ray Ray.set(Ray ray)
Sets the starting position and direction from the given ray

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Rectangle (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class Rectangle

java.lang.Object
    extended by  com.badlogic.gdx.math.Rectangle

public final class Rectangle
extends java.lang.Object

Encapsulates a 2D rectangle defined by it's bottom corner point and its extends in x (width) and y (height).

Author:
badlogicgames@gmail.com

Constructor Summary
Rectangle()
Constructs a new rectangle with all values set to zero
Rectangle(float x, float y, float width, float height)
Constructs a new rectangle with the given corner point in the bottom left and dimensions.
Rectangle(Rectangle rect)
Constructs a rectangle based on the given rectangle
Method Summary
float | getHeight()
float | getWidth()
float | getX()
float | getY()
void | setHeight(float height) Sets the height of this rectangle
void | setWidth(float width) Sets the width of this rectangle
void | setX(float x) Sets the x-coordinate of the bottom left corner
void | setY(float y) Sets the y-coordinate of the bottom left corner
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Rectangle

public Rectangle()
Constructs a new rectangle with all values set to zero

Rectangle

public Rectangle(float x,
                 float y,
                 float width,
                 float height)
Constructs a new rectangle with the given corner point in the bottom left and dimensions.

Parameters:
x - The corner point x-coordinate
y - The corner point y-coordinate
width - The width
height - The height

Rectangle

public Rectangle(Rectangle rect)
Constructs a rectangle based on the given rectangle

Parameters:
rect - The rectangle
Method Detail

getX

public float getX()
Returns:
the x-coordinate of the bottom left corner

setX

public void setX(float x)
Sets the x-coordinate of the bottom left corner

Parameters:
x - The x-coordinate

getY

public float getY()
Returns:
the y-coordinate of the bottom left corner

setY

public void setY(float y)
Sets the y-coordinate of the bottom left corner

Parameters:
y - The y-coordinate

getWidth

public float getWidth()
Returns:
the width

setWidth

public void setWidth(float width)
Sets the width of this rectangle

Parameters:
width - The width

getHeight

public float getHeight()
Returns:
the height

setHeight

public void setHeight(float height)
Sets the height of this rectangle

Parameters:
height - The height
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.Rectangle (libgdx API)

Uses of Class
com.badlogic.gdx.math.Rectangle

Packages that use Rectangle
com.badlogic.gdx.math

Uses of Rectangle in com.badlogic.gdx.math

Methods in com.badlogic.gdx.math with parameters of type Rectangle
static boolean Intersector.intersectRectangles(Rectangle a, Rectangle b)
Returns wheter the two rectangles intersect

Constructors in com.badlogic.gdx.math with parameters of type Rectangle
Rectangle(Rectangle rect)
Constructs a rectangle based on the given rectangle

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Repeat (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class Repeat

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.Repeat
All Implemented Interfaces:
Action
public class Repeat
extends java.lang.Object
implements Action

Field Summary
protected Action | action
protected int | finishedTimes
protected Actor | target
protected int | times
Constructor Summary
Repeat()
Method Summary
static Repeat | $(Action action, int times)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

action

protected Action action

target

protected Actor target

times

protected int times

finishedTimes

protected int finishedTimes
Constructor Detail

Repeat

public Repeat()
Method Detail

$

public static Repeat $(Action action,
                       int times)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.Repeat (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.Repeat

Packages that use Repeat
com.badlogic.gdx.scenes.scene2d.actions

Uses of Repeat in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return Repeat
static Repeat Repeat.$(Action action, int times)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


RevoluteJoint (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class RevoluteJoint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
        extended by  com.badlogic.gdx.physics.box2d.joints.RevoluteJoint

public class RevoluteJoint
extends Joint

A revolute joint constrains two bodies to share a common point while they are free to rotate about the point. The relative rotation about the shared point is the joint angle. You can limit the relative rotation with a joint limit that specifies a lower and upper angle. You can use a motor to drive the relative rotation about the shared point. A maximum motor torque is provided so that infinite forces are not generated.

Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Joint
addr, jointEdgeA, jointEdgeB
Constructor Summary
RevoluteJoint(World world, long addr)
Method Summary
void | enableLimit(boolean flag) Enable/disable the joint limit.
void | enableMotor(boolean flag) Enable/disable the joint motor.
float | getJointAngle() Get the current joint angle in radians.
float | getJointSpeed() Get the current joint angle speed in radians per second.
float | getLowerLimit() Get the lower joint limit in radians.
float | getMotorSpeed() Get the motor speed in radians per second.
float | getMotorTorque() Get the current motor torque, usually in N-m.
float | getUpperLimit() Get the upper joint limit in radians.
boolean | isLimitEnabled() Is the joint limit enabled?
boolean | isMotorEnabled() Is the joint motor enabled?
void | setLimits(float lower, float upper) Set the joint limits in radians.
void | setMaxMotorTorque(float torque) Set the maximum motor torque, usually in N-m.
void | setMotorSpeed(float speed) Set the motor speed in radians per second.
Methods inherited from class com.badlogic.gdx.physics.box2d.Joint
getAnchorA, getAnchorB, getBodyA, getBodyB, getReactionForce, getReactionTorque, getType, isActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RevoluteJoint

public RevoluteJoint(World world,
                     long addr)
Method Detail

getJointAngle

public float getJointAngle()
Get the current joint angle in radians.

getJointSpeed

public float getJointSpeed()
Get the current joint angle speed in radians per second.

isLimitEnabled

public boolean isLimitEnabled()
Is the joint limit enabled?

enableLimit

public void enableLimit(boolean flag)
Enable/disable the joint limit.

getLowerLimit

public float getLowerLimit()
Get the lower joint limit in radians.

getUpperLimit

public float getUpperLimit()
Get the upper joint limit in radians.

setLimits

public void setLimits(float lower,
                      float upper)
Set the joint limits in radians.

Parameters:
upper -

isMotorEnabled

public boolean isMotorEnabled()
Is the joint motor enabled?

enableMotor

public void enableMotor(boolean flag)
Enable/disable the joint motor.

setMotorSpeed

public void setMotorSpeed(float speed)
Set the motor speed in radians per second.

getMotorSpeed

public float getMotorSpeed()
Get the motor speed in radians per second.

setMaxMotorTorque

public void setMaxMotorTorque(float torque)
Set the maximum motor torque, usually in N-m.

getMotorTorque

public float getMotorTorque()
Get the current motor torque, usually in N-m.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.RevoluteJoint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.RevoluteJoint

No usage of com.badlogic.gdx.physics.box2d.joints.RevoluteJoint

Overview Package Class Use Tree Deprecated Index Help
libgdx API


RevoluteJointDef (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class RevoluteJointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
        extended by  com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef

public class RevoluteJointDef
extends JointDef

Revolute joint definition. This requires defining an anchor point where the bodies are joined. The definition uses local anchor points so that the initial configuration can violate the constraint slightly. You also need to specify the initial relative angle for joint limits. This helps when saving and loading a game. The local anchor points are measured from the body's origin rather than the center of mass because: 1. you might not know where the center of mass will be. 2. if you add/remove shapes from a body and recompute the mass, the joints will be broken.

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType
Field Summary
boolean | enableLimit A flag to enable joint limits.
boolean | enableMotor A flag to enable the joint motor.
Vector2 | localAnchorA The local anchor point relative to body1's origin.
Vector2 | localAnchorB The local anchor point relative to body2's origin.
float | lowerAngle The lower angle for the joint limit (radians).
float | maxMotorTorque The maximum motor torque used to achieve the desired motor speed.
float | motorSpeed The desired motor speed.
float | referenceAngle The body2 angle minus body1 angle in the reference state (radians).
float | upperAngle The upper angle for the joint limit (radians).
Fields inherited from class com.badlogic.gdx.physics.box2d.JointDef
bodyA, bodyB, collideConnected, type
Constructor Summary
RevoluteJointDef()
Method Summary
 void initialize(Body bodyA, Body bodyB, Vector2 anchor)
Initialize the bodies, anchors, and reference angle using a world anchor point.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

localAnchorA

public final Vector2 localAnchorA
The local anchor point relative to body1's origin.

localAnchorB

public final Vector2 localAnchorB
The local anchor point relative to body2's origin.

referenceAngle

public float referenceAngle
The body2 angle minus body1 angle in the reference state (radians).

enableLimit

public boolean enableLimit
A flag to enable joint limits.

lowerAngle

public float lowerAngle
The lower angle for the joint limit (radians).

upperAngle

public float upperAngle
The upper angle for the joint limit (radians).

enableMotor

public boolean enableMotor
A flag to enable the joint motor.

motorSpeed

public float motorSpeed
The desired motor speed. Usually in radians per second.

maxMotorTorque

public float maxMotorTorque
The maximum motor torque used to achieve the desired motor speed. Usually in N-m.

Constructor Detail

RevoluteJointDef

public RevoluteJointDef()
Method Detail

initialize

public void initialize(Body bodyA,
                       Body bodyB,
                       Vector2 anchor)
Initialize the bodies, anchors, and reference angle using a world anchor point.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef

No usage of com.badlogic.gdx.physics.box2d.joints.RevoluteJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


RotateBy (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class RotateBy

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.RotateBy
All Implemented Interfaces:
Action
public class RotateBy
extends java.lang.Object
implements Action

Field Summary
protected float | deltaRotation
protected boolean | done
protected float | duration
protected float | invDuration
protected float | rotation
protected float | startRotation
protected float | taken
protected Actor | target
Constructor Summary
RotateBy()
Method Summary
static RotateBy | $(float rotation, float duration)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

rotation

protected float rotation

startRotation

protected float startRotation

deltaRotation

protected float deltaRotation

duration

protected float duration

invDuration

protected float invDuration

taken

protected float taken

target

protected Actor target

done

protected boolean done
Constructor Detail

RotateBy

public RotateBy()
Method Detail

$

public static RotateBy $(float rotation,
                         float duration)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.RotateBy (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.RotateBy

Packages that use RotateBy
com.badlogic.gdx.scenes.scene2d.actions

Uses of RotateBy in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return RotateBy
static RotateBy RotateBy.$(float rotation, float duration)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


RotateTo (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class RotateTo

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.RotateTo
All Implemented Interfaces:
Action
public class RotateTo
extends java.lang.Object
implements Action

Field Summary
protected float | deltaRotation
protected boolean | done
protected float | duration
protected float | invDuration
protected float | rotation
protected float | startRotation
protected float | taken
protected Actor | target
Constructor Summary
RotateTo()
Method Summary
static RotateTo | $(float rotation, float duration)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

rotation

protected float rotation

startRotation

protected float startRotation

deltaRotation

protected float deltaRotation

duration

protected float duration

invDuration

protected float invDuration

taken

protected float taken

target

protected Actor target

done

protected boolean done
Constructor Detail

RotateTo

public RotateTo()
Method Detail

$

public static RotateTo $(float rotation,
                         float duration)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.RotateTo (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.RotateTo

Packages that use RotateTo
com.badlogic.gdx.scenes.scene2d.actions

Uses of RotateTo in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return RotateTo
static RotateTo RotateTo.$(float rotation, float duration)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ScaleTo (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class ScaleTo

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.ScaleTo
All Implemented Interfaces:
Action
public class ScaleTo
extends java.lang.Object
implements Action

Field Summary
protected float | deltaScaleX
protected float | deltaScaleY
protected boolean | done
protected float | duration
protected float | invDuration
protected float | scaleX
protected float | scaleY
protected float | startScaleX
protected float | startScaleY
protected float | taken
protected Actor | target
Constructor Summary
ScaleTo()
Method Summary
static ScaleTo | $(float scaleX, float scaleY, float duration)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

scaleX

protected float scaleX

scaleY

protected float scaleY

startScaleX

protected float startScaleX

startScaleY

protected float startScaleY

deltaScaleX

protected float deltaScaleX

deltaScaleY

protected float deltaScaleY

duration

protected float duration

invDuration

protected float invDuration

taken

protected float taken

target

protected Actor target

done

protected boolean done
Constructor Detail

ScaleTo

public ScaleTo()
Method Detail

$

public static ScaleTo $(float scaleX,
                        float scaleY,
                        float duration)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.ScaleTo (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.ScaleTo

Packages that use ScaleTo
com.badlogic.gdx.scenes.scene2d.actions

Uses of ScaleTo in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return ScaleTo
static ScaleTo ScaleTo.$(float scaleX, float scaleY, float duration)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Screen (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Interface Screen

public interface Screen

Represents one of many application screens, such as a main menu, a settings menu, the game screen and so on.

Note that dispose() is not called automatically.

See Also:
Game

Method Summary
void | dispose() Called when this screen should release all resources.
void | hide() Called when this screen is no longer the current screen for a Game.
void | pause()
void | render(float delta) Called when the screen should render itself.
void | resize(int width, int height)
void | resume()
void | show() Called when this screen becomes the current screen for a Game.

Method Detail

render

void render(float delta)
Called when the screen should render itself.

Parameters:
delta - The time in seconds since the last render.

resize

void resize(int width,
            int height)
See Also:
ApplicationListener.resize(int, int)

show

void show()
Called when this screen becomes the current screen for a Game.

hide

void hide()
Called when this screen is no longer the current screen for a Game.

pause

void pause()
See Also:
ApplicationListener.pause()

resume

void resume()
See Also:
ApplicationListener.resume()

dispose

void dispose()
Called when this screen should release all resources.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.Screen (libgdx API)

Uses of Interface
com.badlogic.gdx.Screen

Packages that use Screen
com.badlogic.gdx

Uses of Screen in com.badlogic.gdx

Methods in com.badlogic.gdx that return Screen
 Screen Game.getScreen()

Methods in com.badlogic.gdx with parameters of type Screen
 void Game.setScreen(Screen screen)
Sets the current screen.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Segment (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math.collision
Class Segment

java.lang.Object
    extended by  com.badlogic.gdx.math.collision.Segment

public class Segment
extends java.lang.Object

A Segment is a line in 3-space having a staring and an ending position.

Author:
mzechner

Field Summary
Vector3 | a the starting position
Vector3 | b the ending position
Constructor Summary
Segment(float aX, float aY, float aZ, float bX, float bY, float bZ)
Constructs a new Segment from the two points given.
Segment(Vector3 a, Vector3 b)
Constructs a new Segment from the two points given.
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

a

public final Vector3 a
the starting position

b

public final Vector3 b
the ending position

Constructor Detail

Segment

public Segment(Vector3 a,
               Vector3 b)
Constructs a new Segment from the two points given.

Parameters:
a - the first point
b - the second point

Segment

public Segment(float aX,
               float aY,
               float aZ,
               float bX,
               float bY,
               float bZ)
Constructs a new Segment from the two points given.

Parameters:
aX - the x-coordinate of the first point
aY - the y-coordinate of the first point
aZ - the z-coordinate of the first point
bX - the x-coordinate of the second point
bY - the y-coordinate of the second point
bZ - the z-coordinate of the second point
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.collision.Segment (libgdx API)

Uses of Class
com.badlogic.gdx.math.collision.Segment

No usage of com.badlogic.gdx.math.collision.Segment

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Sequence (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d.actions
Class Sequence

java.lang.Object
    extended by  com.badlogic.gdx.scenes.scene2d.actions.Sequence
All Implemented Interfaces:
Action
public class Sequence
extends java.lang.Object
implements Action

Field Summary
protected java.util.List<Action> | actions
protected int | currAction
protected Actor | target
Constructor Summary
Sequence()
Method Summary
static Sequence | $(Action... actions)
void | act(float delta) Apply the action.
Action | copy() Creates a copy of this action.
void | finish() Called by the owner of the action when it can release all its resources, e.g.
boolean | isDone()
void | setTarget(Actor actor) Sets the Actor of this action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

actions

protected final java.util.List<Action> actions

target

protected Actor target

currAction

protected int currAction
Constructor Detail

Sequence

public Sequence()
Method Detail

$

public static Sequence $(Action... actions)

setTarget

public void setTarget(Actor actor)
Description copied from interface: Action
Sets the Actor of this action. Will be called when the Action is added to an Actor via Actor.action(Action) before any other call to this interface.

Specified by:
setTarget in interface Action
Parameters:
actor - the actor.

act

public void act(float delta)
Description copied from interface: Action
Apply the action.

Specified by:
act in interface Action
Parameters:
delta - delta time in seconds

isDone

public boolean isDone()
Specified by:
isDone in interface Action
Returns:
whether the action is done or not

finish

public void finish()
Description copied from interface: Action
Called by the owner of the action when it can release all its resources, e.g. put itself back into a pool.

Specified by:
finish in interface Action

copy

public Action copy()
Description copied from interface: Action
Creates a copy of this action. The action must be in a state independent of the original and one must be able to call Action.setTarget(Actor) on it without any side effects.

Specified by:
copy in interface Action
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.actions.Sequence (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.actions.Sequence

Packages that use Sequence
com.badlogic.gdx.scenes.scene2d.actions

Uses of Sequence in com.badlogic.gdx.scenes.scene2d.actions

Methods in com.badlogic.gdx.scenes.scene2d.actions that return Sequence
static Sequence Sequence.$(Action... actions)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Serialized Form (libgdx API)

Serialized Form

Package com.badlogic.gdx.backends.lwjgl

Class com.badlogic.gdx.backends.lwjgl.LwjglApplet extends java.applet.Applet implements Serializable

Serialized Fields

canvas

java.awt.Canvas canvas

app

LwjglApplication app
Package com.badlogic.gdx.math

Class com.badlogic.gdx.math.Quaternion extends java.lang.Object implements Serializable

serialVersionUID: -7661875440774897168L

Serialized Fields

x

float x

y

float y

z

float z

w

float w
Package com.badlogic.gdx.utils

Class com.badlogic.gdx.utils.GdxRuntimeException extends java.lang.RuntimeException implements Serializable

serialVersionUID: 6735854402467673117L

Package com.badlogic.gdx.utils.json

Class com.badlogic.gdx.utils.json.JSONException extends java.lang.Exception implements Serializable

serialVersionUID: 0L

Serialized Fields

cause

java.lang.Throwable cause

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ShaderProgram (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.glutils
Class ShaderProgram

java.lang.Object
    extended by  com.badlogic.gdx.graphics.glutils.ShaderProgram

public class ShaderProgram
extends java.lang.Object

A shader program encapsulates a vertex and fragment shader pair linked to form a shader program useable with OpenGL ES 2.0.

After construction a ShaderProgram can be used to draw Mesh. To make the GPU use a specific ShaderProgram the programs begin() method must be used which effectively binds the program.

When a ShaderProgram is bound one can set uniforms, vertex attributes and attributes as needed via the respective methods.

A ShaderProgram can be unbound with a call to end()

A ShaderProgram must be disposed via a call to dispose() when it is no longer needed

ShaderPrograms are managed. In case the OpenGL context is lost all shaders get invalidated and have to be reloaded. This happens on Android when a user switches to another application or receives an incoming call. Managed ShaderPrograms are automatically reloaded when the OpenGL context is recreated so you don't have to do this manually.

Author:
mzechner

Constructor Summary
ShaderProgram(java.lang.String vertexShader, java.lang.String fragmentShader)
Construcs a new JOglShaderProgram and immediatly compiles it.
Method Summary
void | begin() Makes OpenGL ES 2.0 use this vertex and fragment shader pair.
static void | clearAllShaderPrograms()
void | disableVertexAttribute(java.lang.String name) Disables the vertex attribute with the given name
void | dispose() Disposes all resources associated with this shader.
void | enableVertexAttribute(java.lang.String name) Enables the vertex attribute with the given name
void | end() Disables this shader.
java.lang.String | getLog()
static void | invalidateAllShaderPrograms() Invalidates all shaders so the next time they are used new handles are generated
boolean | isCompiled()
void | setAttributef(java.lang.String name, float value1, float value2, float value3, float value4) Sets the given attribute
void | setUniformf(java.lang.String name, float value) Sets the uniform with the given name.
void | setUniformf(java.lang.String name, float value1, float value2) Sets the uniform with the given name.
void | setUniformf(java.lang.String name, float value1, float value2, float value3) Sets the uniform with the given name.
void | setUniformf(java.lang.String name, float value1, float value2, float value3, float value4) Sets the uniform with the given name.
void | setUniformi(java.lang.String name, int value) Sets the uniform with the given name.
void | setUniformi(java.lang.String name, int value1, int value2) Sets the uniform with the given name.
void | setUniformi(java.lang.String name, int value1, int value2, int value3) Sets the uniform with the given name.
void | setUniformi(java.lang.String name, int value1, int value2, int value3, int value4) Sets the uniform with the given name.
void | setUniformMatrix(java.lang.String name, Matrix4 matrix) Sets the uniform matrix with the given name.
void | setVertexAttribute(java.lang.String name, int size, int type, boolean normalize, int stride, java.nio.FloatBuffer buffer) Sets the vertex attribute with the given name.
void | setVertexAttribute(java.lang.String name, int size, int type, boolean normalize, int stride, int offset) Sets the vertex attribute with the given name.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ShaderProgram

public ShaderProgram(java.lang.String vertexShader,
                     java.lang.String fragmentShader)
Construcs a new JOglShaderProgram and immediatly compiles it.

Parameters:
vertexShader - the vertex shader
fragmentShader - the fragment shader
Method Detail

getLog

public java.lang.String getLog()
Returns:
the log info for the shader compilation and program linking stage. Returns an empty string if the shader program compiled successfully.

isCompiled

public boolean isCompiled()
Returns:
whether this ShaderProgram compiled successfully.

setUniformi

public void setUniformi(java.lang.String name,
                        int value)
Sets the uniform with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the name of the uniform
value - the value

setUniformi

public void setUniformi(java.lang.String name,
                        int value1,
                        int value2)
Sets the uniform with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the name of the uniform
value1 - the first value
value2 - the second value

setUniformi

public void setUniformi(java.lang.String name,
                        int value1,
                        int value2,
                        int value3)
Sets the uniform with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the name of the uniform
value1 - the first value
value2 - the second value
value3 - the third value

setUniformi

public void setUniformi(java.lang.String name,
                        int value1,
                        int value2,
                        int value3,
                        int value4)
Sets the uniform with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the name of the uniform
value1 - the first value
value2 - the second value
value3 - the third value
value4 - the fourth value

setUniformf

public void setUniformf(java.lang.String name,
                        float value)
Sets the uniform with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the name of the uniform
value - the value

setUniformf

public void setUniformf(java.lang.String name,
                        float value1,
                        float value2)
Sets the uniform with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the name of the uniform
value1 - the first value
value2 - the second value

setUniformf

public void setUniformf(java.lang.String name,
                        float value1,
                        float value2,
                        float value3)
Sets the uniform with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the name of the uniform
value1 - the first value
value2 - the second value
value3 - the third value

setUniformf

public void setUniformf(java.lang.String name,
                        float value1,
                        float value2,
                        float value3,
                        float value4)
Sets the uniform with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the name of the uniform
value1 - the first value
value2 - the second value
value3 - the third value
value4 - the fourth value

setUniformMatrix

public void setUniformMatrix(java.lang.String name,
                             Matrix4 matrix)
Sets the uniform matrix with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the name of the uniform
matrix - the matrix

setVertexAttribute

public void setVertexAttribute(java.lang.String name,
                               int size,
                               int type,
                               boolean normalize,
                               int stride,
                               java.nio.FloatBuffer buffer)
Sets the vertex attribute with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the attribute name
size - the number of components, must be >= 1 and <= 4
type - the type, must be one of GL20.GL_BYTE, GL20.GL_UNSIGNED_BYTE, GL20.GL_SHORT, GL20.GL_UNSIGNED_SHORT,GL20.GL_FIXED, or GL20.GL_FLOAT. GL_FIXED will not work on the desktop
normalize - whether fixed point data should be normalized. Will not work on the desktop
stride - the stride in bytes between successive attributes
buffer - the buffer containing the vertex attributes.

setVertexAttribute

public void setVertexAttribute(java.lang.String name,
                               int size,
                               int type,
                               boolean normalize,
                               int stride,
                               int offset)
Sets the vertex attribute with the given name. Throws an IllegalArgumentException in case it is not called in between a begin()/end() block.

Parameters:
name - the attribute name
size - the number of components, must be >= 1 and <= 4
type - the type, must be one of GL20.GL_BYTE, GL20.GL_UNSIGNED_BYTE, GL20.GL_SHORT, GL20.GL_UNSIGNED_SHORT,GL20.GL_FIXED, or GL20.GL_FLOAT. GL_FIXED will not work on the desktop
normalize - whether fixed point data should be normalized. Will not work on the desktop
stride - the stride in bytes between successive attributes
offset - byte offset into the vertex buffer object bound to GL20.GL_ARRAY_BUFFER.

begin

public void begin()
Makes OpenGL ES 2.0 use this vertex and fragment shader pair. When you are done with this shader you have to call end().

end

public void end()
Disables this shader. Must be called when one is done with the shader. Don't mix it with dispose, that will release the shader resources.

dispose

public void dispose()
Disposes all resources associated with this shader. Must be called when the shader is no longer used.

disableVertexAttribute

public void disableVertexAttribute(java.lang.String name)
Disables the vertex attribute with the given name

Parameters:
name - the vertex attribute name

enableVertexAttribute

public void enableVertexAttribute(java.lang.String name)
Enables the vertex attribute with the given name

Parameters:
name - the vertex attribute name

invalidateAllShaderPrograms

public static void invalidateAllShaderPrograms()
Invalidates all shaders so the next time they are used new handles are generated

clearAllShaderPrograms

public static void clearAllShaderPrograms()

setAttributef

public void setAttributef(java.lang.String name,
                          float value1,
                          float value2,
                          float value3,
                          float value4)
Sets the given attribute

Parameters:
name - the name of the attribute
value1 - the first value
value2 - the second value
value3 - the third value
value4 - the fourth value
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.glutils.ShaderProgram (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.glutils.ShaderProgram

Packages that use ShaderProgram
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils

Uses of ShaderProgram in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics with parameters of type ShaderProgram
void | Mesh.bind(ShaderProgram shader) Binds the underlying VertexBufferObject and IndexBufferObject if indices where given.
void | Mesh.render(ShaderProgram shader, int primitiveType) Renders the mesh using the given primitive type.
void | Mesh.render(ShaderProgram shader, int primitiveType, int offset, int count) Renders the mesh using the given primitive type.
void | Mesh.unbind(ShaderProgram shader) Unbinds the underlying VertexBufferObject and IndexBufferObject is indices were given.

Constructors in com.badlogic.gdx.graphics with parameters of type ShaderProgram
SpriteCache(int size, ShaderProgram shader, boolean useIndices)
Creates a cache with the specified size and OpenGL ES 2.0 shader.

Uses of ShaderProgram in com.badlogic.gdx.graphics.glutils

Methods in com.badlogic.gdx.graphics.glutils with parameters of type ShaderProgram
void | VertexBufferObject.bind(ShaderProgram shader) Binds this VertexBufferObject for rendering via glDrawArrays or glDrawElements
void | VertexBufferObjectSubData.bind(ShaderProgram shader) Binds this VertexBufferObject for rendering via glDrawArrays or glDrawElements
void | VertexBufferObject.unbind(ShaderProgram shader) Unbinds this VertexBufferObject.
void | VertexBufferObjectSubData.unbind(ShaderProgram shader) Unbinds this VertexBufferObject.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Shape (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class Shape

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Shape
Direct Known Subclasses:
CircleShape, PolygonShape
public abstract class Shape
extends java.lang.Object

A shape is used for collision detection. You can create a shape however you like. Shapes used for simulation in b2World are created automatically when a b2Fixture is created. NOTE: YOU NEED TO DISPOSE SHAPES AFTER YOU NO LONGER USE THEM! E.g. after calling body.createFixture();

Author:
mzechner

Nested Class Summary
static class Shape.Type
Enum describing the type of a shape
Field Summary
protected  long addr
the address of the shape
Constructor Summary
Shape()
Method Summary
void | dispose() Needs to be called when the shape is no longer used, e.g.
float | getRadius() Returns the radius of this shape
abstract Shape.Type | getType() Get the type of this shape.
protected static int | jniGetType(long addr)
void | setRadius(float radius) Sets the radius of this shape
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

addr

protected long addr
the address of the shape

Constructor Detail

Shape

public Shape()
Method Detail

getType

public abstract Shape.Type getType()
Get the type of this shape. You can use this to down cast to the concrete shape.

Returns:
the shape type.

getRadius

public float getRadius()
Returns the radius of this shape

setRadius

public void setRadius(float radius)
Sets the radius of this shape

dispose

public void dispose()
Needs to be called when the shape is no longer used, e.g. after a fixture was created based on the shape.

jniGetType

protected static int jniGetType(long addr)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.Shape (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.Shape

Packages that use Shape
com.badlogic.gdx.physics.box2d

Uses of Shape in com.badlogic.gdx.physics.box2d

Subclasses of Shape in com.badlogic.gdx.physics.box2d
class | CircleShape A circle shape.
class | PolygonShape

Fields in com.badlogic.gdx.physics.box2d declared as Shape
protected Shape | Fixture.shape the shape, initialized lazy
Shape | FixtureDef.shape The shape, this must be set.

Methods in com.badlogic.gdx.physics.box2d that return Shape
 Shape Fixture.getShape()
Returns the shape of this fixture

Methods in com.badlogic.gdx.physics.box2d with parameters of type Shape
 Fixture Body.createFixture(Shape shape, float density)
Creates a fixture from a shape and attach it to this body.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Shape.Type (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.physics.box2d
Enum Shape.Type

java.lang.Object
    extended by  java.lang.Enum<Shape.Type>
        extended by  com.badlogic.gdx.physics.box2d.Shape.Type
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Shape.Type>
Enclosing class:
Shape
public static enum Shape.Type
extends java.lang.Enum<Shape.Type>

Enum describing the type of a shape

Author:
mzechner

Enum Constant Summary
Circle
Polygon
Method Summary
static Shape.Type | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Shape.Type[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

Circle

public static final Shape.Type Circle

Polygon

public static final Shape.Type Polygon
Method Detail

values

public static Shape.Type[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Shape.Type c : Shape.Type.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Shape.Type valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.Shape.Type (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.Shape.Type

Packages that use Shape.Type
com.badlogic.gdx.physics.box2d

Uses of Shape.Type in com.badlogic.gdx.physics.box2d

Methods in com.badlogic.gdx.physics.box2d that return Shape.Type
Shape.Type | CircleShape.getType() Get the type of this shape.
Shape.Type | Fixture.getType() Get the type of the child shape.
Shape.Type | PolygonShape.getType() Get the type of this shape.
abstract Shape.Type | Shape.getType() Get the type of this shape.
static Shape.Type | Shape.Type.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Shape.Type[] | Shape.Type.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Sound (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio
Interface Sound

public interface Sound

A Sound is a short audio clip that can be played numerous times in parallel. It's completely loaded into memory so only load small audio files. Call the dispose() method when you're done using the Sound.

Sound instances are created via a call to Audio.newSound(FileHandle).

Author:
badlogicgames@gmail.com

Method Summary
void | dispose() Releases all the resources.
void | play() Plays the sound, you can call this repeatedly to play the same sound a couple of times with a bit of lag introduced.
void | play(float volume) Plays the sound, you can call this repeatedly to play the same sound a couple of times with a bit of lag introduced.

Method Detail

play

void play()
Plays the sound, you can call this repeatedly to play the same sound a couple of times with a bit of lag introduced.

play

void play(float volume)
Plays the sound, you can call this repeatedly to play the same sound a couple of times with a bit of lag introduced.

Parameters:
volume - the volume in the range [0,1]

dispose

void dispose()
Releases all the resources.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.audio.Sound (libgdx API)

Uses of Interface
com.badlogic.gdx.audio.Sound

Packages that use Sound
com.badlogic.gdx

Uses of Sound in com.badlogic.gdx

Methods in com.badlogic.gdx that return Sound
 Sound Audio.newSound(FileHandle fileHandle)
Creates a new Sound which is used to play back audio effects such as gun shots or explosions.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Sphere (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math.collision
Class Sphere

java.lang.Object
    extended by  com.badlogic.gdx.math.collision.Sphere

public final class Sphere
extends java.lang.Object

Encapsulates a 3D sphere with a center and a radius

Author:
badlogicgames@gmail.com

Field Summary
Vector3 | center the center of the sphere
float | radius the radius of the sphere
Constructor Summary
Sphere(Vector3 center, float radius)
Constructs a sphere with the given center and radius
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

radius

public float radius
the radius of the sphere

center

public final Vector3 center
the center of the sphere

Constructor Detail

Sphere

public Sphere(Vector3 center,
              float radius)
Constructs a sphere with the given center and radius

Parameters:
center - The center
radius - The radius
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.collision.Sphere (libgdx API)

Uses of Class
com.badlogic.gdx.math.collision.Sphere

No usage of com.badlogic.gdx.math.collision.Sphere

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Sprite (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class Sprite

java.lang.Object
    extended by  com.badlogic.gdx.graphics.TextureRegion
        extended by  com.badlogic.gdx.graphics.Sprite

public class Sprite
extends TextureRegion

Holds the geometry, color, and texture information for drawing 2D sprites using SpriteBatch. A Sprite has a position and a size given as width and height. The position is relative to the origin of the coordinate system specified via SpriteBatch.begin() and the respective matrices. A Sprite is always rectangular and its position (x, y) are located in the bottom left corner of that rectangle. A Sprite also has an origin around which rotations and scaling are performed. The origin is given relative to the bottom left corner of the Sprite, its position.

Author:
mzechner, Nathan Sweet

Constructor Summary
Sprite()
Creates an uninitialized sprite.
Sprite(Sprite sprite)
Creates a sprite that is a copy in every way of the specified sprite.
Sprite(Texture texture)
Creates a sprite with width, height, and texture region equal to the size of the texture.
Sprite(Texture texture, int srcWidth, int srcHeight)
Creates a sprite with width, height, and texture region equal to the specified size.
Sprite(Texture texture, int srcX, int srcY, int srcWidth, int srcHeight)
Creates a sprite with width, height, and texture region equal to the specified size.
Sprite(TextureRegion region)
Sprite(TextureRegion region, int srcX, int srcY, int srcWidth, int srcHeight)
Creates a sprite with width, height, and texture region equal to the specified size, relative to specified sprite's texture region.
Method Summary
void | draw(SpriteBatch spriteBatch)
void | flip(boolean x, boolean y)
Color | getColor() Returns the color of this sprite.
float | getHeight()
float | getOriginX()
float | getOriginY()
float | getRotation()
float | getScaleX()
float | getScaleY()
float[] | getVertices() Returns the packed vertices, colors, and texture coordinates for this sprite.
float | getWidth()
float | getX()
float | getY()
void | rotate(float degrees) Sets the sprite's rotation relative to the current rotation.
void | rotate90(boolean clockwise) Rotates this sprite 90 degrees in-place by rotating the texture coordinates.
void | scale(float amount) Sets the sprite's scale relative to the current scale.
void | scroll(float xAmount, float yAmount) Offsets the region relative to the current region.
void | set(Sprite sprite)
void | setBounds(float x, float y, float width, float height) Sets the position and size of the sprite when drawn, before scaling and rotation are applied.
void | setColor(Color tint)
void | setColor(float r, float g, float b, float a)
void | setOrigin(float originX, float originY) Sets the origin in relation to the sprite's position for scaling and rotation.
void | setPosition(float x, float y) Sets the position where the sprite will be drawn.
void | setRegion(float u, float v, float u2, float v2)
void | setRotation(float degrees)
void | setScale(float scaleXY)
void | setScale(float scaleX, float scaleY)
void | setSize(float width, float height) Sets the size of the sprite when drawn, before scaling and rotation are applied.
void | setU(float u)
void | setU2(float u2)
void | setV(float v)
void | setV2(float v2)
void | translate(float xAmount, float yAmount) Sets the position relative to the current position where the sprite will be drawn.
Methods inherited from class com.badlogic.gdx.graphics.TextureRegion
getRegionHeight, getRegionWidth, getRegionX, getRegionY, getTexture, getU, getU2, getV, getV2, setRegion, setRegion, setRegion, setRegion, setRegionHeight, setRegionWidth, setRegionX, setRegionY, setTexture
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Sprite

public Sprite()
Creates an uninitialized sprite. The sprite will need a texture, texture region, bounds, and color set before it can be drawn.

Sprite

public Sprite(Texture texture)
Creates a sprite with width, height, and texture region equal to the size of the texture.

Sprite

public Sprite(Texture texture,
              int srcWidth,
              int srcHeight)
Creates a sprite with width, height, and texture region equal to the specified size. The texture region's upper left corner will be 0,0. * @param srcWidth The width of the texture region. May be negative to flip the sprite when drawn.

Parameters:
srcHeight - The height of the texture region. May be negative to flip the sprite when drawn.

Sprite

public Sprite(Texture texture,
              int srcX,
              int srcY,
              int srcWidth,
              int srcHeight)
Creates a sprite with width, height, and texture region equal to the specified size. * @param srcWidth The width of the texture region. May be negative to flip the sprite when drawn.

Parameters:
srcHeight - The height of the texture region. May be negative to flip the sprite when drawn.

Sprite

public Sprite(TextureRegion region)

Sprite

public Sprite(TextureRegion region,
              int srcX,
              int srcY,
              int srcWidth,
              int srcHeight)
Creates a sprite with width, height, and texture region equal to the specified size, relative to specified sprite's texture region. * @param srcWidth The width of the texture region. May be negative to flip the sprite when drawn.

Parameters:
srcHeight - The height of the texture region. May be negative to flip the sprite when drawn.

Sprite

public Sprite(Sprite sprite)
Creates a sprite that is a copy in every way of the specified sprite.

Method Detail

set

public void set(Sprite sprite)

setBounds

public void setBounds(float x,
                      float y,
                      float width,
                      float height)
Sets the position and size of the sprite when drawn, before scaling and rotation are applied. If origin, rotation, or scale are changed, it is slightly more efficient to set the bounds after those operations.

setSize

public void setSize(float width,
                    float height)
Sets the size of the sprite when drawn, before scaling and rotation are applied. If origin, rotation, or scale are changed, it is slightly more efficient to set the size after those operations. If both position and size are to be changed, it is better to use setBounds(float, float, float, float).

setPosition

public void setPosition(float x,
                        float y)
Sets the position where the sprite will be drawn. If origin, rotation, or scale are changed, it is slightly more efficient to set the position after those operations. If both position and size are to be changed, it is better to use setBounds(float, float, float, float).

translate

public void translate(float xAmount,
                      float yAmount)
Sets the position relative to the current position where the sprite will be drawn. If origin, rotation, or scale are changed, it is slightly more efficient to translate after those operations.

setColor

public void setColor(Color tint)

setColor

public void setColor(float r,
                     float g,
                     float b,
                     float a)

setOrigin

public void setOrigin(float originX,
                      float originY)
Sets the origin in relation to the sprite's position for scaling and rotation.

setRotation

public void setRotation(float degrees)

rotate

public void rotate(float degrees)
Sets the sprite's rotation relative to the current rotation.

rotate90

public void rotate90(boolean clockwise)
Rotates this sprite 90 degrees in-place by rotating the texture coordinates. This rotation is unaffected by setRotation(float) and rotate(float).

setScale

public void setScale(float scaleXY)

setScale

public void setScale(float scaleX,
                     float scaleY)

scale

public void scale(float amount)
Sets the sprite's scale relative to the current scale.

getVertices

public float[] getVertices()
Returns the packed vertices, colors, and texture coordinates for this sprite.

draw

public void draw(SpriteBatch spriteBatch)

getX

public float getX()

getY

public float getY()

getWidth

public float getWidth()

getHeight

public float getHeight()

getOriginX

public float getOriginX()

getOriginY

public float getOriginY()

getRotation

public float getRotation()

getScaleX

public float getScaleX()

getScaleY

public float getScaleY()

getColor

public Color getColor()
Returns the color of this sprite. Changing the returned color will have no affect, setColor(Color) or setColor(float, float, float, float) must be used.

setRegion

public void setRegion(float u,
                      float v,
                      float u2,
                      float v2)
Overrides:
setRegion in class TextureRegion

setU

public void setU(float u)
Overrides:
setU in class TextureRegion

setV

public void setV(float v)
Overrides:
setV in class TextureRegion

setU2

public void setU2(float u2)
Overrides:
setU2 in class TextureRegion

setV2

public void setV2(float v2)
Overrides:
setV2 in class TextureRegion

flip

public void flip(boolean x,
                 boolean y)
Overrides:
flip in class TextureRegion

scroll

public void scroll(float xAmount,
                   float yAmount)
Description copied from class: TextureRegion
Offsets the region relative to the current region. Generally the region's size should be the entire size of the texture in the direction(s) it is scrolled.

Overrides:
scroll in class TextureRegion
Parameters:
xAmount - The percentage to offset horizontally.
yAmount - The percentage to offset vertically.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.Sprite (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.Sprite

Packages that use Sprite
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.particles

Uses of Sprite in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Sprite
 Sprite TextureAtlas.getSprite(java.lang.String name)
Returns the first region found with the specified name as a sprite.

Methods in com.badlogic.gdx.graphics that return types with arguments of type Sprite
java.util.List<Sprite> | TextureAtlas.getSprites() Returns all regions in the atlas as sprites.
java.util.List<Sprite> | TextureAtlas.getSprites(java.lang.String name) Returns all regions with the specified name as sprites, ordered by smallest to largest index.

Methods in com.badlogic.gdx.graphics with parameters of type Sprite
void | SpriteCache.add(Sprite sprite) Adds the specified sprite to the cache.
void | Sprite.set(Sprite sprite)

Constructors in com.badlogic.gdx.graphics with parameters of type Sprite
Sprite(Sprite sprite)
Creates a sprite that is a copy in every way of the specified sprite.

Uses of Sprite in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles that return Sprite
 Sprite ParticleEmitter.getSprite()

Methods in com.badlogic.gdx.graphics.particles with parameters of type Sprite
 void ParticleEmitter.setSprite(Sprite sprite)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


SpriteBatch (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class SpriteBatch

java.lang.Object
    extended by  com.badlogic.gdx.graphics.SpriteBatch

public class SpriteBatch
extends java.lang.Object

A SpriteBatch is used to draw 2D rectangles that reference a texture (region). The class will batch the drawing commands and optimize them for processing by the GPU.

To draw something with a SpriteBatch one has to first call the begin() method which will setup appropriate render states. When you are done with drawing you have to call end() which will actually draw the things you specified.

All drawing commands of the SpriteBatch operate in screen coordinates. The screen coordinate system has an x-axis pointing to the right, an y-axis pointing upwards and the origin is in the lower left corner of the screen. You can also provide your own transformation and projection matrices if you so wish.

A SpriteBatch is managed. In case the OpenGL context is lost all OpenGL resources a SpriteBatch uses internally get invalidated. A context is lost when a user switches to another application or receives an incoming call on Android. A SpriteBatch will be automatically reloaded after the OpenGL context is restored.

A SpriteBatch is a pretty heavy object so you should only ever have one in your program.

A SpriteBatch works with OpenGL ES 1.x and 2.0. In the case of a 2.0 context it will use its own custom shader to draw all provided sprites. Specifying your own shader does not work (yet).

A SpriteBatch has to be disposed if it is no longer used.

Author:
mzechner

Field Summary
int | maxSpritesInBatch the maximum number of sprites rendered in one batch so far
int | renderCalls number of render calls
Constructor Summary
SpriteBatch()
Constructs a new SpriteBatch.
SpriteBatch(int size)
Constructs a new SpriteBatch.
SpriteBatch(int size, int buffers)
Constructs a new SpriteBatch.
Method Summary
void | begin() Sets up the SpriteBatch for drawing.
void | disableBlending() Disables blending for drawing sprites.
void | dispose() Disposes all resources associated with this SpriteBatch
void | draw(Texture texture, float[] spriteVertices, int offset, int length) Draws a rectangle using the given vertices.
void | draw(Texture texture, float x, float y) Draws a rectangle with the top left corner at x,y having the width and height of the texture.
void | draw(Texture texture, float x, float y, float width, float height, float u, float v, float u2, float v2) Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
void | draw(Texture texture, float x, float y, float originX, float originY, float width, float height, float scaleX, float scaleY, float rotation, int srcX, int srcY, int srcWidth, int srcHeight, boolean flipX, boolean flipY) Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
void | draw(Texture texture, float x, float y, float width, float height, int srcX, int srcY, int srcWidth, int srcHeight, boolean flipX, boolean flipY) Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
void | draw(Texture texture, float x, float y, int srcX, int srcY, int srcWidth, int srcHeight) Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
void | draw(TextureRegion region, float x, float y) Draws a rectangle with the top left corner at x,y having the width and height of the region.
void | draw(TextureRegion region, float x, float y, float width, float height) Draws a rectangle with the top left corner at x,y and stretching the region to cover the given width and height.
void | draw(TextureRegion region, float x, float y, float originX, float originY, float width, float height, float scaleX, float scaleY, float rotation) Draws a rectangle with the top left corner at x,y and stretching the region to cover the given width and height.
void | enableBlending() Enables blending for sprites
void | end() Finishes off rendering.
void | flush() Causes any pending sprites to be rendered, without ending the SpriteBatch.
Color | getColor()
Matrix4 | getProjectionMatrix() Returns the current projection matrix.
Matrix4 | getTransformMatrix() Returns the current transform matrix.
boolean | isBlendingEnabled()
void | setBlendFunction(int srcFunc, int dstFunc) Sets the blending function to be used when rendering sprites.
void | setColor(Color tint) Sets the color used to tint images when they are added to the SpriteBatch.
void | setColor(float color)
void | setColor(float r, float g, float b, float a)
void | setProjectionMatrix(Matrix4 projection) Sets the projection matrix to be used by this SpriteBatch.
void | setTransformMatrix(Matrix4 transform) Sets the transform matrix to be used by this SpriteBatch.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

renderCalls

public int renderCalls
number of render calls

maxSpritesInBatch

public int maxSpritesInBatch
the maximum number of sprites rendered in one batch so far

Constructor Detail

SpriteBatch

public SpriteBatch()
Constructs a new SpriteBatch. Sets the projection matrix to an orthographic projection with y-axis point upwards, x-axis point to the right and the origin being in the bottome left corner of the screen. The projection will be pixel perfect with respect to the screen resolution.

SpriteBatch

public SpriteBatch(int size)

Constructs a new SpriteBatch. Sets the projection matrix to an orthographic projection with y-axis point upwards, x-axis point to the right and the origin being in the bottome left corner of the screen. The projection will be pixel perfect with respect to the screen resolution.

The size parameter specifies the maximum size of a single batch in number of sprites

Parameters:
size - the batch size in number of sprites

SpriteBatch

public SpriteBatch(int size,
                   int buffers)

Constructs a new SpriteBatch. Sets the projection matrix to an orthographic projection with y-axis point upwards, x-axis point to the right and the origin being in the bottome left corner of the screen. The projection will be pixel perfect with respect to the screen resolution.

The size parameter specifies the maximum size of a single batch in number of sprites

Parameters:
size - the batch size in number of sprites
buffers - the number of buffers to use. only makes sense with VBOs. This is an expert function.
Method Detail

begin

public void begin()
Sets up the SpriteBatch for drawing. This will disable depth buffer testing and writting, culling and lighting. It enables blending and alpha testing. If you have more texture units enabled than the first one you have to disable them before calling this. Uses a screen coordinate system by default where everything is given in pixels. You can specify your own projection and modelview matrices via setProjectionMatrix(Matrix4) and setTransformMatrix(Matrix4).

end

public void end()
Finishes off rendering. Must always be called after a call to begin()

setColor

public void setColor(Color tint)
Sets the color used to tint images when they are added to the SpriteBatch. Default is Color.WHITE.

setColor

public void setColor(float r,
                     float g,
                     float b,
                     float a)
See Also:
setColor(Color)

setColor

public void setColor(float color)
See Also:
setColor(Color), Color.toFloatBits()

getColor

public Color getColor()

draw

public void draw(Texture texture,
                 float x,
                 float y,
                 float originX,
                 float originY,
                 float width,
                 float height,
                 float scaleX,
                 float scaleY,
                 float rotation,
                 int srcX,
                 int srcY,
                 int srcWidth,
                 int srcHeight,
                 boolean flipX,
                 boolean flipY)
Draws a rectangle with the top left corner at x,y having the given width and height in pixels. The rectangle is offset by originX, originY relative to the origin. Scale specifies the scaling factor by which the rectangle should be scaled around originX, originY. Rotation specifies the angle of counter clockwise rotation of the rectangle around originX, originY. The portion of the Texture given by srcX, srcY and srcWidth, srcHeight is used. These coordinates and sizes are given in texels. FlipX and flipY specify whether the texture portion should be fliped horizontally or vertically.

Parameters:
texture - the Texture
x - the x-coordinate in screen space
y - the y-coordinate in screen space
originX - the x-coordinate of the scaling and rotation origin relative to the screen space coordinates
originY - the y-coordinate of the scaling and rotation origin relative to the screen space coordinates
width - the width in pixels
height - the height in pixels
scaleX - the scale of the rectangle around originX/originY in x
scaleY - the scale of the rectangle around originX/originY in y
rotation - the angle of counter clockwise rotation of the rectangle around originX/originY
srcX - the x-coordinate in texel space
srcY - the y-coordinate in texel space
srcWidth - the source with in texels
srcHeight - the source height in texels
flipX - whether to flip the sprite horizontally
flipY - whether to flip the sprite vertically

draw

public void draw(Texture texture,
                 float x,
                 float y,
                 float width,
                 float height,
                 int srcX,
                 int srcY,
                 int srcWidth,
                 int srcHeight,
                 boolean flipX,
                 boolean flipY)
Draws a rectangle with the top left corner at x,y having the given width and height in pixels. The portion of the Texture given by srcX, srcY and srcWidth, srcHeight is used. These coordinates and sizes are given in texels. FlipX and flipY specify whether the texture portion should be fliped horizontally or vertically.

Parameters:
texture - the Texture
x - the x-coordinate in screen space
y - the y-coordinate in screen space
width - the width in pixels
height - the height in pixels
srcX - the x-coordinate in texel space
srcY - the y-coordinate in texel space
srcWidth - the source with in texels
srcHeight - the source height in texels
flipX - whether to flip the sprite horizontally
flipY - whether to flip the sprite vertically

draw

public void draw(Texture texture,
                 float x,
                 float y,
                 int srcX,
                 int srcY,
                 int srcWidth,
                 int srcHeight)
Draws a rectangle with the top left corner at x,y having the given width and height in pixels. The portion of the Texture given by srcX, srcY and srcWidth, srcHeight are used. These coordinates and sizes are given in texels.

Parameters:
texture - the Texture
x - the x-coordinate in screen space
y - the y-coordinate in screen space
srcX - the x-coordinate in texel space
srcY - the y-coordinate in texel space
srcWidth - the source with in texels
srcHeight - the source height in texels

draw

public void draw(Texture texture,
                 float x,
                 float y,
                 float width,
                 float height,
                 float u,
                 float v,
                 float u2,
                 float v2)
Draws a rectangle with the top left corner at x,y having the given width and height in pixels. The portion of the Texture given by u, v and u2, v2 are used. These coordinates and sizes are given in texture size percentage. The rectangle will have the given tint Color.

Parameters:
texture - the Texture
x - the x-coordinate in screen space
y - the y-coordinate in screen space
width - the width in pixels
height - the height in pixels

draw

public void draw(Texture texture,
                 float x,
                 float y)
Draws a rectangle with the top left corner at x,y having the width and height of the texture.

Parameters:
texture - the Texture
x - the x-coordinate in screen space
y - the y-coordinate in screen space

draw

public void draw(Texture texture,
                 float[] spriteVertices,
                 int offset,
                 int length)
Draws a rectangle using the given vertices. There must be 4 vertices, each made up of 5 elements in this order: x, y, color, u, v.

draw

public void draw(TextureRegion region,
                 float x,
                 float y)
Draws a rectangle with the top left corner at x,y having the width and height of the region.

draw

public void draw(TextureRegion region,
                 float x,
                 float y,
                 float width,
                 float height)
Draws a rectangle with the top left corner at x,y and stretching the region to cover the given width and height.

draw

public void draw(TextureRegion region,
                 float x,
                 float y,
                 float originX,
                 float originY,
                 float width,
                 float height,
                 float scaleX,
                 float scaleY,
                 float rotation)
Draws a rectangle with the top left corner at x,y and stretching the region to cover the given width and height. The rectangle is offset by originX, originY relative to the origin. Scale specifies the scaling factor by which the rectangle should be scaled around originX, originY. Rotation specifies the angle of counter clockwise rotation of the rectangle around originX, originY.

flush

public void flush()
Causes any pending sprites to be rendered, without ending the SpriteBatch.

disableBlending

public void disableBlending()
Disables blending for drawing sprites. Does not disable blending for text rendering

enableBlending

public void enableBlending()
Enables blending for sprites

setBlendFunction

public void setBlendFunction(int srcFunc,
                             int dstFunc)
Sets the blending function to be used when rendering sprites.

Parameters:
srcFunc - the source function, e.g. GL11.GL_SRC_ALPHA
dstFunc - the destination function, e.g. GL11.GL_ONE_MINUS_SRC_ALPHA

dispose

public void dispose()
Disposes all resources associated with this SpriteBatch

getProjectionMatrix

public Matrix4 getProjectionMatrix()
Returns the current projection matrix. Changing this will result in undefined behaviour.

Returns:
the currently set projection matrix

getTransformMatrix

public Matrix4 getTransformMatrix()
Returns the current transform matrix. Changing this will result in undefined behaviour.

Returns:
the currently set transform matrix

setProjectionMatrix

public void setProjectionMatrix(Matrix4 projection)
Sets the projection matrix to be used by this SpriteBatch. Can only be set outside a begin()/end() block.

Parameters:
projection - the projection matrix

setTransformMatrix

public void setTransformMatrix(Matrix4 transform)
Sets the transform matrix to be used by this SpriteBatch. Can only be set outside a begin()/end() block.

Parameters:
transform - the transform matrix

isBlendingEnabled

public boolean isBlendingEnabled()
Returns:
whether blending for sprites is enabled
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.SpriteBatch (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.SpriteBatch

Packages that use SpriteBatch
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.particles
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actors

Uses of SpriteBatch in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics with parameters of type SpriteBatch
void | BitmapFontCache.draw(SpriteBatch spriteBatch)
void | Sprite.draw(SpriteBatch spriteBatch)
BitmapFont.TextBounds | BitmapFont.draw(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y) Draws a string at the specified position and color.
BitmapFont.TextBounds | BitmapFont.draw(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, int start, int end) Draws a substring at the specified position.
BitmapFont.TextBounds | BitmapFont.drawMultiLine(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y) Draws a string, which may contain newlines (\n), at the specified position.
BitmapFont.TextBounds | BitmapFont.drawMultiLine(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float alignmentWidth, BitmapFont.HAlignment alignment) Draws a string, which may contain newlines (\n), at the specified position and alignment.
BitmapFont.TextBounds | BitmapFont.drawWrapped(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float wrapWidth) Draws a string, which may contain newlines (\n), with the specified position and color.
BitmapFont.TextBounds | BitmapFont.drawWrapped(SpriteBatch spriteBatch, java.lang.CharSequence str, float x, float y, float wrapWidth, BitmapFont.HAlignment alignment) Draws a string, which may contain newlines (\n), with the specified position and color.

Uses of SpriteBatch in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles with parameters of type SpriteBatch
void | ParticleEffect.draw(SpriteBatch spriteBatch, float delta)
void | ParticleEmitter.draw(SpriteBatch spriteBatch, float delta)

Uses of SpriteBatch in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as SpriteBatch
 SpriteBatch Box2DDebugRenderer.batch
a spritebatch and a font for text rendering

Uses of SpriteBatch in com.badlogic.gdx.scenes.scene2d

Methods in com.badlogic.gdx.scenes.scene2d that return SpriteBatch
 SpriteBatch Stage.getSpriteBatch()

Methods in com.badlogic.gdx.scenes.scene2d with parameters of type SpriteBatch
protected abstract void | Actor.render(SpriteBatch batch) Renders the Actor.
protected void | Group.render(SpriteBatch batch)

Uses of SpriteBatch in com.badlogic.gdx.scenes.scene2d.actors

Methods in com.badlogic.gdx.scenes.scene2d.actors with parameters of type SpriteBatch
protected void | Button.render(SpriteBatch batch)
protected void | Image.render(SpriteBatch batch)
protected void | Label.render(SpriteBatch batch)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


SpriteCache (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class SpriteCache

java.lang.Object
    extended by  com.badlogic.gdx.graphics.SpriteCache

public class SpriteCache
extends java.lang.Object

Draws 2D images, optimized for geometry that does not change. Sprites and/or textures are cached and given an ID, which can later be used for drawing. The size, color, and texture region for each cached image cannot be modified. This information is stored in video memory and does not have to be sent to the GPU each time it is drawn.

To cache sprites or textures, first call beginCache(), then call the appropriate add method to define the images. To complete the cache, call endCache() and store the returned cache ID.

To draw with SpriteCache, first call begin(), then call draw(int) with a cache ID. When SpriteCache drawing is complete, call end().

By default, SpriteCache draws using screen coordinates and uses an x-axis pointing to the right, an y-axis pointing upwards and the origin is the bottom left corner of the screen. The default transformation and projection matrices can be changed. If the screen is resized, the SpriteCache's matrices must be updated. For example:
cache.getProjectionMatrix().setToOrtho2D(0, 0, Gdx.graphics.getWidth(), Gdx.graphics.getHeight());

Note that SpriteCache does not manage blending. You will need to enable blending (Gdx.gl.glEnable(GL10.GL_BLEND);) and set the blend func as needed before or between calls to draw(int).

SpriteCache is managed. If the OpenGL context is lost and the restored, all OpenGL resources a SpriteCache uses internally are restored.

SpriteCache is a reasonably heavyweight object. Typically only one instance should be used for an entire application.

SpriteCache works with OpenGL ES 1.x and 2.0. For 2.0, it uses its own custom shader to draw.

SpriteCache must be disposed once it is no longer needed.

Author:
Nathan Sweet

Constructor Summary
SpriteCache()
Creates a cache that uses indexed geometry and can contain up to 1000 images.
SpriteCache(int size, boolean useIndices)
Creates a cache with the specified size, using a default shader if OpenGL ES 2.0 is being used.
SpriteCache(int size, ShaderProgram shader, boolean useIndices)
Creates a cache with the specified size and OpenGL ES 2.0 shader.
Method Summary
 void add(Sprite sprite)
Adds the specified sprite to the cache.
 void add(Texture texture, float[] vertices, int offset, int length)
Adds the specified vertices to the cache.
 void add(Texture texture, float x, float y)
Adds the specified texture to the cache.
 void add(Texture texture, float x, float y, float originX, float originY, float width, float height, float scaleX, float scaleY, float rotation, int srcX, int srcY, int srcWidth, int srcHeight, boolean flipX, boolean flipY)
Adds the specified texture to the cache.
 void add(Texture texture, float x, float y, float width, float height, int srcX, int srcY, int srcWidth, int srcHeight, boolean flipX, boolean flipY)
Adds the specified texture to the cache.
 void add(Texture texture, float x, float y, int srcWidth, int srcHeight, float u, float v, float u2, float v2, float color)
Adds the specified texture to the cache.
 void add(Texture texture, float x, float y, int srcX, int srcY, int srcWidth, int srcHeight)
Adds the specified texture to the cache.
 void add(TextureRegion region, float x, float y)
Adds the specified region to the cache.
 void add(TextureRegion region, float x, float y, float width, float height)
Adds the specified region to the cache.
 void add(TextureRegion region, float x, float y, float originX, float originY, float width, float height, float scaleX, float scaleY, float rotation)
Adds the specified region to the cache.
 void begin()
Prepares the OpenGL state for SpriteCache rendering.
 void beginCache()
Starts the definition of a new cache, allowing the add and endCache() methods to be called.
 void beginCache(int cacheID)
Starts the redefinition of an existing cache, allowing the add and endCache() methods to be called.
 void clear()
Invalidates all cache IDs and resets the SpriteCache so new caches can be added.
 void dispose()
Releases all resources held by this SpriteCache.
 void draw(int cacheID)
Draws all the images defined for the specified cache ID.
 void draw(int cacheID, int offset, int length)
Draws a subset of images defined for the specified cache ID.
 void end()
Completes rendering for this SpriteCache.f
 int endCache()
Ends the definition of a cache, returning the cache ID to be used with draw(int).
 Color getColor()
 Matrix4 getProjectionMatrix()
 Matrix4 getTransformMatrix()
 void setColor(Color tint)
Sets the color used to tint images when they are added to the SpriteCache.
 void setColor(float color)
 void setColor(float r, float g, float b, float a)
 void setProjectionMatrix(Matrix4 projection)
 void setTransformMatrix(Matrix4 transform)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SpriteCache

public SpriteCache()
Creates a cache that uses indexed geometry and can contain up to 1000 images.

SpriteCache

public SpriteCache(int size,
                   boolean useIndices)
Creates a cache with the specified size, using a default shader if OpenGL ES 2.0 is being used.

Parameters:
size - The maximum number of images this cache can hold. The memory required to hold the images is allocated up front.
useIndices - If true, indexed geometry will be used.

SpriteCache

public SpriteCache(int size,
                   ShaderProgram shader,
                   boolean useIndices)
Creates a cache with the specified size and OpenGL ES 2.0 shader.

Parameters:
size - The maximum number of images this cache can hold. The memory required to hold the images is allocated up front.
useIndices - If true, indexed geometry will be used.
Method Detail

setColor

public void setColor(Color tint)
Sets the color used to tint images when they are added to the SpriteCache. Default is Color.WHITE.

setColor

public void setColor(float r,
                     float g,
                     float b,
                     float a)
See Also:
setColor(Color)

setColor

public void setColor(float color)
See Also:
setColor(Color), Color.toFloatBits()

getColor

public Color getColor()

beginCache

public void beginCache()
Starts the definition of a new cache, allowing the add and endCache() methods to be called.

beginCache

public void beginCache(int cacheID)
Starts the redefinition of an existing cache, allowing the add and endCache() methods to be called. If this is not the last cache created, it cannot have more entries added to it than when it was first created. To do that, use clear() and then begin().

endCache

public int endCache()
Ends the definition of a cache, returning the cache ID to be used with draw(int).

clear

public void clear()
Invalidates all cache IDs and resets the SpriteCache so new caches can be added.

add

public void add(Texture texture,
                float[] vertices,
                int offset,
                int length)
Adds the specified vertices to the cache. Each vertex should have 5 elements, one for each of the attributes: x, y, color, u, and v. If indexed geometry is used, each image should be specified as 4 vertices, otherwise each image should be specified as 6 vertices.

add

public void add(Texture texture,
                float x,
                float y)
Adds the specified texture to the cache.

add

public void add(Texture texture,
                float x,
                float y,
                int srcWidth,
                int srcHeight,
                float u,
                float v,
                float u2,
                float v2,
                float color)
Adds the specified texture to the cache.

add

public void add(Texture texture,
                float x,
                float y,
                int srcX,
                int srcY,
                int srcWidth,
                int srcHeight)
Adds the specified texture to the cache.

add

public void add(Texture texture,
                float x,
                float y,
                float width,
                float height,
                int srcX,
                int srcY,
                int srcWidth,
                int srcHeight,
                boolean flipX,
                boolean flipY)
Adds the specified texture to the cache.

add

public void add(Texture texture,
                float x,
                float y,
                float originX,
                float originY,
                float width,
                float height,
                float scaleX,
                float scaleY,
                float rotation,
                int srcX,
                int srcY,
                int srcWidth,
                int srcHeight,
                boolean flipX,
                boolean flipY)
Adds the specified texture to the cache.

add

public void add(TextureRegion region,
                float x,
                float y)
Adds the specified region to the cache.

add

public void add(TextureRegion region,
                float x,
                float y,
                float width,
                float height)
Adds the specified region to the cache.

add

public void add(TextureRegion region,
                float x,
                float y,
                float originX,
                float originY,
                float width,
                float height,
                float scaleX,
                float scaleY,
                float rotation)
Adds the specified region to the cache.

add

public void add(Sprite sprite)
Adds the specified sprite to the cache.

begin

public void begin()
Prepares the OpenGL state for SpriteCache rendering.

end

public void end()
Completes rendering for this SpriteCache.f

draw

public void draw(int cacheID)
Draws all the images defined for the specified cache ID.

draw

public void draw(int cacheID,
                 int offset,
                 int length)
Draws a subset of images defined for the specified cache ID.

Parameters:
offset - The first image to render.
length - The number of images from the first image (inclusive) to render.

dispose

public void dispose()
Releases all resources held by this SpriteCache.

getProjectionMatrix

public Matrix4 getProjectionMatrix()

setProjectionMatrix

public void setProjectionMatrix(Matrix4 projection)

getTransformMatrix

public Matrix4 getTransformMatrix()

setTransformMatrix

public void setTransformMatrix(Matrix4 transform)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.SpriteCache (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.SpriteCache

No usage of com.badlogic.gdx.graphics.SpriteCache

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Stage (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.scenes.scene2d
Class Stage

java.lang.Object
    extended by  com.badlogic.gdx.InputAdapter
        extended by  com.badlogic.gdx.scenes.scene2d.Stage
All Implemented Interfaces:
InputProcessor
public class Stage
extends InputAdapter

A Stage is a container for Actors and handles distributing touch events, animating Actors and asking them to render themselves. A Stage is basically a 2D scenegraph with hierarchies of Actors.

A Stage object fills the whole screen. It has a width and height given in device independent pixels. It will create a projection matrix that maps this viewport to the given real screen resolution. If the stretched attribute is set to true then the viewport is enforced no matter the difference in aspect ratio between the stage object and the screen dimensions. In case stretch is disabled then the viewport is extended in the bigger screen dimensions.

Actors have a z-order which is equal to the order they were inserted into this Stage. Actors inserted later will be drawn on top of Actors added earlier. The same is true for touch events that will get distributed to later Actors first.

Author:
mzechner

Constructor Summary
Stage(float width, float height, boolean stretch)
Constructs a new Stage object with the given dimensions.
Method Summary
void | act(float delta) Calls the Actor.act(float) method of all contained Actors.
void | addActor(Actor actor) Adds an Actor to this stage
float | bottom()
float | centerX()
float | centerY()
void | dispose() Disposes the stage
Actor | findActor(java.lang.String name) Finds the Actor with the given name in the stage hierarchy.
java.util.List<Actor> | getActors()
java.util.List<Group> | getGroups()
Actor | getLastTouchedChild()
Group | getRoot()
SpriteBatch | getSpriteBatch()
java.lang.String | graphToString()
float | height()
Actor | hit(float x, float y) Returns the Actor intersecting with the point (x,y) in stage coordinates.
boolean | isStretched()
int | left()
void | render() Renders the stage
float | right()
void | setViewport(float width, float height, boolean strech) Sets the viewport dimensions in device independent pixels.
float | top()
void | toStageCoordinates(int x, int y, Vector2 out) Transforms the given screen coordinates to stage coordinates
boolean | touchDown(int x, int y, int pointer) Call this to distribute a touch down event to the stage.
boolean | touchDragged(int x, int y, int pointer) Call this to distribute a touch dragged event to the stage.
boolean | touchUp(int x, int y, int pointer) Call this to distribute a touch Up event to the stage.
float | width()
Methods inherited from class com.badlogic.gdx.InputAdapter
keyDown, keyTyped, keyUp
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Stage

public Stage(float width,
             float height,
             boolean stretch)

Constructs a new Stage object with the given dimensions. If the device resolution does not equal the Stage objects dimensions the stage object will setup a projection matrix to guarantee a fixed coordinate system. If stretch is disabled then the bigger dimension of the Stage will be increased to accomodate the actual device resolution.

Parameters:
width - the width of the viewport
height - the height of the viewport
stretch - whether to stretch the viewport to the real device resolution
Method Detail

setViewport

public void setViewport(float width,
                        float height,
                        boolean strech)
Sets the viewport dimensions in device independent pixels. If stretch is false and the viewport aspect ratio is not equal to the device ratio then the bigger dimension of the viewport will be extended (device independent pixels stay quardatic instead of getting stretched).

Parameters:
width - thew width of the viewport in device independent pixels
height - the height of the viewport in device independent pixels
strech - whether to stretch the viewport or not

width

public float width()
Returns:
the width of the stage in dips

height

public float height()
Returns:
the height of the stage in dips

left

public int left()
Returns:
the x-coordinate of the left edge of the stage in dips

right

public float right()
Returns:
the x-coordinate of the right edge of the stage in dips

top

public float top()
Returns:
the y-coordinate of the top edge of the stage in dips

bottom

public float bottom()
Returns:
the y-coordinate of the bottom edge of the stage in dips

centerX

public float centerX()
Returns:
the center x-coordinate of the stage in dips

centerY

public float centerY()
Returns:
the center y-coordinate of the stage in dips

isStretched

public boolean isStretched()
Returns:
whether the stage is stretched

findActor

public Actor findActor(java.lang.String name)
Finds the Actor with the given name in the stage hierarchy.

Parameters:
name -
Returns:
the Actor or null if it couldn't be found.

getActors

public java.util.List<Actor> getActors()
Returns:
all top level Actors

getGroups

public java.util.List<Group> getGroups()
Returns:
all top level Groups

touchDown

public boolean touchDown(int x,
                         int y,
                         int pointer)
Call this to distribute a touch down event to the stage.

Specified by:
touchDown in interface InputProcessor
Overrides:
touchDown in class InputAdapter
Parameters:
x - the x coordinate of the touch in screen coordinates
y - the y coordinate of the touch in screen coordinates
pointer - the pointer index
Returns:
whether an Actor in the scene processed the event or not

touchUp

public boolean touchUp(int x,
                       int y,
                       int pointer)
Call this to distribute a touch Up event to the stage.

Specified by:
touchUp in interface InputProcessor
Overrides:
touchUp in class InputAdapter
Parameters:
x - the x coordinate of the touch in screen coordinates
y - the y coordinate of the touch in screen coordinates
pointer - the pointer index
Returns:
whether an Actor in the scene processed the event or not

touchDragged

public boolean touchDragged(int x,
                            int y,
                            int pointer)
Call this to distribute a touch dragged event to the stage.

Specified by:
touchDragged in interface InputProcessor
Overrides:
touchDragged in class InputAdapter
Parameters:
x - the x coordinate of the touch in screen coordinates
y - the y coordinate of the touch in screen coordinates
pointer - the pointer index
Returns:
whether an Actor in the scene processed the event or not

act

public void act(float delta)
Calls the Actor.act(float) method of all contained Actors. This will advance any Actions active for an Actor.

Parameters:
delta - the delta time in seconds since the last invocation

render

public void render()
Renders the stage

dispose

public void dispose()
Disposes the stage

addActor

public void addActor(Actor actor)
Adds an Actor to this stage

Parameters:
actor - the Actor

graphToString

public java.lang.String graphToString()
Returns:
the Stage graph as a silly string

getRoot

public Group getRoot()
Returns:
the root Group of this Stage.

getSpriteBatch

public SpriteBatch getSpriteBatch()
Returns:
the SpriteBatch offers its Actors for rendering.

getLastTouchedChild

public Actor getLastTouchedChild()
Returns:
the Actor last hit by a touch event.

hit

public Actor hit(float x,
                 float y)
Returns the Actor intersecting with the point (x,y) in stage coordinates. Hit testing is performed in the order the Actors were inserted into the Stage, last inserted Actors being tested first. To get stage coordinates from screen coordinates use toStageCoordinates(int, int, Vector2).

Parameters:
x - the x-coordinate in screen coordinates
y - the y-coordinate in screen cordinates
Returns:
the hit Actor or null

toStageCoordinates

public void toStageCoordinates(int x,
                               int y,
                               Vector2 out)
Transforms the given screen coordinates to stage coordinates

Parameters:
x - the x-coordinate in screen coordinates
y - the y-coordinate in screen coordinates
out - the output Vector2.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.scenes.scene2d.Stage (libgdx API)

Uses of Class
com.badlogic.gdx.scenes.scene2d.Stage

No usage of com.badlogic.gdx.scenes.scene2d.Stage

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Texture (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Interface Texture

public interface Texture

A Texture wraps a standard OpenGL ES texture.

It is constructed by an Graphics via one of the following methods:

  • Graphics#newTexture(com.badlogic.gdx.files.FileHandle, TextureFilter, TextureFilter, TextureWrap, TextureWrap)
  • Graphics#newUnmanagedTexture(Pixmap, TextureFilter, TextureFilter, TextureWrap, TextureWrap)
  • Graphics#newUnmanagedTexture(int, int, com.badlogic.gdx.graphics.Pixmap.Format, TextureFilter, TextureFilter, TextureWrap, TextureWrap)

A Texture can be managed. If the OpenGL context is lost all managed textures get invalidated. This happens when a user switches to another application or receives an incoming call. Managed textures get reloaded automatically.

A Texture has to be bound via the bind() method in order for it to be applied to geometry. The texture will be bound to the currently active texture unit specified via GLCommon.glActiveTexture(int).

You can draw Pixmaps to a texture at any time. The changes will be automatically uploaded to texture memory. This is of course not extremely fast so use it with care. It also only works with unmanaged textures.

A Texture must be disposed when it is no longer used

Author:
badlogicgames@gmail.com

Nested Class Summary
static class | Texture.TextureFilter Texture filter enum
static class | Texture.TextureWrap Texture wrap enum
Method Summary
void | bind() Binds this texture.
void | dispose() Disposes all resources associated with the texture
void | draw(Pixmap pixmap, int x, int y) Draws the given Pixmap to the texture at position x, y.
int | getHeight()
int | getTextureObjectHandle()
int | getWidth()
boolean | isManaged()
void | setWrap(Texture.TextureWrap x, Texture.TextureWrap y)

Method Detail

bind

void bind()
Binds this texture. The texture will be bound to the currently active texture unit specified via GLCommon.glActiveTexture(int).

draw

void draw(Pixmap pixmap,
          int x,
          int y)
Draws the given Pixmap to the texture at position x, y. No clipping is performed so you have to make sure that you draw only inside the texture region.

Parameters:
pixmap - The Pixmap
x - The x coordinate in pixels
y - The y coordinate in pixels

getWidth

int getWidth()
Returns:
the width of the texture in pixels

getHeight

int getHeight()
Returns:
the height of the texture in pixels

isManaged

boolean isManaged()
Returns:
whether this texture is managed or not.

dispose

void dispose()
Disposes all resources associated with the texture

getTextureObjectHandle

int getTextureObjectHandle()
Returns:
the OpenGL texture object handle so you can change texture parameters.

setWrap

void setWrap(Texture.TextureWrap x,
             Texture.TextureWrap y)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.graphics.Texture (libgdx API)

Uses of Interface
com.badlogic.gdx.graphics.Texture

Packages that use Texture
com.badlogic.gdx
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils
com.badlogic.gdx.graphics.particles
com.badlogic.gdx.scenes.scene2d
com.badlogic.gdx.scenes.scene2d.actors

Uses of Texture in com.badlogic.gdx

Methods in com.badlogic.gdx that return Texture
Texture | Graphics.newTexture(FileHandle file, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture from the given FileHandle using the specified minification and magnification filter and texture wraps in u and v.
Texture | Graphics.newTexture(TextureData textureData, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture that loads its data from the given TextureData.
Texture | Graphics.newUnmanagedTexture(int width, int height, Pixmap.Format format, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture with the specified dimensions, minification and magnification filters and texture wraps in u and v.
Texture | Graphics.newUnmanagedTexture(Pixmap pixmap, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture from the given Pixmap using the specified minification and magnification filter and texture wraps in u and v.

Uses of Texture in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Texture
 Texture TextureRegion.getTexture()

Methods in com.badlogic.gdx.graphics with parameters of type Texture
void | SpriteCache.add(Texture texture, float[] vertices, int offset, int length) Adds the specified vertices to the cache.
void | SpriteCache.add(Texture texture, float x, float y) Adds the specified texture to the cache.
void | SpriteCache.add(Texture texture, float x, float y, float originX, float originY, float width, float height, float scaleX, float scaleY, float rotation, int srcX, int srcY, int srcWidth, int srcHeight, boolean flipX, boolean flipY) Adds the specified texture to the cache.
void | SpriteCache.add(Texture texture, float x, float y, float width, float height, int srcX, int srcY, int srcWidth, int srcHeight, boolean flipX, boolean flipY) Adds the specified texture to the cache.
void | SpriteCache.add(Texture texture, float x, float y, int srcWidth, int srcHeight, float u, float v, float u2, float v2, float color) Adds the specified texture to the cache.
void | SpriteCache.add(Texture texture, float x, float y, int srcX, int srcY, int srcWidth, int srcHeight) Adds the specified texture to the cache.
TextureAtlas.AtlasRegion | TextureAtlas.addRegion(java.lang.String name, Texture texture, int x, int y, int width, int height) Adds a region to the atlas.
void | SpriteBatch.draw(Texture texture, float[] spriteVertices, int offset, int length) Draws a rectangle using the given vertices.
void | SpriteBatch.draw(Texture texture, float x, float y) Draws a rectangle with the top left corner at x,y having the width and height of the texture.
void | SpriteBatch.draw(Texture texture, float x, float y, float width, float height, float u, float v, float u2, float v2) Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
void | SpriteBatch.draw(Texture texture, float x, float y, float originX, float originY, float width, float height, float scaleX, float scaleY, float rotation, int srcX, int srcY, int srcWidth, int srcHeight, boolean flipX, boolean flipY) Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
void | SpriteBatch.draw(Texture texture, float x, float y, float width, float height, int srcX, int srcY, int srcWidth, int srcHeight, boolean flipX, boolean flipY) Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
void | SpriteBatch.draw(Texture texture, float x, float y, int srcX, int srcY, int srcWidth, int srcHeight) Draws a rectangle with the top left corner at x,y having the given width and height in pixels.
void | TextureRegion.setRegion(Texture texture) Sets the texture and sets the coordinates to the size of the specified texture.
void | TextureRegion.setTexture(Texture texture)

Constructors in com.badlogic.gdx.graphics with parameters of type Texture
Sprite(Texture texture)
Creates a sprite with width, height, and texture region equal to the size of the texture.
Sprite(Texture texture, int srcWidth, int srcHeight)
Creates a sprite with width, height, and texture region equal to the specified size.
Sprite(Texture texture, int srcX, int srcY, int srcWidth, int srcHeight)
Creates a sprite with width, height, and texture region equal to the specified size.
TextureRegion(Texture texture)
Constructs a region the size of the specified texture.
TextureRegion(Texture texture, float u, float v, float u2, float v2)
TextureRegion(Texture texture, int x, int y, int width, int height)

Uses of Texture in com.badlogic.gdx.graphics.glutils

Methods in com.badlogic.gdx.graphics.glutils that return Texture
 Texture FrameBuffer.getColorBufferTexture()

Uses of Texture in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles that return Texture
protected  Texture ParticleEffect.loadTexture(FileHandle file)

Uses of Texture in com.badlogic.gdx.scenes.scene2d

Fields in com.badlogic.gdx.scenes.scene2d declared as Texture
static Texture Group.debugTexture

Uses of Texture in com.badlogic.gdx.scenes.scene2d.actors

Constructors in com.badlogic.gdx.scenes.scene2d.actors with parameters of type Texture
Button(java.lang.String name, Texture texture)
Creates a new Button instance with the given name, using the complete supplied texture for displaying the pressed and unpressed state of the button.
Image(java.lang.String name, Texture texture)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Texture.TextureFilter (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.graphics
Enum Texture.TextureFilter

java.lang.Object
    extended by  java.lang.Enum<Texture.TextureFilter>
        extended by  com.badlogic.gdx.graphics.Texture.TextureFilter
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Texture.TextureFilter>
Enclosing interface:
Texture
public static enum Texture.TextureFilter
extends java.lang.Enum<Texture.TextureFilter>

Texture filter enum

Author:
badlogicgames@gmail.com

Enum Constant Summary
Linear
MipMap
MipMapLinearLinear
MipMapLinearNearest
MipMapNearestLinear
MipMapNearestNearest
Nearest
Method Summary
static boolean | isMipMap(Texture.TextureFilter filter)
static Texture.TextureFilter | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Texture.TextureFilter[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

Nearest

public static final Texture.TextureFilter Nearest

Linear

public static final Texture.TextureFilter Linear

MipMap

public static final Texture.TextureFilter MipMap

MipMapNearestNearest

public static final Texture.TextureFilter MipMapNearestNearest

MipMapLinearNearest

public static final Texture.TextureFilter MipMapLinearNearest

MipMapNearestLinear

public static final Texture.TextureFilter MipMapNearestLinear

MipMapLinearLinear

public static final Texture.TextureFilter MipMapLinearLinear
Method Detail

values

public static Texture.TextureFilter[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Texture.TextureFilter c : Texture.TextureFilter.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Texture.TextureFilter valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

isMipMap

public static boolean isMipMap(Texture.TextureFilter filter)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.graphics.Texture.TextureFilter (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.Texture.TextureFilter

Packages that use Texture.TextureFilter
com.badlogic.gdx
com.badlogic.gdx.graphics

Uses of Texture.TextureFilter in com.badlogic.gdx

Methods in com.badlogic.gdx with parameters of type Texture.TextureFilter
Texture | Graphics.newTexture(FileHandle file, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture from the given FileHandle using the specified minification and magnification filter and texture wraps in u and v.
Texture | Graphics.newTexture(TextureData textureData, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture that loads its data from the given TextureData.
Texture | Graphics.newUnmanagedTexture(int width, int height, Pixmap.Format format, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture with the specified dimensions, minification and magnification filters and texture wraps in u and v.
Texture | Graphics.newUnmanagedTexture(Pixmap pixmap, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture from the given Pixmap using the specified minification and magnification filter and texture wraps in u and v.

Uses of Texture.TextureFilter in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Texture.TextureFilter
static Texture.TextureFilter | Texture.TextureFilter.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Texture.TextureFilter[] | Texture.TextureFilter.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.badlogic.gdx.graphics with parameters of type Texture.TextureFilter
static boolean Texture.TextureFilter.isMipMap(Texture.TextureFilter filter)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Texture.TextureWrap (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.badlogic.gdx.graphics
Enum Texture.TextureWrap

java.lang.Object
    extended by  java.lang.Enum<Texture.TextureWrap>
        extended by  com.badlogic.gdx.graphics.Texture.TextureWrap
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<Texture.TextureWrap>
Enclosing interface:
Texture
public static enum Texture.TextureWrap
extends java.lang.Enum<Texture.TextureWrap>

Texture wrap enum

Author:
badlogicgames@gmail.com

Enum Constant Summary
ClampToEdge
Repeat
Method Summary
static Texture.TextureWrap | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Texture.TextureWrap[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ClampToEdge

public static final Texture.TextureWrap ClampToEdge

Repeat

public static final Texture.TextureWrap Repeat
Method Detail

values

public static Texture.TextureWrap[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Texture.TextureWrap c : Texture.TextureWrap.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Texture.TextureWrap valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class com.badlogic.gdx.graphics.Texture.TextureWrap (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.Texture.TextureWrap

Packages that use Texture.TextureWrap
com.badlogic.gdx
com.badlogic.gdx.graphics

Uses of Texture.TextureWrap in com.badlogic.gdx

Methods in com.badlogic.gdx with parameters of type Texture.TextureWrap
Texture | Graphics.newTexture(FileHandle file, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture from the given FileHandle using the specified minification and magnification filter and texture wraps in u and v.
Texture | Graphics.newTexture(TextureData textureData, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture that loads its data from the given TextureData.
Texture | Graphics.newUnmanagedTexture(int width, int height, Pixmap.Format format, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture with the specified dimensions, minification and magnification filters and texture wraps in u and v.
Texture | Graphics.newUnmanagedTexture(Pixmap pixmap, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap) Creates a new Texture from the given Pixmap using the specified minification and magnification filter and texture wraps in u and v.

Uses of Texture.TextureWrap in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Texture.TextureWrap
static Texture.TextureWrap | Texture.TextureWrap.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static Texture.TextureWrap[] | Texture.TextureWrap.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.badlogic.gdx.graphics with parameters of type Texture.TextureWrap
 void Texture.setWrap(Texture.TextureWrap x, Texture.TextureWrap y)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


TextureAtlas (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class TextureAtlas

java.lang.Object
    extended by  com.badlogic.gdx.graphics.TextureAtlas

public class TextureAtlas
extends java.lang.Object

Loads images from texture atlases created by TexturePacker.

A TextureAtlas must be disposed to free up the resources consumed by the backing textures.

Author:
Nathan Sweet

Nested Class Summary
static class TextureAtlas.AtlasRegion
Describes the region of a packed image and provides extra information, such as the original image size before any whitespace was stripped.
Constructor Summary
TextureAtlas()
Creates an empty atlas to which regions can be added.
TextureAtlas(FileHandle imagesDir)
Loads a pack file named "pack" in the specified directory and also looks there for page images named in the pack file.
TextureAtlas(FileHandle imagesDir, boolean flip)
TextureAtlas(FileHandle packFile, FileHandle imagesDir)
TextureAtlas(FileHandle packFile, FileHandle imagesDir, boolean flip)
Method Summary
TextureAtlas.AtlasRegion | addRegion(java.lang.String name, Texture texture, int x, int y, int width, int height) Adds a region to the atlas.
TextureAtlas.AtlasRegion | addRegion(java.lang.String name, TextureRegion textureRegion) Adds a region to the atlas.
void | dispose() Releases all resources associated with this TextureAtlas instance.
TextureAtlas.AtlasRegion | getRegion(java.lang.String name) Returns the first region found with the specified name.
java.util.List<TextureAtlas.AtlasRegion> | getRegions() Returns all regions in the atlas.
java.util.List<TextureAtlas.AtlasRegion> | getRegions(java.lang.String name) Returns all regions with the specified name, ordered by smallest to largest index.
Sprite | getSprite(java.lang.String name) Returns the first region found with the specified name as a sprite.
java.util.List<Sprite> | getSprites() Returns all regions in the atlas as sprites.
java.util.List<Sprite> | getSprites(java.lang.String name) Returns all regions with the specified name as sprites, ordered by smallest to largest index.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextureAtlas

public TextureAtlas()
Creates an empty atlas to which regions can be added.

TextureAtlas

public TextureAtlas(FileHandle imagesDir)
Loads a pack file named "pack" in the specified directory and also looks there for page images named in the pack file.

TextureAtlas

public TextureAtlas(FileHandle imagesDir,
                    boolean flip)
Parameters:
flip - If true, all regions loaded will be flipped for use with a perspective where 0,0 is the upper left corner.
See Also:
TextureAtlas(FileHandle)

TextureAtlas

public TextureAtlas(FileHandle packFile,
                    FileHandle imagesDir)

TextureAtlas

public TextureAtlas(FileHandle packFile,
                    FileHandle imagesDir,
                    boolean flip)
Parameters:
flip - If true, all regions loaded will be flipped for use with a perspective where 0,0 is the upper left corner.
Method Detail

addRegion

public TextureAtlas.AtlasRegion addRegion(java.lang.String name,
                                          Texture texture,
                                          int x,
                                          int y,
                                          int width,
                                          int height)
Adds a region to the atlas. The specified texture will be disposed when the atlas is disposed.

addRegion

public TextureAtlas.AtlasRegion addRegion(java.lang.String name,
                                          TextureRegion textureRegion)
Adds a region to the atlas. The texture for the specified region will be disposed when the atlas is disposed.

getRegions

public java.util.List<TextureAtlas.AtlasRegion> getRegions()
Returns all regions in the atlas.

getRegion

public TextureAtlas.AtlasRegion getRegion(java.lang.String name)
Returns the first region found with the specified name. This method uses string comparison to find the region, so the result should be cached rather than calling this method multiple times.

Returns:
The region, or null.

getRegions

public java.util.List<TextureAtlas.AtlasRegion> getRegions(java.lang.String name)
Returns all regions with the specified name, ordered by smallest to largest index. This method uses string comparison to find the regions, so the result should be cached rather than calling this method multiple times.

getSprites

public java.util.List<Sprite> getSprites()
Returns all regions in the atlas as sprites. This method creates a new sprite for each region, so the result should be stored rather than calling this method multiple times.

See Also:
getSprite(String)

getSprite

public Sprite getSprite(java.lang.String name)
Returns the first region found with the specified name as a sprite. If whitespace was stripped from the region when it was packed, the sprite is automatically positioned as if whitespace had not been stripped. This method uses string comparison to find the region and constructs a new sprite, so the result should be cached rather than calling this method multiple times.

Returns:
The sprite, or null.

getSprites

public java.util.List<Sprite> getSprites(java.lang.String name)
Returns all regions with the specified name as sprites, ordered by smallest to largest index. This method uses string comparison to find the regions and constructs new sprites, so the result should be cached rather than calling this method multiple times.

See Also:
getSprite(String)

dispose

public void dispose()
Releases all resources associated with this TextureAtlas instance. This releases all the textures backing all TextureRegions and Sprites, which should no longer be used after calling dispose.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.TextureAtlas (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.TextureAtlas

Packages that use TextureAtlas
com.badlogic.gdx.graphics.particles

Uses of TextureAtlas in com.badlogic.gdx.graphics.particles

Methods in com.badlogic.gdx.graphics.particles with parameters of type TextureAtlas
void | ParticleEffect.load(FileHandle effectFile, TextureAtlas atlas)
void | ParticleEffect.loadEmitterImages(TextureAtlas atlas)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


TextureAtlas.AtlasRegion (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class TextureAtlas.AtlasRegion

java.lang.Object
    extended by  com.badlogic.gdx.graphics.TextureRegion
        extended by  com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion
Enclosing class:
TextureAtlas
public static class TextureAtlas.AtlasRegion
extends TextureRegion

Describes the region of a packed image and provides extra information, such as the original image size before any whitespace was stripped.

Field Summary
int | index The number at the end of the original image file name, or Integer.MAX_VALUE if none. When sprites are packed, if the original file name ends with a number, it is stored as the index and is not considered as part of the sprite's name.
java.lang.String | name The name of the original image file, with any trailing numbers or special flags removed.
float | offsetX The offset from the left of the original image to the left of the packed image, after whitespace was removed for packing.
float | offsetY The offset from the bottom of the original image to the bottom of the packed image, after whitespace was removed for packing.
int | originalHeight The height of the image, before whitespace was removed for packing.
int | originalWidth The width of the image, before whitespace was removed for packing.
int | packedHeight The height of the image, after whitespace was removed for packing.
int | packedWidth The width of the image, after whitespace was removed for packing.
boolean | rotate If true, the region has been rotated 90 degrees counter clockwise.
Method Summary
 void flip(boolean x, boolean y)
Methods inherited from class com.badlogic.gdx.graphics.TextureRegion
getRegionHeight, getRegionWidth, getRegionX, getRegionY, getTexture, getU, getU2, getV, getV2, scroll, setRegion, setRegion, setRegion, setRegion, setRegion, setRegionHeight, setRegionWidth, setRegionX, setRegionY, setTexture, setU, setU2, setV, setV2
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public int index
The number at the end of the original image file name, or Integer.MAX_VALUE if none.

When sprites are packed, if the original file name ends with a number, it is stored as the index and is not considered as part of the sprite's name. This is useful for keeping animation frames in order.

See Also:
TextureAtlas.getRegions(String)

name

public java.lang.String name
The name of the original image file, with any trailing numbers or special flags removed.

offsetX

public float offsetX
The offset from the left of the original image to the left of the packed image, after whitespace was removed for packing.

offsetY

public float offsetY
The offset from the bottom of the original image to the bottom of the packed image, after whitespace was removed for packing.

packedWidth

public int packedWidth
The width of the image, after whitespace was removed for packing.

packedHeight

public int packedHeight
The height of the image, after whitespace was removed for packing.

originalWidth

public int originalWidth
The width of the image, before whitespace was removed for packing.

originalHeight

public int originalHeight
The height of the image, before whitespace was removed for packing.

rotate

public boolean rotate
If true, the region has been rotated 90 degrees counter clockwise.

Method Detail

flip

public void flip(boolean x,
                 boolean y)
Overrides:
flip in class TextureRegion
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.TextureAtlas.AtlasRegion

Packages that use TextureAtlas.AtlasRegion
com.badlogic.gdx.graphics

Uses of TextureAtlas.AtlasRegion in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return TextureAtlas.AtlasRegion
TextureAtlas.AtlasRegion | TextureAtlas.addRegion(java.lang.String name, Texture texture, int x, int y, int width, int height) Adds a region to the atlas.
TextureAtlas.AtlasRegion | TextureAtlas.addRegion(java.lang.String name, TextureRegion textureRegion) Adds a region to the atlas.
TextureAtlas.AtlasRegion | TextureAtlas.getRegion(java.lang.String name) Returns the first region found with the specified name.

Methods in com.badlogic.gdx.graphics that return types with arguments of type TextureAtlas.AtlasRegion
java.util.List<TextureAtlas.AtlasRegion> | TextureAtlas.getRegions() Returns all regions in the atlas.
java.util.List<TextureAtlas.AtlasRegion> | TextureAtlas.getRegions(java.lang.String name) Returns all regions with the specified name, ordered by smallest to largest index.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


TextureData (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Interface TextureData

public interface TextureData

Loads image data for a texture. Used with newTexture, this allows custom image loading for managed textures. If the OpenGL context is lost, the TextureData will be asked to load again when the context is restored. The TextureData doesn't necessary need to keep the image data in memory between loads.

Method Summary
int | getHeight() Returns the height of the texture, which must be a power of two.
int | getWidth() Returns the width of the texture, which must be a power of two.
void | load() Loads the image data into the currently bound texture.

Method Detail

load

void load()
Loads the image data into the currently bound texture. Usually GLCommon.glTexImage2D(int, int, int, int, int, int, int, int, java.nio.Buffer) is used.

getWidth

int getWidth()
Returns the width of the texture, which must be a power of two. This will not be called before load().

getHeight

int getHeight()
Returns the height of the texture, which must be a power of two. This will not be called before load().

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.graphics.TextureData (libgdx API)

Uses of Interface
com.badlogic.gdx.graphics.TextureData

Packages that use TextureData
com.badlogic.gdx

Uses of TextureData in com.badlogic.gdx

Methods in com.badlogic.gdx with parameters of type TextureData
 Texture Graphics.newTexture(TextureData textureData, Texture.TextureFilter minFilter, Texture.TextureFilter magFilter, Texture.TextureWrap uWrap, Texture.TextureWrap vWrap)
Creates a new Texture that loads its data from the given TextureData.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


TextureRegion (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class TextureRegion

java.lang.Object
    extended by  com.badlogic.gdx.graphics.TextureRegion
Direct Known Subclasses:
Sprite, TextureAtlas.AtlasRegion
public class TextureRegion
extends java.lang.Object

Defines a rectangular area of a texture. The coordinate system used has its origin in the upper left corner with the x-axis pointing to the left and the y axis pointing downwards.

Author:
mzechner, Nathan Sweet

Constructor Summary
TextureRegion()
Constructs a region with no texture and no coordinates defined.
TextureRegion(Texture texture)
Constructs a region the size of the specified texture.
TextureRegion(Texture texture, float u, float v, float u2, float v2)
TextureRegion(Texture texture, int x, int y, int width, int height)
TextureRegion(TextureRegion region)
Constructs a region with the same texture and coordinates of the specified region.
TextureRegion(TextureRegion region, int x, int y, int width, int height)
Constructs a region with the same texture as the specified region and sets the coordinates relative to the specified region.
Method Summary
void | flip(boolean x, boolean y)
int | getRegionHeight() Returns the region's height.
int | getRegionWidth() Returns the region's width.
int | getRegionX()
int | getRegionY()
Texture | getTexture()
float | getU()
float | getU2()
float | getV()
float | getV2()
void | scroll(float xAmount, float yAmount) Offsets the region relative to the current region.
void | setRegion(float u, float v, float u2, float v2)
void | setRegion(int x, int y, int width, int height)
void | setRegion(Texture texture) Sets the texture and sets the coordinates to the size of the specified texture.
void | setRegion(TextureRegion region) Sets the texture and coordinates to the specified region.
void | setRegion(TextureRegion region, int x, int y, int width, int height) Sets the texture to that of the specified region and sets the coordinates relative to the specified region.
void | setRegionHeight(int height)
void | setRegionWidth(int width)
void | setRegionX(int x)
void | setRegionY(int y)
void | setTexture(Texture texture)
void | setU(float u)
void | setU2(float u2)
void | setV(float v)
void | setV2(float v2)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextureRegion

public TextureRegion()
Constructs a region with no texture and no coordinates defined.

TextureRegion

public TextureRegion(Texture texture)
Constructs a region the size of the specified texture.

TextureRegion

public TextureRegion(Texture texture,
                     int x,
                     int y,
                     int width,
                     int height)
Parameters:
width - The width of the texture region. May be negative to flip the sprite when drawn.
height - The height of the texture region. May be negative to flip the sprite when drawn.

TextureRegion

public TextureRegion(Texture texture,
                     float u,
                     float v,
                     float u2,
                     float v2)

TextureRegion

public TextureRegion(TextureRegion region)
Constructs a region with the same texture and coordinates of the specified region.

TextureRegion

public TextureRegion(TextureRegion region,
                     int x,
                     int y,
                     int width,
                     int height)
Constructs a region with the same texture as the specified region and sets the coordinates relative to the specified region.

Parameters:
width - The width of the texture region. May be negative to flip the sprite when drawn.
height - The height of the texture region. May be negative to flip the sprite when drawn.
Method Detail

setRegion

public void setRegion(Texture texture)
Sets the texture and sets the coordinates to the size of the specified texture.

setRegion

public void setRegion(int x,
                      int y,
                      int width,
                      int height)
Parameters:
width - The width of the texture region. May be negative to flip the sprite when drawn.
height - The height of the texture region. May be negative to flip the sprite when drawn.

setRegion

public void setRegion(float u,
                      float v,
                      float u2,
                      float v2)

setRegion

public void setRegion(TextureRegion region)
Sets the texture and coordinates to the specified region.

setRegion

public void setRegion(TextureRegion region,
                      int x,
                      int y,
                      int width,
                      int height)
Sets the texture to that of the specified region and sets the coordinates relative to the specified region.

getTexture

public Texture getTexture()

setTexture

public void setTexture(Texture texture)

getU

public float getU()

setU

public void setU(float u)

getV

public float getV()

setV

public void setV(float v)

getU2

public float getU2()

setU2

public void setU2(float u2)

getV2

public float getV2()

setV2

public void setV2(float v2)

getRegionX

public int getRegionX()

setRegionX

public void setRegionX(int x)

getRegionY

public int getRegionY()

setRegionY

public void setRegionY(int y)

getRegionWidth

public int getRegionWidth()
Returns the region's width. May be negative if the texture region is flipped horizontally.

setRegionWidth

public void setRegionWidth(int width)

getRegionHeight

public int getRegionHeight()
Returns the region's height. May be negative if the texture region is flipped horizontally.

setRegionHeight

public void setRegionHeight(int height)

flip

public void flip(boolean x,
                 boolean y)

scroll

public void scroll(float xAmount,
                   float yAmount)
Offsets the region relative to the current region. Generally the region's size should be the entire size of the texture in the direction(s) it is scrolled.

Parameters:
xAmount - The percentage to offset horizontally.
yAmount - The percentage to offset vertically.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.TextureRegion (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.TextureRegion

Packages that use TextureRegion
com.badlogic.gdx.graphics
com.badlogic.gdx.scenes.scene2d.actors

Uses of TextureRegion in com.badlogic.gdx.graphics

Subclasses of TextureRegion in com.badlogic.gdx.graphics
class | Sprite Holds the geometry, color, and texture information for drawing 2D sprites using SpriteBatch.
static class | TextureAtlas.AtlasRegion Describes the region of a packed image and provides extra information, such as the original image size before any whitespace was stripped.

Methods in com.badlogic.gdx.graphics that return TextureRegion
 TextureRegion BitmapFont.getRegion()

Methods in com.badlogic.gdx.graphics with parameters of type TextureRegion
void | SpriteCache.add(TextureRegion region, float x, float y) Adds the specified region to the cache.
void | SpriteCache.add(TextureRegion region, float x, float y, float width, float height) Adds the specified region to the cache.
void | SpriteCache.add(TextureRegion region, float x, float y, float originX, float originY, float width, float height, float scaleX, float scaleY, float rotation) Adds the specified region to the cache.
TextureAtlas.AtlasRegion | TextureAtlas.addRegion(java.lang.String name, TextureRegion textureRegion) Adds a region to the atlas.
void | SpriteBatch.draw(TextureRegion region, float x, float y) Draws a rectangle with the top left corner at x,y having the width and height of the region.
void | SpriteBatch.draw(TextureRegion region, float x, float y, float width, float height) Draws a rectangle with the top left corner at x,y and stretching the region to cover the given width and height.
void | SpriteBatch.draw(TextureRegion region, float x, float y, float originX, float originY, float width, float height, float scaleX, float scaleY, float rotation) Draws a rectangle with the top left corner at x,y and stretching the region to cover the given width and height.
void | TextureRegion.setRegion(TextureRegion region) Sets the texture and coordinates to the specified region.
void | TextureRegion.setRegion(TextureRegion region, int x, int y, int width, int height) Sets the texture to that of the specified region and sets the coordinates relative to the specified region.

Constructors in com.badlogic.gdx.graphics with parameters of type TextureRegion
BitmapFont(FileHandle fontFile, TextureRegion region, boolean flip)
Creates a BitmapFont with the glyphs relative to the specified region.
Sprite(TextureRegion region)
Sprite(TextureRegion region, int srcX, int srcY, int srcWidth, int srcHeight)
Creates a sprite with width, height, and texture region equal to the specified size, relative to specified sprite's texture region.
TextureRegion(TextureRegion region)
Constructs a region with the same texture and coordinates of the specified region.
TextureRegion(TextureRegion region, int x, int y, int width, int height)
Constructs a region with the same texture as the specified region and sets the coordinates relative to the specified region.

Uses of TextureRegion in com.badlogic.gdx.scenes.scene2d.actors

Fields in com.badlogic.gdx.scenes.scene2d.actors declared as TextureRegion
TextureRegion | Button.pressedRegion
TextureRegion | Image.region
TextureRegion | Button.unpressedRegion

Constructors in com.badlogic.gdx.scenes.scene2d.actors with parameters of type TextureRegion
Button(java.lang.String name, TextureRegion region)
Button(java.lang.String name, TextureRegion unpressedRegion, TextureRegion pressedRegion)
Image(java.lang.String name, TextureRegion region)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


ThresholdFunction (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.analysis
Class ThresholdFunction

java.lang.Object
    extended by  com.badlogic.gdx.audio.analysis.ThresholdFunction

public class ThresholdFunction
extends java.lang.Object

Calculates a threshold function based on the spectral flux.

Author:
badlogicgames@gmail.com

Constructor Summary
ThresholdFunction(int historySize, float multiplier)
Consturctor, sets the history size in number of spectra to take into account to calculate the average spectral flux at a specific position.
Method Summary
 java.util.List<java.lang.Float> calculate(java.util.List<java.lang.Float> spectralFlux)
Returns the threshold function for a given spectral flux function.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ThresholdFunction

public ThresholdFunction(int historySize,
                         float multiplier)
Consturctor, sets the history size in number of spectra to take into account to calculate the average spectral flux at a specific position. Also sets the multiplier to multiply the average with.

Parameters:
historySize - The history size.
multiplier - The average multiplier.
Method Detail

calculate

public java.util.List<java.lang.Float> calculate(java.util.List<java.lang.Float> spectralFlux)
Returns the threshold function for a given spectral flux function.

Returns:
The threshold function.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.audio.analysis.ThresholdFunction (libgdx API)

Uses of Class
com.badlogic.gdx.audio.analysis.ThresholdFunction

No usage of com.badlogic.gdx.audio.analysis.ThresholdFunction

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Transform (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class Transform

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Transform

public class Transform
extends java.lang.Object

Encodes a Box2D transform. We are lazy so we only store a 6 float wide array. First two floats are the position of the b2Transform struct. Next two floats are the b2Transform.R.col1 x and y coordinates. Final 2 floats are the b2Transform.R.col2 x and y coordinates;

Author:
mzechner

Field Summary
static int | COL1_X
static int | COL1_Y
static int | COL2_X
static int | COL2_Y
static int | POS_X
static int | POS_Y
float[] | vals
Constructor Summary
Transform()
Transform(Vector2 position, float angle)
Constructs a new Transform instance with the given position and angle
Method Summary
Vector2 | getPosition()
Vector2 | mul(Vector2 v) Transforms the given vector by this transform
void | setPosition(Vector2 pos) Sets the position of this transform
void | setRotation(float angle) Sets the rotation of this transform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

POS_X

public static final int POS_X
See Also:
Constant Field Values

POS_Y

public static final int POS_Y
See Also:
Constant Field Values

COL1_X

public static final int COL1_X
See Also:
Constant Field Values

COL1_Y

public static final int COL1_Y
See Also:
Constant Field Values

COL2_X

public static final int COL2_X
See Also:
Constant Field Values

COL2_Y

public static final int COL2_Y
See Also:
Constant Field Values

vals

public float[] vals
Constructor Detail

Transform

public Transform()

Transform

public Transform(Vector2 position,
                 float angle)
Constructs a new Transform instance with the given position and angle

Parameters:
position - the position
angle - the angle in radians
Method Detail

mul

public Vector2 mul(Vector2 v)
Transforms the given vector by this transform

Parameters:
v - the vector

getPosition

public Vector2 getPosition()
Returns:
the position, modification of the vector has no effect on the Transform

setRotation

public void setRotation(float angle)
Sets the rotation of this transform

Parameters:
angle - angle in radians

setPosition

public void setPosition(Vector2 pos)
Sets the position of this transform

Parameters:
pos - the position
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.Transform (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.Transform

Packages that use Transform
com.badlogic.gdx.physics.box2d

Uses of Transform in com.badlogic.gdx.physics.box2d

Methods in com.badlogic.gdx.physics.box2d that return Transform
 Transform Body.getTransform()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


TWL (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.twl
Class TWL

java.lang.Object
    extended by  com.badlogic.gdx.twl.TWL
All Implemented Interfaces:
InputProcessor
public class TWL
extends java.lang.Object
implements InputProcessor

Convenience class for using TWL. This provides all the basics sufficient for most UIs. TWL can be used without this class if more complex configurations are required (eg, multiple GUI instances).

This class provides a single GUI instance with a root pane set to a widget that takes up the whole screen. setWidget(Widget) puts a widget into the root pane, making it easy to layout your widgets using the whole screen.

This class is relatively heavyweight because it loads a TWL theme. Generally only one instance should be created for an entire application. Use setWidget(Widget) and clear() to change the widgets displayed on various application screens.

This class implements InputProcessor and the input methods return true if TWL handled an event. Generally you will want to use InputMultiplexer to avoid dispatching events that TWL handled to your application.

If an instance of this call will no longer be used, dispose() must be called to release resources.

Author:
Nathan Sweet

Constructor Summary
TWL(java.lang.String themeFile, Files.FileType fileType)
Creates a new TWL instance with the specified theme file.
TWL(java.lang.String themeFile, Files.FileType fileType, Widget widget)
Creates a new TWL instance with the specified theme file.
Method Summary
void | clear() Removes all widgets from the GUI's root pane.
void | dispose()
GUI | getGUI() Returns the GUI instance, which is the root of the TWL UI hierachy and manages timing, inputs, etc.
static java.net.URL | getThemeURL(java.lang.String themeFile, Files.FileType fileType) Returns a URL to a theme file, which can be used with ThemeManager to create a theme for GUI#applyTheme(ThemeManager).
static int | getTwlKeyCode(int gdxKeyCode)
boolean | keyDown(int keycode) Called when a key was pressed
boolean | keyTyped(char character) Called when a key was typed
boolean | keyUp(int keycode) Called when a key was released
void | render() Draws the TWL UI.
void | setWidget(Widget widget) Sets the widget in the GUI's root pane.
boolean | touchDown(int x, int y, int pointer) Called when the screen was touched or a mouse button was pressed.
boolean | touchDragged(int x, int y, int pointer) Called when a finger or the mouse was dragged.
boolean | touchUp(int x, int y, int pointer) Called when a finger was lifted or a mouse button was released.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TWL

public TWL(java.lang.String themeFile,
           Files.FileType fileType,
           Widget widget)
Creates a new TWL instance with the specified theme file. The specified widget is added to the root pane.

TWL

public TWL(java.lang.String themeFile,
           Files.FileType fileType)
Creates a new TWL instance with the specified theme file.

Method Detail

getGUI

public GUI getGUI()
Returns the GUI instance, which is the root of the TWL UI hierachy and manages timing, inputs, etc.

setWidget

public void setWidget(Widget widget)
Sets the widget in the GUI's root pane. By default the root pane takes up the whole screen.

Parameters:
widget - If null, this method is equivalent to clear().

clear

public void clear()
Removes all widgets from the GUI's root pane. This effectively means that no TWL UI will be drawn.

render

public void render()
Draws the TWL UI.

keyDown

public boolean keyDown(int keycode)
Description copied from interface: InputProcessor
Called when a key was pressed

Specified by:
keyDown in interface InputProcessor
Parameters:
keycode - one of the constants in Input.Keys
Returns:
whether the input was processed

keyUp

public boolean keyUp(int keycode)
Description copied from interface: InputProcessor
Called when a key was released

Specified by:
keyUp in interface InputProcessor
Parameters:
keycode - one of the constants in Input.Keys
Returns:
whether the input was processed

keyTyped

public boolean keyTyped(char character)
Description copied from interface: InputProcessor
Called when a key was typed

Specified by:
keyTyped in interface InputProcessor
Parameters:
character - The character
Returns:
whether the input was processed

touchDown

public boolean touchDown(int x,
                         int y,
                         int pointer)
Description copied from interface: InputProcessor
Called when the screen was touched or a mouse button was pressed.

Specified by:
touchDown in interface InputProcessor
Parameters:
x - The x coordinate, origin is in the upper left corner
y - The y coordinate, origin is in the upper left corner
pointer - the pointer for the event.
Returns:
whether the input was processed

touchUp

public boolean touchUp(int x,
                       int y,
                       int pointer)
Description copied from interface: InputProcessor
Called when a finger was lifted or a mouse button was released.

Specified by:
touchUp in interface InputProcessor
Parameters:
x - The x coordinate
y - The y coordinate
pointer - the pointer for the event.
Returns:
whether the input was processed

touchDragged

public boolean touchDragged(int x,
                            int y,
                            int pointer)
Description copied from interface: InputProcessor
Called when a finger or the mouse was dragged.

Specified by:
touchDragged in interface InputProcessor
Parameters:
x - The x coordinate
y - The y coordinate
pointer - the pointer for the event.
Returns:
whether the input was processed

dispose

public void dispose()

getTwlKeyCode

public static int getTwlKeyCode(int gdxKeyCode)

getThemeURL

public static java.net.URL getThemeURL(java.lang.String themeFile,
                                       Files.FileType fileType)
                                throws java.net.MalformedURLException
Returns a URL to a theme file, which can be used with ThemeManager to create a theme for GUI#applyTheme(ThemeManager). This is only needed if not using the TWL class make use of TWL.

Throws:
java.net.MalformedURLException
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.twl.TWL (libgdx API)

Uses of Class
com.badlogic.gdx.twl.TWL

No usage of com.badlogic.gdx.twl.TWL

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Vector2 (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class Vector2

java.lang.Object
    extended by  com.badlogic.gdx.math.Vector2

public final class Vector2
extends java.lang.Object

Encapsulates a 2D vector. Allows chaining methods by returning a reference to itself

Author:
badlogicgames@gmail.com

Field Summary
float | x the x-component of this vector
float | y the y-component of this vector
Constructor Summary
Vector2()
Constructs a new vector at (0,0)
Vector2(float x, float y)
Constructs a vector with the given components
Vector2(Vector2 v)
Constructs a vector from the given vector
Method Summary
Vector2 | add(float x, float y) Adds the given components to this vector
Vector2 | add(Vector2 v) Adds the given vector to this vector
Vector2 | cpy()
float | dot(Vector2 v)
float | dst(float x, float y)
float | dst(Vector2 v)
float | dst2(Vector2 v)
float | len()
float | len2()
Vector2 | mul(float scalar) Multiplies this vector by a scalar
Vector2 | mul(Matrix3 mat) Multiplies this vector by the given matrix
Vector2 | nor() Normalizes this vector
Vector2 | set(float x, float y) Sets the components of this vector
Vector2 | set(Vector2 v) Sets this vector from the given vector
Vector2 | sub(float x, float y) Substracts the other vector from this vector.
Vector2 | sub(Vector2 v) Substracts the given vector from this vector.
Vector2 | tmp()
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

x

public float x
the x-component of this vector

y

public float y
the y-component of this vector

Constructor Detail

Vector2

public Vector2()
Constructs a new vector at (0,0)

Vector2

public Vector2(float x,
               float y)
Constructs a vector with the given components

Parameters:
x - The x-component
y - The y-component

Vector2

public Vector2(Vector2 v)
Constructs a vector from the given vector

Parameters:
v - The vector
Method Detail

cpy

public Vector2 cpy()
Returns:
a copy of this vector

len

public float len()
Returns:
The euclidian length

len2

public float len2()
Returns:
The squared euclidian length

set

public Vector2 set(Vector2 v)
Sets this vector from the given vector

Parameters:
v - The vector
Returns:
This vector for chaining

set

public Vector2 set(float x,
                   float y)
Sets the components of this vector

Parameters:
x - The x-component
y - The y-component
Returns:
This vector for chaining

sub

public Vector2 sub(Vector2 v)
Substracts the given vector from this vector.

Parameters:
v - The vector
Returns:
This vector for chaining

nor

public Vector2 nor()
Normalizes this vector

Returns:
This vector for chaining

add

public Vector2 add(Vector2 v)
Adds the given vector to this vector

Parameters:
v - The vector
Returns:
This vector for chaining

add

public Vector2 add(float x,
                   float y)
Adds the given components to this vector

Parameters:
x - The x-component
y - The y-component
Returns:
This vector for chaining

dot

public float dot(Vector2 v)
Parameters:
v - The other vector
Returns:
The dot product between this and the other vector

mul

public Vector2 mul(float scalar)
Multiplies this vector by a scalar

Parameters:
scalar - The scalar
Returns:
This vector for chaining

dst

public float dst(Vector2 v)
Parameters:
v - The other vector
Returns:
the distance between this and the other vector

dst

public float dst(float x,
                 float y)
Parameters:
x - The x-component of the other vector
y - The y-component of the other vector
Returns:
the distance between this and the other vector

dst2

public float dst2(Vector2 v)
Parameters:
v - The other vector
Returns:
the squared distance between this and the other vector

toString

public java.lang.String toString()
Overrides:
toString in class java.lang.Object

sub

public Vector2 sub(float x,
                   float y)
Substracts the other vector from this vector.

Parameters:
x - The x-component of the other vector
y - The y-component of the other vector
Returns:
This vector for chaining

tmp

public Vector2 tmp()
Returns:
a temporary copy of this vector. Use with care as this is backed by a single static Vector2 instance. v1.tmp().add( v2.tmp() ) will not work!

mul

public Vector2 mul(Matrix3 mat)
Multiplies this vector by the given matrix

Parameters:
mat - the matrix
Returns:
this vector
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.Vector2 (libgdx API)

Uses of Class
com.badlogic.gdx.math.Vector2

Packages that use Vector2
com.badlogic.gdx.graphics
com.badlogic.gdx.math
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints
com.badlogic.gdx.scenes.scene2d

Uses of Vector2 in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics with parameters of type Vector2
void | OrthographicCamera.getScreenToWorld(float screenX, float screenY, Vector2 world) Calculates the world coordinates of the given screen coordinates and stores the result in world
void | OrthographicCamera.getWorldToScreen(float worldX, float worldY, Vector2 screen) Calculates the screen coordinates of the given world coordinates

Uses of Vector2 in com.badlogic.gdx.math

Methods in com.badlogic.gdx.math that return Vector2
Vector2 | Vector2.add(float x, float y) Adds the given components to this vector
Vector2 | Vector2.add(Vector2 v) Adds the given vector to this vector
Vector2 | Vector2.cpy()
Vector2 | Vector2.mul(float scalar) Multiplies this vector by a scalar
Vector2 | Vector2.mul(Matrix3 mat) Multiplies this vector by the given matrix
Vector2 | Vector2.nor() Normalizes this vector
Vector2 | Vector2.set(float x, float y) Sets the components of this vector
Vector2 | Vector2.set(Vector2 v) Sets this vector from the given vector
Vector2 | Vector2.sub(float x, float y) Substracts the other vector from this vector.
Vector2 | Vector2.sub(Vector2 v) Substracts the given vector from this vector.
Vector2 | Vector2.tmp()

Methods in com.badlogic.gdx.math that return types with arguments of type Vector2
 java.util.List<Vector2> EarCutTriangulator.triangulate(java.util.List<Vector2> polygon)
Triangulates the list of points and returns an array of Vector3 triples that each form a single triangle.

Methods in com.badlogic.gdx.math with parameters of type Vector2
Vector2 | Vector2.add(Vector2 v) Adds the given vector to this vector
static float | Intersector.distanceLinePoint(Vector2 start, Vector2 end, Vector2 point) Returns the distance between the given line segment and point.
float | Vector2.dot(Vector2 v)
float | Vector2.dst(Vector2 v)
float | Vector2.dst2(Vector2 v)
static boolean | Intersector.intersectLines(Vector2 p1, Vector2 p2, Vector2 p3, Vector2 p4, Vector2 intersection) Intersects the two lines and returns the intersection point in intersection.
static boolean | Intersector.intersectSegmentCircle(Vector2 start, Vector2 end, Vector2 center, float squareRadius) Returns wheter the given line segment intersects the given circle.
static float | Intersector.intersectSegmentCircleDisplace(Vector2 start, Vector2 end, Vector2 point, float radius, Vector2 displacement) Checks wheter the line segment and the circle intersect and returns by how much and in what direction the line has to move away from the circle to not intersect.
static boolean | Intersector.intersectSegments(Vector2 p1, Vector2 p2, Vector2 p3, Vector2 p4, Vector2 intersection) Intersects the two line segments and returns the intersection point in intersection.
static boolean | Intersector.isPointInPolygon(java.util.List<Vector2> polygon, Vector2 point) Checks wheter the given point is in the polygon.
Vector2 | Vector2.set(Vector2 v) Sets this vector from the given vector
Vector2 | Vector2.sub(Vector2 v) Substracts the given vector from this vector.

Method parameters in com.badlogic.gdx.math with type arguments of type Vector2
static boolean | Intersector.isPointInPolygon(java.util.List<Vector2> polygon, Vector2 point) Checks wheter the given point is in the polygon.
boolean | EarCutTriangulator.polygonClockwise(java.util.List<Vector2> polygon)
java.util.List<Vector2> | EarCutTriangulator.triangulate(java.util.List<Vector2> polygon) Triangulates the list of points and returns an array of Vector3 triples that each form a single triangle.

Constructors in com.badlogic.gdx.math with parameters of type Vector2
Vector2(Vector2 v)
Constructs a vector from the given vector

Uses of Vector2 in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as Vector2
Vector2 | MassData.center The position of the shape's centroid relative to the shape's origin.
Vector2 | BodyDef.linearVelocity The linear velocity of the body's origin in world co-ordinates.
Vector2 | Body.linVelLoc
Vector2 | Body.linVelWorld
Vector2 | Body.localPoint2
Vector2 | Body.localVector
protected Vector2 | WorldManifold.normal
protected Vector2[] | WorldManifold.points
Vector2 | BodyDef.position The world position of the body.

Methods in com.badlogic.gdx.physics.box2d that return Vector2
Vector2 | Joint.getAnchorA()
Vector2 | Joint.getAnchorB()
Vector2 | World.getGravity()
Vector2 | Body.getLinearVelocity()
Vector2 | Body.getLinearVelocityFromLocalPoint(Vector2 localPoint) Get the world velocity of a local point.
Vector2 | Body.getLinearVelocityFromWorldPoint(Vector2 worldPoint) Get the world linear velocity of a world point attached to this body.
Vector2 | Body.getLocalCenter()
Vector2 | Body.getLocalPoint(Vector2 worldPoint) Gets a local point relative to the body's origin given a world point.
Vector2 | Body.getLocalVector(Vector2 worldVector) Gets a local vector given a world vector.
Vector2 | WorldManifold.getNormal() Returns the normal of this manifold
Vector2[] | WorldManifold.getPoints() Returns the contact points of this manifold.
Vector2 | Body.getPosition() Get the world body origin position.
Vector2 | CircleShape.getPosition()
Vector2 | Transform.getPosition()
Vector2 | Joint.getReactionForce(float inv_dt)
Vector2 | Body.getWorldCenter()
Vector2 | Body.getWorldPoint(Vector2 localPoint) Get the world coordinates of a point given the local coordinates.
Vector2 | Body.getWorldVector(Vector2 localVector) Get the world coordinates of a vector given the local coordinates.
Vector2 | Transform.mul(Vector2 v) Transforms the given vector by this transform

Methods in com.badlogic.gdx.physics.box2d with parameters of type Vector2
void | Body.applyForce(Vector2 force, Vector2 point) Apply a force at a world point.
void | Body.applyLinearImpulse(Vector2 impulse, Vector2 point) Apply an impulse at a point.
Vector2 | Body.getLinearVelocityFromLocalPoint(Vector2 localPoint) Get the world velocity of a local point.
Vector2 | Body.getLinearVelocityFromWorldPoint(Vector2 worldPoint) Get the world linear velocity of a world point attached to this body.
Vector2 | Body.getLocalPoint(Vector2 worldPoint) Gets a local point relative to the body's origin given a world point.
Vector2 | Body.getLocalVector(Vector2 worldVector) Gets a local vector given a world vector.
void | PolygonShape.getVertex(int index, Vector2 vertex) Returns the vertex at the given position.
Vector2 | Body.getWorldPoint(Vector2 localPoint) Get the world coordinates of a point given the local coordinates.
Vector2 | Body.getWorldVector(Vector2 localVector) Get the world coordinates of a vector given the local coordinates.
Vector2 | Transform.mul(Vector2 v) Transforms the given vector by this transform
void | PolygonShape.set(Vector2[] vertices) Copy vertices.
void | PolygonShape.setAsBox(float hx, float hy, Vector2 center, float angle) Build vertices to represent an oriented box.
void | PolygonShape.setAsEdge(Vector2 v1, Vector2 v2) Set this as a single edge.
void | World.setGravity(Vector2 gravity) Change the global gravity vector.
void | Body.setLinearVelocity(Vector2 v) Set the linear velocity of the center of mass.
void | CircleShape.setPosition(Vector2 position) Sets the position of the shape
void | Transform.setPosition(Vector2 pos) Sets the position of this transform
void | Body.setTransform(Vector2 position, float angle) Set the position of the body's origin and rotation.
boolean | Fixture.testPoint(Vector2 p) Test a point for containment in this fixture.

Constructors in com.badlogic.gdx.physics.box2d with parameters of type Vector2
Transform(Vector2 position, float angle)
Constructs a new Transform instance with the given position and angle
World(Vector2 gravity, boolean doSleep)
Construct a world object.

Uses of Vector2 in com.badlogic.gdx.physics.box2d.joints

Fields in com.badlogic.gdx.physics.box2d.joints declared as Vector2
Vector2 | PulleyJointDef.groundAnchorA The first ground anchor in world coordinates.
Vector2 | PulleyJointDef.groundAnchorB The second ground anchor in world coordinates.
Vector2 | DistanceJointDef.localAnchorA The local anchor point relative to body1's origin.
Vector2 | FrictionJointDef.localAnchorA The local anchor point relative to bodyA's origin.
Vector2 | LineJointDef.localAnchorA The local anchor point relative to body1's origin.
Vector2 | PrismaticJointDef.localAnchorA The local anchor point relative to body1's origin.
Vector2 | PulleyJointDef.localAnchorA The local anchor point relative to bodyA's origin.
Vector2 | RevoluteJointDef.localAnchorA The local anchor point relative to body1's origin.
Vector2 | WeldJointDef.localAnchorA
Vector2 | DistanceJointDef.localAnchorB The local anchor point relative to body2's origin.
Vector2 | FrictionJointDef.localAnchorB The local anchor point relative to bodyB's origin.
Vector2 | LineJointDef.localAnchorB The local anchor point relative to body2's origin.
Vector2 | PrismaticJointDef.localAnchorB The local anchor point relative to body2's origin.
Vector2 | PulleyJointDef.localAnchorB The local anchor point relative to bodyB's origin.
Vector2 | RevoluteJointDef.localAnchorB The local anchor point relative to body2's origin.
Vector2 | WeldJointDef.localAnchorB
Vector2 | PrismaticJointDef.localAxis1 The local translation axis in body1.
Vector2 | LineJointDef.localAxisA The local translation axis in body1.
Vector2 | MouseJointDef.target The initial world target point.

Methods in com.badlogic.gdx.physics.box2d.joints that return Vector2
Vector2 | PulleyJoint.getGroundAnchorA()
Vector2 | PulleyJoint.getGroundAnchorB()
Vector2 | MouseJoint.getTarget()

Methods in com.badlogic.gdx.physics.box2d.joints with parameters of type Vector2
void | FrictionJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchor) Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
void | RevoluteJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchor) Initialize the bodies, anchors, and reference angle using a world anchor point.
void | WeldJointDef.initialize(Body body1, Body body2, Vector2 anchor)
void | DistanceJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchorA, Vector2 anchorB) Initialize the bodies, anchors, and length using the world anchors.
void | LineJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchor, Vector2 axis) Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
void | PrismaticJointDef.initialize(Body bodyA, Body bodyB, Vector2 anchor, Vector2 axis) Initialize the bodies, anchors, axis, and reference angle using the world anchor and world axis.
void | PulleyJointDef.initialize(Body bodyA, Body bodyB, Vector2 groundAnchorA, Vector2 groundAnchorB, Vector2 anchorA, Vector2 anchorB, float ratio) Initialize the bodies, anchors, lengths, max lengths, and ratio using the world anchors.
void | MouseJoint.setTarget(Vector2 target) Use this to update the target point.

Uses of Vector2 in com.badlogic.gdx.scenes.scene2d

Methods in com.badlogic.gdx.scenes.scene2d with parameters of type Vector2
static void | Group.toChildCoordinates(Actor child, float x, float y, Vector2 out) Transforms the coordinates given in the child's parent coordinate system to the child Actor's coordinate system.
void | Actor.toLocalCoordinates(Vector2 point) Transforms the given point in stage coordinates to the Actor's local coordinate system.
void | Stage.toStageCoordinates(int x, int y, Vector2 out) Transforms the given screen coordinates to stage coordinates

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Vector3 (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class Vector3

java.lang.Object
    extended by  com.badlogic.gdx.math.Vector3

public final class Vector3
extends java.lang.Object

Encapsulates a 3D vector. Allows chaining operations by returning a reference to it self in all modification methods.

Author:
badlogicgames@gmail.com

Field Summary
float | x the x-component of this vector
float | y the x-component of this vector
float | z the x-component of this vector
Constructor Summary
Vector3()
Constructs a vector at (0,0,0)
Vector3(float[] values)
Creates a vector from the given array.
Vector3(float x, float y, float z)
Creates a vector with the given components
Vector3(Vector3 vector)
Creates a vector from the given vector
Method Summary
Vector3 | add(float values) Adds the given value to all three components of the vector.
Vector3 | add(float x, float y, float z) Adds the given vector to this component
Vector3 | add(Vector3 vector) Adds the given vector to this vector
Vector3 | cpy()
Vector3 | crs(float x, float y, float z) Sets this vector to the cross product between it and the other vector.
Vector3 | crs(Vector3 vector) Sets this vector to the cross product between it and the other vector.
float | dist2(Vector3 vector)
Vector3 | div(float value) Divides all components of this vector by the given value
float | dot(float x, float y, float z) Returns the dot product between this and the given vector.
float | dot(Vector3 vector)
float | dst(float x, float y, float z)
float | dst(Vector3 vector)
float | dst2(float x, float y, float z) Returns the squared distance between this point and the given point
float | dst2(Vector3 point) Returns the squared distance between this point and the given point
boolean | equals(java.lang.Object obj)
int | hashCode()
boolean | idt(Vector3 vector)
boolean | isUnit()
boolean | isZero()
float | len()
float | len2()
Vector3 | lerp(Vector3 target, float alpha) Linearly interpolates between this vector and the target vector by alpha which is in the range [0,1].
Vector3 | mul(float value) Multiplies all components of this vector by the given value
Vector3 | mul(Matrix4 matrix) Multiplies the vector by the given matrix.
Vector3 | nor() Normalizes this vector to unit length
Vector3 | prj(Matrix4 matrix) Multiplies this vector by the given matrix dividing by w.
Vector3 | rot(Matrix4 matrix) Multiplies this vector by the first three columns of the matrix, essentially only applying rotation and scaling.
Vector3 | scale(float scalarX, float scalarY, float scalarZ) Scales the vector components by the given scalars.
Vector3 | set(float[] values) Sets the components from the array.
Vector3 | set(float x, float y, float z) Sets the vector to the given components
Vector3 | set(Vector3 vector) Sets the components of the given vector
Vector3 | slerp(Vector3 target, float alpha) Spherically interpolates between this vector and the target vector by alpha which is in the range [0,1].
Vector3 | sub(float value) Subtracts the given value from all components of this vector
Vector3 | sub(float x, float y, float z) Subtracts the other vector from this vector.
Vector3 | sub(Vector3 a_vec) Subtracts the given vector from this vector
Vector3 | tmp() NEVER EVER SAVE THIS REFERENCE!
Vector3 | tmp2() NEVER EVER SAVE THIS REFERENCE!
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

x

public float x
the x-component of this vector

y

public float y
the x-component of this vector

z

public float z
the x-component of this vector

Constructor Detail

Vector3

public Vector3()
Constructs a vector at (0,0,0)

Vector3

public Vector3(float x,
               float y,
               float z)
Creates a vector with the given components

Parameters:
x - The x-component
y - The y-component
z - The z-component

Vector3

public Vector3(Vector3 vector)
Creates a vector from the given vector

Parameters:
vector - The vector

Vector3

public Vector3(float[] values)
Creates a vector from the given array. The array must have at least 3 elements.

Parameters:
values - The array
Method Detail

set

public Vector3 set(float x,
                   float y,
                   float z)
Sets the vector to the given components

Parameters:
x - The x-component
y - The y-component
z - The z-component
Returns:
this vector for chaining

set

public Vector3 set(Vector3 vector)
Sets the components of the given vector

Parameters:
vector - The vector
Returns:
This vector for chaining

set

public Vector3 set(float[] values)
Sets the components from the array. The array must have at least 3 elements

Parameters:
values - The array
Returns:
this vector for chaining

cpy

public Vector3 cpy()
Returns:
a copy of this vector

tmp

public Vector3 tmp()
NEVER EVER SAVE THIS REFERENCE!

Returns:
a temporary copy of this vector

tmp2

public Vector3 tmp2()
NEVER EVER SAVE THIS REFERENCE!

Returns:
a temporary copy of this vector

add

public Vector3 add(Vector3 vector)
Adds the given vector to this vector

Parameters:
vector - The other vector
Returns:
This vector for chaining

add

public Vector3 add(float x,
                   float y,
                   float z)
Adds the given vector to this component

Parameters:
x - The x-component of the other vector
y - The y-component of the other vector
z - The z-component of the other vector
Returns:
This vector for chaining.

add

public Vector3 add(float values)
Adds the given value to all three components of the vector.

Parameters:
values - The value
Returns:
This vector for chaining

sub

public Vector3 sub(Vector3 a_vec)
Subtracts the given vector from this vector

Parameters:
a_vec - The other vector
Returns:
This vector for chaining

sub

public Vector3 sub(float x,
                   float y,
                   float z)
Subtracts the other vector from this vector.

Parameters:
x - The x-component of the other vector
y - The y-component of the other vector
z - The z-component of the other vector
Returns:
This vector for chaining

sub

public Vector3 sub(float value)
Subtracts the given value from all components of this vector

Parameters:
value - The value
Returns:
This vector for chaining

mul

public Vector3 mul(float value)
Multiplies all components of this vector by the given value

Parameters:
value - The value
Returns:
This vector for chaining

div

public Vector3 div(float value)
Divides all components of this vector by the given value

Parameters:
value - The value
Returns:
This vector for chaining

len

public float len()
Returns:
The euclidian length

len2

public float len2()
Returns:
The squared euclidian length

idt

public boolean idt(Vector3 vector)
Parameters:
vector - The other vector
Returns:
Wether this and the other vector are equal

dst

public float dst(Vector3 vector)
Parameters:
vector - The other vector
Returns:
The euclidian distance between this and the other vector

dist2

public float dist2(Vector3 vector)
Parameters:
vector - The other vector
Returns:
The squared euclidian distance between this and the other vector

nor

public Vector3 nor()
Normalizes this vector to unit length

Returns:
This vector for chaining

dot

public float dot(Vector3 vector)
Parameters:
vector - The other vector
Returns:
The dot product between this and the other vector

crs

public Vector3 crs(Vector3 vector)
Sets this vector to the cross product between it and the other vector.

Parameters:
vector - The other vector
Returns:
This vector for chaining

crs

public Vector3 crs(float x,
                   float y,
                   float z)
Sets this vector to the cross product between it and the other vector.

Parameters:
x - The x-component of the other vector
y - The y-component of the other vector
z - The z-component of the other vector
Returns:
This vector for chaining

mul

public Vector3 mul(Matrix4 matrix)
Multiplies the vector by the given matrix.

Parameters:
matrix - The matrix
Returns:
This vector for chaining

prj

public Vector3 prj(Matrix4 matrix)
Multiplies this vector by the given matrix dividing by w. This is mostly used to project/unproject vectors via a perspective projection matrix.

Parameters:
matrix - The matrix.
Returns:
This vector for chaining

rot

public Vector3 rot(Matrix4 matrix)
Multiplies this vector by the first three columns of the matrix, essentially only applying rotation and scaling.

Parameters:
matrix - The matrix
Returns:
This vector for chaining

isUnit

public boolean isUnit()
Returns:
Wether this vector is a unit length vector

isZero

public boolean isZero()
Returns:
Wether this vector is a zero vector

lerp

public Vector3 lerp(Vector3 target,
                    float alpha)
Linearly interpolates between this vector and the target vector by alpha which is in the range [0,1]. The result is stored in this vector.

Parameters:
target - The target vector
alpha - The interpolation coefficient
Returns:
This vector for chaining.

slerp

public Vector3 slerp(Vector3 target,
                     float alpha)
Spherically interpolates between this vector and the target vector by alpha which is in the range [0,1]. The result is stored in this vector.

Parameters:
target - The target vector
alpha - The interpolation coefficient
Returns:
This vector for chaining.

toString

public java.lang.String toString()

Overrides:
toString in class java.lang.Object

dot

public float dot(float x,
                 float y,
                 float z)
Returns the dot product between this and the given vector.

Parameters:
x - The x-component of the other vector
y - The y-component of the other vector
z - The z-component of the other vector
Returns:
The dot product

dst2

public float dst2(Vector3 point)
Returns the squared distance between this point and the given point

Parameters:
point - The other point
Returns:
The squared distance

dst2

public float dst2(float x,
                  float y,
                  float z)
Returns the squared distance between this point and the given point

Parameters:
x - The x-component of the other point
y - The y-component of the other point
z - The z-component of the other point
Returns:
The squared distance

dst

public float dst(float x,
                 float y,
                 float z)

hashCode

public int hashCode()

Overrides:
hashCode in class java.lang.Object

equals

public boolean equals(java.lang.Object obj)

Overrides:
equals in class java.lang.Object

scale

public Vector3 scale(float scalarX,
                     float scalarY,
                     float scalarZ)
Scales the vector components by the given scalars.

Parameters:
scalarX -
scalarY -
scalarZ -
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.Vector3 (libgdx API)

Uses of Class
com.badlogic.gdx.math.Vector3

Packages that use Vector3
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.loaders.md5
com.badlogic.gdx.math
com.badlogic.gdx.math.collision

Uses of Vector3 in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return Vector3
Vector3 | PerspectiveCamera.getDirection()
Vector3 | OrthographicCamera.getPosition()
Vector3 | PerspectiveCamera.getPosition()
Vector3 | PerspectiveCamera.getRight()
Vector3 | PerspectiveCamera.getUp()

Methods in com.badlogic.gdx.graphics with parameters of type Vector3
 void PerspectiveCamera.project(Vector3 pos)
Projects the given vector in world space to screen space, overwritting the x- and y-coordinate of the provided vector.

Uses of Vector3 in com.badlogic.gdx.graphics.loaders.md5

Methods in com.badlogic.gdx.graphics.loaders.md5 with parameters of type Vector3
void | MD5Quaternion.multiply(Vector3 v)
void | MD5Quaternion.rotate(Vector3 vec)

Uses of Vector3 in com.badlogic.gdx.math

Fields in com.badlogic.gdx.math declared as Vector3
 Vector3 Plane.normal

Methods in com.badlogic.gdx.math that return Vector3
Vector3 | Vector3.add(float values) Adds the given value to all three components of the vector.
Vector3 | Vector3.add(float x, float y, float z) Adds the given vector to this component
Vector3 | Vector3.add(Vector3 vector) Adds the given vector to this vector
Vector3 | Vector3.cpy()
Vector3 | Vector3.crs(float x, float y, float z) Sets this vector to the cross product between it and the other vector.
Vector3 | Vector3.crs(Vector3 vector) Sets this vector to the cross product between it and the other vector.
Vector3 | Vector3.div(float value) Divides all components of this vector by the given value
Vector3 | Plane.getNormal()
Vector3 | Vector3.lerp(Vector3 target, float alpha) Linearly interpolates between this vector and the target vector by alpha which is in the range [0,1].
Vector3 | Vector3.mul(float value) Multiplies all components of this vector by the given value
Vector3 | Vector3.mul(Matrix4 matrix) Multiplies the vector by the given matrix.
Vector3 | Vector3.nor() Normalizes this vector to unit length
Vector3 | Vector3.prj(Matrix4 matrix) Multiplies this vector by the given matrix dividing by w.
Vector3 | Vector3.rot(Matrix4 matrix) Multiplies this vector by the first three columns of the matrix, essentially only applying rotation and scaling.
Vector3 | Vector3.scale(float scalarX, float scalarY, float scalarZ) Scales the vector components by the given scalars.
Vector3 | Vector3.set(float[] values) Sets the components from the array.
Vector3 | Vector3.set(float x, float y, float z) Sets the vector to the given components
Vector3 | Vector3.set(Vector3 vector) Sets the components of the given vector
Vector3 | Vector3.slerp(Vector3 target, float alpha) Spherically interpolates between this vector and the target vector by alpha which is in the range [0,1].
Vector3 | Vector3.sub(float value) Subtracts the given value from all components of this vector
Vector3 | Vector3.sub(float x, float y, float z) Subtracts the other vector from this vector.
Vector3 | Vector3.sub(Vector3 a_vec) Subtracts the given vector from this vector
Vector3 | Vector3.tmp() NEVER EVER SAVE THIS REFERENCE!
Vector3 | Vector3.tmp2() NEVER EVER SAVE THIS REFERENCE!

Methods in com.badlogic.gdx.math that return types with arguments of type Vector3
java.util.List<Vector3> | CatmullRomSpline.getControlPoints()
java.util.List<Vector3> | CatmullRomSpline.getPath(int numPoints) Returns a path, between every two control points numPoints are generated and the control points themselves are added too.
java.util.List<Vector3> | CatmullRomSpline.getTangentNormals(int numPoints, java.util.List<Vector3> up)
java.util.List<Vector3> | CatmullRomSpline.getTangentNormals(int numPoints, Vector3 up) Returns the tangent's normals using the tangent and provided up vector doing a cross product.
java.util.List<Vector3> | CatmullRomSpline.getTangentNormals2D(int numPoints) Returns all tangent's normals in 2D space for the points in a path.
java.util.List<Vector3> | CatmullRomSpline.getTangents(int numPoints) Returns all tangents for the points in a path.

Methods in com.badlogic.gdx.math with parameters of type Vector3
void | CatmullRomSpline.add(Vector3 point) Adds a new control point
Vector3 | Vector3.add(Vector3 vector) Adds the given vector to this vector
Ray | Frustum.calculatePickRay(float screen_width, float screen_height, float mouse_x, float mouse_y, Vector3 pos, Vector3 dir, Vector3 up) Calculates the pick ray for the given window coordinates.
Vector3 | Vector3.crs(Vector3 vector) Sets this vector to the cross product between it and the other vector.
float | Vector3.dist2(Vector3 vector)
float | Plane.distance(Vector3 point) Calculates the shortest signed distance between the plane and the given point.
float | Vector3.dot(Vector3 vector)
float | Vector3.dst(Vector3 vector)
float | Vector3.dst2(Vector3 point) Returns the squared distance between this point and the given point
java.util.List<Vector3> | CatmullRomSpline.getTangentNormals(int numPoints, Vector3 up) Returns the tangent's normals using the tangent and provided up vector doing a cross product.
boolean | Vector3.idt(Vector3 vector)
static boolean | Intersector.intersectRayPlane(Ray ray, Plane plane, Vector3 intersection) Intersects a Ray and a Plane.
static boolean | Intersector.intersectRaySphere(Ray ray, Vector3 center, float radius, Vector3 intersection) Intersects a Ray and a sphere, returning the intersection point in intersection.
static boolean | Intersector.intersectRayTriangle(Ray ray, Vector3 t1, Vector3 t2, Vector3 t3, Vector3 intersection) Intersect a Ray and a triangle, returning the intersection point in intersection.
static boolean | Intersector.intersectRayTriangles(Ray ray, float[] vertices, short[] indices, int vertexSize, Vector3 intersection) Intersects the given ray with list of triangles.
static boolean | Intersector.intersectRayTriangles(Ray ray, float[] triangles, Vector3 intersection) Intersects the given ray with list of triangles.
static boolean | Intersector.intersectRayTriangles(Ray ray, java.util.List<Vector3> triangles, Vector3 intersection) Intersects the given ray with list of triangles.
static boolean | Intersector.intersectSegmentPlane(Vector3 start, Vector3 end, Plane plane, Vector3 intersection)
boolean | Plane.isFrontFacing(Vector3 direction) Returns whether the plane is facing the direction vector.
static boolean | Intersector.isPointInTriangle(Vector3 point, Vector3 t1, Vector3 t2, Vector3 t3) Returns whether the given point is inside the triangle.
Vector3 | Vector3.lerp(Vector3 target, float alpha) Linearly interpolates between this vector and the target vector by alpha which is in the range [0,1].
boolean | Frustum.pointInFrustum(Vector3 point) Returns wheter the point is in the frustum.
Vector3 | Vector3.set(Vector3 vector) Sets the components of the given vector
Quaternion | Quaternion.set(Vector3 axis, float angle) Sets the quaternion components from the given axis and angle around that axis.
void | Plane.set(Vector3 point, Vector3 normal) Sets the plane to the given point and normal.
void | Plane.set(Vector3 point1, Vector3 point2, Vector3 point3) Sets the plane normal and distance to the origin based on the three given points which are considered to be on the plane.
void | Matrix4.set(Vector3 xAxis, Vector3 yAxis, Vector3 zAxis, Vector3 pos) Sets the four columns of the matrix which correspond to the x-, y- and z-axis of the vector space this matrix creates as well as the 4th column representing the translation of any point that is multiplied by this matrix.
void | Frustum.setCameraOrientation(Vector3 pos, Vector3 dir, Vector3 up) Sets the camera orientation.
Matrix4 | Matrix4.setToLookAt(Vector3 direction, Vector3 up) Sets the matrix to a look at matrix with a direction and an up vector.
Matrix4 | Matrix4.setToLookAt(Vector3 position, Vector3 target, Vector3 up) Sets this matrix to a look at matrix with the given position, target and up vector.
Matrix4 | Matrix4.setToRotation(Vector3 axis, float angle) Sets the matrix to a rotation matrix around the given axis.
Matrix4 | Matrix4.setToScaling(Vector3 vector) Sets this matrix to a scaling matrix
Matrix4 | Matrix4.setToTranslation(Vector3 vector) Sets this matrix to a translation matrix, overwriting it first by an identity matrix and then setting the 4th column to the translation vector.
Matrix4 | Matrix4.setToTranslationAndScaling(Vector3 translation, Vector3 scaling) Sets this matrix to a translation and scaling matrix by first overwritting it with an identity and then setting the translation vector in the 4th column and the scaling vector in the diagonal.
Matrix4 | Matrix4.setToWorld(Vector3 position, Vector3 forward, Vector3 up)
Vector3 | Vector3.slerp(Vector3 target, float alpha) Spherically interpolates between this vector and the target vector by alpha which is in the range [0,1].
boolean | Frustum.sphereInFrustum(Vector3 center, float radius) Returns wheter the given sphere is in the frustum.
boolean | Frustum.sphereInFrustumWithoutNearFar(Vector3 center, float radius) Returns wheter the given sphere is in the frustum not checking wheter it is behind the near and far clipping plane.
Vector3 | Vector3.sub(Vector3 a_vec) Subtracts the given vector from this vector
Plane.PlaneSide | Plane.testPoint(Vector3 point) Returns on which side the given point lies relative to the plane and its normal.
Matrix4 | Matrix4.trn(Vector3 vector) Adds a translational component to the matrix in the 4th column.

Method parameters in com.badlogic.gdx.math with type arguments of type Vector3
java.util.List<Vector3> | CatmullRomSpline.getTangentNormals(int numPoints, java.util.List<Vector3> up)
static boolean | Intersector.intersectRayTriangles(Ray ray, java.util.List<Vector3> triangles, Vector3 intersection) Intersects the given ray with list of triangles.

Constructors in com.badlogic.gdx.math with parameters of type Vector3
Plane(Vector3 normal, float d)
Constructs a new plane based on the normal and distance to the origin.
Plane(Vector3 normal, Vector3 point)
Constructs a new plane based on the normal and a point on the plane.
Plane(Vector3 point1, Vector3 point2, Vector3 point3)
Constructs a new plane out of the three given points that are considered to be on the plane.
Quaternion(Vector3 axis, float angle)
Constructor, sets the quaternion from the given axis vector and the angle around that axis in degrees.
Vector3(Vector3 vector)
Creates a vector from the given vector

Uses of Vector3 in com.badlogic.gdx.math.collision

Fields in com.badlogic.gdx.math.collision declared as Vector3
Vector3 | Segment.a the starting position
Vector3 | Segment.b the ending position
Vector3 | Sphere.center the center of the sphere
Vector3 | Ray.direction
Vector3 | BoundingBox.max
Vector3 | BoundingBox.min
Vector3 | Ray.origin

Methods in com.badlogic.gdx.math.collision that return Vector3
Vector3 | BoundingBox.getCenter()
Vector3[] | BoundingBox.getCorners()
Vector3 | BoundingBox.getDimensions()
Vector3 | Ray.getEndPoint(float distance) Returns and endpoint given the distance.
Vector3 | BoundingBox.getMax()
Vector3 | BoundingBox.getMin()

Methods in com.badlogic.gdx.math.collision with parameters of type Vector3
boolean | BoundingBox.contains(Vector3 v) Returns wheter the given vector is contained in this bounding box.
BoundingBox | BoundingBox.ext(Vector3 point) Extends the bounding box to incorporate the given Vector3.
BoundingBox | BoundingBox.set(Vector3[] points) Sets the bounding box minimum and maximum vector from the given points.
BoundingBox | BoundingBox.set(Vector3 minimum, Vector3 maximum) Sets the given minimum and maximum vector.
Ray | Ray.set(Vector3 origin, Vector3 direction) Sets the starting position and the direction of this ray.

Method parameters in com.badlogic.gdx.math.collision with type arguments of type Vector3
 BoundingBox BoundingBox.set(java.util.List<Vector3> points)
Sets the bounding box minimum and maximum vector from the given points.

Constructors in com.badlogic.gdx.math.collision with parameters of type Vector3
BoundingBox(Vector3 minimum, Vector3 maximum)
Constructs the new bounding box using the given minimum and maximum vector.
Ray(Vector3 origin, Vector3 direction)
Constructor, sets the starting position of the ray and the direction.
Segment(Vector3 a, Vector3 b)
Constructs a new Segment from the two points given.
Sphere(Vector3 center, float radius)
Constructs a sphere with the given center and radius

Overview Package Class Use Tree Deprecated Index Help
libgdx API


Version (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx
Class Version

java.lang.Object
    extended by  com.badlogic.gdx.Version

public class Version
extends java.lang.Object

The version of libgdx

Author:
mzechner

Field Summary
static java.lang.String VERSION
the current version of libgdx in the major.minor format
Constructor Summary
Version()
Method Summary
static void loadLibrary()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VERSION

public static java.lang.String VERSION
the current version of libgdx in the major.minor format

Constructor Detail

Version

public Version()
Method Detail

loadLibrary

public static void loadLibrary()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.Version (libgdx API)

Uses of Class
com.badlogic.gdx.Version

No usage of com.badlogic.gdx.Version

Overview Package Class Use Tree Deprecated Index Help
libgdx API


VertexArray (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.glutils
Class VertexArray

java.lang.Object
    extended by  com.badlogic.gdx.graphics.glutils.VertexArray
All Implemented Interfaces:
VertexData
public class VertexArray
extends java.lang.Object
implements VertexData

Convenience class for working with OpenGL vertex arrays. It interleaves all data in the order you specified in the constructor via VertexAttribute.

This class does not support shaders and for that matter OpenGL ES 2.0. For this VertexBufferObjects are needed.

Author:
mzechner

Constructor Summary
VertexArray(int numVertices, VertexAttribute... attributes)
Constructs a new interleaved VertexArray
Method Summary
void | bind() Binds this VertexData for rendering via glDrawArrays or glDrawElements.
void | dispose() Disposes this VertexData and all its associated OpenGL resources.
VertexAttributes | getAttributes()
java.nio.FloatBuffer | getBuffer() Returns the underlying FloatBuffer.
int | getNumMaxVertices()
int | getNumVertices()
void | setVertices(float[] vertices, int offset, int count) Sets the vertices of this VertexData, discarding the old vertex data.
void | unbind() Unbinds this VertexData.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VertexArray

public VertexArray(int numVertices,
                   VertexAttribute... attributes)
Constructs a new interleaved VertexArray

Parameters:
numVertices - the maximum number of vertices
attributes - the VertexAttributes
Method Detail

dispose

public void dispose()
Disposes this VertexData and all its associated OpenGL resources.

Specified by:
dispose in interface VertexData

getBuffer

public java.nio.FloatBuffer getBuffer()

Returns the underlying FloatBuffer. If you modify the buffer contents they will be uploaded on the next call to VertexData.bind(). If you need immediate uploading use VertexData.setVertices(float[], int, int);

Specified by:
getBuffer in interface VertexData
Returns:
the underlying FloatBuffer holding the vertex data.

getNumVertices

public int getNumVertices()

Specified by:
getNumVertices in interface VertexData
Returns:
the number of vertices this VertexData stores

getNumMaxVertices

public int getNumMaxVertices()

Specified by:
getNumMaxVertices in interface VertexData
Returns:
the number of vertices this VertedData can store

setVertices

public void setVertices(float[] vertices,
                        int offset,
                        int count)

Sets the vertices of this VertexData, discarding the old vertex data. The count must equal the number of floats per vertex times the number of vertices to be copied to this VertexData. The order of the vertex attributes must be the same as specified at construction time via VertexAttributes.

This can be called in between calls to VertexData.bind() and VertexData.unbind(). The vertex data will be updated instantly.

Specified by:
setVertices in interface VertexData
Parameters:
vertices - the vertex data
offset - the offset to start copying the data from
count - the number of floats to copy

bind

public void bind()
Description copied from interface: VertexData
Binds this VertexData for rendering via glDrawArrays or glDrawElements.

Specified by:
bind in interface VertexData

unbind

public void unbind()
Description copied from interface: VertexData
Unbinds this VertexData.

Specified by:
unbind in interface VertexData

getAttributes

public VertexAttributes getAttributes()
Specified by:
getAttributes in interface VertexData
Returns:
the VertexAttributes as specified during construction.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.glutils.VertexArray (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.glutils.VertexArray

No usage of com.badlogic.gdx.graphics.glutils.VertexArray

Overview Package Class Use Tree Deprecated Index Help
libgdx API


VertexAttribute (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class VertexAttribute

java.lang.Object
    extended by  com.badlogic.gdx.graphics.VertexAttribute

public final class VertexAttribute
extends java.lang.Object

A single vertex attribute defined by its VertexAttributes.Usage, its number of components and its shader alias. The Usage is needed for the fixed function pipeline of OpenGL ES 1.x. Generic attributes are not supported in the fixed function pipeline. The number of components defines how many components the attribute has. The alias defines to which shader attribute this attribute should bind. The alias is used by a Mesh when drawing with a ShaderProgram. The alias can be changed at any time.

Author:
mzechner

Field Summary
java.lang.String | alias the alias for the attribute used in a ShaderProgram
int | numComponents the number of components this attribute has
int | offset the offset of this attribute in bytes, don't change this!
int | usage the attribute VertexAttributes.Usage
Constructor Summary
VertexAttribute(int usage, int numComponents, java.lang.String alias)
Constructs a new VertexAttribute.
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

usage

public final int usage
the attribute VertexAttributes.Usage

numComponents

public final int numComponents
the number of components this attribute has

offset

public int offset
the offset of this attribute in bytes, don't change this!

alias

public java.lang.String alias
the alias for the attribute used in a ShaderProgram

Constructor Detail

VertexAttribute

public VertexAttribute(int usage,
                       int numComponents,
                       java.lang.String alias)
Constructs a new VertexAttribute.

Parameters:
usage - the usage, used for the fixed function pipeline. Generic attributes are not supported in the fixed function pipeline.
numComponents - the number of components of this attribute, must be between 1 and 4.
alias - the alias used in a shader for this attribute. Can be changed after construction.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.VertexAttribute (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.VertexAttribute

Packages that use VertexAttribute
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils

Uses of VertexAttribute in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return VertexAttribute
VertexAttribute | VertexAttributes.get(int index)
VertexAttribute | Mesh.getVertexAttribute(int usage) Returns the first VertexAttribute having the given VertexAttributes.Usage.

Constructors in com.badlogic.gdx.graphics with parameters of type VertexAttribute
Mesh(boolean isStatic, int maxVertices, int maxIndices, VertexAttribute... attributes)
Creates a new Mesh with the given attributes.
Mesh(Mesh.VertexDataType type, boolean isStatic, int maxVertices, int maxIndices, VertexAttribute... attributes)
Creates a new Mesh with the given attributes.
VertexAttributes(VertexAttribute... attributes)
Constructor, sets the vertex attributes in a specific order

Uses of VertexAttribute in com.badlogic.gdx.graphics.glutils

Constructors in com.badlogic.gdx.graphics.glutils with parameters of type VertexAttribute
VertexArray(int numVertices, VertexAttribute... attributes)
Constructs a new interleaved VertexArray
VertexBufferObject(boolean isStatic, int numVertices, VertexAttribute... attributes)
Constructs a new interleaved VertexBufferObject.
VertexBufferObjectSubData(boolean isStatic, int numVertices, VertexAttribute... attributes)
Constructs a new interleaved VertexBufferObject.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


VertexAttributes (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class VertexAttributes

java.lang.Object
    extended by  com.badlogic.gdx.graphics.VertexAttributes

public final class VertexAttributes
extends java.lang.Object

Instances of this class specify the vertex attributes of a mesh. VertexAttributes are used by Mesh instances to define its vertex structure. Vertex attributes have an order. The order is specified by the order they are added to this class.

Author:
mzechner

Nested Class Summary
 class VertexAttributes.Usage
The usage of a vertex attribute.
Field Summary
 int vertexSize
the size of a single vertex in bytes
Constructor Summary
VertexAttributes(VertexAttribute... attributes)
Constructor, sets the vertex attributes in a specific order
Method Summary
VertexAttribute | get(int index)
int | size()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

vertexSize

public final int vertexSize
the size of a single vertex in bytes

Constructor Detail

VertexAttributes

public VertexAttributes(VertexAttribute... attributes)
Constructor, sets the vertex attributes in a specific order

Method Detail

size

public int size()
Returns:
the number of attributes

get

public VertexAttribute get(int index)
Parameters:
index - the index
Returns:
the VertexAttribute at the given index
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.VertexAttributes (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.VertexAttributes

Packages that use VertexAttributes
com.badlogic.gdx.graphics
com.badlogic.gdx.graphics.glutils

Uses of VertexAttributes in com.badlogic.gdx.graphics

Methods in com.badlogic.gdx.graphics that return VertexAttributes
 VertexAttributes Mesh.getVertexAttributes()

Uses of VertexAttributes in com.badlogic.gdx.graphics.glutils

Methods in com.badlogic.gdx.graphics.glutils that return VertexAttributes
VertexAttributes | VertexArray.getAttributes()
VertexAttributes | VertexBufferObject.getAttributes()
VertexAttributes | VertexBufferObjectSubData.getAttributes()
VertexAttributes | VertexData.getAttributes()

Overview Package Class Use Tree Deprecated Index Help
libgdx API


VertexAttributes.Usage (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics
Class VertexAttributes.Usage

java.lang.Object
    extended by  com.badlogic.gdx.graphics.VertexAttributes.Usage
Enclosing class:
VertexAttributes
public final class VertexAttributes.Usage
extends java.lang.Object

The usage of a vertex attribute.

Author:
mzechner

Field Summary
static int | Color
static int | ColorPacked
static int | Generic
static int | Normal
static int | Position
static int | TextureCoordinates
Constructor Summary
VertexAttributes.Usage()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

Position

public static final int Position
See Also:
Constant Field Values

Color

public static final int Color
See Also:
Constant Field Values

ColorPacked

public static final int ColorPacked
See Also:
Constant Field Values

Normal

public static final int Normal
See Also:
Constant Field Values

TextureCoordinates

public static final int TextureCoordinates
See Also:
Constant Field Values

Generic

public static final int Generic
See Also:
Constant Field Values
Constructor Detail

VertexAttributes.Usage

public VertexAttributes.Usage()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.VertexAttributes.Usage (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.VertexAttributes.Usage

No usage of com.badlogic.gdx.graphics.VertexAttributes.Usage

Overview Package Class Use Tree Deprecated Index Help
libgdx API


VertexBufferObject (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.glutils
Class VertexBufferObject

java.lang.Object
    extended by  com.badlogic.gdx.graphics.glutils.VertexBufferObject
All Implemented Interfaces:
VertexData
public class VertexBufferObject
extends java.lang.Object
implements VertexData

A VertexData implementation based on OpenGL vertex buffer objects.

If the OpenGL ES context was lost you can call invalidate() to recreate a new OpenGL vertex buffer object. This class can be used seamlessly with OpenGL ES 1.x and 2.0.

In case OpenGL ES 2.0 is used in the application the data is bound via glVertexAttribPointer() according to the attribute aliases specified via VertexAttributes in the constructor.

Uses indirect Buffers on Android 1.5/1.6 to fix GC invocation due to leaking PlatformAddress instances.

VertexBufferObjects must be disposed via the dispose() method when no longer needed

Author:
mzechner

Constructor Summary
VertexBufferObject(boolean isStatic, int numVertices, VertexAttribute... attributes)
Constructs a new interleaved VertexBufferObject.
Method Summary
void | bind() Binds this VertexData for rendering via glDrawArrays or glDrawElements.
void | bind(ShaderProgram shader) Binds this VertexBufferObject for rendering via glDrawArrays or glDrawElements
void | dispose() Disposes of all resources this VertexBufferObject uses.
VertexAttributes | getAttributes()
java.nio.FloatBuffer | getBuffer() Returns the underlying FloatBuffer.
int | getNumMaxVertices()
int | getNumVertices()
void | invalidate() Invalidates the VertexBufferObject so a new OpenGL buffer handle is created.
void | setVertices(float[] vertices, int offset, int count) Sets the vertices of this VertexData, discarding the old vertex data.
void | unbind() Unbinds this VertexData.
void | unbind(ShaderProgram shader) Unbinds this VertexBufferObject.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VertexBufferObject

public VertexBufferObject(boolean isStatic,
                          int numVertices,
                          VertexAttribute... attributes)
Constructs a new interleaved VertexBufferObject.

Parameters:
isStatic - whether the vertex data is static.
numVertices - the maximum number of vertices
attributes - the VertexAttributes.
Method Detail

getAttributes

public VertexAttributes getAttributes()

Specified by:
getAttributes in interface VertexData
Returns:
the VertexAttributes as specified during construction.

getNumVertices

public int getNumVertices()

Specified by:
getNumVertices in interface VertexData
Returns:
the number of vertices this VertexData stores

getNumMaxVertices

public int getNumMaxVertices()

Specified by:
getNumMaxVertices in interface VertexData
Returns:
the number of vertices this VertedData can store

getBuffer

public java.nio.FloatBuffer getBuffer()

Returns the underlying FloatBuffer. If you modify the buffer contents they will be uploaded on the next call to VertexData.bind(). If you need immediate uploading use VertexData.setVertices(float[], int, int);

Specified by:
getBuffer in interface VertexData
Returns:
the underlying FloatBuffer holding the vertex data.

setVertices

public void setVertices(float[] vertices,
                        int offset,
                        int count)

Sets the vertices of this VertexData, discarding the old vertex data. The count must equal the number of floats per vertex times the number of vertices to be copied to this VertexData. The order of the vertex attributes must be the same as specified at construction time via VertexAttributes.

This can be called in between calls to VertexData.bind() and VertexData.unbind(). The vertex data will be updated instantly.

Specified by:
setVertices in interface VertexData
Parameters:
vertices - the vertex data
offset - the offset to start copying the data from
count - the number of floats to copy

bind

public void bind()
Binds this VertexData for rendering via glDrawArrays or glDrawElements.

Specified by:
bind in interface VertexData

bind

public void bind(ShaderProgram shader)
Binds this VertexBufferObject for rendering via glDrawArrays or glDrawElements

Parameters:
shader - the shader

unbind

public void unbind()
Unbinds this VertexData.

Specified by:
unbind in interface VertexData

unbind

public void unbind(ShaderProgram shader)
Unbinds this VertexBufferObject.

Parameters:
shader - the shader

invalidate

public void invalidate()
Invalidates the VertexBufferObject so a new OpenGL buffer handle is created. Use this in case of a context loss.

dispose

public void dispose()
Disposes of all resources this VertexBufferObject uses.

Specified by:
dispose in interface VertexData
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.glutils.VertexBufferObject (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.glutils.VertexBufferObject

No usage of com.badlogic.gdx.graphics.glutils.VertexBufferObject

Overview Package Class Use Tree Deprecated Index Help
libgdx API


VertexBufferObjectSubData (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.glutils
Class VertexBufferObjectSubData

java.lang.Object
    extended by  com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData
All Implemented Interfaces:
VertexData
public class VertexBufferObjectSubData
extends java.lang.Object
implements VertexData

A VertexData implementation based on OpenGL vertex buffer objects.

If the OpenGL ES context was lost you can call invalidate() to recreate a new OpenGL vertex buffer object. This class can be used seamlessly with OpenGL ES 1.x and 2.0.

In case OpenGL ES 2.0 is used in the application the data is bound via glVertexAttribPointer() according to the attribute aliases specified via VertexAttributes in the constructor.

Uses indirect Buffers on Android 1.5/1.6 to fix GC invocation due to leaking PlatformAddress instances.

VertexBufferObjects must be disposed via the dispose() method when no longer needed

Author:
mzechner

Constructor Summary
VertexBufferObjectSubData(boolean isStatic, int numVertices, VertexAttribute... attributes)
Constructs a new interleaved VertexBufferObject.
Method Summary
void | bind() Binds this VertexData for rendering via glDrawArrays or glDrawElements.
void | bind(ShaderProgram shader) Binds this VertexBufferObject for rendering via glDrawArrays or glDrawElements
void | dispose() Disposes of all resources this VertexBufferObject uses.
VertexAttributes | getAttributes()
java.nio.FloatBuffer | getBuffer() Returns the underlying FloatBuffer.
int | getBufferHandle() Returns the VBO handle
int | getNumMaxVertices()
int | getNumVertices()
void | invalidate() Invalidates the VertexBufferObject so a new OpenGL buffer handle is created.
void | setVertices(float[] vertices, int offset, int count) Sets the vertices of this VertexData, discarding the old vertex data.
void | unbind() Unbinds this VertexData.
void | unbind(ShaderProgram shader) Unbinds this VertexBufferObject.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VertexBufferObjectSubData

public VertexBufferObjectSubData(boolean isStatic,
                                 int numVertices,
                                 VertexAttribute... attributes)
Constructs a new interleaved VertexBufferObject.

Parameters:
isStatic - whether the vertex data is static.
numVertices - the maximum number of vertices
attributes - the VertexAttributes.
Method Detail

getAttributes

public VertexAttributes getAttributes()

Specified by:
getAttributes in interface VertexData
Returns:
the VertexAttributes as specified during construction.

getNumVertices

public int getNumVertices()

Specified by:
getNumVertices in interface VertexData
Returns:
the number of vertices this VertexData stores

getNumMaxVertices

public int getNumMaxVertices()

Specified by:
getNumMaxVertices in interface VertexData
Returns:
the number of vertices this VertedData can store

getBuffer

public java.nio.FloatBuffer getBuffer()

Returns the underlying FloatBuffer. If you modify the buffer contents they will be uploaded on the next call to VertexData.bind(). If you need immediate uploading use VertexData.setVertices(float[], int, int);

Specified by:
getBuffer in interface VertexData
Returns:
the underlying FloatBuffer holding the vertex data.

setVertices

public void setVertices(float[] vertices,
                        int offset,
                        int count)

Sets the vertices of this VertexData, discarding the old vertex data. The count must equal the number of floats per vertex times the number of vertices to be copied to this VertexData. The order of the vertex attributes must be the same as specified at construction time via VertexAttributes.

This can be called in between calls to VertexData.bind() and VertexData.unbind(). The vertex data will be updated instantly.

Specified by:
setVertices in interface VertexData
Parameters:
vertices - the vertex data
offset - the offset to start copying the data from
count - the number of floats to copy

bind

public void bind()
Binds this VertexData for rendering via glDrawArrays or glDrawElements.

Specified by:
bind in interface VertexData

bind

public void bind(ShaderProgram shader)
Binds this VertexBufferObject for rendering via glDrawArrays or glDrawElements

Parameters:
shader - the shader

unbind

public void unbind()
Unbinds this VertexData.

Specified by:
unbind in interface VertexData

unbind

public void unbind(ShaderProgram shader)
Unbinds this VertexBufferObject.

Parameters:
shader - the shader

invalidate

public void invalidate()
Invalidates the VertexBufferObject so a new OpenGL buffer handle is created. Use this in case of a context loss.

dispose

public void dispose()
Disposes of all resources this VertexBufferObject uses.

Specified by:
dispose in interface VertexData

getBufferHandle

public int getBufferHandle()
Returns the VBO handle

Returns:
the VBO handle
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData (libgdx API)

Uses of Class
com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData

No usage of com.badlogic.gdx.graphics.glutils.VertexBufferObjectSubData

Overview Package Class Use Tree Deprecated Index Help
libgdx API


VertexData (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.graphics.glutils
Interface VertexData

All Known Implementing Classes:
VertexArray, VertexBufferObject, VertexBufferObjectSubData
public interface VertexData

A VertexData instance holds vertices for rendering with OpenGL. It is implemented as either a VertexArray or a VertexBufferObject. Only the later supports OpenGL ES 2.0.

Author:
mzechner

Method Summary
void | bind() Binds this VertexData for rendering via glDrawArrays or glDrawElements.
void | dispose() Disposes this VertexData and all its associated OpenGL resources.
VertexAttributes | getAttributes()
java.nio.FloatBuffer | getBuffer() Returns the underlying FloatBuffer.
int | getNumMaxVertices()
int | getNumVertices()
void | setVertices(float[] vertices, int offset, int count) Sets the vertices of this VertexData, discarding the old vertex data.
void | unbind() Unbinds this VertexData.

Method Detail

getNumVertices

int getNumVertices()
Returns:
the number of vertices this VertexData stores

getNumMaxVertices

int getNumMaxVertices()
Returns:
the number of vertices this VertedData can store

getAttributes

VertexAttributes getAttributes()
Returns:
the VertexAttributes as specified during construction.

setVertices

void setVertices(float[] vertices,
                 int offset,
                 int count)

Sets the vertices of this VertexData, discarding the old vertex data. The count must equal the number of floats per vertex times the number of vertices to be copied to this VertexData. The order of the vertex attributes must be the same as specified at construction time via VertexAttributes.

This can be called in between calls to bind() and unbind(). The vertex data will be updated instantly.

Parameters:
vertices - the vertex data
offset - the offset to start copying the data from
count - the number of floats to copy

getBuffer

java.nio.FloatBuffer getBuffer()

Returns the underlying FloatBuffer. If you modify the buffer contents they will be uploaded on the next call to bind(). If you need immediate uploading use setVertices(float[], int, int);

Returns:
the underlying FloatBuffer holding the vertex data.

bind

void bind()
Binds this VertexData for rendering via glDrawArrays or glDrawElements.

unbind

void unbind()
Unbinds this VertexData.

dispose

void dispose()
Disposes this VertexData and all its associated OpenGL resources.

Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.badlogic.gdx.graphics.glutils.VertexData (libgdx API)

Uses of Interface
com.badlogic.gdx.graphics.glutils.VertexData

Packages that use VertexData
com.badlogic.gdx.graphics.glutils

Uses of VertexData in com.badlogic.gdx.graphics.glutils

Classes in com.badlogic.gdx.graphics.glutils that implement VertexData
class | VertexArray Convenience class for working with OpenGL vertex arrays.
class | VertexBufferObject A VertexData implementation based on OpenGL vertex buffer objects.
class | VertexBufferObjectSubData A VertexData implementation based on OpenGL vertex buffer objects.

Overview Package Class Use Tree Deprecated Index Help
libgdx API


VorbisDecoder (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.audio.io
Class VorbisDecoder

java.lang.Object
    extended by  com.badlogic.gdx.audio.io.VorbisDecoder
All Implemented Interfaces:
Decoder
public class VorbisDecoder
extends java.lang.Object
implements Decoder

A Decoder implementation that decodes OGG Vorbis files using tremor

Author:
mzechner

Constructor Summary
VorbisDecoder(java.lang.String filename)
Opens the given file for ogg decoding.
Method Summary
 void dispose()
Disposes the decoder and frees all associated resources
 float getLength()
 int getNumChannels()
 int getRate()
 int readSamples(java.nio.ShortBuffer samples)
Reads in samples.capacity() samples in 16-bit signed PCM format from the decoder.
 int skipSamples(int numSamples)
Skips numSamples samples.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VorbisDecoder

public VorbisDecoder(java.lang.String filename)
Opens the given file for ogg decoding. Throws an IllegalArugmentException in case the file could not be opened.

Parameters:
filename - the filename
Method Detail

dispose

public void dispose()
Disposes the decoder and frees all associated resources

Specified by:
dispose in interface Decoder

getLength

public float getLength()

Specified by:
getLength in interface Decoder
Returns:
the length of the file in seconds

getNumChannels

public int getNumChannels()

Specified by:
getNumChannels in interface Decoder
Returns:
the number of channels

getRate

public int getRate()

Specified by:
getRate in interface Decoder
Returns:
the sampling rate in herz, e.g. 44100

readSamples

public int readSamples(java.nio.ShortBuffer samples)
Reads in samples.capacity() samples in 16-bit signed PCM format from the decoder. Returns the actual number read in. If this number is smaller than the capacity of the buffer then the end of stream has been reached. The provided ShortBuffer must be a direct buffer.

Specified by:
readSamples in interface Decoder
Parameters:
samples - The number of read samples.

skipSamples

public int skipSamples(int numSamples)
Skips numSamples samples. If the decoded file is in stereo the left and right channel samples are counted as 2 samples.

Specified by:
skipSamples in interface Decoder
Parameters:
numSamples - the number of samples to skip
Returns:
the number of samples actually skipped. If this is < numSamples then the end of the file has been reached.
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.audio.io.VorbisDecoder (libgdx API)

Uses of Class
com.badlogic.gdx.audio.io.VorbisDecoder

No usage of com.badlogic.gdx.audio.io.VorbisDecoder

Overview Package Class Use Tree Deprecated Index Help
libgdx API


WeldJoint (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class WeldJoint

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.Joint
        extended by  com.badlogic.gdx.physics.box2d.joints.WeldJoint

public class WeldJoint
extends Joint

A weld joint essentially glues two bodies together. A weld joint may distort somewhat because the island constraint solver is approximate.

Field Summary
Fields inherited from class com.badlogic.gdx.physics.box2d.Joint
addr, jointEdgeA, jointEdgeB
Constructor Summary
WeldJoint(World world, long addr)
Method Summary
Methods inherited from class com.badlogic.gdx.physics.box2d.Joint
getAnchorA, getAnchorB, getBodyA, getBodyB, getReactionForce, getReactionTorque, getType, isActive
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WeldJoint

public WeldJoint(World world,
                 long addr)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.WeldJoint (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.WeldJoint

No usage of com.badlogic.gdx.physics.box2d.joints.WeldJoint

Overview Package Class Use Tree Deprecated Index Help
libgdx API


WeldJointDef (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d.joints
Class WeldJointDef

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.JointDef
        extended by  com.badlogic.gdx.physics.box2d.joints.WeldJointDef

public class WeldJointDef
extends JointDef

Nested Class Summary
Nested classes/interfaces inherited from class com.badlogic.gdx.physics.box2d.JointDef
JointDef.JointType
Field Summary
Vector2 | localAnchorA
Vector2 | localAnchorB
float | referenceAngle
Fields inherited from class com.badlogic.gdx.physics.box2d.JointDef
bodyA, bodyB, collideConnected, type
Constructor Summary
WeldJointDef()
Method Summary
 void initialize(Body body1, Body body2, Vector2 anchor)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

localAnchorA

public final Vector2 localAnchorA

localAnchorB

public final Vector2 localAnchorB

referenceAngle

public float referenceAngle
Constructor Detail

WeldJointDef

public WeldJointDef()
Method Detail

initialize

public void initialize(Body body1,
                       Body body2,
                       Vector2 anchor)
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.joints.WeldJointDef (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.joints.WeldJointDef

No usage of com.badlogic.gdx.physics.box2d.joints.WeldJointDef

Overview Package Class Use Tree Deprecated Index Help
libgdx API


WindowedMean (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.math
Class WindowedMean

java.lang.Object
    extended by  com.badlogic.gdx.math.WindowedMean

public final class WindowedMean
extends java.lang.Object

A simple class keeping track of the mean of a stream of values within a certain window. the WindowedMean will only return a value in case enough data has been sampled. After enough data has been sampled the oldest sample will be replaced by the newest in case a new sample is added.

Author:
badlogicgames@gmail.com

Constructor Summary
WindowedMean(int window_size)
constructor, window_size specifies the number of samples we will continuously get the mean and variance from.
Method Summary
void | addValue(float value) adds a new sample to this mean.
void | clear() clears this WindowedMean.
float | getLatest()
float | getMean() returns the mean of the samples added to this instance.
float | getOldest()
boolean | hasEnoughData()
float | standardDeviation()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WindowedMean

public WindowedMean(int window_size)
constructor, window_size specifies the number of samples we will continuously get the mean and variance from. the class will only return meaning full values if at least window_size values have been added.

Parameters:
window_size - size of the sample window
Method Detail

hasEnoughData

public boolean hasEnoughData()
Returns:
wheter the value returned will be meaningfull

clear

public void clear()
clears this WindowedMean. The class will only return meaningfull values after enough data has been added again.

addValue

public void addValue(float value)
adds a new sample to this mean. in case the window is full the oldest value will be replaced by this new value.

Parameters:
value - The value to add

getMean

public float getMean()
returns the mean of the samples added to this instance. only returns meaningfull results when at least window_size samples as specified in the constructor have been added.

Returns:
the mean

getOldest

public float getOldest()
Returns:
the oldest value in the window

getLatest

public float getLatest()
Returns:
the value last added

standardDeviation

public float standardDeviation()
Returns:
The standard deviation
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.math.WindowedMean (libgdx API)

Uses of Class
com.badlogic.gdx.math.WindowedMean

No usage of com.badlogic.gdx.math.WindowedMean

Overview Package Class Use Tree Deprecated Index Help
libgdx API


World (libgdx API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class World

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.World

public class World
extends java.lang.Object

The world class manages all physics entities, dynamic simulation, and asynchronous queries. The world also contains efficient memory management facilities.

Author:
mzechner

Field Summary
protected LongHashMap<Body> | bodies all known bodies
protected ContactFilter | contactFilter Contact filter
protected ContactListener | contactListener Contact listener
protected LongHashMap<Fixture> | fixtures all known fixtures
protected LongHashMap<Joint> | joints all known joints
Constructor Summary
World(Vector2 gravity, boolean doSleep)
Construct a world object.
Method Summary
void | clearForces() Call this after you are done with time steps to clear the forces.
Body | createBody(BodyDef def) Create a rigid body given a definition.
Joint | createJoint(JointDef def) Create a joint to constrain bodies together.
void | destroyBody(Body body) Destroy a rigid body given a definition.
void | destroyJoint(Joint joint) Destroy a joint.
void | dispose()
boolean | getAutoClearForces() Get the flag that controls automatic clearing of forces after each time step.
java.util.Iterator<Body> | getBodies()
int | getBodyCount() Get the number of bodies.
int | getContactCount() Get the number of contacts (each may have 0 or more contact points).
java.util.List<Contact> | getContactList()
Vector2 | getGravity()
int | getJointCount() Get the number of joints.
java.util.Iterator<Joint> | getJoints()
int | getProxyCount() Get the number of broad-phase proxies.
boolean | isLocked() Is the world locked (in the middle of a time step).
void | QueryAABB(QueryCallback callback, float lowerX, float lowerY, float upperX, float upperY) Query the world for all fixtures that potentially overlap the provided AABB.
void | setAutoClearForces(boolean flag) Set flag to control automatic clearing of forces after each time step.
void | setContactFilter(ContactFilter filter) Register a contact filter to provide specific control over collision.
void | setContactListener(ContactListener listener) Register a contact event listener.
void | setContinuousPhysics(boolean flag) Enable/disable continuous physics.
void | setDestructionListener(DestructionListener listener) Register a destruction listener.
void | setGravity(Vector2 gravity) Change the global gravity vector.
void | setWarmStarting(boolean flag) Enable/disable warm starting.
void | step(float timeStep, int velocityIterations, int positionIterations) Take a time step.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

bodies

protected final LongHashMap<Body> bodies
all known bodies

fixtures

protected final LongHashMap<Fixture> fixtures
all known fixtures

joints

protected final LongHashMap<Joint> joints
all known joints

contactFilter

protected ContactFilter contactFilter
Contact filter

contactListener

protected ContactListener contactListener
Contact listener

Constructor Detail

World

public World(Vector2 gravity,
             boolean doSleep)
Construct a world object.

Parameters:
gravity - the world gravity vector.
doSleep - improve performance by not simulating inactive bodies.
Method Detail

setDestructionListener

public void setDestructionListener(DestructionListener listener)
Register a destruction listener. The listener is owned by you and must remain in scope.

setContactFilter

public void setContactFilter(ContactFilter filter)
Register a contact filter to provide specific control over collision. Otherwise the default filter is used (b2_defaultFilter). The listener is owned by you and must remain in scope.

setContactListener

public void setContactListener(ContactListener listener)
Register a contact event listener. The listener is owned by you and must remain in scope.

createBody

public Body createBody(BodyDef def)
Create a rigid body given a definition. No reference to the definition is retained.

destroyBody

public void destroyBody(Body body)
Destroy a rigid body given a definition. No reference to the definition is retained. This function is locked during callbacks.

createJoint

public Joint createJoint(JointDef def)
Create a joint to constrain bodies together. No reference to the definition is retained. This may cause the connected bodies to cease colliding.

destroyJoint

public void destroyJoint(Joint joint)
Destroy a joint. This may cause the connected bodies to begin colliding.

step

public void step(float timeStep,
                 int velocityIterations,
                 int positionIterations)
Take a time step. This performs collision detection, integration, and constraint solution.

Parameters:
timeStep - the amount of time to simulate, this should not vary.
velocityIterations - for the velocity constraint solver.
positionIterations - for the position constraint solver.

clearForces

public void clearForces()
Call this after you are done with time steps to clear the forces. You normally call this after each call to Step, unless you are performing sub-steps. By default, forces will be automatically cleared, so you don't need to call this function. See setAutoClearForces(boolean)

setWarmStarting

public void setWarmStarting(boolean flag)
Enable/disable warm starting. For testing.

setContinuousPhysics

public void setContinuousPhysics(boolean flag)
Enable/disable continuous physics. For testing.

getProxyCount

public int getProxyCount()
Get the number of broad-phase proxies.

getBodyCount

public int getBodyCount()
Get the number of bodies.

getJointCount

public int getJointCount()
Get the number of joints.

getContactCount

public int getContactCount()
Get the number of contacts (each may have 0 or more contact points).

setGravity

public void setGravity(Vector2 gravity)
Change the global gravity vector.

getGravity

public Vector2 getGravity()

isLocked

public boolean isLocked()
Is the world locked (in the middle of a time step).

setAutoClearForces

public void setAutoClearForces(boolean flag)
Set flag to control automatic clearing of forces after each time step.

getAutoClearForces

public boolean getAutoClearForces()
Get the flag that controls automatic clearing of forces after each time step.

QueryAABB

public void QueryAABB(QueryCallback callback,
                      float lowerX,
                      float lowerY,
                      float upperX,
                      float upperY)
Query the world for all fixtures that potentially overlap the provided AABB.

Parameters:
callback - a user implemented callback class.
lowerX - the x coordinate of the lower left corner
lowerY - the y coordinate of the lower left corner
upperX - the x coordinate of the upper right corner
upperY - the y coordinate of the upper right corner

getContactList

public java.util.List<Contact> getContactList()

getBodies

public java.util.Iterator<Body> getBodies()
Returns:
all bodies currently in the simulation

getJoints

public java.util.Iterator<Joint> getJoints()
Returns:
all joints currently in the simulation

dispose

public void dispose()
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.World (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.World

Packages that use World
com.badlogic.gdx.physics.box2d
com.badlogic.gdx.physics.box2d.joints

Uses of World in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as World
protected  World Contact.world
the world

Methods in com.badlogic.gdx.physics.box2d that return World
 World Body.getWorld()
Get the parent world of this body.

Methods in com.badlogic.gdx.physics.box2d with parameters of type World
 void Box2DDebugRenderer.render(World world)
This assumes that the projection matrix has already been set.

Constructors in com.badlogic.gdx.physics.box2d with parameters of type World
Body(World world, long addr)
Constructs a new body with the given address
Contact(World world, long addr)
Joint(World world, long addr)
Constructs a new joint

Uses of World in com.badlogic.gdx.physics.box2d.joints

Constructors in com.badlogic.gdx.physics.box2d.joints with parameters of type World
DistanceJoint(World world, long addr)
FrictionJoint(World world, long addr)
GearJoint(World world, long addr)
LineJoint(World world, long addr)
MouseJoint(World world, long addr)
PrismaticJoint(World world, long addr)
PulleyJoint(World world, long addr)
RevoluteJoint(World world, long addr)
WeldJoint(World world, long addr)

Overview Package Class Use Tree Deprecated Index Help
libgdx API


WorldManifold (libgdx API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.badlogic.gdx.physics.box2d
Class WorldManifold

java.lang.Object
    extended by  com.badlogic.gdx.physics.box2d.WorldManifold

public class WorldManifold
extends java.lang.Object

This is used to compute the current state of a contact manifold.

Field Summary
protected Vector2 | normal
protected int | numContactPoints
protected Vector2[] | points
Constructor Summary
protected WorldManifold()
Method Summary
Vector2 | getNormal() Returns the normal of this manifold
int | getNumberOfContactPoints()
Vector2[] | getPoints() Returns the contact points of this manifold.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

normal

protected final Vector2 normal

points

protected final Vector2[] points

numContactPoints

protected int numContactPoints
Constructor Detail

WorldManifold

protected WorldManifold()
Method Detail

getNormal

public Vector2 getNormal()
Returns the normal of this manifold

getPoints

public Vector2[] getPoints()
Returns the contact points of this manifold. Use getNumberOfContactPoints to determine how many contact points there are (0,1 or 2)

getNumberOfContactPoints

public int getNumberOfContactPoints()
Returns:
the number of contact points
Overview Package Class Use Tree Deprecated Index Help
libgdx API
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.badlogic.gdx.physics.box2d.WorldManifold (libgdx API)

Uses of Class
com.badlogic.gdx.physics.box2d.WorldManifold

Packages that use WorldManifold
com.badlogic.gdx.physics.box2d

Uses of WorldManifold in com.badlogic.gdx.physics.box2d

Fields in com.badlogic.gdx.physics.box2d declared as WorldManifold
protected  WorldManifold Contact.worldManifold
the world manifold

Methods in com.badlogic.gdx.physics.box2d that return WorldManifold
 WorldManifold Contact.GetWorldManifold()

Overview Package Class Use Tree Deprecated Index Help
libgdx API